NX CAD Realize Shape eBook

Page 1



NX

STUDENT EDITION Synchronous & Realize Shape e-book

T E P  D M www.camdivision.pl

e-book 3


NX

STUDENT EDITION Synchronous & Realize Shape e-book e-Book stanowi rozwinięcie podręcznika „NX Student Edition. Synchronous Technology”

Wydawca: CAMdivision Sp. z o.o. Park Przemysłowy Źródła-Błonie k/Wrocławia 55-330 Miękinia Błonie, ul. Sosnowa 10 tel.: +48 71 780 30 20 e-mail: redakcja@camdivision.pl www.camdivision.pl Projekt okładki, DTP, korekta: Studio Graficzne Stanisławski (maciej@cadblog.pl) Na okładkach i wewnątrz publikacji wykorzystano materiały graficzne Siemens Digital Industries Software.

Autorzy oraz Wydawca dołożyli wszelkich starań, by zawarte w opracowaniu informacje okazały się pomocne, były kompletne i sprawdzone pod względem merytorycznym. Nie biorą jednak żadnej odpowiedzialności za ich wykorzystanie, ani za związane z tym ewentualne naruszenie praw autorskich lub patentowych. Autorzy i Wydawca nie ponoszą także odpowiedzialności za ewentualne szkody wynikłe na skutek wykorzystania informacji zawartych w opracowaniu.

Copyright © CAMdivision 2016/2020 Wszelkie prawa zastrzeżone. Rozpowszechnianie całości lub fragmentów niniejszej publikacji w jakiejkolwiek postaci, bez pisemnej zgody Wydawcy zabronione. Wykonywanie kopii metodą kserograficzną, fotograficzną, a także kopiowanie opracowania na jakimkolwiek nośniku elektronicznym itp. narusza prawa autorskie. D-Cubed, Femap, Geolus, GO PLM, I-deas, Insight, JT, NX, Parasolid, Solid Edge, Teamcenter, Tecnomatix oraz Velocity Series są znakami towarowymi lub zastrzeżonymi znakami towarowymi firmy Siemens Digital Industries Software lub podmiotów od niej zależnych w Stanach Zjednoczonych i innych krajach. Nastran jest zastrzeżonym znakiem towarowym organizacji National Aeronautics and Space Administration (NASA). Pozostałe występujące w niniejszej publikacji logo, znaki towarowe, zastrzeżone znaki towarowe i znaki usług należą do ich właścicieli. 4 NX Synchronous Technology e-book

© CAMdivision 2020


Spis treści

Spis treści Synchronous y & Realize Shape p Część 1 • Synchronous Technology Rozdział 1 Wprowadzenie do Synchronous Technology ................................................................................... 13 Rozdział 2 Move Face (Przesuń ściankę) ............................................................................................................. 15 Rozdział 3 Pull Face (Wyciągnij ściankę) ............................................................................................................ 16 Rozdział 4 Dimensions (Wymiary) ........................................................................................................................ 4.1. Linear Dimension (Wymiar liniowy) ....................................................................................... 4.2. Angular Dimension (Wymiar kątowy)..................................................................................... 4.3. Radial Dimension (Wymiar promieniowy) .............................................................................

30 30 33 36

Rozdział 5 Delete Face (Usuń ściankę).................................................................................................................. 39 Rozdział 6 Replace Face (Zastąp ściankę)............................................................................................................ 44 Rozdział 7 Detail Feature (Obróbka cech) ........................................................................................................... 7.1. Resize Blend (Edytuj zaokrąglenie)............................................................................................ 7.2. Label Notch Blend (Przypisz zaokrąglenie)............................................................................... 7.3. Reorder Blends (Przebuduj zaokrąglenia).................................................................................. 7.4. Resize Chamfer (Edytuj fazę) ..................................................................................................... 7.5. Label Chamfer (Przypisz fazę) ...................................................................................................

49 49 51 52 54 55

Rozdział 8 Resize Face (Edytuj ściankę)............................................................................................................... 58 Rozdział 9 Reuse (Powielanie)................................................................................................................................ 60 9.1. Copy Face (Kopiuj ściankę)........................................................................................................ 60 www.camdivision.pl

NX e-book 5


Spis treści

Spis treści 9.2. Cut Face (Wytnij ściankę) ........................................................................................................... 9.3. Paste Face (Wklej ściankę) ......................................................................................................... 9.4. Mirror Face (Lustro ścianki) ...................................................................................................... 9.5. Pattern Face (Szyk ze ścianek)....................................................................................................

62 64 66 68

Rozdział 10 Relate (Relacje) .................................................................................................................................... 10.1. Make Coplanar (Umieść współpłaszczyznowo) ................................................................... 10.2. Make Coaxial (Umieść współosiowo)................................................................................... 10.3. Make Tangent (Umieść stycznie) ........................................................................................... 10.4. Make Symmetric (Umieść symetrycznie) ............................................................................. 10.5. Make Parallel (Umieść równolegle)....................................................................................... 10.6. Make Perpendicular (Umieść prostopadle)............................................................................ 10.7. Make Offset (Utwórz odsunięcie) ..........................................................................................

75 75 77 78 79 80 81 83

Rozdział 11 Offset Region (Odsuń region) ............................................................................................................. 85 Rozdział 12 Shell (Cienkościenność)........................................................................................................................ 12.1. Shell Body (Obiekt cienkościenny)........................................................................................ 12.2. Shell Face (Region cienkościenny) ....................................................................................... 12.3. Change Shell Thickness (Zmień grubość obiektu)................................................................

88 88 89 91

Rozdział 13 Group Face (Grupowanie ścianek) .................................................................................................... 91 Rozdział 14 Edit Cross Section (Edytuj przekrój) ................................................................................................ 93 Rozdział 15 Optimize (Optymalizuj) ...................................................................................................................... 96 15.1. Optimize Face (Optymalizuj ściankę).................................................................................... 96 15.2. Replace Blend (Zastąp zaokrąglenie)..................................................................................... 98 Rozdział 16 X-form (Kształt X) ............................................................................................................................... 101 Rozdział 17 I-form (Kształt I) .................................................................................................................................. 111 6 NX Synchronous Technology e-book

© CAMdivision 2020


Spis treści

Spis treści Rozdział 18 Move Edge (Przesuń krawędź)........................................................................................................... 117 Rozdział 19 Offset Edge (Odsunięcie krawędzi).................................................................................................... 120

Część 2 • Realize Shape Wprowadzenie do Realize Shape – podstawy ................................................................................. 123 Rozdział 1 Primitive Shape .................................................................................................................................... 124 Rozdział 2 Symmetric Modeling Start / Stop ..................................................................................................... 126 Rozdział 3 Extrude Cage ...................................................................................................................................... 129 Rozdział 4 Transform Cage .................................................................................................................................. 132 Rozdział 5 Split Face ............................................................................................................................................... 137 Rozdział 6 Subdivide Face ..................................................................................................................................... 141 Rozdział 7 Bridge Face ........................................................................................................................................... 143 Rozdział 8 Fill ........................................................................................................................................................... 145 Rozdział 9 Delete Face ............................................................................................................................................ 147 Rozdział 10 Merge Face ............................................................................................................................................ 149 Rozdział 11 Project Cage .......................................................................................................................................... 151 www.camdivision.pl

NX e-book 7


Spis treści

Spis treści Rozdział 12 Set Weight ............................................................................................................................................. 154 Rozdział 13 Set Continuity ....................................................................................................................................... 156 Rozdział 14 Realize Shape Preferences .................................................................................................................. 159 Rozdział 15 Projektowanie Designu ....................................................................................................................... 161

Część 3 • Modelowanie – ćwiczenia praktyczne Rozdział 1 Projektowanie szklanej butelki do perfum (ćwiczenie z modelowania)....................................... 169 I. Rozpoczęcie projektu, ustawienie tolerancji modelowania ........................................................ 169 II. Tworzenie pomocniczej bryły .................................................................................................... 169 III. Tworzenie powierzchni kształtowej butelki ............................................................................. 171 IV. Modelowanie dolnej powierzchni butelki ................................................................................. 172 V. Szyk powierzchni i zamiana powierzchni na bryłę ................................................................... 174 VI. Operacje wykańczające denko ................................................................................................. 176 VII. Modelowanie szyjki butelki .................................................................................................... 178 VIII. Wykonanie standardowego gwintu ....................................................................................... 179 IX. Szybka wizualizacja produktu................................................................................................... 181 Rozdział 2 Projektowanie butelki PET (ćwiczenie z modelowania)................................................................ 183 I. Rozpoczęcie projektu ................................................................................................................... 183 II. Tworzenie kształtu obrotowego denka ...................................................................................... 183 III. Tworzenie poprzecznych wcięć w denku ................................................................................. 186 IV. Rysowanie części łączących denko z szyjką ............................................................................ 188 V. Modelowanie liścia ozdobnego na płaszczyźnie ....................................................................... 189 VI. Przenoszenie liścia na ścianki butelki ...................................................................................... 191 VII. Wstawianie nietypowego kształtu na powierzchnię obrotową z użyciem Realize Shape ... 194 VIII. Wstawianie dodatkowego wzoru w okolicy szyjki butelki .................................................. 198 IX. Dodawanie dwóch końcowych wzorów ozdobnych ............................................................... 200 X. Wizualizacja kształtu .................................................................................................................. 202

8 NX Synchronous Technology e-book

© CAMdivision 2020


Od wydawcy

NX

STUDENT EDITION Synchronous & Realize Shape

e-book

Od wydawcy CAMdivision Sp. z o.o. jest największym partnerem handlowym SIEMENS Digital Industries Software (producenta NX) w Polsce. Od 12 lat wdraża z powodzeniem na polskim rynku rozwiązania CAx/PLM w oparciu o NX CAD/CAE/CAM i Teamcenter. Ponadto jest liderem rynku pod względem ilości wdrożonych licencji NX CAD/CAM, NX CAM Robotics i specjalizowanych aplikacji NX Mold, NX Progressive oraz PCM Tool Costing. Wdrożyliśmy już pierwsze w Polsce licencje NX CAM Additive Manufacturing do druku 3D tworzyw sztucznych i metalu. W marcu 2020 roku SIEMENS rozpoczął akcję marketingową związaną z NX Student Edition. CAMdivision uzupełnia tę ofertę o profesjonalne materiały szkoleniowe do NX CAD i NX CAM w formie bezpłatnych ebooków i cykli webinariów szkoleniowych.

NX Student Edition for Everyone? NX Student Edition to specjalna wersja edukacyjna pakietu NX CAD/CAM (oparta o NX1911), która służy do samodzielnej nauki tego oprogramowania w warunkach domowych. Jest przeznaczona zarówno dla studentów jaki pracowników firm komercyjnych. Instalacja w firmie komercyjnej jest niedozwolona. NX Learning Edition to nazwa własna programu NX, jaka ukaże się nam po instalacji.

Jakie możliwości ma NX Student Edition? W NX Student Edition nie ma dostępu do wszystkich modułów komercyjnej wersji, nie mniej jednak ma bardzo duże możliwości i posiada: • kompleksowe narzędzia do projektowania 3D, w tym modelowanie bryłowe, powierzchniowe i synchroniczne oraz Drafting 2D, • pełny zestaw narzędzi do programowania CAM, umożliwiający tworzenie operacji dla frezarek 3-, 5-osiowych, tokarek i wycinarek drutowych • zaawansowane narzędzia do tworzenia powierzchni w modułach FreeForm Shape modeling & NX Realize Shape, analizy i wizualizacji, • obsługę formatu STL do druku 3D, • możliwość wczytywania plików z komercyjnej wersji NX.

Pozostałe informacje o NX Student Edition Ważne z punktu z punktu widzenia użytkownika informacje: • software działa do 30 września 2020, ale akcja ma być odnawiana, www.camdivision.pl

NX e-book 9


Od wydawcy

Rys. 1 NX jako nieodłączna część rozwiązania PLM • program posiada kilkanaście wersji językowych, w tym: polską, angielską, niemiecką… , które wgrywają się automatycznie przy pierwszej instalacji NX, • plików z NX Student Edition nie można otworzyć w komercyjnych wersjach NX, ale można w pakietach NX Academic, • przy wydruku i plotowaniu dodawany jest znak wodny, • w modułach CAM została zablokowana możliwość generowania kodu NC, • istnieje możliwość eksportu tylko do formatu STL, • program posiada możliwość importu formatów neutralnych: Parasolid, JT, STL oraz natywnych SolidWorks i Solid Edge.

Skąd pobrać NX Student Edition? NX Student Edition możma pobrać bezpośrednio z serwerów SIEMENS, po wypełnieniu ankiety na stronie: https://trials.sw.siemens.com/nx-student-edition/. Proces instalacji został dokładnie opisany w: • NX Student Edition for Everyone – webinarze na YouTube: https://youtu.be/jMrWtUVS_fg, • pliku CAMdivision – NX Student Edition – Webinar.pdf, który można pobrać ze strony http://nx-student-edition.pl, Aktualne informacje o NX Student Edition również można znaleźć pod adresem: http://nx-student-edition.pl.

FAQ 1. Czy można wczytywać pliki z wersji komercyjnej? Tak. 2. Na której wersji NX oparty jest NX Student Edition? NX 1911: czyli NX 1899 Release z grudnia 2019 z MU1911 Monthly Update z marca 2020. 3. Do kiedy działa licencja? Do 30 września 2020 i będzie odnowiona. 4. Czy pliki można zapisywać? Tak 5. Czy pracownik firmy komercyjnej może pobrać NX Student Edition? Tak 6. Czy NX Student Edition można instalować w firmie? Nie. Do testów w firmie polecamy bezpłatne wypożyczenie NX TRIAL, formularz dostępny na stronie https://www.camdivision.pl/pl/uslugi/wersje-testowe. 7. Czy działa SheetMetal i Drafting? Tak. 10 NX Synchronous Technology e-book

© CAMdivision 2020


Od wydawcy

Rys. 2 Wybrani użytkownicy oprogramowania Siemens PLM 8. Jakie formaty 3D można importować, a do jakich eksportować pliki? Import Parasolid, JT, Solid Edge, SolidWorks, STL. Eksport tylko STL 9. Czy można importować DWG/DXF? Nie. 10. Czy jest polska wersja językowa? Tak.

Czym jest NX? Oprogramowanie NX jest zintegrowanym rozwiązaniem CAD/CAM/CAE do obsługi projektowania produktów, analiz inżynierskich i produkcji, które pomaga w szybszym i bardziej efektywnym dostarczaniu lepszych produktów. Oferuje dostęp do innowacyjnych technik – Synchronous Technology, Realize Shape i Convergent Modeling – które umożliwiają błyskawiczne modelowanie, edycję wirtualnych modeli, również skanowanych. NX oferuje najważniejsze funkcje umożliwiające szybkie, efektywne i elastyczne opracowywanie produktów.

Blog o NX (www.nxcad.pl) Zachęcamy wszystkich do korzystania z bazy wiedzy, która gromadzona jest na blogu dedykowanym NX. Znajdą tam Państwo wiele praktycznych porad technicznych i informacji dotyczących poszczególnych zagadnień z dziedzin CAD/CAM/CAE.

Zasady korzystania z bezpłatnego e-booka Podręcznik jest przeznaczony zarówno dla firm, jak i osób prywatnych, dla obecnych i potencjalnych użytkowników systemu NX CAD i NX CAM oraz użytkowników innych systemów CAD/CAM pragnących poznać podstawy pracy w jego środowisku, a zwłaszcza Technologii Synchronicznej. Ideą wydawcy jest zachęcenie użytkowników do samokształcenia, przynajmniej w zakresie wiedzy prezentowanej na łamach rzeczonej publikacji. W związku z tym ograniczeniem, aby legalnie wykorzystywać e-book w firmie komercyjnej lub instytucji edukacyjnej, należy zgłosić ten zamiar wydawcy – firmie CAMdivision Sp. z o.o. telefonicznie pod nr telefonu (71) 780 30 20 lub przesłać powiadomienie na adres e-mail: ebooks@camdivison.pl, pamiętając jednocześnie o tym, iż nie może być on wykorzystywany do prowadzenia zorganizowanych kursów i szkoleń (płatnych lub bezpłatnych) bez otrzymania pisemnej zgody CAMdivision Sp. z o.o. (z wyjątkiem bezpłatnych wykładów kursowych na uczelniach; w tym przypadku wystarczy samo zgłoszenie). Wszelkie uwagi prosimy przesyłać na adres redakcja@camdivison.pl Życzmy przyjemnej pracy! Zespół CAMdivision Sp z o.o. www.camdivision.pl

NX e-book 11


Część I

Część I Synchronous Technology

12 NX Synchronous Technology e-book

© CAMdivision 2019


Rozdział 1

Część I Synchronous Technology

1

Rozdział 1

Wprowadzenie do Synchronous Technology

Od Direct Modeling do Synchronous Technology SIEMENS po przejęciu UGS (w maju 2007 roku) zaczął mocno rozwijać technikę edycji i budowy modeli na bazie istniejącej już we wcześniejszych wersjach NX operacji Direct Modeling. Tak właśnie powstała całkowicie nowatorska w systemach wyższego rzędu Synchronous Technology.

1.1. Widok Menu Synchronous Modeling i okno Nawigatora części. Widoczna historia operacji wykorzystanych przy budowie modelu... www.camdivision.pl

NX e-book 13


Rozdział 1

Synchronous Technology Słowo „Synchronous” nie odnosi się do procesu modelowania, ale raczej do synchronicznego solwera. Solwer jest algorytmem komputerowym, który rozwiązuje grupę równań matematycznych. Każdy program CAD, który obsługuje tworzenie i edycję operacji (feature), ma ukryty swój solwer bardzo głęboko w kodzie. Sekwencyjne solwery są najstarszymi, sprawdzonymi i zarazem najczęściej spotykanymi, posiadają jednak narzucone zależności dotyczące kolejności wykonywania działań. Zmiana pierwszej operacji pociąga za sobą przeliczanie wszystkich po kolei aż do ostatniej operacji, co często jest długotrwałym procesem i nie zawsze kończy się powodzeniem. Symultaniczne solwery wprowadzają możliwość równoczesnego rozwiązywania równań, co umożliwia dodatkowo analizę relacji z innymi elementami w ramach jednej operacji. Synchroniczny solwer przy dokonywaniu zmian kształtu części analizuje, wychwytuje i zachowuje relacje/powiązania (istniejące lub narzucone), jakie występują między elementami lub poszczególnymi powierzchniami w całym modelu części. Umożliwia to szybką edycję kształtu w czasie rzeczywistym bez długotrwałych obliczeń. Synchronous Technology to przełomowa, niezwykła technika modelowania, która obejmuje także możliwość edycji nieparametrycznych plików pochodzących z innych systemów CAD (multi-CAD) wczytanych przez formaty pośrednie np. IGES, PARASOLID, ACIS, STEP lub bezpośrednie np. CATIA V4 (*.exp, *.model), CATIA V5 (*.CATpart, *.CATproduct), Solid Edge (*.par, *.asm, *psm), SolidWorks (*.sldprt, *.sldasm), PTC Creo (*.prt, *.asm)...

14 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Realize Shape

Część II

Realize Shape

Realize Shape – podstawy Realize Shape jest aplikacją przeznaczoną do szybkiego tworzenia designu. Posiada szereg poleceń umożliwiających plastyczne kształtowanie modelu. Każdy płat utworzonej powierzchni zewnętrznej modelu (razem z sąsiednimi) posiada niezbędne warunki brzegowe, gwarantujące płynne przejścia.

Rys. 1

Konstrukcja aplikacji graficznie jest podobna do szkicownika, z ta różnicą, że operujemy na bryłach, a nie na krzywych. Do aplikacji można przejść z modułu Modeling (Ctr+M) (rys. 2.1 a) lub Shape Studio (Ctr+Alt+S) (rys. 2.1 b).

Rys. 2 www.camdivision.pl

NX e-book 123


Część II • Rozdział 1

Rozdział 1

Primitive Shape

1

Polecenie Primitive Shape znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Insert → Primitive Shape.

Rys.1.1 Widok menu w trybie Realize Shape z zaznaczonym poleceniem Primitive Shape

Polecenie służy do wstawia bryły lub powierzchni startowej, od której rozpoczyna się tworzenie designu. Okno operacji

Rys. 1.2

Grupa Type Umożliwia wstawienie prostej bryły lub powierzchni, na podstawie której będzie wykonywana deformacja. Do dyspozycji są następujące obiekty: 124 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Rozdział 1

• Sphere – bryła w kształcie kuli, • Cylinder – bryła o kształcie walca, • Block – bryła o kształcie prostopadłościanu, • Circle – powierzchnia o kształcie okręgu, • Rectangle – powierzchnia o kształcie prostokąta. Grupa Center Specify Point Określa punkt, w którym zostanie wstawiony obiekt. Grupa Size W zależności od wybranego obiektu do wstawienia, zawiera pozycje z parametrami wymiarów. Przykład 1 Celem ćwiczenia jest wstawienie bryły startowej do modyfikacji.

Otwórz plik …/synchronous_modeling/realize_shape/p_1/primitive_shape. 1. Z Menu wybierz Insert → Realize Shape. 2. Kliknij ikonę Primitive Shape. 3. Wybierz tworzenie kuli i w grupie Size wprowadź wartość średnicy równą 20. 4. Zatwierdź polecenie klikając OK. Program wstawi obiekt w zerowej pozycji układu współrzędnych. 5. Operacje powtórz dla pozostałych obiektów. 6. Wyjdź z modelowania, klikając Finish. 7. Zapisz i zamknij plik.

www.camdivision.pl

NX e-book 125


Część II • Rozdział 2

Rozdział 2

Symmetric Modeling (Start/Stop)

2

Polecenia Symmetric Modeling (Start/Stop) znajdują się w przyborniku Realize Shape. Start Symmetric Modeling jest aktywowane, gdy obiekt jest wstawiony poleceniem Primitive Shape. Stop Symmetric Modeling jest z kolei dostępne, gdy wcześniej zostało wykorzystane polecenie Start Symmetric Modeling.

Rys. 2.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Start/Stop Symmetric Modeling

Polecenie służy do uruchomienia modelowania symetrycznego. Użytkownik zmieniając jedną stronę modelu automatycznie uzyskuje efekt na drugiej połówce, przy zachowaniu płynnego przejścia między stronami modelu. Okno operacji

Rys. 2.2 126 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Rozdział 2

Grupa Symmetry Plane Specify Plane Służy do określenia płaszczyzny symetrii. Można zdefiniować nową płaszczyznę lub wskazać istniejącą. Grupa Mirror Procedure Cut Body Opcja przeznaczona do odbijania obiektu płaszczyzną przecinającą obiekt do odbicia. W przypadku, gdy obiekt nie przecina się z płaszczyzną, odbita połowa modelu nie jest łączona z oryginałem (rys. 2.3).

Rys. 2.3

Project Edge Opcja przeznaczona jest do wykonania odbicia płaszczyzną nie przecinającą modelu.

Rys. 2.4

Switch Side Dostępny dla opcji Cut Body. Umożliwia wybór strony, która będzie odbijana w przypadku, gdy płaszczyzna odbicia przecina model. Select Edge Służy do wskazania krawędzi sterujących (krawędzie klatki sterującej), które mają być zrzutowane na płaszczyznę odbicia. www.camdivision.pl

NX e-book 127


Część II • Rozdział 2

Przykład 2 Celem ćwiczenia jest wykonanie symetrii zamodelowanej bryły. Otwórz plik …/synchronous_modeling/realize_shape/p_2/symmetric_modeling 1. W drzewie operacji dwukrotnie kliknij LKM na operację Subdivision Body. 2. Program automatycznie przejdzie do modyfikacji bryły. Wybierz Esc na klawiaturze, aby wyjść z operacji. 3. Wybierz polecenie Symmetric Modeling i wskaż płaszczyznę XZ (rys. 2.5).

Rys. 2.5

4. Kliknij Switch Side w celu wybrania strony, która ma zostać odbita. 5. Zatwierdź polecenie klikając OK. Po przeprowadzeniu powyższych czynności uzyskasz efekt, jak niżej (rys. 2.6).

Rys. 2.6

6. Wyjdź z modelowania klikając Finish. 7. Zapisz i zamknij plik.

128 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Rozdział 3

3

Rozdział 3

Extrude Cage

Polecenie Extrude Cage znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Insert → Extrude Cage.

Rys. 3.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Extrude Cage

Polecenie umożliwia wyciągnięcie segmentu ze ścianki klatki sterującej. Tworzona jest nowa klatka sterująca, pozwalająca na zdeformowanie wyciągniętej części (rys. 3.2).

Rys. 3.2 www.camdivision.pl

NX e-book 129


Część II • Rozdział 4

Rozdział 4

Transform Cage

4

Polecenie Transform Cage znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Edit → Transform Cage.

Rys. 4.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Transform Cage

Polecenie umożliwia deformację klatki sterującej przez naciąganie, obracanie ścianek, krawędzi lub węzłów (rys. 4.2).

Rys. 4.2 132 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Rozdział 5

5

Rozdział 5

Split Face

Polecenie Split Face znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Insert → Split Face.

Rys. 5.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Split Face

Polecenie służy do dzielenia ścianek klatki sterującej na segmenty, które można swobodnie wyciągać i deformować. Okno operacji

Grupa Type

Rys. 5.2

Uniform Dzieli wskazane ścianki na równe segment w kierunku krawędzi referencyjnej (rys. 5.3). www.camdivision.pl

NX e-book 137


Część II • Rozdział 6

6

Rozdział 6

Subdivide Face

Polecenie Subdivide Face znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Insert → Subdivide Face.

Rys. 6.1 Widok menu w trybie Realize Shape z zaznaczonym poleceniem Subdivide Face

Polecenie służy do wykonania płaskiego zakończenia modelu. Polega na maksymalnym zbliżeniu ścianki modelu do ścianki klatki sterującej (rys. 6.2).

Rys. 6.2

Okno operacji

Rys. 6.3 www.camdivision.pl

NX e-book 141


Część II • Rozdział 7

7

Rozdział 7

Bridge Face

Polecenie Bridge Face znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Insert → Bridge Face.

Rys. 7.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Bridge Face

Polecenie służy do połączenia ścianek modelu, tworząc pomost między nimi (rys. 7.2).

Rys. 7.2

Okno Operacji

Rys. 7.3 www.camdivision.pl

NX e-book 143


Część II • Rozdział 8

8

Rozdział 8

Fill

Polecenie Fill znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Insert → Fill.

Rys. 8.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Fill

Polecenie służy do wypełnienia brakujących powierzchni w celu uzyskania bryły (rys. 8.2).

Rys. 8.2

Użytkownik zaślepia część wskazując obrys klatki sterującej, w kierunku którego jest otwarta powierzchnia. Okno operacji

Rys. 8.3 www.camdivision.pl

NX e-book 145


Część II • Rozdział 9

9

Rozdział 9

Delete Face

Polecenie Delete Face znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Edit → Delete Face.

Rys. 9.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Delete Face

Polecenie przeciwne w działaniu do polecania Fill (patrz Realize Shape rozdział 8). Służy do usuwania powierzchni w celu utworzenia otwartego obiektu (rys. 9.2).

Usuwanie ścianek odbywa się przez wskazanie ścianek klatki sterujacej.

Rys. 9.2

Okno operacji

Rys. 9.3 www.camdivision.pl

NX e-book 147


Część II • Rozdział 10

10

Rozdział 10

Merge Face

Polecenie Merge Face znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Edit → Merge Face.

Rys. 10.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Merge Face

Polecenie przeciwne w działaniu do polecenia Split Face (patrz Realize Shape rozdział 5). Służy do łącznia ścianek klatki sterującej (rys. 10.2).

Rys. 10.2

Funkcjonalność okna operacji analogiczna, jak w poleceniu Delete Face (patrz Realize Shape rozdział 9). Przykład 10 Celem ćwiczenia jest połączenie ścianek klatki sterującej. Otwórz plik …/synchronous_modeling/realize_shape/p_10merge_face www.camdivision.pl

NX e-book 149


Część II • Rozdział 11

11

Rozdział 11

Project Cage

Polecenie Project Cage znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Edit → Project Cage.

Rys. 11.1 Widok menu w trybie Realize Shape z zaznaczonym poleceniem Project Cage

Polecenie umożliwia zrzutowanie krawędzi klatki sterującej na dowolną płaszczyznę (rys. 11.2)

Rys. 11.2

Okno operacji

Rys.11.3 www.camdivision.pl

NX e-book 151


Część II • Rozdział 12

Rozdział 12

Set Weight

12

Polecenie Set Weight znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Edit → Set Weight.

Rys. 12.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Set Weight

Polecenie umożliwia deformację ścianek modelu przez zbliżenie ich do ścianek klatki sterującej (rys. 12.2).

Rys. 12.2

Okno operacji

Rys. 12.3 154 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Rozdział 13

Rozdział 13

Set Continuity

13

Polecenie Set Continuity znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Edit → Set Continuity.

Rys. 13.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Set Continuity

Polecenie umożliwia wybór naroża między ściankami klatki sterującej (rys. 13.2).

Rys. 13.2

Okno operacji

Rys. 13.3 156 NX Synchronous Technology e-book

© CAMdivision 2020


Część II • Rozdział 14

14

Rozdział 14

Realize Shape Preferences

Polecenie Realize Shape Preferences znajduje się w przyborniku Realize Shape. Może być uruchomione z paska lub z Menu: Menu → Preferences → Realize Shape Preferences.

Rys. 14.1 Widok menu w trybie Realize Shape z zaznaczonym polecaniem Realize Shape Preferences

Ikona uruchamia okno preferencji wyświetlania dla aplikacji Realize Shape (rys. 14.2).

Rys. 14.2

• Line Color – kolor lini klatki sterującej. • Line Font – rodzaj linii klatki sterującej. • Line Width – grubość linii klatki sterującej. www.camdivision.pl

NX e-book 159


Część II • Rozdział 15

15

Rozdział 15

Projektowanie designu

Celem niniejszego rozdziału jest zaprezentowanie sposobu wykonania designu na podstawie poznanych poleceń aplikacji Realize Shape.

Uwaga! Przed przystąpieniem do realizacji ćwiczeń wykonaj krótkie przykłady z poprzednich rozdziałów. Pomoże ci to lepiej zrozumieć i sprawniej posługiwać wykorzystywanymi narzędziami.

Przykład 15.1 Celem ćwiczenia jest wykonanie modelu pofalowanego flakonu (rys. 5.1) . Otwórz plik …/synchronous_modeling/realize_shape/p_15_1/flakon.prt

Rys. 15.1

1. Wstawianie prymitywu w postaci walca. 1.1. Przejdź na zakładkę Application i wybierz aplikację Shape Studio. 1.2. Następnie z zakładki Home wybierz Realize Shape. www.camdivision.pl

NX e-book 161


Część III

Część III

Modelowanie – ćwiczenia praktyczne

168 NX Synchronous Technology e-book

© CAMdivision 2020


Część III • Rozdział 1

1

Rozdział 1

Projektowanie szklanej butelki do perfum

Przykład 1 Czas: 30-45 min Celem ćwiczenia jest szybkie wykonanie buteleczki szklanej do perfum z wykorzystaniem zaawansowanych powierzchni.

Rys. 1.1 Widok modelu, który będzie wykonywany w kolejnych krokach

I. Rozpoczęcie projektu, ustawienie tolerancji modelowania. 1.1. Uruchom NX. Tworzenie pliku prt 1.2. Wybierz New , zaznacz Model i w polu Name wpisz nazwę pliku glass_bottle_perfume.prt. 1.3. Kliknij OK. Zmiana tolerancji modelownia w pliku. 1.4. Przejdź do ustawień globalnych pliku wybierając Menu-Preferences → Modeling i zmień tolerancję tworzenia obiektów na mikron (Distance Tolerance = 0.001) 1.5. Kliknij OK.

II. Tworzenie pomocniczej bryły Wstawianie płaszczyzny 2.1. Uruchom polecenie Datum Plane (Menu → Insert → Datum/Point → Datum Plane). www.camdivision.pl

NX e-book 169


Część III • Rozdział 1

2.2. Zresetuj okno operacji. 2.3. Wskaż płaszczyznę XY i wprowadź wartość odsunięcia równą 20 mm. 2.4. Kliknij OK. Tworzenie szkicu 2.5. Uruchom polecenie Sketch (Menu-Insert-Sketch). 2.6. Zresetuj okno operacji. 2.7. Wskaż płaszczyznę YZ i wykonaj szkic, jak na rysunku 1.2.

Rys. 1.2 Widok szkicu niezbędnego do wykonania bryły pomocniczej

2.8. Zakończ szkic klikając Finish Sketch . Tworzenie obrotowej bryły 2.9. Uruchom polecenie Revolve (Menu → Insert → Design Feature → Revolve). 2.10. Zresetuj okno operacji i wskaż szkic. 2.11. Przejdź do grupy Axis i kliknij narzędzie Specify Vector. 2.12. Wskaż wektor osi Z układu współrzędnych. 2.13. W grupie Limits w polu Start ustaw 0, natomiast w polu End ustaw 45. 2.14. Kliknij OK.

Rys. 1.3 Widok procesu modelowania skręconej bryły 170 NX Synchronous Technology e-book

© CAMdivision 2020


Część III • Rozdział 2

2

Rozdział 2

Projektowanie butelki PET

Przykład Czas: 45-60 min Celem ćwiczenia jest zaprojektowanie butelki PET. Poniższe techniki modelowania pokazują sposoby szybkiego przenoszenia zaprojektowanego kształtu z płaszczyzny na powierzchnię obrotową.

Rys. 2.1 Widok modelu wykonywanego w kolejnych krokach

I. Rozpoczęcie projektu 1.1. Uruchom NX. 1.2.Wybierz Open i wskaż plik …\cz_3 \PRT\cw_5\bottle_PET. 1.3. Kliknij OK.

II. Tworzenie kształtu obrotowego denka Tworzenie szkicu 2.1. Uruchom polecenie Sketch (Menu → Insert → Sketch). 2.2. Zresetuj okno operacji. 2.3. Wskaż płaszczyznę YZ i kliknij OK. 2.4. Wykonaj szkic, jak niżej (rys. 2.2) i kliknij ikonę Finish Sketch. www.camdivision.pl

NX e-book 183


Część III • Rozdział 2

Rys. 2.2. Widok szkicu niezbędnego do wykonania kształtu obrotowego denka

Wykonanie bryły obrotowej 2.5. Uruchom polecenie Revolve (Menu → Insert → Design Feature → Revolve). 2.6. Zresetuj okno operacji. 2.7. Wskaż szkic i kliknij SKM. 2.8. W grupie Axis zmień narzędzie Specify Vector na ZC (rys. 2.3, 2 a). 2.9. Następnie wskaż punkt 3 (rys. 2.3, a) 2.10. Kliknij OK, a uzyskasz bryłę obrotową (rys. 2.3 b).

Rys. 2.3 Widok definiowania operacji obrotu

Tworzenie pomocniczej linii prostej 2.11. Uruchom polecenie Line (Menu → Insert → Curve → Line). 2.12. Zresetuj okno. 2.13. Wskaz punkt 1 (rys. 2.4 a). 184 NX Synchronous Technology e-book

© CAMdivision 2020


Część III • Rozdział 2

Wskazówka Zauważ, że promień nie może być wpisany przy końcach bryły. Wykonaj edycję operacji Law Extension i w grupie Side ustaw odsunięcie asymetryczne o wartości 4 mm. Powtórz wstawianie promienia. Lustro geometrii

9.26. Uruchom polecenie Mirror Geometry (Menu → Insert → Associative Copy → Mirror Geometry) i wskaż utworzoną bryłę. 9.27. Kliknij SKM i wskaż płaszczyznę XZ. 9.28. Kliknij OK. Sumowanie brył

9.29. Uruchom polecenie Unite (Menu → Insert → Combine → Unite). 9.30. Zresetuj okno operacji. 9.31. Wskaż bryłę butelki i kliknij Ctrl+A w celu zaznaczenia pozostałych brył. 9.32. Kliknij OK. Dodawanie promienia

9.33. Uruchom polecenie Edge Blend (Menu → Insert → Detail Feature → Edge Blend). 9.34. Wskaż wszystkie krawędzie, jak na rysunku 2.40. 9.35. Wprowadź wartość promienia równą 2.5 mm i kliknij OK.

Rys. 2.40 Dodawanie promienia

X. Wizualizacja kształtu Ukrywanie obiektów

10.1. Wybierz skrót klawiszowy Ctrl+W. 10.2. Kliknij Hide przy pozycji All. 10.3. Następnie kliknij Show przy pozycji Solid Bodies. 10.4. Zamknij okno operacji. Renderowanie obiektu

10.5. Kliknij PKM na pustym polu okna graficznego i wybierz Rendering Style-Shaded. 10.6. Uruchom wizualizacje wybierając polecenie Studio Task (Menu → View → Visualization → Studio Task). 10.7. Z bocznego paska (drzewa) rozwiń materiał z grupy Plastic i wybierz Glossy Plastic Green. 10.8. Przytrzymując LKM przeciągnij materiał na bryłę butelki. 10.9. Zmień boczny pasek (drzewo) na System Scenes . 202 NX Synchronous Technology e-book

© CAMdivision 2020