Page 1

Questo corso è valido per il conseguimento della Patente Europea del Computer (European Computer Driving Licence)

Internet and Computing Core Certification (IC3)

Modulo 5 Basi di dati / Sistemi di Archiviazione


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

EUROPEAN COMPUTER DRIVING LICENCE 5.1 Per iniziare Questo quinto modulo pratico è diviso in cinque sezioni. Gli argomenti saranno, in seguito, trattati in maniera da preparare l’allievo nel migliore dei modi a sostenere l’esame. Il candidato imparerà i concetti fondamentali sulle basi di dati. Il modulo è costituito da due parti. La prima verifica la capacità di creare una semplice base di dati usando un pacchetto software standard. La seconda verifica invece la capacità di estrarre informazioni da una base di dati esistente usando gli strumenti di interrogazione, selezione e ordinamento disponibili, e di generare i rapporti relativi. A differenza degli altri programmi del pacchetto Office (Winword, Excel, Powerpoint) Access richiede una preparazione di base per poter utilizzare il programma stesso. La preparazione di base necessaria è quella che riguarda la teoria dei database, cioè si dovrebbe sapere cosa sono i database, cos’è un DBMS, cosa sono le query, le relazioni, cosa si intende per progettazione di un archivio. 5.1.1.1

Aprire un programma di database

Per aprire il programma Microsoft Access possiamo usare due strade: • Doppio clic sull’icona del collegamento a Access sul Desktop (qualora ne esista una) • Clic sul pulsante Avvio sulla barra delle Applicazioni, selezionare Programmi e quindi Access Ci sarebbe anche un terzo modo per avviare Access e sarebbe quello di digitare il path dell’eseguibile da Avvio -> Esegui. 5.1.1.2 Aprire un database esiste con le impostazioni di default Per avviare l’Access possiamo anche cliccare due volte su un file precedentemente creato. Per aprire un file di Access (.mdb) esistente lo possiamo fare anche usando il comando Apri del menù File o dall’icona presente sulla barra degli strumenti standard. Nel menù File sono elencati i nomi degli ultimi 4 db aperti nell'ultima sessione di lavoro. Per aprirli basta selezionarli direttamente. 5.1.1.3 Modificare un record in un database esistente e salvarlo Per effettuare la modifica di un record di un database già esistente bisogna eseguire le seguenti operazioni: 1. Aprire il database 2. Selezionare la finestra Tabelle 3. Doppio click sulla tabella da modificare per aprirla in visualizzazione dati 4. Selezionare il campo con i dati da variare 5. Apportare le modifiche 6. Spostarsi su un altro record 5.1.1.4 Salvare un database su hard disk o dischetto All’atto della creazione di un nuovo database, Access richiede subito il nome del file e la cartella di destinazione. Non è possibile lavorare su un database che non sia stato salvato su un supporto fisico.

2


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Dopo aver scelto la directory e il nome del file si deve fare un clic sul pulsante CREA. A questo punto si apre la finestra di Access, con gli strumenti per creare un nuovo archivio. 5.1.1.5 Chiudere il database Per chiudere il database corrente si effettuano le seguenti operazioni Scegliere dal menù File il comando Chiudi Per chiudere completamente Access si effettuano le seguenti operazioni: Scegliere dal menù File il comando Esci 5.1.1.6 Usare le funzioni di Help del programma Come tutti i programmi della suite Office anche microsoft access offre la funzionalità di help. Per avviare l’assistente di Office basta cliccare sulla prima icona del gruppo che segue: A questo punto basta digitare la domanda a cui si vuole far rispondere l’assistente e il gioco è fatto. Cliccando con il tasto destro del mouse sull’assistente è possibile: • Nasconderlo • Scegliere il tipo di assistente • Scegliere il tipo di animazione • Impostare alcune opzioni 5.1.2.1 Modificare il modo di visualizzazione sullo schermo E’ possibile visualizzare gli oggetti di database: tabelle, maschere, query, report e macro (i più utilizzati) in diverse modalità sullo schermo: • Icone grandi • Icone piccole • Elenco • Dettagli Tutte queste modalità sono selezionabili dal menù Visualizza e scegliendo il comando omonimo.

3


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

5.1.2.2

Modificare le Barre degli strumenti

Nelle figure seguenti sono riportati gli elementi essenziali del programma. 1. BARRA DEL TITOLO Si legge il nome del programma aperto (Microsoft Access).

2. BARRA DEI MENU (File, Modifica, ecc.)

Ogni menù contiene una lista di comandi. Per aprire un qualsiasi menù si deve fare un clic sul nome, per esempio VISUALIZZA. A questo punto appare una “tendina” con una lista di comandi che ha il seguente aspetto:

La lista dei comandi non è completa: sono visibili solo quelli principali e quelli utilizzati più spesso. Per questo motivo, ogni volta che si cerca un comando, si deve fare un clic alla fine della lista, sulle doppie frecce (evidenziate dal rettangolo rosso), in questo modo la lista diventa completa.

Per chiudere il menù si deve cliccare nuovamente sul rispettivo nome.

3. BARRA DEGLI STRUMENTI

Questa barra è formata da una serie di pulsanti che rappresentano un modo più veloce, rispetto ai menù, di applicare i comandi.

4


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

4. BARRA DI STATO Indica l’operazione che si sta compiendo, cioè lo stato in cui si trova il programma in un determinato momento. Si trova in basso, alla fine della finestra di Access, sopra il pulsante START.

5. OGGETTI DI DATABASE In mezzo allo schermo viene visualizzata una finestra di dialogo con tutti gli strumenti per il database che si vuole creare.

Nella finestra di dialogo precedente sono indicati tutti i possibili oggetti che si possono creare con Access 2000: tabelle, query, maschere, pagine, report, macro e moduli. La barra del titolo della finestra visualizza il nome del file, cioè dell’archivio, che in questo caso è db1 (perché non è stato ancora scelto un nome). Per passare dagli strumenti di un oggetto agli strumenti di un altro oggetto, si deve posizionare il puntatore del mouse sopra il nome e fare un clic (nella figura precedente è selezionato l’oggetto tabella). La finestra rimane la stessa, quasi identica, cambiano solamente i comandi utilizzabili.

5.2 Creare un database In questa sezione impareremo a pianificare e creare un semplice database. Agiremo fondamentalmente sull’oggetto tabella imparando a: definire gli attributi (campi) di una tabella, inserire/modificare/cancellare i record (righe dati) di una tabella, definire una chiave primaria, impostare un indice. 5.2.1.1 Impostare e pianificare un database Utilizzare il prodotto Microsoft Access senza conoscere almeno le basi della progettazione di

5


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

un database sarebbe perfettamente inutile. Di seguito daremo delle nozioni di questo tipo cercando di renderle fruibili a tutti, anche agli utenti meno esperti. DBMS è l’acronimo di DATABASE MANAGEMENT SYSTEM (sistema per la gestione di database). Un DBMS è un programma che consente di creare la base di dati e, una volta creata, di utilizzarla per la gestione delle informazioni, cioè per inserimento, ordinamento, ricerche e per ogni altra operazione necessaria. Access è un DATABASE MANAGEMENT SYSTEM, cioè un programma che consente di creare e gestire gli archivi, non è un database. Il concetto di base di dati, database o archivio viene di solito confuso con quello di tabella strutturata. Per tabella strutturata si intende di solito una tabella divisa in righe e colonne, nella prima riga ci sono i titoli delle colonne (campi). La figura seguente mostra un semplice esempio di tabella strutturata.

Questo concetto è in realtà sbagliato: in generale, un archivio comprende non una, ma molte tabelle che possono essere in relazione tra loro, cioè che i dati di una tabella riguardano, o possono riguardare, anche i dati delle altre. Una base di dati viene costruita per inserire, memorizzare, ordinare, cancellare e gestire dei dati. Di seguito riportiamo un semplice esempio di archivio che memorizza informazioni relative a studenti ed esami di un’università. Ci sono due insiemi di informazioni interessanti per il database, cioè gli studenti e gli esami. Ogni insieme è visto come una tabella con tante colonne quanti sono i “campi di interesse”. Per esempio degli studenti interessa gestire il cognome, il nome, il numero di matricola, l’anno di nascita e la città di residenza. Naturalmente queste sono informazioni minime che riguardano lo studente, altre informazioni non sono di interesse per questo esempio.

Per gli esami interessa memorizzare quelli superati con i voti relativi. I “campi di interesse” sono il nome della materia, il voto registrato, lo studente che ha superato l’esame e la data di registrazione.

6


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Riassumendo le informazioni di interesse sono le seguenti: 1. Esistono due insiemi (collezioni) di interesse (tabelle): Studenti e Esami superati; 2. La struttura degli elementi (colonne) di queste due collezioni; 3. Il fatto che ad ogni esame corrisponde uno studente con la matricola specificata, e ad ogni studente corrispondono uno, nessuno, o più esami; I dati sono le righe delle tabelle.

5.2.1.2 Creare una tabella con campi e attributi La tabella è l’entità che ci permette di memorizzare i dati. Ad ogni tabella si deve assegnare un NOME, che, per convenzione, è al plurale, per esempio Studenti, Libri o Clienti. L’iniziale maiuscola è anc’essa una convenzione. Il nome al plurale indica che la tabella non è un singolo oggetto, ma è un contenitore di oggetti dello stesso tipo: la tabella Studenti conterrà tutti gli studenti. Ogni COLONNA (attributo) della tabella memorizza i “campi di interesse”, cioè le informazioni utili per la base di dati. In fase di progettazione del database viene deciso, per ogni tabella, quante colonne dovrà avere. Ad ogni colonna si assegna un nome che distingue il singolo campo dai rimanenti costituenti la tabella. La tabella studenti ad esempio potrebbe avere i campi Matricola, Cognome, Nome, Indirizzo, Numero di telefono, ecc (per convenzione i nomi delle colonne sono al singolare e con la prima lettera in maiuscolo). Il nome del campo deve essere indicativo del suo contenuto: nella colonna Cognome verranno memorizzati solo i cognomi degli studenti. Se per errore si memorizza il nome di uno studente nel campo Cognome, quel nome per il database verrebbe considerato il cognome dello studente stesso. Per Creare una tabella la prima operazione da effettuare è creare un database con la procedura vista in precedenza. Una volta eseguita la creazione del database bisogna fare click su Tabelle nella finestra di Database. A questo punto ci vengono presentati tre modi possibili di creare una tabella: 1. in visualizzazione struttura 2. mediante una creazione guidata 3. mediante l’immissione dei dati Creazione tabella in visualizzazione struttura Si apre una finestra con tre colonne: nome campo, tipo dati, descrizione. La lunghezza massima di un campo nome è di 64 caratteri. Una tabella non può contenere due campi con lo stesso nome. Il tipo dati determina quali valori è possibile memorizzare nel campo. Tipi dati ammessi: testo, memo, numerico, data/ora, valuta, contatore, sì/no, oggetto OLE, collegamento ipertestuale, autocomposizione ricerca (consente di specificare l’elenco dei valori ammesso per quel determinato campo). La descrizione del campo è opzionale e viene visualizzata nella barra di stato quando si seleziona il campo sulla form. Le proprietà dei campi si impostano per personalizzare il campo e variano a seconda del tipo di dati scelto per il campo. Formato: riguarda la visualizzazione del campo sullo schermo e nella stampa, non controlla come sono memorizzati. Maschera di input: controlla l’immissione dei dati quando il campo è vuoto e il formato in cui essi vengono memorizzati. L è richiesta l’immissione di un carattere alfabetico ? è consentita l’immissione di un carattere alfabetico 9 valore numerico facoltativo 0 valore numerico obbligatorio C è consentita l’immissione di qualsiasi carattere o spazio

7


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

--------------------------------------------------< rende in testo minuscolo > rende il testo maiuscolo ! allinea il testo a sinistra Etichetta: nome visualizzato quando viene aperta la tabella in modalità foglio dati. Se non viene specificato alcun valore verrà impostato il nome dato al campo. Valore predefinito: è possibile usare un’espressione del tipo = date() = Time = null = “MI” Generatore di Espressioni

Espressioni

Consente di comporre un’espressione in alcune proprietà del campo. Fare clic sul pulsante ‘Genera’ (…)

Un’espressione è costituita da operatori, nomi di campo o di controlli (identificatori), valori alfanumerici, costanti (null, si, …), funzioni Le espressioni prevedono i seguenti caratteri di controllo: [ ] prima o dopo nomi di maschere, report, campi e controlli es. [nome] # prima e dopo le date es. [data] > #13/1/96# “ prima e dopo un testo Access, in alcuni casi, inserisce automaticamente i caratteri di controllo Gli operatori si suddividono in: operatori aritmetici (*, /, +, -, ^) operatori di concatenazione (&) operatori di confronto (>, <, >=, <=, =, <>) operatori logici (and, or, not) operatori vari (between, in, is (null), is not (null), like) operatori di identificazione (!, .) (es. Maschere![clienti]![codice cliente]) Caratteri jolly: ? (un singolo carattere), caratteri).

# (una singola cifra),

* (un qualsiasi numero di

Valori Null: Campo che non contiene nessun valore. E’ possibile visualizzare una tabella in due modalità: Struttura o Foglio dati. Visualizzando una tabella con la prima modalità è possibile creare o modificare la struttura della tabella stessa, cioè definire il nome e il tipo dei campi. Visualizzando la tabella in modalità foglio dati è invece possibile modificare o aggiungere dati alla tabella stessa. 5.2.1.3 Navigare in una tabella Innanzitutto bisogna aprire la tabella in modalità foglio dati. A questo punto una volta che si ci è posizionati sul record interessato si può utilizzare il mouse (barra di navigazione, barre di scorrimento), oppure la tastiera (tasti di direzione, Pgup, Pgdown, tabulatore). 5.2.1.4 Inserire dati in una tabella Per verificare come sia possibile inserire i dati in una tabella appositamente creata facciamo un esempio pratico. Creiamo prima di tutto una tabella per la memorizzazione dei dati relativi a delle persone (rubrica). La tabella dovrà contenere al minimo i seguenti campi: Cognome, Nome, Città. A questo punto apriamo la tabella in modalità foglio dati (basta fare doppio click sul nome della tabella). Per immettere i dati nella tabella basta digitarli mediante la tastiera. Per spostarsi da un campo ad un altro della tabella utilizzare il tabulatore (TAB). Nella che segue possiamo notare la matita che appare vicino al record che si sta editando.

8


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Finché il simbolo continua a permanere vuol dire che i dati che stiamo inserendo permangono ancora nella memoria RAM. Solo quando il record risulta pieno in ogni suo campo viene memorizzato. Questo è un comportamento comune quasi tutti i DBMS onde evitare incoerenze nei dati inseriti. In Access un record risulta completamente inserito nel momento in cui si passa al record successivo. Per cambiare riga possiamo agire in due modi: 1) direttamente facendo click con il mouse sul primo campo della riga successiva (indicato con * nella figura sopra); 2) premendo il tasto TAB sull’ultimo campo del record che si sta editando.

Il simbolo di matita scompare, al suo posto appare una freccia sul record che si sta per editare (nella figura evidenziato in rosso). Questo significa che il record è stato memorizzato sull’hard disk. Quando si chiude una tabella non è necessario salvare visto che in Access i dati vengono memorizzati automaticamente. Le modifiche alle strutture delle tabella (tipo dei campi, definizione di indici, relazioni etc.) devono essere invece salvate. Ricapitolando si deve sempre ricordare che, quando si inserisce un record nella base di dati si deve sempre completare l’operazione passando al record successivo. 5.2.2.1 Definire una chiave primaria In una tabella i record di una tabella possono essere ripetuti. Non esiste un sistema, semplice e pratico, per controllare che lo stesso record non sia digitato due volte, su due righe diverse della stessa tabella. Ogni tabella di un database relazionale (e in particolare di Access) dovrebbe avere una chiave primaria. La CHIAVE PRIMARIA è un campo della tabella che identifica in modo univoco ogni record della tabella stessa. In una tabella ci possono essere più campi candidati ad essere la chiave primaria: CHIAVI CANDIDATE. 5.2.2.2 Impostare un indice Un indice serve per dare ai record di una tabella un ordine logico (alfabetico, numerico, cronologico) cioè basato sul contenuto dei campi. Quando si usa una tabella con un file indice, essa appare ordinata secondo le chiavi. Un indice velocizza le ricerche (ottimizzazione) e l’ordinamento, ma fa calare la velocità di aggiornamento della tabella. Access crea automaticamente un indice per ogni chiave primaria definita. Non si possono indicizzare campi Memo, Ole e Hyperlink. Per impostare un indice bisogna agire sull’attributo Indicizzato del campo scelto. 5.2.3.1 (2) Modificare gli attributi di una tabella e gli attributi dei campi Per modificare un campo di una tabella basta aprire la stessa in visualizzazione struttura. Successivamente si sceglie il campo che si vuole modificare e poi si opera su ciascun attributo dello stesso. 5.2.4.1(2) Modificare (Cancellare) i dati in una tabella Per modificare i dati di una tabella bisogna agire allo stesso modo dell’inserimento (5.2.1.4). Aprire la tabella in modalità foglio dati, scegliere il record che si vuole modificare e navigarlo con il stato TAB fino ad arrivare al valore del campo di cui si è scelto di modificarne

9


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

(cancellarne) il contenuto. 5.2.4.3(4) Aggiungere (cancellare) record ad un database Ormai abbiamo capito che quando si parla di record si fa riferimento alle righe di ciascuna delle tabelle che costituiscono il nostro database. Apriamo quindi la tabella che nella quale si vuole aggiungere (cancellare) record. Per inserire un record selezionare uno qualsiasi dei record della tabella cliccare con il tasto destro del mouse e scegliere l’opzione Nuovo record oppure scegliere dal menù Inserisci il comando Nuovo record. Per eliminare un record dalla tabella bisogna, come prima, selezionare il record che si desidera eliminare, cliccare con il tasto destro del mouse e scegliere l’opzione Elimina record oppure scegliere dal menù Modifica il comando Elimina record.

5.3. Uso di maschere In questa sezione si imparerà ad utilizzare un altro oggetto di Microsoft Access: le maschere. Si imparerà quindi a creare una semplice maschera, ad utilizzarla per l’immissione dei dati nelle tabelle, a formattare il testo, a creare dei layout grafici per lo sfondo (importando anche immagini), modificare la disposizione degli oggetti etc, etc. 5.3.3.1 Creare una semplice maschera Le maschere servono per personalizzare e semplificare sia la presentazione che l’immissione dei dati nelle tabelle. Una maschera è efficiente nel senso che è possibile visualizzare solo determinati tipi di informazioni, semplice nel senso che la maggior parte dei controlli presenti sulle stesse sono familiari agli utenti di Windows, accattivante potendo presentare una veste grafica a piacere. Per creare una maschera si deve selezionare il pulsante Maschere nella finestra del database; Scegliere creazione guidata (consigliata per le maschere basate su tabelle) oppure creazione (manuale) in visualizzazione struttura. Nella creazione guidata, impostare: 9 i campi della tabella o della query che devono apparire in maschera 9 il layout da applicare alla maschera (es. a colonne, tabellare, ecc.) 9 lo stile per le caselle di testo 9 il titolo da assegnare alla maschera 9 la modalità di apertura della maschera Ogni informazione all’interno di una maschera è contenuta in un controllo. Una maschera può essere suddivisa in 5 sezioni: intestazione maschera intestazione pagina corpo

10


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

piè di pagina pagina piè di pagina maschera Normalmente viene visualizzato solo il corpo. Ogni oggetto all’interno delle maschere (comprese le sezioni) è dotato di proprietà che ne determinano e ne personalizzano la struttura e l’aspetto. 5.3.3.2 Inserire i dati in un database usando semplici maschere Per inserire i dati in un database e quindi in una tabelle è possibile creare una maschera che effettua questa operazione molto più semplicemente. Immaginiamo di aver prima di tutto creato una tabella contatti (nel database contatti.mdb) con i campi testo nome, cognome, indirizzo, telefono. A questo punto creiamo una maschera con la procedura di creazione guidata. Scegliamo la tabella/query su cui ci interessa creare la maschera e scegliamo i campi che ci interessa inserire nella maschera tra quelli disponibili.

Una volta scelti i campi e ciccato sul pulsante Avanti si passa alla scelta del layout della maschera tra una serie di possibili opzioni: • A colonne • Tabulare • Foglio dati • Giustificato • Tabella pivot • Grafico pivot La prima è selezionata per default (le prime due opzioni sono quelle più utilizzate). Premendo sul pulsante Avanti si passa alla scelta dello stile da utilizzare per la maschera tra la rosa di possibilità che seguono: • Carta di riso • Cianografia • Industriale • Internazionale • Pittura Sumi • Quadretti • Sfumature

11


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

• • •

Spedizioni Standard Tessuto

Spuntando un’opzione Access ne fornisce un’anteprima. Una volta scelta quella che più ci aggrada (supponiamo di scegliere quadretti) si clicca sul pulsante avanti. Si arriva finalmente alla schermata nella quale si deve semplicemente scegliere il nome da dare alla maschera. Per default viene dato lo stesso nome della tabella a cui la maschera si referenzia.

Ciccando su fine il gioco è fatto. Viene infatti visualizzata la maschera e i dati relativi al primo record (qualora ne esista uno) della tabella puntata. 5.3.2.1 Definire la formattazione del testo Per definire la formattazione del testo all’intero della maschera si opera in questo modo: • Aprire la maschera in visualizzazione struttura • Selezionare l’elemento che si vuole formattare (ad esempio Etichetta o Casella di Testo) • Agire sulla barra di formattazione oppure cliccare col il tasto destro del mouse sull’elemento e scegliere il comando Proprietà 5.3.2.2 Cambiare il colore di sfondo Per cambiare il colore di sfondo di una maschera si opera in questo modo: • Aprire la maschera in visualizzazione struttura • Cliccare col il tasto destro del mouse su una zona vuota (priva di elementi) della maschera e scegliere l’opzione Colore riempiento/sfondo • Selezionare il colore scelto 5.3.2.3 Importare un’immagine o un file grafico Per inserire un immagine utilizzare il bottone corrispondente dalla casella degli strumenti.

12


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Tracciare un rettangolo che conterrà l'immagine e selezionarla attraverso la finestra inserisci immagine. Per adattare perfettamente il rettangolo all'immagine selezionare Formato > Allinea > alla griglia. Casella degli strumenti Diamo qui l’elenco degli oggetti che è possibile selezionare dalla casella degli strumenti con la corrispondente funzionalità. STRUMENTO Selezione oggetti Autocomposizione controllo Etichetta Casella di testo Gruppo di opzioni

Interruttore Pulsante di opzione Casella di controllo

Casella combinata Casella di riepilogo

Pulsante di comando Immagine Cornice oggetto non associato

Interruzione pagina Struttura a schede Sottomaschera/sottoreport Linea

FUNZIONALITA’ Strumento di default all'apertura della casella degli strumenti. Serve a selezionare o a deselezionare uno strumento. Serve a progettare controlli complessi, come Caselle di riepilogo, Caselle combinate o gruppi di opzioni. Serve a creare una casella con del testo descrittivo. Serve a creare una casella che consente di visualizzare e modificare i dati. Serve a creare un riquadro in cui si possono inserire altri controlli: interruttori, pulsanti opzione e caselle di controllo. Selezionando uno di questi oggetti, gli altri vengono disattivati Serve a creare un pulsante che viene attivato o disattivato facendo clic su di esso. Serve a creare un pulsante rotondo della stessa funzione dell'interruttore. Viene normalmente utilizzato all'interno di un gruppo di opzioni. Serve a creare una casella che attiva o disattiva un oggetto. Viene normalmente usato all'esterno di un gruppo di opzioni per selezionare più di un oggetto per volta. Serve a creare una casella composta da due elementi: un elenco a tendina da cui selezionare un elemento e una casella di testo in cui digitare. Simile alla casella combinata, senza però prevedere la casella di testo per la digitazione. E’ possibile fare clic su un elenco a tendina da cui si può selezionare un elemento. Serve a creare un pulsante di comando che consente di eseguire una macro o una procedura Access VBA. Serve a inserire un’immagine nella maschera. Una volta inserita non è più possibile effettuare modifiche. Serve ad aggiungere il contenuto di un oggetto OLE, realizzato da applicazioni server OLE, come Windows Paint, Excel, Microsoft WordArt. Serve a provocare un salto a nuova pagina nel punto in cui è selezionato (durante la stampa). Serve a creare una maschera a schede. Serve ad aggiungere una sottomaschera ad una maschera principale. Prima di usare questo controllo è necessario che la sottomaschera sia già stata creata. Serve a disegnare una linea retta che può essere

13


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Rettangolo Altri controlli

spostata, dimensionata e modificata nello spessore e nel colore. Serve a disegnare un rettangolo su cui si possono effettuare le medesime operazioni viste per la linea. Serve a verificare la presenza di controlli aggiuntivi che possono essere utilizzati ma che non sono di uso comune

5.3.2.4 Modificare la disposizione degli oggetti nella maschera Per modificare la disposizione degli oggetti nella maschera si opera in questo modo: • Aprire la maschera in visualizzazione struttura • Selezionare l’oggetto che si desidera spostare • Trascinarlo fino a posizionarlo dove si desidera

5.4 Reperire informazioni In questa sezione si imparerà a ricercare informazioni all’interno di un database. Si imparerà ad impostare e utilizzare filtri e a operare con le query . 5.4.1.1

Accedere ad un database esistente

Per aprire un database esistente basta fare doppio clic sul nome del file .mdb corrispondente. 5.4.1.2 Trovare un record sulla base di criteri assegnati Per ricercare dati all’interno di una tabella o di una serie di tabelle c’è bisogno di utilizzare lo strumento query. La traduzione letterale del termine query è "interrogazione", infatti essa è il risultato di una domanda posta al database. Esistono due tipi di query: • Dettaglio: vengono visualizzati tutti i campi di tutti i record • Riepilogo: effettuano calcoli su campi definiti numerici (somma, media, minimo, massimo) oppure permettono di scegliere raggruppamenti di date

Per utilizzare al meglio questo tipo di strumento si dovrebbe conoscere il linguaggio universale di interrogazione dei database cioè l’ SQL. In alternativa si può utilizzare la creazione guidata messa a disposizione da Access e poi intervenire sul codice generato che è possibile visualizzare e manipolare.

5.4.1.3 Creare una semplice query Per effettuare questo tipo di operazione utilizzeremo la creazione guidata. Riferiamoci sempre al database contatti.mdb creato alla sezione 5.3.3.2. . Dopo averlo aperto andiamo selezioniamo l’Oggetto Query e successivamente il comando Creazione query mediante una creazione guidata.

14


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Una volta scelti i campi da selezionare e cliccato sul pulsante Avanti si passa alla scelta del nome da assegnare alla query. Si consiglia di usare una nomenclatura fissa per tutti gli oggetti, ad esempio per la query che stiamo creando potremmo utilizzare il nome query_contatti. Ecco il risultato di questa operazione:

E’ da notare che è come se stessimo aprendo una tabella in modalità foglio dati. Se visualizziamo la struttura della query appena creata avremo il seguente risultato:

Per visualizzare l’SQL corrispondente alla query appena creata bisogna selezionare dal menù Visualizza il comando Visualizzazione SQL. Operando in questo modo si ottiene il seguente risultato:

15


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

SELECT contatti.nome, contatti.cognome, contatti.indirizzo, contatti.telefono FROM contatti; Questa sequenza di istruzioni sta a significare SELEZIONA (SELECT) i campi nome,

cognome, indirizzo, telefono DALLA (FROM) tabella contatti.

5.4.1.4 (5.4.2.1, 5.4.2.2, 5.4.3.1,5.4.3.2) Creare una query con criteri multipli, Aggiungere e eliminare campi da una query, Ordinamento e operatori logici di selezione) Creando una nuova query in visualizzazione struttura è possibile includere qualsiasi criterio di selezione. Di seguito viene mostrata la griglia QBE (Query By Example):

La griglia QBE è suddivisa in colonne (campi di tabella/e) e in righe che specificano, per ogni campo: 1) nome del campo 2) nome della tabella di appartenenza 3) ordinamento (sì/no) e tipo ordinamento (asc, desc) 4) mostra, per visualizzare o meno il campo nel foglio dati della query (recordset) 5) criteri di selezione/oppure 6) formula per inserire raggruppamenti/campi di totali Se si vogliono impostare i criteri per tutti i campi della tabella basta trascinare l’* dalla casella della tabella oppure doppio click sul titolo della tabella e trascinamento sulla griglia con il mouse. Per impostare i criteri solo per alcuni campi della tabella selezionarli dalla tabella stessa e trascinarli ad uno ad uno sulla griglia QBE. Per eliminare un campo dalla griglia QBE selezionare la colonna corrispondente e selezionare il comando Elimina Colonne dal menù Modifica. Ordinamento: A seconda del tipo di dato del campo, l’ordinamento viene eseguito in modalità diverse: • alfabetico per nome • cronologico per data • numerico per valore L’ordinamento (crescente o decrescente) può essere eseguito su più campi, ma viene applicato consecutivamente da sinistra a destra, pertanto i campi devono essere disposti nella stessa sequenza dell’ordinamento voluto. Criteri di selezione: Di seguito riportiamo alcuni semplici esempi su come impostare i criteri di selezione.

16


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

CRITERI0 Univ? Univ* 1## <50 >=10 <>"MO" Between 1 and 100 Is Null Is Not Null Like “a*” >1 And <=10 “Mario” Or “Ugo” In (“Mario”, “Ugo”)

DESCRIZIONE Il ? è un carattere jolly che rappresenta un qualsiasi carattere alfabetico. L’* è un carattere jolly che rappresenta un qualsiasi numero di caratteri. Il # è un carattere jolly che rappresenta un qualsiasi carattere numerico. Valore numerico < di 50. Valore > o = a 10. Valore alfanumerico diverso da “MO”. Valori numerici compresi tra 1 e 100. Tutte le righe con un valore nullo (non presente) per un campo Tutte le righe con un valore diverso da nullo (presente) per un campo. Tutte le parole che iniziano per a. Tutti i numeri contemporaneamente maggiori di uno e minori o uguali a 10. Tutti i record con un campo alfanumerico uguale a “Mario” o “Ugo”. Uguale al precedente.

Riga della Formula nella griglia QBE: Si attiva selezionando dal menu Visualizza il comando Totali. Questa nuova riga contraddistinta dal nome Formula, permette di realizzare delle query di selezione che eseguono dei calcoli sui dati presenti all’interno di ogni singolo campo della tabella. FUNZIONE SOMMA MEDIA MIN MAX CONTEGGIO DEVST VAR PRIMO ULTIMO RAGGRUPPAMENTO DOVE ESPRESSIONE

DESCRIZIONE Somma dei valori di un campo (numerico, valuta) Media dei valori di un campo (numerico, valuta) Il minimo valore in un campo (no per OLE e memo) Il massimo valore in un campo (no per OLE e memo) Conteggio dei valori in un campo, non conteggia i valori Null Deviazione standard dei valori del campo (numerico, valuta) Varianza dei valori contenuti in un campo (numerico, valuta) Primo record contenente il valore Ultimo record contenente il valore Definire i gruppi per i quali si desidera eseguire i calcoli (raggruppa per valori uguali del campo) Specificare dei criteri per un campo che si sta utilizzando per definire dei raggruppamenti Utilizzare un’espressione come criterio in un calcolo

5.4.1.5 Salvare una query Per salvare una query basta scegliere il comando Salva dal menù File o cliccare sull’icona corrispondente. Per il primo salvataggio bisogna dare il nome alla query.

5.5 Rapporti In questa sezione si imparerà a presentare informazioni all’esterno di un database. Si imparerà ad operare con i report.

17


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

5.5.1.1 Presentare i dati (sullo schermo o a stampa) in una particolare sequenza In Access per presentare le informazioni raggruppate e/o riepilogate secondo particolari criteri (derivanti da tabelle e/o query) si utilizzano i cosiddetti report. I report possono essere creati mediante: 1. Creazione guidata 2. In visualizzazione struttura Sezioni in cui è suddiviso un report: 1. Intestazione di report: sezione presente in alto, compare una sola volta nel report. Essa viene utilizzata per immettere informazioni tipo il titolo, un logo, una data etc, etc. 2. Intestazione di pagina: sezione visualizzata nella parte superiore di ogni report tranne che nella prima pagina dove segue l’intestazione del report. Essa viene utilizzata, di norma, per mostrare le intestazioni delle colonne. 3. Corpo: è il cuore del report ed è composto dai dati delle tabelle e/o query di origine. 4. Piè di pagina pagina: sezione che si trova in fondo a ciascuna pagina. Essa viene utilizzata, di norma, per mostrare il numero di pagina. 5. Piè di pagina report: sezione che appare una sola volta al termine del report. Essa viene utilizzata, di norma, per visualizzare i totali. Le sezioni di un report (visualizzazione struttura) sono rappresentate sotto forma di fasce ciascuna delle quali è destinata a contenere controlli analoghi a quelli delle maschere. Le sezioni sono tutte dimensionabili posizionando il puntatore del mouse sul bordo di sezione e trascinandolo quando assume la forma di una freccia verticale a due punte. Tipi di visualizzazione di un report: 1. Anteprima di layout: permette di verificare il formato del testo (tipo e dimensione) e il layout generale del report. Esso mostra solo un esempio di dati della tabella e/o query di origine dei dati. 2. Anteprima di stampa: permette di esaminare l’intero documento così come verrà stampato 3. Struttura: permette di modificare il layout di un report per crearne uno nuovo.

5.5.1.2 Modificare un rapporto Un report realizzato con l’autocomposizione presenta una veste professionale. Se però vogliamo apportare delle modifiche al layout che ci viene presentato basta ricorrere alla Visualizzazione Struttura. Utilizzando quest’ultima è anche possibile creare un report exnovo. I passi da seguire in quest’ultimo caso sono: 1. Selezionare Visualizzazione Struttura (eventualmente dopo avere scelto Nuovo dalla scheda Report, se si vuole realizzare un report a partire da zero) 2. Selezionare il nome della tabella o della query origine dei dati che verranno visualizzati sul report e fare clic su OK; 3. Apparirà la visualizzazione struttura del report nella quale effettuare tutte le modifiche e aggiunte che si vuole. 5.5.1.3 Creare e personalizzare intestazioni e piè di pagina Come abbiamo segnalato precedentemente per modificare le sezioni di un report bisogna utilizzare la Visualizzazione Struttura. Di seguito riportiamo un esempio di un report creato sulla tabella contatti e aperto in visualizzazione struttura:

18


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

Il formato scelto per il report è quello tabellare, come si può notare l’intestazione di pagina è composto dai nomi dei campi della tabella contatti. Va da se che tali intestazioni possono essere cambiate in qualsiasi momento. Riguardo al piè di pagina sono presenti delle funzioni classiche che vengono inserite in tutti i report generati con la creazione guidata. FUNZIONE

DESCRIZIONE Calcola la data Corrente es: sabato 14

=Now()

febbraio 2004

="Pagina " & [Page] & " di " & [Pages]

Indica il numero della pagina corrente [Page] e il numero delle pagine totali [Pages] es: Pagina 1 di 1

5.5.1.4 Raggruppare i dati di un rapporto (es. totali, subtotali, ecc.) Un gruppo è un insieme di record simili corredato di informazioni introduttive e di riepilogo: ciò facilita la comprensione di chi visiona il report. Inoltre all'interno del gruppo è possibile ordinare i dati in ordine alfabetico oppure dal valore minore al massimo o viceversa. I gruppi si creano impostando le proprietà nella finestra di dialogo Ordinamento e raggruppamento da aprire sulla barra degli strumenti: tale finestra elenca nella prima colonna i campi o le espressioni che si vuole raggruppare (o ordinare), e nella seconda il criterio di ordinamento: 1. selezionare il nome di un campo o digitare un'espressione nella prima riga della colonna Campo o espressione; 2. scegliere il Criterio ordinamento nella seconda colonna (crescente o decrescente); 3. selezionare il campo o l'espressione di cui si desidera impostare le proprietà di gruppo; 4. impostare a Sì la proprietà Intestazione (gruppo) (e eventualmente la proprietà Piè di pagina (gruppo)) di un campo o di un'espressione. Si aggiungerà automaticamente

19


Realizzati da Oxfirm.it – Modulo de Basi di dati / sistemi di archiviazione

una sezione intestazione (e una sezione piè di pagina di gruppo) alla struttura del report; 5. se si raggruppano dati di un campo di tipo Data/Ora, impostare la proprietà Raggruppa secondo con i valori Anno, Trimestre, Mese, Settimana, Giorno, Ora e Minuto; se invece i dati si raggruppano in base ad un tipo di campo Testo, la proprietà va impostata a Caratteri iniziali, per raggruppare i dati nei vari gruppi secondo le loro lettere iniziali, oppure a Ogni valore per raggruppare i record che contengono lo stresso valore nel campo o nell'espressione; 6. con la proprietà Stampa sezione unita si decide se stampare un gruppo su una stessa pagina (scegliere Gruppo intero) oppure anche in più pagine (scegliere No).

20

ECDL - Modulo5 syllabus 4.0  

Appunti adatti a per la preparazione del quinto esame per conseguire la certificazione ECDL Core

Read more
Read more
Similar to
Popular now
Just for you