Page 1

Unicon  17

      หลังจากรูจักกับฮารดแวร Unicon จากบทที่ 1 แลว ลําดับตอไปเปนการอธิบายถึงซอฟตแวรที่ใชใน การพัฒนางานสําหรับบอรด Unicon นันคื ่ อ Arduino 1.0 (หรือเวอรชันสูงกวา) แตเนืองจาก ่ Unicon เปน ฮาร ดแวร ที่ไม ไดเกิดจากคณะทํางานอยางเปนทางการของ Arduino จึงทําให INEX ตองจัดทําไฟลติดตัง้ ซอฟตแวร Arduino 1.0 ขึนมาเอง ้ ผูใชงานดาวนโหลดไดฟรีที่ www.uniconboard.com โดยไฟลติดตั้งมีชื่อ ว า arduino1.0.1release_setup120723.exe ตัวเลขในตอนทายของชื่อไฟลอาจเปลียนแปลงตามการปรั ่ บปรุง เวอรชันในอนาคต หรือเลือกจากไฟลติดตังในแผ ้ น DVD ทีจั่ ดมาพรอมกับชุด Unicon cablepack หรือชุดทดลอง อืนๆ ่ ของ Unicon ก็ได

  2.1.1 ติดตั้งซอฟตแวร Arduino1.0x (2.1.1.1) นําแผน DVD ทีมากั ่ บชุด Unicon CablePack หรือชุดทดลอง Unicon รุนต  างๆ ใสเขาไปใน DVD รอมไดรฟของคอมพิวเตอร คนหาและดับเบิลคลิ ้ กทีไฟล ่  arduino1.0.1release_setup120531.exe (เลขเวอรชัน อาจเปลียนแปลงได ่ ) หรือดาวนโหลดไดที่ www.uniconboard.com จะปรากฎหนาตางตอนรับสูการติ  ดตังให ้ คลิก Next หนาตางติดตังจะสอบถามตํ ้ าแหนงการติดตังโปรแกรมให ้ กด Next ขามขันตอนนี ้ ไป ้


18 

Unicon

(2.1.1.2) หนาตางติดตังจะสอบถามชื ้ อที ่ จะใช ่ สรางที่ Start Menu ใหคลิก Next ตอไป หนาตางติดตังจะ ้ แสดงขอสรุปมาให ใหกด Install เพือเริ ่ มขั ่ นตอนการติ ้ ดตัง้ โปรแกรมติดตังจะใช ้ เวลาสักครูก็ จะติดตังเรี ้ ยบรอย จากนันเข ้ าสูหนาตางของการติดตั้งไดรเวอร USB ขันต ้ นของบอรด Unicon ดังรูป คลิก ปุม Next

(2.1.1.3) มีขอความแจงเตือนเกียวกั ่ บการตรวจสอบไดรเวอรตัวนี้ ใหคลิกที่ Install this Driver software anyway โดยจะปรากฎหนาตางนีขึ้ นมา ้ 2 ครัง้ ใหกดเลือกทังสองครั ้ ง้

(2.1.1.4) จากนั้นการติดตั้งไดรเวอรขันต ้ นจะเกิดขึ้น เมื่อติดตั้งเสร็จ จะปรากฏหนาตางแจงการติดตั้ง ไดรเวอรและแสดงชื่อของไดรเวอรที่ติดตั้ง ในที่นีคื้ อ Arduino LLC คลิกปุม Finish


Unicon  19

2.1.2 ทดสอบอัปโหลดโปรแกรมและติดตั้งไดรเวอร USB รอบที่ 2 (2.1.2.1) เปดสวิตชจายไฟใหแกบอรด Unicon อาจเห็น LED สีนําเงิ ้ นกะพริบวูบๆ จากนันต ้ อสาย USBminiB เขาทีจุ่ ดตอ USB ของบอรด Unicon สวนปลายอีกดานของสาย USB ตอเขากับพอรต USB ของคอมพิวเตอร

การติดตังไดรเวอร ้ USB ของบอรด Unicon ตัวใหมที่มาจากผูผลิต จะตองกระทํา 2 รอบ (2.1.2.2) เมื่อตอบอรด Unicon เขากับพอรต USB ระบบจะตรวจสอบฮารดแวรครูหนึง่ ทีมุ่ มขวาลาง ของคอมพิวเตอรจะแจงวา ตรวจพบฮารดแวรตัวใหม คอมพิวเตอรจะใชเวลาสักครูในการติดตั้งไดรเวอร (ซึ่งติด ตังไว ้ แลวกอนหนานี)้ โดยสามารถตรวจสอบการติดตังไดรเวอร ้ จากการคลิกเมาสปุมขวาที  ่ My Computer เลือก Property จากนันเลื ้ อก Device Manager


20 

Unicon

(2.1.2.3) ภายใน Device Manager ใหเลือกหัวขอ Ports (COM&LPT) ซึงถ ่ าการติดตังไดรเวอร ้ ถูกตอง จะพบฮารดแวรทีชื่ อ่ Unicon Board & POP-XT (Ceterina) boot mode (COMxx) โดยตําแหนง COM อาจเปลียน ่ ตามคอมพิวเตอรแตละเครือง ่ ไดรเวอรทีเกิ ่ ดขึนเป ้ นไดรเวอรหนึงตั ่ วจากสองตัวทีจะต ่ องติดตัง้ ดังนันเพื ้ อตรวจสอบ ่ การทํางาน แนะนําใหเปดหนาตาง Device Manager ทิ้ งไวกอน จากตัวอยางไดรเวอรตัวแรกจะใหตําแหนง พอรตเปน COM3 (2.1.2.4) เปดซอฟตแวร Arduino1.0.x ที่ติดตั้งจากขันตอนที ้ ่ (1.1) ถึง (1.5) ขึนมาใช ้ งาน โดยยังคงตอ สาย USB กับบอรด Unicon และพอรต USB ของคอมพิวเตอรอยู (2.1.2.5) จากนั้นเลือกไฟลสเก็ตชตัวอยางเพื่อเปดขึ้นมาทดสอบ ในที่นีเลื ้ อกไฟล Blink31 จาก File > Example > POP-BOT XT > Blink31

(2.1.2.6) หนาตางแสดงซอรสโคดของไฟลสเก็ตชทีเลื ่ อกเปดจะปรากฏขึน้ แลวเลือกฮารดแวรที่นํามา ตอทดสอบจาก Tools > Board > Unicon board (Caterina)


Unicon  21

(2.1.2.7) เลือกตําแหนงพอรตทีใช ่ ในการเชื่อมตอ จาก Tools > Serial port > COMxxx ในที่นีคื้ อ COM3

(2.1.2.8) ทําการอัปโหลดโปรแกรม โดยคลิกทีปุ่ ม

หรือเลือกที่ File > Upload รอจนกระทังการ ่

อัปโหลดไฟลเสร็จสิน้ สังเกตไดจากขอความและแถบแจงสถานะทีด่ านลางของหนาตางโปรแกรม (2.1.2.9) เมืออั ่ ปโหลดเสร็จสิน้ บอรด Unicon จะทํางานทันที LED สีนําเงิ ้ นทีต่ อกับพอรต 31 จะกะพริบ (2.1.2.10) ถาเปดหนาตาง Device Manager อยูจะพบว  าหลังจากอัปโหลดโคดเสร็จเรียบรอย จะมีฮารด แวรตัวใหมปรากฎขึ้นมา มีชื่อวา Unicon Board & POP-XT (COMxx) โดยตําแหนงของ COM จะเปลี่ยนเปน COM4 ดังนันเมื ้ อจะใช ่ งานครั้งตอไปจะตองเลือกตําแหนงพอรตอนุกรมเปนตําแหนงใหมตามหนาตาง Device Manager นี้ หรือตรวจสอบผานทางเมนู Tools > Serial port ของหนาตางโปรแกรม Arduino ก็ได

ดังนันในการติ ้ ดตังไดรเวอร ้ USB ของบอรด Unicon จะเกิดพอรตเชือมต ่ อ 2 ตัวที่ มีหมายเลขตอกัน เวลาใชงานหากประสบปญหาในการอัปโหลดโคด ใหตรวจสอบหมาย เลขพอรตอีกครัง้ หรือถอดสาย USB ออกแลวตอเขาไปใหม รอสักครู จากนันตรวจสอบ ้ ตําแหนงของพอรตเชื่อมตออีกครั้ง กอนทําการอัปโหลดโปรแกรม


22 

Unicon

2.1.3 การแกปญหาในกรณีทีระบบแจ ่ งวา ไมสามารถคนหาไดรเวอรของบอรด Unicon เพือทํ ่ างานตอได หลังจากที่ติดตังไดรเวอร ้ USB เสร็จสินไปแล ้ ว และการใชงานเปนไปอยางปกติ โดยหลักการแลวควร ตอและใชงานพอรต USB ในชองนันๆ ้ ไปตลอด หากเกิดการเปลี่ยนชองตอพอรต USB ใหม อาจจะตองติด ตังไดรเวอร ้ ใหม ซึงให ่ ทําตามขันตอนเดิ ้ ม อยางไรก็ตาม หากประสบปญหาวา ระบบแจงวาไมสามารถคนหาไดรเวอรเพื่อติดตอกับฮารดแวรได ใหทําตามขันตอนดั ้ งนี้ (2.1.3.1) เมื่อเปดหนาตาง Device Manager โดยคลิกเมาสปุมขวาที่ My Computer เลือก Property จากนันเลื ้ อก Device Manager ที่หนาตาง Device Manager จะพบอุปกรณที่มีเครื่องหมาย ! ปรากฎอยูดังรูป คลิกเมาสปุมขวาที่รายการนัน้ แลวเลือก Update Driver

(2.1.3.2) เลือก Browse my computer for driver software


Unicon  23

(2.1.3.3) เลือกโฟลเดอรของไดรเวอรไปที่ C:\Arduino\drivers\Unicon POP-XT Driver และกด Next เพื่ออัปเดตไดรเวอร

(2.1.3.4) เชนเดียวกับการติดตังไดรเวอร ้ ปกติ อาจมีการแจงเตือนวา ไดรเวอรที่กําลังจะติดตังไม ้ ไดผาน การรับรอง ใหเลือก Install this Driver software anyway จากนั้นการอัปเดตไดรเวอรก็จะเสร็จสมบูรณ ทําให คอมพิวเตอรสามารถติดตอกับบอรด Unicon เพื่อใชงานตอไป

เมืออั ่ ปเดตหรือติดตังไดรเวอร ้ เสร็จสมบูรณแลว เวลาใชงานควรตรวจสอบหมายเลขพอรต เชือมต ่ อกอนทําการอัปโหลดโปรแกรมเสมอ เนืองจาก ่ Arduino 1.0x มีความสามารถในการคนหา พอรตเชือมต ่ อทีเกิ่ ดขึนในระบบทั ้ งหมดอย ้ างอัตโนมัติ และดวยไดรเวอรของ Arduino Leonardo (Caterina) ทีใช ่ ในแผงวงจร POP-XT และ Unicon มีการสรางพอรต อนุกรมเสมือนเพือรองรั ่ บกับ คอมพิวเตอรอยู 2 ตําแหนงสลับกันไปมาในทุกครังที ้ มี่ การรีเซตหรืออัปโหลดโปรแกรมใหม


24 

Unicon

    2.2.1 ติดตั้งซอฟตแวร Arduino1.0x (2.2.1.1) นําแผน DVD ทีมากั ่ บชุด Unicon CablePack หรือชุดทดลอง Unicon รุนต  างๆ ใสเขาไปใน DVD รอมไดรฟของคอมพิวเตอร คนหาและดับเบิลคลิ ้ กทีไฟล ่  arduino1.0.1release_setup120531.exe (เลขเวอรชัน อาจเปลียนแปลงได ่ ) หรือดาวนโหลดไดที่ www.uniconboard.com จะปรากฎหนาตางตอนรับสูการติ  ดตังให ้ คลิก Next หนาตางติดตังจะสอบถามตํ ้ าแหนงการติดตังโปรแกรมให ้ กด Next ขามขันตอนนี ้ ไป ้

(2.2.1.2) หนาตางติดตั้งจะสอบถามชื่อที่จะใชสรางที่ Start Menu ใหคลิก Next หนาตางติดตั้งจะแสดง ขอสรุปมาให คลิก Install เพื่อเริ่มการติดตั้ง จากนั้นเขาสูหนาตางติดตั้งไดรเวอร USB ขันต ้ น คลิกปุม Next รอจนกระทังติ ่ ดตังเสร็ ้ จ จะปรากฏหนาตางแจงการติดตังไดรเวอร ้ เสร็จสมบูรณและแสดงชือของไดรเวอร ่ ที่ติด ตั้งลงไป ในที่นีคื้ อ Arduino LLC คลิกปุม Finish ตอบรับการติดตั้งเสร็จสิน้


Unicon  25

2.2.2 ติดตั้งไดรเวอรใหกับบอรด Unicon สําหรับวินโดวส XP (2.2.2.1) เปดสวิตชจายไฟใหแกบอรด Unicon จะเห็น LED สีนําเงิ ้ นกะพริบวูบๆ จากนันต ้ อสาย USBminiB เขาทีจุ่ ดตอ USB ของบอรด Unicon สวนปลายอีกดานของสาย USB ตอเขากับพอรต USB ของคอมพิวเตอร

 ง่ จึงคอยตอสาย ขันตอนนี ้ สํ้ าคัญมาก จะตองเปดสวิตชจายไฟกอน แลวรอสักครูหนึ เขากับพอรต USB ของคอมพิวเตอร มิเชนนันการติ ้ ดตั้งไดรเวอรอาจมีขอผิดพลาดได การติดตังไดรเวอร ้ USB ของบอรด Unicon ตัวใหมที่มาจากผูผลิต จะตองกระทํา 2 รอบ (2.2.2.2) เมือต ่ อบอรด Unicon เขากับพอรต USB ระบบจะตรวจสอบฮารดแวรและสอบถามถึงตําแหนง ของไดรเวอร ใหคลิกเลือกทีช่ อง Install from a list or specific location (Advanced) จากนันคลิ ้ กทีปุ่ ม Next


26 

Unicon

(2.2.2.3) เลือกตําแหนงของไดรเวอรไปที่ C:\Arduino\Drivers ตามรูป แลวคลิกปุม Next จากนั้น กระบวนการติดตั้งไดรเวอรจะเริ่มขึ้น เมื่อติดตั้งเสร็จสิน้ คลิกปุม Finish

(2.2.2.4) ตรวจสอบตําแหนงของพอรตอนุกรมของบอรด Unicon ที่เกิดขึ้นไดที่ Control Panel > System > Hardware > Device Manager แลวดูที่รายการ Ports จะพบชื่อ Unicon Board & POP-XT (COM xx) จากตัวอยางคือ COM3 (หมายเลข COM อาจเปลี่ยนแปลงไดในคอมพิวเตอรแตละเครื่อง)

ถึงตอนนี้การติดตั้งไดรเวอร USB ของบอรด Unicon กับระบบ ปฏิบัติการวินโดวส XP ยังไมเสร็จ จะตองดําเนินการตออีกหนึงกระบวน ่ การ มิฉะนั้นการติดตั้งไดรเวอรอาจไมสมบูรณ สงผลใหใชงานไมได (2.2.2.5) เปดซอฟตแวร Arduino1.0.x ที่ติดตั้งจากขันตอนที ้ ่ (2.2.2.1) ขึนมาใช ้ งาน โดยยังคงตอสาย USB กับบอรด Unicon และพอรต USB ของคอมพิวเตอรอยู (2.2.2.6) เปดไฟลสเก็ตชขึนมาทดสอบ ้ ในที่นีเลื ้ อกไฟล Blink31 จาก File > Example > Blink31


Unicon  27

(2.2.2.7) หนาตางแสดงซอรสโคดของไฟลสเก็ตชทีเลื ่ อกเปดจะปรากฏขึน้ แลวเลือกฮารดแวรที่นํามา ตอทดสอบจาก Tools > Board > Unicon board (Caterina)

(2.2.2.8) เลือกตําแหนงพอรตทีใช ่ เชื่อมตอ จาก Tools > Serial port > COMxxx ในที่นีคื้ อ COM3

(2.2.2.9) ทําการอัปโหลดโปรแกรม โดยคลิกที่ปุม

หรือเลือกที่ File > Upload รอจนกระทั่ง

การอัปโหลดไฟลเสร็จสิน้ สังเกตไดจากขอความและแถบแจงสถานะที่ดานลางของหนาตางโปรแกรม

(2.2.2.10) เมื่ออัปโหลดเสร็จสิน้ บอรด Unicon จะทํางานทันที LED ที่ตอกับพอรต 31 ติดกะพริบ การติดตั้งไดรเวอรของแผงวงจร Unicon เสร็จไปขันตอนหนึ ้ ่ง


28 

Unicon

(2.2.2.11) จากนั้นจะปรากฏหนาตางรองขอการติดตั้งไดรเวอรในรอบที่สองขึนมาทั ้ นที ใหคลิกเลือก ทีช่ อง Install from a list or specific location (Advanced) จากนันคลิ ้ กทีปุ่ ม Next เพือผ ่ านขันตอนนี ้ ไป ้

(2.2.2.12) เลือกตําแหนงของไดรเวอรไปที่ C:\Arduino\Drivers ตามรูป แลวคลิกปุม Next จากนัน้ กระบวนการติดตังไดรเวอร ้ จะเริมขึ ่ น้ รอจนกระทังเสร็ ่ จ คลิกปุม Finish

(2.2.2.13) รอสักครูระบบจะร  องขอใหติดตังไดรเวอร ้ อีกตัวหนึง่ ตามรูป ใหคลิกเลือกทีช่ อง Install from a list or specific location (Advanced) จากนันคลิ ้ กทีปุ่ ม Next เพือผ ่ านขันตอนนี ้ ไป ้ (2.2.2.14) เลือกตําแหนงของไดรเวอรไปที่ C:\Arduino\Drivers อีกครั้ง แลวคลิกปุม Next (2.2.2.15) จากนั้นกระบวนการติดตั้งไดรเวอรจะเริ่มขึ้น รอจนกระทั่งเสร็จ คลิกปุม Finish เปนอัน เสร็จสินการติ ้ ดตั้งไดรเวอรของบอรด Unicon บนระบบปฏิบัติการวินโดวส XP อยางสมบูรณ


Unicon  29

(2.2.2.16) ตรวจสอบตําแหนงของพอรตอนุกรมของบอรด Unicon ที่เกิดขึ้นใหมที่ Control Panel > System > Hardware > Device Manager ดูที่รายการ Ports จะพบชื่อ Unicon Board & POP-XT (COM xx) จากตัวอยางตําแหนงของพอรตจะเปลียนเป ่ น 4 (หมายเลข COM อาจเปลี่ยนแปลงได) หากไมมีการเปลียนตํ ่ า แหนงพอรต USB ที่ใชติดตอกับบอรด Unicon ใหม จะใชตําแหนงพอรตนี้ไปไดตลอด

เมือติ ่ ดตังไดรเวอร ้ ไดเรียบรอย บอร ด Unicon ก็พรอมสําหรับการทดสอบและเริมต ่ นเรียนรูเพื  อพั ่ ฒนา โปรแกรมสําหรับระบบควบคุมในลําดับตอไป


30 

Unicon

     หลังจากทีติ่ ดตังไดรเวอร ้ USB เสร็จสินไปแล ้ ว และการใชงานเปนไปอยางปกติ โดยหลักการแลวควรตอ และใชงานพอรต USB ในชองนั้นๆ ไปตลอด ถาหากเปลี่ยนชองตอพอรต USB จะตองติดตั้งไดรเวอรใหม ถาคอมพิวเตอรมีพอรต USB 3 ชอง และตองการใชงานใหไดครบ จะตองติดตังไดรเวอร ้ 2 รอบนี้ รวม 3 ครัง้ โดย มีขันตอนที ้ แตกต ่ างจากหัวขอ 2.2 ดังนี้ (2.3.1) เมื่อตอบอรด Unicon เขากับพอรต USB ชองใหม ระบบจะตรวจพบฮารดแวรตัวใหมและสอบ ถามถึงตําแหนงของไฟลไดรเวอร ใหเลือกทีช่ อง Install from a list or specific location (Advanced) ตามดวย ปุม Next เพือผ ่ านขันตอนนี ้ ไป ้

(2.3.2) เลือกตําแหนงของไดรเวอรไปที่ C:\Arduino\Drivers ตามรูป แลวคลิกปุม Next


Unicon  31

(2.3.3) จากนั้นกระบวนการติดตั้งไดรเวอรจะเริ่มขึ้น รอจนกระทั่งเสร็จ คลิกปุม Finish (2.3.4) ยังคงตอสาย USB เพื่อเชื่อมตอระหวางแผงวงจรกับพอรต USB จากนั้นปดสวิตช จากนั้นกด สวิตช 31 บนบอรด Unicon ตามดวยเปดสวิตชจายไฟเลียง ้ แลวปลอยสวิตช 31 ตามหลัง


32 

Unicon

(2.3.5) ระบบคอมพิวเตอรจะตรวจพบฮารดแวรใหมเพือร ่ องขอการติดตังไดรเวอร ้ ในรอบที่ 2 ใหเลือก ทีช่ อง Install from a list or specific location (Advanced) จากนันคลิ ้ กทีปุ่ ม Next เพือผ ่ านขันตอนนี ้ ไป ้ (2.3.6) เลือกตําแหนงของไดรเวอรไปที่ C:\Arduino\Drivers ตามรู ป แลวคลิกปุม Next จากนัน้ กระบวนการติดตั้งไดรเวอรจะเริ่มขึ้น รอจนกระทั่งเสร็จ คลิกปุม Finish เพื่อจบการติดตั้ง

(2.3.7) ตรวจสอบตําแหนงของพอรตอนุกรมของบอรด POP-XT ทีเกิ ่ ดขึนได ้ ที่ Control Panel > System > Hardware > Device Manager แลวดูที่รายการ Ports จะพบชื่อ Unicon Board & POP-XT (COM xx) เพือนําไปใชในการอัปโหลดโปรแกรมตอไป (2.3.8) ทําการกดสวิตช RESET บนบอรด Unicon หนึงครั ่ ้งกอนทําการอัปโหลดโปรแกรม (2.3.9) กอนทําการอัปโหลดโปรแกรมไปยังบอรด Unicon ตองทําการตรวจสอบตําแหนงพอรตกอน ทุกครั้ง เพื่อใหแนใจวา มีพอรตทีติ่ ดตอกับบอรด Unicon พรอมทํางาน ถาเปดหนาตาง Device Manager อยู จะพบวา กอนและหลังอัปโหลดโคดเสร็จเรียบรอย ตําแหนงของ COM จะเปลี่ยน 2 ครั้ง ดังนันเมื ้ อจะใช ่ งาน ครังต ้ อไปจะตองเลือกตําแหนงพอรตอนุกรมเปนตําแหนงใหมตามหนาตาง Device Manager นี้ หรือตรวจสอบ ผานทางเมนู Tools > Serial port ของหนาตางโปรแกรม Arduino ก็ได

ดังนันในการติ ้ ดตังไดรเวอร ้ USB ของบอรด Unicon จะเกิดพอรตเชือมต ่ อ 2 ตัวที่ มีหมายเลขตอกัน เวลาใชงานหากประสบปญหาในการอัปโหลดโคด ใหตรวจสอบหมาย เลขพอรตอีกครัง้ หรือถอดสาย USB ออกแลวตอเขาไปใหม รอสักครู จากนันตรวจสอบ ้ ตําแหนงของพอรตเชื่อมตออีกครั้ง กอนทําการอัปโหลดโปรแกรม


Unicon  33

     การติดตังซอฟต ้ แวร Arduino1.0 บนคอมพิวเตอร Macintosh มีขันตอนที ้ ไม ่ ซับซอน เนืองจากไฟล ่ ทั้งหมดไดรับการบรรจุรวมอยูในไฟล .ZIP เพียงไฟลเดียว มีขันตอนดั ้ งนี้ (2.4.1) คัดลอกไฟล Arduino1.0.zip จากแผน DVD หรือจากการดาวนโหลดมาจาก www.inex.co.th หรือ www.uniconboard.com ไปไวที่หนา Desktop (2.4.2) ทําการแตกไฟล โดยเลือกคําสั่ง Open With > Archive Utility หรือใชซอฟตแวรที่ทําหนาที่ ในการแตกไฟล .zip

(2.4.3) จากการแตกไฟล จะไดเปนไฟล Arduino มีไอคอนดังรูป

(2.4.4) เปดหนาตาง Finder ลากไอคอน Arduino ไปไวรวมใน Applications


34 

Unicon

(2.4.5) ดับเบิ้ลคลิกเพื่อเปดซอฟตแวร Arduino จากนั้นไปที่เมนู Tools เลือก Board เปนรุน Unicon

(2.4.6) เปดสวิตชจายไฟแกแผงวงจร POP-XT รอสักครูเพือให ่ แผงวงจรเตรียมความพรอม ใชเวลาประ มาณ 10 วินาที จากนันจึ ้ งเสียบสาย USB จากแผงวงจร POP-XT เขาที่พอรต USB ของคอมพิวเตอร Macintosh (2.4.7) ไปที่เมนู Tools เลือก Serial Port จะพบอุปกรณที่ชื่อ /dev/tty.usbmodemxxxx โดย xxxx ที่ตามมาขางหลังอาจจะมีชื่อใด ๆ อยูก็ได ใหเลือกใชการสื่อสารอนุกรมจากอุปรณตัวนี้

หากไดตามนีแสดงว ้ า การติดตังไดรเวอร ้ ของแผงวงจร Unicon เสร็จสมบูรณ พรอมสําหรับการนํา ไปใชงานจริง


Unicon  35

 2.5.1 สวนประกอบของหนาจอโปรแกรม Arduino1.0 เมื่อเรียกใหโปรแกรมทํางาน จะมีหนาตาดังรูปที่ 2-1 ตัวโปรแกรมประกอบดวยสวนตางๆ ดังนี้  เมนู (Menu) ใชเลือกคําสั่งตางๆ ในการใชงานโปรแกรม ่ อ (Toolbar) เปนการนําคําสั่งที่ใชงานบอยๆ มาสรางเปนปุมเพื  ่อใหเรียกใชคําสั่ง  แถบเครืองมื ไดรวดเร็วขึน้  แถบเลือกโปรแกรม (Tabs) เปนแถบที่ใชเลือกไฟลโปรแกรมแตละตัว (กรณีที่เขียนโปรแกรม ขนาดใหญประกอบดวยไฟลหลายตัว)

เมนู (Menu) แถบเครืองมื ่ อ (Tools bar) แถบเลือกโปรแกรม (Tab)

พืนที ้ ่สําหรับเขียนโปรแกรม (Text Editor)

พืนที ้ แสดงสถานะการทํ ่ างาน (Message area)

รูปที่ 2-1 แสดงสวนประกอบของโปรแกรม Arduino1.0

Serial Monitor คลิกเพือเป ่ ดหนาตาง สําหรับรับและสงขอมูล อนุกรมระหวางฮารดแวร Arduino กับคอมพิวเตอร


36 

Unicon

พื้นที่เขียนโปรแกรม (Text editor) เปนพื้นทีสํ่ าหรับเขียนโปรแกรมภาษา C/C++  พืนที ้ แสดงสถานะการทํ ่ างาน (Message area) เปนพืนที ้ โปรแกรมใช ่ แจงสถานะการทํางานของ โปรแกรม เชน ผลการคอมไพลโปรแกรม  พื้นที่แสดงขอมูล (Text area) ใชแจงวาโปรแกรมที่ผานการคอมไพลแลวมีขนาดกีไบต ่  ปุมสํ าหรับเปดหนาตาง Serial Monitor ปุ มนี้จะอยูทางมุมบนดานขวามือ คลิกปุมนีเมื ้ ่อตอง การเปดหนาตางสื่อสารและแสดงขอมูลอนุกรม โดยตองมีการตอฮารดแวร Arduino และเลือกพอรตการเชื่อม ตอใหถูกตองกอน 

หนาตาง Serial Monitor มีบทบาทคอนขางมากในการใชแสดงผลการทํางานของโปรแกรม แทนการใชอุปกรณแสดงผลอื่นๆ เนืองจาก ่ Arduino ไดเตรียมคําสั่งสําหรับใชแสดงคาของตัวแปรที่ตองการ ดูผลการทํางานไวแลว นันคื ่ อ Serial.print สวนการสงขอมูลจากคอมพิวเตอรไปยังฮารดแวร Arduino หรือแผง วงจรควบคุมใหพิมพขอความและคลิกปุม Send ในการรับสงขอมูลตองกําหนดอัตราเร็วในการถายทอดขอมูล หรือบอดเรต (baud rate) ใหกับโปรแกรมในคําสั่ง Serial.begin กรณีที่ใชงานกับคอมพิวเตอร Mcintosh หรือ คอมพิวเตอรทีติ่ ดตังระบบปฏิ ้ บัติการ Linux ตัวฮารดแวรของ Arduino จะรีเซ็ตเมือเริ ่ มเป ่ ดใชงาน Serial monitor


Unicon  37

2.5.2 เมนูบาร เปนสวนที่แสดงรายการ (เมนู) ของคําสั่งตางๆ ของโปรแกรม ประกอบดวย

2.5.2.1 เมนู File ใน Arduino จะเรียกโปรแกรมที่พัฒนาขึ้นวา สเก็ตช (Sketch) ในโปรแกรมของผูใชงานอาจมีไฟล โปรแกรมหลายตัว จึงเรียกรวมวาเปน สเก็ตชบุก (Sketchbook) เมนูนีจะเกี ้ ยวข ่ องกับการเปด-บันทึก-ปดไฟล มี คําสั่งที่ควรทราบและเกียวข ่ องกับบอรด Unicon ดังนี้

New : ใชสรางไฟลสเก็ตชตัวใหม เพื่อเริ่มเขียนโปรแกรมใหม  Open ใชเปดสเก็ตชที่บันทึกไวกอนหนานี้  Sketchbook : ใชเปดไฟลสเก็ตชลาสุดทีเป ่ ดใชงานเสมอ  Example : ใช ในการเลือกเปดไฟลสเก็ตชตัวอย างที่บรรจุและรวบรวมไวในโฟลเดอร ของ โปรแกรม Arduino1.0  Save : ใชในการบันทึกไฟลสเก็ตชปจจุบัน  Save as : ใชบันทึกไฟลสเก็ตชโดยเปลียนชื ่ ่อไฟล  Upload to I/O board : ใชอัปโหลดโปรแกรมไปยังแผงวงจร Unicon หรือฮารดแวรของ Arduino Leonardo  Page setup : ตังค ้ าหนากระดาษของไฟลสเก็ตชปจจุบัน ่ มพโคดของไฟลสเก็ตชปจจุบันออกทางเครื่องพิมพ  Print : สังพิ  Preference : ใชกําหนดคาการทํางานของโปรแกรม  Quit : ใชจบการทํางานและออกจากโปรแกรม 


38 

Unicon

2.5.2.2 เมนู Edit ในขณะทีพิ่ มพโปรแกรม ใชคําสังในเมนู ่ นีในการสั ้ งยกเลิ ่ กคําสังที ่ ่แลว ทําซํา้ ฯลฯ มีรายการคําสังต ่ างๆ ที่ควรทราบดังนี้

Undo : ยกเลิกคําสั่งหรือการพิมพครั้งสุดทาย  Redo : ทําซํ้าคําสั่งหรือการพิมพครั้งสุดทาย  Cut : ตัดขอความที่เลือกไวไปเก็บในคลิปบอรดของโปรแกรม  Copy : คัดลอกขอความที่เลือกไวมาเก็บในคลิปบอรด  Paste : นําขอความที่อยูในคลิปบอรดมาแปะลงในตําแหนงที่เคอรเซอรชี้อยู  Select All : เลือกขอความทั้งหมด ่ // เพือสร ่ างหมายเหตุหรือคําอธิบายลงในโปรแกรม  Comment/Uncomment : ใชเติมเครืองหมาย หรือยกเลิกหมายเหตุดวยการนําเครื่องหมาย // ออก  Find : คนหาขอความ  Find Next : คนหาขอความถัดไป  Find Previous : คนหาขอความกอนหนา  Use Selection For Find : คนหาดวยการเลือกคําหรือขอความ 


Unicon  39

2.5.2.3 เมนู Sketch เปนเมนูที่บรรจุคําสั่งที่ใชในการคอมไพลโปรแกรม เพิ่มไฟลไลบรารี ฯลฯ โดยมีเมนูยอยดังนี้

Verify/Compile : ใชคอมไพลแปลโปรแกรมภาษาซีใหเปนภาษาเครื่อง  Show Sketch folder : สังเป ่ ดโฟลเดอรทีเก็ ่ บโปรแกรมของผูใช  ้ Arduino จะทําการคัดลอก  Add file : เพิ่มไฟลใหกับสเก็ตชบุกปจจุบัน เมื่อใชคําสั่งนีโปรแกรม ไฟลที่เลือกไวมาเก็บไวในโฟลเดอรเดียวกันกับโปรแกรมที่กําลังพัฒนา  Import Library : เปนคําสังเรี ่ ยกใชไลบรารีเพิมเติ ่ ม เมือคลิ ่ กเลือกคําสังนี ่ แล ้ ว โปรแกรม Arduino IDE จะแสดงไลบรารีใหเลือก เมือเลื ่ อกแลว โปรแกรมจะแทรกบรรทัดคําสัง่ #include ลงในสวนตนของไฟล 

2.5.2.4 เมนู Tools ใชจัดรูปแบบของโคดโปรแกรม, เลือกรุนของฮารดแวร Arduino และเลือกพอรตที่ติดตอ เมนูที่ใชงาน กับบอรด Unicon มีดังนี้

Auto Format : จัดรูปแบบของโคดโปรแกรมใหสวยงาม  Archive Sketch : สังบี ่ บอัดไฟลโปรแกรมทังโฟลเดอร ้ หลักและโฟลเดอรยอยของไฟลสเก็ตช ปจจุบัน ไฟลทีสร ่ างใหมจะมีชือเดี ่ ยวกับไฟลสเก็ตชปจจุบันตอทายดวย -510123.zip  Board : เลือกฮารดแวรของบอรไมโครคอนโทรลเลอร Arduino สําหรับบอรด Unicon ใหเลือก Unicon Board ซึงเข ่ ากันไดกับฮารดแวร Arduini Leomardo  Serial Port : เลือกหมายเลขพอรตของคอมพิวเตอรทีต ่ อกับฮารดแวร Arduino และบอรด Unicon 


40 

Unicon

2.5.2.5 เมนู Help เมือต ่ องการความชวยเหลือ หรือขอมูลเกียวกั ่ บโปรแกรมใหเลือกเมนูนี้ เมือเลื ่ อกเมนูยอย ตัวโปรแกรม จะเปดไฟลเว็บเพจ (ไฟลนามสกุล .html) ที่เกียวข ่ องกับหัวขอนันๆ ้ โดยไฟลจะเก็บในเครื่องของผูใชภายใน โฟลเดอรที่เก็บ Arduino IDE

2.5.3 แถบเครื่องมือ (ทูลบาร : Tools bar) สําหรับคําสั่งที่มีการใชบอยๆ ตัวโปรแกรม Arduino1.0 จะนํามาสรางเปนปุมบนแถบเครื  ่องมือ เพื่อ ใหสามารถคลิกเลือกไดทันที ปุมตางๆ บนแถบเครื่องมือมีดังนี้ Verfy/Compile ใชตรวจสอบการเขียนคําสั่งในโปรแกรมวา มีถูกตองตามหลักไวยกรณ หรือไม และคอมไพลโปรแกรม Upload to I/O Board ใชอัปโหลดโปรแกรมที่เขียนขึนไปยั ้ งบอรดหรือฮารดแวร Arduino กอนจะอัปโหลดไฟล ตองแนใจวาไดบันทึกไฟลและคอมไพลไฟลสเก็ตชเรียบรอยแลว New ใชสรางสเก็ตไฟล (ไฟลโปรแกรม) ตัวใหม Open ใชแทนเมนู File > Sketchbook เพื่อเปดสเก็ตช (ไฟลโปรแกรม) ที่มีในเครื่อง Save ใชบันทึกไฟลสเก็ตชบุกที่เขียนขึน้


Unicon  41

 ในหัวขอนีเป ้ นการแนะนําขันตอนในการพั ้ ฒนาโปรแกรมสําหรับบอรด Unicon ตังแต ้ เริมต ่ นจนถึงการ อัปโหลดโปรแกรมเพื่อทําการทดสอบทางฮารดแวรเบื้องตน (2.6.1) เริ่มจากเปดซอฟตแวร Arduino1.0x (2.6.2) เลือกชนิดของฮารดแวร โดยเลือกที่เมนู Tools > Board > Unicon (Catarina) ดังรูป

(2.6.3) จากนั้นพิมพโคดตอไปนี้ void setup() { pinMode(31, OUTPUT); } void loop() { digitalWrite(31, HIGH); delay(500); digitalWrite(31, LOW); delay(500); }

// // // //

set the LED on wait for 0.5 second set the LED off wait for 0.5 second

(2.6.4) บันทึกเปนไฟลชื่อ Blink31.ino จากนั้นคอมไพลโปรแกรม โดยคลิกที่ปุม หรือเลือกที่ เมนู Sketch > Verify/Compile (2.6.5) เมือคอมไพล ่ โปรแกรมแลว ทีแถบแสดงสถานะและหน ่ าตางแสดงผลการคอมไพล ซึงเป ่ นหนาตาง สีดําอยูด านลางของโปรแกรม ทีแถบแสดงสถานะจะปรากฏข ่ อความ Done compiling และหนาตางแสดงผลแสดง ขอความวา Binary sketch size: 4,830 bytes (of a 28,672 byte maximum) แสดงวาโปรแกรมภาษาเครืองที ่ ได ่ จาก การคอมไพลมีขนาด 4,830 ไบต จากความจุของหนวยความจําของทังหมดที ้ ใช ่ งานได 28,672 ไบต


42 

Unicon

(2.6.6) เลือกพอรตทีใช ่ เชื่อมตอกับบอรด Unicon โดยเลือกจากเมนู Tools > Serial Port โปรแกรม จะแสดงพอรตทีมี่ ในคอมพิวเตอรใหผูใชงานเลือก ในตัวอยางเลือกพอรต COM3

(2.5.7) อัปโหลดโปรแกรมไปยังบอรด Unicon โดยคลิกที่ปุม หรือเลือกที่เมนู File > Upload รอจนกระทั่งการอัปโหลดเสร็จสิน้ บอรดจะทํางานทันที LED ที่ตําแหนง 31 ติดกะพริบทุกๆ 0.5 วินาที เปน อันเสร็จสินการทดสอบการเขี ้ ยนและอัปโหลดโปรแกรมเบื้องตนกับบอรด Unicon

 เนืองจากบอร ่ ด Unicon ใชไมโครคอนโทรลเลอร ATmega32U4 อันเปน USB ไมโครคอนโทรลเลอร ทําใหเมื่อเริ่มตนการทํางานใหมหรือเกิดการรีเซต โมดูล USB ภายในไมโครคอนโทรลเลอรตองใชเวลาในการ เตรียมความพรอมหรือที่เรียกวา การอีนัมเมอเรชั่น (enumeration) ประมาณ 3 ถึง 5 วินาที ซึงหากในจั ่ งหวะ นันเกิ ้ ดการอัปโหลดโปรแกรมมาทันที ตัวซอฟตแวร Arduino IDE จะไมสามารถติดตอหรือคนหาพอรตทีเชื ่ อม ่ ตอได ทําใหเกิดการอัปโหลดโปรแกรมที่ผิดพลาด อาจสงผลถึงกับทําใหบอรด Unicon ใชงานไมได

รูปที่ 2-2 หนาตางหลักของซอฟตแวร Unicon POP-XT Recover Utility1.0


Unicon  43

อยางไรก็ตาม ผูใชงานสามารถแกไขปญหานีได ้ โดยใชซอฟตแวร Unicon POP-XT Recover Utility อันเปนซอฟตแวรเสริมสําหรับชวยแกปญหากรณีไดรเวอรไมสมบูรณหรือไมสามารถติดตอกับบอรด Unicon (รวมถึงบอรควบคุมหุนยนต POP-XT) ได

2.7.1 ดาวนโหลดซอฟตแวร Unicon POP-XT Recover Utility ดาวนโหลดไดที่ www.uniconboard.com โดยไฟลติดตั้งมีชื่อวา UniconPOPXT_RecoverySetup.exe หรือเลือกจากโฟลเดอรในแผน DVD ที่จัดมาพรอมกับชุด Unicon cablepack หรือชุดทดลองอื่นๆ ของ Unicon ก็ได ดับเบิลคลิกเพื่อรันไฟลติดตั้ง จะพบหนาตางตอนรับการติดตั้งโปรแกรม คลิกปุม Next เพื่อตอบรับในแต ละขั้นตอนของการติดตั้งซอฟตแวร จนกระทั่งการติดตั้งเสร็จสินให ้ คลิกปุม Finish เพื่อจบขันตอนการติ ้ ดตั้ง 2.7.2 ขันตอนการแก ้ ไขปญหา (2.7.2.1) ไปที่ Start Menu เลือกเปดซอฟตแวร Unicon POP-XT Recovery จะพบหนาตางหลักของ โปรแกรม ดังรูป เลือกชองของชื่อฮารดแวรเปน Unicon board

(2.7.2.2) ตอสาย USB-miniB เขากับบอรด Unicon (2.7.2.3) กดสวิตช 31 คางไว เปดสวิตช POWER (2.7.2.4) จากนั้นปลอยสวิตช 31 รอใหบอรดเตรียมความพรอมในการทํางานประมาณ 5 วินาที


44 

Unicon

(2.7.2.5) เมื่อบอรด Unicon พรอม ซอฟตแวรจะแสดงตําแหนงพอรตทีตรวจพบบอร ่ ด Unicon ที่ชอง สีเขียวดานลางทางขวาของหนาตางหลัก ดังรูป พอรตทีพบคื ่ อ COM3

(2.7.2.5) คลิกปุม Master Clear สีแดงภายในเวลา 15 วินาที เพื่อลางความผิดปกติของการติดตอทั้ง หมด หากคลิกกดปุม Master Clear ไมทัน ใหกลับไปทําในขั้นตอนที่ (2.7.2.3) และ (2.7.2.4) (2.7.2.6) ที่ชองแสดงสถานะจะเปลี่ยนเปนสีสม พรอมกับแสดงขอความ avrdude : verifying... avrdude : 4266 bytes of flash verified. avrdude done. Thank you. OK.

เพื่อแจงใหทราบวา ไดทําการลางขอมูลของการเชื่อมตอเดิมเรียบรอยแลว


Unicon  45

(2.7.2.7) คลิกที่ปุม Test I/O สีเหลือง เพื่อทดสอบการทํางาน ที่ชองแสดงสถานะการทํางานซึงอยู ่ ตรง กลางของหนาตางโปรแกรมจะแสดงขอความเพื่อแจงใหทราบวา ไดอัปโหลดโปรแกรมสําหรับการทดสอบ พอรต 31 ของบอรด Unicon เรียบรอยแลว รอครูหนึง่ ตําแหนงพอรตของการเชื่อมตอจะเปลี่ยนตําแหนงใหม ซึงนั ่ บจากนีจะต ้ องใชพอรตในตําแหนงนีในการอั ้ ปโหลดโปรแกรมตอไป จากรูปเปลียนเป ่ น COM4 พรอมกัน นั้น LED ที่ขา 31 จะติดกะพริบดวยชวงเวลาสั้นๆ หากไดตามนี้ แสดงวา บอรด Unicon ไดรับการฟนฟูและ แกไขการติดตอพอรต USB เรียบรอยแลว


46 

Unicon

Unicon02-017046  
Read more
Read more
Similar to
Popular now
Just for you