Issuu on Google+

IES María de Molina

Ejercicios de Virtualdub 1.9.11

versión 2 1. ABRIR UN VIDEO •

Entra en la siguiente dirección de Internet: http://recursostic.educacion.es/bancoimagenes/web/

Busca “Tipos de operadores y sensores” y descarga el archivo en formato avi en tu carpeta.

Abre el programa Virtualdub y ve al menú File – Open video file... y en la ventana que sale busca el archivo “175507_avi_1.avi”. Se obtiene lo siguiente:

Observa que en la zona de edición de video aparecen dos ventanas. La de la izquierda muestra el archivo original y la de la derecha nos muestra las modificaciones y retoques efectuados en el video con el programa.

http://mariademolina.blogspot.com.es

Melchor Hermosilla

1


IES María de Molina

Ejercicios de Virtualdub 1.9.11

Podemos redimensionar las ventanas haciendo clic con el botón derecho y eligiendo el tamaño que deseemos.

Comprueba el funcionamiento de los botones de la barra de herramientas reproducción. La linea de tiempo me indica en el fotograma en el que estoy en cada momento. Se puede reproducir independientemente el video de entrada (input) y el modificado (output).

Para guardar los videos siempre hay que indicar al programa como los debe comprimir, si no se hace así ocuparán mucho espacio. •

Ve al menú Video – Compression y en la ventana que sale elige Xvid MPEG-4 Codec y

http://mariademolina.blogspot.com.es

Así mismo haz clic en el menu Audio – Full processing mode y después en Audio – Compression y en la ventana que sale elige MPEG Layer 3 y

Melchor Hermosilla

2


IES María de Molina

Ejercicios de Virtualdub 1.9.11

Para guardar el archivo hacemos clic en el menú File – Save as avi... y elegimos la carpeta de trabajo guárdando la película con el nombre ejercicio_1.avi

Prueba a reproducir con VLC player el archivo que hemos guardado.

2. EXTRAER EL AUDIO DE UN VIDEO •

Abre el programa Virtualdub. Carga en él el fichero “175507_avi_1.avi” haciendo clic en el menú File – Open video file...

Para guardar el audio iremos al menú File – Save WAV... y en la pantalla que sale indicamos donde queremos guardarlo.

Le llamaremos ejercicio_2.wav

Prueba a reproducir el archivo obtenido.

Como puedes ver el archivo es muy grande al estar en formato wav, si quisiéramos podríamos utilizar el programa Audacity para exportarlo a formatos como mp3 o ogg.

3. RECORTAMOS UN ARCHIVO DE VIDEO Vamos a sacar una 2 trozos del video, el primer trozo de video será la parte en que trata las resistencias y la segunda parte que extraerenos la que habla de los motores. •

Abre el programa Virtualdub. Carga otra vez el fichero “175507_avi_1.avi” haciendo clic en el menú File – Open video file...

Debemos colocarnos al comienzo del trozo que deseamos seleccionar; para ello podemos mover el cursor de la línea de tiempos o escribir directamente el fotograma (frame) en el que deseamos que empiece el video. En este caso será el fotograma 1700. Ahora presionamos en el icono de inicio de selección

Nos situamos a continuación al final del trozo que deseamos extraer en este caso en el fotograma 1890. Hacemos clic en el icono de final de selección

En este momento se queda marcado en color azul la parte del video que tenemos seleccionada.

Antes de guardarlo debemos primero indicar al programa el modo de compresión de video y audio como hicimos en el ejercicio 1. En el menú Video – Compression elegimos Xvid MPEG-4 Codec y en el menu Audio – Full processing mode y después Audio – Compression y en la ventana que sale elige MPEG Layer 3.

http://mariademolina.blogspot.com.es

Melchor Hermosilla

3


IES María de Molina

Ejercicios de Virtualdub 1.9.11

Para guardar el archivo hacemos clic en el menú File – Save as avi... guardamos en la carpeta de trabajo con el nombre ejercicio_3-resistencias.avi

Para eliminar la selección vamos al menú Edit – Clear Selection

Repite el proceso para seleccionar el trozo de video en el que se habla de los motores. guardalo comprimido con el nombre ejercicio_3-motores.avi

4. EXTRAER EL VIDEO SIN SONIDO •

Abre otra vez el fichero “175507_avi_1.avi” haciendo clic en el menú File – Open video file...

Comprimiremos el video como siempre: ve al menú Video – Compression y en la ventana que sale elige Xvid MPEG-4 Codec y

Haz clic en el menú Audio – No audio

Guárdalo como ejercicio_4.avi.

Reprodúcelo con el VLCplayer para comprobar el resultado.

5. INSERTAR UN ARCHIVO DE MÚSICA EN UN VIDEO •

Descarga los archivo de video y audio de la siguiente dirección: http://recursostic.educacion.es/bancoimagenes/web/. Busca el archivo de video “Turismo activo” y descárgalo. Baja también la música llamada “Canción house”, baja el archivo en formato mp3.

Abre en Virtualdub el archivo descargado que se llama “t29_01.avi”

Haz clic en el menú Audio – Audio from other file...

Elige el archivo “k00863.mp3” que es el archivo de sonido que hemos descargado.

En la pantalla que sale deja lo que está seleccionado, Autodetect , y pulsa OK.

Recuerda comprimir el video y el audio como hacemos habitualmente.

Guarda el resultado con el nombre de ejercicio_5.avi

Comprueba el resultado obtenido con un programa reproductor de video.

6. SINCRONIZACIÓN DE AUDIO Y VIDEO. En ocasiones el audio y el video no están sincronizados. Esto ocasiona que los sonidos que escuchamos no corresponden a las imágenes que estamos viendo. Con Virtualdub se pueden sincronizar fácilmente. Repetimos el proceso que hemos hecho en el ejercicio 5 (no hace falta repetirlo si lo tenemos todavía abierto). Al ver el video notamos que la música que hemos puesto tiene una introducción al comienzo diferente del resto de la pista. Esta introducción dura aproximadamente hasta el segundo 8. Lo que queremos hacer es conseguir que no se escuche esta introducción. http://mariademolina.blogspot.com.es Melchor Hermosilla 4 •


IES María de Molina

Hacemos clic en el el menú Audio Interleaving

En la ventana que sale debemos modificar el valor (en ms) en Delay audio track by: Pondré un valor positivo o negativo según quiera adelantar o retrasar el sonido.

En nuestro caso queremos que cuando empiece el video la música comience a oírse en su segundo 8 y por lo tanto escribimos en la casilla indicada -8000 y pulsamos OK.

Guarda el resultado comprimido y con el nombre de ejercicio_6.avi

Ejercicios de Virtualdub 1.9.11

7. PONER SUBTÍTULOS A UN VIDEO Utilizaremos, además del programa Virtualdub, el programa DivxLand Media Subtitle que es un programa freeware que se puede descargar de la página http://www.divxland.org/es/mediasubtitler/ Descargaremos el video que vamos a utilizar de la web del ministerio http://recursostic.educacion.es/bancoimagenes/web/. El video se llama “Uso del soldador de estaño en tecnología”

a) Creación de los subtítulos con DivxLand Media Subtitle •

Comenzaremos abriendo el programa Media Subtitler.

Abriremos el video en Archivo – Abrir archivo de video... Buscamos el archivo que se llama “175481_avi_1.avi”

Hacemos clic en el menú Archivo – Nuevo subtítulo y comenzamos a escribir los subtítulos que deseamos poner. Para ello hacemos clic en el menú Edición – Editar Subtítulo y escribimos el primer subtítulo que queramos poner. A continuación vamos haciendo clic en el menú Edición – Añadir subtítulo – Debajo del Actual. Y escribimos en cada pantalla que sale el texto que queremos que salga a la vez en cada subtítulo. •

http://mariademolina.blogspot.com.es

Debemos obtener al final lo siguiente:

Melchor Hermosilla

5


IES María de Molina

Ejercicios de Virtualdub 1.9.11

Ahora debemos aplicar los subtítulos al video. Para ello nos colocaremos en el texto 1 de los 10 subtítulos que hemos escrito.

Haremos clic en el botón reproducir del video

En este momento se irá reproduciendo el video y nosotros iremos colocando los subtítulos en la posición de tiempo que corresponda. Para ello haremos clic en el botón

Debo dejar presionado este botón el tiempo que quiera que permanezca el subtítulo en pantalla.

Al soltar el botón automáticamente se selecciona la siguiente línea de subtítulos para que yo pueda hacer clic de nuevo en el botón aplicar durante el tiempo adecuado y así sucesivamente,

Podemos comprobar si hemos colocado bien los subtítulos seleccionando la opción Vista previa.

Si no queda a nuestro gusto se puede repetir el proceso. •

Para modificar los colores de las letras vamos a Configuración – Opciones de formato y en la ventana que sale a SubStation Alpha aquí podemos cambiar el tipo de letra, el tamaño y si deseamos colocar una sombra para las letras. Elegimos Times New Roman, tamaño 26, color rojo y

sombra de 2 y color amarillo claro. •

Ahora debemos guardar los subtítulos para ello vamos a Archivo – Guardar como … y es muy importante que elijamos en el menú desplegable de arriba la opción de guardarlo como archivo de subtítulos SSA.

Hacemos clic en

Guardamos en la carpeta de trabajo con el nombre archivo de subtítulos.ssa y podemos cerrar el programa DivxLand Media Subtitle.

b) Colocación del archivo de subtítulos ssa al video en Virtualdub utilizando el filtro subtitler.vdf •

Abrimos el programa Virtualdub y cargamos con la opción File – Open video file... el video “175481_avi_1.avi”

Vamos al menú Video – Filters... Hacemos clic en el botón

http://mariademolina.blogspot.com.es

Melchor Hermosilla

6


IES María de Molina

Ejercicios de Virtualdub 1.9.11

Nos sale una pantalla con los filtros que el programa tiene cargado por defecto. Si el filtro subtitler.vdf no aparece en la lista debes cargarlo haciendo clic en el botón

Buscamos el filtro que tenemos en la carpeta de trabajo (se puede descargar de la página http://www.virtualdub.org/virtualdub_filters.html). El filtro se llama subtitler.vdf.

Una ved cargado aparecerá en la lista de filtros con lo que podemos seleccionarlo y hacer clic en botón OK

Nos sale una nueva ventana en la que haremos clic en el botón

Buscaremos en nuestra carpeta de trabajo donde hemos guardado los subtítulos que creamos con el Media Subtitler: archivo de subtítulos.ssa Hacemos clic en

También se puede presionar en el botón Show preview para ver una vista previa de como ha quedado el video con los subtítulos.

Si estamos de acuerdo como ha quedado cerramos la vista previa y hacemos clic en OK 2 veces.

Ahora comprimimos como habitualmente y guardamos el video con el nombre ejercicio_7.avi

8. RECORTAR MÁRGENES DE UN VIDEO Este filtro se utiliza para eliminar margenes no deseados en videos o seleccionar partes de la imagen. Por ejemplo se utiliza para eliminar las bandas negras que hay en determinadas películas. Nosotros lo que vamos a hacer es convertir un video de tamaño 632 x 480 para que sea cuadrado de 480 x 480. •

Abre en Virtualdub el archivo que utilizamos en el ejercicio 5 que se llama “t29_01.avi”

Vamos al menú Video – Filters... Hacemos clic en el botón

http://mariademolina.blogspot.com.es

Melchor Hermosilla

7


IES María de Molina

En la ventana que sale seleccionamos el filtro Null transform y hacemos clic en OK.

En las opciones de la ventana hacemos clic en el botón

Ejercicios de Virtualdub 1.9.11

A continuación aparece una ventana en la que podemos mover los margenes del video como nosotros queramos. En nuestro caso movemos hasta dejarla como ves en la imagen.

Hacemos clic en OK 2 veces.

Comprimimos el video y el audio como en los otros ejercicios y guardamos el video con el nombre ejercicio_8.avi

http://mariademolina.blogspot.com.es

Melchor Hermosilla

8


IES María de Molina

Ejercicios de Virtualdub 1.9.11

9. COLOCAR UN LOGOTIPO EN UN VIDEO En este ejercicio vamos a colocar un logotipo en un video. Podemos utilizar una imagen cualquiera para usarla como logo pero nosotros utilizaremos el programa Gimp para hacer el logo. •

Abre el programa Gimp y haz un documento nuevo de 40 x 40 píxeles. Dibuja lo que quieras y expórtalo como logo.png

Abre en Virtualdub de nuevo el archivo que utilizamos en el ejercicio 5 que se llama “t29_01.avi”

Vamos al menú Video – Filters... Hacemos clic en el botón

En la ventana que sale seleccionamos el filtro logo y hacemos clic en

Nos sale una nueva ventana en la que haremos clic en el botón

Buscaremos en nuestra carpeta de trabajo donde hemos guardado el logotipo que hemos hecho con Gimp y que se llama logo.png

Presionar en el botón Hide preview para ver una vista previa de como ha quedado el video con el logo. Podemos modificar la La separación del borde Y la opacidad en: colocación del logo con: modificando los valores de offset:

http://mariademolina.blogspot.com.es

Melchor Hermosilla

9


IES María de Molina

Ejercicios de Virtualdub 1.9.11

Cerramos la vista previa y hacemos clic en OK 2 veces.

Comprimimos como habitualmente y guardamos el video con el nombre ejercicio_9.avi

10. AUMENTAR O DISMINUIR EL VOLUMEN DEL SONIDO DE UN VIDEO •

Abre el programa Virtualdub y ve al menú File – Open video file... y en la ventana que sale busca el archivo “175507_avi_1.avi”, es el video sobre los operadores electrónicos.

Hay que ir al menú Audio – Full processing mode y después Audio – Volume

En la ventana que sale hay que marcar la casilla Adjust volume of audio channels y podemos mover el cursor para subir o bajar el volumen.

Subiremos el volumen aproximadamente al 272 %. Y hacemos clic en OK.

Comprimimos audio y video y guardamos el video con el nombre ejercicio_10.avi

11. UNIENDO VARIOS ARCHIVOS DE VIDEO En este ejercicio primero vamos a extraer 3 trozos del video sobre la expresión musical en los niños y después uniremos estos 3 trozos en un solo video, pero colocados en orden inverso, es decir, primero el tercero y último el primero. •

Busca en http://recursostic.educacion.es/bancoimagenes/web/ el video “Expresión musical en el aula” y descarga el archivo en formato avi en tu carpeta de trabajo.

Abre el programa Virtualdub. Carga en él el fichero “infantil_02_34.avi” haciendo clic en el menú File – Open video file...

Extrae los trozos siguientes como hicimos en el ejercicio 3: Del fotograma 800 al 1115 guárdalo como ejercicio_11-1.avi Del fotograma 1405 al 1960 guárdalo como ejercicio_11-2.avi Del fotograma 2200 al 2290 guárdalo como ejercicio_11-3.avi Recuerda comprimir audio y video antes de guardar.

Para unir los trozos lo que haremos es abrir el tercer trozo con File – Open video file...

A continuación añadir los otros 2 trozos con la opción File – Append AVI Segment..., pero teniendo cuidado de desmarcar la opción Autodetect aditional segment by filename para que no añada los otros trozos en orden de nombre.

Finalmente comprimimos y guardamos con File – Save as avi... como ejercicio_11.avi

http://mariademolina.blogspot.com.es

Melchor Hermosilla

10


Ejercicios Virtualdub