Page 1

MCE Starter KIT Student DEBUG V4.1

mc electronics

MANUAL DE USUARIO

MCE Starter KIT Student DEBUG v 4.1

1


INTRODUCCIÓN

mc electronics

La tarjeta MCE Starter KIT STUDENT es una placa de aplicaciones para entrenamiento de microcontroladores PIC, la cual sirve para los microcontroladores de Microchip PIC familias PIC18FXXX de 40 terminales. En esta tarjeta usted podrá trabajar con el ADC, el timer0 y Timer1, el PWM, los módulos CCP1 y CCP2 en modo comparación, el módulo SPI y la USART. La tarjeta es ideal para aprender a programar los microcontroladores PIC y viene equipada con diferentes periféricos que le permiten a usted practicar de forma completa en un sistema de desarrollo embebido. Los periféricos que hemos integrados consisten en Leds, los cuales puede excitar de forma directa, pulsadores, presets, un oscilador para RTC, una memoria microSD de 2GB, un MAX232, un LCD inteligente de 2 líneas por 16 caracteres y 2 displays de 7 segmentos cátodo común. Además se incorporó conexión USB a través de un PIC18F14K50 . En esta nueva versión incorpora un programador USB y un analizador lógico de 3 canales, que permite monitorear desde la PC el estado de los puertos en un intervalo determinado. No requiere hardware adicional para su funcionamiento.

MCE Starter KIT Student DEBUG v 4.1

2


CARACTERรSTICAS

mc electronics

Alimentaciรณn de entrada: 9 a 16V Corriente de consumo: 500 mA Frecuencia del cristal: 4Mhz (XT) Interfaz para programar con ICD2 o ICD3. 2 displays de 7 segmentos 1 diplay LCD 2x 16 con BackLight 2 Presets para el ADC 1 Sensor de temperatura TC1047 1 PORT RS232 3 Tactswitch 14 Leds 1 Header de 40 pines 3 Test Point para osciloscopio 1 Zรณcalo ZIF de 40 pines 4 Wire Jumpers 1 Relay de hasta 10 A. 1 XTAL de 32.768 KHz para RTC 1 LED RGB 1 Memoria microSD de 2 GB 1 Conexiรณn USB con PIC18F14K50 1 PIC18F4620-I/P

Informaciรณn actualizada on-line: www.mcelectronics.com.ar/stdv4

MCE Starter KIT Student DEBUG v 4.1

3


COMPONENTES

mc electronics

FURNTE DE ALIMENTACIÓN Requiere fuente externa de 9 a 16v. Consumo típico: 500 mA. Conector para fuente con positivo (+) al centro.

CONECTOR PARA DEBUGGER CON ICD3 Conector RJ-11 compatible con ICSP y debugger en tiempo real. Soporta ICD3 y Real ICE. No es necesario utilizarlo con la placa Student DEBUG que incorpora programador y debugger in circuit.

MCE Starter KIT Student DEBUG v 4.1

4


COMPONENTES

mc electronics

LEDs Para encender los LEDs cerrar el jumper (LEDS) y activar el PIN correspondiente el micro.

LED RGB El led RGB Kingbright de alto brillo está conectado a 5V como indica el diagrama. Los transistores 2N3904 aseguran rápida velocidad de conmutación para lograr una mayor cantidad de colores. Para encender un led colocar en “1” el pin correspondiente.

RD1 RD2 RD3

Rojo (R) Verde (G) Azul (B)

MCE Starter KIT Student DEBUG v 4.1

5


COMPONENTES

mc electronics

Memoria microSD La memoria está conectada al micro con las líneas indicadas en el diagrama. También se incluyen los filtros correspondientes.

LCD El LCD está manejado con 4 líneas. Se alimenta con 5V y se puede variar el contraste con el potenciómetro R33. Además, para ahorrar energía, es posible desconectar el backlight mediante del jumper (BCK).

MCE Starter KIT Student DEBUG v 4.1

6


mc electronics

COMPONENTES DISPLAYS 7 SEGMENTOS:

Son del tipo cátodo común, los segmentos están conectados al PORTB según la siguiente distribución:

Segmento A B C D E F G PUNTO

PORTB RB0 RB1 RB2 RB3 RB4 RB5 RB6 RB7

Para encender cualquier display debe poner JP1 en la posición 2-3, y poner en uno del PORTA el pin RA3. Además debe poner en uno del PORTA el pin RA0 para activar el display menos significativo, y el pin RA1 para activar el display mas significativo. El dato binario que permita encender los segmentos del Display debe colocarlo en el PORTB, poniendo en 1 el bit del segmento que quiera encender.

MCE Starter KIT Student DEBUG v 4.1

7


mc electronics

COMPONENTES Pulsadores

Están colocados en RA0, RA1 y RA2, son normales abiertos y sin pulsar introducen un cero. Cuando se pulsan, introducen un uno. Hay un pulsador denominado RESET, el cual resetea al PIC.

POTE y Sensor de temperatura: Este potenciómetro esta multiplexado con el sensor de temperatura TC1047 con que viene equipada la placa. Para seleccionar el POTE o el SENS. TEMP, modifique la posición del Jumper JP2: JP2: JP2:

1-2 Sens de Temp activado 2-3 POTE

El valor del Sensor o del Pote ingresa por el terminal RA5 (canal 4 del ADC). Para usar el sensor usted puede ajustar el valor de lo que el sensor va a mostrar en pantalla por medio del ajuste de la referencia para que no tenga que hacer ninguna conversión, para ello programe el conversor con referencia externa, coloque el Jumper JP1 en la posición 1-2 y ajuste el POTE EXT.REF. de forma tal que cuando tenga 10 mv, el display LCD indique 1°C. Si no usa el pote de referencia externa, puede usarlo como otro pote más para simular un parámetro analógico. El valor del mismo ingresa por RA3 (canal 3 del ADC).

MCE Starter KIT Student DEBUG v 4.1

8


COMPONENTES

mc electronics

USB En la figura se muestra la conexión entre el PIC18F4620 y el PIC18F14K50 para lograr la comunicación USB. Se maneja la comunicación del 18F4620 a través de la USART por medio de RC6 y RC7, el firmware que tiene cargado el 18F14K50 es quien toma los datos de la USART y los embebe en la trama USB. La comunicación puede ser bidireccional. Mediante el driver provisto en el CD se crea un COM Virtual en la PC.

MCE Starter KIT Student DEBUG v 4.1

9


LAYOUT

mc electronics

STARTER KIT STD DEBUG V4.1 200310

MCE Starter KIT Student DEBUG v 4.1

10


mc electronics

MODO PROGRAMADOR

El MCE Starter KIT DEBUG incorpora un programador USB capaz de programar el 18F4620I/P (incluido) como así también PIC12, PIC16, PIC18, PIC24, dsPIC y PIC32. Se pueden programar en el zócalo ZIF los micros de la familia PIC16 y PIC18 de 28 y 40 pines. En cualquier otro caso se requiere utilizar el conector “ICSP-OUT” ubicado en la parte superior derecha de la placa.

ICSP-OUT

mini USB (a la PC)

Área que ocupa el programador en la placa.

MCE Starter KIT Student DEBUG v 4.1

Conector para wire jumpers

11


MODO PROGRAMADOR

mc electronics

Comencemos programando el PIC18F4620-I/P. Para ello debemos instalar el software PICkit2Setup.msi incluido en el DVD. Una vez instalado en la carpeta por defecto, se debería ver la siguiente pantalla:

En este caso aparece la leyenda “pickit2 no encontrado”, vamos a conectar el MCE Starter KIT Student DEBUG a la PC a través del puerto USB para comenzar a trabajar.

MCE Starter KIT Student DEBUG v 4.1

12


mc electronics

MODO PROGRAMADOR

Antes de conectar el KIT a la PC debemos insertar el micro en el zócalo ZIF y configurar los wire jumpers como indica la figura. Alimentar la placa con 9V DC, positivo al centro.

Colocar el jumper en VPROG-STD para enviar la tensión de programación al STUDENT.

5.0v

mini USB (a la PC)

PIC 18F4620-I/P

Fuente de alimentación (9V - 500mA)

De ahora en mas consideremos que los pines pintados de un mismo color están unidos por un wire jumper. Es decir, conectamos (MCLR-VPP), (PGD-PGD) y (PGC-PGC)

Señales Starter KIT Student

MCLR PGD PGC NC

...... ..

VPP/NC PGD/CH1 PGC/CH2 AUX/CH3

Señales Programador

Conector para wire jumpers

MCE Starter KIT Student DEBUG v 4.1

13


MODO PROGRAMADOR

mc electronics

Ya estamos en condiciones de conectar el KIT a la PC a través del puerto USB. Abrimos nuevamente el programa “PICkit2 v2.61” (Programas->Microchip-> PICkit2 v2.61)

Vemos que ya reconoció el PIC. Estamos listos para trabajar. Si necesita información sobre como utilizar la aplicación “PICkit 2 Programmer” de Microchip, por favor consulte el manual PICkit 2 User Guide DS51553E incluido en el DVD.

MCE Starter KIT Student DEBUG v 4.1

14


MODO PROGRAMADOR

mc electronics

Para cargar un nuevo programa en el PIC, debemos seleccionar File->Import HEX

Luego hacemos click en “Write” y debe aparecer la leyenda “Programación exitosa” una vez concluida la verificación.

Es posible cambiar el seteo de los registros CONFIG sin necesidad de recompilar el proyecto, haciendo click en “Configuration”. El procedimiento de conexión y programación es idéntico para el PIC18LF4620.

MCE Starter KIT Student DEBUG v 4.1

15


mc electronics

MODO PROGRAMADOR EXTERNO

Se puede utilizar el programador incluido en el PCB del Starter KIT Student DEBUG para programar micros que no sean compatibles con el pinout del zócalo ZIF, por ejemplo dsPIC y PIC24. Para ello necesitamos conectar la placa de proyecto que tiene el micro en cuestión al header de programación “ICSP-OUT” En este caso vamos a programar el PIC18F97J60 SMD de 100 pines que utiliza el MCE WeServer. 3.3v Retirar el PIC del zócalo ZIF y desconectar todos los wire jumpers.

Colocar el jumper en VPROGICSP para enviar la tensión de programación a la placa de proyecto.

MCE Starter KIT Student DEBUG v 4.1

... ...

MCLR VDD VSS PGD PGC AUX

mini USB (a la PC)

Señales Programador

ICSP-OUT

16


mc electronics

MODO DEBUGGER

La placa cuenta con debugger incorporado. Para poder utilizarlo debemos conectar los wire jumpers de la siguiente manera:

Colocar el jumper en VPROG-STD para enviar la tensión de programación al STUDENT.

5.0v

mini USB (a la PC)

PIC 18F4620-I/P

Fuente de alimentación (9V - 500mA)

Señales Starter KIT Student

MCLR PGD PGC NC

...... ..

VPP/NC PGD/CH1 PGC/CH2 AUX/CH3

Señales Programador

Conector para wire jumpers

MCE Starter KIT Student DEBUG v 4.1

17


MODO DEBUGGER

mc electronics

Vamos a configurar el debugger express utilizando el entorno del MPLAB. Esta utilidad nos será de gran ayuda para depurar nuestro código tanto a nivel software como hardware. Realizaremos un pequeño ejemplo utilizando el PIC18F4620.

En el Entorno del MPLAB seleccionamos el dispositivo con el cual trabajaremos: Configure -> Select Device… En el cuadro de dialogo debemos observar cuales son las herramientas que permiten depurar este dispositivo, en este caso nos interesara que el PICkit2 lo soporte (un icono de color verde nos indica que podemos depurarlo con esta herramienta).

MCE Starter KIT Student DEBUG v 4.1

18


mc electronics

MODO DEBUGGER

Abrimos una de las practicas para el PIC 18F4620 que viene incluida en el DVD del MCE Starter KIT Student. Recomendamos la práctica “Sensor térmico” para monitorear una variable analógica.”

Comenzamos la depuración cambiando la configuración del proyecto del modo “Release” al modo “Debug”.

Compilamos el proyecto seleccionando Project -> Build All. Seleccionamos el PICkit2 como herramienta de depuración : Debugger -> Select Tool -> PICkit 2. Se agregaran los siguientes iconos en la barra de herramientas que nos permitirán obtener un rápido acceso a las funciones utilizadas en modo debugger: Run - Halt - Animate - Step Into - Step Over - Step Out - Reset

MCE Starter KIT Student DEBUG v 4.1

19


MODO DEBUGGER

mc electronics

Podremos ejecutar el código en tiempo real con “Run” o línea por línea con “Step into”, “Step over”, “Step Out “o “Animate”. Podemos también parar la ejecución del programa con “Halt” o a través de los Breakpoints. Para cargar el programa en el dispositivo seleccionamos Debugger -> Program

Nota: Antes de cargar el programa en la placa de proyecto se debe realizar la siguiente modificación al bit de configuración del MCLRE: en lugar de tener _MCLRE_OFF colocar _MCLRE_ON ya que el programador del Student DEBUG utiliza este pin para la depuración. Ahora estamos en condiciones de correr el programa presionando el botón Run. Podrá ver que al modificar el potenciómetro EXT. REF. el display de led’s cambia de velocidad. Los Led’s conectados a RB6 y RB7 serán desactivados como I/O digitales, ya que estos pines son necesarios para la depuración. Paramos la ejecución del programa oprimiendo en Halt y reseteamos el micro con Reset.

MCE Starter KIT Student DEBUG v 4.1

20


MODO DEBUGGER

mc electronics

Con las Función Step podemos ejecutar el código línea por línea.

Breakpoints La cantidad de breakpoints (puntos donde se detiene la ejecución del programa) depende del dispositivo seleccionado, en la mayoría de los PIC de rango medio se permite un sólo breakpoint.

MCE Starter KIT Student DEBUG v 4.1

21


MODO DEBUGGER

mc electronics

El numero de breakpoints disponibles lo podemos ver en el cuadro de dialogo seleccionando: Debugger -> Breakpoints ‌

Para ver la utilidad de los breakpoints vamos a colocar uno al finalizar la conversiĂłn del A/D.

MCE Starter KIT Student DEBUG v 4.1

22


MODO DEBUGGER

mc electronics

Al correr el programa con Run, se ejecutará el código hasta encontrar el breakpoint, que en este caso, se encuentra al finalizar la conversión. A través de una ventana “Watch” podemos observar la variación de un registro. Por ejemplo, si queremos ver el resultado de la conversión, abrimos una nueva ventana Watch en View -> Watch.

Seleccione ADRESH y agréguelo en la ventana. Luego corra el programa, este se detendrá al finalizar la conversión actualizando el valor del ADRESH en el Watch. Ahora gire el potenciómetro EXT. REF. de la placa MCE Starter KIT Student y corra el programa, sin quitar el breakpoint.

Al detenerse la ejecución del código, el valor del ADRESH se actualizara al nuevo valor del potenciómetro. MCE Starter KIT Student DEBUG v 4.1

23


MODO DEBUGGER

mc electronics

Si necesita modificar el c贸digo fuente, no olvide compilar el proyecto de nuevo y cargarlo al micro seleccionando Debugger -> Program. Al finalizar la depuraci贸n exitosamente ya puede grabar el micro, para ello salga del modo Debug con Debugger -> None y seleccione el programador para cargar el c贸digo con Programmer -> Program.

MCE Starter KIT Student DEBUG v 4.1

24


mc electronics

MODO ANALIZADOR LÓGICO

Se pueden utilizar las señales del programador como 3 canales de entrada para el analizador lógico. En este ejemplo vamos a utilizar el analizador para monitorear la salida por PWM que controla la intensidad del LED conectado a RC2.

5.0v

mini USB (a la PC)

PIC 18F4620-I/P

Fuente de alimentación (9V - 500mA)

Considerar que tenemos 3 canales (CH1-CH2CH3) que se pueden conectar a cualquiera de los 40 pines del micro ubicados en el header principal.

MCLR PGD PGC NC

...... ..

VPP/NC PGD/CH1 PGC/CH2 AUX/CH3

Señales Programador

Conector para wire jumpers

MCE Starter KIT Student DEBUG v 4.1

25


mc electronics

MODO ANALIZADOR LÓGICO

Para monitorear el PWM conectar los Wire Jumper como indica el diagrama: 5.0v

mini USB (a la PC)

PIC 18F4620-I/P

Fuente de alimentación (9V - 500mA)

Header principal Conectado al PIC

MCLR RA0 RA1 RA2 RA3 RA4 RA5 RE0 RE1 RE2 VDD VSS RA7 RA6 RC0 RC1 RC2 RC2 RD0 RD1

...... ...... ...... ...... ...... ...... ....

MCE Starter KIT Student DEBUG v 4.1

RB7 RB6 RB5 RB4 RB3 RB2 RB1 RB0 VDD VSS RD7 RD6 RD5 RD4 RC7 RC6 RC5 RC4 RD3 RD2

MCLR PGD PGC NC

...... ..

VPP/NC PGD/CH1 PGC/CH2 AUX/CH3

Entradas Programador

Conector para wire jumpers

Se conectó el CH1 a VDD (esta va a ser la señal de Trigger), el CH2 a la señal que queremos medir, en este caso RC2 (PWM) y el CH3, para no dejarlo al aire lo conectamos a GND

26


MODO ANALIZADOR LÓGICO

mc electronics

Para ejecutar la funcionalidad de Analizador Lógico, vamos a Tools -> Logic Tool -> Analyzer dentro de la misma aplicación que utilizamos para programar.

Esta es la ventana principal del Analizador Lógico. Se puede seleccionar una fuente de Trigger para cada canal. En este caso seleccionamos que se dispare cuando CH1 = 1 (VDD). La frecuencia de muestreo podemos dejarla en 1 MHz para visualizar correctamente la forma de la señal. En el Starter KIT Student ir a: PWM desde el menú principal. Una vez completados todos los pasos estamos listos para capturar la señal.

MCE Starter KIT Student DEBUG v 4.1

27


MODO ANALIZADOR LÓGICO

mc electronics

Dentro de la aplicación de captura, hacemos clic en RUN.

Se aprecia el CH1 en 1, el CH3 en 0 y el CH2 muestra la señal de PWM que esta controlando el brillo del LED. Si variamos la intensidad del brillo, presionado sucesivamente RA1 vemos como aumenta el ancho efectivo del pulso.

MCE Starter KIT Student DEBUG v 4.1

28


MODO ANALIZADOR LÓGICO

mc electronics

La aplicación nos da la posibilidad de medir el ancho de pulso mediante cursores:

También es posible exportar la imagen a un archivo bmp, haciendo clic en SAVE. Para más información sobre las funciones del analizador lógico consulte LOGIC TOOL USER GUIDE incluido en el DVD.

MCE Starter KIT Student DEBUG v 4.1

29


mc electronics



Impreso en papel reciclado. Buenos Aires - Argentina Mayo 2010 MCE Starter KIT STUDENT v4.10 Manual REV: 040710

Victoria Ocampo 360 - Piso 3 Ciudad de Buenos Aires (1107). BA. Argentina. (011) 4515-6446 www.mcelectronics.com.ar info@mcelectronics.com.ar

Impreso MCE040710

MCE Starter KIT Student DEBUG v 4.1

30

MCE Starter KIT Student DEBUG  

Manual de usuario de la placa MCE Starter KIT Student DEBUG v4.1. Ahora con LED RGB, conexión USB y memoria microSD de 2 GB !

Advertisement