Page 1


Contents

Requirements and description Help and support Using Painting and Classic Frames PSD templates Open template in Photoshop Duplicate template Change size and resolution Place image Convert image layer to Smart Object Preview and automation Generate and export with Data Set Batch rename files in Adobe Bridge Copy and Paste template and text file Open and resize template Load Data Set Preview images Resize image placeholder Export data sets See your files Batch convert to another format Previewing one image with different frames Prepare image to preview Open template in Photoshop Define second variable Load Data Set Set encoding to Unicode (UTF-8) Preview frames as overlay Move JPG image Impress your customer Customization tips Use Variable with other file formats Expand number of files for data sets

For more freebies and Premium content and extensions visit our Marketplace

3 3 4 4 4 4 4 4 5 5 5 5 5 5 5 6 6 6 6 7 7 7 7 7 7 7 8 8 9 9 9


Requirements and description There isn’t any special requirements for Painting and Classic Frames beside any software that supports PNG or/and PSD format. There are some advantages to use PSD files with software which supports PSD and layered images. Examples are Adobe Photoshop, Photoshop Elements, GIMP. Most options and advantages comes when using Painting and Classic Frames with Adobe Photoshop because you can preview any image with multiple frames or export up to 99 different images with the same frame applied. Number of 99 images can be expanded easily. Best of all you do not have to worry about image size, resolution, color mode, orientation because Photoshop will take care of all in background and everything will work perfect. You can use Painting and Classic Frames collection to decorate images for print and web or to enhance any existing composition. There are total of 15 frames from which 4 frames are 10x8in landscape orientation, 4 frames are 5x7in portrait and 7 frames are 8x8in square. All templates have 300dpi resolution which can be changed at any time to suite your needs. Also frames can be downsampled (downsample means make it smaller) to any size you need for your project.

How files are organized

After downloading Painting and Classic Frames you will need to unzip package. All files are inside Painting and Classic Frames folder. There are total of 3 following sub-folders: 1. Horizontal orientation which contains 10 frames in horizontal or landscape orientation and text files with Variables and Data Sets. Subfolder PNG frames contains 10 frames with landscape or horizontal orientation in PNG file format. 2. Vertical orientation which contains 10 frames in vertical or portrait orientation and text files with Variables and Data Sets. Subfolder PNG frames contains 10 frames with landscape or horizontal orientation in PNG file format. 3. Help where is located user guide.

Help and support

One of things I am insisting is help and support for all my files. I am always willing to give additional info and help for any of my files regardless of time and date published, keep that in mind. I know that most people just do not believe in phrase Help and Support because most of developers and publishers on internet are giving emails just for fun or to complete their offer. I am always replying to emails with help requests within 24 hours, actually immediately after I see email in my inbox. Feel free to ask me any question, to send me feedback or feature, customization request.

For more freebies and Premium content and extensions visit our Marketplace


Using Painting and Classic Frames PSD templates In the following tutorial I will explain you how to use PSD templates in Adobe Photoshop. First of all you can change template pixel dimensions and resolution before you place images. After setting document size and resolution you can place images in traditional way using File > Place command, by converting image layer to Smart Object to replace content using command with the same name or to export multiple images with Data Sets provided. You can also preview an image with all available frames and decide which frame works best for that particular image.

Open template in Photoshop

Fisrst step is to run Adobe Bridge and navigate to folder with templates you want to use., for example Painting and Classic > Horizontal orientation. You will see preview of all available templates in that folder. Double click on any template to open it in Adobe Photoshop. Alternatively if you have multiple versions installed, right click on template and choose Open With > Adobe Photoshop (version).

Duplicate template

I suggest you to always duplicate template before using it to keep original intact. With template open in Photoshop go to Image > Duplicate then close original template file.

Change size and resolution

To place image in Photoshop go to File > Place

After opening template in Photoshop first resize it and change resolution for final output from Image > Image Size.

Place image

You can place any image from your hard drive using File > Place command. Click on layer image in Layers panel then go to File > Place. Chosen image will be placed above currently selected image layer which you can delete after placing an image when using this method.

Convert image layer to Smart Object

Another way to place image is to convert image layer to Smart Object. Click on image layer in Layers panel to select then right click and choose Convert to Smart Object. Next step is to right click on created Smart Object layer and to choose Replace Contents command. When Place dialog opens, navigate to image on your hard drive, select it then click Place button at the bottom of Place dialog.

To convert image layer to Smart Object, right click on it and select Convert to Smart Object

For more freebies and Premium content and extensions visit our Marketplace


Preview and automation Generate and export with Data Set

As previosly mentioned you can proccess unlimited number of files with any of available frames as overlay on top of your images. All you need to do is to choose which images to use and to rename them. To batch rename files use Adobe Bridge.

Batch rename files in Adobe Bridge

Start Adobe Bridge and find folder with images you want to use in JPG file format. By the way JPG is not limitation for variables but it is with files provided to you without customization. Select all images you want to use (99 at most) then go to Tools > Batch Rename. In Batch Rename dialog select Copy to other folder option then click browse button below, navigate to any Batch rename files in Adobe Bridge folder or create new one. In New Filenames section choose Text from first drop-down list. Type image_ (image + underscore) in the text field on the right side. From second drop-down list below choose Sequence Number. Type number 1 in the second text field then choose Four Digits from right drop-down list. Click Rename button at the top right corner of Batch Rename dialog. All selected files will be renamed to image_0001.jpg, image_0002.jpg, image_0003.jpg... and copied to previously chosen or created folder.

Copy and Paste template and text file

Now when you have images properly named go to folder with PSD template you want to use. Copy template and Variable_ painting_frames_images.txt then paste them in the same folder with images previously renamed to image_0001.jpg, image_0002.jpg...

Open and resize template

Steps to load data set: 1. Click Import button 2. Click Select Files button and navigate to Variable_painting_frames_images.txt

It is time now to open PSD template in Photoshop. If you want to change pixel dimensions and resolution do it now from Image > Image Size dialog.

Load Data Set

With template resized go to Image > Variables > Data Sets. In Variables dialog click on Import button to open Import Data Set dialog. In Import Data Set dialog click on Select File button and navigate to folder with images, template and text file. Select Variable_painting_frames_images.txt then click Load button in dialog with the same name. Last step to import data set is to set encoding to Unicode (UTF-8) from encoding drop-down menu. That’s it, click OK button to confirm.

Preview images

Steps to load data set: 3. Click Import button 4. Click Select Files button and navigate to Variable_painting_frames_images.txt

Immediately after closing Import Data Set dialog you will see first (image_0001.jpg) on your screen inside frame. If you do not see image that’s because Preview option on the right side of Variables dialog is not checked. Click inside square in front of this option to appear checkmark and to enable it. Now you can see and other images inside frame and how composition will look like when exported. Click on right triangle in Data Set section to load next set or image. Continue clicking untill you list all images. With larger images you may need to wait a second untill image appear inside frame. When you reach the end or last image Photoshop will display error message. Close message and click on left triangle to go backward previewing. With some frames important image details will be covered, to fix this click Close button and read next step. Click OK button in top right corner of Variables dialog to confirm imported data sets and exit Preview data sets or different images dialog so you can export all images as PSD files with frame.

For more freebies and Premium content and extensions visit our Marketplace


Resize image placeholder

While previewing images you may realize that frame hides some important image details you want to see. It is very easy to fix. While previewing images instead of OK button to confirm click Close to exit dialog. Select image layer in Layers panel and resize it so image layer bounds are closer to frame inside bounds. After selecting image layer press Ctrl/Cmd + T. Resize layer then confirm on checkmark in options bar or by pressing Enter/Return. With image layer resized return to previous 2 steps: Load Data Set and Preview images and repeat it.

Export data sets

Last step is to export all images you have in the same folder with template as separate PSD files with frame as overlay. Go to File > Export > Data Sets as Files... In Export Data Sets as Files dialog click on Select Folder button then navigate to folder where you want to export images with frame. Leave other settings to defaults, at least this one: Data Sets: All Data Sets. Click OK and wait a second. When Photoshop exports all available images you will see warning: Could not export data�Data Set xx�... Click No button. You will return to Photoshop window and all images which was in folder with template will be exported in folder chosen in Export Data Sets as Files dialog.

Transform (resize) image layer. Click on layer image then press Ctrl/ Cmd + T to enter free transform mode.

See your files

Now you can go in folder with exported PSD files and check how job is done. Open files and check them. By the way you can click on image layer and move image to the left/right or up/ Export Data Sets as Files dialog done to change its position inside frame.

Batch convert to another format

You may want your images with frame to convert to some other format. To do quickly go to File > Scripts > Image Proccessor.

After files are exported reopen them in Photoshop and adjust image position if needed.

For more freebies and Premium content and extensions visit our Marketplace


Previewing one image with different frames One of advantages to use PSD templates in Adobe Photoshop is to preview any image you want to proccess with multiple frames as overlay. You can decide in this way which frame is best to use with that particular image. We will work with horizontal or landscape frames in this tutorial.

Prepare image to preview

First you need to prepare image you want to use and to place it in folder with PNG frames. Image must be in JPG format with variables provided but you can change extension very easy and use any other supported file format what will be explained later. Rename image you want to use to image_0001.jpg then copy and paste it in folder PNG horizontal frames. Go back Image you want to preview, PNG frames and Variables_horizontal_ one folder up because you will open PSD template. This is frames_preview.txt must be in the same folder. important step because PNG frames, image and Variables_ horizontal_frames_preview.txt must be in same folder.

Open template in Photoshop

Next step is to open any PSD template in Photoshop. Duplicate template then resize and change resolution if needed from Image > Image Size.

Define second variable

Go to Image > Variables > Define. Click on triangle on the right side of Layer drop-down list to see frame displayed in text box in the middle. Click on Pixel Replacement to appear checkmark and do not change anything else.

Load Data Set

Define second variable When you see checkmark in front of Pixel Replacement and PixelVariable2 in Name: textbox, click on Next on the right side of Variables dialog. Next step is to click on Import button to open Import Data Set dialog. Click on Select File button then navigate to text file under Painting and Classic Frames > Horizontal orientation > PNG horizontal frames > Variables_ horizontal_frames_preview.txt, select text file then click Load button.

Set encoding to Unicode (UTF-8)

Data Set will be loaded, from Encoding drop-down list choose Unicode (UTF-8). Click OK button to confirm and exit Import Data Set dialog.

Preview frames as overlay

Now you can preview all frames as overlay over previously pasted image_0001.jpg in folder with PNG frames. Click on triangle on the right side of Data Set drop down list to list data sets. Each time you click triangle and see next data set (for example Data Set 2) wait a second to see frame as overlay over image, then click again on triangle to list next data set. Remember which one you like most. Data Set number correspond to template number, so if you like Data Set 3 remember that and close variables dialog and file. If some frames are covering too much of image then click Cancel button, resize image layer as explained in Resize image placeholder step in previous section and repeat steps from Define second variable. Although you can use same file to generate PSD with image and PNG frame you like, I wont recommend you that because PNG format is designed mainly

Preview data sets (frames) as overlay to decide which one you like best.

For more freebies and Premium content and extensions visit our Marketplace


for web what may not be your indent, perhaps you want to print image. For prints always use PSD templates instead PNG frames, at list I will recommend you that.

Move JPG image

When you are done previwing go in PNG horizontal frames folder and move image_0001.jpg in folder up with PSD templates. Now you can use instructions to generate and export PSD using data sets or simply place image from File > Place in template as explained at the beginning of tutorial.

Impress your customer

This advanced technic you can use to find best template for your images but also to impress customer and allow him to choose template for his/her image by previewing quickly how it will looks like with different frames.

For more freebies and Premium content and extensions visit our Marketplace


Customization tips Use Variable with other file formats

If you want to use variable and data sets with other file formats then JPG, here is how to change Variable_painting_frames_images.txt text file which contains informations about images and their file format. I will strongly suggest you to make copy of provided text file before you open it in any text editor. I am using Notepad++. When you open text file in text editor you will see only one column with data. Your is to change only file extension and thats pretty easy to do. Just find command Replace or Find/Change in your editor. Type in Find field jpg and in replace format you plan to use, for example tiff. Click Replace All then save and close file. Note: regardless of file format you are going to use, images must be always named with image_0001.ext, image_0002.ext... where ext is your custom file format. Customize data sets simply by changing extension in text editor.

Expand number of files for data sets

Although it is very easy to guess how to expand number of files or images you can use for batch proccessing, let me write and that. All you need to do is to continue row after image_0099.jpg with image_0100.jpg, image_0101.jpg... If you have any problem just send me purchase number and your request to expand data set.

For more freebies and Premium content and extensions visit our Marketplace

Painting and Classic Frames  

User Guide, Catalogue and download link for Painting and Classic Frames. Free set with 20 PSD + 20 PNG with transparent background frames.

Read more
Read more
Similar to
Popular now
Just for you