Page 1

FFuunnddaam meennttooss ddeell eennttoorrnnoo ddee CC\\CC++++ V Veerr.. 33..00 Todos los sistemas C\C++ consisten en tres partes: •

El entorno

El lenguaje

La biblioteca estándar

Los programas en C\C++ consisten en módulos o piezas que se denominan FUNCIONES. Usted puede programar todas las funciones que necesite para formar un programa, pero también se puede utilizar una serie de funciones recopiladas, existentes, que se conocen como: BIBLIOTECA ESTÁNDAR.

Fases más frecuentes para la ejecución de un programa en C Fase 1

Fase 2

Fase 3

Fase 4

Editor

Disco

El programa es creado en el editor y almacenado en disco.

Procesador

Disco

El programa procesador procesa el código.

Compilador

Disco

Enlazador

Disco

Fase 5

Cargador

Memoria Primaria

Fase 6

UCP

Memoria Primaria

El compilador crea el código objeto y lo almacena en disco.

El enlazador vincula el código objeto con las bibliotecas creando el .EXE y guardándolo en disco.

El cargador coloca el programa en memoria.

La UCP toma cada una de las instrucciones y las ejecuta, almacenando posiblemente nuevos valores de datos conforme se ejecuta el programa.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 1–


Los programas C\C++ case siempre pasan a través de seis fases para su ejecución. Estas son: • • • • • •

Editar Procesar Compilar Enlazar Cargar Ejecutar

La primera fase consiste en editar un archivo en un editor, el programador escribe un programa C utilizando un editor. Este programa se almacena en un dispositivo de almacenamiento secundario, como por ejemplo un disco duro. Los nombre de los archivos de programas en C se denominan con la extensión .C. En nuestro caso en la versión Borland, el editor esta incorporado en el entorno de programación. A continuación se compila el programa escrito en el editor y guardado en disco. El compilador traduce el programa a código de máquina (también se conoce como código objeto). Luego el enlace, por lo general los programas de C contienen referencias a funciones definidas en algún otro lugar como en bibliotecas estándar o en bibliotecas de un grupo de programadores que trabajen en un proyecto en particular. Entonces, el código objeto producido por el compilador tendrá “huecos” debido a estas partes faltantes. Un enlazador vinculará el código objeto con el código de las funciones faltantes para producir una imagen ejecutable, sin ninguna faltante. La quinta cargar, antes de que un programa pueda ser ejecutado, el mismo debe ser colocado en memoria, esto se lleva a cabo mediante el cargador, que toma la imagen ejecutable del disco y la transfiere a la memoria. La fase quinta y cesta fase se llevan a cabo casi simuladamente, para cargar y ejecutar un programa solo hay que escribir el nombre del programa .EXE en Inicio ejecutar o dar doble clic sobre el nombre del archivo.

PUESTA EN MARCHA DEL LENGUAJE Se inicia Turbo C/C++ con la siguiente orden: Tc <enter> en Inicio ejecutar, o doble clic en el icono del archivo Tc.EXE que se encuentra en la carpeta BIN o acceso directo del mismo archivo. Las carpetas incluidas en el paquete son:

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 2–


El entorno C se inicializará, una vez dentro del ambiente, podremos ver la siguiente pantalla:

APERTURA DE MENÚS DESPLEGABLES La barra del menú de la que cuelgan los menús desplegables de Turbo C/C++, está localizada a lo largo de la línea superior de la pantalla. La línea inferior de la pantalla muestra una breve información de ayuda que indica la forma de hacer cosas tales como abrir o grabar un archivo, compilar un programa o llamar al sistema de ayuda en pantalla de Turbo C/C++. Existen tres formas de abrir un menú: *

Si está utilizando un ratón, se puede hace clic en la palabra apropiada de la barra de menús. Por ejemplo, se puede seleccionar File para abrir el menú File.

*

Pulsar y mantener oprimida la tecla ALT y pulsar la letra iluminada (intensificada) del nombre del menú, por ejemplo, F del menú File, E del menú Edit.

*

Pulsar la tecla F10, utilizar las teclas de movimientos del cursor para iluminar el nombre del menú deseado, y a continuación pulsar enter.

Muchas de las opciones de menús tienen asociadas secuencias rápidas de teclas para ahorrar tiempo de operación. Así, como para cerrar una ventana, basta con pulsar Alt+F3 y para grabar un archivo basta con pulsar F2 en lugar de abrir el menú File y seleccionar Save. Las teclas rápidas se muestran en los menús, localizadas a la derecha de la opción del menú que ellas activan. REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 3–


ENTORNO INTEGRADO DE DESARROLLO Cuando se arranca Turbo C/C++ se visualiza el escritorio Turbo C/C++ en la pantalla. En la línea superior está la barra del menú y la línea inferior contiene información sobre operaciones que se pueden ejecutar con diferentes combinaciones de teclas así como información significativa de ayuda para la ventana actual. Se puede activar la barra de menús y abrir menús en las formas descritas anteriormente. PARTES PRINCIPALES DEL ENTORNO INTEGRADO DE DESARROLLO (EID) El EID tiene cuatro componentes principales: *

barra de menús

*

escritorio

*

área de estado

*

pantalla de salida

*

además

-

ventanas (windows) cuadros de diálogo (diálogo box)

BARRA DE MENÚS Es el área de la parte superior de la pantalla que contiene una lista de menús. Los cuales se activan mediante los métodos explicado anteriormente. La tecla Esc se utiliza para cancelar una orden, se retorna al menú anterior REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 4–


y se cancela cualquier selección de un submenú. sucesivamente se pueden retornar acciones sucesivas.

Pulsando

Esc

Algunas órdenes de submenús tienen una flecha al final de su entrada; en ese caso, cuando se selecciona la orden se visualiza otro submenú. De igual modo si una orden de un menú tiene al final unos puntos suspensivos (...) cuando se ejecute esa orden se visualizará un cuadro de diálogo que puede proporcionar información bien rellenando campos o pulsando botones. ESCRITORIO El escritorio es el área o zona de la pantalla situada en el centro de la pantalla. En esta área se pueden situar una o más ventanas. El escritorio puede contener diferentes ventanas. Se pueden especificar el tamaño y posición de las ventanas y se puede alterar la disposición del escritorio en cualquier momento. Por ejemplo, puede ser útil tener diferentes ventanas de edición abiertas a la vez para facilitar la escritura de una sección de un programa mientras se examina el impacto en otra sección. ÁREA DE ESTADO Es el área que se encuentra en la parte inferior de la pantalla, y sirve como fuente de ayuda al usuario. A medida que se selecciona una orden, el área de estado proporciona una descripción de lo que realiza la orden; se puede prever la acción de una orden antes de que se seleccione. El área de estado informa también de las actividades actuales del programa. PANTALLA DE SALIDA Esta pantalla muestra la salida producida cuando se ejecuta un programa. Para ver la pantalla de usuario, pulse la combinación de teclas ALT+F5. El retorno a la pantalla principal se consigue pulsando de nuevo la misma combinación de teclas. VENTANAS Las ventanas son áreas de la pantalla que se pueden mover, cambiar de tamaño, solapar, abrir y cerrar. Éstas se encuentran en el escritorio de Turbo C/C++. Cuando se está en una determinada ventana, ésta se denomina la ventana activa y cualquier orden o texto que se introduzca se dirige directamente a esa ventana activa. Partes de una ventana La ventana tiene un borde, el cuadro o estructura; en el centro de ella existe una barra de títulos que identifica la ventana (por ejemplo NONAME00.PAS). En la esquina superior derecha del cuadro de la ventana existe un número que identifica el número de la ventana. Las ventanas se numeran sucesivamente en el orden en que se abren. REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 5–


CUADROS DE DIÁLOGO Un cuadro de diálogo proporciona un medio adecuado para visualizar y establecer opciones múltiples de órdenes. Un cuadro típico solicita al programador información. Se puede proporcionar la información en cualquier orden y cambiar los datos tantas veces se desee. Si está utilizando un ratón, posicione el cursor del ratón sobre el control que desea utilizar y pulse el botón izquierdo para seleccionar. Si no esta utilizando un ratón, pulse repetidamente la tecla tabulador (es la que tiene dos flechas, una hacia la izquierda y otra hacia la derecha, se encuentra comúnmente a la izquierda superior de su teclado) o SHIFT ( es la tecla que tiene una flecha hacia arriba y que su dibujo es más grueso, se encuentra a la derecha y a la izquierda de su teclado sobre la tecla control) tabulador para moverse al control deseado, luego pulse el enter para seleccionarlo. Cada cuadro de diálogo tiene tres botones de acción estándar: Cancel OK Help -

-

cierra el cuadro de diálogo e ignora toda su configuración actual. se guarda la configuración actual. abre una ventana de ayuda temporal con información correspondiente al cuadro de diálogo activo.

Existen otros cuadros de diálogo que solo utilizaran las respuestas Yes, No, o Cancel, la contestación dependerá de lo que el usuario desee.

EL EDITOR DE TURBO C/C++ El editor de Turbo C/C++ se invoca cuando se abre una ventana de edición. Permite crear nuevos programas o cambiar los existentes, utilizar órdenes especiales para mover el cursor (use las cuatro flechas), insertar y borrar o buscar en el texto, en la ventana activa. MODO SOBREESCRITURA E INSERCIÓN DE CARACTERES Existen dos modos de escritura proporcionados por el editor Turbo C/C++. En modo sobre escritura, los caracteres que se teclean sobre los ya tecleados, sustituirán a los ya tecleados (similar a una máquina de escribir). En el modo insertar, los caracteres que se teclean se insertan entre los caracteres ya tecleados. En forma estándar Turbo C/C++ tiene modo inserta, puede cambiar los modos pulsando la tecla Insert (activa y desactiva).

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 6–


INSERTA UNA LÍNEA Se puede insertar una línea o un grupo de ellas en cualquier parte dentro del texto del programa. Los pasos a dar son: •

Posicionar el cursor al principio de la línea siguiente a la posición de la inserción.

Pulse el enter. Se inserta una línea en blanco encima del cursor. Si pulsa sucesivos enter, logrará varias líneas.

BORRAR UNA LÍNEA Se puede borrar una línea o un grupo de ellas en cualquier parte dentro del texto del programa. Existen dos métodos: *

Posecionar el cursor al principio de la línea y repetidamente pulsar la tecla Supr hasta que se borren todos los caracteres. A continuación pulsar una vez más la tecla Supr y se borrará la línea en blanco. Esto último indica que si la línea a borrar esta en blanco, basta pulsar una vez la tecla Supr.

*

Llevar el cursor a cualquier posición de la línea a borrar y pulsar la combinación de teclas Control+Y. Repitiendo sucesivamente estos métodos se logra borrar más de una línea.

AUTOSANGRADO El editor Turbo C/C++ sangra (indentar) automáticamente cada línea la misma cantidad que la línea anterior. Utilice la barra espaciadora o la tecla de tabulación para moverse a la derecha y la tecla de retroceso para moverse a la izquierda. MOVIMIENTOS DEL CURSOR MOVIMIENTO

TECLA/S

Carácter a la izquierda

flecha izquierda

Carácter a la derecha

flecha derecha

Palabra a la izquierda

Control + flecha izquierda

Palabra a la derecha

Control + flecha derecha

Línea arriba

flecha arriba

Línea abajo

flecha abajo

Página arriba

Re Pág

Página abajo

Av Pág

Ir al principio de la línea

Inicio

Ir al final de la línea

Fin

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 7–


Ir a la parte superior de la ventana

Control + Inicio

Ir a la parte inferior de la ventana

Control + Fin

Ir al principio del archivo

Control + Ra Pág

Ir al final del archivo ÓRDENES DE INSERTAR Y BORRAR

Control + Av Pág

ACCIÓN

TECLA/S

Cambiar entre modo insertar y sobreescritura

Insert

Insertar línea

Enter o Control + N

Borrar una línea

Supr o Control + Y

Borrar palabra a la derecha del cursor

Control + T

Borrar carácter bajo el cursor

Supr

Borrar carác. a izq. del cursor

Retroceso

OPERACIONES CON BLOQUES DE TEXTO Un bloque de texto puede ser desde un sólo carácter hasta el archivo completo. Desde una línea a un párrafo completo, todo lo que el usuario desee marcar como bloque. ACCIÓN

TECLA/S

Marcar bloque (teclado)

Shift + flechas (↑↓→←)

Marcar comienzo de bloque

Control + K + B

Marcar final de bloque

Control + K + K

Marcar una palabra

Control + K + T

Marcar una línea

Control + K + L

Ocultar/Visualizar bloque

Control + K + H

Copiar bloque

Control + K + C

Mover bloque

Control + K + V

Borrar bloque

Control + K + Y

Recuperar bloque almacenado

Control + K + R

Imprimir bloque

Control + K + P

Sangrar bloque

Control + K + I

Marcar bloque (uso del MOUSE)

Clic mantengo y desplazo

El saber el manejo de bloques le proporcionará, rapidez en la creación de programas extensos, donde es muy frecuente que un bloque de instrucciones se repita o tenga que cambiarlo de lugar.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 8–


MENÚS TURBO C/C++ La siguiente tabla muestra cómo activar los diferentes menús desplegables: ACCIÓN

TECLA/S

Activar barra de menús

F10

Abrir menú File

Alt + F

Abrir menú Edit

Alt + E

Abrir menú Search

Alt + S

Abrir menú Run

Alt + R

Abrir menú Compile

Alt + C

Abrir menú Debug

Alt + D

Abrir menú Project

Alt + P

Abrir menú Options

Alt + O

Abrir menú Window

Alt + W

Abrir menú Help

Alt + H

La siguiente tabla resume las tareas realizadas por las diferentes teclas de función y combinación de las teclas de función con las teclas SHIFT, CONTROL y ALT. TECLA DE FUNCIÓN

ACCIÓN

TECLA DE FUNCIÓN + SHIFT

TECLA DE FUNCIÓN + ALT

TECLA DE FUNCIÓN + CONTROL

Índice de ayuda

Dentro del Índice, Ayuda anterior (atrás)

Con el cursor en una palabra reservada, Encontrar la ayuda sobre esa palabra

F1

Ayuda

F2

Grabar archivo

F3

Abrir archivo

Cerrar ventana (archivo .C)

Abre la ventana de Call Snack del Debug

F4

Ejecutar las líneas de programas hasta el cursor

Ejecuta el inspector del Debug

Evaluación y modificación de variables del Debug

F5

Maximizar y restaurar una ventana

Muestra la última ventana de ejecución de un programa

Con la ventana restaurada mueve y modifica el tamaño de una ventana (usar

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 9–


flechitas y enter para fijar, tamaño shift y fechitas) F6

Ventana siguiente partiendo de la actual

F7

Ejecuta las líneas de un programa secuencialmente, una por una, esto se utiliza para la búsqueda de errores en tiempo de ejecución

Errores previos en buscar

Permite agregar variables a el Watches del Debug para la depuración de programas, así como la búsqueda de errores.

F8

Semejante a F7 pero no ejecuta las líneas de las FUNCIONES del usuario si las hay.

Errores siguientes en buscar

Activa o desactiva un punto de corte, los programas se ejecutan hasta ese punto, finalizando

F9

Compila y enlaza

Compilar

Ejecuta programa

F10

Abrir barra del menú

MENÚ FILE (ALT + F) El menú File permite manipular archivos sin salir del entorno integrado. OPCIONES DEL MENÚ New Crea un nuevo archivo en una nueva ventana de edición con el nombre por defecto NONAME00.C o CPP. 00 aumenta a medida que continúa creando archivos, abriendo ventanas nuevas. Open...(F3) Abre un archivo existente la ventana activa. Pide el nombre del archivo a recuperar. Save (F2) Graba el archivo de la ventana activa. Pide el nombre del archivo y si no se especifica una extensión, por defecto se grabará con extensión .C o .CPP. Save as... Permite grabar un archivo que ya fue grabado o no, con un nombre diferente o en un directorio o unidad distinta. Pide el nuevo nombre. Save all

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 10–


Graba todos los archivos de todas las ventanas abiertas con los nombres originales de cada ventana abierta. Si faltara nombrar algún archivo muestra el cuadrote diálogo correspondiente a Save as.

Change dir... Cambia el directorio por defecto donde se grabarán los archivos. Pide el ingreso del nuevo camino de directorio/s o la nueva unidad. Debe hacer clic en el botón CHDIR luego de encontrar la nueva ubicación. Print Imprime el contenido de la ventana activa en la impresora habilitada.(si se encuentra en Windows se recomienda utilizar el BLOK DE NOTAS para abrir los archivos .C o .CPP e imprimirlos desde allí). DOS shell Permite la salida temporal de Turbo C/C++ al indicativo del DOS. Para volver a Turbo C/C++ teclee la palabra EXIT y luego pulse enter. Quit (Alt+X) Salida definitiva de Turbo C/C++. Cualquier archivo no grabado antes de la salida, pedirá autorización para grabar o perder cambios.

MENÚ EDIT (ALT + E) El menú Edit contiene un número de órdenes de edición extremadamente útiles y potentes. OPCIONES DEL MENÚ Undo (Alt+BkSp) Deshace (anula) el último movimiento de la orden de borrado. Redo (Shift+Alt+BkSp) Anula, cancela la última orden undo. Cut (Shift+Del) Borra un bloque de texto resaltado de su archivo y lo copia en el portapapeles, desde donde puede ser copiado a cualquier parte del archivo o a un archivo diferente.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 11–


Copy (Ctrl+Ins) Copia un bloque de texto seleccionado de la ventana activa Edit o Help al portapapeles, sin eliminarlo de la ventana activa.

Paste (Shift+Ins) Inserta texto del portapapeles en la posición en que se encuentra el cursor. Clear (Ctrl+Del) Borra (limpia) el bloque marcado de texto desde la ventana de edición activa. Copy example Copia los ejemplos del help, del propio C. Show clipboard Abre el portapapeles, de modo que se puede editar su contenido.

MENÚ SEARCH (ALT + S) El menú Search permite buscar y reemplazar texto de la ventana activa. OPCIONES DEL MENÚ Find... Localiza una cadena de texto en un archivo fuente, utilizando la directriz seleccionada en el cuadro de diálogo. Replace... Busca una cadena de texto y se reemplaza por un nuevo texto. Search again (Ctrl+L) Repite la última operación de búsqueda realizada. Go to line number... Lleva el cursor a la posición de la línea cuyo número se especifica. Previous error (Alt+F7)

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 12–


Error previo. Next error (Alt+F8) Próximo error.

Locate funtion... Encuentra el principio del procedimiento o función que se especifica en el cuadro de diálogo.

MENU RUN (ALT + R) El menú Run permite compilar y ejecutar programas. OPCIONES DEL MENÚ Run (Ctrl+F9) Ejecuta el programa en una sola orden. Program reset (Ctrl+F2) Suspende un F7 o F8 para que se ejecute desde el comienzo un programa. Go to cursor (F4) Ejecuta hasta la posición del cursor. Trace into (F7) Es semejante a Step over, pero ejecuta sentencia por sentencia también e las funciones y procedimientos. Step over (F8) Ejecuta el programa paso a paso. Es muy eficaz para verificar algoritmos que contengan errores. En el caso de funciones o procedimientos, los ejecuta como si fueran una única sentencia. Argummentos... Permite especificar parámetros que se pasarán al programa cuando se ejecuta en el entorno integrado de desarrollo.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 13–


MENU COMPILE (ALT + C) El menú Compile permite compilar todo el programa o parte del mismo y especificar dónde se debe almacenar el programa compilado. OPCIONES DEL MENÚ Compile (Alt+F9) Compila el archivo de la ventana activa de edición. Make (F9) Constituye una versión ejecutable del archivo del programa principal, compilando ese archivo y otros archivos modificados utilizados en el programa. Link Para cuando recompila. Build all Es similar a Make excepto que todos los archivos son recompilados, sin tener en cuenta si han sido o no modificados. Information... Muestra un cuadro de diálogo con información sobre el programa y la memoria. Remove messages Borra todos los mensajes de la ventana de mensajes de link

MENU DEBUG (ALT + D) El menú Debug permite visualizar o modificar variables durante una sesión de depuración y establecer o eliminar puntos de ruptura. OPCIONES DEL MENÚ Inspect...(Alt+F4) Cuando un programa se encuentra en ejecución, por ejemplo si esta utilizando F7 o F8, puede utilizar esta opción para verificar el contenido, dirección de memoria y dato de una variable. Evaluate/Modify...(Ctrl+F4) Se puede visualizar y modificar el valor de una variable en cualquier punto del REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 14–


programa. Call Snack...(Ctrl+F3) Muestra un listado de las funciones que se están utilizando hasta ese punto, por ejemplo si dentro de una función main, se invoca a otra función cálculo, y dentro de ella otra función llamada venta, en esta ventana se verán los nombres de las funciones en el orden de invocación. Watches Abre la ventana Watches en la que se especifican variables y se pueden ver sus contenidos en tiempo de ejecución si esta utilizando F7 o F8. Abre una nueva ventana donde se pueden observar los cambios en las variables. Toggle Breakpoint (Ctrl+F8) Activa o desactiva un punto de corte en el programa actual, se indica con una línea en color rojo. Se puede tener más de una punto de corte, significa que cada vez que ejecute su programa este lo ara hasta que encuentre un punto de corte. Luego hasta el próximo y así sucesivamente si hay más de uno. Breakpoints... Permite situar, editar, añadir y borrar puntos de ruptura condicionales.

MENU PROJECT (ALT + P) El menú Project se utiliza para la creación de proyectos en C++. No se utiliza a estos niveles.

MENU OPTIONS (ALT + O) El menú Options determina el modo en que el entorno integrado ejecuta sus tareas. OPCIONES DEL MENÚ Application... Brinda un set donde podrá seleccionar si desea aplicaciones de salida ejecutables o no. Si verifica las opciones, la opción LIBRARY no genera archivos .EXE. De esta manera usted puede probar sus programas sin generar ejecutables innecesarios. Se recomienda el uso de la opción STÁNDARD aunque genere el ejecutable. Compiler Estas opciones estas relacionadas con la Application que selecciono en el punto anterior. Proporciona un control completo sobre el compilador, permitiendo REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 15–


especificar opciones diversas del compilador. Estas opciones se pueden seleccionar utilizando la barra espaciadora, cuando se coloca una X, significa que la orden a sido seleccionada. Tranfer... Permite manipular y asignar nuevas órdenes a la tecla Shift y las teclas de funciones. Tenga cuidad de modificar las opciones estándar. Luego no podrá recuperarlas, solo si instala el entorno nuevamente.

Make... En esta opción se le indique si se desea detener o no la ejecución de sus programas por errores fatales, por advertencias o errores comunes. Se recomienda mantener las opciones estándar. Linker Permite cambiar opciones de enlazador de sus programas. Depende de la Application seleccionada. Se recomienda no modificar. Librarian... Opciones de las librerías, se recomienda no modificar. Debugger... Opciones de depuración, se recomienda no modificar. Directories... Abre un cuadro de diálogo que permite especificar la posición de los archivos que manipula el compilador y los creados por el usuario. TENGA MUCHO CUIDADO CON LOS DIRECTORIOS DE INCLUDE Y LIBRARY, estos dependerán de donde usted instalo el programa. Si instalo en C:\, entonces deberá indicar C:\tc\include y C:\tc\lib, las rutas de OUTPUT y SOURCE son elección del usuario. Environment Permite configurar el entorno Turbo C/C++ a sus necesidades. Tales como Mouse o colores, etc. Save... Grabar las modificaciones realizadas en las opciones, si no utiliza esta opción las modificaciones realizadas se perderán al cerrar la aplicación.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 16–


MENU WINDOWS (ALT + W) El menú Window contiene las órdenes necesarias para gestionar las ventanas visualizadas en el escritorio Turbo C/C++. OPCIONES DEL MENÚ Size/Move (Ctrl+F5) Contrae o expande el tamaño de la ventana, utilizando las flechitas para mover la ventana y las tecla shift + las flechitas para cambiar el tamaño, luego pulse el enter para hacer el tamaño definitivo. Zoom (F5) Permite expandir la ventana activa a su máximo tamaño o restaura. Tile Reduce las ventanas abiertas hasta un tamaño que permita quepan (embaldosar la pantalla) todas en la pantalla. Se puede seleccionar una ventana utilizando la tecla Alt+Nº (el número de ventana). Cascade Ordena las ventanas, poniéndolas en cascada. Visualizando solo la venta activa y de las otras, solo la barra de título. Next (F6) Pasa a la siguiente ventana con numeración. Close (Alt+F3) Cierra la ventana activa. Close all Permite cerrar todas las ventanas del escritorio. Message Muestra el contenido de la ventana de mensajes. Output Muestra el contenido de la ventana de salida, es en la se visualiza la ejecución del programa.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 17–


Watch Muestra el contenido de la ventana de Watches, las variables definidas si las hay. User Screen Muestra el contenido de la ventana del usuario, semejante a OUTPUT pero en este caso sin los límites de la ventana. Register Project Project notes List all... (Alt+0) Muestra una lista de todas las ventanas abiertas hasta el momento.

MENU HELP (ALT +H) El menú Help proporciona acceso al sistema de ayuda en línea. Para abrir la ventana Help pulse F1 en cualquier momento; en la ventana activa, coloque el cursor bajo la palabra deseada y pulse Control + F1, el menú de ayuda presentara toda la información que contenga sobre ella. OPCIONES DEL MENÚ Contents Visualiza una ventana que contiene la tabla principal de contenidos. Index (Shift+F1) Visualiza un cuadro de diálogo con una lista completa de todas las palabras reservadas del sistema de ayuda. Topic search (Ctrl+F1) Abre una ventana de ayuda para información sobre la construcción de C/C++ en la posición actual del cursor. Previous topic (Alt+F1) Abre la ventana de ayuda (si ya no está abierta) en la pantalla que proporciona ayuda sobre el sistema de ayuda. Help on Help REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 18–


Ayuda de cómo utilizar el Help. About... Información sobre versión de Turbo C/C++.

REALIZACIÓN NORA HERNÁNDEZ - ITS 2008 C/C++ ver. 3.0 noraha@adinet.com.uy

- Página 19–

Manual Editor de Turbo C++ ver. 3.0  

Manual Editor de Turbo C++ ver. 3.0