Page 1

SEFOTEC CHILE

Creaci贸n de sitios web en Publisher

Microsoft Office Carlos Garrido

01


2

Preparar, publicar y mantener su sitio Web de Publisher

Después de diseñar y crear una publicación Web en Microsoft Office Publisher 2007, puede publicarla en Internet, en un servidor de red o en una carpeta compartida de su propio equipo. Cualquiera que sea el destino, Publisher crea archivos HTML filtrados a partir de la publicación Web. Puede abrir y leer estos archivos HTML en cualquier explorador Web, como Windows Internet Explorer.

En este artículo En este artículo se describen los procedimientos para crear y publicar una publicación Web como archivos HTML y actualizar el sitio Web modificando la publicación Web y volviendo a publicarla. Preparar el sitio Web Publicar el sitio Web Mantener el sitio Web


3

Preparar el sitio Web Su sitio Web es una prolongación de su trabajo, su organización y su imagen corporativa. Antes de crear el sitio Web, diséñelo. Para obtener ayuda con el diseño, vea el artículo Planear el sitio Web. ¿Cuál es la mejor herramienta? Cuando diseñe el sitio y la información que va a proporcionar, plantéese qué herramienta de creación es la adecuada para sus necesidades. Office Publisher 2007 es una excelente herramienta de creación que le ayudará a crear, publicar y administrar rápidamente sitios Web simples y estáticos acordes con su imagen corporativa y que sólo requieran revisión del texto y los gráficos. Office Publisher 2007 no es la herramienta adecuada en los siguientes casos: Si su sitio Web requiere interacción o contenido controlado por bases de datos para que los visitantes puedan responder a través de un registro Web (blog) o comprar artículos en un carro de la compra Si el sitio Web requiere la validación de datos, como comprobar números de tarjeta de crédito Si prevé que más adelante deberá modificar el código HTML básico en un editor HTML después de crear el sitio Web en Office Publisher 2007, que combina código HTML, XML y VML para crear sitios Web Para el hospedaje (hosting) de sitios Web básicos y la creación de sitios en línea, Microsoft Office Live puede ser la herramienta idónea. Para obtener más información, visite el sitio Web de Microsoft Office Live (En inglés). Para los sitios Web interactivos, el Diseñador Web de expresiones de Microsoft proporciona herramientas para crear sitios Web basados en los estándares con una gran cantidad de datos. Para obtener información, visite el sitio del Diseñador Web de expresiones de Microsoft.

Crear un sitio Web Puede crear una nueva publicación Web en Office Publisher 2007. Si desea trabajar en un sitio Web existente para el que no dispone de ninguna publicación Web, puede copiar y pegar contenido de las páginas Web publicadas en una nueva publicación Web y, de ese modo, volver a crear el


4

sitio Web como una publicación Web, o puede utilizar una herramienta de edición HTML. En el menú Archivo, haga clic Nuevo. En la lista Tipos de publicaciones, haga clic en Sitios Web. Realice uno de los procedimientos siguientes: Para crear un sitio Web personalizado con arreglo a sus objetivos, asegúrese de que Usar Asistente para sitios Web fáciles, en el panel de tareas Opciones, está seleccionado y, a continuación, haga clic en el diseño que desee. Para crear un sitio Web desde el principio, en Sitios Web, haga clic en Tamaños en blanco y, a continuación, haga clic en el tamaño que desee. Haga clic en Crear. Si elige usar el Asistente para sitios Web fáciles, seleccione las opciones que desee en el cuadro de diálogoGenerador fácil de sitios Web y, a continuación, haga clic en Aceptar. Agregue contenido a la publicación y realice los cambios que desee. SUGERENCIA Procure no colocar objetos en las páginas maestras de la publicación Web. Los objetos colocados en las páginas maestras de Office Publisher 2007 no se muestran correctamente cuando se consultan en algunos exploradores Web. Comprobar la publicación Web Antes de publicar el sitio Web, asegúrese de que el sitio funciona según lo previsto y compruebe que ha corregido los posibles problemas que puedan surgir. Puede detectar problemas con el Verificador de diseño y mediante una vista previa del sitio. Usar el Verificador de diseño para detectar y corregir problemas El Verificador de diseño es una herramienta eficaz para detectar posibles problemas. Lo que comprueba son sobre todo problemas básicos de formato, pero algunas comprobaciones están dirigidas especialmente a problemas que pueden afectar a las publicaciones Web. Para ejecutar el Verificador de diseño, realice el procedimiento siguiente: En el menú Herramientas, haga clic en Verificador de diseño.


5

En el panel de tareas Verificador de diseño, active las casillas de verificación Ejecutar comprobaciones de diseño generales y Ejecutar comprobaciones de sitio Web. NOTA Asegúrese de que la casilla de verificación Ejecutar comprobaciones de impresión comercial no está activada. En el panel de tareas Verificador de diseño, en Seleccione un elemento para corregirlo, haga clic en la flecha situada junto al elemento que desea corregir y realice alguno de estos procedimientos: Haga clic en Corrección automática para corregir automáticamente el problema con el elemento. La corrección automática varía en función del problema. Normalmente, no hay ninguna corrección automática disponible. Haga clic en Ir a este elemento para ir a la página donde se encuentra el elemento problemático seleccionado. A continuación, puede corregir el problema realizando los cambios necesarios. Haga clic en Explicar para abrir un tema de la Ayuda con una explicación más detallada del problema y sugerencias sobre cómo corregirlo. Haga clic en No volver a ejecutar esta comprobación para desactivar la comprobación. Esta opción afecta a todos los problemas de este tipo. Obtener una vista de previa del sitio Web En el menú Archivo, haga clic en Vista previa de la página Web. Se mostrará una vista previa del sitio Web en el explorador predeterminado. Compruebe lo siguiente en la vista previa: El sitio se abre y se puede obtener acceso a todas las páginas. Todos los hipervínculos funcionan según lo previsto. Los controles de exploración funcionan según lo previsto. No falta ningún elemento. Todos los sonidos de fondo se reproducen tal como estaba previsto. Buscar un servicio de hospedaje (hosting) Web


6

Para poder publicar su sitio Web, debe suscribirse a un servicio de hospedaje (hosting) Web suministrado por un proveedor de servicios de Internet (ISP). Este servicio le proporcionará acceso a Internet, espacio de almacenamiento en un servidor Web y una dirección URL (Localizador de recursos universal) para que las personas puedan tener acceso a su sitio Web. Antes de publicar el sitio Web, póngase en contacto con su ISP o administrador del sistema para obtener la información necesaria y la dirección URL del sitio Web, o la dirección del sitio FTP en la que puede guardar archivos. Es posible que haya varios ISP en su zona. Asegúrese de que el ISP al que se suscribe ofrece el tipo de soporte que necesita. Si no tiene mucha experiencia en la publicación en el Web, tal vez le convenga recibir ayuda de un ISP para solucionar los posibles problemas.

Publicar el sitio Web Después de realizar las comprobaciones y obtener una vista previa de la publicación Web, y de suscribirse a un servicio de hospedaje (hosting) Web, ya puede publicar su sitio Web. Puede publicar el sitio Web en un servidor Web, un servidor de red, un servidor FTP (Protocolo de transferencia de archivos) o una carpeta de su propio equipo. La publicación del sitio en una ubicación del equipo puede ser útil por varios motivos: Puede utilizar los archivos publicados para probar el sitio Web antes de que dichos archivos estén disponibles en el Web. Puede usar una utilidad FTP para publicar los archivos en el Web cargándolos desde la ubicación de los archivos en su equipo. Mantendrá una copia local de los archivos HTML además de la publicación Web. El ISP puede proporcionarle información que le ayudará a decidir el método de publicación que más le conviene. Tanto si publica en el Web como en su equipo, Office Publisher 2007 reúne todos los archivos relacionados que crea en una sola carpeta. Los archivos que crea Office Publisher 2007 incluyen las demás páginas HTML que


7

componen el sitio, los gráficos GIF y JPEG utilizados en las páginas y todos los archivos de sonido. Puede configurar Office Publisher 2007 para organizar estos archivos en la carpeta en la que publica el sitio Web de dos formas distintas. De manera predeterminada, Office Publisher 2007 crea una única página principal y una subcarpeta que contiene todos los archivos auxiliares necesarios para el sitio Web. También puede organizar la página principal con todos los archivos auxiliares del sitio Web en una sola carpeta. ¿Cómo se controla el lugar en el que Office Publisher 2007 organiza los archivos del sitio Web que publica? Cuando se publica una publicación en el Web, Office Publisher 2007 crea archivos HMTL filtrados, que se propagan en el Web más rápidamente que los que no están filtrados. Como los archivos HTML filtrados que crea Office Publisher 2007 no contienen etiquetas específicas de Microsoft Office, no puede abrir estos archivos en Office Publisher 2007 ni modificarlos. Debe realizar los cambios del sitio Web en la publicación Web y después volver a publicar el sitio en el Web.

Publicar un sitio Web en una ubicación en Internet o en una red Antes de realizar este procedimiento, póngase en contacto con su ISP o administrador del sistema para obtener la información necesaria para publicar y la dirección URL del sitio Web en la que puede guardar los archivos. En el menú Archivo, haga clic en Publicar en el Web. En el cuadro de diálogo Publicar en el Web, en el cuadro Nombre de archivo, escriba la dirección URL del servidor Web o del servidor de red en el que desea guardar el sitio Web. Escriba, por ejemplo,http://www.northwindtraders.com. Haga clic en Guardar. Si se le solicita, escriba su nombre de usuario y contraseña y, a continuación, haga clic en Aceptar. El directorio asociado a la dirección URL aparecerá en el cuadro de diálogo Publicar en el Web. Haga doble clic en la carpeta en la que desea guardar el sitio Web.


8

En el cuadro Nombre de archivo, seleccione index como el nombre predeterminado de la página principal y, después, haga clic en Guardar. NOTA Index.htm es la selección predeterminada. La selección de index como nombre de la página principal facilita el acceso e impide que los usuarios vean la lista de archivos que componen el sitio Web. Cuando se le pida, haga clic en Aceptar. Publicar un sitio Web mediante FTP Antes de realizar este procedimiento, póngase en contacto con su ISP o administrador del sistema para obtener la información que necesita para publicar en un sitio FTP. Puede crear también un sitio FTP en Ubicaciones FTP.

¿Cómo? En el menú Archivo, haga clic en Publicar en el Web. En la lista Guardar en, haga clic en Ubicaciones FTP. En la lista de sitios FTP, haga doble clic en el sitio que desee y, a continuación, haga doble clic en la carpeta en la que desea publicar el sitio Web. NOTA Si el ISP requiere el uso de un programa específico para cargar el sitio Web, o si va a publicar el sitio Web en una intranet corporativa, es posible que tenga que guardar una versión del sitio Web en un formato de archivoHTML específico y realizar un procedimiento distinto para publicar el sitio Web. Pregunte a su ISP o administrador del sistema cómo debe guardar y publicar el sitio Web. Publicar un sitio Web en una carpeta del equipo En Windows Vista En el menú Archivo, haga clic en Publicar en el Web. En la Barra de direcciones, haga clic en la unidad o carpeta en la que desea publicar el sitio Web, como la carpeta Documentos. NOTA Si desea agregar el sitio Web a una nueva carpeta, haga clic en Nueva carpeta en la barra de herramientas para crear una nueva carpeta, escriba un nombre para la nueva carpeta y, a continuación, presione ENTRAR.


9

En el cuadro Nombre de archivo, seleccione index como el nombre predeterminado de la página principal y, después, haga clic en Guardar. NOTA Index.htm es la selección predeterminada. La selección de index como nombre de la página principal facilita el acceso e impide que los usuarios vean la lista de archivos que componen el sitio Web. En el menú Archivo, haga clic en Publicar en el Web. En la lista Guardar en, haga clic en la unidad o carpeta en la que desea publicar el sitio Web, como la carpetaMis documentos. NOTA Si desea agregar el sitio Web a una nueva carpeta, haga clic con el botón secundario del mouse (ratón) en el lugar donde desea agregar la nueva carpeta, seleccione Nuevo, haga clic en Carpeta para crear una nueva carpeta, escriba un nombre para la nueva carpeta en el cuadro Nombre y, a continuación, haga clic en Abrir. En el cuadro Nombre de archivo, seleccione index como el nombre predeterminado de la página principal y, después, haga clic en Guardar. NOTA Index.htm es la selección predeterminada. La selección de index como nombre de la página principal facilita el acceso e impide que los usuarios vean la lista de archivos que componen el sitio Web.

Mantener el sitio Web Después de publicar el sitio Web, puede actualizarlo según sea necesario para incluir nueva información. Sin embargo, no puede abrir los archivos HTML filtrados en Publisher. Debe abrir la publicación Web original, realizar los cambios que desee y volver a publicar el sitio en el Web. NOTA No debe intentar actualizar los archivos HTML filtrados mediante un editor de texto, como el Bloc de notas de Microsoft o Microsoft WordPad. Aunque se puede hacer, el código HTML generado por Publisher es muy complejo y probablemente le resultará difícil modificarlo manualmente. Para obtener mejores resultados, actualice siempre el sitio Web de Publisher utilizando la publicación Web y volviendo a publicarla en el Web.


10

Publicar sólo los cambios En Office Publisher 2007 , puede publicar rápidamente las actualizaciones realizadas en un sitio Web previamente publicado mediante la carga incremental en el Web, con la que sólo se publican las páginas que se han actualizado. Si piensa actualizar el sitio Web a menudo, o si el sitio Web es grande y complejo, la carga incremental en el Web puede simplificar la tarea de actualizar el sitio Web. Sin embargo, si realiza cambios en el sitio Web directamente en un servidor Web fuera de Office Publisher 2007, al activar la carga incremental en el Web es posible que no pueda utilizar el comando Publicar en el Web cuando publique las siguientes actualizaciones en el Web. Si piensa administrar los archivos del sitio Web directamente en el servidor Web (por ejemplo, mediante un programa FTP independiente), debe desactivar la carga incremental en el Web. NOTA La carga incremental predeterminada en Publisher.

en

el

Web

está

activada

de

forma

Activar o desactivar la carga incremental en el Web En el menú Herramientas, haga clic en Opciones y, a continuación, en la ficha Web. En Guardado, siga uno de estos procedimientos: Para desactivar la carga incremental en el Web, desactive la casilla de verificación Habilitar carga incremental en Web. Para activar la carga incremental en el Web, active la casilla de verificación Habilitar carga incremental en Web.

Publicar los cambios en el sitio Web Publicar las actualizaciones realizadas en un sitio Web no es exactamente el mismo proceso que publicar un sitio Web por primera vez. Después de publicar un sitio Web en una ubicación en el Web o una red, aparece un acceso directo al servidor Web o servidor de red en Mis sitios de red. En Windows Vista


11

En el menú Archivo, haga clic en Publicar en el Web. En el cuadro de diálogo Publicar en el Web, en el panel de exploración, haga clic en Equipo. En la lista de archivos, haga doble clic en el acceso directo a la carpeta del servidor Web o servidor de red en la que ha publicado el sitio Web. Haga doble clic en la carpeta en la que desea guardar el archivo. En el cuadro Nombre de archivo, escriba el nombre del archivo que va a actualizar y, a continuación, haga clic en Guardar. En Windows XP En el menú Archivo, haga clic en Publicar en el Web. En el cuadro de diálogo Publicar en el Web, haga clic en Mis sitios de red. Haga doble clic en el acceso directo a la carpeta del servidor Web o servidor de red en la que ha publicado el sitio Web. Haga doble clic en la carpeta en la que desea guardar el archivo. En el cuadro Nombre de archivo, escriba el nombre del archivo que va a actualizar y, a continuación, haga clic en Guardar.

Publisher - Creación de Sitios Web  
Advertisement