Page 1


Cabinets, shadows and colours This month in CatchUp we take

Mike Lucey spends some time

has an indepth explanation of

a look at some cool plugins

with RayLectron and Eric Lay

SketchUp Material tool.

from Tomot’s Cabinet Tools

shows a great visual trick with

and TIG’s Free Rotate. Plus

shadows and 3D Text..

Adriana shows how to create some very useful Dynamic Components that make great assets.

Enjoy!

We also have Randy Wilkins showing you how to use GE imagery to calculate building heights

and Aidan

Chopra

dynamic cabinets

GE and Shadows

Material TiPs

04 Learn to use DCs to create infinte options. Adriana Granados’ guide to DC cabinetry.

09 Top Tip from Randy Wilkins. How to use Google Earth imagery to get building heights.

14 Apply colours in SketchUp. Aidan Chopra’s explains the in and outs of applying textures in Sketchup.

raylectron

Gallery

Hey mr dj

34 Overview. Mike Lucey takes a look at RayLectron.

41 Are you featured? Our members submissions to the Gallery for July.

44 Getting in a spin. Learn how to use TIG’s Free Rotate Plugin.


Dynamic cabinets using 3 parameters by adriana granados

....endless cabinets with two DCs! In a few months I’ll be publishing my new

that I share there. We all know that we have

book Designing Kitchens with Sketchup.

to keep a low counting faces, but when you

Some of the exercises will cover how to use

insert fifteen or more cabinets the size of the

collections from the 3DWarehouse, plugins,

model can be pretty considerably especially

use pictures to present your ideas, create

if we are using raised door designs and other

dynamic

MatchPhoto,

features. So I will share some tips on how

create seamless constructions materials,

to create a kitchen with a small file size and

complete

at the same time can deliver the feel and

components,

the

use

necessary

documents

by

inserting notes and much more. Today’s tutorial even though is not included in my book will touch briefly some concepts

look to your client. I based this exercise on a wall cabinet, but the same procedure can be applied to a base cabinet.


Step 1: Create a box The first step is to create a box of the dimension of the real world picture that you have. In this case, I used 24 “x 12” x36”. Insert the handle as a component and nest it inside the box.

Step 2: Create a Dynamic Components Creating a dynamic component is very simple if you keep the hierarchy order. All parameters you wish to enter a value must be created in the first instance. The parameters that I wanted to change are width, height and the position of the handle in the case of a right or left door. These are images for each of configuration parameters. For Width and Height I established a list with the different options. For the Door Hand I gave two values for each option – Right or Left.


Once the first level of parameters has been set you must define the second hierarchical level, in this case the position of the handle in relation to the door. When you change the width of the cabinet, the component should automatically adjust the width of the door and therefore the position of the handle. But it also needs the ability to vary the hand according to the chosen option. Therefore in the section of the cabinet knob I entered the position whether right or left and used the IF logical parameter to establish each condition. Once you finish entering the formulas the Component Options window will look similar to this:

Step 3: Apply Textures I keep a file with all my door textures. In this file each door has two or three image versions depending the design. For example for the first picture below I keep one image with the complete door, a second one with just the inside raised panel and a third one with the wood grain. In this way I can control what portion of the image I want to apply to each surface. I usually create these new versions by connecting SU with my picture editor, saving as a new image and then importing it as an image or texture.


“...CREATE A KITCHEN WITH A SMALL FILE SIZE...” At this point you could use this cabinet in combination with any picture of a door cabinet. If you do not need to be precise perhaps because you are just sharing your ideas with your client, you could use different textures to apply on the front face like this picture and a wood grain texture for the rest of the cabinet. The same cabinet can be resized. To apply the textures to the box I use in first instance the native Paint tools. Recently I have used Thrupaint plugin of Fredo tools to apply the front door image to the front face. Using this plugin restrains me to enter to the edit mode and makes the texture unique by choosing the face to face option. I can also change easily the rotation and I tile it 1x1. For the image below I sampled first the wood grain applying to the box and then I sampled the door and applied it to the front face. The drawback is that the image will be stretched accordingly with the cabinet size and the stiles will not have the exact dimensions they should have when you choose different cabinet sizes.

You could use your image editor to solve this issue but you will end with many different textures deviating from an original size. If you want to solve this issue there’re many ways to do it so. I will only mention one of those I use.


As I said I have a separate file with my cabinet door textures. I import it as a component to my model. Then I download the Dynamic Door by Eric. I set the stile and rail widths and choose the Flat panel type as with this option I can control the application of my pictures. I use the SU native Paint tools to apply the wood grain to my box. Then with Thrupaint from Fredo Tools I sample the panel image and apply it to the component panel.


Estimating Building Heights Using Sketchup & Google Earth by randy wilkins There are many times when you’re studying an arial photograph of an area and realize it would be great to have some idea of how high a building ( or tree or other object ) is. I figured out a way to do this using Google Sketchup that’s fast and pretty accurate, depending on the quality of the photograph of the object. First, you want to find the location in Google Earth, not Google Maps. The reason is that in Google Earth, each photograph will have a date stamp in the bottom left corner. You need the exact date the photo was taken.


Then, with a new window in Sketchup open, click the “Add Location” button in the toolbar at the top of the window. It’s a little icon that looks like a folded map. Or, you can go under ‘File’ to ‘GeoLocation’ to the ‘Add More Imagery’ sub-menu.

Navigate to the same location on the map and you’ll see that it’s the same arial photo as in Google Earth. Zoom in as close as possible and adjust the grab frame to include only what you need.


Click the ‘Grab’ button in the upper right to bring it into Sketchup. Open the ‘Layers’ panel in the ‘Windows’ sub-menu. You’ll notice that there are two new layers, Google Earth Snapshot and Google Earth Terrain. For the most accuracy, be sure the Google Earth Terrain layer is turned on by checking the box. Now, under the Window menu, you want to check Shadows to open the Shadows Setting dialogue box. Enter the day and month of the Google Earth date stamp and click the box in the top left to turn on the shadows. Be sure the ‘on ground’ box at the bottom is also checked.

Now, using the photo as a guide, draw the outline of one of the buildings and use the push/pull tool to pull it up slightly. You will now see the shadow of the form in relation to the shadow cast in the photo. (SketchUp shadow in red and GE shadow in orange)


Using the Time slider in the Shadow Settings box, slide it back and forth until the two shadow lines meet. Then use the push/pull and move tool once again to pull the building up until the top of its shadow matches the photograph shadow. Pull the other surrounding buildings up to meet their shadows as well.

The accuracy of the final measured height will depend on a number of factors: the quality of the photo, how close the model terrain is to that at the actual site, how accurately you have drawn the position of the footprint of the object, and the shadow length ratio. You’ll get better results if the shadow length is longer than the actual object height. Of course if the shadow is obscured or nonexistant, you’ll have to find the height by going there.


SKetchUp TIP: Understanding Materials by aidan chopra

Everybody knows that faces in SketchUp can be painted with different materials. What lots of folks don’t know is that you can apply materials to groups and components, too. The following illustration shows the Entity Info dialog box, which is a great place to see which materials are applied to your geometry.


The Entity Info dialog box (Window > Entity Info) shows thumbnails for the materials assigned to selected entities. When you select a face, it shows thumbnails for the front and back sides of that face [as in the previous image]. Groups and components have material thumbnails, too [which you can see below].

When you paint a group or component red, only the faces inside it that are painted with the Default* material turn red. Faces that have already been painted with another material don’t change at all.


The group [below] includes faces that are painted with different materials. Only the top face is assigned the Default material.

Applying a material to the entire group only changes the color of faces that are painted the Default material.


This trick also works with groups and components that are nested inside one another. When you apply a material to a top level group or component, all the Default-colored faces that are inside nested, Default-colored groups and components inherit that material automatically. The following diagram is my best attempt at a visual explanation of this phenomenon.


Applying a material to a group or component that in turn contains sub-groups and component instances can be a confusing experience. Just remember that the color you’re painting “trickles down” to Default-colored faces contained within Default-colored groups and components. It’s easier done than said. *SketchUp automatically applies the Default material to faces you create from scratch. You can also paint anything with the Default material at any time; just pick it in the Materials Browser (which looks completely different on PCs and Macs.)

The Windows and Mac versions of the Materials Browser. On the former, the Default material is included as a permanent thumbnail; on the latter, it’s the first material in the “Colors In Model” list. As you can see, this technique is a godsend for building complicated objects that need to change color easily. In the case of the George Nelson Marshmallow Sofa (from FormFonts) in the images that follow, the cushions are individual component instances nested inside the main Sofa component. These are assigned the Default material.


The individual cushions are instances of the same component. Each instance is assigned the Default material.

The faces that make up the surface of each cushion are also painted with the Default material.


All of the metal and rubber frame pieces are also groups and components, but their faces are all assigned specific materials.

When you use the Paint Bucket to paint a color—in this case orange—on the main Marshmallow Sofa component, only the cushions take on that color. Everything not assigned the Default material stays exactly the way it is.


Painting the sofa component orange causes all Default-painted faces to turn that color. Non-Defaultcolored faces remain unchanged.


Shadow Fun by eric lay

The Build 1: Find a silhouette you prefer then change the color of it to something other than black.

2: Use the SketchUp 3D Text tool to place some words in your model.


3: Explode the word components and make each letter a separate group or component.

4: Set your shadow settings to the desired time of day and start placing the letters on your silhouette, elongating or scaling your letters to fit the silhouette edge.

5: Continue placing, elongating and scaling letters.


6: Start adding basic pathways or roads and other features you wish for your scenes.

7: Finish placing your letters then add some other elements like basic vehicles.


8: Delete the reference image and you are done however you can take the detail level as far as you like on the letters, even making them look like real buildings.

You can watch the final result here. Using scenes to control the shadows you are able to reveal the surprise at the very end.


plugin review : cabinet tools by rich o’brien

Everyone knows SketchUp is fast and fun when it comes to designing. But no matter which industry you use it in that fun can sometimes be dulled by repetitive modeling. Sure, components help but not every situation is suited to components. If you are using SketchUp for cabinetry, kitchen design or interior design then you need tools that can quickly and effectively block out new layouts and populate your scene accurately. Plugin author, Tomot, has a few free tools that are already big time savers when it come to modeling shortcuts. Whether it is windows, doors or stairs Tomot has a clever suite of tools that make life easy over on his ThingsVirtual blog. Recently Tomot released a new commercial plugin for cabinetry that is called Cabinet Tools and I had some time to sit and see what it could do.


Cabinet Tools comes in 2 flavours, metric or imperial, so you need to install the version you which to use. Currently you cannot have both in place but this is not a major drawback. Once installed in places an item in the plugins menu and a toolbar. The toolbar itself consists of 4 icons which relate to the 4 types of basic cabineTs you can construct - Single Door, Single Door or Drawer, Double Door and Corner Cabinet.

It is not until you activate the plugin that you come to realise the flexibility you have in terms of options. Each cabinet can be customized via a dialogue box that concerns the width, height and depth of the cabinet along with the kicker height. Depending on the type of cabinet you can also tweak either the door values or the drawer values. As well as the hardware that is used to open/close the cabinets. Finally you can decide the values for the counter type.


Every cabinet you create is placed on the world axis at 0,0,0. This means you must place it within your scene but Tomot also has a version of Cabinet Tools called Component-Cabinet Tools. This version allows you to create cabinets as components and place wherever you wish within a scene similar to loading a component from your Component Library. So depending on your chosen workflow then there is a version to suit. The cabinets themselves are nicely packaged with each element grouped to allow further tweaks if needed. Below you can see the detail of assembly that each cabinet has. Each item is also a solid so using SketchUp Solid Tools you can easily union parts together as needed.

By default base Cabinets are created so simply changing the depth and deleting the Kicker you can create upper Cabinets. Cabinet Doors or Drawers are created with a distinct display color, which can easily be edited later using the Materials pallette.


Overall, Cabinet Tools is a great addition to SketchUp especially if your workflow is cabinetry related. The volume of options you are able to create are limitless. The creation process is quick and easy and at only $5 it is an absolute bargain. Highly recommended!

“volume of options you are able to create are limitless�


Raylectron Overview by Mike lucey

“user

friendly

with

no

complicated settings�

New to the rendering game lately is RayLectron

Currently SketchUp users are spoilt for choice

by SoftByte Labs Inc.

when it comes to rendering solutions but

Raylectron was designed to be user friendly with

RayLectron is competitively priced at $99.95.

no complicated settings, but powerful enough to

Whilst the rendering market for SketchUp is

turn your SketchUp drawings into photo-realistic

cluttered RayLectron does have some standout

images.

features for someone considering adopting to another application.


Some of the key unique features of Raylectron are as follows... •

Raylectron does not need any editing by other graphic software, such as Photoshop, to produce photorealistic renders.

It has the ability to Start/Stop the render to let you fine-tune your lights/materials and camera position, without the need of SketchUp.

Should you need to stop the render, Raylectron provide a Resume option. You can save the render to file and reload it later to continue rendering, even on another PC.

Save your configuration. No need to re-export from SketchUp once you have exported it once already. Very fast to load. Saving the settings include any modifications made to materials and lights and camera.

Once you have exported your model to Raylectron, it lets you view your model as if viewed inside SketchUp. You can Rotate, Pan, Resize, Zoom and even modify your materials and lights outside Sketchup (right from the Raylectron viewer) no need to re-export your model.

The rendering process free Sketchup so you can continue working on your model. It’s all done inside Raylectron.

Supports HDR maps and can save the rendered image as an HDR, JPG, PNG and many other formats including Photoshop (PSD).

The Material editor is simple, yet powerful. It contains, Glossiness, Shininess IOR, Transparency, Reflection, Refraction IOR (Diamond, Glass, Plastic, Plexiglas, Water etc.), Bump mapping, Environment maps, Background image and Normal maps. The Light editor contains, On, Off, Light Beam kind: (Smooth spread, Spot effect, Laser beam), Power, Coverage (degree) / emitting angle, Emitting color, and transparency to have an invisible light source but yet illuminates your scene. Rendering can be done in many different ways to achieve the result you are looking for. Such as... •

Ray tracing

Path tracing

Photon tracing


“save your render to file and resume on another PC�


There are five type of light sources... •

Artificial lights

Sun

Sky (daylight)

From environment maps

Ambient occlusion for both, interior and exterior.

Two notable features in RayLectron are the X-Ray mode and 3D output. With the X-Ray mode there is no need to remove walls to render the interior of a model, and there is no need to position your camera inside in the corners using wide field of view. Simply position your camera outside and use the X-Ray vision. And with ‘Render in Stereo Vision’ (also called stereopsis or 3-D imaging). This will produce an outstanding 3D effect that is so real it feels like you can touch your model.


If you really need to crank out images in a tight timeframe then network rendering is well catered for here. You have an unlimited number of nodes and it is very easy to setup. The communication from server/slave is near nothing, freeing your network for other use.

Once your image is rendered they can be modified directly in Raylectron using tone mapping and many other settings such as brightness, contrast etc. These settings can be used even while the render is running.


Finally RayLectron also supports HDR maps and can save the rendered image as an HDR, JPG, PNG and many other formats including Photoshop (PSD). Which means you can still further refine your images in post production.

Overall, RayLectron is a robust and easy to use application that is well integrated with SketchUp. It offers a lot of features and at ~$100 it is hard to ignore. It is free to download and try with images overlayed with a faint watermark. You can find out more about RayLectron visiting their website.


C OMMUNITY

SHOWCASE

The latest gallery submissions on SketchUcation.com Each month we want to show what our members are achieving using SketchUp. If something takes your fancy just click the image to be brought to that topic.

Mountain suite

Louis e. brown

mid century

Frederic Yves Moro

Allan Casas

Dave Richards

police precinct

caterpillar

office building

Jason Christiansen

John Higgins

Redot


amazon theatre

open box house

audi a5

Elisei Jurubiță.

David Hier

Tuanhm.

old kitchen

water mill

cathedral

Jason Christiansen

John Higgins

Orgelf

NEW BOOKS ADDED! books.sketchUcation.com learn with the experts at your pace


PLUGIN TIP: FREE ROTATE by Rich O’Brien

R

otating

objects

in

SketchUp

is

OK, we have the Rotate Tool but that can

pretty painless. If it is a group or

be a bit of head scratcher when you want

component SketchUp’s Move Tool allows

to rotate about an odd point. Sure, you use

you to rotate about the bounding box

the click drag method to inference funky

centre very quickly.

angles quite easily but it is not exactly fast.

Luckily TIG has answered the call with his Free Rotate plugin. Once installed you But you may not want to rotate about the object centre, then what?

even get Plugins Menu entry and a nifty toolbar icon.


As I said using Free Rotate is pretty easy. Just

Once your pivot and axis point are chosen you

select what you want to rotate and activate the

will immediately be shown your object within a

plugin. You will be first asked to pick your ‘Pivot

‘Gizmo’.

Point’ which is the point at which you will rotate around.

The magenta point on the surface defines your chosen Axis Point you picked earlier and the Then you will be asked to pick your ‘Axis Point’.

black point at the centre is your Pivot Point. So

You can use SketchUp’s inferencing to good

now simply move your point around to get any

effect here.

rotation you need. You can also change to ‘Axial Rotation’ by hitting the TAB key.

You can grab Free Rotate in the Plugins forum.


Setting up a dataWORLD速 - Step 11 The dataWORLD速 is used to automatically generate precisely referenced illustrations of the processes embedded in a piecebased construction model. Originally written in AutoLisp for AutoCAD, the program has been used for both forensic and realtime analysis of construction documents and preconstruction planning. This includes the review of the assembly sequences, jobsite changes, and the movement of personnel and equipment on the jobsite. The intent is to dynamically generate a collection of screenshots and video animations as a graphical database that can then be used to illustrate process assumptions, simulate methods, and anticipate safety concerns. These images facilitate an immediate graphical response to change orders, reports, bulletins, and other field documents. When these illustrations are necessary as legal documents, the piece-based model can be certified as accurate by licensed architects or engineers after a complete review of the design and construction documents. Camera and target for screenshots and videos are from fixed positions

Certified piece-based construction model

Scenes are automatically generated using fixed camera positions

The construction model is geographic oriented to accurately simulate date and time

Single Scene variables include zoom, field of view, time of day, and object deconstructions for animations

Camera Target

Fixed Cameras

24 - 128 positions and 18 variables are programmable for each fixed camera

One or more dataWORLDs速 are configured and imported as a XRefs in a separate Component file for each construction model

Scene Navigation for Complex Models This simplified example uses the piece based construction model built in Steps 1-10. However, when model complexity increases with thousands of pieces and multiple layers, the computational time to navigate between Scenes makes the use of the final model impractical on the jobsite.

Piece-Based Model

Fixed camera positions simplify navigation by standardizing the points of view of the observer. Screenshots are generated as Scenes using the Outliner and Layers Preferences. Up to 18 variables can be indexed according to each of these fixed camera positions using proprietary plugins. These variables include field of view, zoom, time, motion, sequence, line phases, and piece-based deconstructions. Scene images and videos along with their corresponding variables for each camera position are thereby generated, labeled, and filed as a navigable graphical database. This makes it possible to index, sort, and access illustrations for different phases of the construction process in order to quickly support construction with graphic communications.


Related Scenes make it possible to Click-navigate and control model display

Scene to Scene transitions are interactively displayed on a secure website

Scene Data Sets

Scene indices provide immediate access to each image and its corresponding variables for print, fax, and email Clicking on any camera position displays a Scene that includes controls for incremental zooms, alternative assemblies, and related documents

Motion Capture Movement from Scene to Scene can also be navigated using directional arrows on the dashboard of a case file

The piece-based model is deconstructible and reconstructible

Sequence Animation

Movement from Scene to Scene makes it possible to drive-by, fly-over, sequence assemblies, and capture motion as video animations

Scene can be annotated for slide shows using referenced data points

Drive By

Scene navigation speeds point to point movement in a complex construction model

Simple Demonstration

Fly Over http://youtu.be/j8BRN-0q7bY


Taking shape

SketchUcation roundup

Behind the scenes we have being working hard to revamp SketchUcation. Soon we will need YOU to help us. Keep an eye on your inbox in the coming weeks as we will send out beta invites to get things moving. We have lots of cool new features but want YOU to help shape the final result. For ANY further information you can contact us at the email address below.

As always, you can send your feedback to richob@sketchucation.com

CatchUp Edition 12  

SketchUcation Community News

Advertisement