Page 1

MICROSOFT

ACCESS 2003

Revisionata nel giugno 2007 da Fabio Mocciaro

Pagina 1 di 22


Le basi di dati Nei sistemi informatici, per ragioni che in parte sono tecnologiche ed in parte sono legate alla semplicità dei meccanismi di gestione, il concetto di rappresentazione dei dati è fondamentale: le informazioni vengono rappresentate per mezzo di dati, che hanno bisogno di essere interpretati per fornire e costituire informazioni. Come per molti termini fondamentali, non è facile dare la definizione precisa di dato e soprattutto della differenza tra dato e informazione. Possiamo dire che i dati da soli non hanno alcun significato, ma, una volta interpretati e correlati opportunamente, essi forniscono informazioni che consento di arricchire la nostra conoscenza. Per esempio la stringa “Mario Rossi” e il numero “25775”, scritti su un foglio di carta, sono due dati e da soli non significano niente. Se il foglio di carta viene inviato in risposta alla domanda “Chi è il responsabile dell’ufficio tecnico e qual è il suo numero di telefono?”, allora è possibile interpretare i dati e utilizzarli per arricchire la nostra conoscenza con l’informazione che la persona di nome Mario Rossi è il responsabile dell’ufficio tecnico e che il suo numero di telefono è 25775. Introdotto così il concetto di dato, passiamo ad analizzare il concetto di basi di dati, oggetto di questa dispensa, cominciando con una definizione: una base di dati è una collezione di dati, utilizzati per rappresentare le informazioni di interesse in un sistema informatico. Un Sistema di Gestione di Basi di Dati (in inglese Data Base Management System) è un sistema software in grado di gestire collezioni di dati che siano grandi e persistenti, assicurando la loro affidabilità e la privatezza. Una base di dati è una collezione di dati gestita da un DBMS. Passiamo a precisare le caratteristiche dei DBMS e delle basi di dati su cui si fondano:  Le basi di dati possono essere grandi (si pensi alla base di dati di Telecomitalia s.p.a. che gestisce i clienti Business, cioè le aziende, e i clienti residenziali) o piccole (ad esempio un archivio di cd/dvd o una cantina di vini), ma i sistemi debbono poter gestire i dati senza porre limiti alle dimensioni, a parte quelle fisiche dei dispositivi. Pagina 2 di 22


Le basi di dati sono condivisibili, nel senso che applicazioni e utenti diversi possono accedere, secondo opportune modalità; è importante che in questo modo si riduce la ridondanza dei dati, poiché si evitano ripetizioni: se esistono varie copie degli stessi dati, è possibile che in qualche momento essi non siano uguali; viceversa se ogni dato è memorizzato in modo univoco e più utenti accedono agli stessi dati, non c’è possibilità di incorrere in disallineamenti dei dati. Per garantire l’accesso condiviso ai dati da parte di più utenti che operano contemporaneamente, i DBMS dispongono di un meccanismo detto controllo di coerenza. Le basi di dati sono persistenti, cioè hanno un tempo di vita che non è limitato all’esecuzione dei programmi che la utilizzano.

Progettazione di un DB È indispensabile prima di costruire un DB avere ben chiaro lo scopo che si vuole perseguire. Il processo di progettazione è alla base della realizzazione di un DB efficiente, in termini di capacità di reperire informazioni e di velocità di risposta, e per questo rappresenta una fase molto importante e delicata della costruzione di un DB.

Pagina 3 di 22


Le fasi di progettazione sono:  Definizione degli obiettivi del DB per individuare i dati che vi devono essere memorizzati (scopo del DB);  Definizione delle tabelle (suddivisione dei dati per argomenti);  Definizione dei campi e delle loro caratteristiche;  Definizione delle relazioni;  Verifica della struttura ed eventuali correzioni;

Uso di Microsoft Access Caratteristiche del sistema Il sistema viene avviato nel modo tradizionale in cui partono le applicazioni Windows, ovvero selezionando l’icona del programma dal menù Start  Programmi  Microsoft Office  Microsoft Office Access 2003. All’avvio il programma chiede se si vuole creare un nuovo database o aprire un database esistente, fornendo una lista dei database che sono stati utilizzati recentemente dal programma. La creazione di un Database (di seguito indicato come “DB”) può partire da un DB vuoto o seguire una serie di modelli predefiniti. A ogni DB corrisponde un file con estensione standard “.mdb”; per aprire un DB preesistente bisogna selezionare il corrispondente file. Per creare un DB nuovo o aprirne uno esistente si possono utilizzare i comandi “Nuovo database” e “Apri database” del menù File. Il database appena creato o aperto è rappresentato da una piccola finestra, che compare all’interno della finestra principale dell’applicazione. In figura 1 viene illustrata questa situazione; al momento della creazione del nuovo DB, il software chiede la posizione in cui salvare il DB ed il nome del DB (es. DEMOACCESS). Pagina 4 di 22


Figura 1

La finestra principale contiene un insieme di menù a tendina (File, Modifica, Visualizza, etc.) e immediatamente sotto, una riga (detta barra degli strumenti) che contiene un insieme di pulsanti, premendo i quali vengono eseguiti particolari comandi. I menù e la barra degli strumenti variano al variare della finestra in primo piano all’interno di Access. La figura 1 mostra il contenuto della barra degli strumenti quando è selezionata la finestra che rappresenta la base di dati. La finestra della base di dati contiene sul lato sinistro (sotto forma di opzioni) un elenco delle famiglie degli oggetti del sistema: Tabelle, Query, Maschere, etc. In ogni momento è selezionata una delle famiglia. Per passare da una famiglia all’altra, si seleziona il nome corrispondente. Quando una famiglia è selezionata nella finestra centrale compaiono tutti i nomi degli elementi della famiglia presenti nel database (se vi sono più elementi di quanti la Pagina 5 di 22


finestra ne possa contenere, viene automaticamente aggiunta una barra di scorrimento con la quale è possibile navigare lungo la lista). Ad esempio in figura 1 si vede l’insieme di elementi della famiglia Tabelle presenti nella base di dati di riferimento. Oltre le prime tre voci, che rappresentano tre diverse modalità per la creazione di una tabella, osserviamo che la base di dati contiene una tabelle “Città” e una tabella “Persona”. A questo punto, per ogni famiglia, è possibile premere uno dei tre pulsanti che compaiono sulla parte superiore:  Con il pulsante APRI si visualizza il contenuto di un elemento selezionato;  Con il pulsante STRUTTURA si riapre la fase di progetto su un elemento selezionato;  Con il pulsante NUOVO si crea un nuovo elemento della famiglia. Descriviamo ora la definizione di tabella.

La definizione delle tabelle Per definire lo schema di una nuova tabella, bisogna selezionare dalla finestra del DB la famiglia tabelle e premere il pulsante NUOVO. A questo punto Access propone la scelta tra cinque diverse modalità di definizione della tabella: “Visualizzazione foglio dati”, “Visualizzazione struttura”, “Creazione guidata tabella”, ” Importa tabella” e “ Collega tabella”. Con “Visualizzazione foglio dati” si definisce lo schema della tabella come se si definisse la struttura di un foglio elettronico, ovvero come se si definisse utilizzando Microsoft Excel. Le opzioni “Importa tabella” e “Collega tabella” permettono di importare dall’esterno (da altro DB) una tabella, rispettivamente ricopiandone l’intero suo contenuto o costruendone un collegamento che permetta di recuperarne il contenuto dinamicamente dalla risorsa remota (in effetti si stabilisce una vista Pagina 6 di 22


remota). Con l’opzione “Creazione guidata tabella” si accede all’uso di un wizard, ovvero uno strumento di supporto che guida nella creazione di tabelle ponendo una serie di domande e fornendo una collezione di esempi a cui ispirarsi. L’uso di wizard è consigliabile per la creazione di componenti dalla struttura regolare oppure nel caso di utenti alle prime armi; per la gestione delle tabelle, ma soprattutto per una migliore comprensione delle dinamiche di funzionamento, faremo uso delle “Visualizzazione struttura” (Figura 2), sulla quale ci concentriamo dettagliatamente.

Figura 2

Per prima cosa si definiscono i campi (o attributi), utilizzando la finestra in figura 2. Per ciascun campo bisogna specificare il nome del campo e il tipo di dati che il campo “ospiterà”. I tipi di dati definibili sono:  Testo: premette di rappresentare stringhe di caratteri;  Memo: permette di rappresentare stringhe di testo lunghe fino a 64.000 caratteri; Pagina 7 di 22


Numerico: rappresenta l’insieme dei numeri interi e reali. Le proprietà del campo (sempre visibili sotto, e variabili per tipo di campo) permettono di specificare se l’attributo rappresenta valori preci o approssimati, e il grado di precisione; Data/ora: rappresenta momenti temporali e permette di rappresentare rispettivamente solo la data, solo l’ora o entrambe; Valuta: serve a rappresentare valori monetari. È essenzialmente un caso particolare o variante, del tipo “numerico”, caratterizzato da una rappresentazione numerica con due cifre decimali. Contatore: è un particolare tipo, che associa a ogni riga della tabella un valore unico. Questo tipo permette di associare una chiave primaria alla tabella (n.d.r.). Si/no: campo corrispondente ad un valore “vero” o “falso” tipicamente espresso da una casella dove è possibile inserire un segno di spunta. Oggetto OLE: è un oggetto che può essere gestito tramite OLE (Object Linking and Embendding). OLE è un protocollo che permette di specificare quale applicazione deve gestire un oggetto nell’ambiente Windows. In questo modo è possibile inserire all’interno di un DB informazioni di vario tipo, come documenti di Word, di Excel, Immagini, o multimedia, lasciando all’applicazione invocata tramite OLE il compito di gestirne adeguatamente il contenuto. Collegamento Ipertestuale: permette la definizione di un riferimento. Il riferimento può essere interno al DB o anche esterno (ad esempio l’URL di una risorsa disponibile su internet). Ricerca Guidata…: questa opzione permette la definizione di un meccanismo che in fase di inserimento consente di scegliere un valore tra quelli presenti in un elenco predefinito o estratti tramite una query dal DB.

Pagina 8 di 22


Per ciascun attributo si possono poi specificare un certo numero di proprietà, che qualificano ulteriormente il campo e la sua rappresentazione. Le proprietà compaiono nella parte inferiore della finestra di definizioni dello schema:

Dimensione campo: rappresenta la dimensione dell’attributo. Si può specificare solo per i domini TESTO e NUMERICO. Per il TESTO la dimensione è un valore che rappresenta la lunghezza massima della stringa di caratteri; per il NUMERICO, si possono specificare le seguenti dimensioni:  Byte: interi su 8 bit (valori da 0 a 255);  Intero: interi su 16 bit (valori da -32.768 a 32.768);  Intero lungo: interi su 32 bit;  Precisione singola: rappresentazione in virgola mobile a 32 bit;  Precisione doppia: rappresentazione in virgola mobile a 64 bit;  ID Replica: identificatore a 128 bit unico per ogni tupla (o riga);  Decimale: rappresentazione in virgola mobile, con al possibilità di specificare il numero di cifre decimali significative.  Formato: descrive il formato di visualizzazione dei valori degli attributi. Access utilizza, dove possibile, i valori specificati nell’ambiente Windows (opzioni di internazionalizzazione del pannello di controllo). Per la rappresentazione di date, numeri e valori booleani (vero/falso), permette di scegliere tra vari formati predefiniti (sette formati predefiniti per le date, sette per i numeri, tre per i booleani). È possibile inoltre distinguere la rappresentazione dei valori a seconda che siano positivi, negativi, pari a zero, o abbiano associato un valore nullo.  Precisione: questa informazione, definibile solo per attributi di campo “numerico decimale”, specifica quante cifre decimali devono essere utilizzate. Pagina 9 di 22


 Posizioni decimali: questa informazione, definibile solo per attributi di campo “precisione singola”, “precisione doppia” e “decimale”, specifica quante cifre decimali devono essere utilizzate dopo la virgola.  Maschera di input: questo parametro specifica il formato che deve essere rispettato per l’immissione di dati. Se ad esempio un campo registra un numero di telefono composto da tre cifre di prefisso e da un numero di sette cifre, è possibile specificare una maschera di ingresso che introduca automaticamente il trattino, permettendo all’utente di inserire solamente le cifre.  Etichetta: rappresenta il nome che può essere dato al campo quando compare in una maschera o in un report.  Valore predefinito: con questo parametro si specifica il valore di default del campo. Tutte le volte che si inserisce una nuova riga, il valore di default comparirà automaticamente; si può utilizzare anche un valore calcolato, come ad esempio “=Date()” che assegna al campo il giorno corrente.  Valido se: è un vincolo al campo. Access verifica automaticamente che il valore inserito in un campo sia coerente con il tipo di dati.  Messaggio di errore: specifica il messaggio di errore che deve essere visualizzato quando viene inserito un valore che non rispetta i criteri di inserimento.  Richiesto: specifica se deve essere sempre presente un valore per quel campo; questa proprietà può essere vera o falsa (si/no).  Consenti lunghezza zero: è una proprietà che vale solo per i tipi di campo TESTO e MEMO; specifica se devono essere ammesse stringhe di lunghezza nulla (cioè vuote).  Indicizzato: specifica se deve essere costruito un indice sull’attributo. Le opzioni sono No, Si (duplicati ammessi) e Si (duplicati non ammessi). Dopo aver definito i vari attributi, si completa la sessione di definizione indicando quali campi devono essere considerati “chiave primaria” della tabella. L’indicazione di “chiave primaria” avviene Pagina 10 di 22


selezionando il campo e premendo il pulsante che raffigura una chiave nella barra degli strumenti (o selezionando l’opzione “Chiave primaria” nel menù visualizza, o tramite la pressione del tasto destro del mouse sul campo). Il campo che costituisce la “chiave primaria” viene visualizzato con un’icona che rappresenta una chiave nella colonna che precede il nome. Automaticamente Access definirà un indice di tipo “unique” sul campo in questione (unique, rappresenta l’indicizzazione con duplicati NON ammessi). Una chiave primaria non è obbligatoria ma è altamente consigliata nel caso in cui si voglia creare una o più relazioni tra tabelle. Per creare una chiave primaria è possibile seguire una procedura manuale o automatica; la procedura manuale prevede, in fase di creazione della tabella, la selezione della riga prescelta, tramite il tasto destro del mouse e la scelta della voce “Chiave Primaria”; se in fase di creazione non si sceglie alcuna Chiave Primaria, alla chiusura della tabella, Access propone la creazione automatica della stessa. Prima di terminare la sessione di definizione bisogna salvare selezionando l’opzione “salva” dal menù “file”; Access a questo punto chiede quale nome deve essere associato alla tabella. Il nome può contenere spazi al suo interno, sebbene sia consigliabile usare singole parole concatenate da simbolo “_” (es: “tabella_città”). Le Relazioni Un DB relazionale si presenta come un insieme di tabelle correlate mediante relazioni tra i campi. Le relazioni consentono di “costruire” le informazioni, aggregando dati appartenenti a diverse tabelle. Le relazioni possono essere di tre tipi:  Relazione uno a uno: a un record di una tabella può corrispondere al massimo un solo record di un’altra tabella.  Relazione Uno a molti: a un record di una tabella corrispondono più record di un’altra tabella e non si verifica il contrario.  Relazione molti a molti: a un record di una tabella corrispondono più record di un’altra tabella ed è vero anche il Pagina 11 di 22


contrario. La relazione molti a molti non è gestibile direttamente, è formata da due relazioni una a molti con una tabella intermedia creata ad hoc. Popolamento delle tabelle Dopo aver definito lo schema delle tabelle, si possono inserire tuple (o righe) per popolare la tabella del DB. Anche in questo caso Access fornisce un’interfaccia grafica facile da usare. Aprendo una tabella dalla finestra di partenza, premendo il pulsante APRI, compare una rappresentazione tabellare ( o a griglia) con colonne aventi come intestazione i nomi dei campi definiti in precedenza, e righe che descrivono le tuple della tabella. La figura 3 rappresenta questa finestra.

Figura 3

L’inserimento avviene posizionando il cursore nell’ultima riga e digitando un valore (coerente con il tipo) per ogni campo. Se il valore non rispetta tutti i vincoli definiti, l’inserimento viene immediatamente rifiutato. Spostando il cursore fuori dalla riga e cliccando, si indica implicitamente che l’inserimento è terminato. Per effettuare delle modifiche, basta andare a selezionare il valore da modificare con il cursore e inserire il nuovo valore. Terminata la modifica del valore e spostato il cursore in una posizione diversa, i vincoli sono verificati e la modifica completata. Pagina 12 di 22


Le Maschere Se abbiamo una tabella in cui si devono inserire un gran numero di record, si possono avere delle difficoltà se inseriamo i dati dalla visualizzazione della tabella in foglio dati. Per rendere più agevole l’operazione d inserimento dati, ci vengono in aiuto le maschere. Una maschera è uno strumento che consente di visualizzare un solo record per volta, in maniera tale che le informazioni in esso contenute risultino più accessibili e quindi più facilmente consultabili e aggiornabili rispetto alla visualizzazione di una tabella. Le maschere sono utili anche perché aiutano a mantenere la riservatezza. L’importante è sapere che in una maschera possono essere visualizzati i dati appartenenti a più tabelle, e quindi la modifica o l’inserimento di un record è più veloce.

Creare una maschera Per creare una maschera si deve, come prima cosa aprire il DB e poi selezionare nella finestra DB la famiglia Maschere e poi cliccare due volte con il tasto sinistro del mouse “Crea una maschera mediante creazione guidata”. Si apre una finestra che consente la creazione della maschera. Con la prima finestra si selezionano i campi che devono comparire nella maschera: si deve indicare il nome della prima tabella da cui prendere i campi nello spazio “Tabelle/Query”. Selezionata la tabella, nel riquadro “campi disponibili” comparirà l’elenco di tutti i campi presenti nella tabella scelta, come in figura 4.

Pagina 13 di 22


Figura 4

Per scegliere i campi sarà sufficiente selezionarli uno alla volta e poi cliccare sul pulsante ”>” per includerli nell’elenco “Campi selezionati”; ripetere questa operazione per selezionare tutti i campi che si vogliono nella maschera. Se nella maschera che si sta costruendo devono comparire tutti i campi di una tabella, sarà sufficiente cliccare sul pulsante “>>”. Se si vogliono annullare tutte le selezioni fatte, sarà sufficiente cliccare sul pulsante “<<”; a questo punto si può o chiudere qui la creazione guidata ( cliccare su “Fine”) o passare alla finestra successiva (cliccare su “Avanti”). La seconda finestra serve per scegliere come visualizzare i dati: elenca le modalità disponibili e presenta nel riquadro a sinistra l’anteprima. Scelto il formato cliccare su “Avanti”. La terza finestra permette di scegliere il layout della maschera, ed anche in questo caso nel riquadro a sinistra è possibile visualizzare l’anteprima; dopo aver selezionato la scelta del Layout, cliccare su “Avanti”. Nell’ultima finestra viene chiesto di dare un nome alla Maschera e stabilire se visualizzare la maschera in modalità inserimento o visualizzarne la struttura. L’opzione di default consente, una volta Pagina 14 di 22


cliccato il tasto “Fine”, di aprire immediatamente la maschera e potere inserire i dati; qualora necessitasse modificare la struttura o il posizionamento dei campi all’interno della maschera, selezionare “modificare la struttura della maschera” e poi sul tasto “Fine”. Operazioni sulle maschere Aprire una maschera: per eseguire operazioni sulle maschere bisogna innanzitutto aprirle; nella finestra del database (Figura 1) cliccare, tra l’elenco oggetti, su “maschere” e poi cliccare due volte sul nome della maschera da aprire, che compare nella parte desta della finestra. Cancellare una maschera: selezionare il nome della maschera da cancellare, selezionare il comando elimina dal menù Modifica o direttamente il tasto “Canc”; prima di cancellare l’oggetto si apre una finestra in cui viene chiesto di confermare l’operazione. Modificare la struttura della maschera: aprire la maschera in visualizzazione struttura , come da Figura 5. In questa visualizzazione è possibile utilizzare una casella degli strumenti che permette di operare, con estrema semplicità, sulle sezioni della maschera (intestazione, corpo, e piè di pagina). Per aprire la casella degli strumenti si deve cliccare nella barra degli strumenti, sull’icona che la rappresenta . Vediamo alcuni esempi: Inserire un’etichetta di testo nell’intestazione della maschera: se, ad esempio, dobbiamo inserire un’etichetta, dalla casella degli strumenti cliccare sul pulsante Etichetta e poi cliccare nel punto dell’intestazione della maschera in cui si vuole inserire il testo, a questo punto si può cominciare a scrivere. L’impostazione di default non visualizza l’area dell’intestazione, per renderla fruibile posizionare il mouse vicino alla linea che separa l’intestazione dal corpo, finché non assume le sembianze di una crocetta con doppia freccia. Tenendo il tasto sinistro del mouse premuto scorrere in basso fino alla larghezza desiderata.

Pagina 15 di 22


Figura 5

Inserire un’immagine nella maschera: se necessita inserire un riquadro con un’immagine all’interno di una delle tre sezioni della maschera (Intestazione, Corpo e Piè di pagina), cliccare sul pulsante immagine e poi cliccare nel punto in cui si vuole inserire l’immagine, a questo punto si apre una finestra di dialogo che permette di scegliere l’immagine da inserire. Inserire un pulsante di comando: se necessita inserire un pulsante di comando all’interno di una delle tre sezioni della maschera (Intestazione, Corpo e Piè di pagina), cliccare sul pulsante relativo e poi nel punto in cui si vuole inserire il pulsante; compare un pannello di gestione delle funzioni associabili al pulsante (come in Figura 6). Da questo pannello è possibile scegliere le “Categorie” di intervento e le azioni per le singole categorie; a sinistra è visibile un’anteprima dell’aspetto estetico che il pulsante avrà. Pagina 16 di 22


Figura 6 Aggiungere campi alla maschera: se in fase di creazione della maschera, non si è scelto di inserire tutti i campi e necessita invece l’inserimento differito di uno o più campi, cliccare sull’icona elenco campi per visualizzare l’elenco dei campi relativi alla tabella d’origine. L’operazione di inserimento del nuovo campo va effettuata con il “Drag & drop” dall’elenco campi al punto della maschera. Modifica della formattazione di un oggetto della maschera (etichette, pulsanti e caselle di testo): selezionare l’oggetto di interesse e scegliere la formattazione desiderata dalla barra degli strumenti di formattazione (Figura 7). Figura 7

Ordine di tabulazione In fase di inserimento dati in una maschera, è auspicabile muoversi tra i campi usando il tasto TAB; questa procedura segue la successione dei campi coerentemente con l’ordine del loro inserimento. Qualora si desiderasse modificarne la successione, basta cliccare con il tasto destro del mouse e scegliere l’opzione “Ordine di tabulazione…” e selezionare la riga del campo da Pagina 17 di 22


spostare facendo click su di essa e trascinarla nella posizione desiderata. Confermare l’operazione con il tasto “OK”. Esplorazione dei record Per questo scopo si usa la barra di navigazione che si trova in basso a sinistra nella maschera. Come si vede nella figura, nella barra di navigazione è evidenziato il numero (2) del record che si sta visualizzando nelle maschera; per muoversi da un record all’altro è sufficiente cliccare su : “<” per visualizzare il record precedente; “|<” per visualizzare il primo record; “>” per visualizzare il record successivo; “|>” per visualizzare l’ultimo record inserito; “>*” per aggiungere un nuovo record. Ordinare i record Cliccare sul campo da utilizzare come criterio di ordinamento e selezionare il pulsante a seconda se l’ordine dovrà essere crescente o decrescente. Eliminare un record Dopo aver visualizzato il record da eliminare selezionare il comando “Elimina record” dal menù “Modifica”, oppure cliccare sul pulsante nella barra degli strumenti. I Filtri In una maschera è possibile filtrare tutti i dati in base a dei criteri predefiniti. Se ad esempio volessi visualizzare nella maschera tutti i discenti di una scuola che sono nati nella città di Palermo, mi basterà cliccare nel campo “città di nascita” e poi cliccare nel menù Pagina 18 di 22


I report I Report sono lo strumento più adatto per ottenere una copia stampata dei dati e delle informazioni ricavate dalle tabelle di Access. La fase di inserimento e modifica dei record presenti in un DB si gestisce direttamente nella tabella o mediante una maschera di inserimento/modifica; se invece si desidera avere una visione globale dei dati, si utilizzano i report. I report di Microsoft Access, per esempio i resoconti annuali delle attività di una scuola (allievi che frequentano di anno in anno, qualifiche conseguite, etc.) sono tipicamente utilizzati per riepilogare e organizzare informazioni, al fine di esprimere un particolare punto di vista e ottemperare ad una specifica esigenza. Nella progettazione di un report è importante considerare l’obiettivo che si desidera raggiungere, il pubblico al quale è destinato e il livello di informazioni che si desidera fornire. Per molti aspetti i report sono simili alle maschere; è possibile generarli per mezzo di creazioni guidate e l’ambiente di progettazione è in gran parte il medesimo; come nelle maschere, è possibile aggiungere etichette, caselle di testo, immagini e altri controlli e naturalmente impostarne le proprietà; si possono visualizzare informazioni di uno o più record provenienti da una o più tabelle o query ed avere più insiemi di intestazioni e piè di pagina. Le maschere e i report hanno in comune lo scopo di fornire agli utenti un accesso, alle informazioni memorizzate nel database, più semplice e mirato. Le principali differenze fra le maschere e i report sono le seguenti: Pagina 19 di 22


Le maschere vengono utilizzate per immettere, visualizzare e modificare informazioni su un record per volta, i report sono usati soltanto per visualizzare/stampare le informazioni di interesse. Le maschere di solito vengono visualizzate sullo schermo, mentre i report possono essere visualizzati in anteprima sullo schermo, ma generalmente vengono stampati. Le maschere forniscono una visione dettagliata dei record e sono rivolte agli operatori che lavorano con il database, mentre i report sono spesso utilizzati per raggruppare e riepilogare dati e sono strumento a supporto informativo di attività aziendali diverse dalla popolazione e modifica del DB. Ad esempio in una struttura scolastica, dove si tiene traccia degli allievi che frequentano di anno in anno, la segreteria userà le maschere per inserire e/o modificare i dati degli allievi e le tipologie corsuali previste; i report forniranno un elenco dettagliato (dov’è possibile scegliere i campi di interesse) in formato cartaceo, della situazione degli allievi ordinandoli per tipo di corso, o per anno di frequenza al fine di estrapolare informazioni utili al soddisfacimento delle esigenze della segreteria.

Ecco come si presenta ad esempio il Report di nome "Anagrafica" tratto dal DB "Elenco allievi stranieri". I record sono stati riepilogati per Paese (Figura 7).

Pagina 20 di 22


Figura 7

Se aprissimo lo stesso Report in visualizzazione struttura anzichĂŠ in modalitĂ anteprima di stampa, ecco come apparirebbe (Figura 8):

Figura 8

Un Report è composto in tutti i casi di 5 Sezioni "base": 1. una Sezione "Intestazione Report" (visualizzata o stampata una sola volta all'inizio del documento); 2. una Sezione "Intestazione Pagina" (visualizzata o stampata invece per ogni pagina del Report); Pagina 21 di 22


3. una Sezione "Corpo" (ripetuta per ogni Record proveniente dalla Tabella o Query "sottostante"); 4. una Sezione "Piè di pagina" (visualizzata o stampata nel fondo di ogni pagina); 5. ed infine una Sezione "Piè di pagina report" (visualizzata o stampata soltanto una volta ed alla fine del documento). In ciascuna Sezione è possibile come al solito inserire controlli di ogni genere, anche se i più comuni sono le etichette e le caselle di testo.

Pagina 22 di 22

Dispensa di Access 2003  

Appunti liberi di informatica; breve guida all'utilizzo di Access nella versione 2003

Read more
Read more
Similar to
Popular now
Just for you