Issuu on Google+

Guía #7 ESTRUCTURAS ALGORÍTMICAS SELECTIVAS

1. La tangente de un ángulo se define como el cociente entre el seno y el coseno de dicho ángulo

Proceso Tangente Escribir 'Ingrese el Angulo' Leer ang Si COS(ang)<>0 Entonces tang<-SEN(ang)/COS(ang) Escribir 'Tangente=',tang Sino Escribir 'El Coseno del Ang debe ser distinto de 0' FinSi FinProceso


Guía #7


GuĂ­a #7 2. En un negocio de productos electrodomĂŠsticos aplica un descuento del 8% a todos aquellos clientes cuya compra es superior a $2,500. Dado como dato el momento de compra del cliente, calcule lo que el mismo debe pagar. Haga el diagrama de flujo correspondiente.

Proceso Descuento

Escribir 'Ingrese el monto de la compra' Leer Comp Si Comp>2500 Entonces Escribir 'Total a pagar con descuento del 8%=',CompComp*0.08 Sino Escribir 'Su compra es Inferior a $2500, no aplica descuento del 8%' FinSi

FinProceso


GuĂ­a #7

3. Dados los datos A, B, C y D que representan nĂşmeros enteros, construya un diagrama de flujo que calcule el resultado de las siguientes expresiones (Si D es igual a 0 que imprima el mensaje que considere apropiado):

(đ??´â&#x2C6;&#x2019;đ??ś)2đ??ˇ

Y

(đ??´â&#x2C6;&#x2019;đ??ľ)3đ??ˇ


Guía #7

Proceso Numeros_enteros Escribir "OPERACION 1 (A-C)^2/D"

Escribir "OPERACION 2 (A-B)^3/D"

Escribir 'INGRESE EL DATO DE A' Leer A Escribir 'INGRESE EL DATO DE B' Leer B Escribir 'INGRESE EL DATO DE C' Leer C Escribir 'INGRESE EL DATO DE D' Leer d Si d<>0 Entonces expresion1=(A-C)^2/d Escribir "EL RESULTADO DE LA OPERACION 1 ES:" expresion1

expresion2=(A-B)^3/d Escribir "EL RESULTADO DE LA OPERACION 2 ES:" expresion2 Sino ESCRIBIR "NO SE PUEDE REALIZAR LA OPERACION, EL DATO DE (D) DEBE SER DIFERENTE DE 0" FinSi FinProceso


Guía #7


GuĂ­a #7

4.

Construya un diagrama de flujo tal que dado como dato el sueldo de un trabajador, calcule su aumento segĂşn el siguiente criterio:

Sueldo < $10,000 $10,000 <= sueldo <= $15,000 Sueldo > $15,000

Aumento 15% Aumento 11% Aumento 8%

Proceso Sueldo_trabajador Escribir "Ingrese el sueldo del trabajador" Leer sueldo Si sueldo<10000 Entonces sueldo1<-sueldo*1.15 Escribir 'Sueldo del trrabajdor es:' '$', sueldo1

FinSi si sueldo>=10000 y sueldo<=15000 Entonces sueldo2<-sueldo*1.11 Escribir 'Sueldo del trabajador es:' '$', sueldo2

FinSi si sueldo>15000 Entonces sueldo3<-sueldo*1.08 Escribir 'Sueldo del tabajador es:' '$', sueldo3 FinSi

FinProceso


Guía #7


GuĂ­a #7

5. Construya un diagrama de flujo tal que dado como datos A y N, compruebe la igualdad de la siguiente expresiĂłn: đ??´â&#x2C6;&#x2019;đ?&#x2018; =1đ??´đ?&#x2018;

proceso Igualdad Escribir 'Programa dise;ado para comprobar la igualdad de estas dos expresiones' Escribir 'A^-N' Escribir '1/A^N' Escribir "" Escribir "Ingrese A" Leer A Escribir "Ingrese N" Leer N Escribir "A^-N el resultado es:",A^(-N) Escribir "1/A^N el resultado es:",1/A^N FinProceso


Guía #7


Guía #7

6. Construya un diagrama de flujo tal que dado como dato Y, calcule el resultado de la siguiente función: 3 = Y +36 Y2 – 10 Y3 + Y2 – 1 0

SI 0 < Y <= 11 SI 11 < Y <= 33 SI 33 < Y <= 64 Para cualquier otro valor de Y

Proceso Numero_mayor_y_menor

Escribir 'Programa para encontrar el numero mayor y menor de 3 numeros ingresados' Escribir 'Ingrese los numeros' Escribir 'Ingrese el primer numero' Leer a Escribir 'Ingrese el segundo numero' Leer b Escribir 'Ingrese el tercer numero' Leer c Si a>b y a>c entonces Escribir 'El numero mayor es:', a FinSi Si b>a y b>c Entonces Escribir 'El numero mayor es:', b FinSi Si c>a y c>b Entonces Escribir 'El numero mayor es:', c FinSi FinProcESO


Guía #7


Guía #7

7.

Dados tres números reales A, B y C, identifique cuál es el mayor. Considere a fin de simplificar el problema que los números son diferentes. Haga el diagrama de flujo correspondiente.


GuĂ­a #7 Proceso operaciones_elementales resp<-0 Escribir 'Programa que desarrolla las operaciones elementales' Escribir 'Ingrese el primer numero' Leer num1 Escribir 'Ingrese el segundo numero' Leer num2 Escribir 'ÂżQue operacion desea hacer?' Escribir '+ suma' Escribir '- resta' Escribir '* multiplicacion' Escribir '/ divicion' Leer op Si op= '+' Entonces resp<-num1+num2 Sino si op= '-' Entonces resp<-num1-num2 FinSi Sino si op= '*' Entonces resp<-num1*num2 FinSi sino si op= '/' Entonces resp<-num1/num2 FinSi FinSi Escribir 'El resultado es:', resp FinProceso


Guía #7


Guía #7


Guía #7

8. Escriba un diagrama de flujo que permita convertir de pulgadas a milímetros, de yardas a metros y de millas a kilómetros. 1 pulgada equivale a 25.40 milímetros 1 yarda equivale a 0.9144 metros 1 milla equivale a 1.6093 kilómetros


GuĂ­a #7

Proceso convertidor rsp<-0 Escribir 'Programa que permite convertir de pulgadas a milimetros, de yardas a metros y de millas a kilometros' Escribir 'ÂżQue desea convertir?' Escribir '1-Pulgadas a milimetros' Escribir '2-Yardas a metros' Escribir '3-Millas a kilometros' Leer conv Escribir 'Ingrese el dato a convertir' Leer dat Si conv=1 Entonces rsp<-dat*25.40/1 Escribir dat,': pulgadas, equivale a:',rsp,' milimetros' Sino Si conv=2 Entonces rsp<-dat*0.9144/1 Escribir dat,': yardas equivale a:',rsp,' metros' Sino Si conv=3 Entonces rsp<-dat*1.6093/1 Escribir dat,': millas equivale a:',rsp,' kilometros' FinSi FinSi FinSi FinProceso


Guía #7


Guía #7


Guia #7