Manual de Access
O que é uma Base de Dados ? Uma Base de Dados é um conjunto de informações que estão relacionadas a um tópico ou propósito em particular. O segredo da armazenagem e recuperação eficiente de seus dados é o processo de Planeamento. Identificando primeiro aquilo que quer que a sua Base de Dados faça, poderá criar um projecto prático que resultará numa ferramenta de gestão de Base de Dados mais precisa e rápida. Podemos implementar uma Base de Dados manualmente utilizando fichas e pastas de arquivos, livros-caixas, etc. Entretanto realidades mais complexas obrigam-nos, com frequência a lançar mão da rapidez e praticidade dos computadores. São exemplos de Base de Dados: • Endereços de clientes num livro de endereço; • Informações sobre vendas de produtos num livro razão; • Formulários sobre funcionários em pastas arquivadas.
Planeamento de uma Base de Dados Quando se cria uma Base de Dados, passa-se primeiro por um processo de Planeamento que identifica para que serve a Base de dados e quais informações que é preciso monitorar. Antes de começarmos, devemos fazer as seguintes perguntas: • Quais as informações que eu quero obter com a minha base de dados? • Sobre que áreas de assunto distintas eu tenho que armazenar informações? • Como essas áreas de assunto relacionam-se mutuamente? • Que informações preciso armazenar sobre cada assunto? O ACCESS ajuda-nos a gerir a Base de Dados fornecendo uma estrutura eficiente para armazenagem e recuperação de informações. O local onde são unidas as informações sobre cada assunto que se decidir acompanhar é uma tabela. Como o ACCESS é um Sistema relacional de gestão de bases de dados, podemos organizar os dados de áreas de assunto diferentes em tabelas, e depois criar relações entre as tabelas. Essa abordagem facilita a reunião dos dados relacionados quando isso for necessário. Estabelecendo relações entre tabelas individuais, em vez de armazenar todas as suas informações numa tabela grande, evitamos excessiva duplicação de dados, economizamos espaço de armazenagem no computador e maximiza a agilidade e precisão do trabalho com os dados. O Microsoft Access utiliza uma marca única, chamada Chave Primária, para identificar cada Registo Chave na sua tabela. Assim como o número da placa identifica um automóvel, a Chave Primária identifica unicamente um registo.
__________________________________________________________________________________________________________________ Pág.1/25 Luís Roque
Manual de Access • Todas as tabela devem possuir no mínimo uma Chave Primária. • Selecionamos o campo ou os campos que compõem a Chave Primária, pelos métodos clicar ou clicar e arrastar. • Alguns campos não são boas Chaves Primárias. Por exemplo, se escolhermos o campo sobrenome para usar como Chave Primária, a tabela não poderá ter dois registos com o sobrenome “Silva” • Em geral, números são boas Chaves Primárias. Por exemplo, um “Numero de Identidade” pode identificar o registo de cada funcionário.
Composição da Base de Dados Uma Base de Dados é composta de quatro itens:
Dado: Dado é tudo aquilo que se deseja armazenar para consultas posteriores. No ACCESS, os dados podem assumir forma de texto, números, datas e figuras. Por exemplo, se se vende caixa de bombons, podemos armazenar os nomes, as figuras e as receitas dos bombons, os preços e a quantidade das caixas, bem como as datas das vendas.
Campo: É a menor unidade de informação da Base de Dados. Nome do Campo
Nome Carla Patrícia Ana Paula
Endereço Rua 21 nº 12 Rua 33 nº 69
Registo: É um conjunto de campos com seus respectivos dados armazenados em uma linha. Dados Armazenados em forma de Registos
Nome Carla Patrícia Ana Paula
Endereço Rua 21 nº 12 Rua 33 nº 69
Tabela: É uma colecção de Registos. Elas organizam dados em Colunas (chamadas Campos) e Linhas (denominadas Registos).
__________________________________________________________________________________________________________________ Pág.2/25 Luís Roque
Manual de Access
Tipos de Relações existentes nas Bases de Dados
Para melhor entender o desenho acima, vejamos o exemplo: A tabela Funcionários contem os nomes de todos os funcionários da empresa, mas a tabela de produto contem somente o numero da matrícula do funcionário que efectuou a venda do produto nesta empresa. Uma vez que se saiba qual a encomenda, é possível saber qual o funcionário que vendeu o produto e emitir-lhe um cheque nominal no valor de sua comissão.
Relacionamentos Um para Um Neste tipo de Relação, um registo na Tabela A não pode ter mais de um único correspondente na Tabela B, e vice-versa. Isto não é comum e pode exigir algumas alterações na criação da sua Base de Dados. Um para Vários Neste tipo de Relação, um registo na Tabela A pode ter vários correspondentes na Tabela B. Isto é comum e demostra a eficiência das Base de Dados Relacionais.
O que é o Access ? O Access é um programa destinado ao controle de informações armazenadas em Bases de Dados. Através dele podemos criar, adicionar, alterar, consultar e excluir dados.
Iniciando o Access Para iniciar o Access é necessário estar dentro do Windows. 1. No Gestor de Programas, dê um clique duplo no ícone do Grupo Microsoft Office. 2. Dê um clique duplo no ícone do programa Microsoft Access. __________________________________________________________________________________________________________________ Pág.3/25 Luís Roque
Manual de Access
Criando uma Base de Dados Quando iniciamos o Access, nenhuma Base de Dados está aberta. Ao abrir uma Base de Dados, o Access exibe a janela Base de Dados, uma caixa contendo os objectos que se armazena na Base de Dados. 1. Para se criar uma Base de Dados, no Menu Arquivo escolha a opção “Novo” ou clique no Botão “Novo”
na Barra de Ferramentas.
2. Na Caixa nome do Arquivo, digite o nome de arquivo da nova Base de Dados, e depois escolha o botão Criar.
Componentes da Base de Dados O Access armazena num único arquivo de extensão MDB, todos os objectos que fazem parte da Base de Dados.
Tipos de objectos: Tabela - Uma colecção de dados de mesmo assunto ou tópico, uma tabela armazena os dados em Registos (linhas) e Campos (colunas) Consulta - Objecto que seleciona registos e campos armazenados nas tabelas. Podemos pensar numa consulta como uma pesquisa num conjunto particular de dados. Formulário - Objecto no qual se colocam controles para a entrada, exibição e edição de dados nos campos.
__________________________________________________________________________________________________________________ Pág.4/25 Luís Roque
Manual de Access Relatório - Objecto que apresenta os dados formatados e organizados segundo as especificações do utilizador. Macro - Objecto que permite automatizar rotinas sem programação. Módulo - Objecto que permite criar uma aplicação utilizando a linguagem de programação Access Basic.
Recursos Importantes - Menus e Barra de Ferramentas O Access tem vários Menus e Barra de Ferramentas. Neste momento estudaremos o Menu e a Barra de Ferramentas da janela Base de Dados. Menu Arquivo - Neste menu são encontradas opções para criar, abrir, salvar, imprimir entre outras opções. Editar - Além das opções padrões do Windows ( copiar, colar, voltar, recortar) encontraremos neste menu o item Relacionamentos. Exibir - Aqui encontraremos as opções Tabela, Consulta, Formulário, Relatório, Macro e Módulo, estes itens correspondem as abas da janela de Base de Dados. Também neste menu encontraremos as opções Barra de Ferramentas e Opções. Segurança - Este menu contem opções avançadas para protecção das Bases de Dados e segurança em rede. Janela - Este é o menu padrão do Windows, nele podemos ordenar e aceder a janelas que não estão visíveis. ? ( Ajuda ) - Um dos menus mais importantes do Access, para maiores informações veja o item Sistema ajuda do Access. Esta opção pode ser acedida através da Barra de Ferramentas, no botão com uma seta e uma interrogação. Barra de Ferramentas Imprimir Abrir
Novo
Módulo Visualizar Impressão
Anexar
Recortar
Copiar
Colar
Relacionamentos Voltar
Ajuda
Consultor Importar Exportar
Ligação com MS-Excel Ligação com MS-Word
Novo Formulário Nova Consuta
Banco de Dados Novo Relatório
Autorelatório Autoformulario
__________________________________________________________________________________________________________________ Pág.5/25 Luís Roque
Manual de Access Posicionando a seta do rato sobre qualquer item da Barra de Ferramentas, imediatamente é mostrada na barra de status (parte inferior da janela do Access) a descrição da função do botão.
Sistema ajuda do Access O Access traz consigo um poderoso Sistema de Ajuda, além da Ajuda on-line . O Sistema de Ajuda pode ser acedido através do menu ” ? ”, dentro deste menu encontramos as seguintes opções: Conteúdo - Por este item terá acesso a um resumo de opções da Ajuda. Localizar ... - Neste item pesquisará uma informação à sua escolha Consultor - O Consultor vem como um auxiliar aos novos utilizadores, explicando os conceitos do Access e dando exemplos. Dentro do Sistema de Ajuda o Access traz embutido o Consultor, uma ferramenta que dá dicas para um trabalho mais eficiente. O Consultor pode ser acedido através do menu ? e pela Barra de Ferramentas no botão onde aparece um cartão com sinal de interrogação ao centro. Além do Sistema de Ajuda o Access tem os Assistentes que fazem a maior parte trabalho de criação, valendo-se de perguntas que deverá responder para que ele possa criar o objecto desejado. Abra o Consultor e escolha a opção Tendo uma visão geral, depois escolha Base de Dados e leia o texto informativo.
Tabelas Definição Uma tabela de uma Base de Dados é uma colecção de dados sobre o mesmo assunto ou tópico. Como numa folha de cálculo, as tabelas são organizadas em linhas e colunas. As linhas, que na folha de cálculo são representadas por um numero, aqui são chamadas de Registo. As colunas que são representadas por letras, aqui são chamadas de Campos.
__________________________________________________________________________________________________________________ Pág.6/25 Luís Roque
Manual de Access
Para criar uma tabela siga os seguintes procedimentos:
O botão novo traz a janela nova tabela onde se escolhe o modo de criação da tabela, pelo Assistente ou Manualmente pelo botão Nova Tabela.
Barra de ferramentas do modo folha de dados da tabela Modo Folha de Propriedades Dados Indices Salvar
Chave Primaria
Inserir Linha
Excluir Linha
Modo Estrutura
Ajuda
Nova Consulta Novo Formulario Novo Relatorio
Banco de Dados
Voltar Consultor Construtor
__________________________________________________________________________________________________________________ Pág.7/25 Luís Roque
Manual de Access
Dentro de uma tabela Nomeando Campos e selecionado Tipos de Dados Pode acrescentar um campo a uma tabela digitando o nome do campo na parte superior da janela Tabela, e depois selecionado o Tipo de Dados do campo. O Tipo de Dados diz ao Access quais os dados que ele deve aceitar no campo. Na Janela Tabela crie os campos e especifique as propriedades para os campos.
A Tabela seguinte mostra exemplos de campos com diferentes tipos de dados e os dados que cada um pode conter: Campo Tipo Dados aceitáveis Nome Texto Silva Preço da Fita Moeda R$ 1,00 Quantidade Disponível Numero 3 Figura Objecto OLE Figura do Paint Brush
Nomeando Campos
__________________________________________________________________________________________________________________ Pág.8/25 Luís Roque
Manual de Access Na coluna Nome do Campo digitamos o Nome do Campo que pode conter até 64 caracteres incluíndo espaços; os Nomes dos Campos devem começar obrigatoriamente com uma letra; não podemos utilizar o . (ponto), ! (exclamação) e [ ] (colchetes). São exemplos válidos para Nome de Campos: Nome do Funcionário Nome_do_Funcionário
Selecionando os Tipos de Dados Para especificar o Tipo do Dado de um Campo, clique com o rato na coluna Tipo de Dado do campo que deseja definir ou alterar o tipo de dado. Nomes dos Tipos de Dados Texto Memorando Número Data/Hora Moeda Contador Sim/Não Objecto OLE
Descrição dos Tipos Qualquer sequência de caracteres com no máximo 255 caracteres Qualquer sequência de caracteres com no máximo 32000 caracteres Valores Numéricos de 1 até 8 bytes Valores de data ou hora Valores Monetários Valor numérico que o Access atualiza automaticamente quando se inclui um registo Valor Lógico Qualquer tipo de dados, folhas do Excel, documentos do Word, figuras do PaintBrush e etc...
O Tipo Numérico se subdivide em cinco tipos descritos abaixo: Tipo Byte Inteiro Inteiro Longo Simples Duplo
Valores aceitáveis 0 a 255 -32768 a 32767 -214783648 a 214783647 -3.4 E+38 a 3.4 E+38 -1.797 E+308 a 1.797 E+308
Casas decimais 0 0 0 7 15
Por padrão o Access coloca o Tipo de Dado como Texto; se quisermos alterar o Tipo do Dado, basta clicar na seta para baixo e uma lista com os Tipos de Dados irá aparecer.
__________________________________________________________________________________________________________________ Pág.9/25 Luís Roque
Manual de Access
Criando Descrição dos campos Ao lado da Coluna de Tipo de Dado encontra-se a coluna Descrição o preenchimento desta coluna é opcional, mas é bom fazer uma pequena descrição do campo para que no futuro quando for feita alguma manutenção na Base de Dados, a pessoa que fizer a manutenção ter comentários da pessoa que criou a Base de Dados. A descrição dos campos é uma informação muito importante e que nos dá um auxílio muito eficiente, pois além de fornecer a uma outra pessoa que for trabalhar no futuro com o seu sistema, o conteúdo desta área é mostrado ao utilizador na linha de status, quando o referido campo for editado numa consulta ou formulário.
Definindo Chave Primária Todas as tabelas da sua Base de Dados devem conter uma Chave Primária - um ou mais campos cujos valores identificam de uma forma exclusiva cada registo da Tabela. As Chaves Primárias ajudam o Access a processar as informações com a maior eficiência possível. Quando se criou a tabela Clientes o campo Código do Cliente foi definido como Contador . Como é sabido o campo contador não se repete, ele começa com o valor 1 e conforme se vai incluindo novos registos o Access vai incrementando o valor do Contador. Se se excluir um registo, o valor do campo contador não é alterado. Para se definir a Chave Primária, deve-se mover o cursor do rato para o campo desejado e dar um clique na área do selector e depois no botão da Chave Primária na Barra de Ferramentas
.
Para definir uma Chave Concatenada, existem duas maneiras de se fazer: se os campos forem um junto do outro, clicamos no selector dos campos desejados e depois no botão da barra de ferramentas; senão, clicamos no selector dos campos utilizando a tecla Ctrl. Modo Folha de Dados
Visualizar Impressao Imprimir
Classificar Localizar Ascendente Classificar Colar Descendente
Copiar
Novo Recortar
Modo Estrutura Definir Filtro
Aplicar Filtro
Retirar Filtro
Nova Novo Consulta Formulario Novo Relatorio
Banco de Dados
Voltar Voltar Registro Auto Relatorio
Auto Formulario
__________________________________________________________________________________________________________________ Pág.10/25 Luís Roque
Manual de Access
Incluindo Registos Para se incluir dados na tabela deve mudar do Modo Estrutura para o Modo Folha de Dados , para fazer isto deverá utilizar os dois primeiros botões do lado esquerdo da Barra de Ferramentas. O botão mais à esquerda representa o Modo Estrutura e o outro o Modo Folha de Dados. Quando mudar para o Modo Folha de Dados, irá notar que como foi dito antes os Campos são as colunas e cada registo que incluir será uma linha. Agora pode começar a digitar os dados da sua tabela e quando chegar no último campo e teclar ENTER irá automaticamente para o próximo registo.
Definindo Propriedades das Tabelas Cada Campo da Tabela tem suas Propriedades, pode utilizar estas Propriedades para controlar como valores que serão digitados nos campos vão ser exibidos ou se são validos. Cada Tipo de Dado tem o seu conjunto de Propriedades, que pode ver na tabela seguinte: Propriedades Tamanho do Campo O número máximo de caracteres pode entrar no campo Formato Seleciona um formato pré-definido para entrada de dados Casas Decimais Numero de casa decimais Máscara de Entrada Um padrão para os dados entrados neste campo Legenda Título do campo Valor Padrão Valor inicial do campo Regra de Validação Expressão que limita valores que podem ser digitados no campo Texto de Validação Mensagem que será exibida sempre que a regra de validação for quebrada Requerido É obrigatória a entrada deste campo Indexado Acelera a procura dos dados Permitir comprimento zero Permite que o campo fique vazio
Anexando e Importando Dados de Tabelas Se já utilizou outro aplicativo de Base de Dados, pode já estar pronto para converter os seus dados para as tabelas do Microsoft Access. Ou pode manter os dados no formato actual e utilizar o Access como uma forma alternativa para visualizar e editar os dados. De ambas as formas, com o Microsoft Access, pode começar a trabalhar com os dados de diversas fontes.
Anexar ou Importar uma Tabela ?
__________________________________________________________________________________________________________________ Pág.11/25 Luís Roque
Manual de Access O Microsoft Access fornece duas opções para usar dados de outra Base de dados. Pode Importar dados para dentro do Access ou pode utilizar os dados no seu formato actual sem importá-los. Se decidir deixar os dados noutra Base de Dados ou formato de dados, irá Anexar as tabelas de outros Bases de Dados dentro do seu Base de Dados do Access. Desta forma não só pode utilizar as tabelas no seu aplicativo original, como também pode utiliza-las da mesma forma que utiliza as tabelas armazenadas no seu Base de Dados do Access. Por outro lado se utilizar os seus dados apenas no Access, deve importa-los. O Access funciona geralmente mais rápido com suas próprias tabelas e pode personaliza-las para que elas atinjam as suas necessidades.
Anexando uma Tabela Externa Tabela anexada é uma cópia de uma tabela criada em outro software que precisa ser manipulada no Access.
Passos para anexar uma tabela: 1. Para anexar uma tabela use no Menu Arquivo a opção Anexar Tabela. 2. Na lista fonte de dados, clique duas vezes no Tipo de Arquivo desejado. 3. Aparecerá a caixa de diálogo Selecionar Arquivo para que seja selecionado o nome do arquivo que será anexado. 4. Após a mensagem “Anexado com sucesso”, feche a caixa de diálogo Selecionar Arquivo pressionando o botão Fechar.
Importando Uma Tabela A Tabela Importada é uma cópia de uma tabela criada noutro Software ou no próprio Access que precisa ser manipulada na sua Base de Dados.
Passos para anexar uma tabela: 1. Para importar uma tabela use no Menu Arquivo a opção Importar Tabela. 2. Na lista fonte de dados, clique duas vezes no Tipo de Arquivo desejado. 3. Aparecerá a caixa de diálogo Selecionar Arquivo para que seja selecionado o nome do arquivo que será importado. 4. Após a mensagem “Importado com sucesso”, feche a caixa de diálogo Selecionar Arquivo pressionando o botão Fechar.
__________________________________________________________________________________________________________________ Pág.12/25 Luís Roque
Manual de Access
Relacionamentos Conceito O Microsoft Access é uma Base de dados relacional, e portanto, pode usar dados de mais de uma tabela de cada vez. Depois de criar as tabelas na Base de Dados, e definir a chave primária de cada uma delas, podemos criar relacionamentos entre as tabelas. Um relacionamento pode ajudar o ACCESS a associar os dados em qualquer nova consulta, formulário ou relatório que inclua duas tabelas relacionadas. Podemos criar dois tipos de relacionamentos no ACCESS: um relacionamento um-para-vários, ou um relacionamento um-para-um; os relacionamentos um-para-vários são sem dúvida os mais comuns. Neste tipo de relacionamento, um registo de uma tabela pode ter muitos registos relacionados na outra tabela.
Por exemplo: Para definir um Relacionamento um para vários entre a Tabela de Funcionários e a Tabela de Produtos, adicione o(s) campo(s) que compõe(m) a Chave Primária da Tabela de Funcionários à Tabela de Produtos. No exemplo da página anterior, adicionamos o campo Vendido por na Tabela de Produtos que corresponde ao campo Matricula na Tabela Funcionários.
Num relacionamento um-para-um, por outro lado, um registo da tabela primária só pode ter um registo na tabela relacionada. Este tipo de relacionamento é menos comum do que os relacionamentos um-para-vários. Uma razão para usar um relacionamento um-para-um seria quando quisesse separar as informações sobre os empregados em dados públicos e restritos. Por exemplo, poderia colocar informações públicas, tais como nomes e cargos, numa tabela, e as informações restritas, tais como salário do empregado, noutra tabela. Essas duas tabelas teriam um relacionamento um-para-um porque cada registo da tabela pública teria somente um coincidente na tabela restrita. Alguns encontros são temporários; outros duram a vida inteira. As relações entre tabelas também são assim. Se quiser ver informações relacionadas de duas tabelas sempre, é possível criar uma relação permanente entre elas. Isto ajuda o Access a associar automaticamente as informações entre duas tabelas sempre que as usar juntas numa consulta, formulário ou relatório. Se não precisa de relações permanentes entre os seus objectos, é possível criar estes relacionamentos temporários, nas consultas em que eles se fizerem necessários.
__________________________________________________________________________________________________________________ Pág.13/25 Luís Roque
Manual de Access
Relação entre duas tabelas Antes de criar um relacionamento entre duas tabelas, elas têm que conter campos coincidentes. Deve relacionar o campo da Chave Primária na tabela primária a um campo coincidente na tabela relacionada. O campo coincidente também pode ser chamado de Chave Estrangeira . Antes de criar um relacionamento, determine qual é a tabela primária e qual é a tabela relacionada. Caso a tabela relacionada não contenha um campo igual (do mesmo tipo de dados) a Chave da tabela primária, acrescente-o a tabela relacionada para que possa criar o relacionamento. Não é possível fazer relacionamentos com campos do tipo Memorando, OLE, Sim/Não. Um campo do tipo Contador só se relaciona com um do tipo numérico se o tamanho do campo numérico for Inteiro Longo . •
•
• •
No menu Editar, escolha Relacionamentos, ou dê um clique no botão Relacionamentos na barra de ferramentas. Aparece então a janela Relacionamentos. Caso já tenha trabalhado anteriormente com relacionamentos nesta Base de Dados, a janela relacionamentos aparece como a salvou pela última vez. Caso esta seja a primeira vez que está editando os relacionamentos nesse Base de Dados, a janela estará vazia e pode aparecer por detrás da caixa de diálogo Adicionar Tabela. Na caixa de diálogo Adicionar Tabela, selecione e adicione todas as tabelas que deseja relacionar. Depois feche a caixa de diálogo Adicionar Tabela. Na janela relacionamentos, arraste o campo a ser relacionado da tabela primária, para a tabela relacionada (a que contêm a chave estrangeira).
Consultas Conceito Uma Consulta define um grupo de dados que com os quais deseja trabalhar.
Características da Consulta Uma consulta permite fazer uma pergunta sobre os dados armazenados nas tabelas. O modo como a consulta é estruturada diz ao Access exactamente quais os dados a pesquisar. A resposta guarda o segredo do poder de uma Base de Dados Relacional. Quando cria uma tabela separada para cada assunto de dados têm-se uma estrutura que dá uma flexibilidade extraordinária no modo como se juntam dos dados relacionados.
__________________________________________________________________________________________________________________ Pág.14/25 Luís Roque
Manual de Access Barra de ferramentas do modo criar das Consultas. Modo SQL
Seleção
Executar
Atualização
Referencia Cruzada
Criação de Tabela
Inserir Tabela
Totais
Nome das Tabelas
Exclusão Anexação
Tipos de Consulta Os principais tipos de Consulta, São: • Consulta Seleção • Consulta Referência Cruzada • Consulta Acção
Como criar uma Consulta 1. Na Janela Base de Dados, dê um clique no Botão do Objecto Consulta. 2. Escolha o Botão Novo.
3. Na Caixa de Dialogo Consulta, dê um clique no botão Nova Consulta.
__________________________________________________________________________________________________________________ Pág.15/25 Luís Roque
Manual de Access
4. Escolha a Tabela ou outra Consulta e pressione o botão Adicionar.
5. Quando já tiver adicionado todas as Tabelas ou Consultas desejadas, pressione o botão Fechar. Por exemplo: “Mostre-me todos os filmes fornecidos pela Warner”.
A resposta da Consulta é chamada de dynaset (todos os filmes comprados da Warner ). Os registos de um dynaset podem conter campos de uma ou mais tabelas.
__________________________________________________________________________________________________________________ Pág.16/25 Luís Roque
Manual de Access
Consulta Seleção • É o tipo de consulta mais comum. • Uma Consulta Seleção é utilizada para visualizar dados de uma ou mais tabelas através de critérios de seleção de campos e registos. • Para se criar qualquer tipo de Consulta, deve-se primeiro criar uma Consulta Seleção, pois ela é base para qualquer outro Tipo de Consulta. Situação Problema: Desejo Consultar o Nome dos clientes com Data de Admissão igual a 1/8/94. Solução: Devemos criar uma consulta selecção para trazer da tabela Clientes somente os Clientes com Data de Admissão igual a 1/8/04. Passos para a criação de uma Consulta Selecção: 1. Incluir tabelas através da janela Adicionar Tabela. 2. Escolher os campos que farão parte da Consulta, através do método Clicar e Arrastar.
3. Escolher a ordenação dos campos.
__________________________________________________________________________________________________________________ Pág.17/25 Luís Roque
Manual de Access
4. Definir critérios para a seleção de registos. 5. Opcionalmente definir o calculo de totais.
Critérios para ter um conjunto de Registos Relacionados Os critérios são digitados na linha de critério ou: e ou na linha OU. Podemos escrever funções lógicas compostas de várias formas: Podemos utilizar na definição de critérios todas as formas de regras de validação: a) > 100 E <=200, no mesmo campo b) Em campos diferentes, Critérios na mesma linha são associados em modo “E”, e em linhas diferentes em modo “OU”.
__________________________________________________________________________________________________________________ Pág.18/25 Luís Roque
Manual de Access
Exemplos de critérios para validação de campos: 1. >=#01/01/92# ou <#01/01/93# , Relaciona todos registos cuja data seja “qualquer dia do ano de 1992. 2. Como “1?/*/2005”, Relaciona todos registos cuja data seja “qualquer dia entre 10 e 19 de qualquer mês, do ano de 2005”. 3. Como “ADM*”” Relaciona todos registos cujo sector comece com ADM. 4. Entre 20 e 40
Só os registos que tem este campo com o valor entre 20-40.
5. Como ”C*ando” Chamando, Cantando, etc... 6. Como “Maria” Relaciona todos registos que tenha Somente Maria. 7. É Nulo
Relaciona todos registos que tem um valor nulo(em branco) neste campo.
8. É Negado Nulo campo.
Relaciona todos registos que tem um valor não nulo(Preenchido) neste
Formulário Conceito Tal como um formulário de papel, que se preenche à mão, um formulário no Access identifica os dados que se deseja obter. No entanto, ele oferece também uma maneira de inserir os dados na sua Base de Dados , de exibi-lo para revisão e imprimi-lo para distribuição. Com o Access, é possível criar formulários fáceis de serem usados e que apresentam as informações do jeito que se precisa. Pode usar uma variedade de elementos de criação (textos, dados, imagens, linhas e cores) para criar seu próprio formulário. Que elementos usar e como utiliza-los fica ao seu critério.
Como funcionam os formulários A maneira mais rápida de se entender como funcionam os formulários é examinando o formulário e a origem de seus dados. Algumas informações em um formulário vêm de sua tabela ou consulta. As informações também podem ser independentes de uma tabela ou consulta, por exemplo, o nome da companhia e o logotipo no topo do formulário. A aparência fica armazenada na sua estrutura.
__________________________________________________________________________________________________________________ Pág.19/25 Luís Roque
Manual de Access
Características de um formulário. 1. Um único formulário pode ser usado para realizar várias operações. Inserir, editar ou deletar dados de uma tabela. 2. Numa entrada de dados em formulários, pode criar listas com opções para o utilizador no lugar da digitação directa dos dados. 3. Um formulário permite calcular totais, conter gráficos ou mesmo outros formulários; existem recursos para melhorar a formatação com uso de cores, fontes de letras e etc. 4. Toda informação contida num formulário está num controle. existem controles ligados a campos de tabelas ou consultas e controles cuja informação fica contida com o formulário. 5. Cada formulário permite atualizar somente uma tabela.
Criação dos tipos de formulários 1. Selecione o objecto formulário na janela Base de Dados, e acione o botão novo para criar um novo formulário.
__________________________________________________________________________________________________________________ Pág.20/25 Luís Roque
Manual de Access
2. O Access envia uma janela solicitando escolher a tabela ou consulta que será utilizada como fonte de dados, bem como o método de criação. 3. Existem duas formas de criar um formulário: A partir de um formulário em branco ou com a ajuda dos assistentes.
Assistentes - O Access possui cinco tipos diferentes de formulários pré-definidos que podem ser utilizados como ponto de partida para a criação de novos lay-outs, são eles: Coluna Simples - Este assistente cria uma formulário com todos os campos um embaixo do outro, como uma coluna. Tabular - Este assistente cria um formulário que exibe cada registo como uma linha de campos. __________________________________________________________________________________________________________________ Pág.21/25 Luís Roque
Manual de Access Gráfico - Este assistente cria um formulário que exibe um gráfico. Principal/Sub-Formulário - Este assistente cria um formulário que contem um outro formulário. Auto-Formulário - Este assistente cria um formulário sem a interação do utilizador, criando automaticamente um formulário tipo Coluna Simples. Situação problema: Desejo criar um formulário para cadastrar os funcionários da minha empresa, o que devo fazer ? Solução: Na janela de Base de Dados, clique no item Formulário, e accione o Botão Novo, escolha o tipo de formulário desejado e siga os passos do Assistente ate que o formulário esteja pronto.
Modificação da Estrutura do Formulário Janela Formulário no modo Estrutura Reguas
Botões da Barra de Ferramentas
Barra de Ferramentas Corpo do Formulário
Campos do Formulário
Barra de Status __________________________________________________________________________________________________________________ Pág.22/25 Luís Roque
Manual de Access Os formulários têm três tipos de formas para serem exibidos, o Modo Folha de Dados, o Modo Formulário e o Estrutura. Modo Folha de Dados - Neste modo as informações são exibida em forma de planilha. Modo Formulário - Este é o modo padrão de exibição do formulário; com uma interface amigável que pode ser configurada. Modo Estrutura - Este modo permite alterar a forma que se vê o formulário, permitido alterar cores e disposição dos campos, etc.
Itens da Barra de Ferramenta Modo Formulário
Tabela
Italico Tamanho da Fonte
Negrito
Caixa de Modulo Ferramentas
Fontes
Centralizar
Alinhar a Esquerda
Paleta de Cores
Alinhar a Direita
Paleta de Cores
Lista de Campos
__________________________________________________________________________________________________________________ Pág.23/25 Luís Roque
Manual de Access
Relatório Conceito Um Relatório é um meio efectivo de apresentarmos os nossos dados como um documento impresso. Embora possamos imprimir formulários e folhas de dados, os relatórios dãonos um melhor controlo sobre o que queremos imprimir, além de permitir uma melhor apresentação dos dados. Um relatório é informação organizada e formatada para uma melhor análise dos dados das nossas tabelas. No Access, podemos utilizar vários elementos num relatório, como linhas, imagens, caixas, gráficos e, lógico, os dados. O uso e a disposição destes elementos ficam ao nosso critério.
Confecção dos tipos de Relatórios Para o ajudar a criar relatórios, o Access possui o Assistente de Relatório. O Assistente de AutoRelatório produz um relatório pré-formatado de coluna simples, sem solicitar nenhuma informação. Os outros assistentes de relatórios fazem perguntas sobre o relatório desejado e criamno a partir das suas respostas. Mesmo que tenha muita experiência na criação de relatórios, deve-se usar o assistente de relatório a fim de se criar um relatório básico, que possa ser usado tal como está ou ser aperfeiçoado segundo suas especificações. Existem duas formas de criar um Relatório: a partir de um Relatório em branco ou com a ajuda dos assistentes. Selecione o objecto Relatório na janela Base de Dados, e acione o botão novo para criar um novo Relatório.
__________________________________________________________________________________________________________________ Pág.24/25 Luís Roque
Manual de Access O Access envia uma janela solicitando escolher a tabela ou consulta que será utilizada como fonte de dados, bem como o método de criação. Assistentes - O Access possui sete tipos diferentes de Relatórios pré-definidos que podem ser utilizados como ponto de partida para a criação de novos lay-outs, são eles: Coluna Simples - Este assistente cria um Relatório com todos os campos um por baixo do outro, como uma coluna. Grupos/Totais - Este assistente cria Relatórios agrupados, e cria totais para cada grupo. Etiquetas de Endereçamento: Este assistente cria Etiquetas para Mala Direta. Resumo: Este assistente cria um relatório que exibe totais para grupos de registos. Tabular: Este assistente cria um relatório que exibe cada registo com uma linha de campos. AutoRelatório: Este assistente cria um relatório simples baseado na tabela ou consulta selecionada. Mesclagem com Word: Este assistente vincula os seus dados com um documento do Word para criar cartas e envelopes personalizados.
Modificação de Estrutura do Relatório Assim como no Formulário, o Relatório tem um Modo Estrutura, que nos permite alterar as características das informações a serem impressas.
__________________________________________________________________________________________________________________ Pág.25/25 Luís Roque