Issuu on Google+

UNIVERSIDAD AUTÓNOMA DE TAMAULIPAS UNIDAD ACADÉMICA MULTIDISCIPLINARIA DE CIENCIAS, EDUCACIÓN Y HUMANIDADES

MULTIMEDIA 2

CATEDRÁTICO Mtro. Daniel Desiderio Borrego Gómez

Cd. Victoria, Tam. México, Agosto de 2011


UAMCEH Multimedia 2

Índice 3 CONOCIENDO FLASH .................................................................................................................................... 3 Requisitos del sistema para la instalación de flash ............................................................................................................... 3 Microsoft Windows ..................................................................................................................................................... 3 Macintosh .................................................................................................................................................................... 3 Instalación y activación de Flash ........................................................................................................................................... 3 Utilización de la página de inicio ........................................................................................................................................... 4 Espacio de trabajo de Flash................................................................................................................................................... 4 La Barra de Menús ....................................................................................................................................................... 6 Barra de Herramientas ................................................................................................................................................ 7 Creación de un documento nuevo ........................................................................................................................................ 8 Apertura de un nuevo documento .............................................................................................................................. 8 Definición de las propiedades del documento ..................................................................................................................... 8 Utilización de la cuadrícula, las guías y las reglas ............................................................................................................... 10 Utilización de la cuadrícula ........................................................................................................................................ 11 Para mostrar u ocultar la cuadrícula de dibujo: ........................................................................................................ 11 Para establecer preferencias para la cuadrícula: ...................................................................................................... 11 Utilización de las guías ........................................................................................................................................................ 11 Para mostrar u ocultar las guías de dibujo: ............................................................................................................... 12 Para activar o desactivar el ajuste a las guías:........................................................................................................... 12 Para mover una guía:................................................................................................................................................. 12 Para bloquear las guías: ............................................................................................................................................. 12 Para establecer preferencias para las guías: ............................................................................................................. 12 Para quitar guías: ....................................................................................................................................................... 13 Utilización de las reglas ....................................................................................................................................................... 13 Para mostrar u ocultar las reglas: .............................................................................................................................. 13 Para especificar la unidad de medida de las reglas para un documento: ................................................................. 13 Utilización de la barra de herramientas .............................................................................................................................. 14 Herramienta Selección (flecha): ................................................................................................................................ 14 Herramienta Línea: .................................................................................................................................................... 14 Herramienta Texto: ................................................................................................................................................... 14 Herramienta Rectángulo: .......................................................................................................................................... 15 Herramienta Lápiz: .................................................................................................................................................... 15 Herramienta Brocha: ................................................................................................................................................. 15 Herramienta Cubo de Pintura: .................................................................................................................................. 15 Herramienta Borrador: .............................................................................................................................................. 15 Herramienta Lazo: ..................................................................................................................................................... 15 Herramienta Pluma: .................................................................................................................................................. 15 Herramienta Subseleccion: ....................................................................................................................................... 15 Herramienta Bote de Tinta: ....................................................................................................................................... 16 Herramienta Cuentagotas: ........................................................................................................................................ 16 Selección de objetos ........................................................................................................................................................... 16 Selección directa. ................................................................................................................................................................ 16 Seleccionar un relleno: .............................................................................................................................................. 16 Seleccionar un tramo de contorno: ........................................................................................................................... 16 Seleccionar todo el contorno: ................................................................................................................................... 16 Seleccionar el contorno y el relleno: ......................................................................................................................... 17 Sumar selecciones: .................................................................................................................................................... 17 Selección por ventana. .............................................................................................................................................. 17 Selección por lazo. ..................................................................................................................................................... 18 Funcionamiento de los vectores ......................................................................................................................................... 19 Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

1


UAMCEH Multimedia 2

Edición de contornos. ......................................................................................................................................................... 19 Mover un vértice. ................................................................................................................................................................ 20 Curvar un segmento. ........................................................................................................................................................... 20 Añadir un vértice. ................................................................................................................................................................ 20 Suavizar y enderezar contornos. ......................................................................................................................................... 20

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

2


UAMCEH Multimedia 2

3 Conociendo Flash Requisitos del sistema para la instalación de flash A continuación se indican el hardware y software necesarios para ejecutar Flash Microsoft Windows Procesador Intel Pentium III a 600 MHz o equivalente Windows 98 SE, Windows 2000 o Windows XP 128 MB de RAM (se recomiendan 256 MB) 190 MB de espacio disponible en disco Macintosh Procesador PowerPC G3 a 500 MHz Mac OS X 10.2.6 128 MB de RAM (se recomiendan 256 MB) 130 MB de espacio disponible en disco

Instalación y activación de Flash La instalación de Flash es un proceso automatizado. Una vez finalizada la instalación, puede ejecutar el programa en el modo de prueba de Flash durante 30 días, o bien puede activar Flash debe activarse a través de Internet o por teléfono para poder utilizarlas y, para hacerlo, necesita el número de serie a menos que seleccione el modo de prueba.

Nota: cuando se instala Macromedia Flash no se sobrescribe ninguna versión anterior de Flash.

Para instalar Flash:

1 Antes de iniciar la instalación, cierre las versiones de Flash que se estén ejecutando. 2 Siga uno de estos procedimientos para iniciar el proceso de instalación: ■ (Windows) Si tiene un CD, insértelo en la unidad de CD. Se reproduce una película Flash que le indica las opciones de instalación del programa.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

3


UAMCEH Multimedia 2

Nota: también puede ejecutar el archivo Flash.exe para iniciar la película Flash, si es necesario. ■ (Macintosh) Si tiene un CD, insértelo en la unidad de CD y haga doble clic en el icono de instalación Utilización de la página de inicio La página de inicio proporciona acceso a las acciones utilizadas con más frecuencia tanto al iniciar una sesión como cuando la ventana de la aplicación no tiene ningún documento abierto. La página de inicio presenta las áreas siguientes: Abrir un elemento reciente permite ver los documentos más recientes. Abrir muestra el cuadro de diálogo Abrir archivo. Crear nuevo ofrece una lista de tipos de archivo que puede seleccionar, para abrir un nuevo archivo con rapidez. Crear a partir de plantilla muestra las plantillas utilizadas con más frecuencia para crear documentos nuevos y permite seleccionar una plantilla de la lista. Ampliar establece un enlace con el sitio Web de Macromedia Flash Exchange, desde donde puede descargar aplicaciones e información adicionales. La página de inicio también puede mostrar información de prueba sobre la conversión, avisos de actualización y otros mensajes de interés. Puede seleccionar si desea visualizar o no la página de inicio.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

4


UAMCEH Multimedia 2

Para ocultar esta página: • En la página de inicio, seleccione No volver a mostrar este mensaje. Para especificar que la página de inicio aparezca de nuevo, siga uno de estos procedimientos: • Seleccione Edición > Preferencias y haga clic en Mostrar página de inicio en la ficha General. Espacio de trabajo de Flash El espacio de trabajo de Macromedia Flash está compuesto por un escenario donde se coloca el contenido multimedia, una barra de herramientas principal con menús y comandos para controlar las funciones de la aplicación, los paneles y un inspector de propiedades para organizar y modificar los elementos multimedia, y una barra de herramientas para crear o modificar gráficos vectoriales.

Inspector de Propiedades

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

5


UAMCEH Multimedia 2

La Barra de Menús

La Barra de Menús tiene como propósito facilitar el acceso a las distintas utilidades del programa. Es similar a la de cualquier otro programa de diseño web o gráfico, aunque tiene algunas particularidades. Veamos los principales Submenús a los que se puede acceder: Archivo: Permite crear nuevos archivos, abrirlos, guardarlos... Destaca la potencia de la utilidad Importar que inserta en la película actual casi todo tipo de archivos (sonidos, vídeo, imágenes e incluso otras películas Flash), o la de Configuración de Publicación desde donde se pueden modificar las características de la publicación. Edición: Es el clásico menú que te permite Cortar, Copiar, Pegar... tanto objetos o dibujos como fotogramas; también permite personalizar algunas de las opciones más comunes del programa. Ver: Además de los típicos Zooms, te permite moverte por los fotogramas y por las escenas. También incluye la posibilidad de crear una cuadrícula y unas guías. Esto se puede seleccionar desde los submenús Cuadrícula y Guías desde donde también se pueden configurar sus opciones. Insertar: Te permite insertar objetos en la película, así como nuevos fotogramas, capas, acciones, escenas... Modificar: La opción Transformar permite modificar los gráficos existentes en la película, y la opción Trazar Mapa de Bits convierte los gráficos en mapas vectoriales. El resto de opciones permite modificar características de los elementos de la animación. Comandos: Permite administrar los Comandos (conjunto de sentencias almacenadas que permiten emular lo que un usuario pueda introducir en el entorno de edición) que hayamos almacenado en nuestra animación, obtener otros nuevos de la página de Macromedia o ejecutar los que ya tengamos. Control: Desde aquí se modifican las propiedades de reproducción de la película. Reproducir, Rebobinar, Probar Película. Ventana: Este menú, además de las opciones clásicas acerca de cómo distribuir las ventanas, incluye accesos directos a TODOS los Paneles. Ayuda: Desde aquí podemos acceder a toda la ayuda que nos ofrece Macromedia, desde el manual existente, hasta el diccionario de Action Script, pasando por tutoriales, lecciones guiadas etc...

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

6


UAMCEH Multimedia 2

Barra de Herramientas

Las herramientas de la barra de herramientas permiten dibujar, pintar, seleccionar y modificar ilustraciones, así como cambiar la visualización del escenario. La barra de herramientas se divide en cuatro secciones: • La sección de herramientas contiene las herramientas de dibujo, pintura y selección. • La sección de visualización contiene herramientas para ampliar y reducir, así como para realizar recorridos de la ventana de la aplicación. • La sección de colores contiene modificadores de los colores de trazo y relleno. • La sección de opciones muestra los modificadores de la herramienta seleccionada, los cuales afectan a las operaciones de pintura o edición de dicha herramienta.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

7


UAMCEH Multimedia 2

Creación de un documento nuevo

Apertura de un nuevo documento 1 Seleccione Archivo > Nuevo. 2 Seleccione Documento de Flash, lea la descripción del tipo de archivo que aparece y, a continuación, haga clic en Aceptar. 3 Seleccione Archivo > Guardar. 4 Asigne el nombre al archivo y guárdelo en el escritorio o en la ubicación que considere oportuna. Se asigna la extensión .fla al archivo. Definición de las propiedades del documento La configuración de las propiedades de un documento generalmente constituye el primer paso en el trabajo de edición. Puede utilizar el inspector de propiedades para especificar la configuración que afecta a toda la aplicación, como por ejemplo la velocidad de reproducción en fotogramas por segundo (fps), el tamaño del escenario y el color de fondo. 1 Si el inspector de propiedades no está abierto, seleccione Ventana > Propiedades.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

8


UAMCEH Multimedia 2

El inspector de propiedades permite ver y cambiar las especificaciones de los objetos seleccionados. Estas especificaciones dependen del tipo de objeto seleccionado. Si selecciona un objeto de texto, por ejemplo, el inspector de propiedades muestra la configuración para ver y modificar los atributos de texto. Puesto que acaba de abrir un documento nuevo, el inspector de propiedades muestra la configuración del documento. Nota: si el inspector de propiedades no se ha expandido totalmente, haga clic en el triángulo blanco situado en la esquina inferior derecha. 2 En el inspector de propiedades, verifique que 12 es el número del cuadro de texto Velocidad de fotogramas. La aplicación se reproducirá a 12 fotogramas por segundo, una velocidad óptima para reproducir animaciones en la Web. 3 El cuadro Color de fondo indica el color del escenario. Haga clic en la flecha abajo en el cuadro Color de fondo y, a continuación, mueva la herramienta Cuentagotas sobre las muestras de color para ver sus valores hexadecimales en el cuadro de texto Hexadecimal. 4 Busque y haga clic en la muestra de color con el valor hexadecimal deseado.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

9


UAMCEH Multimedia 2

Utilización de la cuadrícula, las guías y las reglas La mayoría de los programas de diseño grafico permiten a los usuarios aplicar guías para alinear objetos o medir distancias precisas entre los elementos. Las reglas pueden utilizarse para separar o alinear objetos específicos a distancias exactas en el escenario. Para ayudarle a alinear los elementos del escenario, flash también posee guías que se pueden extraer de las reglas Flash incluye reglas y guías que ayudan a dibujar y diseñar objetos de manera precisa. Puede colocar guías en un documento y ajustar objetos a las mismas o activar la cuadrícula y ajustar objetos en ésta. Nota: asimismo puede ajustar objetos a otros objetos o a píxeles, o alinear objetos utilizando determinados límites de tolerancia de ajuste. Véase “Ajuste” en el apartado Utilización de Flash de la Ayuda.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

10


UAMCEH Multimedia 2

Utilización de la cuadrícula Cuando aparece la cuadrícula en un documento, se muestra como un conjunto de líneas detrás de la ilustración en todas las escenas. Puede ajustar los objetos a la cuadrícula, así como modificar el tamaño de la cuadrícula y el color de las líneas que la componen. Para mostrar u ocultar la cuadrícula de dibujo: • Seleccione Ver > Cuadrícula > Mostrar cuadrícula. Para activar y desactivar el ajuste a las líneas de la cuadrícula: • Seleccione Ver > Ajuste > Ajustar a cuadrícula. Para establecer preferencias para la cuadrícula: 1 Seleccione Ver > Cuadrícula > Editar cuadrícula. 2 En Color, haga clic en el triángulo del cuadro de color y seleccione un color para las líneas de la cuadrícula en la paleta. El color predeterminado de las líneas de la cuadrícula es gris. 3 Seleccione o anule la selección de la opción Mostrar cuadrícula para mostrar u ocultar la cuadrícula. 4 Seleccione o anule la selección de Ajustar a cuadrícula para activar o desactivar el ajuste a las líneas de la cuadrícula. 5 Para el espaciado de la cuadrícula, introduzca valores en los cuadros de texto situados a la derecha de las flechas verticales y horizontales. 6 En Precisión de ajuste, seleccione una opción del menú desplegable. 7 Si desea guardar la configuración actual como predeterminada, haga clic en Guardar predeterminado. Utilización de las guías Si las reglas son visibles, puede arrastrar las guías horizontales y verticales de las reglas en el escenario. Puede mover, bloquear, ocultar y quitar las guías. También puede ajustar objetos a las guías y cambiar el color de las guías y la tolerancia al ajuste (a qué distancia máxima deben estar los objetos para ajustarlos a una guía). Las reglas que pueden arrastrarse aparecen únicamente en la línea de tiempo en la que se han creado. Puede quitar todas las guías del modo de edición actual: modo de edición de documentos o modo de edición de símbolos. Si quita las guías del modo de edición de documentos, desaparecen todas las guías del documento. Si quita las guías del modo de edición de símbolos, desaparecen todas las guías de todos los símbolos.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

11


UAMCEH Multimedia 2

Para mostrar u ocultar las guías de dibujo: • Seleccione Ver > Guías > Mostrar guías. Nota: si la cuadrícula está visible y la opción Ajustar a cuadrícula está activada, al crear guías, éstas se ajustarán a la cuadrícula. Para activar o desactivar el ajuste a las guías: • Seleccione Ver > Ajuste > Ajustar a guías. Nota: el ajuste a las guías tiene prioridad sobre el ajuste a la cuadrícula, en caso de que haya guías entre las líneas de la cuadrícula. Para mover una guía: • Utilice la herramienta Flecha para arrastrar la guía. Para quitar una guía: • Con las guías desbloqueadas, utilice la herramienta Flecha para arrastrar la guía a la regla horizontal o vertical. Para más información sobre cómo bloquear y desbloquear guías, consulte el procedimiento que se describe a continuación. Para bloquear las guías: • Seleccione Ver > Guías > Bloquear guías. Nota: también puede utilizar la opción Bloquear guías del cuadro de diálogo de preferencias de las guías. Consulte el procedimiento siguiente. Para establecer preferencias para las guías: 1 Seleccione Ver > Guías > Editar guías y siga uno de estos procedimientos: ■ En Color, haga clic en el triángulo del cuadro de color y seleccione un color para las líneas de la guía en la paleta. El color predeterminado de la guía es el verde. ■ Seleccione o anule la selección de la opción Mostrar guías para mostrar u ocultar las guías. ■ Seleccione o anule la selección de Ajustar a guías para activar o desactivar el ajuste a las guías. ■ Seleccione o anule la selección de Bloquear guías para bloquear y desbloquear las guías. ■ En Precisión de ajuste, seleccione una opción del menú desplegable. ■ Si desea quitar todas las guías, haga clic en Borrar todo. ■ Con la opción Borrar todo, se quitan todas las guías de la escena actual. Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

12


UAMCEH Multimedia 2

■ Si desea guardar la configuración actual como predeterminada, haga clic en Guardar predeterminado. 2 Haga clic en Aceptar. Para quitar guías: • Seleccione Ver > Guías > Borrar guías. Si está utilizando el modo Editar documento, desaparecerán todas las guías del documento. Si está utilizando el modo Editar símbolos, desaparecerán sólo las guías que se utilicen en los símbolos. Utilización de las reglas Si se muestran las reglas, éstas aparecen en la parte superior y a la izquierda del documento. Puede cambiar la unidad de medida que se utiliza en las reglas; la unidad predeterminada es píxeles. Al mover un elemento en el escenario con las reglas visibles, aparecerán unas líneas en las reglas indicando las dimensiones del elemento. Para mostrar u ocultar las reglas: • Seleccione Ver > Reglas. Para especificar la unidad de medida de las reglas para un documento: • Elija Modificar > Documento y seleccione una opción del menú emergente situado en la esquina superior derecha.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

13


UAMCEH Multimedia 2

Utilización de la barra de herramientas Las herramientas se pueden seleccionar haciendo clic en la barra de herramientas o mediante métodos de teclado abreviados.

Para seleccionar una herramienta, siga uno de estos procedimientos: • Haga clic en la herramienta que desea utilizar. Según la herramienta que seleccione, puede que aparezca un conjunto de modificadores en el área de opciones situada en la parte inferior de la barra de herramientas. • Utilice el método abreviado del teclado para la herramienta. • Para seleccionar una herramienta situada en el menú emergente detrás de una herramienta visible, haga clic en el icono de la herramienta visible y seleccione otra herramienta del menú emergente.

En la parte izquierda de la ventana podemos observar barra de herramientas que vamos a utilizar para lograr nuestra animación. Aquellos que ya han utilizado algún programa gráfico reconocerán todas las herramientas. La Barra de Herramientas contiene todas las Herramientas necesarias para el dibujo. Veamos cuáles son las más importantes y cómo se usan:

Herramienta Selección (flecha): . Es la herramienta más usada de todas. Su uso principal es para seleccionar objetos. Permite seleccionar los bordes de los objetos, los rellenos, los bordes, zonas a nuestra elección... Además, su uso adecuado puede ahorrarnos tiempo en el trabajo.

Herramienta Línea: Permite crear líneas rectas de un modo rápido. Las líneas se crean como en cualquier programa de dibujo, se hace clic y se arrastra hasta donde queramos que llegue la línea recta. Una vez creada la podemos modificar sin más que seleccionar situar el cursor encima de los extremos para estirarlos y en cualquier otra parte cercana a la recta para curvarla.

Herramienta Texto: Óvalo: sencilla.

Crea un texto en el lugar en el que hagamos clic. Herramienta

La herramienta Círculo permite trazar círculos o elipses de manera rápida y

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

14


UAMCEH Multimedia 2

Herramienta Rectángulo: Su manejo es idéntico al de la Herramienta circulo, tan solo se diferencian en el tipo de objetos que crean.

Herramienta Lápiz: Permite dibujar líneas con la forma que decidamos, modificando la forma de estas a nuestro gusto. El color que aplicará esta Herramienta se puede modificar, en Colores en la Barra de Herramientas.

Herramienta Brocha: Su funcionalidad equivale a la del lápiz, pero su trazo es mucho más grueso. Se suele emplear para aplicar rellenos. Se puede modificar su grosor y forma de trazo.

Herramienta Cubo de Pintura: Permite aplicar rellenos a los objetos que hayamos creado. Al contrario que muchos otros programas de dibujo, no permite aplicar rellenos si la zona no está delimitada por un borde.

Herramienta Borrador: Su funcionamiento es análogo a la Herramienta Brocha. Pero su función es la de eliminar todo aquello que "dibuje". Herramienta Lazo: Su función es complementaria a la de la Herramienta Flecha. Al seleccionar esta Herramienta, en el Panel Opciones aparecen estas imágenes: . Esto, es la Herramienta "Varita Mágica", tan popular en otros programas de dibujo. Permite hacer selecciones según los colores de los objetos. El tercer dibujo que aparece es este:

permite hacer selecciones poligonales.

Herramienta Pluma: Crea polígonos (y por tanto rectas, rectángulos...) de un modo sencillo. Mucha gente encuentra esta herramienta complicada, aunque es una de las más potentes que ofrece Flash. Su empleo consiste en hacer clic en los lugares que queramos definir como vértices de los polígonos, lo que nos asegura una gran precisión. Para crear curvas, hay que señalar los puntos que la delimitan y posteriormente trazar las tangentes a ellas. Con un poco de práctica se acaba dominando.

Herramienta Subseleccion: Esta Herramienta complementa a la Herramienta Pluma, ya que permite mover o ajustar los vértices que componen los objetos creados con dicha herramienta.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

15


UAMCEH Multimedia 2

Herramienta Bote de Tinta: Se emplea para cambiar rápidamente el color de un trazo. Se aplica sobre objetos, si tienen borde, cambia al color mostrado de dicho borde.

Herramienta Cuentagotas: posteriormente podamos utilizarlos.

Su

misión

es

"Capturar"

colores

para

que

Selección de objetos Para llevar a cabo cualquier transformación de los objetos del escenario, primero debemos seleccionarlos. Antes de ver cómo editar y trabajar con los diferentes tipos de vectores primero aprenderemos a seleccionarlos. Las herramientas para seleccionar formas son la Flecha y el Lazo

.

Selección directa. La herramienta de selección Flecha permite seleccionar objetos. Seleccionar un relleno: presionamos sobre cualquier punto del relleno del objeto.

Seleccionar un tramo de contorno: los contornos son segmentos definidos por dos vértices. presionamos sobre cualquier punto del contorno o segmento para seleccionarlo.

Seleccionar todo el contorno: presionamos dos veces seguidas con la herramienta Flecha sobre cualquier punto del contorno.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

16


UAMCEH Multimedia 2

Seleccionar el contorno y el relleno: presionamos dos veces seguidas con la herramienta Flecha sobre cualquier punto del relleno.

Sumar selecciones: si necesitamos seleccionar más de un objeto del escenario, emplearemos cualquier modo de selección anterior y mantendremos pulsada la tecla SHIFT.

Otra manera de seleccionar el objeto es mediante la utilización de la misma herramienta Flecha para enmarcar un área alrededor de ellos. Selección por ventana. 1. Colocamos la herramienta Flecha fuera de los puntos u objetos a seleccionar. 2. Pulsamos el botón del ratón y arrastramos para definir el rectángulo que englobará todos los puntos deseados.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

17


UAMCEH Multimedia 2

3. Soltamos el botón del ratón y ya tendremos nuestros puntos seleccionados de una vez.

Al seleccionar por ventana o marco podemos incluir sólo una parte o área del objeto. De esta forma tenemos la posibilidad de "cortar" ese objeto por la selección. (Para mover una selección arrastrar con la herramienta Flecha).

A veces, según qué tipo de dibujo estemos realizando, nos será casi imposible enmarcar las áreas que deseemos seleccionar con un marco rectangular. Para ello disponemos de la herramienta Lazo. Selección por lazo. 1. Activamos la herramienta Lazo del panel Herramientas. 2. Colocamos la herramienta fuera de los puntos a seleccionar. 3. Pulsamos el botón del ratón y empezamos a "dibujar" el área con la que englobaremos los puntos deseados.

4. Soltamos el botón del ratón y ya tendremos nuestros puntos seleccionados.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

18


UAMCEH Multimedia 2

Funcionamiento de los vectores Los vectores presentan un funcionamiento muy característico. Cuando superponemos dos vectores de colores diferentes "se cortan unos a otros", es decir, la forma situada por encima corta la parte de la forma que se encuentra por debajo. Si ambas formas disponen del mismo color de relleno y contorno se fusionan originando un único vector o una nueva forma. Veamos dos ejemplos.

Superponemos dos objetos y al desplazar el rectángulo vemos que el círculo queda recortado por el área donde se superponían.

Al superponer dos vectores (en este caso dos rellenos del mismo color y sin contorno) se fusionan formando una nueva forma. Edición de contornos. Una vez dibujado un objeto, podemos modificar los objetos con la herramienta Flecha. El resultado será una nueva figura. 1. Activaremos la herramienta Flecha del panel Herramientas . 2. Situamos la herramienta sobre el contorno que queremos variar para curvarlo o sobre un vértice para desplazarlo.

Veamos cada una de las posibilidades.

Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

19


UAMCEH Multimedia 2

Mover un vértice. 1. Situamos la herramienta Flecha sobre el vértice que queramos modificar hasta que aparezca, junto con la herramienta, un símbolo a manera de esquina indica que nos encontramos sobre el vértice. 2. Arrastramos para desplazar el vértice preciso hasta la nueva posición.

. Nos

3. El resultado es una nueva forma. Curvar un segmento. 1. Situamos la herramienta Flecha sobre el segmento hasta que aparezca una pequeña curva junto con la herramienta 2. Arrastramos y curvamos el lado.

.

3. El resultado es una nueva forma. Añadir un vértice. 1. Activamos la herramienta Flecha del panel Herramientas. 2. Colocamos la Flecha en el punto del contorno en el que queremos añadir el nuevo vértice. 3. Pulsamos la tecla Alt y arrastramos.

4. El resultado es una nueva forma. Suavizar y enderezar contornos. Suavizar un contorno. (Botón suavizar de la barra de herramientas), cada vez que pulsamos, conseguimos que las curvas de un contorno sean más suaves (eliminación de vértices).Enderezar contornos. (Botón enderezar de la barra de herramientas), cada vez que pulsamos, las curvas tienden a vectores rectos. Mtro. Daniel D. Borrego Gómez

e-mail linuxppp@hotmail.com

20


Multimedia II Unidad 3