Issuu on Google+

Práctica 4.- Diseña y Elabora Algoritmos y Pseudocódigos Gutiérrez

Molina

Apellido Paterno

20137328 No. de Cuenta

José Alberto

Apellido Materno

2”B”

Nombre(s)

11/04/2014

Grupo

17

Fecha

No. de Lista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema 1: Mostrar en pantalla el factorial de cualquier número, introducido desde el teclado.. Inicio Inicio n = 1 x 2 x 3 x 4 x 5 x… x (n-1) x n. Factorial = 1; El número elegido para el factorial es el 30 Numero=30; (Numero!=0) Factorial=factorial*numero Factorial 1); si n=0 Entonces el factorial es 1 si( n > 1) entonces (n-1)! x n Factorial (double numero) (numero=0) Numero * factorial (numero-1); (Factorial)(40); Fin

Numero

Fact=1 Cont= 1 Fact = Fact x Cont Cont = Cont + 1

SI Cont<=num N Fact

Fin


Problema 2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%.

1. Inicio 2. proceso calculo de horas 3. escribir “obtener el número de horas que trabajo 4. Leer numhoras 5. Escribir “a cuanto le pagan cada hora” 6. Leer costoxhora 7. Descuento=(numhoras*costoxhora)*.12 8. Total=(numhoras*costoxhora)-descuento 9. Escribir “El total que recibe el trabajador” 10. Escribir total 11. Fin

Inicio

CAL.A

A=b*x-12%

A

Fin

Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I.

II.

III.

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.

1.-proceso promedios 2.-Leer b1, b2, b3, b4 3.-Promedio= (b1+b2+b3+b4)/4


4.-Si promedio>=8 entonces 5.-Imprime promedio 6.-Finsi 7.-Si promedio <8 entonces 8.-Imprimir “Te vas a ordinario (primera vuelta) 9.-Fin si 10.-Leer pv 11.-Si p2=(pv+promedio)/2 12.-Si p2>=6 entonces 13.-Imprimir p2 14.-Fin si 15.-Si p2<6 entonces 16.-Imprimir “Te vas a extraordinario (segunda vuelta) 17.-Finsi 18Leer sv 19.-Pfinal=(sv+promedio)/2 20.-Imprimir “tu calificación final”pfinal 21.-Fin

Inicio

Suma, División, Bimestres (1,2,3,4)

Promedio=suma de los bimestres(1,2,3,4)

Promedio = División de la suma

Promedio

Fin


Práctica 4