Issuu on Google+

MATHCAD 2000

1

MATHCAD 2000 1. Wprowadzenie Mathcad 2000 to profesjonalny program matematyczny służący do rozwiązywania różnego typu zagadnień inżynierskich. Umożliwia prowadzenie zaawansowanych obliczeń numerycznych, jak również przekształceń symbolicznych (m.in. symboliczne obliczenia pochodnych, całek i granic funkcji), czyli operacji związanych z analizą matematyczną. W porównaniu do konkurencyjnych produktów Mathcad zajmuje szczególną pozycję. Pomimo faktu, że w obliczeniach numerycznych jest słabszy od Mathlaba a w obliczeniach symbolicznych wyraźnie ustępuje Mathematice, to jednak wyróżnia się z pośród innych pakietów: • łatwością obsługi, • pracą zbliżoną do naturalnych rachunków prowadzonych na kartce papieru, • symboliczną prezentacją tworzonych wzorów (zgodną z ogólnie panującymi zwyczajami), • wygodnym tworzeniem wykresów, • operowaniem i przeliczaniem jednostek miar, • pełnym wykorzystaniem graficznego środowiska systemów Windows.

Obszar roboczy Mathcad używa standardowego interfejsu Windows (zob. rysunek powyżej), dlatego w niniejszym kursie pominiemy oczywiste elementy „klikologii i klawiszologii stosowanej”, a skupimy się na charakterystycznych dla Mathcada operacjach edycyjnych. Naszym głównym celem jest zapoznanie się z ogromnymi możliwościami pakietu i zrozumienie specyfiki obliczeń numerycznych (np. źródeł powstawania błędów numerycznych).


MATHCAD 2000

2

Jak widać na przedstawionym rysunku, okno robocze Mathcada zawiera oprócz menu głównego różne paski narzędzi, które podobnie jak w aplikacjach MS-Office można dowolnie rozmieszczać na pulpicie. Korzystanie z tych narzędzi odbywa się w standardowy sposób, to jest poprzez kliknięcie myszą lub zastosowanie odpowiedniego skrótu z klawiatury. Mathcad stosuje specyficzny sposób edycji wyrażeń matematycznych, podobny do używanego w programie Word edytora równań – tu również operujemy tzw. kursorem dwuwymiarowym, który oprócz punktu wstawiania pokazuje zakres aktywnego argumentu (szczegóły podane zostaną w przykładach). Regiony Wszystkie dane (wzory, wyniki, wykresy) są przechowywane w prostokątnych polach zwanych regionami. W odróżnieniu od komórek Excela mogą one zajmować dowolną pozycję na arkuszu roboczym. Regiony przeznaczone są przede wszystkim do przechowywania wzorów matematycznych ale mogą również zawierać zwykły tekst (komentarze itp.), grafikę (np. wykresy funkcji) oraz obiekty osadzone – tworzone przez inne aplikacje Windows. Należy wspomnieć, że sposób rozmieszczenia regionów ma wpływ na kolejność wykonywanych operacji i widzialność definiowanych przez użytkownika zmiennych, powinien więc być dopasowany do realizowanego algorytmu obliczeniowego. Mathcad przelicza kolejne regiony w naturalny sposób, począwszy od lewego górnego rogu „idąc” w prawo i w dół. (Wyjątkiem od tej zasady są tzw. zmienne globalne, o których dowiemy się z przykładów).

2. Informacje podstawowe – przegląd Punkt niniejszy stanowi przegląd operatorów, klawiszy funkcyjnych i narzędzi stosowanych w Mathcadzie. Pomyślany został jako mała ściąga pomocna przy realizacji przykładów prezentowanych na ćwiczeniach. Zanim zadasz pytanie prowadzącemu zajęcia zajrzyj tutaj i spróbuj samodzielnie znaleźć odpowiedź. Pamiętaj, że podane tu informacje są wybiórcze, gdyż mają jedynie ułatwić początki pracy z Mathcadem. Szczegółowe i pełniejsze informacje należy szukać w systemie pomocy „Resource Center”. Zamiast żmudnego czytania tego punktu zacznij po prostu pracę z Mathcadem i naucz się efektywnie posługiwać wbudowanym systemem pomocy. Podstawowe operatory Wykaz stosowanych w Mathcadzie operatorów i odpowiadających im klawiszy funkcyjnych przedstawiono w załączniku 1. Większość podanych tam skrótów klawiaturowych nie trzeba pamiętać gdyż można je zastąpić kliknięciem odpowiedniej ikonki z pasków narzędziowych lub z menu głównego. Operowanie myszką jest jednak wolniejsze i często mniej wygodne, dlatego warto chociaż pobieżnie zapoznać się z przedstawioną tabelą i zapamiętać kilka kluczowych skrótów klawiaturowych. Przegląd pozostałych klawiszy funkcyjnych można znaleźć w systemie pomocy „Resource Center” (hasło: keyboard help).


MATHCAD 2000

3

Wybrane funkcje wbudowane System Mathcad dysponuje ogromną liczbą wbudowanych funkcji matematycznych, takich jak: • funkcje trygonometryczne, sin, cos, tan, cot • wykładnicze exp, log, ln • wektorowe, max, min, matrix, diag, rows, cols • statystyczne, normal, gamma. Istnieją ponadto funkcje-procedury dedykowane do rozwiązywania konkretnych zagadnień. Ich używanie jest już trudniejsze i wymaga pewnej wiedzy z metod numerycznych, jednak im właśnie należy poświęcić więcej czasu aby móc w pełni korzystać z potencjału obliczeniowego Mathcada. Na początek podajemy tylko dwa przykłady: lsolve(A, v) – rozwiązywanie układu równań liniowych, find(x1, x2, ...) – poszukiwanie rozwiązania równań nieliniowych. Predefiniowane zmienne globalne π = 3.14159... e = 2.71828... ORIGIN = 0 – definiuje początkowy indeks pierwszego elementu wektorów i macierzy TOL = 10-3 – dopuszczalny błąd względny przy obliczaniu całek, rozwiązywaniu równań, itp. Definiowanie własnych zmiennych i funkcji Kluczową rolę w obliczeniach prowadzonych w Mathcadzie odgrywa możliwość definiowania własnych zmiennych i funkcji. Raz zdefiniowaną zmienną lub funkcję można używać wielokrotnie upraszczając i zwiększając przejrzystość obliczeń. Zmienne (lub funkcje) mogą mieć zasięg lokalny lub globalny. Zmienne lokalne widziane są na prawo i poniżej definicji, natomiast zmienne globalne widziane są w całym arkuszu niezależnie od miejsca ich definicji. Definicja zmiennej lokalnej ma postać: nazwa_zmiennej_lokalnej := wartość (lub ogólniej - wyrażenie), a zmiennej globalnej: nazwa_zmiennej_globalnej ≡ wartość. Operatory ”:=” i ”≡” uzyskujemy poprzez wpisanie z klawiatury odpowiednio dwukropka ”:” lub tyldy ”~” – Mathcad automatycznie przekształca wpisane znaki do postaci wyświetlanej powyżej. Wartości zmiennych lokalnych można zmieniać w trakcie obliczeń – zmienna może przechowywać różne wartości w kolejnych etapach obliczeń – nowa definicja niszczy starą. Uwaga: Mathcad rozróżnia wielkie i małe litery a nawet rodzaj zastosowanej czcionki. Na przykład zmienne: abc, ABC oraz abc oznaczają trzy różne wielkości. Obliczenia symboliczne kontra numeryczne Mathcad dysponuje dwoma niezależnymi mechanizmami przetwarzania danych: • obliczenia numeryczne – stosowane w typowych zagadnieniach inżynierskich, gdzie głównym celem jest znalezienie rozwiązania w postaci konkretnych wartości liczbowych, wyrażenie = wynik w postaci liczby (klaw. =) • obliczenia symboliczne – stosowane przede wszystkim w analizie matematycznej, w której (o ile to możliwe) staramy się uzyskać rozwiązanie w postaci zwięzłego wzoru matematycznego wyrażenie → wynik w postaci wzoru (klaw. Ctrl+. lub Shift+Ctrl+.)


MATHCAD 2000

4

W wielu przypadkach możemy stosować obydwie metody zamiennie lub równolegle, jednak istnieją klasy zagadnień do rozwiązania których prowadzi tylko jedna z nich. Na przykład pochodne lub całki nieoznaczone obliczamy w sposób symboliczny, podczas gdy rozwiązanie równania przestępnego możemy (w ogólnym przypadku) przeprowadzić jedynie na drodze numerycznej. Warto zauważyć, że obliczenia symboliczne pozwalają na lepszą ocenę jakościową wyników, ale są kosztowne i nie zawsze możliwe do przeprowadzenia. Jednostki miar Jedną z wyróżniających cech Mathcada jest automatyczne przeliczanie różnych jednostek miar. Mathcad rozpoznaje systemy miar m.in.: SI (m, s, kg,...), CGI (cm, sec, gm,...), US (ft, sec, lb,...). Jednostkę miary dodajemy bezpośrednio po liczbie (lub wyrażeniu) z użyciem lub bez operatora mnożenia (szczegóły podane będą w przykładach). Możemy definiować własne jednostki miar – jako pochodne od miar pierwotnych. Wykaz predefiniowanych miar i odpowiadających im skrótów znaleźć można w Resource Center (hasło: units and dimensions). Liczby zespolone Mathcad stosuje powszechną notację liczb zespolonych: a + b⋅i, lub a + b⋅j. Literę „i” lub „j” należy podać podobnie jak jednostkę miary zaraz po liczbie (lub wyrażeniu), jednak nie można ich stosować oddzielnie, tzn. litera i (lub j) musi być poprzedzona wyrażeniem, w szczególnym przypadku liczbę urojoną i zapisujemy jako 1i. Mathcad automatycznie rozpoznaje zespolone argumenty w operatorach i funkcjach oraz stosuje zespolone odpowiedniki tych funkcji. Zmienne zakresowe – obliczenia iteracyjne Szczególnym typem zmiennych w Mathcadzie są zmienne zakresowe „od..do”, służące przede wszystkim do obliczeń cyklicznych lub iteracyjnych. Typowym ich zastosowaniem jest tablicowanie wartości funkcji lub obliczanie sum szeregów. Mają również zastosowanie w różnego rodzaju operacjach macierzowych. Zmienne zakresowe definiujemy w postaci: x := x1, x2 .. x3

(zamiast dwóch kropek .. używamy średnika ;)

gdzie x jest nazwą definiowanej zmiennej, x1 i x3 oznaczają początek i koniec zakresu, a x2 (opcjonalne) określa w sposób pośredni przyrost kolejnych elementów ciągu. Na przykład do stablicowania funkcji f(x) w przedziale od 1 do 5 co 0.2 wygodnie jest zdefiniować następującą zmienną zakresową: x := 1, 1.2 .. 5. Po wpisaniu formuły „f(x) =” Mathcad poda wszystkie wyniki (dla kolejnych x) w postaci tablicy. Wektory i macierze Wiele zagadnień matematycznych zapisać można w zwartej notacji macierzowej. Mathcad umożliwia definiowanie wektorów i macierzy na wiele różnych sposobów. Typowe operacje algebraiczne jak dodawanie czy mnożenie macierzy zapisujemy w naturalny sposób, korzystając ze standardowych operatorów +, -, *, itd. Jednak istnieje wiele specyficznych operatorów mających zastosowanie jedynie dla zmiennych wektorowych lub macierzowych. Najważniejsze z nich zostały przedstawione w załączniku 1, w sekcji operacje macierzowe. Szczegółowe informacje dotyczące problematyki notacji macierzowej w Mathcadzie zostaną pokazane w przykładach. Uwaga: Domyślnie, początkowy indeks wektorów i macierzy w Mathcadzie zaczyna się od 0 a nie od 1, można go zmienić poprzez przedefiniowanie wbudowanej zmiennej globalnej ORIGIN. Aby początkowe indeksy wektorów i macierzy zaczynały się od 1 należy na początku dokumentu wpisać następującą definicję: ORIGIN := 1 lub zmienić wartość tej zmiennej w menu Math/Options.


MATHCAD 2000

Wykresy funkcji Wykresy w Mathcadzie tworzymy z menu Insert/Graph lub z paska narzędziowego Graph. Na jednym wykresie można przedstawić kilka funkcji oraz dodawać punkty kontrolne lub asymptoty (rys. obok). Kolejne funkcje dodajemy poprzez wpisanie przecinka w polu opisu funkcji, mogą być one zależne od jednej wspólnej zmiennej lub każda z funkcji może mieć swój niezależny argument. Formatowanie wykresu odbywa się po jego podwójnym kliknięciu i wybraniu odpowiednich opcji z okienka dialogowego.

5

4

4 −π 2

π 2 2

tan( x) sin( x)

2

0

2

cos( x) 2

−4

4 −π

x

π

Pola tekstowe Pola tekstowe służą do dokumentowania prowadzonych obliczeń (komentarze, objaśnienia, itp.). Domyślnie każdy nowo tworzony region zawiera równanie, jednak po wpisaniu pierwszego wyrazu i spacji automatycznie zmienia się w region tekstowy. Pewniejszym sposobem jest zastosowanie cudzysłowu [”] na początku wpisywanego tekstu – jest to sygnał dla Mathcada, że chcemy wpisywać tekst a nie wzór. Teksty możemy formatować jak w zwykłych edytorach tekstu lub pośrednio poprzez zastosowanie styli (podobnie jak w Wordzie). Formatowanie danych i wyników Formatowanie równań i wyników uzyskujemy z menu Format/Equation i Format/Result. Za pomocą tych funkcji możemy ustawić rodzaj i wielkość czcionki lub ilość cyfr wyświetlanych w wynikach. Pozycjonowanie regionów Przejrzystość tworzonej w Mathcadzie dokumentacji uzyskamy poprzez właściwe rozmieszczenie regionów, tak aby nie zachodziły na siebie i były odpowiednio wyrównane. Pomocne w tym celu są funkcje z menu Format/Separate_Regions i Format/Align_Regions. Tematy pominięte w niniejszym opracowaniu W niniejszym przeglądzie nie ma miejsca na prezentację innych funkcji Mathcada. Pominięte zostały takie tematy jak osadzanie obiektów i dynamiczna wymiana danych czy współpraca z pakietami pomocniczymi AxumLE i SmartSketch. Zainteresowanych odsyłamy jak zwykle do Resource Center.


MATHCAD 2000

6

Litery greckie, klaw. edycyjne

Operatory macierzowe

Pochodne, całki, granice

Operatory logiczne

Operatory arytmetyczne

Definicja i obliczanie

Załącznik 1:

Podstawowe operatory Mathcada Klawisz

Operacja

: dwukropek ~ tylda = Ctrl+. kropka Ctrl+Shift+. + * / Ctrl+/ Ctrl+Enter ^ (, ), ’apostrof \ Ctrl+\ | " ! < > Ctrl+9 Ctrl+0 Ctrl+= Ctrl+3 ? Ctrl+? & Ctrl+I Ctrl+L Ctrl+A Ctrl+B $ Ctrl+4 Ctrl+Shift+4 # Ctrl+Shift+3 , przecinek ; średnik . kropka [ Ctrl+8 Ctrl+1 Ctrl+6 ^-1 Ctrl+- minus Znak + Ctrl+G Ctrl+Shift+P Ctrl+Shift+Z Insert Spacja Tab, Shift+Tab Ctrl+D

:= definicja zmiennej lub funkcji lokalnej definicja globalna numeryczne obliczenie wyrażenia symboliczne obliczenie wyrażenia symboliczne obliczanie z kluczem dodawanie odejmowanie lub negacja mnożenie dzielenie dzielenie w wierszu dodawanie z przeniesieniem do następnego wiersza potęgowanie nawiasy: (lewy, )prawy, ‘dwustronny-automatyczny pierwiastek kwadratowy pierwiastek dowolnego stopnia wartość bezwzględna lub wyznacznik macierzy liczba sprzężona zespolona silnia (n!) mniejszy większy mniejszy lub równy większy lub równy równy nie równy pochodna pierwszego rzędu pochodna dowolnego rzędu całka oznaczona całka nieoznaczona granica dwustronna granica prawostronna granica lewostronna suma po zmiennej iteracyjnej suma elementów wektora suma od..do iloczyn po zmiennej iteracyjnej iloczyn od..do oddzielanie argumentów funkcji lub elementów wektora definicja zakresu (zmiennej iteracyjnej) separator liczb dziesiętnych lub indeks dolny ozdobny (zwykły) indeks elementu wektora iloczyn wektorowy transpozycja wektora lub macierzy kolumna macierzy macierz odwrotna operator wektoryzacji obliczeń litery greckie (alfa, beta, ...) liczba pi znak nieskończoności przełączenie punktu wstawiania (początek-koniec) poszerzenie aktywnego wyrażenia aktywacja kolejnego lub poprzedniego pola usunięcie aktywnego regionu


7

MATHCAD 2000/2001 - Proste Obliczenia Inteligentny kalkulator

(i trochę o edycji równań)

wzór

klawiatura

1 + 2⋅ 3 = 7

1, +, 2, *, 3, =

( 1 + 2) ⋅ 3 = 9

1, +, 2, spacja, *, 3, =

1 6 1 6

+

+

1 4 1 4

+

+

1

= 0.5

12 1

12

1, /, 6, spacja, +, 1, /, 4, spacja, +, 1, /, 12, =

1

1, /, 6, spacja, +, 1, /, 4, spacja, +, 1, /, 12, Ctrl+.

2

π → 1  6 2

sin

sin(, Ctrl+Shift+P, /, 6, ),Ctrl+.

Definiownie zmiennych i funkcji wzór

klawiatura

a := 1

b := −5

c := 6

a, : dwukropek, 1

a + b = −4

a, +, b, =

a + b ⋅ c = −29

a, +, b, *, c, =

2

(itd))

f ( x) := a⋅ x + b ⋅ x + c

f(x), : dwukropek, a, *, x, ^, 2, spacja, +, b, *, x, +, c

f(1) = 2

f(1)=

f(0) = 6

Rozwiązanie równania kwadratowego f(x) = 0 2

∆ := b − 4a⋅ c x1 :=

x2 :=

−b − ∆ 2a −b + 2a

∆=1

D, Ctrl+G, :, b^2, spacja, -4a*c

x1 = 2

x1, :, -, b, -, \, D, Ctrl+G, spacja, spacja, /, 2a,

x2 = 3

jak wyżej

Bardziej zaawansowany sposób rozwiązania

x1, =


8

f ( x) = 0 solve , x →

2    3 

f(x), Ctrl+=, 0, Ctrl+Shift+., solve, przecinek, x, Enter

Tworzenie wykresu funkcji wykres

opis czynności 2

1. z klawiatury Shift+@ lub myszką menu Insert/Graph/X-Y Plot 2. w pole opisu funkcji wpisać f(x) 3. w pole argumentu wpisać x 4. w polach zakresu argumentu podać 1 i 4 5. sformatować wykres przez podwójne kliknięcie i wybranie odpowiednich opcji np.: X-Y Axes / Axes Style / Crossed

1 f ( x) 1

2

3

4

1 x

−π

π

2

2

2

tan ( x) sin( x) cos( x)

3

2

1

0

1

2

3

2

x

Jednostki miar stosowanie miar

klawiatura

lub z menu

Insert/Unit

1km + 20m + 34cm = 1020.34 m

1, km, +, 20, m, +, 34, cm, =

1ft = 30.48 cm

1, ft, =, cm

(w polu jednostki wyniku)

Przykład: Na ciało o pewnej masie działa siła F = 20kN. Oblicz


9

jego masę jeżeli wiadomo, że przyspieszenie wynosi a = 10m/s2. kN := 1000N

definicja własnej jadnostki miar

F := 20kN

a := 10

m 2

dane

s m :=

F

m = 2000 kg

a

wynik

Uwaga: Definicja zmiennej o takiej samej nazwie jak jednostka miar zasłania jej znaczenie x := 2km

x = 2000 m

km := 123 x := 2km

tu jest OK definicja lokalnej zmiennej

x = 246

teraz km już nie oznacza 1 kilometr a liczbę 123


10

MATHCAD 2000/2001 - Obliczenia iteracyjne, macierze i wektory Zmienne zakresowe 1. Tablicowanie funkcji Wzór

Opis

a := 0 ,

π 10

.. 2 ⋅ π

a =

a, :, 0, przecinek, Ctrl+Shift+P, /, 10, ;średnik, Ctrl+Shift+P

sin( a) = 0

0

0.314

0.309

0.628

0.588

0.942

0.809

1.257

0.951

1.571

1

1.885

0.951

2.199

0.809

2.513

0.588

2.827

0.309

3.142

0

3.456

-0.309

3.77

-0.588

4.084

-0.809

4.398

-0.951

4.712

-1

a, =

sin, (, a, ), =

Wyniki prezentowane po lewej są tablicami, a nie - jak dotychczas skalarem. Aby wyświetlić kolejne elementy tablicy należy ją uaktywnić (poprzez kliknięcie) i przewinąć do szukanego elementu. Można również zwiększyć liczbę wyświetlanych elementów tablicy rozciągając jej dolną krawędź!!! Poniżej przedstawiamy wykres stablicowanej funkcji

1

0

2

4

6

8

1

Inny sposób (wektorowy) n := 10

Tu dla oszczędności miejsca rozrzedzono podział na n=10 odcinków.

i := 0 .. n a := 2 ⋅ π i

i n

definicja wektora poprzez zmienną iterowaną a, [, i, :, 2, Ctrl+Shift+P, i, /, n


11

0

a=

0

Teraz wyniki są nie tablicami a wektorami!!!

0

0

0

0

1

0.628

1

0.588

2

1.257

2

0.951

3

1.885

3

0.951

4

2.513

4

0.588

5

3.142

5

0

6

3.77

6 -0.588

7

4.398

7 -0.951

8

5.027

8 -0.951

9

5.655

10 6.283

sin( a) =

I tak przy okazji doszliśmy do naturalnej definicji wektora poprzez iterowaną definicje kolejnych jego elementów. Dostęp do kolejnych elementów wektora uzyskujemy stosując operator indeksu "[".

9 -0.588 10

0

Zmienne zakresowe 2. Sumowanie szeregów n := 10 i := 0 .. n a := i

1 2

s :=

i

∑ ai i

s = 1.999023

 1   0.5     0.25   0.125   0.0625    a =  0.03125   0.01563     0.00781   0.00391   0.00195     0.00098 

Uwaga: do obliczenia powyższej sumy nie warto definiować wektora a, tylko od razu wpisać wzór n

1 i

= 1.999023

i =0 2

co zaoszczędza zużycie pamięci i zwiększa szybkość obliczeń. (przedstawiony po lewej sposób obliczeń jest nieefektywny - pokazano go jedynie dla celów dydaktycznych).

Wektory i macierze ORIGIN := 1

UWAGA: początkowy indeks wektorów i macierzy to 0 a nie 1. To domyślne zachowanie Mathcada możemy zmienić definiująć zmienną ORIGIN

Różne sposoby definiowania wektorów i macierzy

1. wystarczy określić kilka wyrazów wektora lub macierzy (pozostałe elementy przyjmą domyślne wartości zerowe). Wymiary wektora-macierzy określają maksymalne indeksy użyte do tej pory:


12

V := 1.23

V := 3.5

1

V, [, :, 1.23

3

 1.23  V= 0     3.5  Dla macierzy drugi indeks oddzielamy przecinkiem A

:= 1

A

:= 5

1, 1 2, 3

A=

A, [, 0, przecinek, 0, :, 1 A

2, 2

:= 3

analogicznie

1 0 0    0 3 5 

2. można zastosować zmienne zakresowe i definicję wektora (macierzy) za pomocą wzoru iteracyjnego (jak

przedstawiono przy omawianiu zmiennych zakresowych) lub podając bezpośrednio kolejne elementy wektora oddzielone przecinkami.

i := 1 .. 3 w := 2 ⋅ i i

2  w = 4    6 

j := 1 .. 2 B

i, j

lub

z := i

1 3 7

1  z = 3    7 

:=

1 2 3 4 5 6

1 2  B = 3 4    5 6 

dla macierzy dane czytane są wierszami!!!

3. Ctrl+M lub przycisk Insert Matrix na pasku narzędziowym Matrix.lub w menu Insert 1 2 0   0 3 4 

A := 

4. Poprzez generowanie

A, :, Ctrl+M, podać wymiary i wpisać kolejne elementy


13

1 0 0  I = 0 3 0    0 0 7 

I := diag( z)

1 0 0  H = 0 1 0    0 0 1 

H := identity ( 3 )

Operacje algebraiczne na wektorach i macierzach

1 2  B = 3 4    5 6 

1 2 0  A=  0 3 4 

T

C := B

C=

1 3 5    2 4 6 

A+ B=

A+ C=

A⋅ B =

transpozycja macierzy (Ctrl+1)

BŁĄD! niezgodne wymiary macierzy

2 5 5     2 7 10 

C−A=

 7 10     29 36 

D := B ⋅ A

0 1 5    2 1 2 

suma i różnica macierzy

iloczyn macierzowy

1 8 8  D =  3 18 16     5 28 24 

D =0

wyznacznik macierzy (tylko dla mac. kwadratowych)

 43.866  eigenvals( D) =  −0.866     0 

wartości własne macierzy

Inne rzadziej używane funkcje cols( A) = 3 〈 2〉  2  A =  3 

rows( A) = 2

Ile kolumn i wierszy

wyciągnięcie n-tej kolumny (Ctrl+6)


14

 10  w × z =  −8    2 

iloczyn wektorowy (Ctrl+8)

max( B) = 6

min( B) = 1

szukanie elementów o największej lub najmniejszej wartości

Operacje na blokach Służą do tego specjalne funkcje blokowe: • submatrix() - wyciągnięcie bloku z macierzy • augment() - sklejenie dwóch macierzy w poziomie • stack() - sklejenie macierzy w pionie Opis poszukaj samodzielnie w "Helpie" lub "Recource Center"

Wektory i macierze funkcyjne

przykład

 sin( x) x2 − 2    cos( x) x 

M ( x) := 

M( 1) =

 0.841 −1     0.54 1 

1 2  1 ⋅π − 2    36 2 π M   →   1 6   1⋅ 3  ⋅π 6 2 


15

MATHCAD 2000/2001 - Obliczenia symboliczne Przekształcenia algebraiczne UWAGA: Obliczenia symboliczne można wywoływać na dwa różne sposoby: 1. poprzez menu Symbolics 2. poprzez przyciski paska narzędziowego Symbolic. Pierwszy sposób, choć może trochę łatwiejszy w użyciu, jest o wiele mniej elastyczny, dlatego w niniejszym opracowaniu ograniczamy się do podania przykładów z zastosowaniem paska narzędziowego Symbolic (można też korzystać z klawiatury ale wygodniejsze w tym przypadku jest używanie myszy).

Wzór

Opis 3

f ( x) :=

∏ ( x − i)

definicja funkcji

i=1

f ( x) → ( x − 1 ) ⋅ ( x − 2 ) ⋅ ( x − 3 )

zwykłe obliczenie symboliczne (f(x), Ctrl+.)

UWAGA: X := 4

jeżeli zmienna X została zdefiniowana (tak jak tutaj)

f ( X) → 6

to w wyrażeniach symbolicznych będzie niestety używana jej wartość a nie symbol X

X := X

Aby zapobiec takiej sytuacji należy zastosować rekurencyjną definicję zmiennej

f ( X) → ( X − 1 ) ⋅ ( X − 2 ) ⋅ ( X − 3 )

teraz znów jest OK!!!!

Słowa kluczowe - modyfikatory obliczeń symbolicznych W wielu przypadkach standardowy operator obliczeń symbolicznych -> jest niewystarczający i musimy "podpowiedzieć" Mathcadowi w jakiej postaci chcemy otrzymać wzór. Poniżej przedstawiamy listę najczęściej stosowanych modyfikatorów (zob. pasek Symbolic) expand - rozwinięcie na składniki 3

2

f ( x) expand → x − 6 ⋅ x + 11⋅ x − 6 factor - faktoryzacja - rozkład na czynniki 3

2

x − 6 ⋅ x + 11⋅ x − 6 factor → ( x − 1 ) ⋅ ( x − 2 ) ⋅ ( x − 3 )


16

1

x−2

1 x−1

1

factor →

( x − 2) ⋅ ( x − 1 )

simplify - uprość wyrażenie 2

x −1 x−1

(x2 − 1)

Jeżeli mogą wystąpić potencjalne osobliwości to Mathcad nie upraszcza wyrażeń automatycznie

(x − 1)

2

x −1 x−1

simplify → x + 1

Musimy mu podpowiedzieć żeby starał się możliwie najlepiej uprościć wyrażenie

Materiał dodatkowy Czasami należy pomóc jeszcze bardziej poprzez ograniczenie dziedziny simplify, assume=real - mówi że zmienne są liczbami rzeczywistymi simplify, assume=RealRange(a,b) - lub ograniczone w pewnym przedziale 1

( 2)

2

2

x → x

tu nie wie co z tym chcemy zrobić

2

x simplify → csgn( x) ⋅ x

2

tu upraszczamy ale otrzymujemy rozwiązanie w dziedzinie zespolonej

x simplify , assume = real → signum( x) ⋅ x

dla liczb rzeczywistych - już bez kłopotów

x simplify , assume = RealRange( 0 , ∞ ) → x

podpowiadamy, że x jest nieujemne co pozwala jeszcze lepiej uprościć wyrażenie

2

Podobnie, ale bardziej precyzyjnie działa klucz assume bo pozwala określać dziedzinę pojedynczej zmiennej. Przykład podajemy na końcu tego punktu.

Do przekształceń trygonometrycznych przydatny jest modyfikator simplify, trig - wykorzystaj ogolnie znane tożsamości trygonometryczne 3

2

sin( x) + sin( x) ⋅ cos( x) simplify , trig → sin( x) float,m - podaj wynik w postaci liczb rzeczywistych z m cyframi znaczącymi liczba m może być z zakresu 1 ≤ m ≤ 250 !!! przykład - wyznaczenie 50 cyfry po przecinku liczby π π float , 51 → 3.1415926535897932385


17

Materiał dodatkowy coeffs - podaj współczynniki wielomianu f ( x) → ( x − 1 ) ⋅ ( x − 2 ) ⋅ ( x − 3 ) porównaj współczynniki poniżej

 −6  11 f ( x) coeffs , x →    −6  1   

3

2

f ( x) expand , x → x − 6 ⋅ x + 11⋅ x − 6

Pozostałe modyfikatory stosowane są w bardziej zaawansowanych obliczeniach. Część z nich poznamy w dalszej części materiału. Przydatnym skrótem klawiaturowym jest Ctrl+Shift+. (drugi przycisk), który pozwala na wprowadzanie dowolnych modyfikatorów z klawiatury - trzeba jednak wiedzeć co wpisać. UWAGA: w jednym regionie można zrealizować serię obliczeń symbolicznych po kolei lub poprzez grupowanie modyfikatorów

2

2

2

2

x − π factor → ( x − π ) ⋅ ( x + π ) float , 3 → ( x − 3.14) ⋅ ( x + 3.14)

x −π

grupowanie - klikaj kolejne modyfikatory i dopiero potem je redaguj

factor

→ ( x − 3.14) ⋅ ( x + 3.14) float , 3

Materiał dodatkowy assume X=real - X jest liczbą rzeczywistą assume X=RealRange(a,b) - X jest liczbą rzeczywistą z przedziału (a,b)

2

x

assume , x = RealRange( −∞ , 0 ) → −x simplify

uprość wyrażenie przy założeniu że x ≤ 0

Granice, pochodne i całki Wzór lim x→0

(

Opis sin( x)

→1

x

)

2 d 3 x + sin( x) → 3 ⋅ x + cos( x) dx

Ctrl+L, sin(x)/x, tab, x, tab, 0, Ctrl+.

Shift+/, 'apostrof, x^3, spacja, +, sin(x), tab, x, Ctrl+.


18

⌠   ⌡

1

2

e

−x

dx →

0

1 2

⋅π

2

Shift+7, e^-x^2, tab, x, tab, 0, tab, Ctrl+Shift+Z, Ctrl+.

series,X=x0,N - rozwiń funkcję w szereg Taylora N

rozwinięcie względem X w otoczeniu punktu x0 do rzędu X

sin( x) series , x , 10 → x −

1 3 1 1 1 5 7 9 ⋅x + ⋅x − ⋅x + ⋅x 6 120 5040 362880

Ponieważ temat jest dobrze znany a cała zabawa polega na wywoływaniu odpowiednich symboli z paska narzędziowego "Calculus" lub używaniu odpowiednich skrótów klawiaturowych przechodzimy do ćwiczeń.

Obliczenia symboliczne na macierzach ORIGIN := 1 d −b   ( a d b c ) ( a d ⋅ − ⋅ ⋅ − b ⋅ c) −1 A → a −c   ( a ⋅ d − b ⋅ c) ( a ⋅ d − b ⋅ c)

a b 

A := 

 c d 

    

A → a⋅ d − b ⋅ c Przy okazji pokazujemy przykład zastosowania modyfikatora substitute subtitute,wyr1=wyr2 - podstaw wyr2 zamiast wyr1

−b   d   DET DET −1 A substitute , a⋅ d − b ⋅ c = DET →   a  −c   DET DET  inny przykład

 cos( x) −sin( x)    sin( x) cos( x) 

C( x) := 

2

C ( x) → cos( x) + sin( x)

C ( x) simplify → 1

macierz funkcyjna

2

tu też często trzeba dopomóc w upraszczaniu wyrażeń

teraz OK


19

C( x)

−1

simplify →

 cos( x) sin( x)     −sin( x) cos( x) 

C( α ) → T

 cos( α ) sin( α )     −sin( α ) cos( α ) 

Jeżeli potrafimy obliczyć symbolicznie macierz odwrotną, to tym samym potrafimy symbolicznie rozwiązywać liniowe układy równań.

Rozwiązywanie równań z jedną niewiadomą solve, x - znajdź rozwiązanie równania względem zmiennej x UWAGA: w równaniach nie używamy zwykłago znaku = tylko Ctrl+=. Można nie podawać prawej strony jeśli jest =0 ale zmniejsza to czytelność zapisu, dlatego nie polecamy tego uproszczenia

     1 ⋅  −b + b 2 − 4 ⋅ a⋅ c  2⋅ a  2 a⋅ x + b ⋅ x + c = 0 solve , x →      1  2  2⋅ a ⋅  −b − b − 4⋅ a⋅ c 

1 

(

)

(

)

    1  2     2

Często wynik jest na tyle skomplikowany, że mathcad nie potrafi podać rozwiązania w zwięzłej postaci, jeśli wynik zależy od kilku parametrów. Na przykład, jeżeli podobną do opisanej wyżej metody zastosujemy do ogólnego równania 3-go stopnia to natrafimy na problem!!! Dużo łatwiej otrzymać rozwiązanie, gdy operujemy na konkretnych liczbach, ale wynik też może być bardzo "rozlazły".

3

2

a⋅ x + b ⋅ x + c⋅ x + d = 0 solve , x →


20

1  3 5 1 2 −  ⋅ ( 35 + 15⋅ 6 ) + − 3 3 1   3 3 ⋅ ( 35 + 15⋅ 6 )   1 1  1  3 3 5 2 1 −1 3 2 − + ⋅ i ⋅ 3 ⋅  ⋅ ( 35 + 15⋅ 6 ) − x + 2x + 3x + 4 = 0 solve , x →  6 ⋅ ( 35 + 15⋅ 6 ) − 3 2 1  3 3   6 ⋅ ( 35 + 15⋅ 6 ) 3 ⋅ ( 35 +   1 1    1 3 3 5 2 1 −1 − − ⋅ i ⋅ 3 ⋅  ⋅ ( 35 + 15⋅ 6 ) −  ⋅ ( 35 + 15⋅ 6 ) − 3 2 1 3 6 3   6 ⋅ ( 35 + 15⋅ 6 ) 3 ⋅ ( 35 +  

Jeżeli wystarczają nam konkretne wartości liczbowe, to warto dodatkowo zastosować modyfikator float,N

3

2

x + 2x + 3x + 4 = 0

−1.65062  solve , x   → −.174686 − 1.54687 ⋅ i  float , 6    −.174686 + 1.54687 ⋅ i 

Gdy mamy równanie przestępne to nie jest mozliwe otrzymanie zwięzłego rozwiązania w postaci wzoru. W takich sytuacjach Mathcad podaje rozwiązanie numeryczne z 20 cyframi znaczącymi. Jeżeli nie potrzebujemy aż takiej dokładności to znów przydatny jest modyfikator float,N

Przykład: Znaleźć punkty przecięcia wykresów y = cos(x) i y = x

graficzna ilustracja do tego przykładu 5

cos( x) = x solve , x → .73908513321516064166

cos( x) x

cos( x) = x

solve , x → .739085 float , 6

5

0

5 x

Niestety dla równań przestępnych (nawet najprostszych) Mathcad podaje pierwsze znalezione rozwiązanie.

5


21

Nieco zmodyfikowane zadanie ma trzy pierwiastki, ale Mathcad podaje tylko jedno

graficzna ilustracja do tego przykładu

cos( x)

cos( x) = 0.3x solve , x → 1.2019131636661846248

0.3x

5

0

5

podobnie nie ma co liczyć aby Mathcad podał nam rodzinę rozwiązań np. dla funkcji okresowych

cos( x) = 0 solve , x →

1 2

⋅π

a nie

π 2

x

+ k⋅ π

WNIOSEK: Nie wszystko rozwiąże za nas Mathcad automatycznie. W wielu przypadkach musimy mu umiejętnie pomagać, co wymaga od nas dostatecznego rozumienia zagadnienia i znajomości matematyki w tym zakresie. Musimy też poznać nieco bardziej zaawansowane techniki w Mathcadzie. Do problemu wrócimy w kolejnych ćwiczeniach. Aby liczyć na sukces to niestety trzeba matmę choć trochę znać.

Rozwiązywanie nierówności - przykład x−1 x−2

>

x+ 3 x+ 1

solve , x →

−14

x− 1

To rozwiązanie czytamy następująco:

 x < −1    ( 2 < x) ⋅ ( x < 5 ) 

x ∈ ( −∞, − 1) ∪ ( 2, 5)

Jak widać z przedstawionych wykresów Mathcad dobrze wywiązał się z tego zadania.

2

2

x− 2 x+ 3 x+ 1

4

2

0

2

2

x

4

6

Na piechotę mielibyśmy trochę liczenia: 3 różne równania kwadratowe (tu akurat dwa z nich są tylko liniowe) dla różnych zakresów zmiennej x, a po rozwiazaniu jeszcze weryfikacja pierwiastków, czy zawierają się w założonym przedziale - w sumie żmudne i podatne na błedy rachunki, których można uniknąć stosując Mathcada.


22

MATHCAD 2000/2001 - Rozwiązywanie równań, optymalizacja, wykresy 3D Wprowadzenie Jak zauważyliśmy w poprzednich ćwiczeniach Mathcad dysponuje dość silnym "solverem" symbo- licznym. Tym niemniej przy rozwiązywaniu złożonych problemów, szczególnie przy rozwiązywaniu równań przestępnych, musimy zastosować bardziej zaawansowane techniki obliczeniowe i umiejętnie podpowiadać Mathcadowi poprzez wybranie odpowiedniej do danej klasy zagadnień metody. Wymaga to oczywiście pewnego doświadczenia w posługiwaniu się Mathcadem jak również elementarnej wiedzy z metod numerycznych. Rozwiązania równań (lub układów równań) przestępnych w ogólnym przypadku nie da się przedstawić w postaci zwartego wzoru matematycznego i musimy zadowolić się wynikiem numerycznym. W zależności od klasy problemu stosujemy różne metody rozwiązywania równań. Często też stosujemy różne metody zamiennie lub równolegle co pozwala na weryfikację uzyskanego rozwiązania. Poniżej przedstawiono możliwe strategie obliczeń: 1. Realizacja własnego algorytmu - warto wspomnieć o tym, gdyż jeśli wiemy co i jak policzyć to nie musimy polegać na zawiłych algorytmach wbudowanych w Mathcada, ponadto w wyjątkowych sytuacjach może to być jedyna lub najskuteczniejsza metoda obliczeń. 2. Metoda graficzna - stosowana głównie jako weryfikator wyników i podpowiadacz tzw. punktów startowych w metodach numerycznych. Stanowi ogromną pomoc i jest zawsze zalecana. 3. Solver symboliczny (solve, x ->) - bardzo wygodny i prosty w użyciu, pozwalający na uzyskanie rozwiązania w postaci parametrycznej (wzór a nie liczba), jednak nie zawsze prowadzi do poszu- kiwanego rozwiązania. Tym niemniej jest to podstawowe narzędzie, od którego zawsze możemy rozpocząć nasze poszukiwania i dopiero w razie niepowodzeń zastosować inne metody. 4. Blok "Given" - to najbardziej wszechstronny sposób rozwiązywania równań, a przede wszystkim układów równań nieliniowych z kilkoma niewiadomymi. Blok given stosuje się również w rozwią- zywaniu równań różniczkowych (zwyczajnych lub cząstkowych) oraz zagadnień optymalizacji. 5. Zastosowanie specjalizowanych procedur numerycznych - najbardziej efektywny sposób rozwiązania, pod warunkiem zastosowania właściwej procedury do danej klasy problemu. Solver symboliczny (solve, x ->) z p.3 poznaliśmy już na poprzednich ćwiczeniach. Nadaje się przede wszystkim do rozwiązywania równań z jedną niewiadomą, ale można go również wykorzystać w bardziej złożonych zagadnieniach i przy pewnych "sztuczkach" usprawnić proces przetwarzania danych. Dzisiejsze zajęcia poświęcone jednak będą przede wszystkim metodom z punktów 4 i 5. Warto zauważyć, że z problematyką rozwiązywania równań zetknęliśmy się już w poprzednich ćwiczeniach a pewne tematy zostaną tu powtórzone dla usystematyzowania wiedzy. Już od pierwszych zajęć zaczynaliśmy rozwiązywać proste równania algebraiczne lub układy równań liniowych i stosowaliśmy a) własne algorytmy, b) solver symboliczny lub c) specjalizowaną procedurę lsolve(A,B). Teraz nadszedł właściwy moment aby to wszystko uporządkować. Podzielimy tematykę na kategorie w zależności od rodzaju zagadnienia.


23

Równania z jedną niewiadomą Równania algebraiczne, wielomiany Tu wystarczająco skutecznym narzędziem jest solver symboliczny (solve, x->) ale dla wielomianów mamy alternatywę w postaci specjalnej funkcji polyroots(v), szczególnie zalecana dla wielomianów wyższego stopnia. Ponadto łatwiej przechować rozwiązanie do dalszych przeliczeń.

n := 5 n

W( x) :=

świadomie wybieramy prosty wielomian, dla którego znamy pierwiastki aby łatwiej prześledzić dalsze obliczenia

∏ ( x − i)

i =1

W( x) → ( x − 1 ) ⋅ ( x − 2 ) ⋅ ( x − 3 ) ⋅ ( x − 4 ) ⋅ ( x − 5 ) 5

4

3

2

W( x) expand → x − 15⋅ x + 85⋅ x − 225 ⋅ x + 274 ⋅ x − 120

1  2    W( x) = 0 solve , x →  3  4    5 

Solver bez problemu znajduje rozwiązanie. Ale jak przechować je do dalszych obliczeń? (dla krótkich jednorazowych obliczeń możemy ratować się skopiowaniem wyniku poprzez schowek Windows ale na dłuższą metę jest to niewygodne, bo przy każdej zmianie wyniku musimy od nowa kopiować!!!)

Możemy zastosować następującą sztuczkę: przed wpisaniem równania definiujemy zmienną, w której przechowamy rozwiązanie (tu będzie to wektor p). Potem już łatwo możemy wyciągać poszczególne pierwiastki do dalszych obliczeń.

1  2    p := ( W( x) = 0 ) solve , x →  3  4    5 

p =2 1

( 1) = 0

Wp

1  2    p = 3  4    5 

tu ORIGIN=0 dlatego p1 to drugi element wektora

Aby zastosować funkcję polyroots(v) musimy mieć wektor współczynników wielomianu - możemy go oczywiście policzyć odpowiednim algorytmem, ale na razie aby nie zaciemniać istoty tematu wpiszemy go ręcznie.


24

wpisujemy dla wygody wektor wierszowy i transponujemy go do kolumny

T

v := ( −120 274 −225 85 −15 1 ) n

Y( x) :=

wielomianu nie trzeba nawet wcale definiować tu robimy to tylko dla sprawdzenia

i

v ⋅x i

i=0 5

4

3

2

Y( x) → x − 15⋅ x + 85⋅ x − 225 ⋅ x + 274 ⋅ x − 120 p := polyroots( v) UWAGA: wynik numeryczny szukamy zawsze z pewnym dopuszczalnym (z góry ustalonym) błędem. Tu również wektor p zawiera błędy, o czym przekonać się można po wyświetleniu wyniku z 15 cyframi znaczącymi.

1  2    p = 3  4    5 

Powstaje naturalne pytanie - po co używać polyroots() jeśli (solve, x) robi to dokładniej? Owszem, ale dla wielomianów stopnia > 10 rozwiązanie symboliczne może zająć od kilku sekund do nawet kilku minut na wolnym komputerze, podczas gdy obliczenia numeryczne z użyciem polyroots trwają zaledwie ułamek sekundy. Oczywiście fakt ten nabiera na znaczeniu dopiero w większych projektach, szczególnie jeżeli duże wielomiany musimy wielokrotnie rozwiązywać. Podobna uwaga dotyczy zresztą i pozostałych procedur numerycznych omawianych poniżej. - w skrócie - zyskujemy ogromną szybkość obliczeń kosztem minimalnych błędów (w typowych zastosowaniach inżynierskich pomijalnie małych)

Równania przestępne Wracamy do przykładu z poprzednich ćwiczeń: cos( x) = 0.3x, Tu dla wygody przejdziemy do standardowej postaci f ( x) = 0 gdzie: f ( x) := cos( x) − 0.3x. Jak pamiętamy "solve, x" potrafił

znaleźć tylko jedno rozwiązanie. Poniżej pokażemy jak można znaleźć pozostałe pierwiastki. Jak zwykle bardzo przydatny będzie wykres badanej funkcji i ewentualnie technika "zoomowania" do precyzyjniejszej lokalizacji pierwiastków. a := 0.3

f ( x) := cos( x) − a⋅ x

Pierwszy - zgrubny wykres

f ( x) = 0 solve , x → 1.2019131636661846248 Drugi wykres - zawężony do przedziału (-4,2)


25

1

f ( x)

10

0

10

f ( x)

4

2

0

2

1 x x

Korzystając z techniki zoomowania można stwierdzić, że dwa pozostałe pierwiastki wynoszą około: x2 = -3.3 i x3 = -2.4. Dokładniejsze przybliżenia możemy znaleźć przy pomocy funkcji: tu musimy wcześniej określić punkt startowy • root( f(x), x) tu zamiast punktu startowego podajemy przedział (a,b) • root( f(x), x, a, b) • lub za pomocą bloku given i funkcji find(x)

UWAGA: Omawiane funkcje - jako ogólniejsze - można również z powodzeniem stosować do równań wielomianowych - "tylko po co wyciągać armatę do zabicia muchy".

f ( x) → cos( x) − .3⋅ x

sprawdzamy wzór (czy wszystko OK?)

x2 := −3.3

definiujemy początkowe przybliżenie

root( f ( x2) , x2) = −3.295

i rozwiazujemy

root( f ( x3) , x3 , −2.5 , −2 ) = −2.356

tu podajemy przedział (a,b) tak aby na jego końcach funkcja miała różne znaki

Drugi sposób jest bezpieczniejszy gdyż zmniejsza ryzyko rozbieżności procesu iteracyjnego. Nie ma tu jednak miejsca na dokładniejsze omówienie tego problemu bo nie jest to kurs matematyki czy metod numerycznych. Naszym celem jest zapoznanie się z możliwościami jakie oferuje Mathcad. Pokażemy więc poniżej jak otrzymać wszystkie trzy pierwiastki od razu oraz jak kontrolować dokładność. p := 0

niszczymy starą definicje wektora p - to zabieg typowo kosmetyczny

 −5  a :=  −3    0 

(

 −3  b :=  −2    2 

p := root f ( x) , x , a , b i

i

i := 0 .. 2

definiujemy początki i końce przedziałów jako wektory, a nastepnie poprzez zmienną zakresową wykonamy kolejne obliczenia cyklicznie

)

i

Wywietlimy wyniki i sprawdzimy ewentualne błędy podstawiając do oryginalnego równania tu szczęśliwie udało się rozwiązać problem


26

 −3.294  p =  −2.356     1.202 

0  f(p) =  0    0 

super dokładnie ale na ogół powstają pewne błędy. Ich wielkość możemy kontrolować poprzez globalne zmienne TOL i CTOL.

Zmienne TOL i CTOL używane są przede wszystkim przy rozwiązywaniu równań w bloku Given. • TOL określa dopuszczalny błąd względny rozwiązania • CTOL określa dopuszczalny błąd względny niespełnienia warunków ograniczających Domyślnie wartości te ustawione są na 10-3 ale możemy je definiować wg własnych potrzeb. Warto jednak pamiętać, że zmniejszając dopuszczalny błąd zmuszamy Mathcada do cięższej pracy Blok Given + funkcja find(x) x0 := 1.5

0. przed użyciem bloku given należy podać punkt startowy

Given

1. wpisujemy słowo kluczowe "Given"

f ( x0) = 0

2. poniżej określamy równanie (lub kilka równań)

r := Find( x0)

3. i rozwiązujemy funkcją find(var1,var2,...)

--------------------------------------------r = 1.202 f ( r) = 1.099 × 10

jak widać rozwiązanie jest mniej dokładne niż z funkcji root co wynika z zastosowania innego algorytmu numerycznego. Możemy jednak sterować dokładnością obliczeń, a prawdziwe zalety bloku Given, będziemy mogli docenić dopiero dla układów równań z kilkoma niewiadomymi.

−7

p = 1.202 2

( 2) = 0

f p

Powtórzymy teraz powyższe obliczenia przy zmniejszonej tolerancji na błędy TOL = 1 × 10 TOL := 10

−3

−3

CTOL = 1 × 10

− 10

− 10

CTOL := 10

Given

tak było do tej pory

podajemy nowe wartości (10-10 to naprawdę bardzo mały błąd) - przeważnie rozwiązanie będzie i tak dokładniejsze o kilka rzędów

f ( x0) = 0 r := Find( x0) --------------------r = 1.202

f ( r) = 0

teraz jest OK

W bloku Given też możemy obliczyć wszystkie pierwiastki za jednym razem jeżeli za punkt startowy podamy wektor a nie pojedynczą wartość

 −5  z :=  −2    1 

Given f ( z) = 0

 −3.294  Find( z) =  −2.356     1.202 


27

Układy równań z wieloma niewiadomymi Układy równań liniowych Temat ten szczegółowo omówiliśmy w ćw. 2 (zajrzyj do pliku mcad_2.mcd). Przypomnijmy jedynie, że obliczenia możemy przeprowadzić z zastosowaniem funkcji lsolve(A,B) lub poprzez macierz odwrotną.

Nieliniowe układy równań Rozwiązywanie nieliniowych układów równań jest skomplikowanym zagadnieniem. Klasyczne podejście analityczne jest na ogół z góry skazane na niepowodzenie, gdyż eliminacja kolejnych zmiennych (nawet gdy możliwa) jest czasochłonna i prowadzi na ogół do skomplikowanego równania przestępnego. Mathcad pozwala w dość łatwy sposób przezwyciężyć te trudności na drodze numerycznej. Najbardziej uniwersalne jest w tym przypadku zastosowanie bloku Given, ale w niektórych szczególnych przypadkach możliwe jest nawet uzyskanie rozwiązania symbolicznego (solve, vec(x,y,z) ->).Aby nie zagłębiać się dalej w zawiłości teoretyczne przejdziemy od razu do przykładu.

Przykład: Wyznacz okrąg przecinający punkty (x,y) = (2,-4), (-3,1), (5,5) Zadanie to można łatwo rozwiązać wykonując proste obliczenia geometrii analitycznej. Na wstępie należy wyznaczyć dwie proste prostopadłe do boków np. 12 i 23 i przechodzące przez ich środki. Następnie z układu 2 równań liniowych (równań tych prostych) znaleźć można środek okręgu (x0,y0) a na koniec wyznaczyć promień jako odległość (x0,y0) do np. (x1,y1). Opisany tu algorytm wymaga jednak trochę "ręcznej" pracy aby wpisać odpowiednie wzory i równania. Czy nie możemy wykonać obliczeń prościej? Spróbujmy zapisać w bezpośredniej postaci odpowiedni układ równań i zlecić jego rozwiązanie Mathcadowi. Poniżej podajemy różne sposoby zapisu i rozwiązania problemu.


28

======================================================================= x1 := 2

y1 := −4

x2 := −3

y2 := 1

x3 := 5

y3 := 5

x0 := 0

y0 := 0

definiujemy parametry zadania (tu współrzędne punktów)

r := 4

podajemy punkt startowy do rozwiązania

definiujemy blok Given

Given 2

2

2

2

2

2

2

2

2

( x1 − x0) + ( y1 − y0) = r ( x2 − x0) + ( y2 − y0) = r

punkty muszą spełniać to samo równanie okręgu mamy 3 równania z 3-ma niewiadomymi x0, y0, r

( x3 − x0) + ( y3 − y0) = r

2  Find( x0 , y0 , r) =  1    5 

otrzymaliśmy okrąg o promieniu 5 i środku (2,1)

=======================================================================

Rozpatrywany układ równań jest na tyle prosty, że można go nawet rozwiązać symbolicznie

 ( x1 − xs ) 2 + ( y1 − ys) 2 = rs2     xs  2 1 5    2 2 2 solve ,  ys  →    ( y2 ys ) ( x2 xs ) rs − = − +      2 1 −5  rs    ( x3 − xs ) 2 + ( y3 − ys) 2 = rs2    Tu również możemy podać dodatkowe ograniczenia nierównościowe

 ( x1 − xs ) 2 + ( y1 − ys) 2 = rs2     xs   ( x2 − xs ) 2 + ( y2 − ys) 2 = rs2    solve ,  ys  → ( 2 1 5 )  ( x3 − xs ) 2 + ( y3 − ys) 2 = rs2   rs    rs > 0   ======================================================================= W bloku Given można również uzyskać rozwiązanie symboliczne (po find() wciskamy Ctrl+. anie =). Given


29

2

2

2

2

2

2

2

2

2

( x1 − xx) + ( y1 − yy) = rr ( x2 − xx) + ( y2 − yy) = rr ( x3 − xx) + ( y3 − yy) = rr

Ale z niewiadomych przyczyn nie można tu podać ograniczeń typu rr > 0 (Mathcad protestuje).

2 2  Find( xx , yy , rr ) →  1 1     5 −5 

2  xp :=  −3    5 

 −4  yp :=  1    5  2

5 5 sin( t) + 1

Na zakończenie omawianego przykładu zilustrujemy rozwiązanie graficznie. 1. tworzymy parametryczny wykres znalezionego okręgu 2. dodajemy serie punktów xp i yp 3. oraz pojedynczy punkt (2,1) Aby uzyskać końcowy efekt jak na wykresie obok musimy go jeszcze odpowiednio sformatować.

1

yp 1

0

5

5 5 cos( t) + 2 , xp , 2

2

2

0

2

2

Wprowadzenie do optymalizacji Tematyka optymalizacji jest na tyle bogata, że nie sposób tu podać nawet fragmentarycznych wiadomości. Punkt niniejszy proszę więc traktować czysto technicznie - czyli jak znaleźć optimum pewnej funkcji (tzw. funkcji celu) w Mathcadzie. Otóż rozwiązanie problemu zapisujemy praktycznie zawsze w podobny do opisanego niżej algorytmu. Z formalnego punktu widzenia nie jest istotne czy rozwiązujemy zadanie z jedną lub wieloma zmiennymi decyzyjnymi, z ograniczeniami lub bez, oraz czy zadanie jest liniowe lub nieliniowe. Zapis w Mathcadzie będzie zawsze podobny a


30

solver sam będzie próbował sklasyfikować problem i zastosować odpowiednią procedurę numeryczną. Podobnie jak wcześniej, przejdziemy do konkretnego przykładu.

Przykład: Obliczyć odległość dwóch krzywych y = e

x

2 i y = x.

Dla ułatwienia parametryzujemy obydwie krzywe - dla pierwszej krzywej przyjmujemy parametr a= x, a dla drugiej b=y. Musimy teraz zdefiniować funkcję odległości dla tych parametrów i obliczyć kiedy osiągnie minimalną wartość. Dla uproszczenia możemy wziąć kwadrat odległości - unikniemy pierwiastkowania i zmniejszymy stopień nieliniowości naszej funkcji celu

2 t

e t

2

0 2 2

t, t

(

f ( a , b ) := a − b

) + ( ea − b )

2

2

2

definiujemy funkcję celu

f ( 0 , 0) = 1 a := 0

to tylko dla sprawdzenia czy OK b := 0

punkty startowe - musimy zawsze podać pusty blok given bo nie mamy ograniczeń

Given

tu ew. mogą być zapisane ograniczenia r := Minimize( f , a , b )

r=

 −0.074     0.538 

Ostatecznie odległość jest równa

obliczenie (a,b) => min f(a,b)

a := r

0

L := f ( a , b )

b := r

1

L = 0.534

2


31

Na koniec przedstawiamy wykres z zaznaczeniem znalezionych (najbliższych) punktów na wykresie.

(

rx := a b

2

)

( a b)

T

T

ry := e

 −0.0735622    0.2896245 

rx = 

1.5 1 t

e

0.5

t ry

1

0.5

0

0.5

0.5 1 2

t , t , rx

1

1.5

UWAGA: Aby prawidłowo pokazać odległość musimy zadbać aby skale osi x i y były takie same. W innym razie wykres będzie zniekształcony i trudno będzie ocenić czy rozwiązanie jest OK.


32

MATHCAD 2000/2001 - wykresy 3D Wykresy 3D Poniżej przedstawiamy wykresy funkcji f(x,y) omawianej przy zagadnieniu optymalizacji w pliku mcad4.mcd. Formatowanie wykresu dokonujemy po jego dwukrotnym kliknięciu i ustawieniu żadanych opcji.

(

2

f ( x , y) := x − y

f

) + (ex − y) 2

2

f

Wykresy warstwicowe choć mniej efektowne od powierzchniowych są pomocne przy graficznym szukaniu ekstremów funkcji. Nie mamy tutaj tak wygodnych narzędzi jak przy zwykłych wykresach 2D, takich jak zoom - powiększanie lub trace - śledzenie punktów wykresu. Jednak przy niewielkiej dodatkowej pracy możemy łatwo przeskalować dziedzinę (x,y) do interesującego nas obszaru co pozwoli na lepsze dobranie punktu startowego do bloku Given.

f

f


33

MATHCAD 2000/2001 - elementy programowania Obliczenia warunkowe Funkcja if() Funkcja if() umożliwia warunkowe obliczanie wyrażenia w zależności od spełnienia określonego kryte- rium (testu) logicznego. Przydatna jest przede wszystkim do definiowania tzw. funkcji warunkowych (zwanych też sklejanymi). Funkcje te charakteryzują się tym, że nie dają się zapisać w postaci jednego wzoru obowiązującego w całej dziedzinie i z reguły są nieciągłe lub mają nieciągłe pochodne w punktach zszycia. Definicja takiej funkcji składa się z dwóch lub więcej wzorów obowiązujących w rozłącznych podzbiorach dziedziny. Składnia funkcji if() jest następująca: if( test_logiczny, wartość_gdy_prawda, wartość_gdy_fałsz) Przykłady jej zastosowań prezentujemy poniżej.

Przykład 1 Dana jest następująca funkcja:

dla x ≤ 0 dla x > 0

 x f ( x) =  sin x

Odpowiednia definicja w Mathadzie ma postać: f ( x) := if ( x ≤ 0 , x , sin( x) )

5

0

5

10

f ( x)

| | | | | | | | | | | | | | | | | | | | | |

Przykład 2 Dla 3 przedziałów:

dla x ≤ −π / 2 dla − π / 2 x < x < π / 2 dla x ≥ π / 2

 −1  g ( x) = sin x  +1 

należy zastosować zagnieżdżoną funkcję if() p :=

π 2

to tylko dla wygody

g( x) := if ( x ≤ −p , −1 , if ( x ≥ p , 1 , sin( x) ) )

g( x)

2

0

2

5 x x

Funkcje max(), min() i mod() Przy definicji pewnych klas funkcji warunkowych przydatne mogą być funkcje min(), max() i mod() - pierwsze dwie używamy w sytuacjach gdy chcemy ograniczyć (obciąć) zakresy wartości a ostatnia jest przydatna do definicji funkcji okresowych.


34

max( cos( x) , −0.3)

mod( x , 2 )

1

2

0

1

1

10

0

10

0

0

2

4

6

UWAGA: funkcje warunkowe definiowane przy pomocy if() można bez ograniczeń stosować w obliczeniach numerycznych i rysować ich wykresy nawet gdy są nieciągłe. Nie można ich jednak używać w obliczeniach symbolicznych: d f ( x) → f ( x) → błąd dx Ograniczenie to można pokonać stosując odpowiednie funkcje z grupy "piecewise continuous", w szczególności przydatna jest funkcja Heaviside'a. Na przykład omawianą powyżej funkcję f(x) można zapisać następująco: f ( x) := Φ ( x) ⋅ sin ( x) + Φ ( −x) ⋅ x

co pozwoli na poprawne operowanie w obliczeniach symbolicznych: f ( x) → Φ ( x) ⋅ sin ( x) + Φ ( −x) ⋅ x d f ( x) simplify → 1 + Φ ( x) ⋅ cos ( x) − Φ ( x) dx Temat ten wykracza jednak poza ramy niniejszego opracowania, gdyż wymaga elementarnej wiedzy z dziedziny dystrybucji

Materiał dodatkowy

Funkcja until() Funkcja until() służy do iteracyjnego (cyklicznego) wykonywania obliczeń aż do spełnienia określonego warunku logicznego. Typowe jej zastosowanie to obliczanie kolejnych wyrazów ciągu lub sumy szeregu dla z góry zadanej dokładności (zob. przykłady poniżej). Pierwszy parametr funkcji until określa tzw. kryterium stopu. Obliczenia trwają tak długo aż parametr ten przyjmie ujemną wartość. Nie podajemy więc warunku logicznego w bezpośredniej postaci a jego odpowiednik liczbowy, tzn. zamiast wyrażenia typu x < a podajemy x-a (<0 już nie piszemy). Drugi parametr określa zwracaną wartość. Aby cały cykl obliczeń miał sens należy dynamicznie zmieniać wartości obydwu parametrów z wykorzystaniem zmiennych zakresowych (iterowanych). Wyjaśnimy to na konkretnym przykładzie poniżej. UWAGA 1: niewłaściwe użycie funkcji until może doprowadzić do bardzo długiego cyklu obliczeń. Co prawda - ze względu na ograniczenia jakie są nałożone na zmiennne zakresowe - nie grozi nam pętla nieskończona (tzw. "zapętlenie"), ale i tak należy definiować testowy warunek logiczny ze szczególną uwagą, tak aby zapewnić jego spełnienie w skończonej liczbie iteracji. UWAGA 2: funkcja until jest przeżytkiem i od Mathcada w wersji 2000 obsługiwana jest tylko dla zgodności z wcześniejszymi wersjami programu. Obecnie zalecaną metodą obliczeń iteracyjnych jest zdefiniowanie własnej funkcji-programu, wykorzystującej instrukcję while. Temat ten zostanie przedstawiony w dalszej części materiału.


35

Elementy programowania

Materiał dodatkowy

Wprowadzenie Mathcad oferuje pewne narzędzia do programowania własnych funkcji. Należy podkreślić, że ich możliwości są bardzo skromne w porównaniu do klasycznych języków programowania, z których zapożyczono na przykład podstawowe instrukcje sterujące (takie jak if, for i while), jednak ich składnia jest inna i mało intuicyjna (szczególnie dla osób mających już jakieś doświadczenie z programowaniem i przyzwyczajonych do innych niż Mathcad standardów). Kod programu może być realizowany jedynie wewnątrz definicji funkcji, co ogranicza zakres jego zastosowań. Największą wadą jest jednak brak jawnych deklaracji zmiennych i kontroli poprawności typów co utrudnia znalezienie błędów w większych programach. Pomimo wspomnianych wad warto jednak zapoznać się z elementami programowania oferowanymi w Mathcadzie, ponieważ są sytuacje, w których programowanie (nawet prymitywne) jest wręcz niezbędne lub bardzo upraszcza skomplikowane obliczenia. Materiał prezentowany poniżej jest krótkim przeglądem możliwości Mathcada w tym zakresie a nie kursem programowania. Dlatego ograniczono się do podania podstawowych instrukcji sterujących i kilku prostych przykładów bez wnikania w tajniki algorytmiki i sztuki programowania. Dalsze informacje i ciekawe przykłady można znaleźć w "Resource Center". Uwaga: Osobom nie mającym żadnego doświadczenia z programowaniem proponuję - a nawet zalecam przestudiowanie poniższego materiału dopiero pod koniec sem. 2. Wskazówka: Aby zacząć programowanie funkcji, należy po wpisaniu początkowej definicji funkcji f(x) := kliknąć przycisk "Add Line" z paska narzędziowego "Programming". W kolejnych liniach (Add Line) wpisujemy kod programu, ale słów kluczowych nie można wpisywać bezpośrednio z klawiatury - należy je wywoływać poprzez odpowiednie przyciski paska "Programming" (lub ew. skróty klawiaturowe).

← - definicja lokalnej zmiennej wewnątrz bloku (operator przypisania) Składnia:

Akcja

var ← value

przypisz zmiennej var wartość value

x←x+ 1

zwiększ x o jeden

if ... if ... otherwise - warunkowe obliczenie wyrażenia Składnia:

Akcja = podaj wartość:

wart1 if warunek1

wart1 gdy spełniony jest warunek1

wart2 if warunek2

wart2 gdy spełniony jest warunek2

"......." wartX otherwise

itd. wartX we wszystkich pozostałych przypadkach


36

Przykład 1

Przykład 2

funkcję f(x) omawianą na początku tego dokumentu można zapisać następująco

podobna lecz trochę bardziej rozbudowana będzie definicja funkcji g(x) - tu dla wygody definiujemy roboczą-lokalną zmienną p; jest ona widoczna jedynie wewnątrz bloku reprezento- wanego przez pionową kreskę

f ( x) :=

x if x ≤ 0 sin( x) otherwise

2

g( x) := 0

5

p←

π 2

−1 if x ≤ −p

10

1 if x ≥ p sin( x) otherwise

2 4

for - pętla "od-do-co" (cykliczne wykonanie instrukcji dla zmiennej zakresowej) Składnia:

Akcja = wykonaj-powtórz N razy

for i ∈ 1 .. N

dla i równe od 1 do N

instrukcja

wykonaj podaną instrukcję

lub for i ∈ 1 , 3 .. N lub

instr_1

(tu z krokiem 2)

"....." instr_K

ciąg instrukcji w bloku

Pętla for ma zastosowanie gdy z góry wiemy ile razy dana pętla będzie powtórzona. Szczególnie przydatna jest przy operacjach na wektorach i macierzach

Przykład 3 silnia( n ) :=

2

s←1

sum( n ) :=

for i ∈ 2 .. n

2

s←0 for i ∈ 1 .. n

s ← s⋅ i

s←s+i

s

2

2

s

silnia( 10) = 3.629 × 10

6

11

sum( 11) = 506 6

10! = 3.629 × 10

2

suma: 1 + 2 + 3 + .. + N

Przykład 4

i =1

2

i = 506


37

znalezienie maksymalnego elementu wektora

Przykład 5

tu w odróżnieniu od standardowej funkcji max() chcemy znaleźć numer maksymalnego elementu, przy okazji zwrócimy też wartość tego elementu. Nasza funkcja będzie więc zwracać od razu dwie wartości (w postaci wektora dwuelementowego). Dla przejrzystości pomijamy w poniższym przykładzie sprawdzenie czy dane wejściowe są wektorem (zakładamy, że tak jest).

ix ← ORIGIN

imax( v) :=

Zmienna ix przechowuje dotychczasowy-najlepszy-znaleziony indeks.

for i ∈ ORIGIN .. last( v) ix ← i if v > v i

Aby program był uniwersalny nie możemy zaczynać od 0 lub 1 tylko od ORIGIN i kończyć pętlę dla last(v).

ix

 ix  v   ix  Testujemy naszą funkcję i := 0 .. 9

v := rnd( 10)

generujemy losowy wektor

i

T

v = ( 0.013 1.933 5.85 3.503 8.228 1.741 7.105 3.04 0.914 1.473 ) nasza funkcja imax( v) =

dla porównania funkcja max()

 4     8.228 

max( v) = 8.228

OK

while - pętla "tak długo jak" Składnia: while war_log instrukcja lub while x < Xmax instr_1

Akcja = wykonaj-powtórz obliczenia tak długo jak spełniony jest warunek logiczny war_log wykonaj podaną instrukcję lub (tu konkretny przykład na war_log).

"....." instr_K

wykonaj ciąg instrukcji w bloku

Pętlę while stosujemy wtedy gdy nie wiemy z góry ile iteracji trzeba wykonać do osiągnięcia danego celu. Jest ogólniejsza i bardziej wszechstronna od pętli for (na przykład tą ostatnią można bez trudu zapisać w formie while), ale też wymaga większej uwagi, gdyż łatwo przez prostą pomyłkę doprowadzić do tzw. pętli nieskończonej. Należy więc bardzo starannie programować warunek logiczny (i wewnętrzne instrukcje pętli), tak aby zagwarantować osiągnięcie wartości fałsz w skończonej liczbie kroków.


38

Obliczenie pierwiastka kwadratowego

Przykład 6 sqrt( a , ε ) :=

a metodą iteracyjną p

p←1

=

1

a p +   i 2 p i 

pierwsze przybliżenie 2

tak długo jak błąd > ε

while p − a > ε p←

i+ 1

1 2

⋅  p +

a

p

licz kolejne przybliżenia

Testujemy naszą funkcję sqrt ( 4 , 0.01) = 2.00060975609756

(

sqrt 4 , 10

−5

sqrt ( 4 , 0.001) = 2.00000009292229

) = 2.00000009292229

(

sqrt 4 , 10

−7

)=2

Gdybyśmy chcieli dowiedzeć się ile iteracji zostało przeprowadzonych wystarczy nieco zmodyfikować naszą funkcję sqrt( a , ε ) :=

x←1 i←0 2

while x − a > ε x←

1 2

⋅  x +

a

x

i←i+1 (x i )

| | | | | | | | | |

sqrt ( 9 , 0.1) = ( 3.00009155413138 4 ) sqrt( 9 , 0.0001) = ( 3.00000000139698 5 )

(

sqrt 9 , 10

) = (3

− 12

6)

Podobnie - drobna korekta - gdybyśmy chcieli prześledzić historię zbieżności naszego algorytmu: sqrt( a , ε ) :=

x←1 i←0 v ←x i

2

while x − a > ε x←

1 2

⋅  x +

i←i+1 v ←x i

v

a

x

| | | | | | | | | | | | | |

(

2

sqrt 17 , 10

)

− 12

1     145    73.4965517241379   38.7143544958308    23.0896429413719   =  17.8030386448063   17.0181112639791     17.0000096373175   17.0000000000027    17  


39

Sumowanie szeregów z ustaloną dokładnością

Przykład 7

Jak zauważyliśmy używanie funkcji until() jest niewygodne i mało efektywne gdyż wymaga tworzenia wektorów (czasami o dużych rozmiarach) tylko po to aby wyciągnąć jego ostatni element. W takich przypadkach idealnym wręcz rozwiązaniem jest zastosowanie własnej funkcji zaprogramowanej z użyciem pętli while.

Napiszemy własną funkcję sinus(x,ε), która liczy wartość sin(x) z ustaloną dokładnością Na początek trochę teorii rozwijamy sin(x) w szereg Taylora sin( x) series , x , 10 → x −

1 3 1 1 1 5 7 9 ⋅x + ⋅x − ⋅x + ⋅x 6 120 5040 362880 3

Ten szereg potęgowy możemy przedstawić w postaci: x −

x

3!

5

+

x

5!

− ..

Sumę określonej liczby wyrazów takiego szeregu można zapisać bez programowania: N

sinN ( x , N) :=

2⋅ i+ 1

x

i

( −1 ) ⋅

i =0

sinN ( 1 , 4 ) = 0.841471009700176

( 2 ⋅ i + 1 )!

sin( 1 ) = 0.841470984807897 Ale ile wyrazów trzeba zsumować aby osiągnąć ustaloną dokładność??? Aby nie wnikać za głęboko w tajniki szeregów funkcyjnych podajemy gotowe rozwiązanie. Reszta rozpatrywanego szeregu jest nie większa niż k+ 1

R <

x

k

dla k = 2i+1 nieparzyste

( k + 1 )! Trzeba po prostu sumować szereg tak długo jak (ang. while) błąd określony powyższym wzorem jest większy od ustalonego z góry, dopuszczalnego błędu ε.

Jeszcze kilka uwag zanim zaczniemy programować!!! 2

kolejne elementy szeregu można liczyć efektywnie z rekurencyjnej formuły: a = a i

−x

i− 2 i ⋅ ( i − 1 )

.

podobnie można postąpić dla oszacowania bieżącego błędu (reszty) szeregu dla dużych x szereg może być na początku wolno zbieżny dlatego warto policzyć jego resztę z dzielenia przez 2π (modulo), aby uniknąć niepotrzebnej pracy procesora - można tu zapewnić jeszcze lepszą (szybszą) zbieżność ale... (pomyśl sam).


40

Definicja naszej funkcji sinus sinus( x , ε ) :=

x ← mod( x , 2π ) i←1 a←x s←a 2

r← x ÷ 2 xx ← −x⋅ x while r > ε i←i+2 a ← a⋅

xx i⋅ ( i − 1 )

s←s+a r←

s   i 

a⋅ x i+1

| | | | | | | | | | | | | | | | | | | | |

Testowe zadanie −8

x := 1

e := 10

sin( x) = 0.841470984807897

 0.841470984648068   11  

sinus( x , e) = 

trzeba było obliczyć szereg do wyrazu x11

err := sin( 10) − sinus( 10 , e)

0

− 10

err = −4.915 × 10

rzeczywisty błąd jest dużo mniejszy, gdyż zastosowane oszacowanie błędu jest pesymistyczne (gwarantowane) - w typowych sytuacjach błąd jest o 1 lub 2 rzędy niższy.

dodano "i" do wyniku dla celów testowych


MATHCAD 2000 PL