Issuu on Google+

Pro Tools 101 – MIDI Basics (Updated for Pro Tools 8) Opening Pro Tools

 Open the Pro Tools Application Remember, when Pro Tools first launches, you are presented with the ‘Quick Start’ dialogue (unless you have disabled this function in preferences) Set Up a New Session

 Create a New Session by either of the following methods: 1) Use the Quick Start menu to create a new session by clicking the ‘Create Blank Session’ option in the dialogue box and click ‘OK’.

Entitle your session ‘MIDI Basics’ and save to your Local Disc.

2) If you have disabled the Quick Start menu, create a new session like so: Menu: File > New Session… Shortcut: COMMAND + N Create a new session by clicking the ‘Create Blank Session’ option in the dialogue box and click ‘OK’.

Entitle your session ‘MIDI Basics’ and save to your Local Disc. Make sure you save you session to your Local Disk


Session Overview You should now be presented with the following empty session:

As we are going to be working with MIDI and using a click track, we should switch to the Grid Edit Mode.  Switch to Grid Mode

In Keyboard Command Focus mode: Shortcut: F4 Make sure you’re in Grid and not Rel Grid.


Changing Grid Settings The Grid settings are located in the top bar of the Edit Window near the Main Counter and Transport buttons.

 Click on the small downward pointing arrow and change the Grid Settings to ‘1/4 note’:


Using MIDI and Aux Input tracks

 Create a MIDI track and a Stereo Aux Input by either of the following methods: Menu: Track > New… Shortcut: COMMAND + SHIFT + N

Shortcuts: COMMAND + up/down arrows = track type COMMAND + left/right arrows = stereo/mono COMMAND + OPTION + up/down arrows = Samples or Ticks COMMAND + SHIFT + up/down arrows = add or remove more track types

 If you are currently in the Edit Window, toggle into the Mix Window. Shortcut: COMMAND + = toggles between mix and edit windows. REMEMBER: The Mix and Edit Windows are the ONLY ‘Main Windows’ in Pro Tools, all other windows in Pro Tools are called ‘Floating Windows’ You should now see 2 tracks an Aux Input and a MIDI Track. The MIDI Track can be identified by its MIDI symbol.

The Aux Input can be identified by its arrow symbol:


Changing Track Views In the bottom right corner of the Mix Window, just below the first track, you’ll find this symbol:

This is the Mix Window View Selector, it allows you to view different aspects of the tracks in the Mix Window, like so:

The Aux Input track to the right shows the viewable information for a typical track in the Mix Window.

 Try turning on and off the various view options 1) What elements of a track are always visible in the Mix Window? NOTE: An Aux Input and a Master Fader do not have a record enable button.

This button is usually located above the Solo button.

 Create a Master Fader 1) What other elements are missing from the Master Fader?


Setting Up a Virtual Instrument In the Mix Window, navigate to the Inserts of your Aux Input Track and click on this symbol:

You should now be presented with an Insert Selector menu, like so:

Select ‘multi-cannel plug-in > Instrument > Xpand2 (stereo)’ to create an Instance of the Xpand2 virtual instrument. You should now be presented with a Plug-in window containing Xpand2


Overview of the Plug-in Window All floating plug-in windows in Pro Tools have some controls in common, these are found in the top bar.

Track selector Indicates and changes which Track this Plug-In is assigned to. Insert Position selector Indicates and changes which Track Insert position this Plug-In is assigned to. Plug-In selector Indicates and changes which Plug-in is currently assigned to the Track Insert position. Effect Bypass Plug-In bypass switch. Target button Indicates which floating Plug-In (or Send) window is currently targeted. Settings menu Allows access to Save, Copy and Import specific settings and presets for the Plug-In. Librarian menu Allows the user to access the loaded settings or presets. Plug-In Settings select & Previous/Next Setting These controls allow navigation of any loaded settings or presets. Plug-In automation enable Allows Plug-In parameters to be specified for automation purposes Automation safe Automation safe mode toggle.


Routing MIDI to a Virtual Instrument

 In you MIDI track, locate the Output Routing button (above the automation button)…

 Click this button and you will see this menu:

 Select Xpand2 1 – channel-1 from the menu.

Your MIDI Output Routing button

should now look like this:

 Click the Record Enable button in the MIDI track

It should now be flashing red

 Play some notes on your controller keyboard, you should see the meters on both the MIDI track and Aux Input move and you should hear sound. This is because we are feeding MIDI data into out MIDI track which is, in turn, firing the MIDI information into the instance of Xpand2 which is inserted in our Aux Input track. The audio output of Xpand2 is then feeding into the Aux Input track allowing us to hear sound from the Virtual Instrument.


Navigating Plug-In Settings Using the Librarian In your instance of Xpand2

 Click the Librarian menu, you should see a huge list of presets (as show in the images to the right). Try navigating through the menu and accessing different presets on the Xpand2 Synth. Using the Previous & Next buttons Once you have chosen a preset…

 Click the Previous and Next setting buttons to change the previous or next preset.

Using the Plug-In Settings selector

 Click the Plug-In Settings selector. You should now be presented with a different menu (as show in the picture to the left). This is an alternative way of navigating through the presets. Take some time to experiment with each method before moving on to the next page.


Using Instrument Tracks From version 7.x onwards Pro Tools added a new track type, called Instrument Track. An Instrument Track combines the Aux Input and MIDI track into one track.

 Create a new stereo Instrument track via either of the following methods: Menu: Track > New… Shortcut: COMMAND + SHIFT + N

 Navigate to Insert A of the Instrument Track and click the Insert selector A button and add a Vacuum synth, like so…

You should now see an Instance of Vacuum:


 Click the Record enable button in the MIDI track until it stops flashing, then click the record enable button in the Instrument Track until it flashes red.

 Play some notes on your controller keyboard, you should see the meters on the Instrument Track move and hear sound from Vacuum. NOTE: As we are now using an Instrument Track the routing has already been setup by Pro Tools and therefore we don’t have to set-up inputs or outputs like we did with our instance of Xpand2 using MIDI and Aux Input tracks.

 Take a moment to experiment with the Settings and Presets on Vacuum. 1) How do the two Virtual Instruments compare? 2) What are some of the major differences between Xpand2 And Vacuum? 3) How does the sound from each of these two Virtual Instruments differ?


Creating a Click Track You can create a Click Track in Pro Tools (which is an Aux Input with a ‘Click’ virtual instrument on Insert A) by using the following method: Menu: Track > Create Click Track You can now activate the click by either using the metronome button in the Transport window or, using Keyboard Command focus: Shortcut: 7 (on the numeric keypad) You should now hear a click every time you press play. Adjusting the Tempo Manually

 Activate the Transport window using either of the following methods Menu: Window > Transport Shortcut: COMMAND + 1 (on the numeric keypad) You should now see the Transport Window

If you are not seeing the MIDI controls on the Transport (the right hand side of the picture above), you can change the views like so: Menu: View > Transport > MIDI Controls

 Click the conductor button until it becomes grey.


Tap Tempo

 Click in the Current Tempo box until it become highlighted, like so….

 With the tempo highlighted, press ‘T’ on your keyboard repeatedly to taptempo. The Grid will change based on your tempo settings Recording MIDI

 If you are in the Mix Window, toggle into the Edit Window. You should now have 4 Tracks: A MIDI Track, 2 Aux Inputs and an Instrument Track.

Your Instrument Track should be ready to record with the record light flashing red. You can activate record in Pro Tools by any of the following methods: Shortcuts: F12 (please note: this won’t work on the Deep Blue Sound computers as the Finder uses this key for window selections) 3 (on the numeric keypad) COMMAND + Space Bar


 Activate record and record some MIDI on your Instrument track

The MIDI track shown above is in ‘Notes’ view, you can change the track view by clicking on the notes button and using the menu to select a different view.

In Region view, the MIDI data can be edited (repeated, duplicated, trimmed, selected, grabbed, stretched, etc.) just like any other audio region in Pro Tools.


The MIDI Editor Window Double clicking the region will open the MIDI Editor Window.

Menu: Window > MIDI Editor Shortcut: CONTROL + = Countoff Often you’ll want a count off before you record. The standard countoff in Pro Tools is 2 bars of clicks. You can activate this either via the Transport or by using the shortcut in Keyboard Command Focus mode Shortcut: 8 (on the numeric keypad)


MIDI Merge MIDI Merge can be toggled on and off in Keyboard Command Focus using: Shortcut: 9 (on the numeric keypad) Building Your Song

 Experiment with the Edit Modes and Edit Tools on the MIDI regions.  Try the Pencil Tool on MIDI notes.

1) What happens when you hover the Pencil over the middle of a MIDI notes? 2) What happens when you hover the pencil tool over the beginning or end of the MDID note?

 Set-up and record on different tracks using different instruments. Bouncing to Disk Once you are happy with your finished song, you’ll want to Bounce it to Disk as a wav file for burning to CD. 1. Select the entire session by either using the Selector and dragging across the entire song, or by clicking in the timebase ruler to set the playback head across all the tracks and then using: Shortcut: Select All: COMMAND + A 2. Make sure you have allowed enough time at the end for any reverbs to decay, etc.


3. Activate the ‘Bounce to Disk’ dialogue by either: Menu: File > Bounce to > Disk… Shortcut: COMMAND + OPTION + B You should now see this dialogue:

4. Make your settings: Source: 1-2 Stereo (or whatever your main stereo source is on your system) File Type: WAV Format: Stereo Interleaved Resolution: 16 Bit Sample Rate: 44100 Convert after bounce 5. Click ‘Bounce…’ 6. Pro Tools will now ask you where to save the file, select somewhere memorable on your Local Disk. Remember: Pro Tools bounces in real time, so your song will now play through 6. Check your Local Disk to make sure the file is present and play correctly.


Closing a Session Close your session via either of the following methods: Menu: File > Close Session Shortcut: COMMAND + SHIFT + W Quitting Pro Tools When you have finished using Pro Tools, make sure you exit the application via the Pro Tools menu or by using the standard Mac shortcut for quitting applications. Menu: Pro Tools LE > Quit Pro Tools LE Shortcut: COMMAND + Q

For more information on Digidesign速 Advanced Instrument Research (A.I.R.) group and the Xpand2, Vacuum, Structure, Strike and Velvet RTAS plugins, check the following link: http://www.digidesign.com/index.cfm?navid=108&langid=100 The Xpand2 synth and a version of the Structure sampler called Structure Free are currently free to download from the Digidesign web site.


Pro Tools MIDI Basics