Issuu on Google+

Глава 3 Режим эскиза

DesignModeler

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-1

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

Содержание

Training Manual

• Геометрия DesignModeler • Единицы длины • Геометрические объекты DesignModeler • Режим Эскиза • Кнопка New Plane • Кнопка New Sketch • Плоскость/эскиз “From Face” • Режим эскиза в GUI • Плоскости и эскизы • Плоские преобразования • Инструменты эскиза • Создание эскизов • Детали эскиза • Привязки в эскизе ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

• Размеры в эскизе

• Отображение эскиза • Редактирование размеров • Изменение эскизов • Экземпляр эскиза • Проектирование Эскизов • Интерфейс создания геометрии

• Связанные CAD Сессии • Импортирование CAD файлов • Позиционирование импортированной геометрии • Импорт единиц измерения • Экспорт модели 3-2

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

A. DesignModeler Geometry

Training Manual

• Чтобы изучить модуль DesignModeler, сосредоточимся на четырех фундаментальных областях: – Режим Эскиза: • Содержит инструменты, чтобы создать 2-D геометрические элементы как предварительные для 3-D геометрии или элементов моделирования.

– 3D Геометрия: • Геометрия, полученная из объектов эскиза, таких как вытягивание, вращение, поверхностные модели, и т.д.

– Импорт геометрии: • Геометрия, построенная в коммерческой системе CAD. Обычно импортируется в DM, чтобы модифицировать ее для создания КЭ сетки и проводить анализ.

– Концепция моделирования: • Эти инструменты используются, чтобы создать и изменить линейные и поверхностные тела, которые могут использоваться в качестве основы для FE балок и оболочечных моделей. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-3

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

B. Единицы измерения

Training Manual

• Когда запускается новый сеанс DM, появляется диалоговое окно, которое позволяет выбрать требуемые единицы длины (может быть установлено как значение по умолчанию) – Единицы длины не могут быть изменены в середине сеанса.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-4

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

C. Геометрические объекты DesignModeler

Training Manual

• Точки – 2D точки эскиза – 3D вершины – PF точки (Объекты точек): • Пятна сварки • Точки закреплений • Точки связей

• Кромки (Линии, Кривые) – 3D, и 2D Эскизы

• Грани (Плоскости, Поверхности)

• Тела (Объемы) • Многотельные тела (не показано) ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-5

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

D. Режим эскиза

Training Manual

• Эскизы в DM создаются на плоскостях. В новой DM сессии по умолчанию есть три глобальных ортогональных плоскости (XY, ZX, YZ). • Пользователи могут создавать новые плоскости по мере необходимости путем задания положения и ориентации или с помощью существующей геометрии в качестве справочной. • Эскиз создается в два этапа: 1. Определение плоскости, на которой вы хотите создать эскиз. 2. Создать или определить эскиз который лежит на желаемой плоскости.

• Пользователи могут создать столько плоскостей, сколько необходимо. • На каждой плоскости может быть создано несколько эскизов. • На следующих слайдах будет показано, как создавать эскизы на плоскости, а также инструменты для создания эскиза. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-6

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

E. Кнопка создания новой плоскости • >New Plane

Training Manual

создается новая плоскость:

– New plane объект находится в Tree – Шесть типов плоскостей (Detail Pane): • From Plane – новая плоскость базируется на другой существующей плоскости • From Face – новая плоскость базируется на грани • From Point and Edge – новая плоскость определяется точкой и прямой кромкой

• From Point and Normal – новая плоскость определяется точкой, в то время, как нормаль плоскости определяется направлением кромки • From Three Points – новая плоскость через три точки • From Coordinates – новая плоскость определяется путем ввода координат и нормали

– Эскизы добавляются к плоскости • Эскиз используется для создания 3D геометрии

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-7

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

F. Кнопка создания нового эскиза • New Sketch

Training Manual

: создание нового эскиза в активной плоскости.

• Новые эскизы помещаются в Tree модели в активную Plane. • Перейдите в эскиз (сделайте его активным) с помощью дерева или раскрывающегося списка. • Примечание: выпадающий список привязок в эскизах активирует все плоскости (см. пример ниже). Отображаются эскизы только в XYPlane

Активная XYPlane

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-8

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

G. Создание Plane/Sketch “From Face”

Training Manual

• Показано создание новой “From Face” плоскости и эскиза на имеющейся геометрии: – Выделите желаемую поверхность в месте новой плоскости.

– Перейдите на вкладку Sketch и нарисуйте новый эскиз. – New plane и sketch будут созданы автоматически!

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-9

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

H. Изменение плоскости

Training Manual

• В DM доступны различные преобразования плоскостей. Они могут быть применены быстро, выбрав желаемые преобразования через меню "Transform" в поле окна подробностей плоскости.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-10

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Изменение плоскости

Training Manual

• После преобразования доступны дополнительные свойства, которые позволяют ввести величину смещения, углы поворота оси вращения, и т.д. Это преобразование требует как смещение, так и угол поворота.

PLANE4

Варианты для дополнительного преобразования появляются автоматически при добавлении преобразования. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-11

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

I. Детали Planes и Sketch После задания опций плоскости нажмите кнопку "Generate" и будет создана новая плоскость (можно нажать на “Generate” из RMB)

Training Manual

Исходные плоскости могут быть вкл/выкл.

Примечание: этот шаг не является обязательным для создания эскиза. Отображение систем координат и линейки может быть вкл./выкл. “Details” для каждой плоскости и эскиза контролирует их поведение.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

Triad Ruler

3-12

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

J. GUI режим эскиза

Training Manual

• В режиме GUI эскиз отображается в “toolboxes” в серии плоскостей.

Plane и sketch создание и управление Draw Panel В начале новой сессии плоскости XY отображает ся в нуле.

Toolbox Panels

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-13

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

K. Инструмент эскиза – Grid (сетка)

Training Manual

• “Settings” панель позволяет в эскизе включить и отобразить сетку (по умолчанию = выкл.). – Приведено изображение сетки с малыми и основными интервалами сетки

Малые интервалы (пунктир) ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

Основные интервалы (сплошная) 3-14

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Инструмент эскиза – Grid (сетка)

Training Manual

• Строящаяся геометрия позволяет привязки к Grid Snaps так и между главными линиями.

Этот прямоугольник построен с привязкой к линиям сетки с установленным коэффициентом 2

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-15

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Инструмент эскиза – Ruler (линейка)

Training Manual

• Инструмент Ruler (линейка) позволяет быстро оценить масштаб.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-16

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Инструмент эскиза – Auto Constraints (авто-привязка)

Training Manual

• По умолчанию DM в “auto-constraint” режиме. • Авто привязки позволяют в новых эскизах создавать автоматические привязки или ориентацию. • Курсор указывает тип привязок, которые будут применяться. • Пример: (см. документацию для полного списка)

Vertical и Horizontal привязки для линии в эскизе.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

Point привязки для начала линии в эскизе.

3-17

Совпадение привязок в начале линии на эскизе.

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Инструмент эскиза – Советы

Training Manual

• При создании или изменении плоскостей и эскизов «Look At" инструмент сразу ориентирует отображение так, что плоскость эскиза или выбранного объекта становится нормально расположенной к экрану. • Многие операции являются более эффективными с RBM в контекстном меню графического экрана. Клик правой кнопкой мыши “RMB”

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-18

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Инструмент эскиза – Советы …

Training Manual

• Undo/Redo кнопки доступны только в режиме эскиза. – Removes (удаляет) последнюю законченную операцию в эскизе. – Позволяется множественная отмена (отмена нескольких операций). – ВАЖНО: Каждая плоскость хранит свой “stack” Undo.

• "Back" операции (доступны через RMB) действует как микро отмена в течение операции эскиз. • Помните: только один эскиз активен в любое время!

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-19

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Инструмент эскиза – Советы …

Training Manual

• GUI панель меню содержит инструкцию по заполнению каждой операции. • Пример: использование операции окружность. . . 1. Выберите “Circle”

2. Следуйте инструкциям в строке состояния: выберите место для центральной точки 3. Следуйте инструкциям в строке состояния: перетащите и отпустите радиус

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-20

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

L. Эскиз – основные фигуры

Training Manual

• Как только плоскость и эскиз были указаны вы можете приступить к созданию новой геометрии из инструмента "Draw". • Помните! Некоторые операции требуют RBM для окончания! – Пример: для создания "spline" операции необходимо RMB и выбрать нужный вариант.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-21

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

M. Детали эскиза

Training Manual

• Условные обозначения для каждого эскиза (линии, окружности, многоугольники и т.д.) будут отображены.

• Полезно для параметрического моделирования, обсуждаться позже.

Можно переименовать эскиз из Detail панели.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-22

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Детали эскиза

Training Manual

• Выделение линий на графическом экране (режим отображения), будет отображать детали для линии. Можно переименовать эскиз из Detail панели.

Подробная информация для выделенной линии

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-23

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

N. Привязки в эскизе

Training Manual

• Привязки эскиза могут также отображаться в его деталях. • Привязки создаются в результате автоматического создания или определяются пользователем.

Отображение привязок

• Для удаления привязки выберите ее и нажмите RMB и delete (или используйте клавишу delete). Определение привязок

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-24

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Привязки в эскизе

Training Manual

• Эскизы также имеют цветовую маркировку, чтобы указать их текущий статус: • Бирюзовый: Не закреплен • Синий: Полностью определен

Бирюзовый

• Черный: Зафиксированный • Красный: Переопределен • Серый: Неизвестно

• Пример: • Первоначально созданные линии отображаются как незакрепленные. Обратите внимание, даже если размеры были заданы на линии, эти линии будут незакрепленными, так как они не являются фиксированными в пространстве

Синий

• Добавление еще ​2х размеров определяют эскиз и все линии отображаются синим цветом

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-25

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Привязки в эскизе

Training Manual

• Добавляя слишком много размеров и/или ограничений эскиз становится более определенным. Переопределенные линии отображаются красным цветом в графическом режиме

• Применяя "Fixed" ограничения по 2м краям показанные здесь линии отображается черным цветом

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-26

Красный Синий Красный

Бирюзовый Черный

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Привязки в эскизе

Training Manual

• Изображение ниже показывает, несовместимую ситуацию (линии отображаются серым цветом). Здесь дуга построена с радиусом 5 однако вертикальный размер был указан как 15. Очевидно, связи и размеры не могут быть удовлетворены между 2 горизонтальными линиями и дугой при сохранении этих размеров.

Серый

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-27

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

O. Привязки в эскизе

Training Manual

• DesignModeler содержит полный инструментарий размеров. • В дополнение к ручному заданию необходимых размеров, доступны также полуавтоматические размеры. – Полуавтоматические размеры окружностей выбираются пока модель полностью не ограничится, или пользователь выбирает размер в полуавтоматическом режиме. – RBM кнопка контролирует пропуск или окончание функции.

• Инструмент General размер обеспечивает быстрый доступ ко всем первичным размерам через контекстное меню правой кнопки. RMB клик в Graphics Pane ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-28

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Привязки в эскизе

Training Manual

• Move функция позволяет менять местоположение размера. • Animate для просмотра динамически измененяющегося выбранного размера. • Размеры могут быть показаны в качестве значения размера и/или названия.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-29

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Размеры в эскизе

Training Manual

• Чтобы изменить размеры выделите и измените значение в окне деталей. Выделенный размер

Введите новое значение

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-30

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

P. Редактирование размеров

Training Manual

• После создания размера его можно быстро редактировать с помощью меню опций RMB, >Edit Name/Value.

Примечание: “Generate” необходим, чтобы увидеть “Value” и его “Name”

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-31

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

Q. Отображение эскиза

Training Manual

• Управление отображением эскиза с помощью опций RMB: – Always Show Sketch (всегда отображать эскиз) – Hide Sketch (скрыть эскиз)

• По умолчанию, эскиз отображается только тогда, когда выбирается в дереве.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-32

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

R. Редактирование эскиза

Training Manual

• Инструмент Modify содержит ряд функций для редактирования эскизов.

• Некоторые функции говорят сами за себя (например, скругление, фаска). Этот раздел будет посвящен некоторые из менее очевидных функциям. • Помните! - В строке состояния в нижней части графического интерфейса в режиме реального времени отображаются инструкции для каждой функции.

Status Bar - Example

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-33

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Редактирование эскизов

Training Manual

• Split: – RMB опции (выберите прежде, чем выбрать кромки): • Split Edge at Selection (по умолчанию): разделяет кромки на две части в выбранном месте (если кромка замкнутая окружность или эллипс). Для полной окружности или эллипса, как начало так и конец создаются на выбранном месте.

• Split Edges at Point: Выберите точку, и все ребра, которые проходят через выбранную точку и они будут в ней разделены. • Split Edge at All Points: Выберите ребро и оно будет разделено во всех точках на всех точках, через которые оно проходит и у которых имеются совпадающие препятствия на его пути. • Split Edge into n Equal Segments: Установите значение N в окне редактирования, а затем выберите ребро, которое вы хотите разделить. – Примечание: n может быть задано до 100.

– “Split” полезно для эскизов, которые будут использоваться с Skin/Loft – “Split” ребра также предлагают больший контроль при последующей разбивке КЭ сетки и/или операций для создания граничных условий. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-34

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Редактирование эскизов

Training Manual

• Drag: – Можно перетащить точки или края с помощью курсора. – Изменение модели зависит от того, что выбрано, существующие привязки или размеры. – Можно заранее выбрать несколько объектов до выбора функции Drag. Drag - Пример

Выберите угловую точку прямоугольника и перетащите.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-35

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Редактирование эскизов

Training Manual

• Cut/Copy: – Необходимо выбрать paste handle (RMB), относительно которой будет выполняться Paste. – Вставка происходит вручную на место, в которое прилипает курсор при перемещении изображения в положение вставки. – Опции RMB вставки вручную: • Clear Selection (Очистить выбранный) • Использование Plane Origin как Paste Handle, плоскость в координатах 0.0, 0.0 будет использоваться для вставки элемента

– Это позволяет выбрать набор элементов для копирования в буфер обмена, и базовые плоскости в эскизе. – Если Cut или Copy нажать без выбора, то по умолчанию paste (вставка) руками будет использоваться.

Copy: RMB опции. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-36

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Редактирование эскизов

Training Manual

• Paste: – RMB Контекстное меню: • Rotate by +/- r Degrees (вращение) • Flip Horizontally / Vertically (перемещение)

• Scale by Factor f or 1/f (масштабирование) • Paste at Plane Origin (вставка) • Change Paste Handle (изменение) • End

– Paste позволяет вставить элементы, находящиеся в буфере обмена, Cut или Copy и размещать их в текущем (или новом) эскизе, даже если он находится на другой плоскости.

• Заметки о Copy/Cut/Paste: – Копирование и вставку можно выполнять несколько раз. – Можно копировать из одного эскиза и вставлять в другой. – Во время операции вставки можно изменить вставку вручную. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-37

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Редактирование эскизов

Training Manual

– Примеры Copy/Paste . . . • После создания прямоугольника мы хотим скопировать его и повернуть на 45 градусов по отношению к исходному состоянию и масштабом его в 0,5.

3. RMB

1. Copy 2. Выбор кромки

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-38

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Редактирование эскизов

Training Manual

4. Выберите Paste и укажите опции

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-39

5.

RMB Rotate

6.

RMB Scale

7.

RMB Paste

8.

RMB End

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Изменение эскиза – Быстрая Cut/Copy/Paste

Training Manual

• Cut, Copy, и Paste команды доступны в качестве опций RMB в режиме эскиза.

1) Выберите необходимое ребро 2) RMB>Copy 3) Выберите paste 4) Вставьте ребро

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-40

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Изменение эскиза

Training Manual

• Replicate: – Команда Replicate эквивалентна команде Copy, а затем Paste. – После выбора одного из вариантов RBM и Paste.

• Move: – Move команда функционирует так же, как команда Replicate с исключением того, что ваш оригинальный элемент перемещяется в новое место, а не копируется.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-41

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Изменение эскиза

Training Manual

• Offset: – Offset функция позволяет создавать множество прямых и дуг, которые строятся смещением на равное расстояние от существующего набора линий и дуг. – Оригинальный набор линий и дуг, должны быть выбраны из открытых или закрытых профилей. – Предварительно выберите ребра или элементы эскиза затем правой кнопкой мыши “End selection / Place offset” – Курсор используется для определения трех вещей: • Offset distance (расстояние смещения) • Offset side (смещение стороны)

• Offset area (смещение плоскости)

– Distance и Side ясно, но “area” является очень важным: • Если часть из выбранных кривых разрушится или ��удет пересекать друг друга, с учетом смещения стороны, и расстояния, то стрелка определяется каком направлении будет создаваться элемент. • Например. . . ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-42

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Изменение эскиза

Training Manual

2. Выделите все края, чтобы выполнить скопировать со смещением

1. Выберите инструмент Offset 3. RMB > End selection/Place offset 4. Направление стрелки определяет направление смещения.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-43

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Изменение эскиза

Training Manual

5. Обратите внимание, как создание смещения вовнутрь создает пересекающиеся дуги, показанные в нижней части экрана.

6. Чередуя выбор курсором (левый и правый элементы), мы можем определить, какие смещения области будут сохранены.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-44

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

S. Дублирование эскизов

Training Manual

• Дублирование элементов на другой поверхности эскиза или плоскости (все эскизы должны быть в текущей плоскости). • Позволяет дублировать плоские поверхности (возможно, импорт из CAD), чтобы создать из них новые объекты эскиза. • Например . . .

Создается новый эскиз, который содержит линию совпадающую с краем, выбранным в предыдущем шаге. 1) Выбрана грань на импортированной модели из CAD и создана плоскость.

2) Активирована новая плоскость и создан на ней эскиз Sketch mode > modify, ‘Duplicate’ выбран 3) Выбрано ребро в плоскости.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

4) Кликнуть RMB > ‘Duplicate Selection’. 3-45

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

T. Sketch Instance (Образцы эскиза)

Training Manual

• Sketch Instancing позволяет создавать копии эскизов и добавлять их в другой плоскости. Копии являются постоянными, то есть они будут обновляться, когда источник эскиза обновляется. – Особенности: • Кромки в Sketch Instancing фиксированы (например, с плоской границей) и не могут быть перемещены, отредактированы или удалены операциями эскиза

• При внесении изменений в базовый эскиз его образцы будут обновляться при регенерации • Образцы эскиза можно использовать как обычные эскизы для создания других элементов, кроме: – Не может быть использован в качестве базового эскизы для других копий – Sketch instances не включается в выпадающем списке эскизов

Шаг 1: Выберите необходимую плоскость для образца.

Образец эскиза должен быть в плоскости до ее назначения (выше в дереве). Therefore, you can never place a sketch instance onto the XYPlane. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-46

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Sketch Instance (Образцы эскиза)

Training Manual

Шаг 2: Выберите источник эскиза, выбрав эскиз с дерева и нажав Apply. Шаг 3: Измените параметры размещения. Образец эскиза может быть offset, повернут, и отмасштабирован. Шаг 4: Кликните Generate для завершения создания образца эскиза.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-47

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Sketch Instance (Образцы эскиза)

Training Manual

• Пример: Sketch1 является образцом для Sketch2 на Plane4. Обратите внимание как выглядят зафиксированные кромки, которые являются краями прямоугольника.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-48

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

U. Sketch Projection (Проекция эскиза)

Training Manual

• Sketch Projection: – Проекция 3D геометрии на плоскость для создания новых объектов эскиза. – Выделение вершин, кромок, поверхностей или тел на проекции. – Не может быть изменена с помощью обычных инструментов эскиза. – Остается связана с исходной геометрией (если 3D геометрия изменяется, то проекция эскиза может обновляться).

Эскиз проецируется на существующую плоскость

3D Геометрия выбранная для проекции ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-49

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

V. Geometry Interfaces

Training Manual

• Все Workbench Geometry Interfaces поддерживаются в DesignModeler – Можно также импортировать CFX-BladeGen 4.1 геометрию (*.bgd) в Design Modeler • По желанию выберите необходимую геометрию в ‘Blade Sets’ и импортируйте

• DM >File>Import & >File>Attach capability: – Можно Import/Attach в любое время, даже несколько раз в модели – Можно добавлять, или вычитать, и т.д. в течении Import/Attach процесса – Базируется на базовых Плоскостях для ориентации

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-50

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

W. Attaching to a CAD Session

Training Manual

• Если CAD сессия в данный момент открыта, то модель автоматически импортируется в DesignModeler File>Attach to Active CAD File • Поддерживается двунаправленная ассоциативность

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-51

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Attaching to a CAD Session

Training Manual

• Двунаправленное обновление – Обновляется геометрия, используя значения параметров из любого исходного CAD пакета или для CAD параметров в DesignModeler's Details View.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-52

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

X. Importing CAD Files

Training Manual

• File>Import External Geometry File… – “Активные” плоскости контроля размещаются для моделирования “сборки” (мультитела).

– Позволяет создавать следующие операции: Add Material, Cut Material, Imprint Faces, Add Frozen – Не поддерживает ассоциативность Активная плоскость

Операция Типы файлов ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-53

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

Y. Позиционирование Imports

Training Manual

• Import и Attach имеют “Base Plane”. – Укажите плоскости (ориентация) на которые ссылается Import или Attach модель … – Когда создается новый Import или Attach элемент, активируется выбор плоскости Base Plane по умолчанию – Пользователи выбирают Plane из дерева или выпадающего списка

• Пример: – XY выбрана первой для импорта – YZ выбрана второй для импорта

– Operation: ‘Add material’ выбрана

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-54

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

Z. Импорт единиц измерения

Training Manual

• Большинство информации о единицах измерения содержится в формате файла (автоматически устанавливается на импорт). • SAT формат файла должен быть установлен в правильные единицы длины через импорт детали (до Generate) – DM затем преобразует единицы длины модели в текущие единицы системы

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-55

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

AA. Exporting a Model

Training Manual

• File>Export … • IGES экспортирование: – При экспорте модели в файл IGES, у Вас есть возможность экспортировать твердые тела или просто отделаны поверхности. – >Tools>Options

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-56

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

BB. Атрибуты тел

Training Manual

• DM поддерживает два типа тела атрибутов через Import и Attach функции: – Толщину поверхностных тел – Свойства материала • Свойства материала находятся под контролем Import Material Properties опции в списке свойств по импорту и Attach свойств. Если установлено значение > Yes, то любые свойства материала будут обрабатываться с телами. Свойства материала доступны только для чтения в DM - они добавлены через Import и Attach элементы, но вы не можете редактировать их. – Свойства передаются с моделью при отправке ANSYS Mechanical.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-57

April 28, 2009 Translated by TMMiSAPR, 2012


Sketch Mode

… Атрибуты тел

Training Manual

• Толщина поверхностного тела переносится в DM из CAD систем, которые ее поддерживают. – Пользователи могут изменять толщину любого поверхностного тела в DM. – Толщина будет прикреплен к поверхностному телу, когда модель передается в ANSYS Mechanical.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

3-58

April 28, 2009 Translated by TMMiSAPR, 2012


DM_12_CH03_sketch-rus