Page 1

Часть 2 Графический интерфейс пользователя

DesignModeler

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-1

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

A. DesignModeler Обзор

Training Manual

• DesignModeler (DM) является компонентой ANSYS Workbench. • CAD моделер для решения следующих задач: – Позволяет выполнять уникальные модификации геометрии для моделирования:

• Функция упрощения • Операция замыкания

DesignModeler

• Операция заполнения • Пятна сварки • Разделение поверхности • Удаление поверхности модели • Удаление плоского тела

• Моделирование балок ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-2

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… DesignModeler Обзор

Training Manual

– Позволяет параметрически моделировать: • 2D Эскиз с размерами и связями – Интегрируется непосредственно с Ansys Workbench модулями

DesignModeler

• Simulation • Meshing • Advanced Meshing (ICEM) • DesignXplorer • BladeModeler

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-3

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

B. DesignModeler и CAD файлы

Training Manual

• DesignModeler сессия может начинаться с CAD геометрии (импорт): – File > Attach to Active CAD Geometry: • Обнаруживает и импортирует текущую CAD модель из открытой CAD системы • Способ программного расширения (Двунаправленный) – File > Import External Geometry File . . . • Просматривает и открывает нейтральные файлы геометрии (Parasolid, SAT и др.) • Только форма – Опции импорта включают: • Тип тела (твердое, оболочка, все) • Упрощение – Geometry: возвращает NURBs в аналитическую геометрию, если возможно – Topology: сливает дублирующиеся обьекты • Clean/Heal: пытается восстановить неполную или плохо определенную геометрию

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-4

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

C. DesignModeler Обзор GUI

Training Manual

• Расположение GUI: – Меню и панели инструментов принимают команды введенные пользователем – Панель инструментов может быть “приклеена” и изменена в соответствии с предпочтениями пользователя

• Два основных режима работы

Основные режимы

– Создание эскизов (2D) – Создание модели (3D)

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-5

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… DesignModeler Обзор GUI

Training Manual

Меню, Панель инструментов, Раскрывающийся лист Панель дерева (включая плоскости, свойства, операции, тела, и т.п.)

ГРАФИКА (Просмотр модели)

Основные режимы Отображение осей

Панель свойств Статус/Инфо ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-6

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

D. Менеджер окон Workbench

Training Manual

• Позволяет пользователям настраивать отдельные панели по мере необходимости – Перемещать и изменять размеры панелей – Прикреклеевать вкладки – Автоматическое скрытие

• Автоматическое скрытие – Панели или прикрепляются или освобождаются – Отстегнутая вкладка прячется когда неактивна

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-7

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… Менеджер окон Workbench

Training Manual

• Перемещение и прикрепление – Перетащите строку заголовка, чтобы переместить область (выберите с помощью левой кнопки мыши и перетащите) – Перетащите вкладку, чтобы 'расстыковать' область – Используйте прикрепляющиеся цели, чтобы предварительно просмотреть будущий результат расположения области – Отпустите кнопку мыши на цели, чтобы поместить или прикрепить область Кликните и тащите

Новое расположение панели Tree Outline Прикрепление цели

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-8

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… Менеджер окон Workbench

Training Manual

• Восстановление Оригинального оформления – Выберете “View>Windows>Reset Layout”

• ‘Менеджер окон’ доступен в Simulation и Meshing • Эффективное использование рабочего пространства

• Простота использования включений и интуитивная работа

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-9

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

E. DesignModeler Главное меню

Training Manual

• Главное меню: – File: базовые операции с файлами – Create: 3D операции и инструменты изменения – Concept: инструменты создания линий и поверхностей – Tools: операции моделирования, управление параметрами, настройка программы – View: модификация настроек изображения – Help: доступ к документации

Подробные данные для каждой темы рассматриваются далее ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-10

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

F. DesignModeler Toolbars

Файл менеджер

Training Manual

Только для эскиза

Контроль плоскости/эскиза

Фильтры/инструменты выбора

Контроль графики

Инструменты 3D геометрии

Подробные данные для каждой темы рассматриваются далее ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-11

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

G. DesignModeler Documentation

Training Manual

• Интерактивная помощь • Авторское право и информация о поддержке

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-12

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

H. Accessing Help Topics Вкладка поиска Вкладка содержания

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

Training Manual

Вкладка индекса

2-13

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

I. Basic Mouse Functionality

Training Manual

• Основы управления мышью (3 принятые кнопки мыши): – LMB • Выбор геометрии • <CTRL> + LMB добавляет/удаляет выбранные объекты • Удерживая LMB и перемещая курсор = непрерывному выбору

– MMB • Свободное вращение (ярлык)

– RMB • Масштаб окна (ярлык) • Открывает контекстное меню

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-14

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

J. Фильтр выбора

Training Manual

• Функции в модели идентифицируются при их графическом выборе (выбор), используя левую кнопку мыши • Выбор элементов происходит при активации одного из фильтров отбора (также для RMB)

Новый выбор Поверх2D точки, Единичный/ 2D ребра, ности 3D вершины оконный края модели выбор

Опции расширения Твердые тела, поверхностные тела, линейные тела

Adjacent/Flood Select

• В режиме выбора курсор изменяет отображение в соответствии с выделенным фильтром (он будет соответствовать значку). • Adjacent Select, выбирает поверхности или ребра, прилегающие к текущему выделению. Adjacent Select выбирает все касательные поверхности или края. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-15

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

Фильтр выбора

Training Manual

• Selection filters можно также вызвать RMB в Model View: В режиме эскиза:

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

В режиме модели:

2-16

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

K. Выбор мышью

+

Ctrl

+ Hold

Training Manual

• Добавить или удалить из текущего набора выбора – В зависимости от текущего выбора фильтра (линии, поверхности и т.д.)

• “Paint Select” - удерживайте левую кнопку мыши, затем переместите (“paint”) мыши над элементами, которые будут выбраны – В зависимости от текущего выбора фильтра (линии, поверхности и т.д.)

Примечание: Для отмены выбора всех элементов, щелкните один раз в пустой области геометрии окна ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-17

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

L. Selection Panes

Training Manual

• “Selection Panes” позволяет выбрать скрытую геометрию (линии, поверхности и т.п.) после первоначального выбора – Панели имеют цветовую маркировку, и соответствуют цвету детали (в сборке) – Методы множественного выбора применяются к выбору прозрачных Первоначальный щелчок мыши элементов Отметим, каждая область представляет объект (поверхность, кромку, и т.д.), который на воображаемой геометрии проходил бы от начального расположения щелчка мышью и как продолжение на экране в нормальном направлении просмотра. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-18

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

M. Box Selection

Training Manual

• Selection Toolbar включает в себя “Select Mode” кнопку, позволяющую пользователям выбирать элементы с помощью Single Select или Box Select – Выбор на основе активного фильтра – Тип выбора, основанный на перемещении курсора при выборе рамкой: • Выделение слева направо: элементы полностью охваченные полем выбора

Слева направо

Справа налево

• Выделение справа налево: элементы полностью или частично охваченные полем выбора

– Обратите внимание на разницу хэш марок по краям рамки, они предназначены чтобы помочь вам определить, какой тип выбора в окне будет выполняться. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-19

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

N. Graphics Controls

Training Manual

• Поведение при повороте (LMB): – Курсор недалеко от центра графического экрана = свободное вращение.

– Курсор за пределами центра = вращения вокруг Z оси отображения.

– Курсор вблизи верхнего или бокового края графического экрана = вращения вокруг X (сверху / снизу) или Y (влево / вправо) осей.

Примечание: курсор будет меняться в зависимости от стиля вращения и расположения курсора от графического объекта ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-20

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

…Graphics Controls

Training Manual

– Панорамирование (перетаскивание) – Изменение масштаба уменьшение/увеличение – Изменение масштаба модели – Вписывание модели в графический экран – Look At: выбор элемента модели (поверхность, линия, и др.) как “Look At”: Модель автоматически ориентируется нормально к выбранному элементу, с центром в указанной точке. – Экранная лупа – Следующий / Предыдущий вид

• Дополнительное управление с помощью мыши (срезы) – Находясь в режиме выбора: • Средняя кнопка мыши = свободное вращение. • Правая кнопка мыши = масштаб в рамке. • Shift + Средняя кнопка мыши = масштаб. • Ctrl + Средняя кнопка мыши = передвижение. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-21

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

…Graphics Controls

Training Manual

– Хотя в Rotate, Pan, или Zoom режим: • Щелкните левой кнопкой мыши на модели, временно сбрасывается центр зрения и вращения на месте курсора (который отображается красной точкой). • Щелкните левой кнопкой мыши в пустой области и центр модели вернется в центр тяжести.

Временный центр вращения

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-22

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

O. Контекстное меню

Training Manual

• RMB

Просмотр модели

– Context Sensitive Menus appear:

Предпросмотр печати

Дерево объекта

Tree

Примечание: Для удаления функции: выделить его на объекта: выделите его в Tree, RMB >Delete, или <Delete> используя клавиатуру, или в Create>Body Operation, и выберите объект и кликните Delete

Размеры в эскизе ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-23

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… Контекстное меню

Training Manual

• Вставка Feature (объектов): – Кликните RBM на объекте в Tree Outline и выберите Insert – Позволяет вставить новый объект к выбранному объекта в Tree Outline – Insert Feature произойдет откат объектов, то выбранного в Tree Outline – Features ниже Insert будут оставаться неактивным до регенерации модели

Новый объект

Откат

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-24

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… Контекстное меню

Training Manual

• Подавление Объектов/Деталей: RMB – Детали и Тела могут быть Suppressed (Подавлены) в Tree Outline или в Model View – Подавленные детали или тела остаются скрытыми и НЕ экспортируются в CFX-Mesh или Simulation. • Пример: Подавите твердые тела и оставьте только то тело, которое представляет часть жидкости в CFX сетке

– Объекты могут быть подавлены в Tree Outline – Когда объекты подавлены, любая функция, которая зависит от них также подавлена

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-25

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

… Контекстное меню

Training Manual

• “Go To” позволяет быструю навигацию объекта из графического окна и назад к дереву. • Выберите to go “Feature” или “Body” в дереве.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-26

April 28, 2009 Translated by TMMiSAPR, 2012


Graphical User Interface

P. Типы курсора

Training Manual

• Курсор мыши контекстно-зависим – Указывают на выбранную операцию • Просмотр, Вращение… • Выборка

• Автоматические привязки в эскизе • Статус системы “занятый, ожидайте”

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

2-27

April 28, 2009 Translated by TMMiSAPR, 2012

Profile for Ansys tmm-sapr

DM_12_CH02_gui-rus  

DM_12_CH02_gui-rus  

Profile for tmm-sapr
Advertisement