Page 1

Глава 1 Введение

DesignModeler

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-1

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Цели курса

Training Manual

• Научиться использовать DesignModeler в следующих областях: – Понимание пользовательского интерфейся – Процедура создания эскизов и задание размеров – Порядок создания и редактирования 3D геометрии – Работа с импортированной геометрии из CAD и использования 3D операций для создания регионов жидкости из твердых тел – Параметрическое моделирование

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-2

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

A. О компании ANSYS, Inc.

Training Manual

ANSYS, Inc. • Разработчик семейство продуктов ANSYS • Штаб-квартира в Канонсберг - США (к югу от Питтсбурга) – Разработка и офисы продаж расположены в США и по всему миру – Официально котируются на фондовой бирже NASDAQ под "ANSS"

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-3

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

… Семейство продуктов ANSYS

Training Manual

Семейство продуктов ANSYS, Inc. включает следующее: •ANSYS Workbench – Всеохватывающая среда для исследования и моделирования необходимых задач. •ANSYS CFD – Современные CFD решатели, в том числе CFX и FLUENT. • ANSYS Mechanical APDL – Расширенный анализ для решения механических и мультифизических КЭ задач с возможностью использования традиционного интерфейса пользователей ANSYS. • ANSYS AUTODYN – Явный решатель динамики для исследования переходных нелинейных процессов с учетом больших деформаций и напряжений, нелинейного поведения материала, нелинейного продольного изгиба, сложного контакта, фрагментации и распространения ударной волны. •ANSYS LS-DYNA – LS-DYNA это технология с явным решателем динамических процессов с пре-/постпроцессором программного обеспечения ANSYS. Этот мощный решатель может быть использован для моделирования краш тестов, ковки металла, штамповка, и катастроф. • ANSYS ICEM CFD – Мощный инструмент сеточной генерации с общей пре- и пост-обработкой. • ANSYS EKM – Engineering Knowledge Manager ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-4

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

ANSYS EKM - Engineering Knowledge Manager

Training Manual

• Что такое ANSYS EKM? – ANSYS Engineering Knowledge Manager (EKM) является многопользовательским продуктом совместной работы, который направлен на совместное управления процессами моделирования и исследований, с которыми сталкиваются пользователи. EKM тесно интегрирован с другими программами ANSYS и он также может быть легко интегрирован с другими кодами моделирования.

• Что такое ANSYS EKM Desktop? – ANSYS EKM Desktop является одним пользователем, локальная версия среды расширенного управления ключами. Она доступна как часть ANSYS R12 релиза и она может быть доступна через Workbench. Работа EKM ориентирована на решение задачи "повторного использования существующих задач" и тем самым повышения производительности и эффективности моделирования.

• EKM Desktop может быть запущен в меню "Файл" в окне проекта

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-5

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Как управлять данными и процессом?

Training Manual

• Управление данными моделирования сокращает инженерные расходы – Уменьшается время на поиски предварительных расчетов – Включение повторного использования существующих данных

• Управление процессами моделирования и рабочих процессов – Представляет среду совместной работы распределенных исследований ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-6

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

ANSYS EKM - A User Scalable Solution

Встроенный и доступный из Workbench в R12

Training Manual

Model & Data Sharing

EKM Enterprise (предприятие)

EKM Desktop (Один пользователь)

EKM Work Group (рабочая группа)

Automated Workflows

Knowledge Capture, Data Management, Protect Intellectual Property

Organization/Process Maturity ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-8

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

B. Обзор ANSYS Workbench

Training Manual

• Что такое ANSYS Workbench? – ANSYS Workbench предоставляет мощные методы для взаимодействия с семейством решателей ANSYS. Эта среда обеспечивает уникальную интеграцию с системами CAD и процессом проектирования.

• ANSYS Workbench состоит из различных приложений (некоторые примеры): – Mechanical для проведения структурных и термических анализов с использованием решателя • Meshing также включен в приложение Mechanical

– Fluid Flow (CFX) для проведения CFD анализа с использованием CFX – Fluid Flow (FLUENT) для проведения CFD анализа с использованием FLUENT – Geometry (DesignModeler) для создания и редактирования CAD геометрии для подготовки твердотельной модели для использования в Mechanical. – Engineering Data для задания свойств материалов – Meshing Application для генерации CFD и Explicit Dynamics сеток – Design Exploration для анализа оптимизации – Finite Element Modeler (FE Modeler) для импорта NASTRAN и ABAQUS сетки для использования в ANSYS – BladeGen (Blade Geometry) для создания геометрии лопатки – Explicit Dynamics моделирование явной динамики, в том числе моделирование нелинейной динамики ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-9

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

… Обзор ANSYS Workbench

Training Manual

• Среда Workbench поддерживает два типа приложений: – Родные приложения (рабочие): Текущие родные приложения Project Schematic, Engineering Data и Design Exploration. • Родные приложения запускаются и работают полностью в окне Workbench.

– Интегрированные приложения: эти приложения включают Mechanical, Mechanical APDL, FLUENT, CFX, AUTODYN и другие.

Родные приложения Интегрированные приложения ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-10

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

C. Старт DesignModeler

Training Manual

• Есть два способа запуска Workbench : – Из меню "Пуск" Windows :

– Из CAD системы

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-11

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

D. The Workbench Environment

Training Manual

• В большинстве случаев Workbench GUI разделен на 2 части (Существуют и другие окна, это будет показано далее):

The Toolbox

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

The Project Schematic

1-12

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

The Toolbox

Training Manual

• Toolbox состоит из 4 подгрупп: • Analysis systems: – Предопределенные шаблоны, которые могут быть размещены на схеме.

• Component systems: – Различные приложения, которые могут быть доступны для создания или расширения, анализа системы.

• Custom Systems: – Стандартные типы анализа для связанных задач (FSI, тепловой напряжения и др.). Пользователи могут также создавать свои собственные шаблоны.

• Design Exploration: – Инструменты параметрического управления и оптимизации. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-13

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Toolbox

Training Manual

• Отображение в панели инструментов систем и компонент будет зависеть от установленных продуктов. • С помощью флажков в окнах элементов "View All / Customize", отображаемых в панели инструментов анализ может включаться и выключаться. • В окне настройки панели инструментов, как правило оно закрыто, так как редко используется. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-14

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Старт Design-Modeler

Training Manual

• Workbench GUI>Component Systems>Geometry

b

RMB

a

• DM можно начать, нажав на CFX / FLUENT компоненты

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-15

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

The Project Schematic

Training Manual

• Проект схемы Workbench является графическим представлением определения рабочей системы или группы систем • Рабочий процесс в схеме проекта всегда слева направо. • Есть несколько приложений, которые являются родными для Workbench, то есть они работают полностью в окне Workbench: – Project Schematic, Engineering Data и Design Exploration

• Интегрированные приложения (т.н. интегрированные данные) запускаются в отдельном окне: – Mechanical (ранее Simulation), Mechanical APDL (ранее ANSYS), ANSYS FLUENT, ANSYS CFX, и др. . . .

• Блоки клеток могут быть удалены путем выбора из RMB меню.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-16

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Project Schematic

Training Manual

• В этом примере выбран статический структурный тип анализа для схемы проекта. • Из инструментов выбора можно перетащить на схему или просто кликнуть дважды.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-17

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Project Schematic

Training Manual

• При перетаскивании приложений и/или систем в различных местах на схеме, определяется проект общего анализа. • “Connectors” указывает на уровень связи между системами. • В примере показана структурная схема при перетаскивании на тепловой анализ на ячейку анализа (A4). • До завершения операции убедитесь, что есть несколько дополнительных "drop" мест, которые будут предоставлять различные типы связей между анализами (продолжение на следующей странице).

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-18

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Project Schematic

Training Manual

• По завершении операции с предыдущей страницы, обратите внимание на связь, здесь она только на уровне модели и выше. • В этом случае не будет thermal/structural связи.

• Обратите внимание, что каждому блоку анализа дается алфавитное обозначение (A, B, C и т.д.).

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-19

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Project Schematic

Training Manual

• При перетаскивании структурного анализа на уровень "Solution" мы получаем структурную задачу, которая связана с тепловым анализом.

Обратите внимание, маркер "drop" места указывает что данные будут получены из поля А2:А4, и А6.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-20

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Project Schematic

Training Manual

• Схема может быть построена при RMB выборе и выборе в "Transfer Data To New" или "Transfer Data From New". • При использовании передачи данных представлены (отображаются) все возможности передачи (вверх и вниз). • Эти выборы будут отличаться в зависимости от ячейки, которую вы выделите.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-21

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . The Project Schematic

Training Manual

• Определение состояний ячейки: • Unfulfilled: отсутствуют данные верхнего уровня. • Attention required: возможно, необходимо исправить эту или более верхнего уровня ячейку. • Refresh required: данные верхнего уровня изменились. Необходимо обновить ячейку. Обновление также исправит ячейку и восстановит любые выходные данные (например, КЭ сетку, результаты).

• Update required: данные изменились и результаты ячейки должны быть обновлены. • Всё правильно. • Input changes pending: ячейки привязаны локально, но могут изменяться при следующем обновлении. • Interrupted: решение было остановлено ​вручную, прежде чем оно выполнилось. Можно использовать Resume или Update и продолжать решение. • Pending: в ходе пакетной обработки ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-22

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Опции окна Workbench

Training Manual

• “View” меню (и RMB) позволяет отобразить дополнительную информацию в среде Workbench. – Ниже, отображаются свойства геометрии.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-23

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Workbench File Management

Training Manual

• Workbench создает файл проекта и ряд подкаталогов для управления всеми связанными файлами. • Пользователи должны позволить Workbench управлять каталогами. – Пожалуйста, не изменяйте вручную содержимое или структуру каталогов проекта.

• При сохранении проекта создается файл (. wbpj), используя указанное пользователем имя файла (e.g. MyFile.wbpj). • Для проекта будет создан каталог с использованием имени проекта. В приведенном ниже примере каталог будет MyFile_files. • Несколько подкаталогов будет создано в каталоге проекта.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-24

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

. . . Workbench File Management

Training Manual

• Структура директорий: – dpn: это – каталог проекта. Это по существу состояние всех параметров для определенного анализа. В случае единственного анализа будет только один “dp0” каталог. – global: содержит подкаталоги для каждого приложения в анализе. В примере справа "Mech" каталог будет содержать базу данных, а также другие связанные с ней файлы из приложений Mechanical. – SYS: "SYS" каталог содержит подкаталоги для каждого типа проекта (например, Mechanical, FLUENT, CFX и т.д.). Каждая система подкаталога содержит определенные файлы решения. Например подкаталог MECH будет содержать файл с результатами, ds.dat файл, solve.out файла и так далее. – user_files: содержит исходные файлы, файлы макросов пользователей и т.д., которые могут быть связаны с проектом. ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-25

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Workbench File Management

Training Manual

• Из Workbench меню "View" можно активировать меню "Files" для отображения окна, содержащего файл деталей и места сохранения.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-26

April 28, 2009 Translated by TMMiSAPR, 2012


Введение

Workbench File Management • Archive: быстро генерирует один сжатый файл, содержащий все необходимые файлы.

Training Manual

– Файл в формате ZIP и может быть открыт с помощью "Restore Archive . . ." в WB или распаковать программой.

– Существует несколько вариантов для архивирования расчета, как здесь показано.

ANSYS, Inc. Proprietary © 2009 ANSYS, Inc. All rights reserved.

1-27

April 28, 2009 Translated by TMMiSAPR, 2012


DM_12_CH01_intro-rus  
Advertisement
Read more
Read more
Similar to
Popular now
Just for you