Page 1

3DVIA Composer Hands-on Test Driver

Image courtesy of National Optical Astronomy Observatory, operated by the Association of Universities for Research in Astronomy, under cooperative agreement with the National Science Foundation.


3DVIA Composer Training  使用本书: 正如标题所提级的,这是一个真实地体验。你将很快学会使用3DVIA Composer,你将会体验许多3DVIA Composer的专业能力,你将会在操作 中得到学习。一旦开始了3DVIA Composer,你将采用3D数据去创建视 图和动画。  开始之前: 本书所使用的3DVIA Composer文件都在“3DVIA Composer Test Drive”文件夹下,本书都是假设你将在同一个子文件 下保存文件或发布 产品。

© 2006 SolidWorks Corp. Confidential.

2


3DVIA Composer Training

Hands-on Test Driver – 成功完成本章的学习,你将对3DVIA Composer有一定的了解, 包括:  3D数据导航  发布2D高分辨率光栅图片  发布2D矢量图片  创建带有编号和零件清单的爆炸视图  制作3D动画  对CAD几何角色更新处理

© 2006 SolidWorks Corp. Confidential.

3


用户界面简介

© 2006 SolidWorks Corp. Confidential.

4


一、创建图片 我们首先创建一个2D图片,此图片要显示整个装配体外形,以作 为服务流程指南的封面。 打开3DVIA Composer文件(*smg), 这个3DVIA Composer文 件包含从CAD系统输入的模型。 在3DVIA Composer中可以旋转装配 体以及应用可视效果,并且可以发布为JPEG图片作为服务流程指南的 封面。

© 2006 SolidWorks Corp. Confidential.

5


开启3DVIA Composer并打开文件 1.开启3DVIA Composer应用程序:  从Windows[开始]—[所有程序]—[3DVIA Composer V6R2009]— [3DVIA Composer ]开始。  双击桌面快捷方式(如图所示) 2.打开文件:  单击菜单[文件]—[打开],打开Seabotix LBV150.smg文件。 3.另存文件:  单击菜单[文件]—[另存为],保存名为My Seabotix LBV150。 4.激活视图:  切换视图标签,双击[Deault],这时显示的是Deault方向。 Note: 当使用3DVIA Composer打开CAD系统文件时,3DVIA Composer文件不能自动保存(包括Deault视图),这个Deault视 图是手动的添加到文件中的。

© 2006 SolidWorks Corp. Confidential.

6


导航3D数据 3DVIA Composer以装配树特征形式显示3D数据,你可以改变装配 体的视图方向,方法如下:  缩放模型:在视图区域,你可以通过双击被选择的几何角色来缩放, 或者滚动鼠标中键来缩放。  移动模型:在视图区域,通过按住鼠标中键平移模型。  旋转模型:在视图区域,按下鼠标右键,拖动旋转模型。 另外,视图区域右上角的“罗盘”确定3D的位置方向,红色、绿色、 蓝色轴各自代表X、Y、Z方向。当你旋转模型时, “罗盘”也随之旋转。 你可以单击某个轴以正视“罗盘”,旋转至那个方向。 下面的视图显示了不同方向和比例。

© 2006 SolidWorks Corp. Confidential.

7


显示特殊视图 1.使用“罗盘”  单击垂直轴Y查看模型的上视图。  再次单击垂直轴Y查看模型的底部视图。  单击垂直轴Z查看模型的前视图。 2.旋转模型  按下鼠标右键拖动并旋转,旋转至如图所示。 3.平移装配体  按下鼠标中键,拖动模型至视图区中央。

非透视模式

© 2006 SolidWorks Corp. Confidential.

8


显示特殊视图 4.应用透视模式  单击[导航]—[透视模式] 5.缩放至合适大小  滚动鼠标中键,缩小几何体。  在视图区域的空白区域双击,模型以合适大小显示。

透视模式

© 2006 SolidWorks Corp. Confidential.

9


利用视图 视图代表了视图区域的模型的快照。视图保存了属性以及模型和画 中所有可视零件,视图也记录了照相机位置、爆炸视图里零件的位置 以及视图区域的属性。 要保存当前视图区域的显示模型(假设属性、位置、方向已调整好) 然后[查看]—[视图]—[创建视图],或者在视图标签选择(1,2)。 1

如果要在视图区域显示已经保存的视图,通过 双击视图标签的小图标,或者用鼠标把小图标 拖放至视图区域。

2 Note:如果想对已经保存的视图修改,此时系统 不能自动更新,需要手动更新。(如下图所示) 新视图 更新视图 © 2006 SolidWorks Corp. Confidential.

10


给手册封面创建视图 1.创建视图  在视图标签,单击[创建视图] ,此时在视图标签会出现一缩略 视图。 2.给新视图重命名  单击—暂停—单击新视图的名称,并且命名为Cover Image

© 2006 SolidWorks Corp. Confidential.

11


采用高分辨率图像模式 3DVIA Composer的高分辨率图像模式能生成光栅图像,支持的文 件类型格式为:.bmp,.jpg,.png,和.tif 采用高分辨率图像模式,你可以控制输出设置,包括:  图像的尺寸和分辨率  视图的背景  抗锯齿,等等。 下面是一个出版的高分辨率图像。

© 2006 SolidWorks Corp. Confidential.

12


发布高分辨率图像 1.激活高分辨率图像模式  单击[模块]—[高分辨率图像] 2.设置属性  选择[抗锯齿]以使模型的边线平坦光滑。  在像素宽度内设置为2000。 3.发布图片  在高分辨率图像面板上单击[另存为] 2  文件名称为Cover Image  在保存类型中选择Jpeg(.Jpg,.Jpeg,.Jpe)  设置保存路径  单击[保存]

© 2006 SolidWorks Corp. Confidential.

3

13


发布高分辨率图像 4.预览视图  找到保存的文件预览图片 5.关闭高分辨率图像模式  在3DVIA Composer中,单击任务面板右上角的”X”关闭高分辨率 图像模式. 6.保存文件  单击[文件]—[保存]

© 2006 SolidWorks Corp. Confidential.

14


创建其他视图 在这个文件中包含了一系列视图,它代表了服务流程的步骤。这个服 务流程需要移除零件,以取下Seabotix LBV150的缓冲器和框架。 在你观阅视图标签中的缩略图时,能看到Step1至Step11,这其中缺 失Step4和Step5,在下面几页中,你将创建缺失的视图,如下图所示:

Step4

© 2006 SolidWorks Corp. Confidential.

Step5

15


隐藏零件 1.激活视图  在视图标签中,双击Step3缩略图标以显示在视图区。Note:模型 方向的改变,零件的隐藏(两个螺栓),角色的显示(细节视图)。 2.隐藏协作角色  选择细节视图,也称作2D图像面板。  单击[渲染]—[隐藏选定对象] 3.隐藏几何体  选择2D图像面板的黄色螺母。 Tip:你可以放大范围去选择角色, 把鼠标移动至要选择的角色上,然 后滚动鼠标中键去放大特定区域。  单击[渲染]—[隐藏选定对象]

© 2006 SolidWorks Corp. Confidential.

16


隐藏零件 Note:你可以隐藏、甚至删除角色,如果你删除角色,那么你将从 所有文件中删除。 4.缩放至合适大小 在视图区的空白区域双击,缩放至合适大小以显示整个模型。

© 2006 SolidWorks Corp. Confidential.

17


修改属性 属性是3DVIA Composer中实体的描述。几何角色、协作角色以及 视图区域都有属性。例如:  几何角色的属性包括:颜色、边线类型等等。  协作角色的属性包括:文本、字体、形状等等。  视图区域的属性包括:颜色、光线等等。 若修改属性,选择一个或多个角色,然后在属性面板中更新信息。 下面是一些不同属性的箭头的样本,如颜色、不透明度、以及长度的 变化。

© 2006 SolidWorks Corp. Confidential.

18


强调螺栓视图 1.选择螺栓  放大螺栓区域并选择角色 2.修改属性  在属性面板,单击颜色栏,选择黄色。 3.缩放至合适大小  在视图区的空白区单击,取消选择角色。  在视图区的空白区域双击,缩放至合适大小以显示整个模型。 4.创建视图  在视图标签,单击[创建视图] 5.重命名视图 单击—暂停—单击新视图的名 称,并且命名为Step4.

© 2006 SolidWorks Corp. Confidential.

19


Digger简介 Digger是一项专业技术,它可以在模型不同区域放大,剥落角色以 查看内部结构等等。如图所示, Digger可以重点显示模型的一部分,剥 落(隐藏)上面的角色以显示它下面(被它遮盖)的角色。 Digger的工具如下: 隐藏显示工具栏

洋葱皮 X射线

缩放比率

剪裁平面 缩放 调整范围

更改兴趣点

改变光源 © 2006 SolidWorks Corp. Confidential.

解除/锁定深度 2D图象截图

20


创建细节视图 1.激活Digger视图  在视图区(你想放置视图的位置)单击;  按下Space键以激活Digger 2.显示Digger的工具  单击显示/隐藏工具以显示Digger工具(如图)。 3.更改焦点  拖动[更改兴趣点]工具,直至黄色螺栓出现在圆圈中心。 4.放大黄色螺栓  拖动[缩放比率]手柄,调整缩放比例。

© 2006 SolidWorks Corp. Confidential.

2

3

21


创建细节视图 5.创建细节视图  单击[2D图像截图], Digger关闭并且2D图像面板出现。

© 2006 SolidWorks Corp. Confidential.

22


完成视图 1.应用黑色边界  选择2D图像面板;  在属性面板中,改变[外型边框]下面的颜色为黑色。 2.更新视图  在视图标签,选择Step4视图;  单击视图标签上的更新视图。 Note:当你创建一个细节视图 时, Step4视图不能自动更 新,你必须手动更新视图。

© 2006 SolidWorks Corp. Confidential.

23


创建标注和动画 3DVIA Composer包含一系列的工具,允许你标注和动画视图以 及测量角色。下面是一些工具如:箭头、标签、编号、测量等等,这些 都称作协作角色。

© 2006 SolidWorks Corp. Confidential.

24


为下个视图准备 1.隐藏协作角色  选择2D图像面板;  单击菜单[渲染]—[隐藏选定对象]。 2.隐藏几何体角色  在2D图像面板中,选择黄色螺母;  单击菜单[渲染]—[隐藏选定对象]。 Tip:你可以按下快捷键“H键”去隐藏被选择的角色。 3.旋转视图  单击“罗盘”上的垂直轴X;  按下鼠标右键旋转装配体 大致如图所示,确保能看到 环绕的螺栓。

© 2006 SolidWorks Corp. Confidential.

25


增加箭头(一) 1.选择两个螺栓  选择一个螺栓;  按下Ctrl键再选择另一个螺栓。 2.修改属性  在属性面板,单击颜色栏选择黄色。 3.增加箭头  单击[协同]—[标记]—[3D箭头];  单击螺栓的头部以开始箭头;  单击装配体上方以结束箭头;  单击另一个螺栓的头部以开始箭头;  单击装配体上方以结束箭头;  按下ESC键退出3D箭头命令。

© 2006 SolidWorks Corp. Confidential.

26


增加箭头(二) 4.选择两个箭头  按下Ctrl键选择两个箭头 5.修改箭头属性  向右拖动不透明度控杆(至255);  清除背景下的“渐变”选项。

© 2006 SolidWorks Corp. Confidential.

27


创建新视图 1.创建一个视图  在视图标签上,单击创建视图 2.重命名视图  单击—暂停—单击新视图的名称,并且命名为Step5 3.保存文件  单击[文件]—[保存]

© 2006 SolidWorks Corp. Confidential.

28


爆炸视图 爆炸视图能够显示模型中的零件位置关系,爆炸视图一般用在 手册中以显示零件的位置,它可以联系BOM表和零件标号指明零件清 单。 在3DVIA Composer有多种方法创建爆炸视图,你可以拖动被选 择的角色至新的位置,也可以采用线性、球面、圆柱面分解模式自动地 分离角色至新的位置。 下面是Seabotix LBV150机器的一个子装配体的爆炸视图:

© 2006 SolidWorks Corp. Confidential.

29


改进装配视图 1.激活视图  双击Parts List视图,以显示在视图区。 2.爆炸其他角色  单击[变换]—[平移模式];  选择附近的一个壳体;  拖动蓝色的箭头移动壳体;  选择另一个壳体;  拖动蓝色的箭头移动另一个壳体;  再次单击[变换]—[平移模式]关闭工具; 3.更新视图  在视图标签上,选择Parts List视图;  在视图标签上,单击[更新视图]。

© 2006 SolidWorks Corp. Confidential.

爆炸两个壳体

爆炸一个壳体

30


创建矢量图像 3DVIA Composer的技术图解模式能够产生矢量图像。矢量图像 描述图片用于外型,如:线型、多边形、文本等等。 矢量图像能够缩放至任何尺寸,小的或大的,并没有失去图片的分 辨率和完整性。矢量图像还能通过编辑补偿图片的对象以编辑这些图片。 在下一个步骤里,你将采用技术图解模式去创建矢量图像,这个图 像包括服务流程里的一些关键零部件。

© 2006 SolidWorks Corp. Confidential.

31


创建零件目录表(一) 1.激活技术图解模式  单击[模块]—[技术图解];此时视图区被分为两个窗口,上面的 窗口能够旋转、缩放和添加注解,下面的窗口能够预览矢量图像。 2.改善视图  在视图区移动编号,以防引线和几何体相重叠。 3.设置属性  选择BOM表格包括角色列表。 Note:5个角色有标号,BOM ID分配给他们。最后,5个角色出现在 角色的列表中。 4.预览图像  单击“预览”,底下的窗口显示了矢量图像,你可以单击角色、编号 和列表行,此时这些对应项目会高量显示。

© 2006 SolidWorks Corp. Confidential.

32


创建零件目录表(二) 5.发布图片  在技术图解任务面板,单击“保存”;  保存文件名称:Parts List;  选择保存类型:SVG(.svg);  设置保存路径,单击“保存”。 6.关闭技术图解模式  单击任务面板右上角的“X”;  当出现右侧对话框时,单击“是”。 7.保存文件  单击[文件]—[保存]

© 2006 SolidWorks Corp. Confidential.

33


使用3D动画 一个优秀的动画能够表达流程以及可以代替大量的文本和2D图片, 在3D动画中通过观察模型的移动和变化,能够非常地表达服务流程和 装配指南。 在3DVIA Composer中的动画包括:  照相机视图的切换;模型能够缩放、平移和旋转。  位置的改变;几何角色能够爆炸,协同角色能从视图区移动。  属性的改变;几何角色能够改变颜色、不透明度、尺寸以及显示 与否。  Digger的改变; Digger能够改变尺寸、位置、焦点中心等等。

© 2006 SolidWorks Corp. Confidential.

34


播放现有动画 1.切换至动画模式  单击视图区的[照相机模式]切换至[动画模式] 2.播放动画  清除时间轴面板上[循环播放模式],此时动画播放一次;  单击时间轴面板上的[播放/暂停] Note:动画中出现:  角色旋转和缩放,几何角色和协作角色的显示与隐藏,以及Digger 的显示与隐藏。  箭头指示螺母在Step10没有出现,螺母隐藏,但是箭头没有。  Step11在动画中缺失,缓冲器和外壳仍在装配体中。

© 2006 SolidWorks Corp. Confidential.

35


改善动画 1.隐藏箭头  选择两个箭头;  在时间轴面板上的59s处单击,此时,红色的竖直时间线出现在 59s处。  在属性面板,拖动不透明度滑杆调至最左侧。此时在59s处会增加 一个时间线。 2.在时间轴面板添加一视图  在视图标签里,把Step11拖放至时间轴面板的63s处。 3.移动标记  把Step11的标记从63s拖放至60s处

© 2006 SolidWorks Corp. Confidential.

36


改善动画 4.播放后面的动画  单击时间轴面板50s处,此时时间线出现在此处。  单击时间轴面板上的[播放/暂停] 此时,动画隐藏箭头,隐藏缓冲器和外壳,并且旋转模型至它的 后面。 Tip:你可以保存动画为AVI文件,单击[文件]—[AVI另存为] 5.保存文件  单击[文件]—[保存]

© 2006 SolidWorks Corp. Confidential.

37


合并设计更改 3DVIA Composer让你把设计更改合并到你的工作中,你可以从 来自3D CAD文件更新几何角色,能够随着装配体的修改增加和删 除零件。 当3D CAD数据发生更新时,在你的服务指南里,不再需要重新生 成数字图片。在你的装配指南里,不再需要重画所有的插图。当你使 用3DVIA Composer时,最后的设计会涉及到2D图片和3D动画。 下面是SeaBotix LBV150端盖修改前后的图片:

设计修改前 © 2006 SolidWorks Corp. Confidential.

设计修改后 38


更新几何体 1.激活视图  在视图标签,双击”Default”. 2.选择要更新的角色  移动鼠标至如图所示位置,然后按下TAB键。这是临时隐藏视图区 的Acrylic 150m-1角色。  选择后盖{CH End Cap-300m STBD-no tab-revf-1}角色。 3.更新几何体  单击[文件]—[更新SMG]  在3DVIA Composer Test Drive文件夹中选择STBD_Updated.smg

© 2006 SolidWorks Corp. Confidential.

39


更新几何体  选择[修改几何体]并清除其他所有选项。  单击[更新] Note:你能够更新3DVIA Composer里的单个角色 下面是几何体的后盖的变更:

设计修改前 © 2006 SolidWorks Corp. Confidential.

设计修改后 40


更新其他角色(一) 1.选择另一个角色  在视图标签,双击“Default”;  旋转装配体如图所示方向;  移动鼠标至如图所示位置,然后按下TAB键。这是临时隐藏视图区 的Acrylic 150m-1角色。  选择后盖{CH End Cap-300m STBD-no tab-revD-1}角色。 2.更新几何体  单击[文件]—[更新SMG]  在3DVIA Composer Test Drive文件夹中选择PORT_Updated.smg  单击[更新]

© 2006 SolidWorks Corp. Confidential.

41


更新其他角色(二)

Step6

Step11

3.播放动画  单击视图区左上角的“照相机模式”切换至“动画模式”。  单击时间轴面板上的[快退]  单击时间轴面板上的[播放/暂停] Notice:更新过的角色在动画中已经自动更新。

© 2006 SolidWorks Corp. Confidential.

42


发布所有视图(一) Note:发布视图去创建服务流程所需的图片,不是所有的视图描述服务 图片。比起创建多个单一视图,他很容易丢弃关联图片。 1.激活“高分辨率图像模式”  单击[模块]—[高分辨率图像] 2.设置属性  选择[抗锯齿]以使装配体的边线平坦光滑。  在像素宽度内设置为2000。  在“多个图像”下,选择视图去创建3DVIA Composer文件中每个 视图的图片。 3.发布图片  在高分辨率图像面板单击[另存为];  设置文件名称为:Service images;  选择保存类型为:Jpeg(.jpg,.jpeg,.jpe);  设置保存路径;  单击[保存] © 2006 SolidWorks Corp. Confidential.

43


发布所有视图(二) 4.预览视图  找到保存的文件预览图片 5.关闭高分辨率图像模式  在3DVIA Composer中,单击任务面板右上角的”X”关闭高分辨率 图像模式. 6.保存文件  单击[文件]—[保存]

© 2006 SolidWorks Corp. Confidential.

44


3DVIA播放器介绍 3DVIA播放器是一个免费的工具,它能够满足发布者发布3DVIA Composer文件给任何用户。 3DVIA Composer安装时会自动安装, 3DVIA播放器使得用户高效地体验产品的发布。 取决于3DVIA Composer保存的权限,你可以:  缩放、平移、旋转角色;  使用Digger,以及它的缩放、”X”射线和别的工具;  显示视图和动画播放;  添加注解、尺寸和其他协作角色。

© 2006 SolidWorks Corp. Confidential.

45


在3DVIA播放器中观看文件 1.开启3DVIA播放器应用程序:  从Windows[开始]—[所有程序]—[3DVIA Composer V6R2009]— [3DVIA Player ]开始。  双击桌面快捷方式(如图所示) 2.打开文件:  单击菜单[文件]—[打开],打开My Seabotix LBV150.smg文件。 3.体验3DVIA播放器:  双击视图标签中的小图标,显示视图;以及播放动画; Note:这是在3DVIA Composer中移动Step11的原因, Step11旋转装 配体并隐藏角色。  通过单击[快退],然后单击[播放/暂停]以播放整个动画;  单击“罗盘”上的轴重新定向模型;  按下鼠标右键以旋转模型;  双击视图区的空白区域,以在窗口中缩放至合适大小。 © 2006 SolidWorks Corp. Confidential.

46


Thanks 3DVIA Composer Training Solidwizard Co.,Ltd Charles Engineer

Image courtesy of National Optical Astronomy Observatory, operated by the Association of Universities for Research in Astronomy, under cooperative agreement with the National Science Foundation.

3dvia_08110105_张国伟  

3dvia,via,composer

Read more
Read more
Similar to
Popular now
Just for you