Page 1


Plugins Galore We’ve gone plugin crazy this edition with new, old and essential plugins.

When

the

guy

the

made

Artisan, BoolTools and Profile Builder asks you to test his latest creation, SketchUV, you bite his arm off.

say we were impressed is an

There’s also links to some cool

understatement.

cars, dynamic molding tutorials

Not only that, we took Vertex Tools for a test drive too,

and Autodesk’s 123D. Enjoy this edition!

and debunked some of the

After weeks of testing and

often overlooked features of

tweaking we have an exclusive

RoundEdge.

first look at SketchUV and to

dynamic molding

Vroom Vroom

LayOUt tips

04 Create an intricate molding. Adriana Granados’ shows you how to utilise the power of dynamic components.

11 Ultra Lo-Poly cars? Richard Jeffrey shares some exquite models for your NPR scenes plus an extra treat for LayOut users.

14 LayOut workflow. Aidan Chopra’s SketchUp to LayOut tip makes scene setup so easy.

Sketchuv review

Gallery

Vertex tool

18 Dale’s back with SketchUV. UV Mapping plugin gets chewed and reviewed. Is this a game changer for SketchUp?

31 Are you featured? Our members submissions to the Gallery for February

28 Revisiting an old classic. A closer look at Thomthom’s powerful editor.


Dynamic molding onlay by adriana granados

ornate designs are more intricate but make a big difference

ated.

To avoid having too many faces and overload

counts. Crown molding can change the entire feel

the model I always try to create a model based

of a room. Usually having a profile and drawing a

on as many components that can be. In this

path to apply the Follow Me tool is enough to add

particular case I created one knot of the rope as

this kind of details. Other ornate designs are more

a component. Using the capabilities of repeating

intricate and need other ways to create them.

sub-components within Dynamic Components the

is amazing what a difference a small half-round wood strip of molding can bring to a scene. In this tutorial I will show you how to make a half rope to place along an edge of the cabinetry or as the facing on the front of a shelf.

step consisted of defining the contours of the knot shape.

Using the Create loft based on Spline Curves the contours were selected as shown and the knot was cre-

When designing an interior space, every detail

While cabinetry may be considered utilitarian, it

To create the shape I found that the faster approach was to use the Curviloft plugin by Fredo6. The first

knot will replicate as many times as necessary to cover a given length entered by the user. Note that I mentioned sub-components, so in order to achieve the repetition goal it is necessary to look up this creation process. The main issue when creating a replicating sub-component is the spacing between each replicated part and how the part is replicated

Another shape was created for the initial piece of the molding.


Both rope groups were converted to components (right click > make component) named Part A and Part B with alignment set to None. Select both these components and make them a component named Rope with aignment set to Any.

Right-click on the Rope component to display the context menu. Select the Dynamic Components > Component Attributes menu option. Note: A list of attributes will only appear if you have constrained the component before trying these steps.

Add a Position attribute to Rope and a custom attribute named Length to have a field where you can input the strip length. In the Length attribute Details dialogue box specify the following parameters.

Right-click on Part B (the replicating component) to display the context menu. Select the Dynamic Components > Component Attributes menu option. The Component Attributes dialog box is displayed. Add Position and Size attributes. Constrain the LenX parameter by typing (=) before the number that it is displayed. This will prevent of changing the X size if you use the Scale tool.

Add a Position attribute to Part A.

In Part B add a custom attribute named Length and then point with the mouse to the Length attribute in Rope.


Create another custom attribute called Spacing. Enter a (=) sign and type the distance that each copy

Now right click your Rope component and choose Dynamic Comonents > Component Options. In the dia-

should be apart.

logue box that appears input you can input your required length and your molding dynamically redraw.

Add the Copies attribute from the Behavior list and type inside the value field =Length/Spacing.

Finally change the X position to ‘=COPY*Spacing’.

This formula uses a predefined attribute called ‘Copy’ to determine X positioning for each Part B. The Copy attribute is simply a counter that begins at 0 (for the original component) and adds one for each additional copy. So, Copy is equal to 1 for the first copy, equal to 2 for the second copy, equal to 3 for the third copy, and so on. Your final Part B parameters should looks like this.


a king’s ransom by richard jeffrey

Long time member, Richard Jeffrey, recently shared

Tho collection includes:

a set of ultra lo-poly cars that are great for NPR

BMW X5

scenes or as plastic/cast models in photorealistic

CITROEN XSARA

renders.

HOLDEN ASTRA

HOLDEN MONARO

MERCEDES A CLASS

PEUGEOT 307

‘To work best in sketchy NPR type renders, the

TOYOTA RAV4

critical curves of the surface have been smoothed

TOYOTA TACOMA

and a group of minimal line work added over the

VOLVO S80

Each model weighs-in at less than 100kb which is testament to Richard’s skill with SketchUp.

surface to maintain lines where needed to illustrate the panels.’

Not content with sharing this excellent collection Richard also shared a very stylish CD template designed in LayOut.


‘I have been using this for a few years from a word document so decided I’d reformat for use in Layout. It is a simple 2 fold printable CD envelope. Can be printed front side only. It certainly works best with a bubble jet printers that can print to the edge on 200-250gsm Matt stock (gloss coated stock tends to curl). If setting up for printing on any printer that doesn’t allow printing to the edge the artwork should be designed to suit. It is always worth scoring the fold lines before folding and this should as always be done on the back of the fold (front printed side). It is also worth folding and gluing before cropping to get a better finished product. Clients love receiving these as they give a very polished feel to your deliverables. I hope to see some examples of use.’ To grab your copy of the ultra lo-poly cars you can click here or for the stylish CD template you can click here. Don’t forget to show your appreciation by commenting on the threads.


SKetchUp PRO TIP: SketchUp Scenes to LayOut viewPorts by aidan chopra

Voilà! Your scene is now associated with your model Here’s a juicy little factoid that experienced SketchUp

1. In LayOut, right-click on a model viewport and

Pro users know: When you’re working with multiple

choose Open with SketchUp from the context

SketchUp model viewports in LayOut, it really helps

menu.

to create corresponding scenes in your SketchUp model. The primary reason for this is pretty simple. While it’s easy to pan, zoom and orbit your model view around in LayOut until it’s exactly right, there’s no easy way to save that view in case you need to come back to it later. If there’s a particular camera angle you want to use in your LayOut doc, it’ll save you time in the long run to open the model in SketchUp and create a scene with the view you want. Follow these steps to associate a scene you’ve created in SketchUp with a model viewport in an existing LayOut file:

2. In SketchUp, use the navigation tools to frame the view you want. 3. Add a new scene to your model (View > Animation > Add Scene). 4. Save your model. 5. In LayOut, right-click on the model viewport and

viewport.

Using section cuts in LayOut There are a few situations when you MUST use SketchUp scenes in combination with LayOut viewports. One of these involves section cuts. Because you can’t create, activate (or de-activate) section cuts directly in LayOut, you have to set up scenes to be able to make use of them*.

choose Update Reference from the context

In this example, I’ve modeled J.R. Davidson’s Case

menu.

Study House #1, and I want to create a two-page

6. Make sure the model viewport is selected, then open the SketchUp Model dialog box (Window > SketchUp Model). 7. In the “Scene” drop-down menu, choose the scene you created in Step 3.

LayOut doc as a presentation file. The first page will show a bird’s-eye perspective; the second page, a first-floor plan. I use a horizontal Section Plane to produce the plan view (see below).


Still in SketchUp, I save a scene for each of the two

*It’s technically possible to show/hide section cuts

views I want to present in LayOut:

in LayOut by making clever use of Styles, but even that has its limitations. Section cut visibility in Styles is either on or off; as soon as you add two section planes, you’re back to needing Scenes. For this reason, I prefer sticking to Scenes all the time -- it’s simpler and it works all of the time.

In LayOut, I create a two-page doc and insert the CSH#1 model on each page. Using the SketchUp Model dialog box, I assign one scene to each of the two viewports (one on each page).

For more information about J.R. Davidson’s Case Study House #1 and many more case studies you can head on over to: http://www.artsandarchitecture.com For up to date Google SketchUp news head over to: http://sketchupdate.blogspot.com/


sketchuv plugin Review by rich o’brien

Clicking the Mapping tool immediately allows you to spin(roll) your view to align your geometry if needed. To map your model you need to have geometry selected then simple right click and choose from 6 mapping methods. Planar, Spherical and Cylindrical are view based mapping methods meaning that it is dependent on your camera position. With planar, similar to the native projection method, you can get notable distortion of textures that are at sharp angles to your camera.

It does not seem like a year since

at best with external applications

Both Spherical and Cylindrical methods work as

Dale Martens released Artisan

needed for proper results. So,

expected with the best results coming from aligning

which coincided with the release

does SketchUV bridge the gap to

your camera to front view and parallel projection. Even

of our very first CatchUp. Now 12

proper mapping in SketchUp?

though this method of mapping isn’t anything new it

months later Dale is back and has given SketchUcation an exclusive look at his latest tool SketchUV.

to do for any user level and comes with some very clever tools that

current plugins then you know

can knock hours off otherwise

that they are always pushing the

fiddly texturing.

BoolTools or Artisan, Dale has a knack of creating just what users want. Well, he has gone and done it again with SketchUV.

SketchUp

9

improvements

is as

UV the

The toolbar itself is limited to just 2 buttons, a mapping tool and a path select tool, but within the mapping tool there are a plethora of options.

One of the top requests for mapping current

method of mapping textures on organic shapes are rudimentary

and the added camera spin function makes aligning

much more intuitive and very easy

If you are familiiar with Dale’s

boundaries of SketchUp, whether

is a dramatic improvement over the current system

SketchUV does make mapping

The mapping options come in 2 flavours, view based and UV based and these are initiated via a context menu click.

always pushing the boundaries of SketchUp

a breeze. Once you apply a texture (SketchUV will apply a default map if there’s none applied) you can perform further tweaks using either the VCB or the arrow keys. Textures can be rotated or scaled by holding either CTRL/Shift and pressing the arrow keys. This is also view based so the further you are from geometry the larger the transformation. The VCB commands are standard affair with numerical values rotating textures and values ending with ‘U’ or ‘V’ with scale. For example entering *2u in the VCB will scale your texture by 2 in the U direction. This gives total control over the mapping that is very simple to use.


The Box Map method is a very simple method that places a texture based on a box enclosing the selected shape. This is best used on objects that do not have many rounded edges and are roughly box shaped. A quick and dirty method of mapping but saves alot of time.

Personally, SketchUV’s strongest feature is the export/import UVs option. This is already available via UV Tools Pro Beta 0.1 but has gotten a complete overhaul for SketchUV. Now rather than export an .obj file to your appdata folder you can now assign a location where to export the UVs to. This allows you to map your

The Tube Map method is great for pipes that

model in an external application and then

the geometry is all quads. Or any tubular shape

import back into SketchUp. When you add the

where the geometry is quad based. In a matter of

scaling and rotating features to the mix you

clicks you can texture what would normally be a

now have a complete mapping solution within

painstaking task.

SketchUp.

The final mapping method is Quad Face Map which

Dale’s approach to SketchUV is catered to all

will map your texture within each quad face. If your

users levels. Meaning if you have very little

already familiar with Thomthom’s QuadFace Tools

mapping experience you can easily texture

then you can appreciate how useful this is within

with the view based methods. If you are some

SketchUp especially when your geometry is quad

what proficient with SketchUp the Tube and Quad

based.

mapping methods will give you great results. Or if Further options with the SketchUV Mapping Tool are Triangulate and Load/Save

UVs.

The

Triangulate

you regularly UV map externally then this process has been more streamlined. Overall

the

mapping

element

of

function helps when export to external

SketchUV is fairly robust. But there’s

render applications that do not play

that second tool that that we have not

nice with SketchUp geometry but an

mentioned as yet. The Path Select Tool

added feature is that it automatically

is designed to breakdown the mapping

remaps UVs after triangulating to

even further. Even as a standalone tool this is an

remove distorted perspective textures.

excellent addition to SketchUp.

The Load/Save UV feature comes into play when

It is basically a form of loop select whereby you

you want to swap out textures. Just select the area

pick a start point and it will run along a continuous

you want to change, save the UVs and the paint

edge and update live on screen to show the path

your new texture and load the UVs so the texture

it is taking.

now obeys the mapping.

SketchUV caters for all users levels


The advantage of this is that you can now mark seams in your geometry and apply one of the mapping methods to it. This increases the mapping process by a factor of ten compared with previous solutions. The mapping on this soldier took minutes to achieve using no external application. I was really surprised at how effective view based mapping can be when you have the ability adjust the camera and textures with such precision. Overall SketchUV is the best solution available to map in SketchUp. It does require you to invest some time but the rewards are worth it and at only $15 it is a bit of a bargain. You can purchase SketchUV here and make sure check out the video links below to see a thorough overview of all the features in action.

Full Overview of SketchUV

increase the mapping process by a factor of 10!

http://youtu.be/0V6NN3hqG8w

Box Mapping Tutorial http://youtu.be/clGnQdaHseM

SketchUV to Roadkill http://youtu.be/NXS6_WdXZ3s

Mapping a Road http://youtu.be/leOM55ilbOk

Exporting to other apps http://youtu.be/baQwxL6mgMQ


belkin liveaction by mike lucey

Yet again, this month’s gadget is iPhone based!

The second part of the device is a slide out iPhone

This time it is the Belkin LiveAction iPhone Camera

swivel prop.

Remote Release, a very simple to use remote

to the iPhone and the user can then position the

shutter release for the iPhone.

iPhone at the desired angle by adjusting the plastic

What I initially liked about the little device was that I did not have to read a boring instruction manual, just

The swivel prop is spring clamped

arm, ready to take shots from a distance of 30 feet / 9.14m away.

view some self explanatory images. After opening the box promptly delivered by PhotoJoJo (more about the box further on), I had it up and running in

A minor drawback is that the device can currently only

the USA. They sell for $40 plus $2.50 USA shipping

a few minutes.

be used with the LiveAction app. Ideally Belkin will

and $12 International First Class shipping.

in time provide a universal update to the LiveAction

The device consists of a sturdy hand remote with an

app and I feel this will probably happen soon as it

on/off button, a Bluetooth pair pin button, a camera

would broaden its appeal to iPhone photographers

and a video button. The package even came with

with other camera apps.

the two AAA batteries required to run the device.

The bottom line for me is that I have been waiting for a remote release for my iPhone / GoPano / tripod set up for interior panoramas which eliminates the need The software end of the package is again simple

to use a shutter time-delay and quickly vacate the

to set up with a quick download of the free Belkin

room.

LiveAction app from the App Store. The app is quite robust and easy-to-use. A useful feature is the ability to take a still shot while shooting a video Images can be sent to FaceBook, Emailed or Saved to Camera Roll for further editing and not to forget canceled if required.

Price wise the RRP of the Remote Release at Belkin is a little on the high side at $49.99. I ordered from a small but very efficient company called Photojojo in

Oh, and the box it came in! There was a ‘Warning - This shipment may contain a Stow-way-assaurus!’ notice and the box did indeed contain a dino!


IRender nXt

Photorealistic Rendering Plugin

plugin tip : Roundcorners by rich o’brien

IRender nXt is an easy to learn, yet powerful plugin for creating photorealistic renderings from right inside Google SketchUp. Create stunning images of your designs with this amazingly flexible, surprisingly affordable, plugin. If you can draw it in SketchUp, you can render it with iRender nXt.

If you use plugins then it is highly likely you have heard of, and used, Fredo’s epic collection of tools. But what most people do not seem to do these days is read the associated user manual that Fredo packages with his plugins. There are lots of hidden treasures staring you in face while you use RoundCorners that make a straight forward tool even more powerful.

While some are fairly obvious options others are often overlooked or simply forgotten about. For instance, Pivot Direction can orientate the rounding using the arrow keys. Here I’ve selected 3 edges meeting at a corner. By tapping the arrow keys I can cycle between each edge to align the rounding. This only works when rounding and not for SharpCorners or BevelEdges. Still pretty nifty feature though.


Next little treasure is the Strict Offset

and some experimentation

with this will yield interesting results. With Strict Offset you can force the rounding to remain constant with the specified distance. In these examples you can see the yellow area has Strict Offset on and the rounding is contant with the chosen distance whereas the red area shows how turning Strict Offset off yields a rounding a much larger rounding. Super truly

Rounding incredible

is feature

a of

RoundCorner but at times you may need to achieve a rounding that has a harsher appearance. Here you can see the difference between Super Rounding on (yellow) and off (red). Also you can dictate what RoundCorner does to the rounded edges using the Border Edges/Inner Edges options. Edges can be hard, soft, smooth and hidden. Here you can see how I set the yellow rounding border edges to hard and the inner edges to soft and smooth. Whereas in the second example I reversed the settings. Finally, once you have RoundCorners parameters set to your liking don’t forget you can use the Save Current to keep the settings. If you have not already tried RoundCorner you can download it here. Or if you do have RoundCorner but need to locate the User Manual try Tools > Fredo Collection > RoundCorner > Documentation... You can download RoundCorner here and make sure to read the installation instructions carefully.


CO M M U NI T Y

SHOWCASE

The latest gallery submissions on SketchUcation.com Each month we want to show what our members are achieving using SketchUp. If something takes your fancy just click the image to be brought to that topic.

solaris

cragside

USMC X-1 Theseus

Maxwell guru Jason Maranto revisits a 3DWarehouse model.

John Higgins has way too much time on his talented hands.

Amazing what Khai can fit in his Tardis.

Bye bi

loft remake

In they go

kitchen marked

Bellissimo

corner’s cut

Alejande’s incredibly detailed model of a Bi-Plane is jawdropping.

Allanx’s unique style is always a winner and very pleasing to the eye.

Dale Martens’ showcases his latest Indigo exterior work.

Jason Christiansen with Twilight and overlays gets great results.

Massimo takes a Glenn Murcutt design and gives it some Thea love.

RCossoli’s exterior and interior shots using vRay are exquisite.

turned pedestal

barcelona

mountain chalet

Dave Richards’ precision modeling and styling is feast for the eyes.

Frederico revisits an old classic and injects something new.

Fred’s still got the Twilight touch after a long sabbatical.

books.sketchUcation.com learn with the experts at your pace


There doesn’t seem to be anything by the way of an instruction manual but I did find the instructional videos quite informative. Again, as I said the process

by mike lucey

is straightforward so maybe there is no need for manuals.

photos of a Coke can, 16 in total, 8 low and 8 high level. I uploaded these and the processing time I’m no fan of Autodesk software, particularly

Currently the app is for Win folks but it looks like

was quite short, about 5 minutes

AutoCad, but like many I have had to use it, simply

they will be facilitating iPad users in the future. They

or so. The resulting 3D textured

because its an industry standard. I have always

have a ‘Notify Me!’ section on the site for the future

model was not perfect by any

found Autodesk software to be quite cumbersome

versions. They propose an Online version also

means but in fairness I think my

and bloated but 123D Catch, part of the 123D suit,

which should be interesting but alas, no mention of

photos where not consistently lit.

might just change my mind.

an OSX version.

I think with more carefully taken

Firstly, it is free, a word not normally associated with

The system requirements are as follows,

Autodesk products, so this was a good start. 123D

MS Win 7 (32 / 64 bit)

Catch’s slogan is ‘Take and make’ and from what I

Intel Core 2 Duo

have learned so far this is what it does, take picture

1 GB Ram

One use I am looking forward

and make 3D models.

1GB free disk space

to trying on Catch is ‘stationary’ person model

OpenGL compatible video car with 256MB+ memory

production but to get the subject to stay still while the

Internet connection

pictures are being taken might be a tall order!

MS run-time libraries

The process is fairly straightforward, just shoot a selection of pics of stationary people, places or things with a digital camera. Then upload the images for model generation in the cloud and once generated

Login / account set up is required before the app

the user can save as a movie, .obj or .dwg. There

can be downloaded. I installed the app on my Mac-

are some inbuilt sharing options, YouTube and

Book Pro under Boot Camp and found the set up

Email. I am still playing around with ways to get the

quite straightforward. Actually the app interface and

model into SketchUp using the .obj files. I think with

navigation tools are very user friendly and intuitive,

a little more work, the results should be okay.

maybe Autodesk and mending their ways!

"I'm no fan of Autodesk software, particularly AutoCad, but...."

is no need for a manual?'

For my test I took a selection of

photos, possibly under daylight conditions

'maybe there

the

resulting

3D

output might be quite good.

http://www.123dapp.com/


The Select Tool has 4 selection methods •

Rectangle,

Circle,

Polygon

Freehand

This makes any selection type possible. Selected vertices are marked red and if you context click you can change whether to ignore back faces which is a great feature that eliminates unneccessary Thomas Thomassen a.k.a Thomthom is part of

are

SketchUp plugin folklore with a vast collection ruby

One thing of note about Vertex Tools is that it is

wonders. But it is his one and only commercial

highly customisable via preferences and context

plugin, Vertex Tools, that stands out in the crowd.

menu.

To understand what it does you will need to understand what a vertex is. In SketchUp we are used to them being called endpoints and manipulating these is done with the move tool. In other 3D modeling

immediately

familiar

with

each

function.

selections. The selection method has a soft select feature that is controlled through the VCB. Vertices within your desired distance from the selected vertices are affected by tools that modify the geometry. The further away from the selection, the less they are affected. This is illustrated by colour-coding the vertices from Red, Orange, Yellow, Green and Blue.

packages, like Blender or C4D, manipulating

The advantage of soft selection really comes into

vertices is an essential part of the modeling

play when you use any of the transformation tools

process. Whereas in SketchUp you are not able to

with either linear(left) or cosine(right) falloff.

select and adjust vertices without impacting edges and faces. In short, it can be a very tedious task.

When you install Vertex Tools it places a single icon on the toolbar. The true toolset is activated once you click the toolbar button. This secondary toolbar is where the bulk of options reside and standard SketchUp icons are utilised for the select, move, rotate and scale tools so you


CONSTRUCTION MODELING - Step 8 There are three general types of animations that can be quickly recorded from a piecebased construction model. The first is a simple sequence massing model using Layer visibility and Scenes to control phasing and transitions. 1. Finalize the massing models for each phase 2. Organize the sequence alphanumerically in the Outliner 3. Add Layers to match the piece names in the Outliner 4. Assign pieces to Layers in the Entity dialog box 5. Deselect Layer visibility to begin Scene sequence 6. Set visibilities, camera, and preferences and add Scenes 7. Adjust the animation with Scene updates and settings

1

Edit the massing surfaces with the Push Pull tool

Push massing surfaces against face of framing View Menu sets Face Style to see transparency

Each of the transformation tools(move, scale and

Vertex Tools is one of those plugins that can be

rotate) work exactly like the native SketchUp tools.

applied in so many fields. What is really exciting

So inferencing, modifier keys etc., are all as you

is that its author Thomthom is currenly reworking

would expect but with the added power of the soft

Vertex Tools to add even more features like speed

selection and falloff options.

improvements and a nifty gizmo that is amazing!

Set color Opacity to transparent to see framing

At $20 it is great value for money and anything that

2

speeds up your workflow will pay for itself. To see a full overview of the tools and grab your copy click here. Pieces selected in the Outliner are visible in model SketchUp Version 6 or earlier onion skins hidden pieces

Away from the transformation tools you have some further toys to play with. The first is Insert Vertex ,which speaks for itself, and secondly Make Planar, which levels and smooths areas to a best fitting plane as in the image above.

U-TUBE

Videos from our books Simple sequence animation Adjusting massing models Scene set-up and updates

Label each piece of the animation in sequence Alphanumeric names self-sort in the Outliner


Click to add a Layer for each piece to control

SketchUcation roundup We need your help

Use the pull-down menu to select Layers

3 4 Select a piece in the Outliner to assign layers

Click the header to sort the layer names

If you have a few minutes to spare and want to help shape SketchUcation then fill out this survey. We

really

value

your

opinion

and

getting

to

know

you

better

helps

shape

SketchUcation.

5 Layer names match the alphanumeric piece names SketchUp Version 6 is free and faster for animations and basic modeling

6

Add and name Scenes to match layers

Hold down Shift-key and select top layer Then click last layer to select the range

Position camera angle in model*

To show our appreciation, we will be sending 3 SketchUcation Baseball Caps to the three members we consider

Add, delete, update, and reorder with Scene controls

With layers selected click to deselect Visible

As always, you can send your feedback to richob@sketchucation.com Transition times slow video

Adjust Scenes and update Prefences *Change the Camera position slightly for each Scene to slow transitions and animate changes

have contributed the most useful ideas / comments / suggestions.

7 Delay pauses the video at each Scene

CatchUp Edition 9  

SketchUcation Community News

Read more
Read more
Similar to
Popular now
Just for you