Issuu on Google+

Práctica 4.- Diseña y Elabora Algoritmos y Pseudocódigos Ramírez

Lomeli

Monica Margarita

Apellido Paterno 20137394

Apellido Materno 2”A”

No. de Cuenta

Nombre(s)

4-4-14

Grupo

30

Fecha

No. de Lista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema 1: Mostrar en pantalla la factorial de cualquier número, introducido desde el teclado. Inicio

Proceso Factorial Escribir "Ingresar su número"; Leer n; fact<-1 Para i<-1 Hasta n Con Paso 1 Hacer Fact<-fact*i FinPara Escribir "El factorial es " fact; FinProceso

Numero

Fact=1 Cont= 1 Fact = Fact x Cont Cont = Cont + 1

SI Cont<=num N Fact

Fin


b)Problema 2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%.

Proceso Salario_Neto escribir "ingrese el sueldo por hora"; leer a; escribir " Ingrese las horas trabajadas"; leer b; c<- a*b d<- c*.12 e<-c-d escribir "El sueldo neto es " e; FinProceso

C) Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I.Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. II.Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. III.El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final. Proceso Promedio Escribir 'Ingrese calificacion del primer bimestre' Leer a Escribir ' Ingrese calificacion del segundo bimestre' Leer b Escribir ' Ingrese calificacion del tercer bimestre' Leer c Escribir ' Ingrese calificacion del cuarto bimestre' Leer d z<-(a+b+c+d)/4 Si z>=8 Entonces Escribir ' El promedio final es ',z


Sino Escribir 'Pasar a primera vuelta' Escribir 'Ingrese el promedio de calificacion de primera vuelta' Leer w q<-(z+w)/2 Si q>=6 Entonces Escribir 'El promedio final es ',q Sino Escribir 'Pasar a segunda vuelta' Escribir ' Ingrese el promedio de segunda vuelta' Leer e m<-(e+z)/2 Escribir 'El promedio final es ',m FinSi FinSi FinProceso



Práctica 4 parcial 2