Page 1

Rafael Torres


Pilas Una pila (stack en inglés) es una lista ordinal o estructura de datos en la que el modo de acceso a sus elementos es de tipo LIFO (del inglés Last In First Out, último en entrar, primero en salir) que permite almacenar y recuperar datos. Se aplica en multitud de ocasiones en informática debido a su simplicidad y ordenación implícita en la propia estructura.


Insertar en Pila {procedimiento METER (PUSH)} procedimiento METER Inicio Si P = LONGMAX entonces escribir "error en METER" escribir "desbordamiento de la pila" Sino P=P+1 S(P) = X Finsi Fin

Retirar en Pila Procedimiento SACAR Inicio Si VACIA {invocación a la función VACIA} Entonces Escribir "error en SACAR" Escribir "pila vacía" Sino X = S(P) P=P–1 Finsi Fin


Colas Una cola es una estructura de datos, caracterizada por ser una secuencia de elementos en la que la operación de inserción push se realiza por un extremo y la operación de extracción pop por el otro. También se le llama estructura FIFO (del inglés First In First Out), debido a que el primer elemento en entrar será también el primero en salir.


Insertar en una cola

procedure Insertar_Elemento(var Rnumero:cola;elemento:integer;var Rfrente,Rfinal:integer;var Rexito:Boolean); begin If colallena(frente,final) then Exito:=False else begin If colavacia(Frente,Final) then begin frente:=1; final:=1; end Else if final=maxcola then final:=1 else Inc(final); Rnumero[final]:=Elemento; Exito:=true; End; End;


Eliminar en una cola Function remover(var Rnumero:cola;var Rfrente,Rfinal:integer;VAR Rexito:boolean):integer; var Elemento:Integer; Begin If colavacia(frente,final) then begin Write('La cola esta vacia'); Exito:=false; end else Begin Remover:=Rnumero[frente]; Inc(frente); If frente>maxcola then Begin Frente:=0; Final:=0; Exito:=true; End; End; End;

Analisis de Algoritmos  

Revista Pilas y Colas

Read more
Read more
Similar to
Popular now
Just for you