Page 1

Práctica 4.-DiseñayElaboraAlgoritmosyPseudocódigos Álvarez

Ochoa

Apellido Paterno 20137266

No. de Cuenta

Ángeles Teresa

Apellido Materno

Nombre(s)

2.-D

Grupo

3

Fecha

No.deLista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema1: Mostrar en pantalla el factorial de cual quier número, introducido desde el teclado.

Pseudocódigo

Diagrama de flujo

Proceso factorial Leer num1 Fact=1 Cont=1 Fact=fact*cont Cont=cont+1 Si cont <=num1 Entonces fact fact*cont Cont=cont+1 Finsi imprimir fact Fin de Proceso

Inicio

Número

Fact = 1 Cont =1

Fact = Fact X Cont

Cont = Cont + 1

SI

Cont <=num

N Fact

Fin


Problema2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es12%.

Pseudocódigo

Diagrama de Flujo

Proceso cálculo de horas Escribir “Dame el número de horas que trabajo” Leer núm. horas Escribir “A cuánto le pagan cada hora” Leer costo x hora Descuento= (numhoras*costoxhora)*.12 Total=(numhoras*costoxhora)-descuento Escribir “El total que recibe el trabajador en pesos es:” Escribir total Fin proceso

Inicio

Horas Trabajadas

Costo por hora

Sueldo = horas Trabajadas * COSTO

Sueldo

Fin

Problema3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente:

I. II.

III.

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.


Pseudocódigo

Diagrama de Flujo

Proceso promedios Leer b1, b2, b3, b4 Promedio= (b1,b2, b3,b4)/4 Si promedio>=8 Entonces Imprimir promedio Finsi Si promedio<8 Entonces Imprimir “Lo siento te vas a ordinario (primera vuelta)” Finsi Leer pv P2= (pv+ promedio)/2 Si p2<=6 entonces Imprimir p2 Finsi Si p2<6 entonces Imprimir “Lo siento, te vas a extraordinario

Inicio

Primera parcial Cal1, cal2, cal3, cal4, cal5, cal6, cal7 /7

Segunda parcial Cal1, cal2, cal3, cal4, cal5, cal6, cal7 /7

Tercera parcial Cal1, cal2, cal3, cal4, cal5, cal6, cal7 /7

Promedio = primera parcial más segunda parcial más tercera parcial /3

Promedio >0?

SI Reprobaste con un promedio

Pasaste con un promedio

Fin

Practica 4 manual  
Read more
Read more
Similar to
Popular now
Just for you