Page 1

EVeiws 8


TABLE OF CONTENTS 1

Introduction 1.1 About This Manual . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2 Navigating EViews . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2.1 Main Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2.1.1 Title Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2.1.2 Main Menu. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2.1.3 The Work Area . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2.1.4 Command Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.2.1.5 The Status Line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1.3 Additional Operations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

4

1-1 1-1 1-1 1-2 1-2 1-3 1-4 1-7 1-7

Main Menu 4.1 4.2 4.2.1 4.2.1.1 4.2.1.2 4.2.2 4.2.2.1 4.2.2.2 4.2.3 4.2.4 4.2.5 4.2.6 4.2.7 4.2.8 4.2.9 4.2.10 4.2.11 4.2.12 4.2.13 4.3 4.3.1 4.3.2 4.3.3 4.3.4 4.3.5 4.3.6 4.3.7 4.3.8 4.3.9 4.3.10 4.4 4.5 4.6 4.7 4.8 4.9

Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-1 File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2 New. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2 Workfile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2 Database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2 Program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-6 Run Program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-7 Print . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-8 TextFile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-9 Open . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Save . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 SaveAs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Close. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Import . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Export . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Print. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Print Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Run . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Exit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-10 Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Undo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Copy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Cut . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Paste. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Paste Special . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Delete . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Find . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Replace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Next. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Insert Text File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-11 Object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-12 Veiw . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-13 Proc . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-14 Quick . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-15 Options Addins . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-16 Windows. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-17

EVeiws Reference Guide

TOC-1


TABLE OF CONTENTS 4.10

2

Workfiles 2.1 2.2 2.2.1 2.2.2 2.2.3 2.3 2.3.1 2.3.1.1 2.3.2 2.3.2.1 2.3.2.2 2.3.3 2.4 2.4.1 2.4.2 2.4.3 2.4.4 2.4.5 2.4.6 2.5 2.5.1 2.5.2 2.5.3 2.5.4 2.5.5 2.6 2.6.1 2.6.2 2.6.3 2.6.4 2.7 2.7.1 2.7.1.1

3

Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-18 Workfile Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-1 Creating a Workfile. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2 To create a new workfile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2 Creating a Workfile by Reading from a Foreign Data Source. . . . . . 2-8 Creating a Workfile from an Excel File . . . . . . . . . . . . . . . . . . . . . . 2-11 New . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-14 Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-14 Browse Registry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-15 Program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-18 Run Program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-19 Print . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-19 TextFile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-21 Open. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-21 EViews Workfile... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-22 Foreign Data as Workfile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-22 Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-25 Programs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26 Programs in Add-ins Folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26 Text File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26 Import . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26 Import from File. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26 Fetch from DB. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-26 TSD File Input . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-27 DRI Basic Economic Database. . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-27 Read . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-27 Export . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-27 Store to Database . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-28 TSD File Export. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-28 Write Text-Lotus-Excel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-28 System Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-28 Edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-29 Object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-30 The Main Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-39

Objects 3.1 3.1.1 3.1.2 3.1.3 3.1.4 3.1.5

TOC-2

Objects Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Description . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Object Types. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Equation - Workfile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Series - Workfile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Graph - Workfile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

3-1 3-1 3-2 3-4 3-5 3-6

EVeiws Reference Guide


Chapter 1 1.1

Introduction

About This Manual This manual is intended to be a supplement to the User Guide which provides in depth discussions and examples for EViews and its operation. This manual provides a quick resource to guide in choosing parameters of which options to use. The chapters are divided into sections that break down various topics and matching program functions. Common practices such as creation workfiles will give preliminary instructions followed by screen-shots that include tables that describe each option and how it is used. This manual will refer to the other EViews documentation that will describe the topic in further detail.

1.2

Navigating EViews This program has several components. This section describes those features and provides some common operations instructions.

1.2.1

Main Screen The main screen has of five parts that controls the function of this program. •

Title Bar

Main Menu

Command Window

Work Area

Status Line

1-1


Chapter 1 Introduction

Navigating EViews

Title Bar

Status line

Main Menu

Command Window

Work area

Figure 1-1 Main Screen 1.2.1.1

Title Bar The Titlebar has the following active functions:

1.2.1.2

When EViews is the active program in Windows, the title bar has a darker color and intensity that differs from the other windows.

If another program is active, the EViews title bar will be lighter.

To make EViews the active program; - click anywhere in the EViews window - use ALT-TAB to cycle between applications until the EViews window is active.

Main Menu EViews function like most program you are already familiar with.

1-2

If you move the cursor to an entry in the main menu and click on the left mouse button, a drop-down menu will appear.

Clicking on an entry in the drop-down menu selects the highlighted item.


Chapter 1 Introduction

1.2.1.2.1

Navigating EViews

Navigation Menu There are several terms used in this manual used to describe commands, functions, and action when navigating through EViews. The table defines the feature on the screen and its function. NAME

DESCRIPTION

Action Button

A command button that performs a specific, pre-programmed task.

Command button

A screen button usually associated with changes in the operating parameters. Using the mouse, point to the button, and click the left mouse button.

Command Window Dialog box

A small window that appears with information or command choices.

Drop-Down menu

A menu with a list of commands or options. To display a dropdown menu, select the downward-pointing arrow that accompanies some text fields, and click on the left mouse button.

Edit field

A screen box that allows you to alter the data in the box. Examples: • Text field • Selection field (with a down arrow to reveal a drop-down menu)

Function group

A group of command buttons or icons with related actions. The group is usually surrounded by a box.

Icon

A graphic button that accesses a specific function to change a program. Using the mouse, point to the icon, and click the left button.

Information or Data field

Shows labels you can read but not edit. The unit updates the information.

Navigation Menu

A directory with branches that are used to access parameter edit screens. This program tree is located on the right-hand side of the screen.

Option buttons

Circular or square button that appear in pairs or groups. Only one button can be selected at a time. A selected button deselects when you select another button

1.2.1.3

The Work Area There are several key techniques to know when using the windows; •

they can overlap each other with the foremost window being in focus or active 1-3


Chapter 1 Introduction

Navigating EViews

only the active window has a darkened titlebar

move a window by clicking on its title bar and dragging the window to a new location

change the size of a window by clicking on any corner and dragging the corner to a new location

When a window is partly covered, you can;

1.2.1.4

bring it to the top by clicking on its Titlebar or on a visible portion of the window

cycle through the displayed windows by pressing the F6 or CTRL-TAB keys

select a window by clicking on the Window menu item, and selecting the desired name

Command Window EViews commands are typed or pasted into this window.

Figure 1-2 Command Window The command window supports Windows cut-and-paste so that you can easily move text between the command window, other EViews text windows, and other Windows programs to create and edit commands. •

The command is executed as soon as you hit ENTER.

If you have entered more commands than will fit in your command window, EViews turns the window into a standard scrollable window. Use the scroll bar or up and down arrows on the right-hand side of the window to see various parts of the list of previously executed commands.

You may: a. Move the insertion point to previously executed commands. b. Edit the existing command. c. Press ENTER to execute the edited version of the command.

1-4


Chapter 1 Introduction

Navigating EViews

To save the contents of the command window (text file format) 1.

Ensure that the command window is active by clicking anywhere in the window.

2.

Select File/Save As‌ from the main menu.

3.

Select Save Active Workfile and click OK.

Figure 1-3 Save As Popup 4.

Select the desired features from the table below.

Figure 1-4 Workfile Save

1-5


Chapter 1 Introduction

Navigating EViews

Table 1-1: Workfile Save Popup NAME Single Precision

The workfile is saved in 7 digit accuracy It is recommended for XXXXXXXXX

Double Precision

The workfile is saved in 16 digit accuracy It is recommended for XXXXXXXXX

Use Compression

This option uses Winzip to compress the workfile before saving.

Prompt on each Save

Every time you save a workfile, a prompt will appear alerting you that XXXXX

OK

Accepts all inputs and changes.

Cancel

Ends menu with no inputs or changes.

5. 1.2.1.4.1

DESCRIPTION

Click on OK. The complete workfile will be saved in the directory location you selected and can be retrieved using Open EViews Workfiles.... (Cntrl+O).

Command Display

To display a list of previous commands in the order of entry 1.

Press the Control key and the UP arrow (CTRL+UP). The last command will be entered into the command window.

2.

Holding down the CTRL key and pressing UP repeatedly will display the next prior commands.

3.

Repeat until the desired command is recalled.

To examine the history of the last 30 commands 1.

Press the Control Key and the J key (CTRL+J).

2.

In the popup window you may use the UP and DOWN arrows to select the desired command and then press the ENTER key to add it to the command window, or simply double click on the command.

3.

To close the history window without selecting a command, click elsewhere in the command window or press the Escape (ESC) key.

4.

To execute the retrieved command, simply press ENTER again. NOTE

1-6

You may first edit the command before you enter it..


Chapter 1 Introduction

Additional Operations

To change the default command window size

1.2.1.5

1.

Place the cursor at the bottom of the command window, holding down the mouse button and dragging the window up or down.

2.

Release the mouse button when the command window is the desired size.

The Status Line At the very bottom of the window is the Status Line which is divided into several sections.

Figure 1-5 Status Line •

The left section can contain status messages sent to you by EViews. These status messages can be cleared manually by clicking on the box at the far left of the status line.

The next section shows the Default Directory used to look for data and programs.

The last two sections display the names of the default database and workfile. NOTE

1.3

Chapters XXX we will show you how to change both defaults.

Additional Operations To cancel EViews 

If you wish to cancel the current task or ongoing operation, press ESC.

To close EViews

1-7


Chapter 1 Introduction

Additional Operations

There are a number of ways to close EViews.

1-8

You can always select File/Exit from the main menu, or you can press ALT-F4.

If you are running Windows 95 or NT, you

Alternatively, you can click on the close box in the upper right-hand corner of the EViews window, or double click on the EViews icon in the upper left-hand corner of the window.

Under Windows 3.1, click on the Control-menu box in the upper left-hand corner of the EViews window, and select Close.

NOTICE

EViews will warn you and provide you with the opportunity to save any unsaved work.


Chapter 4 Main Menu

Chapter 4

Overview

Main Menu

In this chapter: • •

4.1

Overview The Main Menu is comprised of ten items; File Edit Object Veiw Proc Quick Options Addins Windows Help

4-1


Chapter 4 Main Menu

4.2

File

4.2.1

New

4.2.1.1

Workfile

4.2.1.2

Database

Figure 4-1 Database 4-2

File


Chapter 4 Main Menu

File

NAME Database specification

DESCRIPTION Database/File Type: EVeiws Database EViews v6 Database DRIPro Link Fame Local Database Aremos TSD File DRI DDS Format File GiveWin/PcGive File Rats 4.x File Rats Portable File TSP Portable File DB File name/path Browse files Browse Registry: see screen below Add to Registry

Open as

4.2.1.2.1

Database alias (optional short name)

Browse Registry

Figure 4-2 Database-Browse Registry

4-3


Chapter 4 Main Menu

File

NAME

DESCRIPTION

Registered Databases Edit Registry Select Cancel

4.2.1.2.2

Edit Registry

Figure 4-3 Database - Database Registry

NAME Registered Databases and files

DESCRIPTION Add new entry Edit entry Remove entry Toggle search Move to top of Search

Auto Search

4-4


Chapter 4 Main Menu

File

Default database in search Include at start of search order Path Include at end of search order Do not include in search OK Cancel

4.2.1.2.3 Add new entry/edit entry Database Registry Entry

Figure 4-4 Database - Database Registry Entry

NAME Registry Entry

DESCRIPTION Database alias (short name) Include database in autosearch

Database Specification

Database/file type;

Database/name path 4-5


Chapter 4 Main Menu

File

Server specification User name Password Browse files OK

Accepts all inputs and changes.

Cancel

Ends menu with no inputs or changes.

4.2.2

Program

Figure 4-5 Program

NAME Run Print Save Save As Cut Copy Paste Insert Txt Find Replace

4-6

DESCRIPTION


Chapter 4 Main Menu

File

Wrap +/Line Number +/Encrypt

4.2.2.1

Run Program

Figure 4-6 Run Program

NAME

DESCRIPTION

Program name or path Program arguments Runtime errors

Verbose (slow) update screen/line status Quiet (fast) no screen/Staus line updates Version 4 compatible variable substitution and program boolean comparisons. Maximum errors before halting. Save options as default

OK Cancel

4-7


Chapter 4 Main Menu

4.2.2.2

File

Print

Figure 4-7 Print

NAME Destination

DESCRIPTION Printer Redirect Filename Properties

Text/Table options

Text size Percent Orientation

Print Range

Entire Table/Text Current Selection

Table Options

Box around tables Include headers

OK Cancel

4-8


Chapter 4 Main Menu

4.2.3

File

TextFile

Figure 4-8 Textfile

NAME

DESCRIPTION

Print Save Save As Cut Copy Paste Find Replace

4-9


Chapter 4 Main Menu

4.2.4

Open

4.2.5

Save

4.2.6

SaveAs

4.2.7

Close

4.2.8

Import

4.2.9

Export

4.2.10

Print

4.2.11

Print Setup

4.2.12

Run

4.2.13

Exit

4-10

File


Chapter 4 Main Menu

4.3

Edit

4.3.1

Undo

4.3.2

Copy

4.3.3

Cut

4.3.4

Paste

4.3.5

Paste Special

4.3.6

Delete

4.3.7

Find

4.3.8

Replace

4.3.9

Next

4.3.10

Insert Text File

Edit

4-11


Chapter 4 Main Menu

4.4

Object

New Object

4-12

Object


Chapter 4 Main Menu

4.5

Veiw

Veiw

4-13


Chapter 4 Main Menu

4.6

4-14

Proc

Proc


Chapter 4 Main Menu

4.7

Quick

Quick

4-15


Chapter 4 Main Menu

4.8

4-16

Options Addins

Options Addins


Chapter 4 Main Menu

4.9

Windows

Windows

4-17


Chapter 4 Main Menu

4.10

4-18

Help

Help


Chapter 2

Workfiles

In this chapter:

2.1

All menus/commands/operations under the File tab

Explains what a workfile is and how to make them

Workfile Overview A workfile is simply a container for EViews objects (see XXX). Most of your work in EViews will involve objects that are contained in a workfile. The first step in any project will be to create a new workfile or to load an existing workfile into memory. •

Every workfile contains one or more workfile pages, each with its own objects.

A workfile page may be thought of as a subworkfile or subdirectory that allows you to organize the data within the workfile.

Treat a workfile page as though it were a workfile (just as a subdirectory is also a directory) since there is often no practical distinction between the two.

Workfile Flange and Structure (click to structure or resize)

Title Bar

Button Bar

Current Sample (click to change)

Current Filter (click to change)

Workfile Directory

Click to scroll page tabs Workfile page tabs (click to set active page)

Click here to create a new workfile page

Figure 2-1 Workfile Features

2-1


Chapter 2 Workfiles

NOTE

2.2

Creating a Workfile

The terms “workfile” and “workfile page” may be used interchangeably.

Creating a Workfile There are three choices when it come to deciding on the type of workfile you may choose to create. They are: •

Dated - regular frequency - for simple time series dataset. EViews will prompt you to select a frequency for your data.

Unstructured - unstructured data are simply data which use the default integer identifiers.You should choose the Unstructured type if your data - is not a Dated- regular frequency - you wish to create an undated workfile that uses the default identifiers or you will eventually define an advanced structure your data.

Balanced Panel - this entry provides a simple method of describing a regular frequency panel data structure. Panel data is the term that is used to refer to data containing observations with both a group (cross-section) and time (within-group) identifiers.This entry may be used when you wish to create a balanced structure in which every cross section follows the same regular frequency with the same date observations.

NOTE

2.2.1

Unbalanced panel workfiles or ones involving more complex panel structures should be created by first defining an unstructured workfile, and then applying a panel workfile structure.

To create a new workfile 1.

Select File/New/Workfile... from the main menu to open the Workfile Create dialog box.

2.

Locate the “Workfile structure type” dialog box to determine the underlying structure of your dataset. You will choose between these settings; a. Dated - regular frequency - you may choose the following settings:

2-2


Chapter 2 Workfiles

Creating a Workfile

Figure 2-2 Workfile Create Menu- Dated regular frequency

2-3


Chapter 2 Workfiles

Creating a Workfile

NAME Date Specification

DESCRIPTION In selecting a frequency, you set intervals between observations in your data. You may choose from the following settings: •Multi-year, •Annual •Semi-annual, •Quarterly, • •Bimonthly, •Fortnight, •Ten-day, •Weekly, •Daily - 5 day week •Daily - 7 day week •Daily - custom week •Intraday •(Integer date (which is a generalization of a simple enumeration). If, for example, you select the Daily -custom week frequency, the dialog will prompt you to provide a range for the days of the week in your custom week. You should use the Intraweek/ Intraday range combo boxes to define a the start and end of the week. If you choose the Intraday frequency you will be prompted to provide additional information about the structure of your observed days. You must provide information about the frequency of observations within the day, the days of the week for the days of the week for which you observe data, and the time, and the time range of observations within a day. Start date: Choose a date in the format 00/00/00 00:00:00 as a beginning point for the project. The first part specifies the day/month/ year. The End date is also specified in hours. Alternately, the Time field denotes the hour/minute/second. End date: Choose a date in the format 00/00/00 as a beginning point for the project.

2-4

Monthly


Chapter 2 Workfiles

Workfile Name

Creating a Workfile

WF: Choose a name for the workfile. It can be any combination of alpha or numeric letters up to ____ characters. Page: Choose the number of pages you want in the workfile. Minimum number is one and the maximum is _____.

b. Unstructured - you may choose the following settings:

Figure 2-3 Workfile Create Menu- Unstructured/Undated

NAME

DESCRIPTION

Date Range

Observations: this single field prompts you for the number of observations. Enter the number of observations, and click on OK to proceed. In many cases, the integer identifiers will be sufficient for you to work with your data. In more complicated settings, you may wish to further refine your identifiers. We describe this process in “Applying a Structure to a Workfile� on page 223.

Workfile Name

WF: Choose a name for the workfile. It can be any combination of alpha or numeric letters up to ____ characters. Page: Choose the number of pages you want in the workfile. Minimum number is one and the maximum is _____. 2-5


Chapter 2 Workfiles

3.

When you click on OK, EViews will create a regular frequency workfile with the specified number of observations and the associated identifiers. c. Balanced Panel - you may choose the following settings:

Figure 2-4 Workfile Create Menu- Balanced Panel

2-6

Creating a Workfile


Chapter 2 Workfiles

Creating a Workfile

NAME Date Specification

DESCRIPTION You may choose from the following EViews standard supported settings: •

Multi-year,

Annual

Semi-annual,

Quarterly,

Monthly

Bimonthly,

Fortnight,

Ten-day,

Weekly,

Daily - 5 day week

Daily - 7 day week

Daily - custom week

•Intraday)

Workfile Name

(Integer date (a special frequency which is a generalization of a simple enumeration)

in selecting a frequency, you set intervals between observations in your data which allows EViews to use all available calendar information to organize and manage your data.

WF: Choose a name for the workfile. It can be any combination of alpha or numeric letters up to ____ characters. Page: Choose the number of pages you want in the workfile. Minimum number is one and the maximum is _____.

2-7


Chapter 2 Workfiles

2.2.2

Creating a Workfile

Creating a Workfile by Reading from a Foreign Data Source The second method for creating an EViews workfile is to open a foreign (nonEViews format) data source and to read the data into an new EViews workfile. EViews can create a new workfile by opening data from a variety of formats (HTML, Excel Ž, CSV, ASCII, RATS, Stata, SPSS, SAS, etc‌). The program automatically recognize the format and structure of files. One method to read foreign data into a new workfile is to: 1.

Copy the foreign data source to the Windows clipboard, right click on the gray area in your EViews window.

2.

Select Paste as new Workfile.

EViews will automatically create a new workfile containing the contents of the clipboard. This method is only practical for small amounts of data. Alternately, you may open a foreign data source as an EViews workfile. There are two ways to proceed. 1.

First, you may select File/Open/Foreign Data as Workfile..., to bring up the standard file Open dialog.

Figure 2-5 Open File Dialog Box 2.

2-8

Clicking on the Files of type combo box brings up a list of the file types that EViews currently supports for opening a workfile.


Chapter 2 Workfiles

Creating a Workfile

Figure 2-6 Workfile Create

Figure 2-7 Workfile Create 3.

Select a file type to narrow the list of files in the dialog, then choose the file you wish to open.

2-9


Chapter 2 Workfiles

Creating a Workfile

Figure 2-8 Workfile Create 4.

Select OK. EViews will open the specified foreign data as an EViews workfile.

NOTE

Please review the following: • If you select a time series database file (e.g., Aremos TSD, GiveWin/Pc-Give, Rats 4.x, Rats Portable, TSP Portable), EViews will create a new, regular frequency workfile containing the contents of the entire file. • If there are mixed frequencies in the database, EViews will select the lowest frequency, and convert all of the series to that frequency using the default conversion settings (we emphasize here that all of these database formats may also be opened as databases by selecting File/Open/Database... and filling out the dialogs, allowing for additional control over the series to be read, the new workfile frequency, and any frequency conversion).

If you choose one of the remaining source types, EViews will create a new unstructured workfile. •

First, EViews will open a series of dialogs prompting you to describe and select data to be read.

The data will be read into the new workfile, which will be resized to fit.

If

Then

If possible

EViews will attempt to structure the workfile using information in the file. You will have to define a structured workfile using the advanced workfile structure tools (see “Structuring a Workfile” on page 213).

If this is not possible but you still wish to apply a specific workfile structure with these data,

2-10


Chapter 2 Workfiles

2.2.3

Creating a Workfile

Creating a Workfile from an Excel File The easiest way to create a workfile is to drag/drop the file onto EViews desktop. A “+” (plus) “Copy” sign appears when the file is in the appropriate area Excel Read dialog appears. In most cases (including this one), clicking Finish on this dialog will load the data EViews scans the Excel file to determine the structure. EViews will successfully open the file. Each of the Excel columns is now an individual series EViews created an undated workfile (with 50 observations) since there were no date columns in Excel

Another way to create a workfile is to: 1.

Click File → Open → Foreign Data as Workfile.

2.

Select the directory where the Excel file is stored and open file.

Open File Dialog Box 3.

The Excel Read dialog appears again.

Figure 2-9 Workfile Create - Excel 2-11


Chapter 2 Workfiles

4.

Creating a Workfile

Click on Finish to complete the file transfer. If you want to make changes to the file use the following table to select changes the parameters. Select Next to access the next menu.

NAME Cell range

DESCRIPTION Predefined Cell Range Custom Range Sheet

End cell Transpose Next/Back Finish Cancel

Figure 2-10 Workfile Create - Excel

2-12


Chapter 2 Workfiles

Creating a Workfile

NAME Column headers

DESCRIPTION Header lines: Header type:

Column info

Name: Description: Data type

Text Representing N/A

5.

Click Finish to load the data

EViews automatically detected that the source data was a time series. You can see that the Range at the top of the workfile correctly shows the date format of the file.

2-13


Chapter 2 Workfiles

2.3

New

New Form the

2.3.1

Database

Figure 2-11 Database

NAME

2-14

DESCRIPTION


Chapter 2 Workfiles

Database specification

New

Database/File Type: EVeiws Database EViews v6 Database DRIPro Link Fame Local Database Aremos TSD File DRI DDS Format File GiveWin/PcGive File Rats 4.x File Rats Portable File TSP Portable File DB File name/path Browse files Browse Registry: see screen below Add to Registry

Open as

2.3.1.1

Database alias (optional short name)

Browse Registry

Figure 2-12 Database-Browse Registry

NAME

DESCRIPTION

Registered Databases

2-15


Chapter 2 Workfiles

New

Edit Registry Select Cancel

2.3.1.1.1

Edit Registry

Figure 2-13 Database - Database Registry

NAME Registered Databases and files

DESCRIPTION Add new entry Edit entry Remove entry Toggle search Move to top of Search

Auto Search Default database in search Include at start of search order Path Include at end of search order Do not include in search OK Cancel

2-16


Chapter 2 Workfiles

New

2.3.1.1.2 Add new entry/edit entry Database Registry Entry

Figure 2-14 Database - Database Registry Entry

NAME Registry Entry

DESCRIPTION Database alias (short name) Include database in autosearch

Database Specification

Database/file type;

Database/name path Server specification User name Password

2-17


Chapter 2 Workfiles

New

Browse files OK

Accepts all inputs and changes.

Cancel

Ends menu with no inputs or changes.

2.3.2

Program

Figure 2-15 Program

NAME Run Print Save Save As Cut Copy Paste Insert Txt Find Replace Wrap +/Line Number +/Encrypt

2-18

DESCRIPTION


Chapter 2 Workfiles

2.3.2.1

New

Run Program

Figure 2-16 Run Program

NAME

DESCRIPTION

Program name or path Program arguments Runtime errors

Verbose (slow) update screen/line status Quiet (fast) no screen/Staus line updates Version 4 compatible variable substitution and program boolean comparisons. Maximum errors before halting. Save options as default

OK Cancel

2.3.2.2

Print

2-19


Chapter 2 Workfiles

New

Figure 2-17 Print

NAME Destination

DESCRIPTION Printer Redirect Filename Properties

Text/Table options

Text size Percent Orientation

Print Range

Entire Table/Text Current Selection

Table Options

Box around tables Include headers

OK Cancel

2-20


Chapter 2 Workfiles

2.3.3

Open

TextFile

Figure 2-18 Textfile

NAME

DESCRIPTION

Print Save Save As Cut Copy Paste Find Replace

2.4

Open This command is accessed from the File pulldown menu. It has six options that

2-21


Chapter 2 Workfiles

Open

Figure 2-19 Open Menu

2.4.1

EViews Workfile... You can use File/Open/EViews Workfile… to load into memory a previously saved workfile. You may also drag-and-drop the workfile onto your EViews workspace. When you select File/Open/EViews Workfile… •

You will see a standard Windows file dialog.

Navigate to the appropriate directory and double click on the name of the workfile to load it into RAM.

The workfile window will open and all of the objects in the workfile will immediately be available. NOTE

NOTICE

2.4.2

EViews keeps a record of the most recently used files at the bottom of the File menu. Select an entry and it will be opened in EViews.

The current version of EViews can read workfiles from all previous versions of EViews. Some objects may be modified when they are read into the current version.

Foreign Data as Workfile Opening a foreign (non-EViews format) data source and to reading the data into an new EViews workfile is another method of creating an EViews workfile. •

EViews can create a new workfile by opening data from a variety of formats (HTML, Excel ®, CSV, ASCII, RATS, Stata, SPSS, SAS, etc…).

EViews automatically recognizes the format and structure of files.

Open the file in EViews and the application do the rest. 2-22


Chapter 2 Workfiles

Open

Method 1 This method is only practical for small amounts of data. 1.

Copy the foreign data source to the Windows clipboard, right click on the gray area in your EViews window.

2.

Select Paste as new Workfile.

EViews will automatically create a new workfile containing the contents of the clipboard. Method 2 There are two ways to proceed. 1.

First, you may select File/Open/Foreign Data as Workfile..., to bring up the standard file Open dialog.

Figure 2-20 Workfile Create 2.

Clicking on the Files of type combo box brings up a list of the file types that EViews currently supports for opening a workfile.

Figure 2-21 Workfile Create

2-23


Chapter 2 Workfiles

Open

Figure 2-22 Workfile Create 3.

Select a file type to narrow the list of files in the dialog, then choose the file you wish to open.

Figure 2-23 Workfile Create 4.

Select OK. EViews will open the specified foreign data as an EViews workfile.

Please note the following: •

If you select a time series database file (e.g., Aremos TSD, GiveWin/Pc-Give, Rats 4.x, Rats Portable, TSP Portable), EViews will create a new, regular frequency workfile containing the contents of the entire file.

If there are mixed frequencies in the database, EViews will select the lowest frequency, and convert all of the series to that frequency using the default conversion settings (we emphasize here that all of these database formats may also be opened as databases by selecting File/Open/Database... and filling out the dialogs, allowing for additional control over the series to be read, the new workfile frequency, and any frequency conversion).

If you choose one of the remaining source types, EViews will create a new unstructured workfile. •

2-24

First, EViews will open a series of dialogs prompting you to describe and select data to be read.


Chapter 2 Workfiles

Open

The data will be read into the new workfile, which will be resized to fit.

If

Then

If possible

EViews will attempt to structure the workfile using information in the file. You will have to define a structured workfile using the advanced workfile structure tools (see “Structuring a Workfile” on page 213).

If this is not possible but you still wish to apply a specific workfile structure with these data,

2.4.3

Database

pg 281 296

Figure 2-24 Open/Database

NAME Database Specification

DESCRIPTION Database/file type;

Database/name path Browse files

2-25


Chapter 2 Workfiles

Import

Browse Registry Add to Registry Open as

Database alias (optional short name)

OK

Accepts input and changes.

Cancel

Ends menu.

2.4.4

Programs

2.4.5

Programs in Add-ins Folder

2.4.6

Text File

2.5

Import

2.5.1

Import from File

2.5.2

Fetch from DB

2-26


Chapter 2 Workfiles

Export

Figure 2-25 Fetch from DB

NAME

DESCRIPTION

Fetch from Path for DE files Objects to fetch Links OK Cancel

2.5.3

TSD File Input

2.5.4

DRI Basic Economic Database

2.5.5

Read

2.6

Export

2-27


Chapter 2 Workfiles

2.6.1

Store to Database

2.6.2

TSD File Export

2.6.3

Write Text-Lotus-Excel

2.6.4

System Tools

Export

Print Print Setup Run Save You should name and save your workfile for future use. Push the Save button on the workfile toolbar to save a copy of the workfile on disk. You can also save a file using the File/Save As… or File/Save… choices from the main menu. EViews will display the Windows common file dialog.

You can specify the target directory in the upper file menu labeled Save in. You can navigate between directories in the standard Windows fashion—click once on the down arrow to access a directory tree; double clicking on a directory name in the display area gives you a list of all the files and subdirectories in that directory. Once you have worked your way to the right directory, type the name you want to give the workfile in the File name field and push the Save button. Alternatively, you could just type the full Windows path information and name in the File name edit field.

2-28


Chapter 2 Workfiles

Edit

In most cases, you will save your data as an EViews workfile. By default, EViews will save your data in this format, using the specified name and the extension “.WF1�. You may, of course, choose to save the data in your workfile in a foreign data format by selecting a different format in the combo box. We explore the subject of saving foreign formats below in xxxxxx.

Saveas Close Exit

2.7

Edit

Figure 2-26 Edit Pull-down Menu

NAME

DESCRIPTION

Undo Cut Copy Paste Paste Special 2-29


Chapter 2 Workfiles

Edit

Delete Find... Replace Next Insert Next File

2.7.1

Object

Figure 2-27 Object Pulldown Menu

NAME New Object Fetch from DB Update from DB Copy Object Name Delete Freeze Output Replace Next

2-30

DESCRIPTION


Chapter 2 Workfiles

Edit

Insert Next File Print View Options

Object An elemental part of EViews design is the concept of an object. Objects are collections of related information and operations that are bundled together into an easy-to-use unit. EViews holds all of its objects in object containers. The most important object container in EViews is the workfile, which is described in Chapter 3.“Workfile Basics,� beginning on page 33.

2-31


Chapter 2 Workfiles

Edit

NAME New Object..

DESCRIPTION After you click on the Object/New Object… menu entry, you will see the New Object dialog box. CONDITIONS: •Until you have created or loaded a workfile, this selection is unavailable. •To create an object, you must first make certain that you have an open workfile container and that its window is active.

Generate Series.. Manage Links & Formulas.. Fetch from DB.. Update selected from DB.. Copy selected... Rename selected... Delete selected... Print selected...

2-32


Chapter 2 Workfiles

Edit

View

NAME Open selected

DESCRIPTION (You may also select View/Open Selected or right-mouse click and select Open to access menus for opening the multiple objects.) Note that if you select multiple graphs and double click or select View/Open Selected/One Window, all of the graphs will be merged into a single graph and displayed in a single window. Other multiple item selections are not valid, and will either issue an error or will simply not respond when you double click. When you open an object, EViews will display the current view. In general, the current view of an object is the view that was displayed the last time the object was opened (if an object has never been opened, EViews will use a default view). The exception to this general rule is for those views that require significant computational time. In this latter case, the current view will revert to the default.

Show...

Click on the Show button on the toolbar, or select Quick/Show… from the menu and type in the object name or names.An alternative method of selecting and opening objects is to “show” the item.The Show button can also be used to display functions of series, also known as auto-series*. •Showing an object works exactly as if you first selected the object or objects, and then opened your selection. •If you enter a single object name in the dialog box, EViews will open The Object Window—73 the object as if you double clicked on the object name. •If you enter multiple names, EViews will always open a single window to display results, creating a new object if necessary. *All of the rules for auto-series that are outlined in “Database AutoSeries” on page 279 will apply.

Select All (except C-RESID) Select By Filter... 2-33


Chapter 2 Workfiles

Edit

Deselect All Details +/Display Filter... Name Display Statistics Label

Proc

NAME Set Sample Structure/Resize Current Page... Contract Current Page... Reshape Current Page Copy Extract Current Page Sort Current Page... Load Workfile Page... Sqave Current Page...

2-34

DESCRIPTION


Chapter 2 Workfiles

Edit

Delete Current Page Import Export

Quick

NAME

DESCRIPTION

Sample... Generate Series... Show... Graph... Empty Group (Edit Series) Series Statistics Group Statistics Estimate Equations... Estimate VAR...

Options

2-35


Chapter 2 Workfiles

NAME

Edit

DESCRIPTION

General Options... Graphics Defaults Data Registry EViews Auto-update from Web

NAME

DESCRIPTION

General Options... Graphics Defaults Data Registry EViews Auto-update from Web

Add-ins

NAME

DESCRIPTION

Mange Add-ins... Download Add-ins... Manage User Objects...

NAME Mange Add-ins... Download Add-ins... Manage User Objects...

2-36

DESCRIPTION


Chapter 2 Workfiles

NAME

Edit

DESCRIPTION

Mange Add-ins... Download Add-ins... Manage User Objects...

Window

2-37


Chapter 2 Workfiles

Edit

Help NAME

DESCRIPTION

Cascade Close All Close All Objects Toggle Command Docking Activate Next

NAME EViews Help Topics... READ ME Quick Help Reference User Guide I User Guide II

Object Reference

EViews License Agreement EViews Registration 2-38

DESCRIPTION


Chapter 2 Workfiles

Edit

EViews on the Web EViews Users Forum EViews Update About EViews

2.7.1.1

The Main Menu

NAME

DESCRIPTION

NAME

DESCRIPTION

File Edit Object View Proc Quick Options Windows Help

View Proc Properties Print Name Freeze

2-39


Chapter 2 Workfiles

Edit

Raw Data Sort

NAME View Proc Properties Print Name Freeze Raw Data Sort

2-40

DESCRIPTION


Chapter 3 Objects

Objects Overview

Chapter 3

Objects

In this chapter:

3.1

•

All menus/commands/operations under the Objects tab

•

Explains what a Object is and how to make them

Objects Overview Central to the program design is the concept of an object. They are collections of related information and operations that are bundled together into a unit. Most of your work in EViews will involve using or changing objects. EViews holds all of its objects in object containers. The most important object container in EViews is the workfile, which is described in Chapter 2.

3.1.1

Description Just below the Titlebar is a button bar that provides you with easy access to useful workfile operations. These buttons are simply shortcuts to items that may be accessed from the main EViews menu. For example, the clicking on the Fetch button is equivalent to selecting Object/Fetch from DB... from the main menu. Workfile Flange and Structure (click to structure or resize)

Title Bar

Current Sample (click to change)

Button Bar

Current Filter (click to change)

Workfile Directory

Click to scroll page tabs Workfile page tabs (click to set active page)

Click here to create a new workfile page

3-1


Chapter 3 Objects

Objects Overview

What is an Object? Information in EViews is stored in objects. Each object consists of a collection of information related to a particular area of analysis. For example, a series object is a collection of information related to a set of observations on a particular variable. An equation object is a collection of information related to the relationship between a collection of variables. Note that an object need not contain only one type of information. For example, an estimated equation object contains not only the coefficients obtained from estimation of the equation, but also a description of the specification, the variancecovariance matrix of the coefficient estimates, and a variety of statistics associated with the estimates. Associated with each type of object is a set of views and procedures which can be used with the information contained in the object. This association of views and procedures with the type of data contained in the object is what we term the object oriented design of EViews. The object oriented design simplifies your work in EViews by organizing information as you work. For example, since an equation object contains all of the information relevant to an estimated relationship, you can move freely between a variety of equation specifications simply by working with different equation objects. You can examine results, perform hypothesis and specification tests, or generate forecasts at any time. Managing your work is simplified since only a single object is used to work with an entire collection of data and results.

3.1.2

Object Types The most common objects in EViews are series and equation objects. There are, however, a number of different types of objects, each of which serves a unique function. Most objects are represented by a unique icon which is displayed in the object container (workfile or database) window. The basic object icons are given by:

NAME

3-2

DESCRIPTION


Chapter 3 Objects

Objects Overview

Alpha

Matrix

Spool

Text

Coef

Model

Sspace

Valmap

Equation

Pool

String

Var

Factor

Rowvector

Svector

Vector

Graph

Sample

Sym

Group

Scalar

System

Logl

Series

Table

Despite the fact that they are also objects, object containers do not have icons since they cannot be placed in other object containers—thus, workfiles and databases do not have icons since they cannot be placed in other workfiles or databases. Note also that there are special icons that correspond to special versions of the objects: Auto-updating Series Group data and definitions (in databases) Undefined Link

If you set a series object to be auto-updating (see ), EViews will use the special icon to indicate that the series depends upon a formula. In contrast, an auto-updating alpha series (which we imagine to be less common) uses the original alpha icon, with an orange color to indicate the presence of a formula. When group data are stored in databases, you will be given the option of storing the group definition (list of series names) alone, or both the group definition and the series contained in the group (see ). If the latter are stored, the standard group icon will be modified, with the “+” indicating the additional presence of the series data. Lastly, a link object (see ), is always in one of three states, depending upon the definition contained in the link. If the link is to a numeric source series, the link object is displayed using a series icon, since it may be used as though it were an ordinary series, with a distinctive pink color used to indicate that the object depends on linked data. If the link is to an alpha source series, the link will show up as an alpha series icon, again in pink. If, however, the link object is unable to locate the source series, EViews will display the “?” icon indicating that the series type is unknown.

3-3


Chapter 3 Objects

3.1.3

Objects Overview

Equation - Workfile

Figure 3-1 Workfile - Equation

NAME View Proc Object Print Name Freeze Estimate Forecast Stats

3-4

DESCRIPTION


Chapter 3 Objects

3.1.4

Objects Overview

Series - Workfile

Figure 3-2 Workfile - Series

NAME

DESCRIPTION

View Proc Object Properties Print Name Freeze Sort Edit+/Smpl+/Label+/Wide+/Sample Genr

3-5


Chapter 3 Objects

3.1.5

Objects Overview

Graph - Workfile

Figure 3-3 Workfile - Graph

NAME View Proc Object Print Name Freeze Option Update Add Text Line/Shade Remove Template Zoom

3-6

DESCRIPTION


sfxt guide  

software guide

Advertisement
Read more
Read more
Similar to
Popular now
Just for you