Issuu on Google+

ΑΣΚΗΣΗ 4 Σεμιαβιομηχανίααπασχολούνται25 εργαζόμενοι.Οιεργαζόμενοικαθημερινάκαι για 6 ημέρεςτηνεβδομάδα εργάζονταιαπό 4 έωςτοπολύ 12 ώρεςτηνημέρα.Γιακάθεώραμέχρικαιτις8 αμείβονταιμε 6,80€ανάώρα, ενώγιακάθεώραπάνωαπότις8 η αμοιβήτουςείναι 9,50€ανά .ώρα.Τα Σάββατα(6η ημέρατοημερομίσθιο ) γίνεται9,00€γιαόλεςτιςώρεςεργασίας.Ναγίνειπρόγραμματοοποίο: 1)

Ναπεριλαμβάνειτμήμαδηλώσεων. Μονάδες4

2)

Ναδιαβάζειταονοματεπώνυματωνεργατώνκαινα τακαταχωρείσεμονοδιάστατοπίνακα Όνομα[25] Μονάδες2

3)

Ναδιαβάζειτοχρόνοεργασίαςσεώρεςγιακάθεεργάτηκαιγιακάθεμέραστηδιάρκειατης εβδομάδας(6 ημέρες)καινα τιςκαταχωρείσεδισδιάστατοπίνακαΧρόνος[25,6], κάνονταςέλεγχο γιασωστέςκαταχωρήσεις Μονάδες3

4)

Νακαλείκατάλληλουποπρόγραμμαγιανα υπολογίζειτηνημερήσιααμοιβήγιακάθεεργάτη

5)

Ναυπολογίζεικαι να εμφανίζειτοσυνολικόποσότηςαμοιβήςτουκάθεεργάτηστηνεβδομάδακαι να τοαποθηκεύεισενέοπίνακα Μονάδες2

6)

Ναεμφανίζειτηλίστατωνονομάτωντωνεργατώνκαι τησυνολικήαμοιβήτουςκατάφθίνουσα σειράαμοιβών Μονάδες4

7)

ΝαυπολογίζειτοσύνολοτωναμοιβώνόλωντωνεργατώντοΣάββατο Μονάδες2

Ναγραφείτουποπρόγραμμαυπολογισμούτηςαμοιβήςγιατοερώτημα4 τοοποίονα καλείταιαπότοκύριο πρόγραμμα.Τουποπρόγραμμαθαδέχεταιαπότοπρόγραμματιςώρεςεργασίαςκαιτοναριθμότηςημέρας από 1 έως6, θαυπολογίζεικαιθαεπιστρέφειτοποσότηςαμοιβήςπουαντιστοιχείσύμφωναμε την παραπάνωδιαδικασία.


ΠΡΟΓΡΑΜΜΑ Θέμα_4 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: I, j, Χρόνος[25,6], ΆθροισμαΩρών _ ΠΡΑΓΜΑΤΙΚΕΣ: Ποσό[25], Temp, ΣύνολοΣύνολο , _Σαββάτου ΧΑΡΑΚΤΗΡΕΣ: Όνομα[25], Temp2 ΑΡΧΗ ! ερωτήματα 2 και 3 (γέμισμα των δύο πινάκων) Γιαi από1 μέχρι25 Γράψε ‘Δώσετοόνοματου’, i, ‘ου εργάτη’ ΔιάβασεΌνομα[i] Γιαj από1 μέχρι6 Γράψε ‘ Δώσετιςώρεςεργασίαςτην’ ,j, ‘η ημέρα’ Αρχή_Επανάληψης ΔιάβασεΧρόνοςi,j] [ Μέχρις_Ότου(Χρόνοςi,j]>=4 [ ΚΑΙ Χρόνος[i,j]<=12 Τέλος_Επανάληψης Τέλος_Επανάληψης

! Ερώτημα 5 Γιαi από1 μέχρι25 Σύνολο0 Γιαj από1 μέχρι6 ΣύνολοΣύνολο+Αμοιβή(Χρόνος,j) Τέλος_Επανάληψης Ποσό[i]Σύνολο Τέλος_Επανάληψης

! Ερώτημα 6 Γιαi από2 μέχρι25 Γιαj από25 μέχριi με_βήμα–1 Αν Ποσόj-1] [ < Ποσόj] [ τότε Temp1Ποσό[j-1] Ποσό[j-1],Ποσό[j] Ποσόj] [ temp1

! Ταυτόχρονη αντιμετάθεση των ονομάτων Temp2 Όνομαj] [ Όνομα[j-1],Όνομα[j] Όνομα[j] temp2 Τέλος_αν Τέλος_Επανάληψης Τέλος_Επανάληψης Γιαi από1 μέχρι25 Γράψε ‘Οεργαζόμενος’,Όνομα[i] , ‘θαπληρωθεί ’ , Ποσόi] [ , ‘Eυρώ’ Τέλος_Επανάληψης

! Ερώτημα 7 Άθροισμα_Ωρών0 Γιαi από1 μέχρι25 Άθροισμα_Ωρών ΆθροισμαΩρών _ + Χρόνος[i,6] Τέλος_Επανάληψης Σύνολο_ΣαββάτουΑμοιβή(Άθροισμα_Ωρών,6) Γράψε ‘ΣυνολικόποσόαμοιβήςτουΣαββάτου=’, Σύνολο_Σαββάτου

Τέλος_Προγράμματος ΣΥΝΑΡΤΗΣΗ Αμοιβήώρεςημέρα ( , ): Πραγματική ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: ώρεςημέρα , ΑΡΧΗ Αν ημέρα=6τότε Αμοιβή ώρες*9,00 Αλλιώς Αν ώρες<=8τότε Αμοιβή ώρες*9,50 Αλλιώς Αμοιβή8*6,80+ (ώρες-8)*9,50 Τέλος_αν Τέλος_αν

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


ΑΣΚΗΣΗ 4 Ελευθερίας 2007