Issuu on Google+

MIRIAM MICHELLE MÁXIMO LÓPEZ

PROYECTO WIX

APLICACIONES DE INFORMATICA PARA LA INGENIERIA

INGENIERIA INDUSTRIAL

1er. CUATRIMESTRE


INDICE

1…………………………………………………………………….. Semáforo 2…………………………………………………………………….. Tipo de productos con if anidados 3.……………………………………………………………………. Número positivo y negativo con if anidados 4…………………………………………………………………….. Número mayor 5……………………………………………………………………… Longitud 6.……………………………………………………………………. Áreas de cuadrado, rectángulo y triángulo 7.……………………………………………………………………. Tipo de producto con switch 8.……………………………………………………………………. Número positivo y negativo con switch 9.……………………………………………………………………. Repetir semáforo 10.…………………………………………………………………. Repetir frutas 11.…………………………………………………………………. Edad con if anidado 12.…………………………………………………………………. Tablas de multiplicar con para

1. Semáforo


Enunciado: Hacer un algoritmo que solicite el color des semรกforo y dependiendo el color la acciรณn a tomar. Verde: Siga. Amarillo: Precauciรณn y Rojo: Alto

usuario

sistema

color texto

color

Declaracion de variable

introduce un color

color=="verde"

V

"Siga"

f

color=="amarillo"

V

"Precucion

F color =="rojo"

F "Error"

"Pare"


2. Tipo de productos con if anidados


Enunciado: Algoritmo que de acuerdo al tipo de producto calcular el monto a pagar Tipos de productos son: Medicamentos – 5 % Comestibles – 0% Otros – 16 %


3. NĂşmero positivo y negativo con if anidados


Enunciado: Hacer un algoritmo que solicite un nĂşmero. El algoritmo debe determinar si el nĂşmero es positivo o negativo y si el caso es cero poner no valido.


4. Número mayor Enunciado: Que solicite tres números el algoritmo determinará cuál será el número mayor


5.

Longitud

Enunciado: Longitud en metros, longitud debe calcular en yardas y en pies. En caso que el usuario meta un dato menor = 0 marcarรก error y terminarรก el algoritmo


6.Áreas de cuadrado, rectángulo y triángulo Enunciado: Hacer una figura que muestre lo siguiente. Menú: 1. Cuadrado 2.Rectangulo 3. Triángulo equilátero Solicitar al usuario la opción deseada y el algoritmo. Calculará: El área y el perímetro. Por lo que según la opción solicitará los datos correspondientes.


7. Tipo de producto con switch


8.

NĂşmero positivo y negativo con switch


Algoritmo numero //Declaraci de variables //N 伹 ero Como Entero Escribir "Introduce un n 伹 ero" Leer num Si num > 0 Entonces Escribir "Positivo" Sino Si num < 0 Entonces Escribir "Negativo" Sino Escribir "Dato no v 疝 ido" Fin Si Fin Si FinAlgoritmo


9.

Repetir semรกforo


10.

Repetir frutas

Enunciado: Hacer un algoritmo que solicite los kilos comprados de las siguientes frutas: jícama, sandia y piña. Por un kilogramo jícama – 8 vasos a 11.0 c/u Por un kilogramo sandia – 11.5 vasos a 8.50 c/u Por un kilogramo piña – 9 vasos a 10 c/u Calcular 1) Por tipo de fruta el número de vasos a vender así a ganar por la venta de lo mismo 2) Total general de punto anterior


11.

Edad con if anidados


Usuario

Sistema

Int i = 1, suma = 0, edad

"Dame # de familiares"

num

num > = 1

edad

"Dame la edad"

suma = suma + edad

i=i+1

no

El rpom de la edad de tu famili; suma/num


12. Tablas de multiplicar con para


Usuario

Sistema

introducir tabla_num, i

tabla

"Dame la tabla"

numero

"Hasta que nĂşmero multiplicarĂĄ"

Prueba tabla=5 num=6 i=1 2 3 4 5 6 7 5*1=5 5*2=10 5*3=15 5*4=20 5*...

i=1

num >=i

tabla, "x", i, "=", tabla*i i=i+1



Wix