Page 1

เริ่มใช้ Visual Basic หัวข้ อเรื่องและงาน 1. การเรี ยกโปรแกรม Visual Basic 2. องค์ประกอบภายใน Visual Basic 3. การสร้าง Project ใหม่ 4. การจัดวางคอนโทรลลงบนฟอร์ม 5. การกําหนด Properties ให้กบั Control 6. การเขียนรหัสโปรแกรมตามเหตุการณ์ 7. การทดสอบการทํางานของโปรแกรม 8. การบันทึกแฟ้ ม Project 9. การเปิ ดแฟ้ ม Project เดิม 10. การปิ ด Project 11. การออกจากโปรแกรม Visual Basic 12. การสร้างไฟล์ .EXE 13.การแก้ปัญหาการแสดงผลภาษาไทยในหน้าจอEditor ของ Visual Basic

สาระสํ าคัญ ในบทนี้เนื้อหาจะกล่าวถึงการเริ่ มต้นใช้งานโปรแกรม Visual Basic โดยนักศึกษาควรฝึ ก ทําความคุน้ เคยกับองค์ประกอบ และสภาพแวดล้อมภายใน และศึกษาขั้นตอนในการดําเนินการ เกี่ยวกับแฟ้ ม Project เพื่อเป็ นพื้นฐานในการศึกษาเนื้อหาในบทต่อไป

เนือ้ หาสาระ การเรียกโปรแกรม Visual Basic ขั้นตอนการเข้าสู่โปรแกรมมีดงั นี้ 1. คลิกที่ Start > Programs > Microsoft Visual Basic 6.0 > Microsoft Visual Basic 6.0 2. เลือก Standard EXE


3. คลิกที่

เข้าสู่ภายใน

โปรแกรม 1. TitleBar 2. MenuBar 3. ToolBar 4. ToolBox 5. From Designer 6. Code Window 7. Project Explorer 8. Properties Window 9. From Layout

ไตเติลบาร์ แสดงชื่อโปรแกรมที่กาํ ลังใช้งานอยู่ เมนูบาร์ แถบคําสัง่ ให้เรี ยกใช้งาน ทูลบาร์ แถบเครื่ องมือให้เรี ยกใช้งาน(คําสัง่ ลัด) ทูลบ็อกซ์ กล่องเก็บเครื่ องมือที่ใช้พฒั นาโปรแกรม(Control) ฟอร์มดีไซเนอร์ ส่ วนออกแบบหน้าจอของโปรแกรมที่พฒั นา หน้าต่างที่ใช้เขียนรหัสของโปรแกรม หน้าต่างควบคุมโปรเจ็กต์ หน้าต่างควบคุมคุณสมบัติ(Properties) ของวัตถุต่างๆ หน้าต่างแสดงและกําหนดตําแหน่งการแสดงผลของโปรแกรม ที่พฒั นา บนจอภาพ

การสร้ าง Project ใหม่ ขั้นตอนการสร้าง Project ใหม่มีดงั นี้ คลิกเมนูบาร์ ที่ คําสั่ ง File > New Project คลิกเลือก Standard EXE 1. คลิกปุ่ ม เพื่อสร้าง Project

การจัดวางคอนโทรลลงบนฟอร์ ม ขั้นตอนมีดงั ต่อไปนี้ คลิกเมาส์เลือก Control ที่แถบ ToolBox (ตัวอย่างนี้ใช้ CommandButton 1. คลิกเมาส์ปุ่มซ้ายค้างไว้ลากให้เกิดกรอบสี่ เหลี่ยม ขนาดตามต้องการแล้วปล่อย 2. ย้ายหรื อปรับขนาดปุ่ มตามต้องการ


การกําหนด Properties ให้ กบั คอนโทรล ขั้นตอนมีดงั ต่อไปนี้ 1.คลิกเมาส์เลือกบนคอนโทรล (สังเกตจะมีจุดสี่ เหลี่ยมล้อมรอบ) 2.ในหน้าต่าง Properties คลิกเลือกที่ Name พิมพ์ชื่อของ Control โดยอักษร 3 ตัวแรกควรเป็ นชื่อ ย่อ จากตัวอย่างคือ CmdOK (Cmd ย่อมาจาก CommandButton) ซึ่งชื่อดังกล่าวจะใช้อา้ งถึงปุ่ มนี้ใน การเขียนรหัสโปรแกรม 3.คลิกเลือกที่ Caption พิมพ์ขอ้ ความที่ตอ้ งการให้แสดงบนปุ่ ม จากตัวอย่างพิมพ์ ตกลง

การเขียนรหัสโปรแกรมตามเหตุการณ์ ตัวอย่ างต่ อไปนีจ้ ะเป็ นการเขียนรหัสโปรแกรมให้ แสดงคําทักทายเมื่อผู้ใช้ คลิกเมาส์ ทปี่ ุ่ ม และ จะจบการทํางานเมื่อใช้ เมาส์ ดับเบิลคลิกบริเวณพืน้ ทีข่ องฟอร์ ม ขั้นตอนมีดงั นี้ 1. ดับเบิลคลิกที่ปุ่ม 2. คลิกเลือกเหตุการณ์ที่จะตอบสนอง ในที่น้ ีให้เลือก Click 3. พิมพ์รหัสโปรแกรมดังนี้ MsgBox "สวัสดีครับ" 4. ดับเบิลคลิกบริ เวณพื้นที่ของฟอร์ม 5. คลิกเลือกเหตุการณ์ที่จะตอบสนอง ในที่น้ ีให้เลือก DblClick 6. พิมพ์รหัสโปรแกรมดังนี้ Unload Me การทดสอบการทํางานของโปรแกรม

ขั้นตอนมีดงั ต่อไปนี้ 1. คลิกเมาส์ที่เมนูบาร์คาํ สัง่ Run > Start หรื อกดแป้ นพิมพ์ F5 2. ถ้าหากไม่มีขอ้ ผิดพลาดจะปรากฏหน้าจอการทํางานของโปรแกรม ทดลองคลิกเมาส์ที่ปุ่ม จะปรากฏหน้าต่างแสดงคําทักทาย ให้คลิก OK 3. ทดลองดับเบิลคลิกเมาส์ที่บริ เวณพื้นที่ของฟอร์ม โปรแกรมจะจบการทํางาน และกลับสู่หน้าจอ ของ Visual Basic การบันทึกแฟ้ม Project ขั้นตอนการบันทึก Project มีดงั นี้ 1. คลิกเมนูบาร์ที่ คําสัง่ File > Save Project 2. คลิกเลือกที่เก็บ Form (หน้าจอที่ออกแบบ) 3. พิมพ์ชื่อ Form (ตั้งชื่อให้สอดคล้องกับโปรแกรม)


4. 5. 6. 7. 8.

คลิกที่ปุ่ม คลิกเลือกที่เก็บ Project พิมพ์ชื่อ Project (อาจใช้ชื่อเดียวกับฟอร์มก็ได้) คลิกที่ปุ่ม หากปรากฏหน้าต่าง Source Code Control ให้คลิกเลือก No

การเปิ ดแฟ้ม Project เดิม ขั้นตอนการเปิ ดแฟ้ ม Project มีดงั นี้ 1. คลิกเมนูบาร์ที่ คําสัง่ File > Open Project 2. คลิกเลือกที่เก็บ Project ที่ตอ้ งการเปิ ด 3. หรื อคลิกที่ Existing (Project ที่บนั ทึกไว้) หรื อ Recent (Project ที่เคยเปิ ดล่าสุ ด) 4. คลิกเลือก Project ที่ตอ้ งการเปิ ด 5. คลิกที่ปุ่ม เพื่อทําการเปิ ด

การปิ ด Project ขั้นตอนการปิ ด Project มีดงั นี้ 1. คลิกเมนูบาร์ที่ คําสัง่ File > Remove Project 2. โปรแกรมจะถามยืนยัน จะบันทึกการเปลี่ยนแปลงก่อนหรื อไม่ 3. คลิก Yes ถ้าต้องการบันทึก หรื อคลิก No ถ้าไม่ตอ้ งการบันทึก ถ้าคลิก Cancel จะยกเลิก และ กลับสู่ หน้าจอก่อนหน้านี้

การออกจากโปรแกรม Visual Basic ขั้นตอนการปิ ดแฟ้ ม Project มีดงั นี้ 1. คลิกเมนูบาร์ที่ คําสัง่ File > Exit 2. ถ้าหากโปรแกรมยังไม่ถูกบันทึกจะปรากฏหน้าต่าง ยืนยันการบันทึก 3. จากนั้นโปรแกรมจะถูกปิ ดลง


การสร้ างไฟล์ .EXE เมื่อนักศึกษาสร้าง และทําการทดสอบโปรแกรมแล้วไม่พบข้อผิดพลาด เราสามารถสร้าง ไฟล์ที่มีนามสกุล .EXE ที่สามารถทํางานได้โดยไม่ตอ้ งผ่านโปรแกรม Visual Basic เมื่อสําเนาไป ไว้ในเครื่ องอื่นๆ ก็สามารถใช้งานในเครื่ องนั้นได้ทนั ที (ในการพัฒนา Application ที่มีการใช้ คอนโทรลในระดับสู ง หรื อคอนโทรลพิเศษ จะต้องทําขั้นตอนการ Package & Deployment คือ การรวบรวมเอาไฟล์ที่เกี่ยวข้องเช่น .OCX,DLL และมีการลงทะเบียน Register ไว้กบั Windows )


การทดสอบการทํางานของโปรแกรม ขั้นตอนมีดังต่ อไปนี้ 4. คลิกเมาส์ที่เมนูบาร์คาํ สัง่ Run > Start หรื อกดแป้ นพิมพ์ F5

1

2

5. ถ้าหากไม่มีขอ้ ผิดพลาดจะปรากฏหน้าจอการทํางานของโปรแกรม ทดลองคลิกเมาส์ที่ปุ่ม จะปรากฏหน้าต่างแสดงคําทักทาย ให้คลิก OK

3


6. ทดลองดับเบิลคลิกเมาส์ที่บริ เวณพื้นที่ของฟอร์ม โปรแกรมจะจบการทํางาน และกลับสู่หน้าจอ ของ Visual Basic

การบันทึกแฟ้ ม Project

ขั้นตอนการบันทึก Project มีดงั นี้ 9. คลิกเมนูบาร์ที่ คําสัง่ File > Save Project

2 4 3

1 10. คลิกเลือกที่เก็บ Form (หน้าจอที่ออกแบบ) 11. พิมพ์ชื่อ Form (ตั้งชื่อให้สอดคล้องกับโปรแกรม) 12. คลิกที่ปุ่ม

5 7 6

13. คลิกเลือกที่เก็บ Project 14. พิมพ์ชื่อ Project (อาจใช้ชื่อเดียวกับฟอร์มก็ได้) 15. คลิกที่ปุ่ม 16. หากปรากฏหน้าต่าง Source Code Control ให้คลิกเลือก No

8


หลังจากบันทึก Project แล้ ว จะได้ ไฟล์ 2 ไฟล์ โดยมีรายละเอียดดังนี้ ไฟล์ Visual Basic Project นามสกุล Vbp เก็บ Project ไฟล์ Visual Basic Form File นามสกุล Frm เก็บหน้าจอที่ออกแบบไว้

การเปิ ดแฟ้ม Project เดิม

1

1

3

2

4

5

ขั้นตอนการเปิ ดแฟ้ ม Project มีดงั นี้ 6. คลิกเมนูบาร์ที่ คําสัง่ File > Open Project 7. คลิกเลือกที่เก็บ Project ที่ตอ้ งการเปิ ด 8. หรื อคลิกที่ Existing (Project ที่บนั ทึกไว้) หรื อ Recent (Project ที่เคยเปิ ดล่าสุ ด)


9. คลิกเลือก Project ที่ตอ้ งการเปิ ด 10. คลิกที่ปุ่ม เพื่อทําการเปิ ด

การปิ ด Project

11

2 3

ขั้นตอนการปิ ด Project มีดงั นี้ 4. คลิกเมนูบาร์ที่ คําสัง่ File > Remove Project 5. โปรแกรมจะถามยืนยัน จะบันทึกการเปลี่ยนแปลงก่อนหรื อไม่ 6. คลิก Yes ถ้าต้องการบันทึก หรื อคลิก No ถ้าไม่ตอ้ งการบันทึก ถ้าคลิก Cancel จะยกเลิก และ กลับสู่ หน้าจอก่อนหน้านี้


การออกจากโปรแกรม Visual Basic

1

ขั้นตอนการปิ ดแฟ้ ม Project มีดงั นี้ 4. คลิกเมนูบาร์ที่ คําสัง่ File > Exit 5. ถ้าหากโปรแกรมยังไม่ถูกบันทึกจะปรากฏหน้าต่าง ยืนยันการบันทึก 6. จากนั้นโปรแกรมจะถูกปิ ดลง

การสร้ างไฟล์ .EXE เมื่อนักศึกษาสร้าง และทําการทดสอบโปรแกรมแล้วไม่พบข้อผิดพลาด เราสามารถสร้าง ไฟล์ที่มีนามสกุล .EXE ที่สามารถทํางานได้โดยไม่ตอ้ งผ่านโปรแกรม Visual Basic เมื่อสําเนาไป ไว้ในเครื่ องอื่นๆ ก็สามารถใช้งานในเครื่ องนั้นได้ทนั ที (ในการพัฒนา Application ที่มีการใช้ คอนโทรลในระดับสู ง หรื อคอนโทรลพิเศษ จะต้องทําขั้นตอนการ Package & Deployment คือ การรวบรวมเอาไฟล์ที่เกี่ยวข้องเช่น .OCX,DLL และมีการลงทะเบียน Register ไว้กบั Windows )


ขั้นตอนการสร้ างไฟล์ .EXE มีดังนี้ 1. สร้างโปรแกรม และ Run ทดสอบการทํางาน จนไม่พบข้อผิดพลาด 2. บันทึก Project ตัวอย่างอ้างอิงในที่น้ ีให้ต้ งั ชื่อเป็ น Test ใช้ชื่อนี้ท้ งั Form และ Project 3. คลิกเลือกที่คาํ สัง่ เมนู File > Make Test.exe (ถ้าตั้งชื่ออื่นหลัง Make ก็จะเป็ นชื่อนั้น)

3 7. จะปรากฏหน้าต่าง Make Project คลิกเลือกที่เก็บ(ในที่น้ ีจะบันทึกใน My Documents)

4

5

8. พิมพ์ชื่อไฟล์ (ในที่น้ ีใช้ชื่อ test.exe) 9. คลิกที่ปุ่ม 10. ออกจากโปรแกรม Visual Basic

6


11. เข้า My Document 12. สังเกตรู ป Icon จะมีเหมือนกันให้คลิกขวาที่ไฟล์ test เลือก Properties ดูหวั ข้อ Type of file ถ้าแสดงเป็ น Application แสดงว่าไฟล์น้ นั เป็ น exe

9 13. ดับเบิลคลิกที่ไฟล์ test.exe ไฟล์จะทํางานได้โดยไม่ตอ้ งทํางานผ่านโปรแกรม Visual Basic

การแก้ ปัญหาการแสดงผลภาษาไทยในหน้าจอ Editor ของ Visual Basic

ในการเริ่ มใช้งาน Visual Basic ในบางครั้งอาจพบปั ญหาการแสดงผลตัวอักษรภาษาไทย ในหน้าจอ การเขียนรหัสโปรแกรม(Code) หรื อหน้าจอ Editor ดังรู ป

ซึ่งสามารถแก้ปัญหาดังกล่าวโดยการปฏิบตั ิตามขั้นตอนดังต่อไปนี้ 1. คลิกที่เมนูคาํ สัง่ Tools > Option

1

2. คลิกที่แท็ป Editor Format


3. คลิกเลือก Normal Text 4. คลิกเลือก Font เป็ น AngsanaUPC

2

3

4 5

6 5. กําหนด ขนาด(Size) เป็ น 16 6. คลิกที่ปุ่ม 7. จากนั้นจะสามารถพิมพ์และแสดงผลภาษาไทยได้อย่างถูกต้อง

7


บทที่ 4 เริ่มต้นการใช้งาน Visual Basic  
Read more
Read more
Similar to
Popular now
Just for you