Issuu on Google+

TSDI

Tableur : MS Excel

Tableur

I. Introduction 1. Définition MS Excel, est un tableur ou un chiffrier est un programme d'application (ou logiciel) utilisé pour l'établissement de budgets, de planifications ou d'autres tâches comptables. Il permet de saisir des données, de faire des traitements sur ces données et de les afficher. Dans les entreprises, il sert souvent à l'analyse de chiffres d'affaire, analyse des coûts, détermination des prix... bien d'autres applications sont envisageables, que ce soit dans les domaines scientifiques, statistiques ou autres... Le tableur est très adapté pour manipuler des chiffres, des listes, pour effectuer des calculs, des statistiques. Relié à des bases de données, il permet d'extraire puis de représenter avantageusement des informations, d'effectuer des synthèses, des bilans et des simulations qui serviront de bases aux décideurs.

2. Les éléments essentiels Voici une courte description de certains éléments que on retrouvera dans les tableurs tels qu'Excel. Les données (du texte, des nombres, des dates… ou une formule.) sont stockées

Les cellules:

dans des cellules. Chaque cellule se trouve à l'intersection d'une ligne et d'une colonne dans une feuille de calcul.

Les formules: Feuille de calcul:

Opérations mathématiques pour calculer ou analyser les chiffres du modèle. Feuille contenant des cellules, un graphique, les résultats du gestionnaire de scénarios ...

Classeur:

Fichier ou document dans lequel on retrouve plusieurs feuilles de calcul.

Graphique:

Image qui représente une ou plusieurs séries de chiffres.

II. Le menu principal d'Excel 1. Présentation de l'environnement Lorsque Excel est lancé, un nouveau classeur vide contenant plusieurs feuilles de calcul s'ouvre par défaut (les fichiers d'Excel, avec l'extension .xls, s'appellent des "classeurs"). Une interface est la manière ou l'utilisateur accède aux commandes et fonctions d'une application.

FARIH SAID

1


TSDI

Tableur

2. Les composants de l'écran Excel. 1 2 3

4

5 8

6 7

17

15

14

13 10

9 11

12 Permet de gérer l'application dans sa fenêtre. Elle donne aussi le nom de

1) La barre titre

l'application (Excel) et du document actuel (par défaut Classeur1. A droite de cette barre se trouve les boutons système (Réduire - Agrandir / Restaurer - Fermer)

2) La barre menu 3) Les barres d'outils

On retrouve toutes les commandes de l'application dans ces menus. Elle regroupe les icônes des fonctions les plus utiles du logiciel : créer, ouvrir, enregistrer, imprimer un classeur, afficher un aperçu avant impression, correction orthographique ainsi que les fonctions de travail dans le tableau. D’un clic sur l’icône adéquate on va pouvoir copier, coller, répéter la mise en forme d’une autre cellule, annuler ou rétablir la saisie, obtenir automatiquement la somme de plusieurs nombres, insérer une fonction, trier les données dans l’ordre croissant ou décroissant, insérer un graphique un dessin, sélectionner le pourcentage d’affichage du tableau pour l’adapter à la vue et enfin faire appel à l’aide d’Excel. Elle permet, comme le nom l’indique, de mettre en forme la feuille en

La barre de Mise en

choisissant un caractère (ou police), la taille de celui-ci. En cliquant sur les icônes,

forme

on peut également mettre en gras, en italiques, voire souligner un texte ou un nombre. On y déterminera l’alignement du contenu des cellules (à gauche, à droite, au centre justifié). On attribuera aux nombres des styles : monétaire, pourcentage,

FARIH SAID

2


TSDI

Tableur nombre de décimales. On mettra en retrait le contenu de la cellule, décidera des encadrements du tableau, de la cellule, ou d’un groupe de cellule, et éventuellement de changer la couleur du caractère ou surligner une cellule, une ligne, une colonne ou une zone.

4)

Indicateur

de

Affiche la position de la cellule active. Peut aussi servir pour donner un nom à une cellule. Aide aussi à se déplacer d'une cellule nommée à une autre.

position

La barre de formule : affichée juste au-dessus de la feuille de calcul, c’est là qu’apparaissent les données que on est en train de saisir. que ce contenu soit du texte, des chiffres ou des formules. Pour pouvoir entrer des informations dans une

5) La barre formule

cellule, la modifier, y taper une opération arithmétique ou y placer une fonction, il faut cliquer dans la barre, la barre verticale clignotante indique que la cellule est prête à recevoir des données. (qui est propre à Excel) affiche le contenu de la cellule sélectionnée. La cellule active, autrement dite, celle dans laquelle on travaille, est cernée

6) La cellule active

d’un gros trait noir terminé en bas à droite par un petit carré.

7) La poignée de

Permet de recopier le contenu d'une cellule, une formule ou une série de chiffres ou de titres.

recopie

8) Les en-têtes des

Permet d'identifier la position des cellules par rapport à l'intersection avec la

colonnes et des lignes lettre de la colonne (A à IV) et le chiffre de la ligne (1 à 65 536) Excel permet d'avoir plusieurs feuilles de calcul dans un même classeur. Les

9) Les onglets des onglets sont utilisés pour identifier chaque feuille. Excel permet d'accomplir des calculs en longueur, en largeur et aussi en "profondeur". Il est possible de créer un

feuilles de calcul

bloc de cellules provenant de plusieurs feuilles de calcul.

10)

La

barre

défilement

de

Puisqu'un classeur peut avoir plusieurs feuilles de calcul, il est impossible

des d'afficher tous les onglets en même temps. Cette barre permet donc d'afficher les

onglets

feuilles de calcul qui ne sont pas visible à un moment donné. La barre d’état indique si on est en train de saisir une donnée dans une

11) La barre d'état

cellule (mention Entrer) ou pas, et si le verrouillage numérique du clavier est actionné (mention NUM).

12) Les barres de

Permet de se déplacer horizontalement et verticalement sur une feuille de

défilement horizontal calcul. Chaque feuille est composée de 256 colonnes et 65 536 lignes. et vertical

13) Les curseurs de fractionnement

14) Les colonnes

FARIH SAID

Permet

de

découper

l'affichage

en

deux

horizontalement

et/ou

verticalement. Ceci permet de comparer des chiffres qui sont éloignés par exemple Chaque feuille de calcul contient 256 colonnes nommées de A à IV.

3


TSDI

Tableur

15) Les lignes 16) Le pointeur

Chaque feuille de calcul contient des lignes numérotées de 1 à 65 536. Permet de sélectionner une cellule, un bloc de cellules, un objet, ou d'activer les options du menu ou les boutons des barres d'outils.

17) Volet Office

Permet de créer, ouvrir un classeur ou chercher de l’aide..

3. La feuille de calcul Chaque élément, classeur, feuille de calcul, ligne, colonne, cellule est désigné par sa référence. La référence permet d'identifier précisément et sans ambiguïté un élément. Par exemple :  Les lignes portent des numéros comme 1, 2, 3... 65 536 lignes au total.  Les colonnes portent des lettres A, B, C... IV, 256 colonnes au total.  Et les cellules sont Les cases dans lesquelles on peut entrer du texte ou des chiffres, sont

référencées avec A1, B6, D3... Les informations sont saisies dans une seule cellule à la fois, la cellule active. Visible par son contour épais, sa position est affichée dans la zone nom, à gauche de la barre des formules (par défaut A1) Aussi, chaque cellule peut contenir jusqu'à 65 000 caractères.

4. Déplacement a. Se déplacer dans la feuille de calcul i. A l’aide du clavier:  Entrée: Confirme l'entrée du texte, d'un chiffre ou d'une formule et déplace le curseur d'une cellule

vers le bas.  Tab: Déplace le curseur une cellule vers la droite  Maj (Shift) + Tab: Déplace le curseur une cellule vers la gauche  Les flèches de direction permettent un déplacement de ligne à ligne ou colonne à colonne;  Page Suiv ou Page Préc, déplace la cellule active du nombre de lignes visibles vers le bas ou vers le

haut;  ALT+ Page Suiv ou Page Préc déplace la cellule active du nombre de colonnes visibles vers la droite

ou vers la gauche;  CTRL + ORIGINE amène le curseur sur la cellule A1.  CTRL + FIN amène le curseur à la dernière cellule modifiée en bas à droite de la feuille.  F5 ou Ctrl+T Pour se déplacer à n'importe quelle cellule du classeur.

ii. Avec la souris  Les barres de défilement. La cellule active peut alors n'être plus visible. 

Maintenir le clic étend la sélection, si le pointeur de souris glisse vers un bord de fenêtre, la feuille de calcul défile plus ou moins vite selon la position du pointeur.

Dans la zone Nom, saisir l'adresse soit de la cellule à atteindre, soit d'une plage de cellule à sélectionner.

FARIH SAID

4


TSDI

b. Se déplacer dans le classeur

Tableur

Au bas à gauche de la feuille de calcul se trouvent les quatre flèches de déplacement dans le classeur (début, précédent, suivant, fin) et les onglets des feuilles qui constituent le classeur. Sélectionnés, ils sont blancs, sinon grisés. Ils contiennent le nom de feuille.

i. Au clavier  CTRL + Page Suiv ou Page Préc affiche la feuille suivante ou précédente  CTRL + SHIFT + Page Suiv ou Page Préc sélectionne plusieurs feuilles

ii. Avec la souris  Clic sur l'onglet sélectionne la feuille  Double clic permet de modifier le nom de la feuille  Clic + SHIFT étend la sélection.  Clic + CTRL sélectionne les feuilles de manière dissociée  Clic droit sur les flèches affiche la liste des feuilles  Clic droit sur les onglets sélectionnés, affiche le menu : Insérer... , Supprimer, Renommer, Déplacer

ou Copier, Sélectionner toutes les feuilles.

iii. Par les menus  Édition / Supprimer une feuille  Édition / Déplacer ou Copier une feuille...  Insertion / Feuille  Format / Feuille / Renommer  Format / Feuille / Masquer ou Afficher; les feuilles de calcul peuvent être masquées.  Outils / Protection / Protéger la feuille..., ce qui peut être utile pour sauvegarder les formules

Les modifications de cellules s'effectuent sur toutes les feuilles sélectionnées. Il y a plusieurs manières de se déplacer dans Excel. On peut toujours cliquer sur la feuille de calcul et la cellule dont on a besoin. Voici une liste des touches que on peut utiliser pour on déplacer.

III. La modification des cellules 1. Le contenu d’une cellule Une feuille est constituée de cellules pouvant contenir du texte, des données numériques ou des formules utilisant des valeurs d'autres cellules pour calculer un résultat attendu, mais peuvent contenir toutes sortes d'objets :  Les objets de la barre dessin, formes automatiques, images, WordArt, etc  Des objets liés d'autres applications Word, ou PowerPoint  Des graphiques  Des contrôles, tels des listes déroulantes, cases à cocher...

2. Modifier une cellule Pour modifier le contenu d'une cellule, il faut :  Double-cliquer sur la cellule contenant les données à modifier, puis effectuer les modifications

nécessaires.

FARIH SAID

5


TSDI

Tableur

 Valider les modifications en appuyant sur ENTRÉE, ou annuler les modifications en appuyant sur

ÉCHAP.  Pour ajouter rapidement du contenu de la cellule, sélectionner la, puis appuyer sur F2.

Excel affiche en couleurs les cellules auxquelles le calcul ou la fonction fait référence.

3. Imposer la saisie d’un type de données dans un tableau Derrière le menu Données/Validation… se cache la possibilité de forcer la personne qui alimentera le tableau à soit choisir dans une liste déroulante, soit un format de nombre particulier (date, monnaie etc.), en fonction des options, si la saisie ne concorde pas avec ce qui est attendu, il sera possible d’émettre un message d’erreur que on aurait conçu et soit d’arrêter tant que la personne n’a pas rempli comme il le fallait, soit simplement de passer outre après le message d’erreur. On doit commencer par saisir la liste dans la feuille (on pourra ensuite la masquer, Format/Colonne/Masquer). Ensuite, Données/Validation…

Choisir Liste, retourner sur le Entrer, le titre et le message Entrer, le style, le titre et le tableau pour sélectionner la liste d’aide de saisie.

message d’erreur.

à prendre en compte, Terminer en cliquant sur Ok. Au moment de la saisie, lorsque la cellule affectée par cette validation est active, Excel affiche le message d’aide que on a saisi : Veuillez saisir H ou F. En cas de mauvaise saisie, le message d’erreur apparaît : On a dit H ou F !!!

4. Annuler en cas d’erreur La façon la plus simple de procéder consiste à utiliser le raccourci clavier Ctrl+Z Elle est aussi accessible via le menu Édition/Annuler, ou via l’icône

de la barre d’outils standard.

5. Les blocs Plusieurs cellules peuvent être sélectionnées en même temps, mais une seule reste active, Le logiciel offre au moins trois manières de sélectionner un bloc de cellules.

a. Utiliser la souris.  Placer le pointeur par-dessus la première cellule du bloc.  En gardant un doigt sur le bouton gauche de la souris, déplacer le pointeur jusqu'à la dernière cellule du bloc.  Relâcher le bouton de la souris.

FARIH SAID

6


TSDI

Tableur

Ceci est pratique lorsque le bloc de cellules est relativement petit. Mais que faire lorsqu'on doit faire

un bloc de cellules qui prend plus qu'un écran? C'est à ce moment que l'utilisation et de la souris avec la touche MAJ (Shift) est pratique.

b. Utiliser la touche shift ou MAJ.  Placer le pointeur par-dessus la première cellule du bloc et appuyer sur le bouton gauche de la souris.  Déplacer le pointeur par-dessus la dernière cellule du bloc.  En gardant un doigt appuyé sur la touche MAJ (Shift), cliquer sur la dernière cellule du bloc. La dernière méthode démontre comment faire un bloc avec des cellules qui sont réparties un peu partout à l'intérieur de la feuille de calcul.

c. Utiliser la touche Ctrl.  Faire le premier bloc de cellules en utilisant la souris ou avec la touche MAJ (Shift).  En gardant un doigt sur la touche Ctrl, faire le second bloc de cellules.  Si on a besoin d'autres blocs de cellules, garder toujours le doigt sur la touche Ctrl et utiliser la souris pour les faire. Remarque:  La sélection est dite étendue et constitue une plage de cellule, dont l'adresse ou le nom est A2:B4, une cellule de départ et une cellule d'arrivée séparées par deux points.  La cellule active dans la sélection peut être déplacée par la touche Tabulation.  Dans une sélection discontinue, la poignée a disparue.  Pour Excel, la plage est ici, A1:C4;A6:C6, le séparateur de plages discontinues est alors le point virgule.

6. Sélectionner des lignes et/ou des colonnes a. Cliquer sur les en-têtes. Elles peuvent être adjacentes.  En faisant glisser la souris sur les en-têtes de colonnes ou sur les numéros de lignes,  En sélectionnant la première ligne ou colonne, puis en maintenant la touche MAJ enfoncée, on sélectionne la dernière ligne ou colonne,  Elles peuvent être discontinues par la touche CTRL.

b. Sélectionner par la saisie  En cliquant dans la zone nom, on peut saisir la plage de cellules à atteindre ou à sélectionner  Valider avec la touche ENTREE.

IV. Gestion des classeurs 1. Créer une feuille de calcul  Pour créer une feuille de calcul: cliquer sur la page blanche dans la barre Standard

.

 On peut aussi choisir l’option Nouveau dans le menu Fichier. Dans ce cas

FARIH SAID

7


TSDI

Tableur

le volet office apparaît et nous demande de choisir un modèle de document sur lequel s’appuyer. Par défaut il faut choisir Nouveau Classeur Excel qui ouvre un classeur vide.

2. Enregistrer le classeur Pour sauvegarder un classeur: dans le menu Fichier, sélectionner Enregistrer sous La boite de dialogue Enregistrer s’ouvre.

On doit sélectionner un dossier dans lequel le texte sera rangé Enregistrer dans: et donner un nom au classeur Nom de fichier: Ensuite, pour sauvegarder les modifications : cliquer sur Enregistrer du menu Fichier ou faire le raccourci Ctrl+S.

3. Manipulation sur les cellules Chaque cellule peut contenir une valeur. Cette valeur est soit saisie directement par l'utilisateur ou est le résultat d'un calcul exprimé par une formule. Une valeur possède un type et est affichée sous un format.

a. Les types Ce sont par exemple : des valeurs numériques entières ou décimales, des mots ou des phrases (appelées en informatique chaînes de caractères), des valeurs logiques (VRAI ou FAUX, appelées valeurs booléennes en informatique).

b. Les formules Ce sont des expressions qui sont évaluées par le tableur et retournent un résultat. Par exemple, (1+cos(95))*12-5,6 est une formule (mathématique). Les formules sont bâties avec des fonctions. Dans ce dernier exemple, cos est une fonction, mais aussi +, * et -. La facilité d'utilisation du tableur provient aussi du fait qu'on puisse mettre des références de cellules ou d'ensembles de cellules dans les formules. On peut donc écrire par exemple : (1+cos(A1))*B2C3. L'expression sera évaluée avec la valeur contenue dans la cellule A1, la cellule B2 et la cellule C3.

c. Les formats Ce sont les attributs des cellules qui permettent de présenter lisiblement les valeurs. On peut citer par exemple, les formats de date, d'heure, monétaires, pourcentage, mais aussi gras, souligné, italique, ... Police de caractères

FARIH SAID

8


TSDI

i. Police

Tableur

Il faut évidemment d'abord sélectionner la (ou les) cellule(s) dont on veut imposer la police. Puis appeler le menu "Format/ Cellule", puis l'onglet "Police". De là, on peut choisir la police (Verdana ou Arial par exemple), mais aussi le Style (gras, italique, normal), la Taille, le type de Soulignement, la Couleur des caractères, et les Attributs (Barré, Exposant, Indicé).

ii. Alignement À l'intérieur d'une cellule le texte peut être positionner de différentes façons: Sur le plan horizontal; Sur plan vertical ou selon un angle prédéfini (diagonal). De le centrer verticalement dans la cellule (ou de le positionner en bas ou en haut).

Sélectionner les cellules dont on veut cadrer le texte. Puis menu "Format/ Cellule", onglet "Alignement". On peut opter pour Renvoyer le texte à la ligne automatiquement, Il restera ainsi intégralement lisible et on ne sera pas obligé d’avoir des colonnes très larges. Pour positionner un texte sur plusieurs colonnes (pour donner un titre à un tableau par exemple) : les sélectionner. Dans la boîte de dialogue Format de cellule, choisissez l’alignement horizontal Centré sur plusieurs colonnes.

iii. Nombre On appel format de nombres la façon de présenter les nombres. En sélectionnant l’option Cellule du menu Format, on ouvrira une boîte de dialogue qui offre plus de choix comme par exemple : Exemple : pourcentage, monétaire, pour des nombres décimaux, imposition du nombre de décimal à afficher et à imprimer, etc. Excel propose plusieurs formats prédéfinis.

FARIH SAID

9


TSDI

Tableur

iv. Bordure et grisé Une bordure est un cadre (des traits) que l'on place autour d'une (ou des) cellule(s). Un grisé est un motif ou une couleur que l'on place en arrière plan d'une (ou des) cellule(s).  Sélectionner les cellules dont on veut encadrer ou mettre en grisé.  Menu " Format/ Cellule ", puis l'onglet "Motifs" pour le fond de la cellule et l'onglet "Bordure" pour le type d'encadrement.

d. Taille des lignes et des colonnes Changer la taille des lignes et colonnes peut se faire deux façons différentes :

i. Redimensionner les colonnes Sélectionner un trait situé entre deux titres de colonnes (cellules grisés A, B, C ou D par exemple). En maintenant le bouton de la souris appuyé, déplacer le trait.

ii. Redimensionner de ligne Sélectionner un trait situé entre deux titres de lignes (cellules grisés 1, 2, 3 ou 4 par exemple). En maintenant le bouton de la souris appuyé, déplacer le trait.

iii.

Redimensionner automatiquement

 Dans le menu Format, sélectionner Ligne ou Colonne.  On peut décider d’Ajuster automatiquement la taille au contenu ou paramétrer la Hauteur de ligne et la Largeur de colonne.

4. Manipulation sur les Lignes et les colonnes a. Ajouter, Supprimer des Lignes et des colonnes Pour intercaler des cellules, lignes ou colonnes supplémentaires dans un tableau : Dans le menu Insertion, sélectionner l’option désirée. Les Lignes seront rajoutées au-dessus de la ligne sélectionnée, les Colonnes à gauche. L’insertion de Cellules fait apparaître une boîte de dialogue spécifique. Attention l’option décaler les cellules vers le bas où la droite peut altérer le tableau.

FARIH SAID

10


TSDI

Tableur

Pour supprimer des lignes ou des colonnes : dans le menu Édition, choisir l’option Supprimer... Il ne

on reste plus qu’à cocher la bonne option dans la boîte de dialogue.

b. Mise en page d’un tableau

Dans le menu Fichier/ Mise en page, on retrouve une boîte comportant quatre onglets : "Page", "Marges", "En-tête/Pied de page" et "Feuille".

i. Onglet "Page" Deux choses nous intéressent ici :  Orientation "Portrait" ou "Paysage". Permet de choisir l'orientation du papier (verticale ou horizontale).  Réglage de l'échelle. Le tableau n'occupe que quatre lignes sur quatre colonnes, il sera donc très petit une fois imprimé. Pour obtenir un tableau plus lisible: Cocher l'option Réduire/agrandir et tapez, par exemple, 150 dans le champ voisin (% de la taille normale) Si la plage de cellules que l'on désire imprimer ne tient pas sur une page, on peut aussi demander un ajustement automatique. Dans ce cas c'est Excel qui va lui même déterminer l'échelle (en pourcentage).

ii.

Onglet "Marges" Réglages des marges. Il est conseillé de mettre les marges à 1,5 ou 2 cm au minimum. Pour des

raisons techniques, certaines imprimantes impriment incorrectement les pages comportant trop d'éléments surtout quand la page est entièrement remplie par un tableau. Avec possibilité de centrer l'impression sur le plan horizontal ou vertical.

iii. Onglet "En-tête/Pied de page"

FARIH SAID

11


TSDI

Tableur

La boîte de dialogue En-tête on permet d’insérer automatiquement un certain nombre d’indications comme, par exemple le nom du fichier et son emplacement, le nom de l’auteur du fichier… Cela permet de mettre des informations (comme un titre ou la pagination) qui vont se répéter à chaque page au moment de l'impression. Si le tableau imprimé occupe une dizaine de pages, il est préférable de numéroter et de dater les feuilles. Pour cela, cliquer sur En-tête personnalisé... Pour faire apparaître, par exemple, le nom de l'auteur en haut à gauche de la feuille, cliquer dans la zone Partie gauche, et saisir le nom désiré. Puis dans la zone du centre cliquer sur le bouton numéro de la page actuelle et sur

pour insérer le

pour insérer le nombre total de page. Pour imprimer en haut à

droite la date et l'heure d'impression, cliquer dans le champ Partie droite, puis cliquer sur le bouton Date

, taper une espace et cliquer sur le bouton Heure

. Valider par OK.

iv. Onglet "Feuille"

 Réglage manuel de la zone d'impression. On consulte plus facilement une longue liste si les intitulés de colonnes sont imprimés sur chaque feuille. La zone "Titres à imprimer" permet de sélectionner des cellules et de les considérer comme des titres à répéter à chaque page au moment de l'impression. Cliquer dans le champ Ligne à répéter en haut: puis cliquer sur la ligne où se trouvent les en-têtes de colonnes (si c'est la première ligne, on verra s'afficher $1:$1). Valider par OK.

FARIH SAID

12


TSDI

Tableur

 Zone d'impression

Une zone d'impression permet de n'imprimer que certaines cellules d'une feuille. On obtient cette zone en sélectionnant les cellules et en cliquant sur le bouton "Zone d'impression:".

V. Les formules 1. Présentation L'un des plus grands avantages d'un tableur est l'automatisation des calculs. En entrant une formule au lieu d'un chiffre, il est plus facile de modifier le modèle et d'avoir de l'information pertinente. Les formules devraient être utilisées à chaque opportunité qui se présente. Pour que le tableur comprenne que le contenu d'une cellule est une formule, on utilise la convention suivante : une formule commence toujours par le symbole « = ».

2. Les opérateurs Les formules permettent de faire des calculs (des additions ou des moyennes par exemple) à l'aide d'opérateurs:  Les opérateurs arithmétiques : sont des expressions construites à l'aide des opérateurs arithmétiques usuels et de constantes, de références, de fonctions. Les opérateurs disponibles sont : « + » (Addition), « - » (unaire : prendre l'opposé), « - » (binaire : soustraction), « / » (division), « * » (multiplication), « ^ » (élévation à la puissance);  Les expressions conditionnelles : Elles sont construites à l'aide d'opérateurs de comparaison. Ces expressions

ont

pour

résultat

une

valeur

logique

VRAI

ou

FAUX.

Les opérateurs de comparaison sont : « = » (égal à), « > » (supérieur strictement à), « >= » (supérieur ou égal à), « < » (inférieur strictement à), « <= » (inférieur ou égal à), « <> » (différent de).  Les expressions texte : Elles sont construites à l'aide de l'opérateur « & » qui permet de concaténer (mettre bout à bout) deux chaînes de caractères. Ex.: +a1+a2, =somme(a1:z20), =moyenne(a1:z20), =recherchev(a1;b1:c20;2) Une erreur qui est souvent commise en utilisant les fonctions d'Excel est de mettre une espace entre le nom de la fonction et de la première parenthèse. Ex: =somme () au lieu de =somme(). On veut obtenir ce relevé de note d'un élève: Matière Mathématiques Sciences naturelles Physique et Chimie

Relevé de notes de: Note Coefficient Note*Coefficient 12 6 72 14 4 56 08 5 40 Somme: 15 168

Moyenne: 11,20 Décision finale: Réussi  Pour cela, dans la cellule C4 on place la formule := =B2&"*"&C2.  Dans la cellule D3 on place la formule: =B3*C3

FARIH SAID

13


TSDI

Tableur

 La partie =somme est la fonction qui permet d'additionner des nombres. Dans la cellule C6 on place la formule: =SOMME(C3:C5), et dans la cellule D6 on place la formule: =SOMME(D3:D5)

Les parties C3:C5 et D3:D5 situées entre parenthèses définies la plage de cellules comportant les nombres que l'on veut additionner.  Dans la cellule D8 on place la formule: =D6/C6.  Dans la cellule B9 on place la formule: =SI(D8>=10;"Réussi";"Ajourné")

VI. Les fonctions 1. Présentation Les fonctions sont des outils de calcul puissants. Un tableur, Excel en particulier, met à la disposition un large éventail de fonctions. Excel possède une bibliothèque de fonctions étendue. Quelle que soit la fonction, le processus de mise en place est toujours le même :  Il faut rendre la cellule de destination de la fonction active en cliquant dessus

2. Obtention On utilisera avec profit l'assistant fonction qui peut être appelé par un bouton dans la barre d'outils

, ou par l'appel du menu Insertion/Fonction.

 Sélectionner la fonction  Suivre les instructions qui, généralement, demanderont de sélectionner une plage (ou étendue de cellules). Noter que toute fonction est suivie de parenthèses. Remarque:  On peut aussi créer des formules en utilisant le curseur ou la souris. Il y a un exemple en utilisant la somme automatique à la page sur les fonctions. Cette technique s'applique à la création de toutes les formules.  Il est possible de faire une formule qui utilise le contenu de cellules qui sont sur une autre feuille de calcul. Il faut spécifier le nom de la feuille de calcul en plus de l'adresse de la cellule. Exemple: =B5+MaFeuille4!C3,

FARIH SAID

=somme(feuil2!A3:feuil3!a1)

14


TSDI

Tableur

 Il faut savoir utiliser l'aide (accessible facilement à partir de l'assistant fonction) pour rechercher une fonction et connaître son utilisation : sa syntaxe (comment l'écrire), ses paramètres (à quoi peut-on l'appliquer), son effet, ses restrictions.

3. Exemples de fonctions a. Exemples de fonctions de date et d'heure  AUJOURDHUI : Cette fonction renvoie la valeur numérique correspondant à la date du jour. Cette fonction est une fonction sans paramètre (elle n'a pas d'argument). La syntaxe est AUJOURDHUI().  JOURS360: Renvoie le nombre de jours compris entre deux dates sur la base d'une année de 360 jours (12 mois de 30 jours), Syntaxe JOURS360(date_début;date_fin;méthode)

b. Exemples de fonctions de texte  MAJUSCULE :

Cette

fonction

renvoie

le

texte

passé

en

argument

en

majuscules.

La syntaxe est MAJUSCULE(valeurtexte).  NBCAR : Cette fonction renvoie le nombre de caractères contenus dans une chaîne de texte.

c. Exemples de fonctions logiques Les fonctions logiques permettent de construire des expressions logiques à partir d'expressions conditionnelles.  ET : Cette fonction renvoie la valeur VRAI si tous ses arguments ont la valeur VRAI, et FAUX sinon. Cette fonction admet un nombre d'arguments compris entre 1 et 30. La syntaxe est ET(valeurlogique1;valeurlogique2;...).  OU : Cette fonction renvoie la valeur VRAI si l'un au moins des arguments a la valeur VRAI, et FAUX sinon (c'est-à-dire si tous les arguments ont la valeur FAUX). Cette fonction admet un nombre d'arguments compris entre 1 et 30. La syntaxe est OU(valeurlogique1;valeurlogique2;...).  NON : Cette fonction renvoie la valeur logique contraire de la valeur logique passée en argument. La syntaxe est : NON(valeurlogique).  SI : Cette fonction renvoie une valeur ou une autre selon la valeur de vérité d'une expression logique. La syntaxe est : SI(testlogique;valeursiVRAI;valeursiFAUX). Le premier argument testlogique doit être une expression logique de résultat VRAI ou FAUX, le deuxième argument est la valeur retournée par la fonction si l'expression logique a la valeur VRAI, le troisième argument est la valeur retournée par la fonction si l'expression logique a la valeur FAUX. On peut imbriquer les SI.

d. Exemples de fonctions mathématiques Toutes les fonctions mathématiques et trigonométriques usuelles sont disponibles (SIN, LN, RACINE,...).  ARRONDI : Cette fonction renvoie la valeur numérique donnée comme premier argument arrondie au nombre

de

chiffres

passé

en

second

argument.

La

syntaxe

est

ARRONDI(valeurnumérique;nombrechiffres).  ALEA() : Renvoie un nombre aléatoire supérieur ou égal à 0 et inférieur à 1. Un nouveau nombre aléatoire est renvoyé chaque fois que la feuille de calcul est recalculée. Syntaxe: ALEA( ) Pour générer un nombre réel aléatoire compris entre a et b, utiliser : ALEA()*(b-a)+a

FARIH SAID

15


TSDI VII. Les graphiques

Tableur

1. Insertion du graphique Prenons l’exemple suivant de la pluviométrie d’une ville X : Mois

Janvier Février Mars Avril Mai Juin Juillet Août Septembre Octobre Novembre Décembre

Pluviométrie

1500 1350 900 1100 500 250 60 20 300 950 800 1200

Température

18 17 22 26 28 26 30 32 24 22 24 16

 Sélectionner les cellules.  Cliquer sur l‘icône

, ou sélectionner cette option Graphique dans le menu Insertion.

 L’assistant graphique propose de choisir entre plusieurs types de graphiques. Le format est à sélectionner en fonction des données. En plusieurs étapes, il aidera à définir le graphique, notamment à rajouter des étiquettes, des pourcentages et à choisir la place de la légende.

Étape 1 : Choix du type de graphique. Si c'est des pourcentages, secteurs, courbes…on prendra le style adéquat.

Étape 2 : Confirmation du choix de la plage de cellules

FARIH SAID

16


TSDI

Tableur

Étape 3 : permet de paramétrer la présentation du graphique sélectionné : les titres de graphiques, des axes, les légendes…

Étape 4 : Choix de l’emplacement du graphique.

2. Modification du graphique En cliquant (rapidement deux fois de suite) sur les différents éléments du graphique, on accède au menu de paramétrage. En cliquant sur la courbe des données, dans les pages "Nom et valeurs Y" et "Valeurs X", on peut revoir la sélection des données à prendre en compte dans le graphique. Utilité : À un moment donné on construit un graphique, ultérieurement on ajoute ou on supprime une donnée, il faudra donc en tenir compte dans le graphique.

FARIH SAID

17


TSDI VIII. Copie des formules dans d’autres cellules

Tableur

1. Référence relative Prenons le tableau suivant : on construira une table de multiplication (Lignes * Colonnes). On écrira dans la case B2 la formule : =A2*B1, puis on recopiera cette formule dans toute la table, le résultat est décevant.

X 4 5 6 7

5 6 7 8 9 10 20 120 840 6720 60480 604800 100 12000 10080000 6,77E+10 4,1E+15 2,48E+21 600 7200000 7,26E+13 4,92E+24 2,01E+40 4,99E+61 4200 3,02E+10 2,19E+24 1,08E+49 2,17E+89 1,1E+151

Cela vient du fait que les références utilisées lors de l'écriture de la formule dans la cellule C3 sont des références relatives. Ainsi B3 désigne davantage la cellule se trouvant une ligne plus haut et sur la colonne de gauche. Lorsque cette formule est recopiée dans le presse-papiers, c'est ce point de vue qui est conservé. Lors du collage dans la cellule E4 par exemple, la référence est modifiée pour continuer à désigner la cellule se trouvant une ligne plus haute et sur la colonne de gauche. Ainsi B3 se transforme en D3 et C2 se transforme en E4, etc... Comment s'en sortir ?

2. Référence absolue La référence absolue signifie que si l'on duplique (ou déplace) le lien dans une autre cellule, quel que soit la référence, elle fera toujours référence à la cellule d'origine. Si en B2 au lieu de mettre A2 et B1, on aurait mis : $A2 et B$1, cela renvoie toujours une valeur juste, les autres références copies à partir de B2 seront toujours liées à la ligne 1 et à la colonne A. Pour garder les valeurs d’origine, c’est-à-dire les transformer en références absolues, il est nécessaire de précéder la lettre et/ou le numéro de la colonne par le signe : $. On peut ainsi décider que :  seulement la ligne exemple $C3, (référence mixte)  ou seulement la colonne, exemple : C$3 (référence mixte)  Ou la cellule entière se transforme en référence absolue exemple : $C$3, Cette écriture désigne réellement la cellule $C$3, et non pas la cellule se trouvant trois lignes plus haut et trois colonnes à droite. Lors d'une opération de Copier-Coller, la référence n'est pas modifiée.

3. Lien avec une cellule d'un autre fichier Dans le cas général, pour désigner un ensemble de cellules adjacentes les unes aux autres et formant une plage rectangulaire, on se contente de désigner les deux cellules se trouvant aux extrémités haut-gauche et bas-droite de cette plage, en séparant toutefois la référence à chacune de ces cellules par le signe « : ». La syntaxe est =[Classeur1.XLS]Feuil1!$A$1 Le lien fait référence à la cellule A1 située en page Feuil1 du fichier Classeur1.xls. La partie $A$1 signifie que l'on fait une référence absolue.

FARIH SAID

18


TSDI IX. Base de données

Tableur

Une base de données et un ensemble de données structurées en fiches. Chacun des éléments des fiches est d'un type précis de donnée. La présentation générale est sous forme d'un tableau ; Chaque ligne représente une fiche, chaque colonne représente un élément de chaque fiche.

1. Les listes Une liste est la mémorisation dans Excel de données organisées, une liste est constituée d'une suite d'enregistrements et un certain nombre de champs. Chaque champ porte un nom qui correspond à l'en-tête de colonne. Il existe deux modes de représentation pour les listes : le mode tableau et le mode Formulaire. On passe d'un mode de représentation à l'autre en utilisant le menu Données/ Formulaire...  Le mode tableau est le mode usuel tel qu'il est étudié. Un enregistrement correspond alors à une ligne de la liste. Nom Noubi Alami Karimi Goumi Nachit Filali Ennouri Raadoudi El wafi Zerban Moumni El wardi Dmii Fadi Hazimi El houssaini Mehdaoui Hamdani Yahyaoui Rchidi

Prénom Noureddine Hamid Karim Radwan Kamal Said hamid Ali Houssine Rachid Abdou Mimoun Wafae Khadija Maryem Houda Amal Zineb Noura Warda

Ville de naissance Berkane Casa Casa Casa Fès Goulmime Marrakech Oujda Rabat Salé Sefrou Tetouan Agadir Casa Casa Casa Fès Meknes Rabat Rabat

Sexe Age H 19 H 20 H 19 H 19 H 18 H 18 H 20 H 19 H 19 H 18 H 20 H 18 F 20 F 20 F 19 F 19 F 18 F 18 F 21 F 21

Rue FAR HASSAN 2 MED V SEBOU DAKHLA MOKIT HOUSSAIN NACHAT TAZI ALAHAMDI ESSABTI OHOUD BIDAOUI RAJAE MOHAMADI SAMIR KADI NARJISS KHOUKHA HASSAN II

En mode tableau, on parcourt la liste à l'aide des touches de déplacement ou des ascenseurs ; pour rechercher, on peut utiliser le menu Édition/ Rechercher.

 Le mode Formulaire présente à l'utilisateur une fiche par enregistrement avec la liste des valeurs de ses champs. Par exemple : En mode Formulaire, on parcourt la liste à l'aide des boutons Précédente et Suivante ou des ascenseurs ; pour rechercher, on précise les critères de recherche après l'appui sur le bouton Critères.

FARIH SAID

19


TSDI

2. Ajouter/ supprimer/ modifier des enregistrements

Tableur

Dans le mode Formulaire, ces opérations sont facilitées à l'aide de boutons : Nouvelle pour ajouter, Supprimer pour supprimer, les modifications sont faites dans la grille, on peut annuler une modification à l'aide du bouton Restaurer.

3. Le tri On peut ranger les enregistrements dans différents ordres: croissant ou décroissant. Un ordre est défini en précisant des critères de tri. Pour cela, cliquer sur la colonne puis, dans le menu Données, cliquer sur Trier... S’il y a une ligne de titre qu’Excel ne doit pas prendre en compte dans le tri, vérifier que l’option «Ligne de titre » est bien cochée. Si non, Excel incorporera cette ligne, ce qui est source de désordre. On a la possibilité de tri sur trois colonnes. Par contre, il est n’est pas possible de faire des tris sur les lignes. Spécifications : on doit préciser la zone de liste par son nom ou par les références à la plage de cellules et préciser les critères de tri

4. Les filtres Il faut d’abord faire la différence en deux notions : Filtrer et extraire  Filtrer consiste à ne faire apparaître et de n'imprimer dans la liste que les enregistrements vérifiant certains critères sans être obliger de masquer les autres une par une. On peut filtrer à l'aide des filtres automatiques ou des filtres élaborés  Extraire consiste à recopier la sous liste des enregistrements vérifiant certains critères à un autre endroit dans le classeur. on peut extraire à l'aide des filtres élaborés.

a. Filtres automatiques On peut sélectionner les informations qui s’afficheront :  Dans le menu Données/ Filtrer/ Filtre automatique.  Excel affichera des flèches de menus déroulants à droite de chaque cellule de titre de colonne : En cliquant sur la flèche, on fait apparaître un menu déroulant qui propose plusieurs options, L’option Personnalisé permet d’entrer ses propres critères de filtre.

 Lorsqu'on filtre sur plusieurs colonnes, on filtre selon la conjonction des critères.

b. Filtres élaborés. Les filtres élaborés permettent de faire des filtres qui ne peuvent être réalisés à l'aide de l'outil Filtre automatique. Ce sont les filtres pour lesquels les critères de filtre contiennent des disjonctions (des «ou») ou contiennent des expressions calculées. Ils permettent également de réaliser des extractions. La zone

FARIH SAID

20


TSDI

Tableur

d'extraction définit la plage de cellules où seront placées les données remplissant les conditions précisées dans la zone de critères. Par exemple, on souhaite extraire une liste composée de candidats H ou F natifs de Fès et Casa: Spécifications des filtres élaborés. Il faut préciser :  la zone source (le nom ou les références de la plage contenant la liste),  la zone de critères (le nom ou les références de la plage contenant les critères de filtre, Dans la définition des critères, on utilise la convention suivante : les critères sur une même ligne correspondent à une conjonction, les critères sur des lignes différentes à une disjonction.  la zone de destination (la cellule à partir de laquelle on va ranger la liste). Sur notre exemple, on aurait :  zone source : MaListe (nom donné à la liste)  zone de critères : MesCritères (nom donné à la plage contenant les critères)  zone destination : Résultat!A1 (à partir de la première cellule d'une feuille Résultat du classeur)

5. Tableau croisé dynamique Les tableaux croisés permettent de synthétiser des données provenant d’une ou plusieurs listes. en regroupant des résultats sous forme de tableaux en fonction de différents critères. Pour les statistiques par exemple, on a besoin de faire des dénombrements ou des calculs de moyenne par regroupement de données. On peut facilement retirer ou ajouter des critères, ils peuvent être réactualisés lorsque les données d'origine sont modifiées.

a. Création Quatre étapes : i. Type de données, à choisir parmi 4 :  Liste Excel  Source de données externes.  Plages de consolidations multiples  Autre tableau croisé.

FARIH SAID

21


TSDI

Tableur

ii. La zone source (la zone de liste par son nom ou par les références à la plage de cellules).

iii. La zone destination (la feuille dans laquelle sera placé le tableau résultat).

iv. Disposition…: Les champs de page, les champs de ligne, les champs de colonne, les champs valeurs et les opérations de synthèse associées. L'exemple du tableau ci-dessous consiste à calculer la somme des moyennes par sexe (ou par tranche d’age) dans chaque ville :

b. La barre d'outils. La barre d'outils des TCD (Tableaux Croisés Dynamiques), montre les actions possibles sur un TCD construit :  Actualiser (

)

Si les données d'origine, c'est-à-dire les données contenues dans la liste, ont changé, le TCD peut être recalculé avec cette action.  Assistant (

)

On lance l'assistant pour permettre de modifier le TCD.  Grouper ou dissocier (

FARIH SAID

et

)

22


TSDI

Tableur

Cela concerne les éléments en ligne ou en colonne ou en page. C'est très intéressant surtout s'il y en

beaucoup. Exemple : des dates, des notes, des sommes. On peut grouper de deux façons : 

automatique : on donne une base et un incrément : dans le cas de dates ou d'heures on regroupe par minute, heure, ..., mois, trimestre, année... ;

par sélection : on sélectionne à la souris les champs que l'on veut regrouper.

 Afficher ou masquer des détails (

et

)

On sélectionne une valeur du TCD (synthétisée), Excel construit une nouvelle feuille de calcul montrant tous les éléments qui ont contribué au résultat. Le but est d'obtenir toutes les données qui sont à l'origine de cette valeur. On sélectionne un élément en ligne ou colonne, on peut afficher pour cet élément des éléments d'autres champs.  Mise en forme Mise en forme automatique (menu Format, puis Mise en forme automatique) Format numérique des cellules (option Nombre du champ dynamique) Affichage des cellules vides (options du TCD) Affichage des valeurs d'erreurs

6. Calculs personnalisés a. Définition Les sous-totaux permettent d'ajouter à la liste des lignes récapitulatrices, par exemple un décompte, une moyenne, une somme. Les sous-totaux portent sur des groupes. Un groupe est formé par des suites d'enregistrements pour lesquels la valeur d'un champ est identique. Remarque: pour que les groupes soient correctement formés, il faut préalablement trier sur le champ sur lequel doit porter le groupe.

b. Création  Pour commencer, il faut trier les données de la liste (Ville),  Sélectionner le menu Données/ Sous-totaux… et les options voulues.  Le tableur introduira des lignes avec le calcul par type de données.  On pourra ensuite décider de n’afficher que les sous-totaux, ou l’ensemble des informations en cliquant sur les plus (ou les moins) en marge. La boîte de dialogue Sous-totaux contient :  La liste À chaque changement de : sélectionne le champ de référence pour le sous-total.  La liste Utiliser la fonction, choisit le type de sous total. Généralement on utilise Somme, mais Nombre et Moyenne sont parfois utiles. Nombre compte le nombre de valeur.  Ajouter un sous-total à : on ajoute les champs dont on désire un sous-total. Excel propose toujours, par défaut, le dernier champ.  Remplacer les sous-totaux existants permet de supprimer au préalable les sous-totaux existant déjà dans la liste.

FARIH SAID

23


TSDI

Tableur

 Saut de page entre les groupes insère un saut de page après chaque changement du champ sélectionné dans la liste À chaque changement.  Synthèse sous les données insère les lignes de sous-total et de total sous les données détaillées.

 Par exemple, si on souhaite calculer la moyenne des moyennes pour chaque ville, on trie la colonne ville de naissance, puis on demande d'effectuer l'opération sous-total avec la fonction moyenne sur le champ Moyenne à chaque changement de ville de naissance.  Si on souhaite obtenir le nombre de candidats par ville et par sexe, on trie sur les colonnes ville de naissance et Sexe, puis on demande d'effectuer l'opération sous-total avec la fonction Nombre sur le champ Age à chaque changement de ville de naissance, on répète en choisissant la fonction Nombre sur le champ Sexe à chaque changement de Sexe. Remarque : Pour supprimer les sous-totaux :  Sélectionner à nouveau une cellule de la table.  Retourner dans le Menu Données/Sous-totaux et cliquer sur Supprimer tout.

X. Pour aller plus loin 1. La valeur cible Cette commande permet de trouver une valeur que doit contenir une cellule pour que le résultat d'une formule (dont dépend la cellule) ait une valeur précise. Dans l'exemple suivant, on pourrait rechercher la valeur que doit contenir la cellule Rés3 pour que la moyenne soit égale à 12.

Pour cela :  Sélectionner la cellule qui doit atteindre une valeur précise, ici la cellule de la Moy.  Puis sélectionner : Outils/ Valeur cible…  Dans la zone Cellule à définir, l'adresse de la cellule est déjà indiquée.  Dans la zone Valeur à atteindre, taper la valeur qu’on désire, dans l’exemple : 12.  Dans la zone Cellule à modifier, cliquer sur le bouton

, pour réduire la fenêtre.

 Sélectionner la cellule dont on recherche la valeur. Dans l’exemple la cellule Rés3.  Cliquer sur le bouton

ou appuyer sur Entrée. Puis Ok.

2. La fonction Rang() On a une liste (notes) et on veut la classer automatiquement :  Sélectionner la cellule C2

FARIH SAID

24


TSDI

 Taper la formule =RANG(B2;$B$2:$B$7). Si on désire un

Tableur

ordre inverse, taper la formule =RANG(B2;$B$2:$B$7;1)  Valider cette formule en appuyant sur Entrée.  Tirer cette cellule jusqu'en C7.

3. Aligner les décimales d'un tableau Pour aligner les décimales dans une colonne sans imposer le nombre de décimales comme dans l'exemple, utilisez le format personnalisé suivant : # ##0,???????????????

4. Collage avec liaison Définissons une plage de données dans Excel que nous allons copier. Dans Word faire un collage avec liaison. Cela fonctionne et même les données mises à jour dans Excel seront automatiquement reportées dans Word. L'avantage ? Faire évidemment un tableau sous Excel en profitant des fonctions (somme, moyenne, etc), puis sous Word en faire un rapport. Cela permet de séparer en plusieurs fichiers les différents traitements.

5. Les listes a. Utilise les listes standards Les listes standard d'Excel couvrent les jours de la semaine (Lundi ou Lun) et les mois de l'année (Janvier ou Janv).

b. Créer les propres listes  Supposons qu’on veuille régulièrement saisir une liste de différentes classes : TSDI, TSSI, TSDM, TSGE, TSI.  Dérouler le menu Outils/ Options…/ Liste pers. Dans la zone Listes personnalisées : sélectionner Nouvelle liste.  Puis, dans le champ Entrées de la liste, taper les éléments de la liste en terminant chaque fois par Entrée.

 Quand on a terminé, cliquer sur Ajouter, puis sur OK. La liste est désormais utilisable dans la feuille et dans le classeur qui la contient, mais aussi dans n'importe quel autre classeur Excel. Pour le vérifier :  Taper TSDI dans une cellule quelconque,  Activer la poignée de recopie et étendre la sélection.  Excel écrit TSSI, TSDM, TSGE, TSI. dans les cellules voisines.

FARIH SAID

25


TSDI

Les raccourcis clavier de Word

Tableur

1. Créer, afficher et enregistrer des documents Appuyer sur Pour CTRL+N Créer un nouveau document du même type que le document actif ou le document le plus récent CTRL+O Ouvrir un document CTRL+W Fermer un document ALT+CTRL+S Fractionner la fenêtre du document ALT+CTRL+S Supprimer le fractionnement de la fenêtre du document CTRL+S Enregistrer un document 2. Rechercher, remplacer et parcourir du texte Appuyer sur Pour CTRL+F Rechercher du texte, des mises en forme et certains éléments spéciaux ALT+CTRL+Y Relancer la recherche (après avoir fermé la fenêtre Rechercher et remplacer) CTRL+H Remplacer du texte, une mise en forme déterminée et certains éléments spéciaux CTRL+B Accéder à une page, un signet, une note de bas de page, un tableau, un commentaire, un graphisme ou tout autre endroit ALT+CTRL+Z Revenir à une page, un signet, une note de bas de page, un tableau, un commentaire, un graphisme ou tout autre endroit ALT+CTRL+ORIG Parcourir un document 3. Annuler et refaire des actions Appuyer sur Pour ÉCHAP Annuler une action non validée CTRL+Z Défaire une action CTRL+Y Refaire ou répéter une action 4. Modifier la taille des caractères Appuyer sur Pour CTRL+MAJ+P Changer la police CTRL+MAJ+E Changer la taille de la police CTRL+ALT+MAJ+> Augmenter la taille de la police CTRL+MAJ+< Réduire la taille de la police ALT+CTRL+MAJ+< Augmenter la taille de la police de 1 point ALT+CTRL+< Réduire la taille de la police de 1 point 5. Mises en forme de caractères, polices Appuyer sur Pour CTRL+D Changer la mise en forme des caractères (commande police, menu Format) MAJ+F3 Changer la casse des lettres CTRL+MAJ+A Mettre toutes les lettres en majuscules CTRL+G Appliquer l'attribut gras CTRL+U Appliquer l'attribut souligné ALT+MAJ+U Souligner les mots, mais pas les espaces ALT+CTRL+U Appliquer l'attribut double souligné à du texte CTRL+MAJ+U Appliquer l'attribut texte masqué CTRL+I Appliquer l'attribut italique CTRL+MAJ+K Mettre toutes les lettres en petites majuscules CTRL+SIGNE EGAL Mettre en indice (espacement automatique) CTRL+MAJ+SIGNE PLUS Mettre en exposant (espacement automatique) CTRL+ESPACE Supprimer la mise en forme manuelle des caractères

FARIH SAID

26


TSDI

Tableur

CTRL+MAJ+Q Appliquer à la sélection la police Symbole 6. Affichage et copier des mises des paragraphes Appuyer sur Pour CTRL+MAJ+8 afficher des caractères non imprimables MAJ+F1 (cliquer ensuite sur le texte dont on souhaitez Modifier la mise en forme du texte modifier la mise en forme) CTRL+MAJ+C Copier des mises en forme CTRL+MAJ+V Coller des mises en forme 7. Choix des interlignes Appuyer sur Pour définir l'interligne CTRL+MAJ+L Appliquer un interligne simple ALT+MAJ+L Appliquer un interligne double CTRL+5 Appliquer un interligne de 1,5 CTRL+0 (zéro) Ajouter ou supprimer une ligne avant un paragraphe 8. Positionner les paragraphes Appuyer sur Pour CTRL+E Centrer un paragraphe CTRL+J Justifier un paragraphe CTRL+MAJ+G Aligner un paragraphe à gauche CTRL+MAJ+D Aligner un paragraphe à droite CTRL+M Mettre un paragraphe en retrait à gauche CTRL+MAJ+M Supprimer un retrait de paragraphe à gauche CTRL+T Créer un retrait négatif de première ligne CTRL+MAJ+T Réduire un retrait négatif de première ligne CTRL+Q Supprimer la mise en forme d'un paragraphe 9. Appliquer des styles de paragraphes Appuyer sur Pour CTRL+MAJ+S Appliquer un style CTRL+MAJ+1 Activer la fonction Mise en forme automatique CTRL+MAJ+N Appliquer le style Normal CTRL+MAJ+1 Appliquer le style Titre 1 CTRL+MAJ+2 Appliquer le style Titre 2 CTRL+MAJ+3 Appliquer le style Titre 3 ALT+P Appliquer le style Liste à puces 10. Supprimer du texte et des graphismes Appuyer sur Pour RETOUR ARRIÈRE Supprimer un caractère vers la gauche CTRL+RETOUR ARRIÈRE Supprimer un mot vers la gauche SUPPRESSION Supprimer un caractère vers la droite CTRL+SUPPRESSION Supprimer un mot vers la droite CTRL+X Couper le texte sélectionné et le placer dans le presse-papiers CTRL+Z Annuler la dernière action CTRL+F3 Couper vers le pique-notes 11. Copier et déplacer du texte et des graphismes Appuyer sur Pour CTRL+C Copier du texte ou des graphismes CTRL+C, CTRL+C Afficher le presse-papiers F2 (déplacer ensuite le point d'insertion et appuyer sur Déplacer du texte ou des graphismes ENTRÉE) ALT+F3 Créer une insertion automatique

FARIH SAID

27


TSDI CTRL+V CTRL+MAJ+F3 ALT+MAJ+R

Tableur Coller le contenu du presse-papiers Coller le contenu du pique-notes Copier l'en-tête ou le pied de page utilisé dans la section précédente du document

12. Insérer des caractères spéciaux Appuyer sur Pour insérer CTRL+F9 Un champ ENTRÉE (après avoir tapé les premières lettres du nom de Une insertion automatique l'insertion automatique, une fois l'info-bulle affichée) MAJ+ENTRÉE Un saut de ligne CTRL+ENTRÉE Un saut de page CTRL+MAJ+ENTRÉE Un saut de colonne CTRL+- (trait d'union) Un trait d'union conditionnel CTRL+MAJ+- (trait d'union) Un trait d'union insécable CTRL+MAJ+ESPACE Un espace insécable ALT+CTRL+C Un symbole de copyright ALT+CTRL+R Un symbole de marque déposée ALT+CTRL+T Un symbole de marque ALT+CTRL+point Des points de suspension 13. Sélectionner du texte et des graphismes Appuyer sur Pour étendre une sélection MAJ+DROITE D'un caractère vers la droite MAJ+GAUCHE D'un caractère vers la gauche CTRL+MAJ+DROITE À la fin d'un mot CTRL+MAJ+GAUCHE Au début d'un mot MAJ+FIN À la fin d'une ligne MAJ+ORIGINE Au début d'une ligne MAJ+BAS D'une ligne vers le bas MAJ+HAUT D'une ligne vers le haut CTRL+MAJ+BAS À la fin d'un paragraphe CTRL+MAJ+HAUT Au début d'un paragraphe MAJ+PG.SUIV D'un écran vers le bas MAJ+PG.PRÉC D'un écran vers le haut CTRL+MAJ+ORIGINE Au début du document CTRL+MAJ+FIN À la fin d'un document ALT+CTRL+MAJ+PG.SUIV À la fin d'une fenêtre CTRL+A Au document tout entier CTRL+MAJ+F8, puis utilisez les touches de direction; À un bloc de texte vertical appuyer sur ECHAP pour annuler le mode de sélection F8+ touches de direction; appuyer sur ECHAP pour À un endroit déterminé du document annuler le mode de sélection 14. Sélectionner du texte et des graphismes dans un tableau Appuyer sur Pour TABULATION MAJ+TABULATION Maintenez la touche MAJ enfoncée et appuyer plusieurs fois sur une touche de direction Cliquer dans la cellule en haut ou en bas de la colonne. Maintenez la touche MAJ enfoncée et appuyer plusieurs fois sur la touche HAUT ou BAS CTRL+MAJ+F8, puis utilisez les touches de direction; appuyer sur ECHAP pour annuler le mode de sélection

FARIH SAID

Sélectionner le contenu de la cellule suivante Sélectionner le contenu de la cellule précédente Étendre une sélection aux cellules avoisinantes Sélectionner une colonne

Étendre une sélection (ou un bloc)

28


TSDI

Tableur

MAJ+F8 Réduire la taille de la sélection ALT+5 sur le pavé numérique (VERR.NUM étant désactivé) Sélectionner l'intégralité d'un tableau 15. Étendre une sélection Appuyer sur Pour F8 Activer le mode extension F8, et appuyer sur DROITE ou GAUCHE Sélectionner le caractère le plus proche F8 (appuyer une fois pour sélectionner un mot, deux fois Augmenter la taille d'une sélection pour sélectionner une phrase, etc...) MAJ+F8 Réduire la taille d'une sélection ECHAP Désactiver le mode extension 16. Déplacer le point d'insertion Appuyer sur Pour on déplacer GAUCHE D'un caractère vers la gauche DROITE D'un caractère vers la droite CTRL+GAUCHE D'un mot vers la gauche CTRL+DROITE D'un mot vers la droite CTRL+HAUT D'un paragraphe vers le haut CTRL+BAS D'un paragraphe vers le bas MAJ+TABULATION D'une cellule vers la gauche (dans un tableau) TABULATION D'une cellule vers la droite (dans un tableau) HAUT D'une ligne vers le haut BAS D'une ligne vers le bas FIN Vers la fin de la ligne ORIGINE Vers le début de la ligne ALT+CTRL+PG.PRÉC En haut de la fenêtre ALT+CTRL+PG.SUIV En bas de la fenêtre PG.PRÉC En haut de l'écran (défilement) PG.SUIV En bas de l'écran (défilement) CTRL+PG.SUIV En haut de la page suivante CTRL+PG.PRÉC En haut de la page précédente CTRL+FIN À la fin d'un document CTRL+ORIGINE Au début d'un document MAJ+F5 Vers une révision précédente MAJ+F5 À l'emplacement occupé par le point d'insertion lors de la dernière fermeture du document 17. Se déplacer dans un tableau Appuyer sur Pour on déplacer TABULATION À la cellule suivante d'une ligne MAJ+TABULATION À la cellule précédente d'une ligne ALT+ORIGINE À la première cellule d'une ligne ALT+FIN À la dernière cellule d'une ligne ALT+PG.PRÉC À la première cellule d'une colonne ALT+PG.SUIV À la dernière cellule d'une colonne HAUT À la ligne précédente BAS À la ligne suivante 18. Insérer des marques de paragraphe et de tabulation dans un tableau Appuyer sur Pour insérer ENTRÉE De nouveaux paragraphes dans une cellule CTRL+TABULATION Des marques de tabulation dans une cellule Changer d'affichage Appuyer sur Pour

FARIH SAID

29


TSDI

Tableur

ALT+CTRL+P Passer en mode Page ALT+CTRL+O Passer en mode Plan ALT+CTRL+N Passer en mode Normal CTRL+\ Se déplacer entre un document maître et ses sous-documents 19. Relecture de documents à l'aide des touches de raccourci Remarque Pour agrandir la fenêtre d'aide afin qu'elle occupe tout l'écran, appuyer sur ALT+ESPACE, puis sur X. Pour rétablir la fenêtre à sa taille et son emplacement précédent, appuyer sur ALT+ESPACE, puis sur R. Pour imprimer une rubrique, appuyer sur CTRL+P. Appuyer sur Pour ALT+CTRL+M Insérer un commentaire CTRL+MAJ+E Activer ou désactiver le suivi des modifications ORIGINE Atteindre le début d'un commentaire FIN Atteindre la fin d'un commentaire CTRL+ORIGINE Atteindre le début de la liste de commentaires CTRL+FIN Atteindre la fin de la liste de commentaires 20. Utilisations de références, de notes de bas de page et de notes de fin Appuyer sur Pour ALT+MAJ+O Marquer une entrée de table des matières ALT+MAJ+I Marquer une entrée de la table des références juridiques ALT+MAJ+X Marquer une entrée d'index ALT+CTRL+F Insérer une note de bas de page ALT+CTRL+D Insérer une note de fin 21. Organisation d'un document sous forme de plan à l'aide des touches de raccourci En mode Plan, appuyer sur Pour ALT+MAJ+GAUCHE Hausser un paragraphe ALT+MAJ+DROITE Abaisser un paragraphe CTRL+MAJ+N Abaisser un corps de texte ALT+MAJ+HAUT Déplacer les paragraphes sélectionnés vers le haut ALT+MAJ+BAS Déplacer les paragraphes sélectionnés vers le bas ALT+MAJ+SIGNE PLUS Développer le texte sous un titre ALT+MAJ+SIGNE MOINS Réduire le texte sous un titre ALT+MAJ+A ou * (astérisque du pavé Développer ou réduire l'ensemble du texte ou les titres numérique) / (barre oblique du pavé numérique) Masquer ou afficher la mise en forme de caractères ALT+MAJ+L Afficher l'ensemble du corps de texte ou simplement la première ligne ALT+MAJ+1 Afficher tous les titres mis en forme à l'aide du style Titre 1 ALT+MAJ+n Afficher tous les titres jusqu'au Titre n

FARIH SAID

30


Excel