Issuu on Google+

ADMINISTRACION PYMES CLASE 3 - FUNCIONES CONDICIONALES“PARTE 1” Tal como empezamos en la clase pasada, aquí haremos lo mismo, lo primero que hay que hacer es una tabla de SOCIOS DE UN CLUB como la mostrada en Excel y luego recién nos dedicaremos a las cosas importantes: • Las celdas grises se ponen • Las celdas blancas, el alumno debe colocar las que quiera • Las celdas Naranjas y Celestes rellanaremos luego.

Si bien las funciones simples vistas en la clase pasada son muy buenas, tienen un problema, este problema se radica en que no siempre quiero saber la cantidad total, ni la suma de TODOS los elementos, pero si, solamente de algunos. Por ejemplo, ahora estamos en condiciones de obtener la suma TOTAL de las cuotas de los socios pero no podemos sacar solamente de los CASADOS, o de los que viven en CATRILO, debido que para ello debes sumar según una CONDICION. Por lo tanto, hoy daremos lo que serán llamadas las FUNCIONES CONDICIONALES.

FUNCIONES CONDICIONALES Como ya menciones, las funciones condicionales son todas aquellas funciones que al menos el argumento debe cumplir alguna condición, por lo tanto, eso implica que tendremos al menos 2 argumentos (un dato y una condición). • •

Van a tener al menos una condición Tiene al menos de 2 datos (se separan con ;) NOTA: no confundir ; con : , uno separa datos, el otro establece un rango


Antes de empezar con la primera función, quiero aclarar que de aquí en adelante se nos va a complicar empezar a manejar las funciones, debido a que la cantidad que debemos recordar va a aumentar por lo cual recomiendo: 1. Relacionar cada función con su nombre y RECORDAR su definición. (Esto es muy importante debido a que la definición nos dice como deben colocarse los argumentos) 2. Si bien, a veces, las funciones pueden parecer un código difícil de comprender, hay que acostumbrarse a LEER las funciones con lenguajecoloquial (veremos ejemplos luego) y de allí traducirlas a su estructura.

SIFECHA CALCULA CUANTO TIEMPO PASA DESDE LA FECHAINICIAL HASTA LA FECHAFINAL, Y TE PREGUNTA QUECUENTA (DÍAS, MESES O AÑOS) Esta función se usa mucho para calcular la edad, para calcular cuántos días faltan para año nuevo, o para saber cuántos días faltan para tu cumpleaños, cuantos días te pasaste en el vencimiento de una factura, cuántos meses vas de socio en algún club o cuantos meses vas de novio/a con alguna/n chica/o o simplemente cuántos años estas trabajando en una empresa. Su lenguaje coloquial seria: Cuantos (días, meses o años) pasan de (la primer fecha) hasta (la segunda Fecha) Su estructura: =SIFECHA(Fecha Inicial; Fecha Final; condición)

LA CONDICIÓN: Valor a Español Colocar “D” Día “M” Mes “Y” Año

Pregunta: si queremos calcular la edad: • La Fecha Inicial, ¿la tenemos? SI, la fecha de nacimiento. • La Fecha Final, ¿la tenemos? No, entonces hay que agregarla (sería hoy).

Ingles Day Month Year

En la celda B13 vamos a calcular la fecha de hoy (según el reloj de tu computadora) para ello poner: =HOY()

La condición, ¿la tenemos? SI, debemos calcular AÑOS por eso va “Y”.

Entonces, para calcular la EDAD de Ramírez Juan debemos: • • • • •

Calcular cuántos años pasaron de su fecha de nacimiento hasta el día de hoy (leng. coloquial) =SIFECHA(Fecha de Nacimiento; Fecha Actual; Años) =SIFECHA( D2; B13; “y”) =SIFECHA( 19/04/1992; 13/01/2013;año) =20

CALCULAR TODAS LAS EDADES


(Antes de seguir tienen que asegurarse de saberse la función de memoria, si no lo saben, borren sus resultados y reháganlos tantas veces como sea necesario) Lo siguiente que vamos a aprender será la función:

CONTAR.SI PERMITE CONTAR LA CANTIDAD DE CELDAS DE UN RANGO QUE CONTIENEN UN VALOR QUE CUMPLEN UNA “X” CONDICION. Esta función se usa mucho para contar cuantos caramelos vendiste, cuántos alumnos son mayor de edad, cuantas veces gastaste en videojuegos o cuantas veces fue usada la maquina 1 en un ciber. Para ello los datos a contar deben cumplir ciertas REGLAS: o Todos los valores a contar deben ser iguales entre ellos: Es decir el Estado Civil para varones como para mujeres es CASADO, VIUDO o SOLTERO. Siempre con “o” porque si tendríamos una CASADA al momento de contar los CASADO no la contaría.

o

o

La condición debe estar escrita EXACTAMENTE IGUAL a los valores: sucede que a veces en la condición ponemos: “Guatrache”, la cuanta va a dar “0 (cero)”, debido a que los valores en la tabla estan como “Guatraché” (con acento en la e). El valor de la condición debe estar entre comillas (en la función): ejemplos: “Guatraché”, “>18”, “Futbol”, “Masculino”, etc.

Su lenguaje coloquial seria: La cantidad de “condición” que hay. Su estructura: =CONTAR.SI(rango;“condición”) Ejemplo: Cantidad de cuotas que sean 200. =contar.si(Cuota;”que sea 200”) =contar.si(F2:F11;“200”)


En el cuadrito resolví el resto de las funciones y el rango fue cambiando de acuerdo a lo que contaban.

En este tipo de funciones suele ser muy común que tengamos ERRORES, los diferentes errores de EXCEL pueden ser: •

#¡N/A!(presente en las funciones de búsqueda, las vamos a ver después)

#¡REF! o Este tipo de error surge cuando eliminamos un renglón o una columna que era parte de la

o

Significa que el valor buscado no fue encontrado porque no existe.

formula, la formula ya no se puede calcular y entonces aparece el error.

#¡NUMERO! o o

Este se produce cuando ingresamos algún valor no numérico como un argumento de función que Excel espera que sea argumento numérico. Otra posibilidad es ingresar un número inválido, como uno negativo cuando se espera uno positivo, un 2 cuando el argumento solo admite 0 ó 1, la fecha 30/02 (30 de febrero) o incluso la hora 30 y 70 minutos.

#¡NOMBRE! o

Este error lo obtenemos cuando escribimos mal el nombre de alguna función.

#¡DIV/0!

#¡VALOR!

o o

Se produce al hacer una división por cero. Lo obtenemos cuando el tipo de argumento solicitado por la función, es distinto al ingresado por el usuario. (Si nos pide un numero y le damos texto, saltará este error)

#########

Otro error común es cuando la celda aparece llena de símbolos #. Esto se debe a que la celda no es lo suficientemente ancha para mostrar todo el resultado o cuando contiene una fecha inválida. De resultado o Este error se presenta cuando no nos da el resultado que esperamos obtener. Esto se debe a que nos equivocamos al momento de escribir la función y/o que no cumplimos con las reglas de la misma. o

En todos los casos la función se corrige: • •

Apretando la tecla “F2” y corrigiendo lo que está mal escrito. Corrigiendo el contenido de la celda cual está haciendo menciona. (Si sumamos el contenido de dos celdas y en una de esas dos celdas está escrito “banana”, el resultado será un error, pero no en la formula, sino en el contenido de la celda, debería cambiar “Banana” por el numero que corresponde).

¿Qué pasa cuando se nos pide hacer algo y nos faltan datos? Eso es el caso que debemos resolver ahora, si queremos contar cuantas mujeres y varones hay no podemos hacerlo porque en ningún lugar me dice si son varones o mujeres.


EN TODOS LOS CASOS DONDE ME FALTA ALGUN DATO simplemente DEBO AGREGARLO.

En este ejemplo: Estoy queriendo agregar una columna entre NOMBRE y FECHA DE NACIMIENTO, por ello me posiciono en la celda D2 y pongo INSERTAR>>INSERTAR COLUMNAS DE HOJA eso ocasiona que se inserte una columna, desplazando a la derecha la columna donde estoy posicionado. Allí van a agregar SEXO y luego lo van a rellenar con MASCULINO y FEMENINO, así calculan cuantos varones y mujeres hay.

Lo siguiente que vamos a aprender a calcular será: Que sea Casado • Viudo • Sin hijos • Soltero • Mayor de edad • Local • Menor de edad • Extranjero • Que no sea futbol • Con hijos • Que no se llame Oscar

• • • • •

Sin pareja Mayores de 40 años Que no sea López Que no sea Raúl Menores de 41

Debería quedar algo más o menos así:

Los tres primeros van a ser fáciles y hasta aquí vamos a ir perfectos, pero el resto de las cosas a contar no van a ser así, porque no siempre lo que queremos contar podemos expresarlo de manera tan sencilla, por ende, vamos a aplicar ejemplos más reales y para poder resolverlos tenemos que aprender a usar los SIGNOS DE COMPARACIÓN.


Es igual Es Distinto Mayor Menor Mayor o igual Menor o igual

= <> > < >= <=

numero “0” “<>0” “>17” “<18” “>=18” “<=17”

texto “jac.arauz” “<>jac. Arauz” -

Como verán, hasta ahora, sin darnos cuenta habíamos usado el “igual”: • Contar los valores que sean iguales a “casado” • Contar los valores que sean igual a “Masculino” (varones) • Contar los valores que sean iguales a “Futbol” Para poder calcular el resto tenemos que: • ENTENDER DE QUE NOS ESTAN HABLANDO • USAR EL SENTIDO COMUN • NO SER PEREZOSOS Y PONERNOS A PENSAR Se espera que resuelvan solos los valores recientemente agregados. De cualquier forma en la siguiente forma está el razonamiento pero cuanto más dependas de esa hoja más te costará resolverlo por ti mismo/a.


CALCULAR • • • • • • • • • • • • •

LOCAL: si yo estuviera viviendo en Guatraché, los locales solo son los de Guatraché, entonces: E19 =CONTAR.SI(I2:I11;"Guatraché") EXTRANJERO: si yo estuviera viviendo en Guatraché, los extranjeros son los que NO son de aquí, que es lo mismo a decir, que son DISTINTOS a Guatraché, entonces en E20: =CONTAR.SI(I2:I11;"<>Guatraché") CONHIJOS: Si tiene algún hijo, asumimos que la cantidad total de hijos es mayor que 0 (cero) osea en E21:=CONTAR.SI(J2:J11;">0") SINHIJOS: que no tenga hijos, eso se traduce en números a CERO es decir en E22: =CONTAR.SI(J2:J11;"=0") MAYORDEEDAD: hoy en día la mayoría de edad se alcanza al cumplir los 18 años, es decir de 18 para arriba, que es lo mismo decir MAYOR o IGUAL a 18, entonces en E23: =CONTAR.SI(F2:F11;">=18") MENORDEEDAD: si la mayoría de edad es a los 18 entonces los menores son los que no alcanzan los 18 años, que es lo mismo decir MENOR que 18, en E24: =CONTAR.SI(F2:F11;"<18") QUENOSEAFUTBOL:no ser futbol es lo mismo a decir DISTINTO, en I16: =CONTAR.SI(K2:K11;"<>Futbol") QUENOSELLAMEOSCAR: es decir “DISTINTO A”, en I17: =CONTAR.SI(C2:C11;"<>oscar") SINPAREJA: si tenemos: casado, soltero y viudo, el que no tiene pareja es aquello que no son casados, es decir en I18: =CONTAR.SI(H2:H11;"<>casado") MAYORESDE40AÑOS: eso implica de 41 hacia arriba o en I19: =CONTAR.SI(F2:F11;">40") QUENOSEALÓPEZ: es decir “DISTINTO A”, en I20: =CONTAR.SI(B2:B11;"<>lópez") QUENOSEARAÚL: es decir “DISTINTO A”, en I21: =CONTAR.SI(B2:B11;"<>Raul") MENORESDE41: es decir “DISTINTO A”, en I22: =CONTAR.SI(F2:F11;"<41")

Por último para asegurarse que todo este correcto fíjense que tengan sentido sus resultados. Es decir si arriba cuento que tengo 4 personas casadas y me salta un 3 es que algo pasó.


Adm clase 03 excel 3 condicionales parte 1