Issuu on Google+

Departamento de Sistemasde Información Facultad de Ciencias Empresariales Universidad del Bío-Bío

Concepción, 17 de marzo 2011

Listado ejercicios básicos Introducción a la Programación Profesores: Yasna Meza, Grisell Osses, Luis Angulo, Manuel Crisosto 2011-I

1. Indique cual es el valor de a, b y c después de las siguientes operaciones: a=2 b = 20 c = a+a a = a+c-5 b = a+c+7 a = c-b 2. Resolver las siguientes operaciones (Mod, obtiene el resto de la división de enteros y Div, obtiene el entero de una división): a) X = 21 Mod ( 17 Mod 3) =? b) Y = 38 Div (49 Mod 5) =? 3. Diseñar un algoritmo que permita obtener el valor absoluto de un número. 4. Desarrolle un algoritmo que permita calcular la función: f(x) = (x + 1) 2 + (2*x)2, para un valor de x 5. Escriba un algoritmo que reciba un ángulo en radianes y lo transforme en grados. 6.  Desarrolle un algoritmo que permita imprimir el número mayor de dos elementos de

entrada. 7. Desarrolle un algoritmo que permita dados dos puntos del plano cartesiano, determinar la pendiente de la recta que pasa por dichos puntos. 8. Desarrolle un algoritmo que permita calcular la distancia entre dos puntos de plano cartesiano.


Departamento de Sistemasde Información Facultad de Ciencias Empresariales Universidad del Bío-Bío

9. Desarrolle un algoritmo que permita, dado un valor entero x calcular: - el perímetro del cuadrado cuyo lado mide x - el área de un circulo, cuyo diámetro es x - el área de un rectángulo, cuyos lados miden x y 2*x respectivamente. - el perímetro de un triangulo equilátero, cuyo lado mide x - la hipotenusa de un triangulo isósceles, cuyo cateto mide x 10. Desarrolle un algoritmo que permita calcular el cuadrado de un número ingresado por teclado. 11. Desarrolle un algoritmo que permita calcular la raíz para cualquier número ingresado por teclado. 12. Determine que realiza el siguiente algoritmo: Proceso ejercicio1_listado_1 Variables x,w,f Entero Escribir 'Ingresar dos valores'; Leer x,w; f<- 3*x*x*x+5*w*w+7*(x+w); f<- f*f; Escribir 'El resultado es: ', f; FinProceso 13. Determine que realiza el siguiente algoritmo: Proceso ejercicio1_listado_1 Variables a, b, c, d Entero Escribir 'Ingresar dos valores'; Leer a,b,c; d<- b*b - 4*a*c; Escribir 'El resultado es: ', d; FinProceso


Listado uno