Page 1

INSTITUTO SUPERIOR KHIPU CARRERA PROFESIONAL DE COMPUTACION

Aplicaciones con Software Libre

Guía de aplicación N° 6 Estructuras de control Selectiva I.

FECHA

II.

COMPETENCIAS A CONSEGUIR : Conoce la estructura selectiva simple.

: 24 de Julio del 2013

III. Fundamento Teórico Estructura Selectiva Simple Se evalúa una expresión que puede tomar dos valores (Verdadero o Falso; Si o No, etc). Según el valor de la expresión se ejecuta uno de los bloques.

1.

SI ( condición ) ENTONCES Bloque verdadero SINO Bloque Falso FINSI

El bloque Verdadero o Falso se ejecuta cuando la condición es V o F respectivamente. 2. Operadores relacionales >

Mayor

<=

menor o igual

>=

mayor o igual

= igual

Ej.: X==7

<

Menor

<> distinto

Ej.: 6 % 3!=0

3. Operadores lógicos No

Not

!

Y

And

&&

O

Or

||

Conditional

(condicion)?

C = (d < 10) ? 5:15

Ejercicios de Aplicación Ejercicio N° 1. Elaborar un algoritmo que determine si un estudiante esta aprobado o desaprobado en su primera unidad de introducción a la informática.

Ing. Godofredo Poccori Umeres

gpoccori@khipu.edu.pe

1/6


INSTITUTO SUPERIOR KHIPU CARRERA PROFESIONAL DE COMPUTACION

Aplicaciones con Software Libre 1.

ANÁLISIS 1.1. Entender el Problema. Datos Nota 13 11.3 15.5

Resultado Mensaje “Aprobado” “Desaprobado” “Aprobado”

1.2. Modelo . SI (Nota ≥ 12.5 ) ENTONCES Mensaje =”Aprobado” SINO Mensaje= “Desaprobado” FINSI 1.3. Especificación del algoritmo. 1.3.1. Diccionario de variables - Variables de entrada.nota: nota de la primera evaluación de introducción a la informática : real - Variables de salida.Mensaje : condición de aprobado o desaprobado : cadena 1.3.2. Pre Condición {| nota ≥0 y la nota ≤ 20|} 1.3.3 Acción que realiza el algoritmo : Determina si la nota esta aprobado o desaprobado según la nota ingresada 2.

DISEÑO 2.1. Descripción del Algoritmo. Segunda fase Inicio {determinar si un alumno esta aprobado o desaprobado} {declarar e inicializar variables} Declarar nota : real Declarar , mensaje : cadena {Leer datos } Escribir “ingrese el promedio de la primera unidad” Leer nota {determinar condición de la nota} . SI (nota >= 12.5 ) ENTONCES Mensaje =”Aprobado” SINO Mensaje= “Desaprobado” FINSI {Escribir la solución} Escribir Mensaje fin

Ing. Godofredo Poccori Umeres

gpoccori@khipu.edu.pe

2/6


INSTITUTO SUPERIOR KHIPU CARRERA PROFESIONAL DE COMPUTACION

Aplicaciones con Software Libre

3.

Codificación en lenguaje de Programación Java package appnota; import java.util.Scanner; /* * @author Ing. Godofredo Poccori Umeres */ public class Main { public static void main(String[] args) { //Declarar variales float nota; String mensaje=""; //Ingresar datos Scanner dato=new Scanner(System.in); System.out.print("Ingrese la nota final: "); nota=dato.nextFloat(); //Realizar calculos if(nota>=12.5) { mensaje="Aprobado"; } else { mensaje="Desaprobado"; } //Escribir resultados System.out.println("El Alumno esta: "+mensaje); } }

Ejercicio N° 2. Elaborar un algoritmo que determine si una nota ingresada es válida o no. 4.

ANÁLISIS 1.4. Entender el Problema. Datos Nota 17 -13 21.5

Resultado Mensaje Nota valida Nota es invalida Nota es invalida

1.5. Modelo . SI (Nota ≥ 0 y Nota ≤ 20 ) Ing. Godofredo Poccori Umeres

gpoccori@khipu.edu.pe

3/6


INSTITUTO SUPERIOR KHIPU CARRERA PROFESIONAL DE COMPUTACION

Aplicaciones con Software Libre ENTONCES Mensaje =”Nota valida” SINO Mensaje= “Nota no es valida” FINSI 1.6. Especificación del algoritmo. 1.3.1. Diccionario de variables - Variables de entrada.nota: nota de un alumno : real - Variables de salida.Mensaje : nota valida o no valida : cadena 1.3.2. Pre Condición {| nota Є Real |} 1.3.3 Acción que realiza el algoritmo : Determina si la nota ingresa es valida o no. 5.

6.

DISEÑO 5.1. Descripción del Algoritmo. Segunda fase Inicio {determinar si un alumno esta aprobado o desaprobado} {declarar e inicializar variables} Declarar nota: entero declarar mensaje : cadena {Leer datos } Escribir “ingrese una nota” Leer nota {determinar condición de la nota} . SI (Nota >= 0 y Nota <= 20 ) ENTONCES Mensaje =”Nota válida” SINO Mensaje= “Nota no es válida” FINSI {Escribir la solución} Escribir Mensaje fin Codificación en lenguaje de Programación Java package AppValidar; import java.util.Scanner; /* * @author Ing. Godofredo Poccori Umeres */ public class Main { public static void main(String[] args) { //Declarar variales

Ing. Godofredo Poccori Umeres

gpoccori@khipu.edu.pe

4/6


INSTITUTO SUPERIOR KHIPU CARRERA PROFESIONAL DE COMPUTACION

Aplicaciones con Software Libre

}

float nota; String mensaje=""; //Ingresar datos Scanner dato=new Scanner(System.in); System.out.print("Ingrese la nota: "); nota=dato.nextFloat(); //Realizar calculos if(nota>=0 && nota<=20) { mensaje="Valido"; } else { mensaje="Invalida"; } //Escribir resultados System.out.println("La nota es: "+mensaje);

}

IV Actividades Para Casa 4.1.-Elaborar un algoritmo luego codificarlo en Java para calcular el promedio de 3 notas y me indique si está aprobado, desaprobado o reprobado, considere el siguiente cuadro. Condición Mensaje 12.5<=nota<=20 Aprobado 6.5<=nota<=12.4 Desaprobado 0<=nota<=6.4 Reprobado 4.1 Elaborar un algoritmo que permita determinar si un número es positivo o negativo 4.2 Elaborar un algoritmo que determine el menor de 3 números ingresados. ENTREGAR EL DESARROLLO DE ACTIVIDADES, PARA CADA ACTIVIDAD EL ANÁLISIS, DISEÑO EN HOJAS DE EXAMEN, A LAPICERO Y CODIFICACIÓN impreso o logico mostrando la pantalla de ejecución.

Ing. Godofredo Poccori Umeres

gpoccori@khipu.edu.pe

5/6


INSTITUTO SUPERIOR KHIPU CARRERA PROFESIONAL DE COMPUTACION

Aplicaciones con Software Libre

V Actividades en casa 5.1 Elaborar un algoritmo que determine si un año ingresado es bisiesto o no es bisiesto 5.2 Elaborar un algoritmo que ingresados tres números enteros, determine si éstos están en orden creciente. 5.3 Un librería ofrece dos tipos de descuentos, si la venta es mayor de 500 soles el descuento es 12.5% de la venta, si l venta es entre 100 y 499 soles el descuento es 8.5% del total de la venta, elaborar un algoritmo que calcule la venta total y el descuento si se conoce el precio unitario y la cantidad de libros que se vende.

Ficha de calificación GUIA DE APLICACIÓN Nº 06 Estructuras de control selectiva Nombre: …………………………………………………………………………………Código: …………………………………. Criterio

Puntaje

Actitudinal

20

Procedimental Ejercicio 1 y 2 de la guía

5

Actividad en clase 4.1

3

Actividad en clase 4.2

3

Actividad 5.1

3

Actividad 5.2

3

Actividad 5.3

3 Total

Calificación Obtenida por el estudiante

20

Firma de Profesor ………………………………………….

Ing. Godofredo Poccori Umeres

gpoccori@khipu.edu.pe

6/6

Guia6 selectiva simple en java  

Estructura de control selectiva IF Else

Read more
Read more
Similar to
Popular now
Just for you