Issuu on Google+

Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 2007 ΘΕΜΑ 1 Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1. Με τη λειτουργία της συγχώνευσης, δύο ή περισσότερες δομές δεδομένων συνενώνονται σε μία ενιαία δομή. 2. Ο τρόπος κλήσης των διαδικασιών και των συναρτήσεων είναι ίδιος, ενώ ο τρόπος σύνταξής τους είναι διαφορετικός. 3. Όταν αριθμητικοί και συγκριτικοί τελεστές συνδυάζονται σε μία έκφραση, οι αριθμητικές πράξεις εκτελούνται πρώτες. 4. Η έννοια του αλγορίθμου συνδέεται αποκλειστικά και μόνο με προβλήματα της Πληροφορικής. 5. Κάθε βρόχος που υλοποιείται με την εντολή ΟΣΟ … ΕΠΑΝΑΛΑΒΕ μπορεί να γραφεί και με χρήση της εντολής ΓΙΑ … ΑΠΟ … ΜΕΧΡΙ. Μονάδες 10 Απάντηση 1Σ 2Λ 3Σ 4Λ 5Λ

Β.1. i. Να εξηγήσετε τι εννοούμε με τον όρο μεταφερσιμότητα των προγραμμάτων. Μονάδες 3 Απάντηση: Τα προγράμματα σε μία γλώσσα υψηλού επιπέδου μπορούν να εκτελεστούν σε οποιονδήποτε υπολογιστή με ελάχιστες ή καθόλου μετατροπές. Η δυνατότητα της μεταφερσιμότητας των προγραμμάτων είναι σημαντικό προσόν. ii. Ποια ή ποιες από τις παρακάτω κατηγορίες γλωσσών προσφέρουν αυτή τη δυνατότητα στα προγράμματα: α. γλώσσες μηχανής β. συμβολικές γλώσσες γ. γλώσσες υψηλού επιπέδου. Μονάδες 2 Απάντηση: Η σωστή επιλογή είναι το γ Β.2. Για ποιες από τις παρακάτω περιπτώσεις μπορεί να χρησιμοποιηθεί συνάρτηση: α. εισαγωγή ενός δεδομένου β. υπολογισμός του μικρότερου από πέντε ακεραίους γ. υπολογισμός των δύο μικρότερων από πέντε ακεραίους δ. έλεγχος αν δύο αριθμοί είναι ίσοι ε. ταξινόμηση πέντε αριθμών στ. έλεγχος αν ένας χαρακτήρας είναι φωνήεν ή σύμφωνο. Μονάδες 6 Απάντηση: Στις περιπτώσεις β, δ, στ Γ. Δίνεται το παρακάτω τμήμα αλγορίθμου σε φυσική γλώσσα κατά βήματα: Βήμα 1: Αν Α > 0 τότε πήγαινε στο Βήμα 5 Βήμα 2: Αν Α = 0 τότε πήγαινε στο Βήμα 7 Βήμα 3: Τύπωσε “Αρνητικός’’

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Βήμα 4: Πήγαινε στο Βήμα 8 Βήμα 5: Τύπωσε “Θετικός’’ Βήμα 6: Πήγαινε στο Βήμα 8 Βήμα 7: Τύπωσε “Μηδέν’’ Βήμα 8: Τύπωσε “Τέλος’’ 1. Να σχεδιάσετε το ισοδύναμο διάγραμμα ροής. Μονάδες 6 Απάντηση:

α>0

ΟΧΙ

ΝΑΙ Εμφάνισε "Θετικός"

α=0

ΟΧΙ

ΝΑΙ Εμφάνισε "Μηδέν"

Εμφάνισε "Αρνητικός"

Εμφάνισε "Τέλος"

2. Να κωδικοποιήσετε τον αλγόριθμο σε ψευδογλώσσα σύμφωνα με τις αρχές του δομημένου προγραμματισμού. Μονάδες 5 Απάντηση: Αν α>0 τότε Εμφάνισε «θετικός» Αλλιώς_αν α=0 τότε Εμφάνισε «Μηδέν» Αλλιώς Εμφάνισε «Αρνητικός» Τέλος_αν Εμφάνισε «Τέλος» Δ. Δίνονται οι παρακάτω προτάσεις: Π1. Ο συνδέτης-φορτωτής μετατρέπει το ___1___ πρόγραμμα σε ___2___ πρόγραμμα Π2. Ο συντάκτης χρησιμοποιείται για να δημιουργηθεί το ___3___ πρόγραμμα Π3. Ο μεταγλωττιστής μετατρέπει το ___4___ πρόγραμμα σε ___5___ πρόγραμμα και οι παρακάτω λέξεις: α. αντικείμενο β. εκτελέσιμο γ. πηγαίο. 1. Να γράψετε στο τετράδιό σας τους αριθμούς (1–5) των κενών διαστημάτων των προτάσεων και δίπλα το γράμμα της λέξης (α, β, γ) που αντιστοιχεί σωστά.

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΣΗΜΕΙΩΣΗ: Κάποιες από τις λέξεις χρησιμοποιούνται περισσότερες φορές από μία. Μονάδες 5 Απάντηση: 1α 2β 3γ 4γ 5α 2. Κατά την ανάπτυξη ενός προγράμματος σε ένα προγραμματιστικό περιβάλλον, με ποια χρονική σειρά πραγματοποιούνται τα βήματα που περιγράφουν οι παραπάνω προτάσεις; Να απαντήσετε γράφοντας τα Π1, Π2, Π3 με τη σωστή σειρά. Μονάδες 3 Απάντηση: Π2, Π3, Π1

ΘΕΜΑ 2 Δίνεται παρακάτω ένα πρόγραμμα με ένα υποπρόγραμμα: ΠΡΟΓΡΑΜΜΑ Υπολογισμοί ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ ΑΡΧΗ ΔΙΑΒΑΣΕ α, β γ ← α + Πράξη (α, β) ΓΡΑΨΕ γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΝΑΡΤΗΣΗ Πράξη (χ, ψ): ΠΡΑΓΜΑΤΙΚΗ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ ΑΡΧΗ ΑΝ χ >= ψ ΤΟΤΕ Πράξη ← χ – ψ ΑΛΛΙΩΣ Πράξη ← χ + ψ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ α. Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί συνάρτησης. Μονάδες 7 Απάντηση: ΠΡΟΓΡΑΜΜΑ Υπολογισμοί ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ ΑΡΧΗ ΔΙΑΒΑΣΕ α, β ΚΑΛΕΣΕ Πράξη(α, β, δ) γα+δ ΓΡΑΨΕ γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΔΙΑΔΙΚΑΣΙΑ Πράξη(χ, ψ, κ) ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ, κ) ΑΡΧΗ

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΑΝ χ >= ψ ΤΟΤΕ κχ–ψ ΑΛΛΙΩΣ κχ+ψ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ β. Να ξαναγράψετε το πρόγραμμα που δόθηκε αρχικά, ώστε να επιτελεί την ίδια λειτουργία χωρίς τη χρήση υποπρογράμματος. Μονάδες 7 Απάντηση: ΠΡΟΓΡΑΜΜΑ Υπολογισμοί ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ ΑΡΧΗ ΔΙΑΒΑΣΕ α, β ΑΝ α >= β ΤΟΤΕ δα–β ΑΛΛΙΩΣ δα+β ΤΕΛΟΣ_ΑΝ γα+δ ΓΡΑΨΕ γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ γ. Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του αρχικού προγράμματος που δόθηκε, αν ως τιμές εισόδου δοθούν οι αριθμοί: i. α = 10 β=5 ii. α = 5 β=5 iii. α = 3 β=5 Μονάδες 6 Απάντηση: Σε κάθε περίπτωση εμφανίζονται οι τιμές: i. 15 ii. 5 iii. 11 ΘΕΜΑ 3 Ένας συλλέκτης γραμματοσήμων επισκέπτεται στο διαδίκτυο το αγαπημένο του ηλεκτρονικό κατάστημα φιλοτελισμού προκειμένου να αγοράσει γραμματόσημα. Προτίθεται να ξοδέψει μέχρι 1500 ευρώ. Να αναπτύξετε αλγόριθμο ο οποίος: α. Για κάθε γραμματόσημο, να διαβάζει την τιμή και την προέλευσή του (ελληνικό/ξένο) και να επιτρέπει την αγορά του, εφόσον η τιμή του δεν υπερβαίνει το διαθέσιμο υπόλοιπο χρημάτων. Διαφορετικά να τερματίζει τυπώνοντας το μήνυμα «ΤΕΛΟΣ ΑΓΟΡΩΝ». Μονάδες 10 ΣΗΜΕΙΩΣΗ: Δεν απαιτείται έλεγχος εγκυρότητας για τα δεδομένα εισόδου.

β. Να τυπώνει: 1. Το συνολικό ποσό που ξόδεψε ο συλλέκτης. Μονάδες 2 2. Το πλήθος των ελληνικών και το πλήθος των ξένων γραμματοσήμων που αγόρασε. Μονάδες 4

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

3. Το ποσό που περίσσεψε, εφόσον «ΕΞΑΝΤΛΗΘΗΚΕ ΟΛΟ ΤΟ ΠΟΣΟ».

υπάρχει, διαφορετικά Μονάδες 4

το

μήνυμα

Απάντηση: Αλγόριθμος Θέμα_3 ΠΕ  0 ΠΞ  0 ΣΠ  0 !συνολικό ποσό Διάβασε Τα !τιμή Όσο ΣΠ+Τ <= 1500 Επανάλαβε ΣΠ  ΣΠ+Τ Διάβασε Π !προέλευση Αν Π = «Ελληνικό» τοτε ΠΕ  ΠΕ + 1 Αλλιώς ΠΞ  ΠΞ + 1 Τέλος_αν Διάβασε Τ Τέλος_επανάληψης Εκτύπωσε «Τέλος αγορών» Εκτύπωσε ΣΠ , ΠΕ , ΠΞ ΥΠ  1500 - ΣΠ Αν ΥΠ>0 τοτε Εκτύπωσε ΥΠ Αλλιώς Εκτύπωσε «Εξαντληθηκε το ποσό» Τέλος_αν Τέλος Θέμα_3 ΘΕΜΑ 4 Μια δισκογραφική εταιρεία καταγράφει στοιχεία για ένα έτος για κάθε ένα από τα 20 CDs που κυκλοφόρησε. Τα στοιχεία αυτά είναι ο τίτλος του CD, ο τύπος της μουσικής που περιέχει και οι μηνιαίες του πωλήσεις (ποσά σε ευρώ) στη διάρκεια του έτους. Οι τύποι μουσικής είναι δύο: «ορχηστρική» και «φωνητική». Να αναπτυχθεί αλγόριθμος ο οποίος: α. Για κάθε ένα από τα 20 CDs, να διαβάζει τον τίτλο, τον τύπο της μουσικής και τις πωλήσεις του για κάθε μήνα, ελέγχοντας την έγκυρη καταχώριση του τύπου της μουσικής. Μονάδες 2 β. Να εμφανίζει τον τίτλο ή τους τίτλους των CDs με τις περισσότερες πωλήσεις τον 3ο μήνα του έτους. Μονάδες 6 γ. Να εμφανίζει τους τίτλους των ορχηστρικών CDs με ετήσιο σύνολο πωλήσεων τουλάχιστον 5000 ευρώ. Μονάδες 6 δ. Να εμφανίζει πόσα από τα CDs είχαν σύνολο πωλήσεων στο δεύτερο εξάμηνο μεγαλύτερο απ’ ό,τι στο πρώτο. Μονάδες 6 Απάντηση: Αλγόριθμος Θέμα_4 Για i από 1 μέχρι 20 Διάβασε ΤΙΤ[i] Τέλος_Επανάληψης

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Για i από 1 μέχρι 20 Αρχή_επανάληψης Διάβασε ΤΥΠ[i] !Δημιουργία πινάκων Μέχρις_ότου ΤΥΠ[i]= “ορχηστρική” ή ΤΥΠ[i]= “φωνητική” Τέλος_Επανάληψης Για i από 1 μέχρι 20 Για j από 1 μέχρι 12 Διάβασε ΜΠ[i,j] Τέλος_Επανάληψης Τέλος_Επανάληψης max  ΜΠ[1,3] Για i από 2 μέχρι 20 Αν ΜΠ[i,3] > max τότε !εύρεση του cd με τις περισσότερες πωλήσεις max  ΜΠ[i,3] !τον 3ο μήνα του έτους Τέλος_Αν Τέλος_Επανάληψης Για i από 1 μέχρι 20 Αν ΜΠ[i,3] = max τότε !εύρεση ΤΩΝ cd με τις περισσότερες πωλήσεις Εμφάνισε ΤΙΤ[i] Τέλος_Αν Τέλος_Επανάληψης Για i από 1 μέχρι 20 ΣΠ[i]  0 Για j από 1 μέχρι 12 ΣΠ[i]  ΣΠ[i] + ΜΠ[i,j] Τέλος_Επανάληψης Τέλος_Επανάληψης Για i από 1 μεχρι 20 Αν (ΤΥΠ[i]= “ορχηστρική”) και (ΣΠ[i]>= 5000) τότε Εμφάνισε ΤΙΤ[i] Τέλος_αν Τέλος_επανάληψης Για i από 1 μεχρι 20 Sum0 Για j από 1 μεχρι 6 Sum  Sum + ΜΠ[i,j] Τέλος_επανάληψης Ε1 [i]  Sum Τέλος_επανάληψης Για i από 1 μεχρι 20 Sum  0 Για j από 7 μεχρι 12 Sum  Sum + ΜΠ[i,j] Τέλος_επανάληψης Ε2 [i]  Sum Τέλος_επανάληψης ΠΛ0 Για i από 1 μεχρι 20 Αν Ε2 [i] > Ε1 [i] τότε ΠΛ  ΠΛ +1 Τέλος_αν Τέλος_επανάληψης Εμφάνισε ΠΛ

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 2006 ΘΕΜΑ 1 Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1. Η σειριακή αναζήτηση χρησιμοποιείται αποκλειστικά στους ταξινομημένους πίνακες. 2. Η εντολή επανάληψης ΓΙΑ … ΑΠΟ … ΜΕΧΡΙ … ΜΕ_ΒΗΜΑ μπορεί να χρησιμοποιηθεί, όταν έχουμε άγνωστο αριθμό επαναλήψεων. 3. Για την εκτέλεση μιας εντολής συμβολικής γλώσσας απαιτείται η μετάφρασή της σε γλώσσα μηχανής. 4. Η λίστα των πραγματικών παραμέτρων καθορίζει τις παραμέτρους στην κλήση του υποπρογράμματος. 5. Σε μία δυναμική δομή δεδομένων τα δεδομένα αποθηκεύονται υποχρεωτικά σε συνεχόμενες θέσεις μνήμης. Μονάδες 10 Απάντηση: 1Λ

2Λ

3Σ

4Σ

5Λ

Β. Να αναφέρετε τους κανόνες που πρέπει να ακολουθούν οι λίστες των παραμέτρων κατά την κλήση ενός υποπρογράμματος. Μονάδες 9 Απάντηση: -Ο αριθμός των πραγματικών και των τυπικών παραμέτρων πρέπει να είναι ίδιος. -Κάθε πραγματική παράμετρος αντιστοιχεί στην τυπική παράμετρο που βρίσκεται στην αντίστοιχη θέση. Για παράδειγμα η πρώτη της λίστας των τυπικών παραμέτρων στην πρώτη της λίστας των πραγματικών παραμέτρων κοκ. -Η τυπική παράμετρος και η αντίστοιχη της πραγματική πρέπει να είναι του ιδίου τύπου. Γ. Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα: ΠΡΟΓΡΑΜΜΑ Κύριο ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ ΔΙΑΒΑΣΕ Α, Β, Γ ΚΑΛΕΣΕ Διαδ1(Α, Β, Γ) ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΔΙΑΔΙΚΑΣΙΑ Διαδ1(Β, Α, Γ) ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ Α←Α+2 Β←Β–3 Γ←Α+Β ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Τι θα εμφανιστεί κατά την εκτέλεση του προγράμματος, αν ως τιμές εισόδου δοθούν οι αριθμοί 5, 7, 10; Μονάδες 12

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Απάντηση:

Θα εμφανιστούν οι τιμές: 9

2

11

2

9

11

Δ.Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά. Στη Στήλη Β υπάρχει ένα επιπλέον στοιχείο. Στήλη Α 1. “ΑΛΗΘΗΣ” 2. ΚΑΙ 3. α > 12 4. αριθμός_παιδιών 5. ≤

Στήλη Β Α. λογικός τελεστής β. μεταβλητή γ. αλφαριθμητική σταθερά δ. λογική σταθερά ε. συγκριτικός τελεστής στ. συνθήκη Μονάδες 5

Απάντηση: 1γ

2α

3  στ

4β

5ε

Ε. Αν α = 5, β = 7 και γ = 10, να χαρακτηρίσετε στο τετράδιό σας τις παρακάτω προτάσεις χρησιμοποιώντας μία από τις λέξεις ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ. Πρόταση Α. (όχι (α + 2 ≥ β)) ή β + 3 = γ Πρόταση Β. α + 2 * β < 20 και 2 * α = γ Μονάδες 4 Απάντηση: Πρόταση Α: Αληθής Πρόταση Β: Αληθής ΘΕΜΑ 2 1. Δίνεται ο παρακάτω αλγόριθμος σε μορφή διαγράμματος ροής: Αρχή Διάβασε Χ

Ψ

Χ mod 2 = 0

Α Y←X DIV 2

Y←X ^ 2 Y <= 10

Α

Ψ Y←2 * X + Y

Εμφάνισε Υ

Τέλος

α. Να κατασκευάσετε ισοδύναμο αλγόριθμο σε ψευδογλώσσα. Μονάδες 7 Απάντηση: Αλγοριθμος θεμα_2_1 Διαβασε Χ Αν Χ mod 2 = 0 τοτε

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΥΧ div 2 Αν Υ< = 10 τοτε Υ2 * Χ + Υ Τελος_αν Αλλιως ΥΧ ^ 2 Τελος_αν Εμφανισε Υ

Τελος θεμα_2_1 β. Να εκτελέσετε τον αλγόριθμο για κάθε μία από τις παρακάτω τιμές της μεταβλητής Χ. Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Υ, όπως θα εμφανισθεί σε κάθε περίπτωση. i. Χ = 9 ii. Χ = 10 iii. Χ = 40 Μονάδες 3 Απάντηση i. 81 ii. 25 iii. 20 2. Δίνεται ο παρακάτω αλγόριθμος σε ψευδογλώσσα: Αλγόριθμος Μετατροπή Χ←0 Για Κ από 1 μέχρι 10 Διάβασε Λ Αν Λ > 0 τότε Χ←Χ+Λ Αλλιώς Χ←Χ–Λ Τέλος_Αν Τέλος_Επανάληψης Εμφάνισε Χ Τέλος Μετατροπή Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής. Απάντηση:

Μονάδες 10

Αρχή

Χ 0

Κ 1

Κ<=10

Αληθής

Ψευδής

Διάβασε Λ

Εμφάνισε Χ Ψευδής Τέλος

Λ>0

Χ Χ–Λ

Χ Χ+Λ

Κ Κ+1

Καστούμης Γιώργος

Αληθής


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΘΕΜΑ 3 Σε ένα διαγωνισμό του ΑΣΕΠ εξετάζονται 1500 υποψήφιοι. Ως εξεταστικό κέντρο χρησιμοποιείται ένα κτίριο με αίθουσες διαφορετικής χωρητικότητας. Ο αριθμός των επιτηρητών που απαιτούνται ανά αίθουσα καθορίζεται αποκλειστικά με βάση τη χωρητικότητα της αίθουσας ως εξής: ΧΩΡΗΤΙΚΟΤΗΤΑ

ΑΡΙΘΜΟΣ ΕΠΙΤΗΡΗΤΩΝ

Μέχρι και 15 θέσεις

1

Από 16 μέχρι και 23 θέσεις

2

Πάνω από 23 θέσεις

3

Να γίνει πρόγραμμα σε γλώσσα προγραμματισμού «ΓΛΩΣΣΑ» το οποίο: α. για κάθε αίθουσα θα διαβάζει τη χωρητικότητά της, θα υπολογίζει και θα εμφανίζει τον αριθμό των επιτηρητών που χρειάζονται. Ο υπολογισμός του αριθμού των επιτηρητών να γίνεται από συνάρτηση που θα κατασκευάσετε για το σκοπό αυτό. Μονάδες 12 β. θα σταματάει όταν εξασφαλισθεί ο απαιτούμενος συνολικός αριθμός θέσεων. Μονάδες 8 Σημείωση: Να θεωρήσετε ότι η συνολική χωρητικότητα των αιθουσών του κτιρίου επαρκεί για τον αριθμό των υποψηφίων.

Απάντηση: ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_3 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Σ, ΧΩΡ, ΑΡ_ΕΠ ΑΡΧΗ Σ0 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘ΔΩΣΤΕ ΧΩΡΗΤΙΚΟΤΗΤΑ ΑΙΘΟΥΣΑΣ’ ΔΙΑΒΑΣΕ ΧΩΡ ΑΡ_ΕΠ  ΥΠ_ΕΠ ( ΧΩΡ ) ΓΡΑΨΕ ‘Ο ΑΡΙΘΜΟΣ ΤΩΝ ΕΠΙΤΗΡΗΤΩΝ ΕΙΝΑΙ:’, ΑΡ_ΕΠ ΣΣ+ΧΩΡ ΜΕΧΡΙΣ_ΟΤΟΥ Σ > = 1500 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΜΑ_3 ΣΥΝΑΡΤΗΣΗ ΥΠ_ΕΠ ( Χ ): ΑΚΕΡΑΙΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ ΑΡΧΗ ΑΝ Χ <= 15 ΤΟΤΕ ΥΠ_ΕΠ  1 ΑΛΛΙΩΣ_ΑΝ Χ <= 23 ΤΟΤΕ ΥΠ_ΕΠ  2 ΑΛΛΙΩΣ

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΥΠ_ΕΠ  3 ΤΕΛΟΣ-ΑΝ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ ΥΠ_ΕΠ ΘΕΜΑ 4 Για την παρακολούθηση των θερμοκρασιών της επικράτειας κατά το μήνα Μάιο καταγράφεται κάθε μέρα η θερμοκρασία στις 12:00 το μεσημέρι για 20 πόλεις. Να σχεδιάσετε αλγόριθμο που: α. θα διαβάζει τα ονόματα των 20 πόλεων και τις αντίστοιχες θερμοκρασίες για κάθε μία από τις ημέρες του μήνα και θα καταχωρεί τα στοιχεία σε πίνακες. Μονάδες 2 β. θα διαβάζει το όνομα μίας πόλης και θα εμφανίζει τη μέγιστη θερμοκρασία της στη διάρκεια του μήνα. Αν δεν υπάρχει η πόλη στον πίνακα, θα εμφανίζει κατάλληλα διαμορφωμένο μήνυμα. Μονάδες 9 γ. θα εμφανίζει το πλήθος των ημερών που η μέση θερμοκρασία των 20 πόλεων ξεπέρασε τους 20οC, αλλά όχι τους 30οC. Μονάδες 9 Απάντηση: Αλγόριθμος θέμα_4 Για i από 1 μέχρι 20 Διάβασε Ο[ i ] Για j από 1 μέχρι 31 Διάβασε θερ[ i , j ] Τέλος_Επανάληψης Τέλος_Επανάληψης Εμφάνισε «Δώστε το όνομα μιας από τις πόλεις» Διάβασε πόλη pos  0 I1 done  ψευδής Οσο (i<=20) και (done=ψευδής) επανάλαβε Αν Ο[ i ] = πόλη τότε pos  i done  αληθής Αλλιώς i  i+1 Τέλος_αν Τέλος_Επανάληψης Αν done = αληθής τότε max  θερ[ pos , 1 ] Για j από 2 μέχρι 31 Αν θερ[ pos , j ] > max τότε max  θερ[ pos , j ] Τέλος_αν Τέλος_Επανάληψης Εμφάνισε max Αλλιώς Εμφάνισε «Η πόλη που δώσατε δεν είναι καταχωρημένη» Τέλος_αν Για j από 1 μέχρι 31

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

sum 0 Για i από 1 μέχρι 20 sum  sum + θερ[ i , j ] Τέλος_Επανάληψης MO[ j ]  sum /20 Τέλος_Επανάληψης Π0 Για j από 1 μέχρι 31 Αν (ΜΟ [ j ] > 20) και (ΜΟ[ j ] <= 30) τότε Π  Π+1 Τέλος_αν Τέλος_Επανάληψης Εμφάνισε Π Τέλος Θέμα_4

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 2005 ΘΕΜΑ 1 Α.1. Να αναφέρετε ονομαστικά τα κριτήρια που πρέπει απαραίτητα να ικανοποιεί ένας αλγόριθμος. Μονάδες 5 Απάντηση

Η Απάντηση βρίσκεται στις σελίδες 25-26 του 2ου κεφαλαίου: Είσοδος, Έξοδος, Περατότητα, Καθοριστικότητα, Αποτελεσματικότητα Α.2. Ποιο κριτήριο δεν ικανοποιεί ο παρακάτω αλγόριθμος και γιατί; S←0 Για Ι από 2 μέχρι 10 με_βήμα 0 S←S+I Τέλος_επανάληψης Εμφάνισε S Μονάδες 5 Απάντηση: Δεν ικανοποιείται το κριτήριο της περατότητας,. Το βήμα στη συγκεκριμένη δομή επανάληψης είναι μηδέν (0) με αποτέλεσμα η τιμή του μετρητή Ι να παραμένει για πάντα 2 και η δομή επανάληψης να μην τερματίζεται ποτέ (ατέρμων βρόχος) Β. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1. Η ταξινόμηση είναι μια από τις βασικές λειτουργίες επί των δομών δεδομένων. 2. Τα στοιχεία ενός πίνακα μπορούν να αποτελούνται από δεδομένα διαφορετικού τύπου. 3. Ένα υποπρόγραμμα μπορεί να καλείται από ένα άλλο υποπρόγραμμα ή από το κύριο πρόγραμμα. 4. Στην επαναληπτική δομή Όσο … Επανάλαβε δεν γνωρίζουμε εκ των προτέρων το πλήθος των επαναλήψεων. 5. Κατά την εκτέλεση ενός προγράμματος μπορεί να αλλάζει η τιμή και ο τύπος μιας μεταβλητής. Μονάδες 10 Απάντηση:

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

1Σ

2Λ

3Σ

4Σ

5Λ

Γ. Δίνεται το παρακάτω τμήμα αλγορίθμου: S←0 Για Ι από 2 μέχρι 100 με_βήμα 2 S←S+I Τέλος_επανάληψης Εμφάνισε S 1. Να μετατραπεί σε ισοδύναμο με χρήση της δομής Όσο … Επανάλαβε Μονάδες 5 2. Να μετατραπεί σε ισοδύναμο με χρήση της δομής αρχή_επανάληψης… μέχρις_ότου. Μονάδες 5 Απάντηση: 1. S  0 I2 ΟΣΟ I<=100 ΕΠΑΝΑΛΑΒΕ S  S+I I  I+2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΕΜΦΑΝΙΣΕ S 2. S  0 I2 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ S  S+I I  I+2 ΜΕΧΡΙΣ_ΟΤΟΥ Ι > 100 ΕΜΦΑΝΙΣΕ S

Δ. Να γράψετε τις παρακάτω μαθηματικές εκφράσεις σε ΓΛΩΣΣΑ: 1. 2.

5X  3Y A  B2

Μονάδες 3

X Y 2

2

Μονάδες 3

Απάντηση: 1. (5*Χ-3*Υ)/(Α-Β^2) 2. Τ_Ρ(Χ^2-Υ^2) Ε. Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά. Στη Στήλη Β υπάρχει ένα επιπλέον στοιχείο. Στήλη Α Είδος εφαρμογών 1. επιστημονικές 2. εμπορικές- επιχειρησιακές 3. τεχνητής νοημοσύνης 4. γενικής χρήσης- εκπαίδευσης

Στήλη Β Γλώσσες α. COBOL β. LISP γ. FORTRAN δ. PASCAL ε. JAVA Μονάδες 4

Απάντηση: 1Γ

2Α

Καστούμης Γιώργος

3Β

4Δ


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

ΘΕΜΑ 2 Δίνεται το παρακάτω τμήμα προγράμματος και μια συνάρτηση: Διάβασε Κ L←2 A←1 Όσο Α < 8 επανάλαβε Αν Κ MOD L = 0 τότε Χ ← Fun(A, L) αλλιώς Χ←Α+L Τέλος_αν Εμφάνισε L, A, X A←A+2 L←L+1 Tέλος_επανάληψης …………… Συνάρτηση Fun(Β, Δ) : Ακέραια Μεταβλητές Ακέραιες: Β, Δ Αρχή Fun ← (B + Δ) DIV 2 Tέλος_συνάρτησης Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών L, A, X, όπως αυτές εκτυπώνονται σε κάθε επανάληψη, όταν για είσοδο δώσουμε την τιμή 10. Μονάδες 20

Απάντηση: Οι τιμές των που παίρνουν οι μεταβλητές του προγράμματος και της συνάρτησης «Fun» (όταν αυτή εκτελείται) φαίνονται στον πίνακα που ακολουθεί: Άρα οι τιμές που θα τυπωθούν είναι οι παρακάτω:

Αρχικά 1η επανάληψη 2η επανάληψη 3η επανάληψη 4η επανάληψη

Βασικό πρόγραμμα K L A X 10 2 1 3 3 1 4 5 6 5 7 9 6 9 6

Συνάρτηση Fun Β Δ Fun 1

2

1

7

5

6

Εμφανιζεται

2,1,1 3,3,6 4,5,9 5,7,6

ΘΕΜΑ 3 Δίνεται πίνακας Α[Ν] ακέραιων και θετικών αριθμών, καθώς και πίνακας Β[Ν-1] πραγματικών και θετικών αριθμών. Να γραφεί αλγόριθμος, ο οποίος να ελέγχει αν κάθε στοιχείο Β[i] είναι ο μέσος όρος των στοιχείων Α[i] και Α[i+1], δηλαδή αν Β[i] = (Α[i] + Α[i+1])/2. Σε περίπτωση που ισχύει, τότε να εμφανίζεται το μήνυμα «Ο πίνακας Β είναι ο τρέχων μέσος του Α», διαφορετικά να εμφανίζεται το μήνυμα «Ο πίνακας Β δεν είναι ο τρέχων μέσος του Α». Για παράδειγμα:

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Έστω ότι τα στοιχεία του πίνακα Α είναι: 1, 3, 5, 10, 15 και ότι τα στοιχεία του πίνακα Β είναι: 2, 4, 7.5, 12.5. Τό��ε ο αλγόριθμος θα εμφανίσει το μήνυμα «Ο πίνακας Β είναι ο τρέχων μέσος του Α», διότι 2 = (1+3)/2, 4=(3+5)/2, 7.5= (5+10)/2, 12.5=(10+15)/2. Μονάδες 20 Απάντηση: Αλγόριθμος Θέμα_3 Δεδομένα // Α, Β, Ν // Ι1 ΜΕΣΟΣ  αληθής Όσο ( ( Ι<=Ν-1 ) ΚΑΙ ( ΜΕΣΟΣ = αληθής ) ) επανάλαβε Αν Β[ Ι ]=( Α[ Ι ]+Α[ Ι+1 ] ) / 2 τότε Ι  Ι+1 Αλλιώς ΜΕΣΟΣ  ψευδής Τέλος_αν Τέλος επανάληψης Αν ΜΕΣΟΣ = αληθής τότε Εμφάνισε "Ο πίνακας Β είναι ο τρέχων μέσος του Α" Αλλιώς Εμφάνισε "Ο πίνακας Β δεν είναι ο τρέχων μέσος του Α" Τέλος_αν Τέλος Θέμα_3

ΘΕΜΑ 4 Σ’ ένα διαγωνισμό συμμετέχουν 100 υποψήφιοι. Κάθε υποψήφιος διαγωνίζεται σε 50 ερωτήσεις πολλαπλής επιλογής. Να αναπτύξετε αλγόριθμο που να κάνει τα παρακάτω: α. Να καταχωρεί σε πίνακα AΠ[100,50] τα αποτελέσματα των απαντήσεων του κάθε υποψηφίου σε κάθε ερώτηση. Κάθε καταχώρηση μπορεί να είναι μόνο μία από τις παρακάτω: i. Σ αν είναι σωστή η Απάντηση ii. Λ αν είναι λανθασμένη η Απάντηση και iii. Ξ αν ο υποψήφιος δεν απάντησε. iv. Να γίνεται έλεγχος των δεδομένων εισόδου. Μονάδες 4 β. Να βρίσκει και να τυπώνει τους αριθμούς των ερωτήσεων που παρουσιάζουν το μεγαλύτερο βαθμό δυσκολίας, δηλαδή έχουν το μικρότερο πλήθος σωστών απαντήσεων. Μονάδες 10 γ. Αν κάθε Σ βαθμολογείται με 2 μονάδες, κάθε Λ με -1 μονάδα και κάθε Ξ με 0 μονάδες τότε i. Να δημιουργεί ένα μονοδιάστατο πίνακα ΒΑΘ[100], κάθε στοιχείο του οποίου θα περιέχει αντίστοιχα τη συνολική βαθμολογία ενός υποψηφίου. Μονάδες 4 ii. Να τυπώνει το πλήθος των υποψηφίων που συγκέντρωσαν βαθμολογία μεγαλύτερη από 50. Μονάδες 2

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Απάντηση: Αλγόριθμος Θέμα_4 Για Ι από 1 μέχρι 100 Για J από 1 μέχρι 50 Αρχή_Επανάληψης Διάβασε ΑΠ[ I, J ] Μέχρις_Ότου ((ΑΠ[ I, J ]="Σ") Ή (ΑΠ[ I, J ]="Λ") Ή (ΑΠ[ I, J ]="Ξ")) Τέλος_Επανάληψης Τέλος_Επανάληψης Για J από 1 μέχρι 50 ΠΛΗΘΟΣ[ J ]  0 Για Ι από 1 μέχρι 100 Αν ΑΠ[ I, J ] = "Σ" τότε ΠΛΗΘΟΣ[ J ]  ΠΛΗΘΟΣ[ J ] + 1 Τέλος_Αν Τέλος_Επανάληψης Τέλος_Επανάληψης MIN  ΠΛΗΘΟΣ[ 1 ] Για J από 2 μέχρι 50 Αν ΠΛΗΘΟΣ[ J ] < ΜΙΝ τότε ΜΙΝ  ΠΛΗΘΟΣ[ J ] Τέλος_Αν Τέλος_Επανάληψης Για J από 1 μέχρι 50 Αν ΠΛΗΘΟΣ[ J ] = ΜΙΝ τότε Εκτύπωσε J Τέλος_Αν Τέλος_Επανάληψης ΠΛΗΘ  0 Για Ι από 1 μέχρι 100 ΒΑΘ[ Ι ]  0 Για J από 1 μέχρι 50 Αν ΑΠ[ I, J ] = "Σ" τότε ΒΑΘ[ Ι ]  ΒΑΘ[ Ι ] + 2 Αλλιώς_Αν ΑΠ[ I, J ] = "Λ" ΒΑΘ[ Ι ]  ΒΑΘ[ Ι ] - 1 Τέλος_Αν Τέλος_Επανάληψης Αν ΒΑΘ[ Ι ] > 50 τότε ΠΛΗΘ  ΠΛΗΘ + 1 Τέλος_Αν Τέλος_Επανάληψης Εκτύπωσε ΠΛΗΘ Τέλος Θέμα_4

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 2004 ΘΕΜΑ 1 Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασµένη. 1.

Ένα πρόγραµµα σε γλώσσα µηχανής είναι µια ακολουθία δυαδικών ψηφίων.

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

2.

Ο µεταγλωττιστής δέχεται στην είσοδό του ένα πρόγραµµα γραµµένο σε µια γλώσσα υψηλού επιπέδου και παράγει ένα ισοδύναµο πρόγραµµα σε γλώσσα µηχανής.

3.

Το πηγαίο πρόγραµµα εκτελείται από τον υπολογιστή χωρίς µεταγλώττιση.

4.

Ο διερµηνευτής διαβάζει µία προς µία τις εντολές του πηγαίου προγράµµατος και για κάθε µια εκτελεί αµέσως µια ισοδύναµη ακολουθία εντολών µηχανής.

5.

Ένα πρόγραµµα σε γλώσσα µηχανής χρειάζεται µεταγλώττιση. Μονάδες 10

Απάντηση: 1Σ

2Σ

3Λ

4Σ

5Λ

Β. Να γράψετε στο τετράδιό σας τους αριθµούς της Στήλης Α και δίπλα τα γράµµατα της Στήλης Β που αντιστοιχούν σωστά (Να σηµειωθεί ότι στις Εντολές της Στήλης Α αντιστοιχούν περισσότερες από µία Προτάσεις της Στήλης Β). Μονάδες 8 Στήλη Α Εντολές 1. Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης 2. Αρχή_επανάληψης εντολές Μέχρις_ότου συνθήκη

α.

β.

γ. δ.

Απάντηση: 1 β Γ.

2α

Ο βρόχος επανάληψης τερµατίζεται, όταν η συνθήκη είναι ψευδής Ο βρόχος επανάληψης εκτελείται οπωσδήποτε µία φορά Ο βρόχος επανάληψης είναι δυνατό να µην εκτελεστεί

2γ

∆ίδονται οι τιµές των µεταβλητών Α=5, Β=7 και Γ=–3. Να χαρακτηρίσετε στο τετράδιό σας κάθε έκφραση που ακολουθεί µε το γράµµα Α, αν είναι αληθής, ή µε το γράµµα Ψ, αν είναι ψευδής. 1. ΟΧΙ (Α+Β< 10) 2. (Α >= Β) Η (Γ < Β) 3. ((Α > Β) ΚΑΙ (Γ < Α)) Η (Γ > 5) 4. (ΟΧΙ (Α <> Β)) ΚΑΙ (Β + Γ <> 2*Α) Μονάδες 4

Απάντηση: 1Α ∆.

1δ

Στήλη Β Προτάσεις Ο βρόχος επανάληψης τερµατίζεται, όταν η συνθήκη είναι αληθής

2Α

3Ψ

4Ψ

∆ίνεται η παρακάτω εντολή : Για i από τ1 µέχρι τ2 µε_βήµα β εντολή1 Τέλος_επανάληψης Να γράψετε στο τετράδιό σας πόσες φορές εκτελείται η εντολή1 για κάθε έναν από τους παρακάτω συνδυασµούς των τιµών των µεταβλητών τ1, τ2 και β. 1. τ1=5 τ2=0 β =–2 2. τ1=5 τ2=1 β =2 3. τ1=5 τ2=5 β =1 4. τ1=5 τ2=6,5 β =0,5 Μονάδες 4

Απάντηση:

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

13 Ε.

20

31

44

Να αναφέρετε δύο µειονεκτήµατα της χρήσης των πινάκων. Μονάδες 4

Απάντηση: -Οι πίνακες απαιτούν μνήμη. Κάθε πίνακας δεσμεύει από την αρχή του προγράμματος πολλές θέσεις μνήμης. Σε ένα μεγάλο και σύνθετο πρόγραμμα η άσκοπη χρήση μεγάλων πινάκων μπορεί να οδηγήσει ακόμη και σε αδυναμία εκτέλεσης του προγράμματος. -Οι πίνακες περιορίζουν τις δυνατότητες του προγράμματος. Αυτό γιατί οι πίνακες είναι στατικές δομές και το μέγεθος τους πρέπει να δηλώνεται στην αρχή του προγράμματος, ενώ παραμένει υποχρεωτικά σταθερό κατά την εκτέλεση του προγράμματος. ΣΤ.1. Να αναφέρετε τέσσερα πλεονεκτήµατα του τµηµατικού προγραµµατισµού. Μονάδες 4 2. Να αναπτύξετε δύο από τα παραπάνω πλεονεκτήµατα του τµηµατικού προγραµµατισµού. Μονάδες 6 Απάντηση: Απαιτεί λιγότερο χρόνο και προσπάθεια στη συγγραφή του προγράμματος. Πολύ συχνά χρειάζεται η ίδια λειτουργία σε διαφορετικά σημεία ενός προγράμματος. Από τη στιγμή που ένα υποπρόγραμμα έχει γραφεί, μπορεί το ίδιο να καλείται από πολλά σημεία του προγράμματος. Έτσι μειώνονται το μέγεθος του προγράμματος, ο χρόνος που απαιτείται για τη συγγραφή του και οι πιθανότητες λάθους, ενώ ταυτόχρονα το πρόγραμμα γίνεται πιο εύληπτο και κατανοητό. Διευκολύνει την ανάπτυξη του αλγορίθμου και του αντιστοίχου προγράμματος. Επιτρέπει την εξέταση και την επίλυση απλών προβλημάτων και όχι στην αντιμετώπιση του συνολικού προβλήματος. Με τη σταδιακή επίλυση των υποπροβλημάτων και τη δημιουργία των αντιστοίχων υποπρογραμμάτων τελικά επιλύεται το συνολικό πρόβλημα. Διευκολύνει την κατανόηση και διόρθωση του προγράμματος. Επεκτείνει τις δυνατότητες των γλωσσών προγραμματισμού. ΘΕΜΑ 2 ∆ίνεται ο µονοδιάστατος πίνακας C µε έξι στοιχεία που έχουν αντίστοιχα τις παρακάτω τιµές: 2, 5, 15, –1, 32, 14 και το παρακάτω τµήµα αλγορίθµου: min  100 max  –100 Για i από 1 µέχρι 6 µε_βήµα 2 Α C[i] B C[i+1] Αν A<Β τότε Lmin A Lmax B αλλιώς Lmin Β Lmax Α Τέλος_αν Αν Lmin<min τότε min Lmin Τέλος _αν Αν Lmax>max τότε max Lmax

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Τέλος_αν Εκτύπωσε Α, Β, Lmin, Lmax, min, max Τέλος_επανάληψης D max*min Εκτύπωσε D Να εκτελέσετε το παραπάνω τµήµα αλγορίθµου και να γράψετε στο τετράδιό σας: α. Τις τιµές των µεταβλητών Α, Β, Lmin, Lmax, min και max, όπως αυτές εκτυπώνονται σε κάθε επανάληψη. Μονάδες 18 β. Την τιµή της µεταβλητής D που εκτυπώνεται. Μονάδες 2 Απάντηση: Οι τιμές των μεταβλητών κατά την εκτέλεση του προγράμματος είναι i A B min max Lmin Lmax Αρχικά 100 -100 1η 1 2 5 2 5 2 5 2η 3 15 -1 -1 15 -1 15 3η 5 32 14 -1 32 14 32

D

Εμφανιζ. 2,5,2,5,2,5 15,-1,-1,15,-1,15 32,14,14,32,-1,32

-32

-32

Άρα οι τιμές που θα τυπωθούν είναι: Στην 1η …,Στην 2η …., Στην 3η ….., Στο τέλος…

ΘΕΜΑ 3 Μία εταιρεία ταχυδροµικών υπηρεσιών εφαρµόζει για τα έξοδα αποστολής ταχυδροµικών επιστολών εσωτερικού και εξωτερικού, χρέωση σύµφωνα µε τον παρακάτω πίνακα: Χρέ ωση ε σωτε ρικ ού σε Ευ ρώ

Χρέ ωση ε ξ ωτε ρικ ού σε Ευ ρώ

2

4,8

άνω των 500 έως και 1000

3,5

7,2

άνω των 1000 έως και 2000

4,6

11,5

Βάρος ε πιστολής σε γραµ µ άρια από 0 έως και 500

Για παράδειγµα τα έξοδα αποστολής µιας επιστολής βάρους 800 γραµµαρίων και προορισµού εσωτερικού είναι 3,5 Ευρώ. Να γράψετε αλγόριθµο ο οποίος: α. Να διαβάζει το βάρος της επιστολής.

Μονάδες 3

β. Να διαβάζει τον προορισµό της επιστολής. Η τιµή "ΕΣ" δηλώνει προορισµό εσωτερικού και η τιµή "ΕΞ" δηλώνει προορισµό εξωτερικού. Μονάδες 3 γ. Να υπολογίζει τα έξοδα αποστολής ανάλογα µε τον προορισµό και το βάρος της επιστολής. Μονάδες 11

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

δ. Να εκτυπώνει τα έξοδα αποστολής. Μονάδες 3 Σημείωση: Θεωρείστε ότι ο αλγόριθµος δέχεται τιµές για το βάρος µεταξύ του 0 και του 2000 και για τον προορισµό µόνο τις τιµές "ΕΣ" και "ΕΞ". Απάντηση: Αλγόριθμος Θέμα_3 Εμφάνισε "Δώσε το βάρος της επιστολής" Διάβασε Β Εμφάνισε "Δώσε προορισμό ΕΣ για εσωτερικό, ΕΞ για εξωτερικό" Διάβασε ΠΡ Αν ΠΡ="ΕΣ" τότε Αν Β<=500 τότε ΧΡ2 Αλλιώς_αν Β<=1000 τότε ΧΡ3,5 Αλλιώς ΧΡ4,6 Τέλος_αν Αλλιώς Αν Β<=500 τότε ΧΡ4,8 Αλλιώς_αν Β<=1000 τότε ΧΡ7,2 Αλλιώς ΧΡ11,5 Τέλος_αν Τέλος_αν Εκτύπωσε "Τα έξοδα αποστολής είναι: ", ΧΡ Τέλος Θέμα_3 ΘΕΜΑ 4 Για την πρώτη φάση της Ολυµπιάδας Πληροφορικής δήλωσαν συµµετοχή 500 µαθητές. Οι µαθητές διαγωνίζονται σε τρεις γραπτές εξετάσεις και βαθµολογούνται µε ακέραιους βαθµούς στη βαθµολογική κλίµακα από 0 έως και 100. Να γράψετε αλγόριθµο ο οποίος: α. Να διαβάζει τα ονόµατα των µαθητών και να τα αποθηκεύει σε µονοδιάστατο πίνακα. Μονάδες 2 β. Να διαβάζει τους τρεις βαθµούς που έλαβε κάθε µαθητής και να τους αποθηκεύει σε δισδιάστατο πίνακα. Μονάδες 2 γ. Να υπολογίζει το µέσο όρο των βαθµών του κάθε µαθητή. Μονάδες 4 δ. Να εκτυπώνει τα ονόµατα των µαθητών και δίπλα τους το µέσο όρο των βαθµών τους ταξινοµηµένα µε βάση τον µέσο όρο κατά φθίνουσα σειρά. Σε περίπτωση ισοβαθµίας η σειρά ταξινόµησης των ονοµάτων να είναι αλφαβητική. Μονάδες 7 ε. Να υπολογίζει και να εκτυπώνει το πλήθος των µαθητών µε το µεγαλύτερο µέσο όρο. Μονάδες 5

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Σημείωση: Θεωρείστε ότι οι βαθµοί των µαθητών είναι µεταξύ του 0 και του 100 και ότι τα ονόµατα των µαθητών είναι γραµµένα µε µικρά γράµµατα. Απάντηση: Αλγόριθμος Θέμα_4 Για i από 1 μέχρι 500 Εμφάνισε "Δώσε όνομα: " Διάβασε Ο[i] Τέλος_επανάληψης Για i από 1 μέχρι 500 Εμφάνισε Ο[i] Για j από 1 μέχρι 3 Εμφάνισε "Μάθημα ", j Διάβασε Β[i, j] Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 500 Sum  0 Για j από 1 μέχρι 3 Sum  Sum + Β[i, j] Τέλος_επανάληψης MO[i]  Sum / 3 Τέλος_επανάληψης Για i από 2 μέχρι 500 Για j από 500 μέχρι i με_βήμα -1 Αν ΜΟ[j-1]<ΜO[j] τότε Temp2MO[j] MO[j]MO[j-1] MO[j-1]Temp2 Temp1O[j] O[j]O[j-1] O[j-1]Temp1 Αλλιώς_Αν ΜΟ[j-1]=ΜO[j] τότε Αν Ο[j-1]>O[j] τότε Temp1O[j] O[j]O[j-1] O[j-1]Temp1 Τέλος_αν Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 500 Εκτύπωσε Ο[i], " : ", MO[i] Τέλος_επανάληψης n1 max  MO[1] Για i από 2 μέχρι 500 Αν ΜΟ[i] = max τότε nn+1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε "Το πλήθος των μαθητών με το μέγιστο M.O. είναι: ", n Τέλος Θέμα_4 Για i από 1 μέχρι 10 Εμφάνισε "Δώσε τις εισπράξεις της αίθουσας", ΟΝΟΜΑ[i]

Καστούμης Γιώργος


Θέματα κα ι Λύσε ις Παν ελληνί ων Εξε τά σεων (200 4-2007 )

Για j από 1 μέχρι 12 Εμφάνισε "μήνας", j Διάβασε ΕΙΣΠΡΑΞΕΙΣ[i,j] Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 10 Sum0 Για j από 1 μέχρι 12 SumSum+ ΕΙΣΠΡΑΞΕΙΣ[i,j] Τέλος_επανάληψης ΜΟ[i]Sum / 12 Τέλος_επανάληψης minMO[1] Για i από 2 μέχρι 10 Αν ΜΟ[i] < min τότε min ΜΟ[i] Τέλος_αν Τέλος_επανάληψης Εμφάνισε min Για i από 1 μέχρι 10 Αν ΜΟ[i] = min τότε Εμφάνισε ΟΝΟΜΑ[i] Τέλος_αν Τέλος_επανάληψης Τέλος Κινηματογράφοι

Καστούμης Γιώργος


ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ ΑΕΠΠ 2004-2007