Issuu on Google+

TÉCNICAS DE PROGRAMAÇÃO

6ª AULA

TÉCNICAS DE PROGRAMAÇÃO

Tadeu Astori


6ª AULA

TÉCNICAS DE PROGRAMAÇÃO

ESTRUTURA ( CASO OU ESCOLHA )

Tadeu Astori


6ª AULA

TÉCNICAS DE PROGRAMAÇÃO

ESTRUTURA ( CASO OU ESCOLHA ) E UMA ESTRUTURA CONDICIONAL MUITO PARECIDO COM AS QUESTÕES DE MÚLTIPLA ESCOLHA, IDEAL PARA VERIFICAR VARIOS VALORES DE UMA MESMA VARIÁVEL DE FORMA MAIS SIMPLES DO QUE A ESTRUTURA (SE) ALINHADA.

Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

6ª AULA

INSTRUÇÃO ( ESCOLHA ) ESCOLHA < VARIÁVEL > CASO <EXP11>, <EXP12>, ... , <EXP1n> < AÇÕES A SEREM REALIZADA SE FOR VERDADEIRO> CASO <EXP21>, <EXP22>, ... , <EXP2n> < AÇÕES A SEREM REALIZADA SE FOR VERDADEIRO> ( ... ) OUTROCASO < AÇÕES A SEREM REALIZADA SE FOR VERDADEIRO> FIMESCOLHA OBS: PODE TER UMA OU MAIS AÇÕES A SEREM REALIZADAS Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

6ª AULA

EXEMPLO 1 “VERIFICAR QUAL NUMERO FOI DIGITADO” LEIA (NUMERO) ESCOLHA NUMERO CASO 1 ESCREVA (“FOI DIGITADO O NUMERO 1”) CASO 2 ESCREVA (“FOI DIGITADO O NUMERO 2”) CASO 3 ESCREVA (“FOI DIGITADO O NUMERO 3”) CASO 4 ESCREVA (“FOI DIGITADO O NUMERO 4”) CASO 5 ESCREVA (“FOI DIGITADO O NUMERO 5”) OUTROCASO ESCREVA (“FOI DIGITADO UM NUMERO INVALIDO”) FIMESCOLHA Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

6ª AULA

EXEMPLO 2 “VERIFICAR A CATEGORIA DO ATLETA” LEIA (IDADE) ESCOLHA IDADE CASO 5, 6, 7, 8, 9, 10 ESCREVA (“INFANTIL”) CASO 11, 12, 13, 14, 15 ESCREVA (“JUVENIL”) CASO 16, 17, 18, 19, 20 ESCREVA (“JUNIOR”) CASO 21, 22, 23, 24, 25 ESCREVA (“PROFISSIONAL”) OUTROCASO ESCREVA (“IDADE INVALIDA”) FIMESCOLHA Tadeu Astori


6ª AULA

TÉCNICAS DE PROGRAMAÇÃO

EXEMPLO 3 “SACAR DINHEIRO DO CAIXA ELETRONICO” LEIA (OPCAOSAQUE) ESCOLHA OPCAOSAQUE CASO 100 ESCREVA(“R$100,00 LIBERADO”) CASO 200 ESCREVA(“R$200,00 LIBERADO”) CASO 300 ESCREVA(“R$300,00 LIBERADO”) OUTROCASO LEIA (OUTRAOPCAO) ESCREVA(“R$”, OUTRAOPCAO, “ LIBERADO”) FIMESCOLHA

Tadeu Astori


Técnicas de Programação - Aula 6