Page 1

TÉCNICAS DE PROGRAMAÇÃO

13ª AULA

TÉCNICAS DE PROGRAMAÇÃO

Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

13ª AULA

ESTRUTURA ( PARA )

Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

13ª AULA

ESTRUTURA ( PARA ) E UMA ESTRUTURA DE CONTROLE DE REPETIÇÃO, ELA REPETE UMA INSTRUÇÃO POR UM DETERMINADO NÚMERO DE VEZES. PARA DETERMINAR-MOS A QUANTIDADE DE VEZES QUE REPETIRAR, UTILIZAMO UMA VARIÁVEL “CONTADOR”.

Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

13ª AULA

INSTRUÇÃO ( PARA )

PARA < CONTADOR > DE < INICIO > ATE < FIM > FACA < AÇÕES A SEREM REALIZADA SE FOR VERDADEIRO> FIMPARA

OBS 1: PODE TER UMA OU MAIS AÇÕES A SEREM REALIZADAS; OBS 2: SEMPRE USE UM CONTADOR PARA VERIFICAR O NUMERO DE REPETIÇÕES FEITAS E ASSIM EVITAR O LOOP INFINITO. OBS 3: <INICIO> E <FIM> PODE SER DO MAIOR PARA O MENOR OU DO MENOR PARA O MAIOR Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

13ª AULA

EXEMPLO 1 “SENHAS DE FILA DE BANCO” TAMANHOMAXIMO = 800 FILA = 1 PARA FILA DE 1 ATE TAMANHOMAXIMO FACA ESCREVA (“PRESSIONE UMA TECLA PARA PEGAR A SENHA”) LEIA (TECLA) FILA <- FILA + 1 FIMPARA Tadeu Astori


TÉCNICAS DE PROGRAMAÇÃO

13ª AULA

EXEMPLO 2 “TIRAR A MEDIA DE 4 NOTAS” MEDIA <- 0 I=1 PARA I DE 1 ATE 20 FACA LEIA(NOTA1) LEIA(NOTA2) LEIA(NOTA3) LEIA(NOTA4) MEDIA <- (NOTA1 + NOTA2 + NOTA3 + NOTA4) / 4

SE MEDIA < 6 ENTAO ESCREVAL (“REPROVADO”) SENAO ESCREVAL (“APROVADO”) FIMSE I <- I + 1 FIMPARA Tadeu Astori

Técnicas de Programação - Aula 13  

Decima-terceira aula de técnicas de programação

Read more
Read more
Similar to
Popular now
Just for you