Page 1

EPI INFO Elaborada pelo Prof. Antônio Augusto Moura da Silva Programa de Pós-Graduação em Saúde Coletiva - UFMA O Epi Info é um programa integrado desenvolvido para uso em Epidemiologia, mas se aplica também à pesquisa biomédica em geral. Reúne aplicações de banco de dados (criação, entrada e processamento), análise estatística, geração de tabelas e gráficos e possibilita ainda algumas tarefas de programação. É usado para criar e analisar questionários de protocolos de pesquisa.

Os módulos que compõem o Epi Info são:

Criar Ficha

- criação e edição de questionários. Permite criar critérios para checar erros durante a entrada de dados, permitindo a definição de restrições para a entrada de dados em campos específicos, fixação de valores mínimos e máximos a ser aceitos na digitação, codificação automática e saltos condicionais. Na versão em inglês este componente é chamado Make View.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

1


Entrar Dados

- módulo de entrada de dados a partir de um questionário criado no Criar Ficha View para um arquivo em disco. Na versão em inglês este componente é chamado Enter Data.

Analisar Dados- produz listagens, frequências, tabulações cruzadas e outros resultados. Realiza estatística descritiva (média, qui-quadrado) a partir de tabelas. Gera gráficos de barra, linha e círculo. Faz análises estatísticas de regressão linear, logística e análise de sobrevivência. Transforma dados de outros programas para uso no Epi Info. Converte dados do Epi Info para uso em outros programas de banco de dados ou estatísticos. Combina arquivos de diferentes maneiras ou atualiza registros de um arquivo usando dados de outro. Realiza análise de dados de delineamentos complexos, considerando amostragem por conglomerados (clusters), estratificação e ponderação. Na versão em inglês este componente é chamado Analyze Data. Criar Mapas

- para gerar mapas temáticos. Na versão em inglês este componente é chamado Create Maps.

Criar Relatórios –para criar programas de processamento de dados. Na versão em inglês este componente é chamado Create Reports. Site do Epi Info –para acessar a página do Epi Info na internet. Na versão em inglês este componente é chamado Epi Info Website. Sair

- para fechar o programa e retornar para o Windows. Na versão em inglês este atalho é chamado Exit.

BANCO DE DADOS: Um programa de banco de dados simula em computador o uso dos registros manuais de informações. Alguns conceitos são importantes de serem aprendidos: ARQUIVO - é o espaço aberto na memória ou no disco para armazenar as informações. Um arquivo tem um nome e uma extensão, usualmente de 3 letras. No Epi Info, o arquivo criado tem a terminação MDB, ou seja, Microsoft Database, que é o padrão do Microsoft Access para banco de dados. No Epiinfo você vai criar um arquivo MDB para cada projeto. O questionário de pesquisa é chamado de Ficha ou View. O conteúdo de uma ficha ou questionário (view) é armazenado em uma tabela (Table). Da mesma forma os dados após a digitação são armazenados em outra Tabela (Table). REGISTRO - é a informação individualizada do arquivo. Por exemplo, se eu tenho um arquivo de dados AIDS.REC, os dados de um paciente compõem 1 registro. CAMPO - são as informações separadas de cada registro. São exemplos de campos: NOME, SEXO, IDADE etc. O nome de campo é também chamado de VARIÁVEL. Um arquivo no Epi Info pode conter um número indefinido de campos e de registros.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

2


TIPOS DE CAMPOS: Os campos se dividem basicamente em dois tipos: caractere e numérico. O campo caractere serve para armazenar qualquer caractere do teclado do computador, como letras, números, os sinais + - / etc. É usado quando se quer armazenar uma informação que não precisa ser manipulada matematicamente. O campo numérico serve para armazenar números. É usado quando se deseja realizar operações matemáticas com os dados. O campo número deve ter um tamanho especificado, de acordo com o tipo de dado que se quer armazenar. O tamanho é dado pelo número de caracteres componentes. Quando do projeto de um arquivo de banco de dados, você deve prever antecipadamente qual o tamanho que terá um campo. Assim, se você pretende criar um campo númerico chamado IDADE, no qual você armazenará a idade dos pacientes em anos completos e você sabe de antemão que não haverá pacientes com mais de 99 anos, basta você criar um campo de tamanho 2 ou com 2 dígitos para caber as idades, pois estas só terão no máximo 2 algarismos. O Epi Info trabalha com vários tipos de campo. Os principais são os seguintes: Label/Title – serve para colocar um título no questionário Text- Qualquer caracter é aceito neste tipo de campo. Espaços em branco serão interpretados como "dados prejudicados" no programa de análise de dados (ANALYSIS). O tamanho da variável ou do campo será o número de caracteres de sublinha usados. Aceita até 255 caracteres. Text[Uppercase] - é bastante semelhante ao campo texto, porém aqui todas as digitações serão convertidas para letras maiúsculas. Yes/No – aceita apenas as letras Y (Yes), N (No) , espaço ou [ENTER] são aceitos. O espaço é interpretado como "dado prejudicado ou ignorado". As letras também são convertidas para maiúsculas. Number ##.# apenas números ou espaços e o ponto decimal (.) são aceitos. Se nada for digitado o resultado será considerado prejudicado (missing) e aparecerá no programa de análise de dados (Analysis) como ponto (.). O número de dígitos é indicado pelo número de "#"s. Se um ponto for colocado entre os números, você estará trabalhando com casas decimais. O exemplo acima representa um campo numérico de tamanho 4, com duas casas para a parte inteira do número, 1 casa para o ponto (em português seria vírgula mas este programa é americano) e 1 casa para o decimal. Multiline – é um campo texto que aceita mais de 255 caracteres. Date - o campo data possui diferentes formatos: formato americano formato europeu

- aceita mês/dia/ano MM-DD-YYYY ou mês/dia MM-DD - aceita dia/mês/ano DD-MM-YYYY ou dia/mês DD-MM

Você escolhe um tipo de formato por ocasião da criação do questionário. Quando da entrada de dados, as datas serão checadas para saber se são válidas. Se você escolher um formato e der entrada na data em outro formato, o programa não aceita e pede nova digitação. Você precisa digitar apenas os números das datas, o programa coloca automaticamente as barras separadoras. Time – armazena a hora em dois formatos: formato americano formato europeu

- HH:MM:SS AMPM - HH:MM:SS

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

3


PhoneNumber - armazena o número de telefone, local, por exemplo ###-#### , onde os "#"s são dígitos, ou de longa distância, armazena DDD + número do telefone, por exemplo: ###-###-####. Aceita também outros formatos. Image – campo que serve para armazenar imagens, como fotos, desenhos Grid – é um campo em formato de Tabela, utilizado para a digitação de medidas repetidas, como por exemplo, a pressão arterial em diferentes momentos. Cada coluna é como se fosse um campo independente. Cada coluna de um campo grid pode ser de quatro tipos: Text, Number, Phonenumber e Date.

ACESSO AO EPI INFO:

Localize na área de trabalho o ícone . Dê um duplo clique e aparecerá o menu principal que dá acesso aos diversos programas. O menu do Epi Info 200 é, ou seja, você pode alterar as suas características. Há 5 opções de menu, ou seja, Programas, Editar, Configurações, Utilitários e Ajuda. Você pode entrar nos módulos componentes do Epi Info ou nos itens de menu usando o mouse. No menu Ajuda, no item Conteúdo você pode acessar o manual completo do programa. Assim, por exemplo, observe que ao entrar no menu, logo após a barra de menus está escrito: Idioma=Português. Para alterar o idioma, você precisa escolher: clique no menu Configurações, em seguida, Install Language. Aparece uma tela verde com uma janela branca contendo os idiomas disponíveis. Se a sua verão não estiver instalada em português, clique em Port e em Install. Em seguida feche a janela do MS-DOS (clicando no X no canto superior direito) depois feche a janela de diálogo clicando em OK. Vamos agora alterar o idioma. Clique em Configurações, em seguida, Choose Language, depois no idioma de preferência na caixa de diálogo (Port) e clique em cima de OK. Observe que agora, logo após a barra de menus está escrito: Idioma=Português. OBS: Para os comandos acima funcionarem adequadamente, é necessário que o arquivo port.exe esteja copiado para o diretório c:\Epi_Info\TransExe. Se você não dispuser do arquivo acesse o site www.epiinfo.com.br para obtê-lo.

CRIAÇÃO DE UMA FICHA OU QUESTIONÁRIO (VIEW) NO Criar Ficha (Make View): EXERCÍCIO 1: O Epi Info utiliza o formato Microsoft DataBase ou MDB. Para cada projeto criado o programa grava um arquivo no formato .MDB. Cada questionário ou arquivo de dados é gravado em uma tabela separada (Table). Assim, cada projeto tem várias tabelas (Tables), geralmente uma Table para a Ficha - View (questionário) e uma outra Table para a base de dados. Ou seja, os dados digitados no programa Entrar Dados (Enter Data) são gravados em outra tabela dentro do arquivo do projeto. Porém um projeto pode ter mais de um questionário e mais do que uma base de dados. Na Tabela (Table) do questionáirio (View), são gravados: a tela do questionário, as características dos campos e os códigos de checagem que dão instruções especiais para a entrada de dados. Geralmente é melhor criar um novo arquivo MDB para cada projeto. Para acessar o Criar Ficha (Make View), clique no botão Criar Ficha no menu principal. Você verá uma página em branco para construir uma ficha ou questionário (View). Para criar um questionário, clique em Arquivo depois em Novo. Surgirá a caixa de diálogo Criar ou Abrir

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

4


PROJETO (Create or Open Project). Digite o nome aids para o projeto e clique em Abrir. Na caixa de diálogo Nomeie a Ficha (Name the View), digite aids e depois OK. Em seguida, vamos criar os campos ou variáveis do arquivo. Vamos inicialmente criar o título: aponte o mouse para o quadrado desejado na tela, clique no botão direito do mouse. Você vai abrir a janela de Definição de Campo (field definition), igual à que aparece na figura abaixo. Há opções para digitar a questão, tipo de campo e tamanho ou padrão e várias características de checagem de dados com a finalidade de reduzir os erros de digitação. Digite em Pergunta ou Prompt (Question or Prompt): VIGILÂNCIA EPIDEMIOLÓGICA DA AIDS MARANHÃO. Na opção Tipo (Type) de Campo ou Variável (Field or Variable), escolha Label/Title (Rótulo/Título), clicando com o mouse na seta para baixo, usando a barra de rolamento para escolher o tipo de campo. Em seguida em Tipo de letra para o prompt, escolha negrito, tamanho 14 e depois clique em OK e OK novamente para retornar para a ficha. Observe que o programa criou um campo título com o conteúdo definido para a questão. Em seguida, posicione o cursor em outra localização da tela conveniente e clique no lado direito do mouse. No item pergunta ou prompt digite NUMERO, escolha Number como tipo de campo, padrão ## e marque a opção Necessário (Required) de checagem (indicando que a digitação sempre é requerida, ou seja, este campo não poderá ser deixado em branco. Finalmente clique em OK. O Epi Info cria automaticamente os NOMES DOS CAMPOS a partir do questionário. Se você quiser você pode digitar uma frase de Pergunta ou Prompt (Question or Prompt) e escolher um campo com um menor número de caracteres. Para isto basta alterar o nome do campo na janela Nome de Campo (Field Name). Quando a questão colocada for grande, como por exemplo: Qual o seu sexo, é conveniente escolher como nome de campo apenas Sexo. Para tanto posicione o cursor em cima da palavra sexo e dê um duplo clique. Observe que no Nome de Campo (Field Name) surgirá automaticamente a palavra Sexo e desta forma sexo será escolhida como nome de campo. Agora posicione o cursor em outra localização da tela conveniente e clique no lado direito do mouse. No prompt digite SEXO, escolha Text como tipo de campo, marque a opção Necessário (Required) de checagem e clique em Valores Legais (Legal Values). Surgirá a caixa de diálogo Configurar Códigos/Valores Legais (Set Up Code/Legal Links), onde você irá informar ao programa quais os valores permitidos para o campo sexo, no caso M e F. Clique em Criar Novo (Create New). Surgirá uma nova caixa de diálogo. Digite M, seguido de Enter e depois F seguido de Enter e finalmente clique em OK. Em seguida feche a caixa de diálogo de definição de campo, clicando em OK. Clique agora no botão esquerdo do mouse na barra de rolamento à direita de sexo para observar a lista dos valores permitidos para este campo.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

5


Usando o mesmo procedimento crie as demais variáveis do arquivo, usando a tabela abaixo como guia. Padronize, digitando sempre o nome das variáveis em maiúsculas e sem acentuação. Tipo de campo Label/Title

Padrão (Pattern)

Number Text

Nome VIGILÂNCIA EPIDEMIOLÓGICA DA AIDS MARANHÃO NUMERO SEXO

Date Number Number

DATA IDADE CATEGORIA

DD-MM-YYYY ## #

Yes/No

KAPOSI

###

Checagem Necessário (Required) Valores Legais – M F (Legal values – M F) Necessário (Required) Necessário (Required) Necessário (Required) Faixa Mais baixo 1 Superior 4 (Range Lower 1 Upper 4) Necessário (Required) Necessário (Required)

Abaixo consta um exemplo dos procedimentos no caso da variável CATEGORIA.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

6


Para movimentar um campo na tela, clique no nome da variável e arraste-o para uma nova localização na tela, mantendo pressionado o botão esquerdo do mouse. Use este método para arrumar os campos na tela e se quiser, para mudar as variáveis de posição e/ou ordem. Se você quiser modificar opções ou deletar uma variável, clique com o botão direito do mouse em cima do nome da variável. Surgirá novamente a caixa de diálogo Definição de campo (Field Definition). Faça as modificações necessárias ou clique em Apagar (Delete) para apagar a variável. Quando terminar de confeccionar o questionário clique em Arquivo (File) e depois em Salvar (Save) para salvar o seu questionário. Após clique em Arquivo (File) e depois em Sair (Exit). O programa vai pedir para você confirmar a criação de uma nova tabela para entrada de dados (observe que o programa já atribui automaticamente o nome aids a esta tabela). Clique em OK para confirmar e observe que o sistema volta ao menu principal do Epi Info. As principais opções para checagem de dados são:

• • •

Faixa (Range) - definição de limites mínimo (lower) e máximo (upper) - se no campo numérico CATEGORIA, só existem as opções de 1 a 4, definiremos 1 como limite mínimo e 4 como limite máximo. Valores Legais (Legal values) - valores legais admitidos – no campo SEXO, só serão admitidas as digitações de M e F. Se se digitar N inadvertidamente, o programa não aceitará. Necessário (Required) – indicando que é obrigatória a digitação de dados naquele campo, não podendo se deixar em branco (o que o programa entende como ignorado).

EXERCÍCIO 2: Antes de criar um questionário no Criar Ficha (Make View), você deve montar a sua estrutura definindo os campos a serem utilizados, seu tipo, formato e se for um campo numérico, o seu tamanho e casas decimais.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

7


Monte, em papel, a estrutura de um questionário (protocolo de pesquisa) sobre um determinado assunto ou doença. Antes de começar, lembre-se que é preciso:

a) Definir o nome do arquivo (Projeto - Project) e da tabela do questionário (Ficha - View). b) Economizar espaço em disco. Para isto trabalhe com dados codificados, como no exemplo abaixo: Procedência - campo BAIRRO, tipo numérico, de tamanho 2 (codificado em 2 dígitos. Centro (01), Anjo da Guarda (12), Prejudicado (99) etc, ao invés de BAIRRO, tipo texto, de tamanho 30 para escrever o nome do bairro. Observe que se economiza tempo de digitação (digita-se 1 número ao invés de várias letras, reduzem-se os erros, pois é mais fácil errar ao escrever "ANJO DA GUARDA" do que 12. Prefira campos numéricos em vez de campos texto ou caractere maiúsculo sempre que possível (para o digitador é melhor trabalhar digitando apenas números, utilizando os caracteres númericos à direita do teclado - acionados apertando-se a tecla NUM LOCK - do que alternado letras e números). Não se esqueça de prever em todo campo um código para "ignorado" ou "prejudicado" (prefira os números 9, 99 ou 999). c) Defina bem as informações necessárias. Evite criar perguntas mal formuladas que geram respostas duvidosas. Evite digitar no computador dados que não serão tabulados. Dificilmente você precisa, por exemplo, trabalhar com NOME do paciente; ao invés disso, identifique cada questionário com um número. d) Use campo lógico (Yes/No) para sintomas. Observe a estrutura do questionário AIDS acima e utilize-o como modelo. Crie agora um questionário com o seu exemplo de banco de dados no Criar Ficha (Make View). Utilize a tabela de codificação e os procedimentos de checagem.

ENTRAR DADOS – Enter Data Em seguida, rode o módulo Entrar Dados (Enter Data) a partir do menu principal. Mova o mouse até Entrar Dados e dê um clique. Depois tecle em Arquivo (File) e Abrir (Open). Surgirá a caixa de diálogo Selecione o projeto (Select the project). Localize o projeto aids, clique em cima dele e depois em Abrir. Na caixa de diálogo Selecione uma tabela (Select a table) observe que já aparece selecionada a tabela Aids. Clique em OK. Aparecerá na tela o questionário da aids para digitação. Entre com os dados abaixo. Após digitar o conteúdo de cada variável, pressione [ENTER]. Depois que você completar o primeiro registro, observe que o programa passa automaticamente para o registro seguinte. Observe que, ao posicionar o cursor no campo, surgirá na parte de baixo da tela os comandos de checagem correspondentes àquele campo. No campo inferior esquerdo, em uma pequena telinha branca (janela Record), o programa mostra o número do registro corrente para digitação. NUMERO

SEXO DATA

IDADE

CATEGORIA

KAPOSI

1 2 3 4 5 6 7 8 9 10

M M M F M M M F M M

34 41 29 35 26 18 38 19 22 23

1 4 1 2 1 3 1 3 1 2

N N Y (ou S) N N N Y (ou S) Y (ou S) N N

22/10/1999 30/03/1999 23/02/1998 16/05/1999 30/06/1998 26/10/2000 03/03/1999 28/06/2000 27/08/1998 30/11/2000

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

8


A codificação utilizada no campo SEXO foi M = masculino, F = feminino, I = ignorado; no campo GRUPO foi 1 = homossexual, 2 = heterossexual, 3 = usuários de drogas injetáveis e 4 = hemofílicos.

COMANDOS DO MÓDULO Enter Data No canto inferior esquerdo da tela, abaixo da janela Registro (Record), há quatro botões com setas, para você se movimentar dentro do banco de dados. A seta retorna para o

«

primeiro registro. A seta a seta

< volta para o registro anterior. A seta > vai para o registro seguinte e

»

vai para o último registro do arquivo. Há ainda botões na parte esquerda da tela que executam tarefas específicas. Se você quiser criar um novo registro utilize o botão Novo (New). Se quiser salvar os dados utilize o botão Salvar Dados (Save). Se quiser procurar por algum registro específico use Encontar (Find). Ao clicar no botão Encontrar (Find) surgirá uma janela com todos os campos do arquivo. Se você quiser localizar os registros com categoria igual a 1, por exemplo, clique em Categoria, digite 1 na janela menor e clique em OK. Surgirão abaixo todos os registros da categoria 1. Se desejar você pode editar e modificar os dados nesta janela e para finalizar clique em Retornar. Se desejar você pode modificar as opções do campo Yes/No, transformando Yes em Sim e No em Não. Para isto, clique no menu Options. Surgirá a janela de diálogo Setting for Yes/No Fields. Onde consta Represente Sim como (Represent Yes as): digite Sim e Não como (No as) digite Não. Depois tecle em OK. Observe que todos os dados do campo lógico estão agora categorizados em Sim e Não. Observe que o programa ENTER usou o seu questionário ou ficha (view) Aids para construir os nomes de variáveis (campos), os tipos de campos e o tamanho das entradas automaticamente. Após isto, o Enter Data apresenta o questionário no monitor de vídeo e espera pela entrada de dados.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

9


Quando você entra dados: campos numéricos (#) só aceitam números, se você tentar digitar letras surgirá um aviso de erro. Se você estiver utilizando a opção Faixa (Range), ele só aceitará números no intervalo definido previamente no Criar Ficha (Make View). Por exemplo, se você tentar digitar o número 5 no campo CATEGORIA, o programa não aceitará, pois você definiu como Faixa (Range) de 1 a 4. Se você estiver trabalhando com a opção Necessário (Required), o cursor só se moverá para o próximo campo depois que você digitar dados. Se não estiver usando Necessário (Required), teclando [ENTER] você criará uma entrada em branco, significando valores ignorados; quando o campo estiver totalmente preenchido, você precisará teclar [ENTER] para mover o cursor para o próximo campo; erros na entrada de dados são avisados por um sinal sonoro podendo ser corrigidos e o número do registro corrente é mostrado no canto inferior esquerdo do vídeo. Pressionando o botão Marcar Registro como Apagado (Mark Record as Deleted) em qualquer ponto de um registro, você marca o registro como DELETADO (apagado). Ele continua fisicamente visível no programa Enter Data, mas não será considerado no processamento do programa Analisar Dados (Analyze Data), pois este registro deletado é pulado. Observe que ao marcar um registro como Deletado, o botão Marcar Registro como Apagado (Mark Record as Deleted) se transforma no botão Recuperar (Undelete). Um registro marcado como deletado pode ser recuperado pressionando-se novamente o botão Recuperar (Undelete) em qualquer ponto do registro. Este botão Marcar Registro como Apagado (Mark Record as Deleted) / Recuperar (Undelete) alterna deleção e recuperação.

MÓDULO DE ANALISAR DADOS – ANALYZE DATA: O módulo ANALYSIS produz listagens, frequências, tabelas e estatísticas e gráficos dos arquivos. Para acessar este módulo, no menu principal clique em Analisar Dados (Analyze Data). Surgirá na tela uma janela igual a da figura abaixo:

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

10


Você observa três janelas, uma à esquerda, a janela de comandos, e duas à direita, uma grande acima, a janela de resultados e uma menor abaixo, a janela de edição de programas, na qual os comandos selecionados são exibidos e onde você pode também digitar os comandos no modo prompt. Na janela da esquerda, você escolherá os comandos, na maior da direita os resultados dos comandos aparecerão e na menor da direita o comando completo é reproduzido. Os principais comandos deste modo serão descritos a seguir com exemplos:

PRIMEIRO PASSO - LENDO UM ARQUIVO: Abrir (Importar) ou Read (Import) - lê ou abre o arquivo (tabela) a ser analisado. Vamos abrir o arquivo AIDS, que você digitou anteriormente. Na janela de comandos, item Dados, clique em Abrir (Importar) ou Read (Import). Surgirá uma caixa de diálogo do comando. Clique no botão --- Origem dos Dados (Change Project). Clique em cima do projeto aids.MDB e depois em Abrir. Na janela Fichas (Views) clique em viewaids e a seguir em OK. Aparece então uma nova janela de diálogo de criação de link temporário. Clique novamente em OK. Pronto, o programa abriu o arquivo e mostra os dados abaixo, indicando que o programa abriu a tabela viewaids que está no projeto aids.MDB que está no diretório Epi_Info no disco C. E demonstra ainda que o arquivo tem 10 registros e que os registros apagados foram excluídos.

Epi Info Ficha Atual: C:\Epi_Info\aids.MDB:viewaids Conta de registros 10 (Registros apagados excluidos) Data: 22/10/2006 09:59:02

VISUALIZAÇÃO DOS DADOS: Listar (List)

- produz uma listagem dos dados. Este comando mostrará apenas as variáveis que couberem na largura da tela. Na janela de comandos, item Estatísticas, clique em

*

Listar (List). Surgirá a janela list. Observe no campo Variáveis (Variables) que consta um (indicando todas as variáveis). Clique em OK para o programa listar todas as variáveis. Se você quiser obter a listagem de uma variável específica, tecle na barra de rolamento de Variáveis (Variables) e escolha a(s) variável(is) desejada(s). Observe que as variáveis vão sendo copiadas para a janela de baixo. À medida que os resultados aparecem na janela superior, aqueles dados que rolaram para fora da vista no alto da tela podem ser vistos de novo, utilizando-se a barra de rolamento da janela de resultados. Use a barra de rolamento da janela de resultados se necessário para visualizar os resultados de qualquer comando. Neste exemplo, como o arquivo só tem 10 registros, todos cabem na tela e não será necessário fazer a rolagem. Observe que além das variáveis do arquivo aparecem ainda duas outras variáveis do programa: UniqueKey, que armaneza o número do registro e RecStatus, que informa se o registro está gravado (código 1) ou não.

GERANDO FREQUÊNCIAS E TABULAÇÕES CRUZADAS: Frequencias (Freq)

- produz uma distribuição de frequência do campo especificado. Na janela de comandos no item Estatística (Statistics) clique em Frequencias (FREQuencies). Surgirá a caixa de diálogo FREQ. Clique na barra de rolamento do item Frequencia de (Frequency of) e escolha a variável desejada, no caso Categoria. Observe que a variável é colada para a janela de baixo. Clique em OK. A tela que surge, é semelhante à apresentada abaixo. Observe que aparece a freqüência absoluta, a freqüência relativa (percentagem), a

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

11


freqüência relativa (percentagem) acumulada e um gráfico de barras. Abaixo da tabela o programa calcula o intervalo de confiança de 95% para cada categoria da variável. Veja, por exemplo, que para o item 1 (homossexual masculino) o limite inferior do intervalo é 18.7% e o superior 81.3%. Neste caso, os intervalos são largos porque a amostra é pequena (apenas 10 observações).

Outra forma alternativa de obter um comando é digitar na janela de comandos: FREQ CATEGORIA e, em seguida, clicar no botão Executar este comando (Run This Command). Usando FREQ *, o Epi Info fará a distribuição de frequência de todas as variáveis contidas no arquivo. Agora tente usar FREQ * e em seguida obtenha freqüências de outras variáveis do arquivo.

TABLES - faz tabelas de cruzamento do campo 1 com o campo 2 e fornece uma estatística sumária, incluindo qui-quadrado. O odds ratio (razão de chances) e o risk ratio (risco relativo) que aparecem são estatísticas usadas em epidemiologia em estudos de coorte e caso-controle, que podem se aplicar também à pesquisa biomédica. Vamos obter uma tabela do sexo de acordo com a categoria de exposição. No item Estatística clique em Tabelas (Tables). Surgirá a caixa de diálogo TABLES. Na barra de rolamento Variável de Exposição (Exposure Variable) escolha Categoria e na barra de rolamento Variável de Saída (Outcome Variable) escolha Sexo. Finalmente clique em OK. Surgirá uma tela como a de baixo. Procure agora interpretar o significado da tabela. Observe que existem 3 linhas de informação para cada categoria da variável. No caso, na primeira linha aparece a freqüência absoluta, na Segunda linha o percentual relativo à linha (Linha % - Row %) e na terceira linha o percentual relativo à coluna (Col %).

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

12


Você pode também fazer tabelas de 3 ou mais campos. Experimente. Clique em Tabelas (Tables), e na barra de rolamento Variável de Exposição (Exposure Variable) escolha Categoria. Na barra de rolamento Variável de Saída (Outcome Variable) escolha Sexo e na barra de rolamento Estratificado por (Stratify by) escolha Kaposi. Finalmente clique em Ok. Observe que surgirão duas tabelas estratificadas segundo a ocorrência ou não de Sarcoma de Kaposi. Na primeira consta uma tabela de Sexo e Categoria para as pessoas que tinham Sarcoma de Kaposi e na Segunda uma tabela de Sexo e Categoria para quem não tinha Sarcoma de Kaposi. Ou alternativamente digite na janela de comandos:

TABLES Sexo Categoria STRATAVAR= Kaposi E finalmente, sem teclar Enter, tecle no botão Executar este comando (Run This Command).

USANDO O BANCO DE DADOS DE NOTIFICAÇÃO DE AIDS: Abra agora o arquivo AIDSMA, que armazena dados de notificação de aids no Estado do Maranhão. Neste arquivo constam notificações de casos adultos e pediátricos até meados de 1998. Na janela de comandos clique em Abrir (Importar) ou Read (Import). Surgirá uma caixa de diálogo do comando. Clique no botão Origem dos Dados (Change Project). Clique em cima do projeto aidsma.MDB e depois em Abrir. Na janela Fichas (Views) clique em viewaids e a seguir em OK. Depois clique novamente em OK para criar um link temporário e abrir o arquivo. O arquivo AIDSMA possui os campos SEXO, ID, ESCOLAR, ANO, OBITO, EXP, MUNIC. Clique em Listar (List) na janela de comandos para ver as variáveis contidas no arquivo AIDSMA. Surgirá a janela LISTAR (LIST). Observe no campo Variáveis (Variables) que

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

13


consta um variáveis.

*

(indicando todas as variáveis). Clique em OK para o programa listar todas as

O diagrama de codificação para estas variáveis consta na tabela abaixo: SEXO

Sexo do paciente

ID ESCOLAR

Idade em anos completos (varia de 0 a 77) Escolaridade

ANO OBITO

Ano de início dos sintomas Ocorrência de óbito

EXP

Categoria de exposição

MUNIC

Município de residência

1=masculino 2=feminino 00=menor de 1 ano 99=idade ignorada 1=analfabeto 2=1o. grau – 1a. à 4a.série 3=1o. grau – 5a. à 8a.série 4=2o. grau 5=superior 9=ignorado 85 a 98 0=não 1=sim 9=ignorado 1=homossexual 2=bissexual 3=heterossexual 4=usuário de drogas E.V. 5=hemofílico 6=receptor de sangue/comp. 8=perinatal 9=não definida/ignorada 1=São Luís 2=Imperatriz 3=Timon 4=Caxias 5=Pedreiras 6=S.J.Ribamar 7=Bacabal 8=Santa Inês 0=outros

Observe as variáveis ID, que armazena a idade em anos completos (há idade 0 no caso de menores de 1 ano em 4 pacientes), SEXO (1 =masculino, 2=feminino), OBITO (1 = morto e 0 = vivo). Peça a distribuição de freqüência do sexo. Na janela de comandos no item Estatísticas (Statistics) clique em Frequencias (FREQuencies). Surgirá a caixa de diálogo FREQ. Clique na barra de rolamento do item Frequencia de (Frequency of) e escolha a variável desejada, no caso Sexo. Observe que a variável é colada para a janela de baixo. Clique em OK. Ou alternativamente digite na janela de comandos: FREQUENCIAS SEXO (FREQ SEXO) E finalmente, sem teclar Enter, tecle no botão Executar este comando (Run This Command). Observe que a informação está codificada, sendo que 1 = masculino e 2 = feminino. Peça também a freqüência dos campos ANO e OBITO e anote a letalidade por aids no Maranhão. Observe também a distribuição de notificações segundo ano dos primeiros sintomas.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

14


Médias (Means) – obtém estatística descritiva de variáveis numéricas (média, mediana, moda, desvio padrão, percentis). No caso de campos numéricos podemos usar o comando Médias (Means) para obter uma estatística descritiva. Por exemplo, peça a estatística descritiva do campo IDADE. Na janela de comandos, item Estatísticas, clique em Médias (Means). Na caixa de diálogo Médias (Means) clique na barra de rolamento Médias de (Means of) em ID e a seguir em OK. Surgirá ao final a tela abaixo.

O Epi Info mostrará na tela a distribuição de frequência da idade à época dos primeiros sintomas. Abaixo ele mostra a média de idade dos casos (Mean = 32,9988). Esta não é a média verdadeira de idade dos pacientes, porque existe o código 99 para representar idade desconhecida. Para se calcular a média é necessário usarmos um comando que só vai processar os dados de idade quando esta for diferente de 99. Trata-se do comando Selecionar (Select).

Selecionar (Select)

– Seleciona alguns registros segundo critério definido para processamento. Na janela de comandos, item Selecionar/Se clique em Selecionar (Select). Na caixa de diálogo Selecionar (Select) digite na janela SELECIONAR CRITÉRIOS (Select Criteria) : ID <> 99 (Idade diferente de 99) e a seguir em OK. Surgirá ao final a tela abaixo.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

15


Ou alternativamente digite na janela de comandos: SELECIONAR ID<>99 (SELECT ID<>99) Observe na segunda linha da tela que surge após Selecionar (Select): a modalidade da seleção feita, no caso ID<>99. Repita o comando anterior para calcular a média de idade dos pacientes: MEDIAS ID (MEANS ID) O Epi Info mostrará na tela a distribuição de frequência da idade dos pacientes, desta vez excluindo os casos com idade ignorada. Abaixo ele mostra a média de idade dos pacientes (Mean = 32,92). Observe que o resultado é praticamente o mesmo, pois só havia 1 paciente com idade desconhecida.

Obs 848 Mínimo 0.0000

Total 27917.0000 25% 27.0000

Média 32.9210 Mediana 32.0000

Variancia 96.9229 75% 38.0000

Desvio padrão 9.8449 Máximo Moda 77.0000 31.0000

Precisamos desfazer o comando select, para voltar a processar os registros que tiverem idade ignorada. Na janela de comandos clique em Selecionar (Select) e a seguir em OK. O programa desfaz a seleção anterior. SELECIONAR (SELECT) Peça uma tabela de SEXO e OBITO e verifique se a taxa de letalidade da aids foi diferente nos dois sexos. TABELAS SEXO OBITO (TABLES SEXO OBITO)

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

16


COMANDOS AVANÇADOS: SELECT, DEFINE E RECODE: Selecionar (Select) - seleciona um subconjunto de dados segundo um atributo. Vamos selecionar para análise apenas as pessoas do sexo masculino SELECIONAR SEXO=1 (SELECT SEXO=1) Observe na segunda linha da tela que surge após da seleção feita, no caso SEXO = 1. Repita o comando:

Selecionar (Select): a modalidade

FREQUENCIAS SEXO (FREQ SEXO) Observe que agora só foram processados os registros do sexo masculino (1). Desfaça a seleção digitando: SELECIONAR (SELECT)

Definir (Define)

- cria novas variáveis. Funciona do mesmo modo como a criação de variáveis no Criar Ficha (Make View). Vamos criar uma nova variável, IDADE, para recodificar as idades em 3 grupos: 0 a 12 anos, 13 a 49 anos e 50 anos e mais. Na janela de comandos, item Variáveis, clique em Definir (Define). Na janela Nome da Variável (Variable name) digite: IDADE e a seguir clique em OK Ou alternativamente digite na janela de comandos: DEFINIR IDADE (DEFINE IDADE)

Recodificar (Recode)

- recodifica os dados para processamento. O campo ID será recodificado para o campo IDADE, da seguinte forma. Na janela de comandos, item Variáveis, clique em Recodificar (Recode). Surgirá a caixa de diálogo Recodificar (RECODE). Na barra de rolamento De (From) escolha a variável ID e na barra de rolamento Para (To) escolha a nova variável IDADE. Na primeira coluna Valor (Value) digite 0 e tecle Enter. Na segunda coluna Até Valor (To Value) digite 12 e em seguida Enter. Na coluna Valor Recodificado (Recoded Value) digite 0A12. Preencha o restante da mesma forma, conforme a figura abaixo e para terminar clique em OK.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

17


Peça agora uma listagem dos campos ID e IDADE para ver como se processou a recodificação. LISTAR ID IDADE (LIST ID IDADE)

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

18


Faça agora uma freqüência do campo IDADE recodificado e observe o resultado. Observe que o caso com idade ignorada não entrou na recodificação. FREQUENCIAS IDADE (FREQ IDADE)

Peça agora uma tabela cruzando IDADE e OBITO. TABELAS IDADE OBITO (TABLES IDADE OBITO) Em qual grupo de idade a letalidade da aids foi maior ? Verifique através da tabulação de IDADE com ANO, se houve variação na idade dos pacientes, segundo ano dos primeiros sintomas. TABELAS IDADE ANO (TABLES IDADE ANO)

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

19


GRAVAR NOVO ARQUIVO: Os comandos Definir (Define) e Recodificar (Recode) trabalham na memória. Se você sair do programa e voltar você perderá a nova variável IDADE. Para gravar um novo arquivo, incluindo as variáveis recodificadas é necessário usar o comando Escrever (Exportar) ou Write (Export). Na janela de comandos, item Dados, clique em Escrever (Exportar). Você pode gravar todas as variáveis do arquivo (opção Todas - All) ou escolher apenas algumas variáveis para colocar no arquivo novo. Há duas opções para este comando em Modo Saída (Output Mode): você pode escolher Anexar (Append) (continua a gravação no arquivo existente) ou Substituir (Replace) (grava por cima, apagando o arquivo anterior). No caso escolha Substituir (Replace). Na janela Nome do arquivo (File Name) digite: aidsma2. Na janela Tabela de dados (Tables) digite: aidsma2. Depois clique em OK.

Abra o novo arquivo (AIDSMA2) e verifique que a variável IDADE agora faz também parte do arquivo. Ordenar (Sort) - ordena o conjunto dos dados segundo um atributo. Vamos ordenar os dados do arquivo pela idade dos pacientes. Clique em Ordenar (Sort), no item Selecionar/Se na janela de comandos. Na caixa de diálogo Ordenar (Sort) dê um duplo clique em cima da variável ID. Há três opções de ordenação: ascendente (ascending - ordem crescente), descendente (descending - ordem decrescente) e remover ordenamento (remove from sort), para desfazer a ordenação. Deixe habilitada a opção ascendente (ascending). Em seguida clique em OK.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

20


Peça a seguir uma listagem do campo ID para ver o resultado do comando Ordenar (Sort). LISTAR ID (LIST ID) Rota de Saída (ROUTEOUT) – muda o nome do arquivo HTM para onde é dirigida a saída dos dados. O Epiinfo vem programado para dar saída aos dados em formato HTM (o formato gráfico da Internet) em um arquivo de nome OUT, seguido de um número (1,2,3 etc) atribuídos em seqüência. Você pode alterar isto utilizando o comando Rota de Saída (ROUTEOUT) no item Saída da janela de comandos. Na janela de comandos escolha Rota de Saída (RouteOut). Se necessário use a barra de rolamento da janela de comandos. Na caixa de diálogo em nome do arquivo digite: aidsma e em seguida clique em OK. Se quiser, você também pode marcar a opção Substituir qualquer arquivo existente (Replace), para gravar por cima.

DESENHANDO GRÁFICOS DE BARRAS, LINHAS E CÍRCULO: Gráficos (GRAPH) – o comando Gráficos (Graph) é usado para desenhar gráficos. Como exemplo, vamos fazer um gráfico com a variável Escolar, do tipo Barra. Na janela de comandos, item Estatísticas, escolha Gráficos (Graph). Na caixa de diálogo Gráficos (Graph) em Tipo de Gráfico (Graph Type) escolha Barra (Bar). Digite o título para o gráfico em 1st Title: Aids segundo escolaridade, Maranhão, 1985 a 1998. Em X-Axis (Eixo X), Variável Principal escolha Escolar. Na opções de Y-Axis (Eixo Y) digite em Show Value of (Mostrar Valor de): Count % Em seguida clique em OK.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

21


Você vai obter o gráfico abaixo:

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

22


Agora clique em cima de ESCOLAR. Abrirá a Escolaridade e clique em OK. Depois clique em cima de Axis Label. Digite: % e clique em OK. Em seguida clique descrição correspondente. Por exemplo, clique em cima de Label. Digite: Analfabeto e clique em OK.

janela Enter X-Axis Label. Digite: PERCENT. Abrirá a janela Enter Yem cima de cada código e digite a 1. Abrirá a janela Enter X-Data Point

Usando os conhecimentos adquiridos faça um gráfico do tipo Torta (Pie) da variável SEXO. Em seguida faça um histograma (histogram) com a variável ID. E, finalmente um gráfico de Linha (Line) com a variável ID. Explore as opções do Menu dentro do Epi Graph. Clique em Menu e surgirão as opções Arquivo, Editar, Visualizações e Ajuda. No menu Arquivo (File) você pode salvar o gráfico atual, exportá-lo para outro programa ou imprimi-lo. No menu Editar (Edit) você pode copiar o gráfico para a área de trabalho do Windows (Clipboard). Se quiser depois você pode abrir o seu processador de texto e colar o gráfico no seu documento para compor o seu relatório. No menu Visualizações (View) você poderá mudar o tipo de gráfico e modificar várias opções do mesmo como, por exemplo, o título, legenda, fazê-lo tridimensional, alterar a fonte, o fundo ou rotacionálo. Experimente algumas destas opções.

CONFECÇÃO DE PROGRAMAS: Um programa é um arquivo criado no módulo Analisar Dados (Analyze Data), contendo os mesmos comandos já apresentados e digitados via teclado ou menu de comandos. Se você quiser, ao invés de dar entrada nos comandos para processamento do arquivo AIDSMA pelo teclado, você pode usar o Editor de Programas e criar o arquivo de comandos abaixo. Ou, alternativamente, ir executando os comandos via menu. Observe que, à medida que você vai executando cada comando, ele vai sendo copiado para o editor de programas. Ao final, clique no Botão Salvar (Save), para salvar o programa. Na caixa de diálogo Salvar (Save), clique primeiro no botão Mudar Projeto (Change Project). Clique em aidsma.mdb e depois no botão Salvar. Na opção Programa (Program) digite: aidsma. Depois clique em OK. READ 'C:\Epi_Info\aidsma.MDB':viewAIDSMA LINKNAME=TMPLNK_1 ROUTEOUT 'aidsma' REPLACE FREQ SEXO MEANS ID SELECT ID <> 99 MEANS ID SELECT TABLES SEXO OBITO SELECT SEXO = "1" FREQ SEXO SELECT DEFINE IDADE RECODE ID TO IDADE 0 - 12 = "0A12" 13 - 49 = "13A49" 50 - 77 = "50A77" END LIST ID IDADE GRIDTABLE FREQ IDADE TABLES IDADE OBITO TABLES IDADE ANO Depois que o programa estiver salvo, clique no Botão: Executar PGM (Run) e os comandos serão realizados em bloco da mesma forma como se tivessem sido digitados pelo teclado ou chamados pelo menu. PGM é abreviatura de Programa.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

23


EXERCÍCIOS DE PROGRAMAÇÃO COM O ARQUIVO AIDSMA EXERCÍCIO 1: 1. Recodifique a variável SEX- transforme SEXO em SEX, sendo 1 = MASC e 2 = FEM 2. Peça a distribuição de freqüência dos casos de aids segundo sexo 3. Em qual dos sexos houve predomínio da doença ?

EXERCÍCIO 2: 1. MORTE- transforme OBITO em MORTE, tornando 1 = SIM e 0 = NAO. Não recodifique o 9. 2. Peça a distribuição de freqüência dos casos de aids segundo letalidade 3. Qual a letalidade da aids ?

EXERCÍCIO 3: 1. Transforme a variável EXP na variável CATEGORIA, substituindo os códigos pelos itens correspondentes. Exemplo: 1=HOMO 2. Peça a distribuição de freqüência dos casos de aids segundo categoria de exposição detalhada. 3. Quais as três categoria de exposição com maior freqüência relativa ? 4. Transforme a variável EXP em CATEG, considerando transmissão sexual, sanguínea e perinatal. Não recodifique os ignorados. 5. Peça a distribuição de freqüência dos casos de aids segundo categoria de exposição simplificada. 6. Em qual categoria de exposição ocorreu maior número de casos

EXERCÍCIO 4: 1. Transfome ID em GRUPID2, considerando 0A9, 10A19, 20A29, 30A39, 40A49, 50+ 2. Peça a distribuição de freqüência dos casos de aids segundo idade agrupada em 6 categorias 3. Qual a faixa etária de maior predomínio dos casos ?

EXERCÍCIO 5: 1. Peça a distribuição de freqüência dos casos de aids segundo ano dos primeiros sintomas 2. Recodifique a variável ANO em PERIODO, da seguinte forma: agrupe 85A90, 91A95 e 96A98. 3. Peça a distribuição de freqüência dos casos de aids por período. 4. Em qual período ocorreu maior percentual dos casos ?

EXERCÍCIO 6: 1. Recodifique ESCOLAR em ESCOLA, substituindo os códigos numéricos pela descrição correspondente. Exemplo: 1=ANALF 2. Peça a distribuição de freqüência dos casos de aids segundo escolaridade 3. Qual a escolaridade onde houve o maior número de casos ?

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

24


EXERCÍCIO 7: 1. Transforme MUNIC em LOCAL, substituindo os códigos numéricos para os municípios pela descrição correspondente. Exemplo: 1=SL 2. Peça a distribuição de freqüência dos casos de aids segundo município de ocorrência 3. Quais os dois municípios com maior número de notificações ?

Para responder aos exercícios seguintes, você necessita pedir TABLES de algumas variáveis:

EXERCÍCIO 8: 1. Houve alteração na razão M/F, considerando-se os três períodos em análise? 2. Houve alteração nas categorias de exposição, comparando-se os três períodos de análise (85A90, 91A95 e 96A98) ?

EXERCÍCIO 9: 1. Houve alteração na distribuição por idade dos casos, comparando-se os três períodos de análise (85A90, 91A95 e 96A98) ? 2. Houve alteração nas categorias de exposição (considerando-se 3 categorias), comparandose os três períodos de análise (85A90, 91A95 e 96A98) ?

EXERCÍCIO 10: 1. Houve alteração em relação à escolaridade dos casos, comparando-se os três períodos de análise (85A90, 91A95 e 96A98) ? 2. Houve alteração da letalidade por aids, comparando-se os três períodos de análise (85A90, 91A95 e 96A98) ?

Ao final do exercício salve todos os comandos em um programa e chame-o aids. Em seguida execute-o e verifique se não contém erros. Caso haja erros você pode deletar linhas de comando, modificá-las e salvar novamente o arquivo.

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

25


EXERCÍCIO COM O BANCO DE DADOS DO ESTUDO DE FRAMINGHAM Importando arquivos do Epiinfo 6 No diretório Epi_Info há um arquivo DCOR.REC, no formato do Epiinfo 6. Este arquivo armazena as variáveis do estudo “FRAMINGHAM HEART STUDY”, realizado nos Estados Unidos que acompanhou por 18 anos a população da cidade de FRAMINGHAM, para estudar os fatores de risco para doença coronariana, realizando exames periódicos de 2/2 anos. Para importar este arquivo para o Epi Info para Windows, clique em Abrir/Importar (Read/Import) na janela de comandos. Surgirá uma caixa de diálogo do comando. Clique no botão ↓ em Formato do Banco de Dados (Data Formats) e escolha o formato Epi6. Use a caixa de diálogo --- em Origem dos Dados para se dirigir ao diretório Epi_Info e localize e clique em cima do arquivo DCOR.REC e depois em Abrir. Finalmente clique em OK. Pronto o arquivo está convertido para o Epiinfo para Windows. Agora você poderá salvá-lo no novo formato no diretório Epi_Info, com o nome dcor.mdb, usando o comando Escrever/Exportar (Write/Export). Peça Listar (List) e observe o formato do arquivo Dcor.mdb. Em seguida, faça os exercícios abaixo e ao final salve o programa Dcor, para processá-lo no final da aula. SEX

Sexo do paciente

1=masculino 0=feminino 0=não teve 1=estava doente no 1o. exame 2 a 10= número do exame em que foi feito o diagnóstico

CHD

Diagnóstico de doença coronariana

AGE SBP CHOL CIG DEATH

Idade em anos ao exame inicial Pressão arterial sistólica em mmHg Colesterol sérico em mg/100 ml Número de cigarros fumados por dia 0=não é fumante Óbito 0=vivo 2-10= número do exame em que já estava morto

EXERCÍCIO 1: 1. Calcule a média do colesterol sérico nesta população 2. Crie a variável COL, para recodificar o nível de colesterol sérico em 3 classes: menor de 220, de 220 a 259 e 260 e mais 3. Peça a distribuição de freqüência da variável COL 4. Qual o percentual de pessoas com colesterol sérico maior ou igual a 260 mg/100 ml

EXERCÍCIO 2: 1. Calcule a média da pressão arterial sistólica nesta população 2. Crie a variável PAS - para recodificar a pressão arterial sistólica em 3 classes: menor de 140, de 140 a 164 e 165 e mais 3. Peça a distribuição de freqüência da variável PAS. 4. Qual o percentual de pessoas com pressão arterial sistólica maior ou igual a 165 mmHg ?

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

26


EXERCÍCIO 3: 1. Crie a variável IDADE - para recodificar as idades em 4 classes: 45 a 49, 50 a 54, 55 a 59 e de 60 a 62 2. Peça a distribuição de freqüência da variável IDADE.

EXERCÍCIO 4: 1. Crie a variável PDC - para recodificar CHD em 0 (doença coronariana ausente) e 1 (doença coronariana presente) – casos prevalentes ao exame inicial 2. Crie a variável IDC - para recodificar CHD em 0 (doença coronariana ausente) e 2 a 10 (doença coronariana presente) – casos incidentes, descartando os casos com valor 1, prevalentes ao exame inicial 3. Peça a distribuição de freqüência das variáveis PDC e IDC. 4. Qual a prevalência de Doença Coronariana ? 5. Qual a incidência da Doença Coronariana ?

EXERCÍCIO 5: 1. Crie a variável FUMO - para recodificar CIG em 0 (não fumante) e 1 (fumante) 2. Peça a distribuição de freqüência da variável FUMO 3. Qual a prevalência do fumo nesta população ?

EXERCÍCIO 6: 1. Crie a variável OBITO - para recodificar DEATH em 0 (vivo) e 1 (morto) 2. Peça a distribuição de freqüência da variável ÓBITO 3. Qual a taxa de mortalidade nesta população (%)

Para responder às perguntas seguintes, você necessita pedir TABLES de algumas variáveis: EXERCÍCIO 7: 1. Qual a incidência de doença coronariana no sexo masculino e no sexo feminino ? 2. Qual a incidência de doença coronariana nas três classes de pressão arterial sistólica ?

EXERCÍCIO 8: 1. Qual a incidência de doença coronariana nas três classes de colesterol sérico ? 2. Qual a incidência de doença coronariana de acordo com o fumo ?

EXERCÍCIO 9: 1. Os indivíduos com doença coronariana tiveram uma média de colesterol sérico maior, comparados aos demais ? 2. Os indivíduos com doença coronariana tiveram uma média de pressão arterial sistólica maior, comparados aos demais ?

EXERCÍCIO 10: 1. Qual o risco relativo do fumo em relação à doença coronariana ? O intervalo de confiança inclui o 1 ? 2. Qual o risco relativo de desenvolver doença coronariana dentre aqueles que têm colesterol de 260 e mais, comparados aos que têm colesterol abaixo de 220 ?

Apostila Epi Info – Programa de Pós-Graduação em Saúde Coletiva - UFMA

27

Apostila de Epiinfo  

apostila de epiinfo

Read more
Read more
Similar to
Popular now
Just for you