Issuu on Google+

CONSULTAS Y RELACIONES EN ACCESS. 1. CONSULTAS. 1.1 DEFINICION. Una consulta recupera informaciones de la Base de Datos y eventualmente las presenta en la pantalla. Serán estudiados tres tipos de consultas: 

De selección: selecciona y presenta registros en formato patrón

De referencias cruzadas: selecciona y presenta registros en formato de planilla

De acción: altera el contenido de registros en una única operación

Los registros seleccionados constituyen un conjunto. Este conjunto es dinámico en el sentido de que su contenido tiene por origen varias tablas y con el sentido de solo existir mientras la consulta esté activa. Al cerrar una consulta, el conjunto de registros deja de existir. Esto constituye una gran ventaja pues si alteramos los datos de una tabla las consultas sobre ella automáticamente reflejarán esas alteraciones. 1.2 GENERAR UNA NUEVA CONSULTA. La obtención de una nueva consulta es hecha a partir de la ventana Base de Datos, seleccionando Consultas y picando en la opción Nuevo. En respuesta aparecerá un cuadro de diálogo que le permite a Ud. elegir el modo de cómo, la consulta, debe ser construida. O Ud. mismo monta la consulta a través del modo Vista Diseño o Ud. utiliza los Asistentes, que facilitan el montaje tanto de consultas como de informes, formularios, etc. 1.3 ADICIONAR CAMPOS A LA CONSULTA. Inicialmente se debe seleccionar los campos en la tabla. Se Puede seleccionar varios campos picando y apretando simultáneamente SHISFT o CTRL. Enseguida, apuntar para alguno de los campos seleccionados y arrastrarlo para la línea Campo: en el área inferior. Para adicionar todos los campos de la tabla a la planilla QBE es necesario inicialmente seleccionar todos los campos. Hay un atajo para esta tarea: basta picar dos veces en la barra de título de la tabla. Otro método consiste en el arrastre de la línea de asterisco (*) de la tabla para algún campo de la parte inferior. Mientras tanto, en este caso él arrastra toda la tabla y produce un efecto secundario interesante: en caso que la tabla vaya a ser alterada en su estructura, por adición/exclusión de campos, no será necesario rehacer la consulta. Por otro lado, campos QBE basados en asterisco no admiten criterio de clasificación y selección. Para insertar un campo entre otros ya existentes en la planilla QBE basta arrastrar un campo seleccionado, en la parte superior, para el campo que quedará a la derecha del campo insertado. Para reordenar campos en la planilla QBE basta seleccionar y arrastrar para otra posición. Para


eliminar un campo, basta seleccionar y dar DEL. Para remover todos los campos de la planilla use la opción Borrar cuadrícula del menú Edición. 1.4 GRABAR E IMPRIMIR CONSULTAS. Para grabar la consulta, use las opciones Guardar y Guardar como o Exportar del menú Archivo. Para imprimir la consulta debemos estar en la hoja de datos y accionar Vista preliminar para ver el layout de la hoja a ser impresa. La opción Imprimir del menú Archivo realiza la impresión permitiendo eventualmente imprimir apenas los registros seleccionados en la hoja de datos. Para eso, basta elegir la opción Registro Seleccionados como Intervalo de Impresión. 2. RELACIONES. Es común que informaciones de una tabla estén asociadas con informaciones de otras tablas. En este caso podemos establecer una relación entre las dos tablas. Es a través de la relación que el Access consigue, a partir de informaciones en una tabla, obtener informaciones registradas en la otra tabla. Existen tres tipos de relaciones entre dos tablas A y B: uno – a – uno, uno – a – varios, varios – a – varios. 2.1 RELACIONES UNO A UNO. La relación uno a uno ocurre cuando un registro de la tabla A posee como máximo un registro asociado en la tabla B y un registro de la tabla B posee como máximo un registro asociado en la tabla A. Esta relación está presente en el número de gerente/número de empleado, entre el PADRÓN DE DEPARTAMENTOS y el PADRÓN DE EMPLEADOS. Para cada número de gerente identificamos apenas un registro en el PADRÓN DE EMPLEADOS y cada funcionario es eventualmente gerente de apenas un departamento. 2.2 RELACIONES UNO A VARIOS. La relación uno a varios ocurre cuando un registro de la tabla A puede tener mas de un registro asociado en la tabla B, mientras que, un registro de la tabla B posee como máximo un registro asociado en la tabla A. Esta relación está presente en la sigla del departamento entre el PADRÓN DE DEPARTAMENTO y el PADRÓN DE EMPLEADOS. Para cada sigla del PADRÓN DE DEPARTAMENTOS identificamos varios registros con esta sigla en el PADRÓN DE EMPLEADOS, mientras que, para cada sigla en el PADRÓN DE EMPLEADOS identificamos como máximo un registro en el PADRÓN DE DEPARTAMENTOS. También debe quedar claro que, en principio, podemos tener departamentos sin funcionarios y funcionarios que momentáneamente no están asignados a ningún departamento. 2.3 RELACION VARIOS A VARIOS.


La relación varios a varios ocurre cuando un registro de la tabla A puede tener más de un registro asociado en la tabla B y, análogamente, un registro en la tabla B puede tener más de un registro asociado en la tabla A. Los cargos ocupados por un empleado a lo largo del tiempo constituyen una relación de esta naturaleza. Cada empleado ocupó varios cargos y un cargo fue ocupado por diversos empleados. En esta relación queda inmediatamente aparente que al par empleado/cargo probablemente estarán asociadas otras informaciones, por ejemplo, la fecha en que el empleado asumió el cargo en cuestión. Relaciones de este tipo varios a varios no pueden ser especificadas directamente en Access. Es necesario la creación de una tabla intermediaria que en nuestro caso podría tener el nombre: cargos ocupados. Cada registro en esta tabla sería compuesto de tres campos: Número de empleado, Código del cargo y Fecha de admisión a este cargo. Como se observa, se creó una relación uno a varios entre el PADRÓN DE EMPLEADOS y el PADRÓN DE CARGOS OCUPADOS y, análogamente, otra relación uno a mucho entre el PADRÓN DE CARGOS Y SALARIOS y el PADRÓN DE CARGOS OCUPADOS. Por lo tanto una relación varios a varios es convertida en dos relaciones una a varios cuando hubiera informaciones asociadas a los pares relacionados. 2.4 CREACION DE LAS RELACIONES. En Access podemos crear relaciones localizadas, utilizadas en una consulta específica, o relaciones globales que posiblemente tendrán un uso más general. Relaciones de uso localizado serán vistas más adelante en el capítulo referente a consultas. Las Relaciones de uso general son útiles porque pueden ser usadas automáticamente en nuevas consultas, facilitan la generación de subformularios y subinformes y permiten un cierto grado de protección en operaciones de actualización al imponerse la integridad referencial para las relaciones como será visto más adelante.


Consultas y Relacines en Access