Issuu on Google+

Algoritmos y Diagramas de Flujo de la Materia Metodología de la Programación Realizar un algoritmo para realizar una suma

Datos de entrada celda principal A1 y celda final A3

1.- Analizar la fórmula de suma

2.- Verificar si está bien escrita la fórmula de suma

2.1.- Si es errónea mostrar #¡VALOR

2.2 Si es correcta va a paso 3

3.- Verificar si A1 es numérico

3.1.- Si un valor no es numérico omitirlo

4.- Verificar si A2 es numérico

4.1.- Si un valor no es numérico omitirlo

5.- Verificar si A3 es numérico

5.1.- Si un valor no es numérico omitirlo


6.-Sumar los valores no omitidos

7.-Mostrar valores

INICIO

INTRODUCIR VALORES DE CELDA A1 a A3

VALIDAR FORMULA T

#ยกVALOR

F =SUMA(A1:A3)

MOSTRAR RESUTADOS

FIN


Hacer un algoritmo que al capturar una calificación válida muestre error reprobado o aprobado según corresponda

1.-Dame la calificación

2.-Verificar si la calificación es valida

2.1.-Si la calificación es >10 ó <0

2.1.2.-Cumple, Marcar error, vuelve al paso 1

2.2.2 No cumple, continua

3.-Verificar si la calificación es aprobatoria o no aprobatoria

4.-Si la calificación está dentro del rango 7-10

4.1.-Cumple, Marcar aprobado, continua paso 5

4.2.-Si no cumple, marcar reprobado

6.-Fin


INICIO

DAME UNA CALIFICACIÓN

SI LA CALIFICACIÓN ES >10 ó <0 F

“ERROR”

T SI CALIFICACION >=7 Y <=10

F

T APROBADO

REPROBADO

FIN


Algoritmos y diagramas de flujo de la materia metodología de la programación