Page 1

Algoritmo de los registros que podria sacar un HOTEL /*********************************************************/ /* Programa: registro_de_un_hotel */ /* */ /* Descripción: hacer un algoritmo en el cual se pueda */ /* Ingresar todos los nombres, los géneros que sea */ /* Necesario y sacar tanto su suma como su costo en días*/ /* de hospedaje */ /* */ /* Autor: Orlando gamboa */ /* */ /* Fecha: 01/06/2011 */ /********************************************************/ /* Cabecera */ algoritmo Proceso registro

Escribir "BIENVENIDOSAL HOTELSANTANA"; Escribir "---------------------------------------------------------------"; contador<-1; contadorgenm<-0; contadorgenf<-0; contadordiast<-0; contadornochest<-0; contadortotalpersonas<-0; contadortatalprecio<-0; preciopordia<-30000; Repetir Escribir "HOLA APRECIADOCLIENTE,PORFAVORDIGITESUNOMBRE"; Leer nombre; Escribir "por favor escriba su sexo,f si es usted una mujer y m si usted es hombre "; Leer genero; Escribir "el sexo del cliente es:",genero; Si genero='m' Entonces contadorgenm<-contadorgenm+1; Sino contadorgenf<-contadorgenf+1; FinSi Escribir "escriba los dias que usted ",nombre," se quedara en el hotel"; Leer DIAS; Escribir "los dias que el cliente se quedara en este hotel son:",DIAS; Escribir "digite el numero de NOCHESque usted se hospedara en nuestro hotel: ";


Leer NOCHES; Escribir "las noches que el cliente se quedara en este hotel son:",NOCHES; escribir 'deseacontinuar? (S/N)?' leer resp; Hasta que resp='n' o resp='N' contadordiast<-contadordiast+dias; contadornochest<-contadornochest+noches; contador<-contador+1; Escribir 'Numero de Mujeres: ',contadorgenf; Escribir 'Numero de Hombres: ',contadorgenm; Escribir 'Numero de Dias: ',contadordiast; Escribir 'Numero de Noches: ',contadornochest; contadortotalpersonas<-contadorgenm + contadorgenf; Escribir "Numero total de personas hospedadasen el hotel:",contadortotalpersonas; presiopordia<-preciopordia*contadortotalpersonas; Escribir "total a pagar por los huespedesdel hotel:",presiopordia; FinProceso

algoritmo del hotel  

se realizo un algoritmo para un listado de registros

algoritmo del hotel  

se realizo un algoritmo para un listado de registros

Advertisement