Issuu on Google+

Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

Estructura Repetitiva Mientras El proceso de una estructura repetitiva Mientras es el siguiente: para que ingrese al cuerpo del bucle tiene que evaluarse una condición, si ésta es verdadera se ingresa y se realizan todas las instrucciones que están dentro del cuerpo del bucle; terminado la última instrucción se vuelve a comprobar la condición; se seguirá realizando el bucle mientras la condición siga siendo verdadera y si en un momento es falsa sale del bucle. Es decir, la estructura repetitiva Mientras es aquella en que el cuerpo del bucle se repite mientras se cumpla una determinada condición, y termina cuando ya no se cumple. Si al querer ingresar al cuerpo del bucle por primera vez y la condición es falsa, no ingresa al bucle, ninguna acción se realiza y el algoritmo prosigue en la siguiente instrucción fuera del bucle. La representación gráfica de la estructura repetitiva Mientras es la siguiente:

Figura 55. Diagrama de Flujo de la estructura repetitiva Mientras

Figura 56. Diagrama Estructurado de la estructura repetitiva Mientras

1


Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

mientras (condición) hacer instrucción 1 instrucción 2 . . instrucción n fin_mientras Figura 57. Pseudocódigo de la estructura repetitiva Mientras

A continuación se presenta el siguiente ejemplo para comprender el funcionamiento de la estructura repetitiva Mientras. Ejemplo 8: Escribir un algoritmo que lea las 40 notas finales del curso de Fundamentos de Programación, e informe cuántos alumnos han aprobado y cuántos desaprobaron. Dato: (Nota >= 10.5 Aprobado)

Figura 58. Diagrama de Flujo del ejemplo 8

2


Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

Figura 59. Diagrama estructurado del ejemplo 8

algoritmo Ejemplo8 var entero: c, ca, cd real: notaFinal inicio c=0 ca = 0 cd = 0 mientras ( c < 40 ) hacer c=c+1 leer (notaFinal) si (notaFinal >= 10.5) entonces ca = ca + 1 sino cd = cd + 1 fin_si fin_mientras escribir(‘Aprobados : ’,ca) escribir(‘Desaprobados : ’,cd) fin Figura 60. Pseudocódigo del ejemplo 8

3


Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

Ejemplo 9: Realizar un algoritmo que permita calcular la suma de los números enteros comprendidos entre dos cantidades ingresadas por teclado. Hallar adicionalmente el promedio de la suma.

Figura 61. Diagrama de Flujo del ejemplo 9

4


Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

Figura 62. Diagrama estructurado del ejemplo 9

algoritmo Ejemplo9 var entero: Pnum, Snum, c, suma, aux real: prom inicio leer( Pnum , Snum ) c =0 suma = 0 si (Pnum>Snum) entonces aux = Pnum Pnum = Snum Snum = aux fin_si mientras ( Pnum <= Snum ) hacer c=c+1 suma = suma + Pnum Pnum = Pnum + 1 fin_mientras prom = suma / c escribir(‘La suma es : ’,suma) escribir(‘El promedio es : ’,prom) fin Figura 63. Pseudocódigo del ejemplo 9

5


Estructura Repetitiva While