Issuu on Google+

Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

Estructura Selectiva Doble La estructura selectiva doble permite elegir entre dos opciones o alternativas, en función del cumplimiento de una determinada condición, de tal forma que, si se cumple, se ejecutan las acciones del primer bloque; si no se cumple, se ejecutan las acciones del segundo bloque. La representación gráfica de una estructura selectiva doble en los métodos para representar a los algoritmos es el siguiente:

Figura 19. Diagrama de flujo de la estructura selectiva doble

Figura 20. Diagrama estructurado de la estructura selectiva doble

si condición entonces instrucción 1 instrucción 2 . . instrucción n si_no instrucción 1 instrucción 2 . . instrucción m fin_si Figura 21. Pseudocódigo de la estructura selectiva doble

De acuerdo a la condición podemos realizar actividades por el lado verdadero o por el lado falso, PERO NUNCA se realizan las actividades de ambos lados al mismo tiempo.

1


Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

Ahora pondremos en práctica los nuevos conocimientos adquiridos solucionando el siguiente ejemplo: Ejemplo 3: Realizar un algoritmo que lea dos números enteros distintos entre sí y mostrar por pantalla el mayor y el menor. Al final del algoritmo mostrar también el nombre del creador del algoritmo.

Figura 22. Diagrama de flujo del ejemplo 3

Figura 23. Diagrama estructurado del ejemplo 3

2


Universidad los Ángeles de Chimbote Facultad de Ingeniería Escuela Profesional de Ingeniería de Sistemas

Asignatura: Fundamentos de Programación

algoritmo Ejemplo3 var entero : num1, num2 inicio leer (num1, num2) si (num1 > num2) entonces escribir(‘El mayor es’, num1, ‘y el menor es’, num2) si_no escribir(‘El mayor es’, num2, ‘y el menor es’, num1) fin_si escribir(‘Mi nombre es Maverick’) fin Figura 24. Pseudocódigo del ejemplo 3

Ejemplo de autoaprendizaje: Resuelva en diagrama de flujo, estructurado y pseudocódigo. Ejemplo 4: Realizar un algoritmo que permita el ingreso de tres notas de un alumno. Calcular la nota promedio y si el promedio es mayor o igual a 10.5 mostrar un mensaje “Aprobado” o “Desaprobado”.

3


Estructura Selectiva Doble