Issuu on Google+

arcon visual architecture

2D to 3D professional CAD Software

The complete solution for all your building design requirements

ARCON ARCON Self-builder Developer Edition Edition

ARCON Architect Edition

ARCON Architect + Renderer

The ideal tool for

Increased flexibility

Our most advanced

The full Architect

2D plans & 3D

& scalable projects

toolset for all your

edition plus enhanced

models for home

allow for larger

needs including

rendering for

renovations or a

designs including

complex domestic &

professional quality

self-build project

multiple properties

commercial designs

3D visualisations


What is ARCON Visual Architecture? Easy-to-use 2D & 3D CAD Applications for Architects, Building Professionals, Self-builders & Home Improvers Eleco Software provide CAD applications dedicated to designing building exteriors and interiors. Detailed plans can be rapidly drawn and cross-sections and side elevations can be generated automatically on screen. By utilising a simpleto-use interface with dedicated tools for each part of a design, users can plan out and see their ideas in full 3D simply by drawing a 2D plan. This is what makes ARCON software the perfect choice if you are new to CAD or want something to compliment your existing CAD software. Created for use by professionals, but quickly adopted by the self-build market, ARCON Visual Architecture has since been discovered by many other users over the years. The simplicity and speed with which plans can be created makes it the ideal tool for planning and visualising projects including self-builds, extensions, loft conversions, renovations and all aspects of a building project. Due to ARCON's success as one of the leading 2D/3D home design applications, it continues to be demonstrated at the major self-build and home improvement shows including Homebuilding and Renovating Show, UK’s number one self-build show.

Which Edition Should I Choose? Following many years experience in bringing 2D & 3D CAD software to the market, we have been able to identify our main user groups and their particular needs. In the latest range of ARCON software we have therefore been able to tailor the toolset to the specific requirements of each user group. These user groups are reflected clearly by the new naming convention we have chosen for this latest range, which should help you to easily identify the edition which suits your needs. A full explanation of the key features of each version is explained in detail on the individual pages in this brochure and an in-depth full feature list and comparison is available at the end.

Key features of all ARCON Visual Architecture Editions

Create professional drawings ideal for planning applications With fast and accurate drawing tools, creating scaled floor plans, elevations and cross-sections is one of the key strengths of the ARCON system. All plans and elevations are produced to scale with flexible control over scale, paper size and measurement units. All of our ARCON home design software packages also come complete with our built-in Creative Lines package. This provides even greater control of your layouts, enabling you to produce single pages containing multiple views and floor plans. Ideal for planning applications, floor plan presentations to clients or service information for each trade. 2

Used by architects & building professionals worldwide For over 15 years, ARCON has been the choice home design software system for thousands of building professionals, architects and self-builders. Working closely with our users we continue to develop and support our ARCON system to ensure it can be adapted to even the most demanding design project.


Easy to use interface for planning and design The modular toolset enables us to provide tools and icons for specific elements of the design in a logical manner. Easily identifiable, each tool will guide you through a particular part of the design process and will be familiar to anyone having used Windows based software. Each tool can be customised and adapted to your preferred drawing style with full flexible options, easily accessed at any time.

Drag & drop or numeric input methods Everyone has their preferred working methods and styles and so in ARCON we reflect this by providing multiple methods for achieving construction tasks. Use simple drag & drop to insert objects, point and click to place walls or use numeric input methods to enter dimensions such as wall lengths.

No CAD knowledge required One of the main advantages of the ARCON system over a traditional CAD system is the use of a modular toolset. Designed specifically for building design we have been able to create an intuitive set of modules to guide you logically through the design process. This means it's simple for anyone to learn, both experienced professionals and novice amateurs embarking on their first self-build project.

2D plans to 3D models in a single click Creating realistic 3D models for visualisation couldn't be simpler. Draw your floor plans in a traditional 2D plan view and your 3D model is created automatically at the same time. With a single mouse click or key press you can then enter the 3D mode to view your design, modify finishes and fittings and take a virtual tour of your building.

Automatic and manual dimensions tools 2D plans and elevations in ARCON are always drawn to scale (which you have full control over) and accordingly there are many ways of displaying important dimensions and measurements. Set automatic dimensions to display as you draw, choose from many styles of dimension line to add manually, use height point dimensions on elevations and cross-sections, easily add room areas and volumes and even angle dimensions.

Create estates and multibuilding developments With the ability to create multiple buildings per project file, ARCON is flexible enough to enable you to design entire developments and plan estates. Easily save a design and load multiple copies into your project to create a complete development. Use the independent railing tool to manually add rails around decks, walkways or gallery landings.

Metric and imperial measurement units Unlike similar systems, ARCON is created to cater for either metric or imperial measurement units. Define your preferred units for each project whether it's metres, millimetres or feet and inches. Even swap from metric and imperial and back again at anytime. With the same control over scale and the ability to include or exclude interior furnishings and objects. Combined with the architectural mode display, crosssections will show detailed wall construction detailing. With cross-sections in place, toggle into design mode to display the cross-section in 3D.

Produce simple or complex roof designs

Powerful measuring and ruler tools

For simple roof constructions you can select from any of the standard roof types in the library and simply drag and drop into position and amend pitch etc. as required. Alternatively use the free form roof editor to create complex roof designs for more unusual shaped buildings. Easily edit the roof settings from pitch and eaves height right through to wood construction details. Then modify the roof easily with dedicated tools for dormer windows and skylights.

For simple design ideas, drawings in ARCON can easily be created freehand. However for the majority of projects you will need to know that your plans are accurate. ARCON software contains many tools to ensure that your drawing elements are spaced and aligned correctly. With powerful guidelines, rulers, origins, grids and measures you can be certain that your plans will be correct every time.

Customisable wall construction types, including cavity walls Walls come complete with a number of standard settings in the library. These wall settings can be completely customised to change the library or create your own for future projects. Walls can be completely customised right down to specifying each individual layer of a wall. This makes the walls tool easily able to cater for cavity walls, sips, solid stone or even straw bales. 3


Advanced wall outline editing

Create split level buildings

Take full control of the profile of your walls for maximum design flexibility. Decide how and where walls interact with features such as stairs and roofs. Manually edit individual wall profiles to recreate unusual shapes, architectural features of even garden walls.

Not all building plots are level and often a design will need to include split levels within the building. This could range from a simple step-down kitchen through to a hillside home staggered with the slope of the site. By using the 'multiple building' concept within ARCON it is simple to overcome these design issues enabling you to create design solution perfectly suited to your plot requirements.

Modify existing walls with flexible editing tools =

Integrate balconies and railings Balconies can be attached to your floor plans using the simple balcony outline tool. Define the size and placement of the balcony and it will automatically integrate with your existing walls, placing parapet walls and/or railings where needed. Take full control of the railings to change style, size, and shape right down to specifying the fitting method.

View 2D & 3D views simultaneously Whilst it only takes a single key press or click of the mouse to toggle between the 2D construction mode and the 3D design mode, there are occasions when you may want to see both at the same time. Simply enable the 3D preview and watch everything you draw in 2D replicated in 3D as you design.

Define the site, plot or landscape Use the define landscape tool to mark the boundaries of your building plot or site. Break the area down into individual gardens, driveways and paths using the ground area tool. The add contours using the land topography tools or even individual height points for a realistic visualisation of your building plot.

Create 2D & 3D crosssections Our section tool enables you to create both elevations (by placing the section line outside the building) and crosssections (by placing the section line through the building).

The ARCON system provides you with the flexibility to produce drawings in your own way and when you need to change your plans, nothing could be simpler. With a complete suite of wall editing options available, amending, modifying or adding to your drawings is quick and intuitive. Simply select the tool that matches what you want to change and edit the wall. With options to enable you to change lengths, angles, wall ends, splitting walls, merging and trimming walls you can always ensure your designs can evolve with your requirements.

Enhance your 3D scene with picture backgrounds Select from one of the photographic backgrounds included or use your own to provide a greater insight into how your design will look in situ.

Generate elevation views automatically By using the section tool to designate the start and end viewpoints, an elevation can be generated automatically for everything visible within the boundaries of the section. The section tool enables you to define the scale of your elevation (which can be different for the floor plans) and specify whether to include one or more buildings or just an individual floor. Multiple sections can be added within a project to easily provide the standard front/rear/side elevation views.

Over 1300 textures and materials for decoration Apply textures to surfaces, objects, fixtures and fittings to change their appearance and style. The add materials to provide reflective surfaces, glass properties and mirrored finishes.

Increase your library with import options Need a specific texture or object? Can't find anything suitable in the library? Easily add to the library to increase your options. Textures can be added in the common bmp format, enabling you to take images from the web, catalogues or you own images. Furthermore add more 3D objects to your catalogue by using the import feature to import files in the widely used 3DS standard. 4


Over 7000 furniture items and objects included

Create tiling plans on walls and floors

The standard library contains over 7000 3D models for the furnishing and fittings of your project. Included are objects for bathrooms, kitchens, living areas, dining, gardens, offices and many more. All objects can be amended and modified, resized and adjusted as required.

Use the tile planner macro to define unique and complex tiling patterns to decorate both floors and walls.

3D virtual walkthrough Analyze your design in detail with the 3D walkthrough function. Enter and explore your 3D model to check for space issues and practicality of design. With animated door and window information, check your plans will work for you.

Import/Export DXF & DWG Check lighting and shadows By selecting to use the variable daylight settings to light your 3D model, you are able to select your location anywhere in the world by entering your latitude and longitude (or pick your closest town/city). Then choose a date and time and see the impact of the lighting from the sun. Calculate where shadows are cast from all elements within the project. Alternatively use artificial lighting in night time mode to light your interiors.

Share information with advanced export functions ARCON provides many ways to share your plans, drawings and models. Create image files of your 2D and 3D views, save your plans as pdf files, produce a 3D model in o2c format to share with clients or export your plans in CAD formats compatible with other software systems.

Many alternative CAD systems will produce files in the common DXF/DWG file types. ARCON is no exception and will enable you to produce 2D plans and elevation in DXF or DWG format. Additionally, some versions will also enable you export your 3d models into the 3D DXF format. It is also possible to import DXF/DWG files into your ARCON projects, enabling you to use them as the basis for creating your project.

Includes Creative Lines 3.5 Included as standard in all our new ARCON visual architecture range is the latest version of Creative Lines. Creative Lines is our stand-alone 2D drafting tool that is an ideal companion to ARCON. Simply export your completed drawings to Creative Lines with the in-built automatic transfer button and you can add enhanced detailing, experiment with different layouts or breakdown all elements into individual line items for complete control.

ARCON Self-builder Edition - Key Features An ideal package for the self-builder or home re-modeller looking to design their own home, extension or complex renovations. The toolset includes the ability to produce scaled accurate drawings for planning submissions together with automatic 2D to 3D model creation. This allows you to instantly view your designs in 3D with virtual walkthroughs to ensure that your design works for you. The simple to use interface and quick drawing method means you can experiment with multiple layouts and designs quickly until you find the building that works for you. With a toolset dedicated to home design, the ARCON Visual Architecture Self-builder Edition will help you to realise your designs quickly, saving you both time and money on expensive mistakes and redesigns.

Create up to 15 buildings and 50 floors Use multiple buildings to create complex designs, split level buildings or multiple dwelling projects. By using multiple buildings on a single project you can cater for large self build projects to include outbuildings or neighbouring properties.

instances of an object. Ideal should you realise that you've placed a window in the wrong position and subsequently copied it across fifty floors. This function enables you to select all instances of the same element and simply delete them from all floors at the same time.

Define worksheet display In ARCON we can often use the concept of multiple buildings to enable complex structures to be created which provides maximum flexibility for all types of design. The Self-builder Edition comes complete with an allocation limit of 50 floors per building, enough for even the most ambitious self-builder!

All our ARCON software titles come with multiple display types and options. Within the 2D construction mode, choose between the standard 2D floor plan view or a more traditional architect style view. Set up your projects to your preferred standard and style when creating a new project or toggle the view types as you progress.

Select and edit multiple construction elements over multiple floors

Manipulate objects and furniture in construction mode

Using this new feature enables instant editing of multiple

ARCON home design software has two distinct modes for

5


working, each with it's own toolset. For creation of the building we use the 2D 'Construction Mode'. This enables all of your construction drawing elements to be created and is used to design your building. 'Design Mode' is specifically for reviewing, manipulating and decorating with full 3D visualisation. In design mode we can add, adjust and position objects, furniture and decorative items including re-sizing and rotating. New in Self-builder Edition comes the ability to also manipulate object alignment and positioning in construction mode.

Enhanced wall editing tools All walls within ARCON visual architecture are fully customisable, enabling you to edit wall structures right down to each individual layer, create custom wall types and of course set dimensions and joints. Our enhanced wall editing tools provide greater flexibility than ever before to enable walls which have already been placed in a project to be manipulated quickly to achieve your design requirements.

Multiple point section tool A key feature in all ARCON software titles is the ability to quickly and automatically generate elevations and crosssections by using the 'section tool'. Simply drop a section line across the viewplane see the results quickly and to scale. In addition to the existing section line options, the new multi-point section line enables greater flexibility of the view to provide greater selection over the items that should be included in the view. This tool enables you to create composite elevation/cross-sections for different parts of the building.

Modify ceiling cutout display Ceiling cutouts, whether created manually to provide gallery landings double height rooms or automatically for staircase designs, can be difficult to convey in a 2D drawing. With the new modification options, ceiling cutouts can be identified with their own unique fill pattern and line style to help quickly identify these features on your 2D plans.

Edit construction elements in 3D Each element within ARCON is editable and customisable. Often however you need to ensure you are in the correct mode (construction mode or design mode) in order to make the necessary changes. However with the release of the new ARCON versions the majority of construction elements of your building can now be accessed and edited from within the 3D design mode.

Height point 2D display One of the most useful tools for those creating accurate landscaping designs is the ability to insert individual height points within the plot area to create realistic terrain contours and plot designs which closely mirror your real world scenario. The height points tool has been refined to improve the process of editing and amending your landscape contours.

Windows within curved and rounded walls Insert windows within any curved wall to generate a stylish and contemporary design. The flexibility to add windows into curved walls enables modern designs to be created where non-traditional materials are being used. This feature also makes bay windows and older period property designs much simpler.

ARCON Developer Edition - Key Features As the construction market continues to be competitive, many building professionals need the tools to ensure they can keep costs down and win over clients. ARCON Visual Architecture Developer Edition has been created with the demands of developers and construction companies in mind. Enabling you to create small developments by utilising multiple buildings and multiple floor apartments, the Developer Edition is perfect the independent contractor. With the ability to create 2D plans for planning permission quickly and easily, then further enhance the 2D drawings with building regulation information or trade specific information, the Developer Edition is a great tool to provide you with more control over your designs. Add in the ability to quickly show your plans to clients in full 3D and you have a flexible package for plan creation and customer satisfaction.

Contains all the features of ARCON Self-Builder Edition plus the following: Create up to 40 buildings on a single plan The concept of utilising multiple buildings within a single project file enables ARCON to provide superb level of flexibility for all your design requirements. Within a single project the Developer Edition can cater for up to 40 buildings. This enables large scale designs to be created including domestic and commercial estate developments. In ARCON we can often use the concept of multiple buildings to enable complex structures to be created which provides maximum flexibility for all types of design.

6


Create buildings of up to 100 floors

Design custom doors and windows, complete with parts lists

Developers can often be faced with the design and creation of apartment blocks or commercial office suites. Within ARCON, designing multiple storey buildings couldn't be easier as entire floors (including fixtures, fittings and furniture) can be copied to form the rest of the building. This enables a 100 storey design to be created simply by drawing a single floor. The Developer Edition comes complete with an allocation limit of 100 floors per building to allow for large scale designs to quickly be created.

The standard door and window libraries within ARCON contain substantial numbers of different styles and types of door and window fixtures. Each can be amended, re-sized and re-textured. Within the Developer Edition, we also include a macro feature to enable you to design your own doors and windows from scratch.

Import image overlays for construction design

Each element can be designed pane by pane, enabling full control over size, style, opening methods, handles, hinges and locks. Your designs are then added to your library for use on any future project. Once your building has been completed and your created doors and windows added, easily produce a parts list to display the information for each fixture and the total number of each type within the build.

A common request is to be able to use existing plans in ARCON as the basis for your drawing. With it's ability to import DXF files, ARCON is great if you have access to CAD drawings. However often, especially for older properties, plans are only available on paper. The Developer Edition now comes with a background import feature to enable you to use common image types (JPG, BMP etc.) and set the scale. This opens up the possibilities of using scans of older plans as the basis of your new designs.

Export directly to Real Time Renderer with full lighting

Navigate complex designs quickly with room viewer

ARCON Real Time Renderer is the latest development in our 3D visualisation range. Using the Real Time Renderer enables you to add greater detailing to your 3D models with enhanced texturing and materials, greater control over shadows and reflections and full scenic image integration. The export feature provides the facility to format your 3D models from ARCON with all the relevant lighting detail ready to enhance your models in Real Time Renderer*

With larger scale projects comprising multiple floors or multiple buildings it can be difficult to keep track of individual room layouts, decorations and viewpoints. Whilst it is simple to navigate around your plans, often when demonstrating to clients you may need to be able to easily toggle to specific areas within a build to demonstrate design ideas. Using our Room Viewer and our Project View Manager enables you to create waypoints of chosen views and specific rooms of interest to automatically select the same viewpoint each and every time.

Import 3DS files Import 3DS format files of 3D models to add to your object library.

Export projects to 3DS Used in the majority of high-end 3D modelling and CAD tools, 3DS is one of the industry standard file formats for the creation and sharing of 3D models. Used widely within many software applications, the ability to export your designs to 3DS format enables greater opportunity to share your designs.

*N.B. Real Time Renderer available separately. Not included in this edition.

Convert ARCON drawings directly to Adobe速 PDF files ARCON now includes pdfMachine by Broadgun Software allowing you to create, save and send PDF files directly from ARCON. PdfMachine is the perfect and complete solution for anyone that often sends drawings and other documents electronically to clients, colleagues, business partners and plan printing companies.

7


(3D) space and 3D objects in full color with special texture, animation, and lighting effects. This means you can move in three dimensions on a VRML Web page as you do with a video game or flight simulator. The VRML export feature enables you to share your 3D information with other applications using this method.

Export to VRML (Virtual Reality Modeling Language) VRML is a modeling language for specifying interactive animation. Text descriptions of geometries are downloaded and those geometries are created locally. VRML allows Web developers to create three-dimensional

ARCON Architect Edition - Key Features A powerful and extensive CAD package for all aspects of building design, our ARCON Visual Architect Edition is the most flexible design package we provide. The Architect Edition has been created following extensive research with our experienced users and architects to ensure that it easily fulfils the most demanding set of requirements. Complex customisation options, huge scope for complex multi-level buildings and large scale developments means that this is the only CAD solution you will require. Fully scoped to allow for large scale projects as well as simple domestic designs, our Architect Edition building design software is ideal for quickly creating designs to meet your clients brief. Additionally, the inclusion of automatically generated elevations and 3D models enables you to quickly meet the requirements of the most demanding of clients. The speed and simplicity of making changes to plans means that as requirements evolve, you can evolve plans to meet them, resulting in satisfaction for your customers.

Contains all the features of ARCON Developer Edition plus the following: Create up to 50 buildings on a single plan

Fast and flexible conservatory design

The concept of utilising multiple buildings within a single project file enables ARCON to provide superb level of flexibility for all your design requirements. Within a single project the Architect Edition can cater for up to 50 buildings. This enables large scale designs to be created including domestic and commercial estate developments.

With a dedicated module exclusively for the design of conservatories you can quickly experiment with different styles and designs to integrate into you project. Create a library of your conservatory designs to integrate into future projects or experiment with the designer to create lantern roofs and orangeries.

In ARCON we can often use the concept of multiple buildings to enable complex structures to be created which provides maximum flexibility for all types of design.

Advanced guideline management Guidelines are an efficient and simple way to ensure your project is drawn accurately and consistently. They enable you to define dimensions, angles, mid-points and parallel surfaces and can be used to align any construction item or furniture object. The advanced guideline manager provides additional levels of control over your guidelines, ideal for larger or more complex projects. Edition this includes the ability to quickly place an alcove or bay window into a wall already placed within the project. Simply set the bay dimensions and style, drop into place and ARCON will make all of the necessary amendments to the wall structure to accommodate your design changes.

Automatic advanced downpipe editor Adding finishing touches to your designs often increases the realism of your 3D models. In ARCON guttering is automatically added to roof designs. The downpipe macro enables you to quickly place additional drainage items which can be calculated to the correct floor to roof height. Enables choices of finish and materials including pvc, copper and zinc.

Create buildings of up to 100 floors Unlike many smaller software packages we understand that our users will often be faced with the design and creation of apartment blocks or commercial office suites. Within ARCON, designing multiple storey buildings couldn't be easier as entire floors (including fixtures, fittings and furniture) can be copied to form the rest of the building. This enables a 100 storey design to be created simply by drawing a single floor. The Architect Edition comes complete with an allocation limit of 100 floors per building to allow for large scale designs to quickly be created. 8


Custom cabinet designer

Quickly enhance existing walls with bay windows

Enhance your designs and increase your object library with custom made content. The simple to use cabinet designer is ideal for creating your own bespoke designs including cupboards, shelving units, kitchen cabinets, storage units and wall units. Easily configure the number of doors and shelves, add handles, feet and other detailing. Then place your custom objects into you project or save them to your library for future use.

Within the ARCON system, creating walls is very simple and they can be drawn to any shape and angle, even including circular and curved walls. In addition we provide a full suite of tools to easily edit existing walls within a project. In the Architect Edition this includes the ability to quickly place an alcove or bay window into a wall already placed within the project. Simply set the bay dimensions and style, drop into place and ARCON will make all of the necessary amendments to the wall structure to accommodate your design changes.

Advanced control over ceiling detailing Adjust the shape and style of ceiling cut-outs and recesses including those around stair wells to provide further control over your 2D plan views.

Advanced roof editing and enhancement tools

Extended object catalogue including swimming pools

Create even more unique or complex roof designs with the advanced tools. Easily edit roof overhang profiles, insert additional polygon points for greater flexibility of design and automatically add guidelines in attic rooms for any specified head height.

Add from a selection of swimming pool styles from the increased object library.

Framework and support editor Create steel framework supports and cross beams for enhanced visuals, particularly useful for commercial spaces.

360 degree panoramic background maker An advanced option for adding a background image to your 3D model. Using a panoramic image, it can be wrapped around the building and aligned to ensure that the correct views are visible from windows on a 3D walkthrough or from any angle during when saving a viewpoint. This enhances the realism and enables easier visualisation of the design in situ.

Chimney stack positioning tools Ensure chimney stacks are positioned correctly with the appropriate height settings. Apply the known measurement from a variety of reference points including roof apex and roof surface.

9


Modify 2D object representation

Export direct to o2c with lighting (for Real Time Renderer)

Each furniture item and 3D object used within your designs is crafted as a full 3D object. When in the normal plan view your objects are represented by a 2D symbol (i.e. a top down view). The symbol editor enables you to change the 2D representation and customise it for your own requirements. This can help easily identify objects of different heights, different finishes or even use the symbol editor to add an item reference or catalogue number for space planning.

Our Real Time Renderer add-on is designed for those who want to get more out of their 3D visualisations enabling you to enhance the level of detail with unique textures, materials and effects. Our Architect Edition contains a useful export option to carry over lighting detail from your models into the Real Time Renderer to save time when lighting the project for shadow calculations.

Export 3D DXF files The ability to export DXF files in 3D increases the flexibility when integrating with other CAD software packages. In a traditional CAD environment creating 3D designs can be exceptionally time consuming. Creating the 3D in ARCON is quick and simple and now enables you to export this 3D model back to other compatible CAD packages.

Import PLT files Vector-based plotter files created by other CAD drawing software can be imported into ARCON.

Import HPG files Plotter files created in the Hewlett-Packard Graphics Language (HPGL) can be imported into ARCON.

ARCON Architect + Renderer Edition - Key Features Our most feature rich edition, containing a full version of the ARCON Visual Architecture Architect Edition plus our all new Real Time Renderer package. Architect Edition provides the largest and most flexible toolset to enable complex, large scale designs to be created and is therefore suitable for the design of both domestic and commercial buildings. The ability to create projects containing multiple buildings and many floors ensures that this edition is suitable for all your requirements. In addition to the Architect Edition, this package also contains our full stand alone enhanced rendering tool. The Real Time Renderer takes your 3D models to the next level of detail. Utilising detailed textures complete with bump-mapping, enhanced shadow and reflection control as well as full lighting control, the Real Time Renderer makes stunning visuals simple to achieve. Combined with the ability to fully control scene views with background and foreground detailing and the ability to apply Photoshop plugins to your 3D models, this edition is the complete planning and visualisation solution for architects, building designers, interior designers and building professionals.

Contains all the Renderer:

features of ARCON

Architect

Edition

plus Real-Time

ARCON Real Time Renderer Export your models quickly and simply to create high-quality rendering with ambient shade, real time shade, real time reflections and Photoshop速 plugins. With the ARCON Real Time Renderer your ARCON projects can quickly and effectively be turned into a full visualisation scene. Its compact format enables fast scene building combined with close-to-reality quality and simple handling. Suitable for use by experienced visualisation professionals or first time users. See each feature below for more details.

10


Ambient shadows

Real time reflections

Take greater control of your shadow detail settings to create the effect you require for your project and visualisation style. Control ambience and diffusion of the light source together with strength and intensity of shadow detailing to create your distinct style.

Reposition, rotate and walkthrough your project with continual reflection detailing in place to provide consistently realistic visualisations.

Reflection mapping Reflection mapping is an efficient image-based lighting technique for representing the appearance of a reflective surface. This can be applied to any surface and is ideal for use in water features, polished surfaces, mirrored surfaces and swimming pools. Adding a reflection map to these objects will enable them to realistically reflect the surrounding environment.

Texture picker Using our standard texture pipette and dropper, you are able to quickly copy and replace textures from one part of a project to the other.

Layer manager

Bump mapping

Real Time Renderer introduces the concept of layers to perfect your scene. A scene can be created from multiple layers and by using combinations of background (sky, landscape), mid-ground (your 3D model) and foreground (fencing, overhanging trees) you are able to quickly build a photorealistic scene around your 3D model.

Bump mapping is a technique in computer graphics for simulating bumps and wrinkles on the surface of an object. With built in bump mapping capabilities, you can now add greater levels of realism to your textures, enabling more detailed and realistic visualisations.

Multi-layer textures

Export multiple file formats

Combine texture effects such as bump mapping and reflection mapping onto a single multi-layer texture. This provides greater creative flexibility enabling you to ensure you are able to obtain the finish and style you require.

Export your final scenes as either o2c or e3d format for use within the relevant model viewer. Save your scenes as images in the standard formats such as BMP, JPG and PNG.

Texture & materials database

Layer manager

Thousands of new textures and materials are included in the new database, unique to the Real Time Renderer. Take advantage of the new higher quality image settings to improve your 3D designs with a greater selection of brick, stone, paving, wood, roof tiles and more. Additionally edit or add your own textures to the database for use on future projects.

Real Time Renderer introduces the concept of layers to perfect your scene. A scene can be created from multiple layers and by using combinations of background (sky, landscape), mid-ground (your 3D model) and foreground (fencing, overhanging trees) you are able to quickly build a photorealistic scene around your 3D model.

Real time shadows Reposition, rotate and walkthrough your project with continual shadow detailing in place to provide consistently realistic visualisations.

Light source manager Automatically integrate light sources from within ARCON, add new light sources or combine both. Then select each light source for additional control including direction, strength and colour.

Scenery manager

Import multiple file formats

Along with layers, use the scenery manager to add additional fine detailing to your projects. Using 2D PNG scenic images add plants, people and other items to add interest to your scene. Pin scenery items in place to rotate and move with your model when re-positioned.

Import your models in either o2c format direct from ARCON or import models in the standard 3DS modelling format. 2D images for layers and scenery can be imported in the standard formats such as BMP, JPG and PNG.

11


Scenery & layer library Scenery and layers makes use of PNG file format images which contain transparent backgrounds. This enables images to be stacked to create rich, detailed scenes. The library contains images for both background and foreground layers and scenic items such as plants and people. Easily add your own to the library using this common file format.

Normal view

Utilise Photoshop速 plugins for creative control ARCON Real Time Renderer is compatible with plugins created for Adobe Photoshop速. Experiment with Photoshop速 plugins with your models to provide unlimited creativity. Try line art, or pastel plugins. Use cell-shading and edge definition filters or any other plugin that provides you with unique and creative visualisations.* *N.B. Photoshop速 plugins not supplied. View after plugin filter has been applied

For a detailed list of ARCON software features and comparison see over

12


ARCON Architect Edition

ARCON Developer Edition

ARCON Self-builder Edition

ARCON Architect + Renderer Edition

ARCON Architect Edition

ARCON Developer Edition

ARCON Self-builder Edition

ARCON Self-builder Edition

ARCON Developer Edition

ARCON Architect + Renderer Edition

Protection Starforce Copy Protection Starf rce License Other software license Limits Floors- Number o Reading Encrypted Project Files (ARCON Software) Saving Encrypted Project Files (ARCON Software) Buildings- Number of 2D Mode Top Menu Bar in 2D Mode File menu New, Save, Open project Start project assistant Project options (scale & measurements) Project information Save project as HTML/o2c object Import DXF (Standard ARCON) Import DWG (Standard ARCON) Import HPG Import PLT Import 3DS Export DXF Export VRML Export 3DS Export ARCON object Export o2c o2c with lights Export 3D DXF Export MBA Expor HPGL Save view Export BMP Export J G Export Windows Metafile Export Enhanced Windows Metafile Email project PDF export

ARCON Architect Edition

ARCON Architect + Renderer Edition

ARCON Visual Architecture Features and Comparison List

● ● 99 ● ●

● ● 99 ● ●

● ● 99 ● ●

● ● 50 ● ●

Align objects Mirror objects Rotate objects Object lights on/off Objects menu Load object group Save object group

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ●

● ●

● ●

● ●

● -

● -

● -

● -

99

99

99

50

Floor menu View current floor View all floors New top & bottom floor - total no Edit floor Delete floor Building menu

View current / all buildings

Load object

● 50

● 50

● 40

● 15

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● -

New building - o of Edit building Delete building Building plan rotation Building plan mirror Save & load building into new project Room info menu Object List General room info Survey of rooms Area calculation Options menu Room info properties Wall properties Door properties Window properties Skylight properties Support propertie Chimney properties Floors / ceiling properties Section properties Text properties Dimension properties Exterior dimension properties Ruler properties Display dimensions during input Title block properties Room planning properties Program / General setup op ions Sound options Save options

50 ● ● ● ● ●

50 ● ● ● ● ●

40 ● ● ● ● ●

15 ● ● ● ● ●

● ● ● ● ● ● ●

● ● ● ● ● ● ●

● ● ● ● ● ●

● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

-

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Save as object Place camera position Load 3DS object 3Ds object conversion tool Save as o2c object Save as 3DS data Block insertion editor View menu Object/Texture catalog (docking) Options menu Brightness properties Viewer (proper ies) Raytracing (properties) Background properties Walkthrough mode/3DHardware (properties) Light calculations real time (properties) Delete properties Construction elements selection Top icon Bar in 3D Mode Additional functions not in Top Menu Bar 3D Mode & Top icon Bar 2D Mode Collision control walkthrough mode Plan view Plan view texture 3D Cross section 3D View textured 3D View wire frame 3D View wire frame hidden surfaces Day, night, variable time of day Create AVI Elevate through floors

● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ●

13


Print Edit menu Undo Redo Cut, copy, paste Edit dialog (will change via function)

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

Delete all (selectable elements) Insert menu Plan assistant Wall types - standard Wall types - virtual Round room Upper / Lower beams Number of standard doors Door edit macro Number of standard windows Number of extended windows Window edit macro

● 7 ● ● ● 59 ● 21 3 ●

● 7 ● ● ● 59 ● 21 3 ●

● 7 ● ● ● 59 ● 21 3 ●

● 7 ● ● ● 59 ● 21 3 ●

Stairs Wood Stairs Concrete Stairs Spiral Ramp Polygonal staircase Ceiling cut-out

6 6 1 1 2 ●

6 6 1 1 2 ●

6 6 1 1 2 ●

6 6 1 1 2 ●

Wall cut-out Additional Ceiling Outline (block) editor Outline (block) editor (contour) Balcony editor Railing editor Object placement in 2D mode Supports - number of standard Supports - additional variable x section Chimneys Roof types Dormer types Skylight standard types Skylights Velux types Solar PV types types Solar thermal types Define area Define plot Define area cut out Define height points Insert slope / hill no. of types Guidelines no. of Text input Dimension types- number of Height measure Angle dimension Define section Offset section 2D Cross section 2D Cross section with dimensions 2D Cross section in new view View menu Normal / layout view Zoom in / out / all / entire page Hatched walls Roof surface

● ● ● ● ● ● ● 3 11 4 10 8 16 8 6 3 ● ● ● ● 10 5 ● 6 2 ● ● ● ● ● ●

● ● ● ● ● ● ● 3 11 4 10 8 16 8 6 3 ● ● ● ● 10 5 ● 6 2 ● ● ● ● ● ●

● ● ● ● ● ● ● 3 11 4 10 8 16 8 6 3 ● ● ● ● 10 5 ● 6 2 ● ● ● ● ● ●

● ● ● ● ● ● ● 3 11 4 10 8 16 8 6 3 ● ● ● ● 10 5 ● 6 2 ● ● ● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

Print options Save view options New view options New project options Zoom options Snap and select options Snap & Select options construction & design mode Grid options Mirror buildings options o2c object options Origin options Landscape options Guideline options Windows menu New Vi w Cascade Tile Top icon Bar in 2D Mode Additional functions not in Top Menu Bar 2D Mode Room planner Switch 2D/3D mode Architectural display toolbar icon Camera view Left icon Bar in 2D Mode Additional functions not in Top Menu Bar 2D Mode Select elements Select elements (with polygon) Multiple copy Wall types curved Wall type spline Wall editing tools Wall editing tool: Intersection Wall editing tool: direction Wall direction tool Cavity wall editing tools Transfer properties Measure distance Element - free positioning Element - midway positioning Element - set distance positioning Move selected plan (numerically) Other Features / Functions 2D Mode Dimension plan Dimension: metric/imperial Preview before load Cavity walls Wall contour editor Wall cut editor Wall cut by stairs Wall cut by roof Stair Railings Stair Advanced Railings Stair Construction Detail Title block editor Advanced title block editor Alternative 2D symbol Stretch plan Automatic room area data Move working sheet Global Raster on/off

14

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● ●

Viewer Camera view Camera view (record) Name and save viewpoint Additional viewer no. of ARCON catalog icon creation

● ● ● ● ● ● ●

● ● ● ● ● ● ●

● ● ● ● ● ● ●

● ● ● ● ● ● ●

● ● ●

● ● ●

● ● ●

● ● ●

Left icon Bar in 3D Mode Additional functions not in Top Menu Bar 3D Mode & Left icon Bar 2D Mode Lights on/off Select and transfer texture/material tool Light calculation for individual rooms 3D Modeller Other Features / Functions Rendering with soft shadows 3D Object Editing Tool Advanced 1 3D Object Editing Tool Advanced 2 Uses Direct X

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● 7 ● 7 ● ● ● ● ● ● ● ● ● ●

● ● ● 7 ● 7 ● ● ● ● ● ● ● ● ● ●

● ● ● 7 ● 7 ● ● ● ● ● ● ● ● ● ●

● ● ● 7 ● 7 ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● 4 ●

● ● ● ● 4 ●

● ● ● ● 4 ●

● ● ● ● 4 ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

Insert doors / windows / skylights in 3D mode Object properties transfer tool World locator for light calculations Change properties for individual lighting objects 2D transfer to CreativeLines 2D Symbol in 3D Object

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● -

● ● ● ● ● -

Edit wall properties in 3D General Objects / Materials / Textures Objects (aco) x 1000 Objects (o2c) x 1000 Swimming pool object Textures (bmp) x 1000 Materials mdb Database support for aco/bmp Documentation Online / context help Printed getting started PDF documentation Interfaces Active X Active X license control Modules DWG export Creative Lines 3.5 ARCON Real-Time Renderer o2c player Macros Advanced tool: Insert bays Advanced tool: Guidelines manager Advanced tool: Add polygon points to ceiling slab or recess Advanced tool: Insert roof overhangs Advanced tool: Insert additional polygon points to roof Advanced tool: Automatic guidelines at roof level Advanced tool: Adapt height of chimney to roof Display project data as tree Framework editor: Design framework and support structures 2D Graphics editor Advanced Door and window designer Door and window viewer Window Macro Viewer/parts list Tile planner / editor

7.2 67 ● 1.3 442 ●

7.2 67 ● 1.3 442 ●

7.2 67 1.3 442 ●

7.2 67 1.3 442 ●

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ●

● ● ●

● ●

● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ● ● ● ● ●

● ● ● ● ●

● ● ●


Wood constructi n Internal objects Dimensions (& automatic exte nal) Text Architectural display Grid Guidelines DXF layers Set origin Compass Ruler Cameras on/off

● ● ● ● ● ● ● ● 4 ● ● ●

● ● ● ● ● ● ● ● 4 ● ● ●

● ● ● ● ● ● ● ● 4 ● ● ●

● ● ● ● ● ● ● ● 4 ● ● ●

Landscapes Sections Numeric input Title block Enter object position 3D preview window

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● ●

● ● ● ● ● ●

Rotate Objects in Construction Mode Ceiling/Floor hatches on/off in section Global settings for view Architectural view at new project Selection of all floors Line properties for openings Sections with offsets Define section depth Heightpoint with circles in drawing Mousewheel zooming 3D Mode Top Menu Bar in 3D Mode Additional functions not in Top Menu Bar 2D Mode Edit menu Select all (objects) Group objects Ungroup objects 3D Object Editing Tool

15

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● -

● ● ● ● ● ● ● ● ● -

● ● ● ●

● ● ● ●

● ● ● ●

● ● ● ●

Project manager Load background picture as transparency in 2D mode Room viewer XML Export Pack and go Extended ground area assistant Downpipe generator 360° Panorama Maker Cabinet and shelf designer Conservatory designer 4

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● ● ● ● ●

● ● ● ● ● ● -

● ● ● ● -


For further information & ordering: www.3darchitect.co.uk tel: 01252 339 132 email: arconsales@eleco.com Eleco Software Ltd Christy Estate, Ivy Road Aldershot, Hampshire GU12 4XG, UK 16


Arcon 3D Visual Architecture