Issuu on Google+

TEST DE EVALUARE INIȚIALĂ Anul şcolar 2012-2013 Disciplina: Informatică Clasa a X a Numele şi prenumele elevului: Data susţinerii testului: Clasa:  Pentru rezolvarea corectă a tuturor cerinţelor din Partea I şi din Partea a II-a se acordă 90 de puncte. Din oficiu se acordă 10 puncte.  Timpul efectiv de lucru este de 45 minute.

(40 puncte)

(10p) a) i5; j6; cât_timp j>4 execută scrie i; j  j – 1; sfârșit_cât_timp;

b) j5; pentru i5, 5 execută scrie i; sfârșit_pentru;

c) i5; j6; cât_timp j>4 execută scrie j; sfârșit_cât_timp; j  j - 1;

d) j5; pentru i1, 1 execută scrie j; sfârșit_pentru;

a) intreg prim, d; inceput pentru d2, (n/2)-1 execută daca n%d = 0 atunci prim0; altfel prim1; sfarsit_daca; sfarsit_pentru; sfarsit.

b) intreg prim, d; inceput d2; cat_timp d<=n/2 si n%d ≠ 0 executa dd+1; sfarsit_cat_timp; daca d>(n/2) atunci prim1; altfel prim0; sfarsit_daca; sfarsit.

c) intreg prim, d; inceput cat_timp d<=(n/2) si n%d=0 atunci dd+1; sfarsit_cat_timp; daca d > (n/2) atunci prim1; altfel prim0; sfarsit_daca; sfarsit.

d) intreg prim, d; inceput pentru d2, (n/2)-1 execută daca n%2 ≠ 0 atunci prim1; altfel prim0; sfarsit_daca; sfarsit_pentru; sfarsit. (10p)


not ((x>=5) si (x<10))

(10p)

a) (x<5) sau (x>=10)

b) (x<5) sau (x>10)

c) (not (x>=5)) si (not (x>10))

d) (x>=5) sau (x<10)

4. Care dintre următoarele construcții nu reprezintă o structură repetitivă ? a) pentru i0, n execută ... sfârșit_pentru;

b) dacă x>5 atunci … sfârșit_dacă;

c) cât_timp a<b si b<c execută ... sfârșit_cât_timp;

d) execută ... cât_timp a<=3 ;

(10p)

(50 puncte) 1. Se consideră algoritmul următor descris în pseudocod: întreg n, nr; început nr0; pentru a9, 0, -1 execută mn; cât_timp m≠0 și m%10≠a execută mm/10; sfârșit_cât_timp; dacă m≠0 atunci nrnr*10+m%10; sfârșit_dacă; sfârșit_pentru; scrie nr; sfârșit. Ce valoare se va afișa, în urma executării algoritmului, dacă se citește pentru n valoarea 232493 ? (20p) 2. Scrieți în pseudocod algoritmul care să calculeze suma cifrelor unui număr natural n.

(15p)

3. Scrieți în pseudocod algoritmul care să determine cel mai mare divizor comun (cmmdc) dintre două numere naturale a și b.

(15p)


Test_evaluare_init_info X