Page 1

Geographical 2 Data Analysis for Techniques Research

2.8

Descriptive DescriptiveStatistics Statistics

Using SPSS to Calculate Descriptive Statistics Having considered the basic calculation of the mean, median and mode by hand (and hopefully not to painfully!), the aim of this next section is to show you how to produce basic descriptive statistics using SPSS. You can also produce descriptive statistics in Access, and this will be demonstrated later in the module. We first need to consider the basic elements of the SPSS operating system.

2.8.1

An Introduction to SPSS SPSS (PASW Statistics) is a powerful statistical tool that can be used to perform a wide range of statistical techniques. When analysing data in SPSS it is often convenient to transfer over the data you which to analyse from an Excel spreadsheet. The following section will highlight how to import an Excel spreadsheet, and provide a basic introduction to the SPSS environment, before detailing in more detail how to produce descriptive statistics. To import an Excel spreadsheet, first open SPSS. SPSS asks you what you would like to do. Move the mouse over Open an Existing Data Source and press the left mouse button. Either choose the required files or select More Files and click OK.

simulation

Š Dr Andrew Clegg

p. p. 2-37 37


Geographical 2 Data Analysis for Techniques Research

Descriptive DescriptiveStatistics Statistics

The Open File dialog box appears. Move the mouse over the drive containing the file you want to open and then press the left mouse button. The file Dataset is located in the BML224 home page on Moodle.

SPSS must be told to look for an Excel file. Therefore in the Files of Type box make sure that Excel is selected [Move the mouse over and press the left mouse button. A sub menu of different file types appear. Move the mouse over Excel and press the left mouse button]. Now select the Dataset file and click Open. The Opening File Options dialog box appears. In the Excel spreadsheet you are going to import, the first row in the spreadsheet contains the field names of the variables you want to examine. To assist your data analysis, you need to ensure that SPSS recognises this.

Move the mouse over Read Variable Names option and press the left mouse button becomes ). Move the mouse over OK and ( press the left mouse button. Š Dr Andrew Clegg

p. p. 2-38 38


Geographical 2 Data Analysis for Techniques Research

Descriptive DescriptiveStatistics Statistics

SPSS now automatically imports the fields in the Excel spreadsheet and the data is displayed in the Data Editor window.

You know need to save this file to your own homespace on the network. Move the mouse over File and press the left mouse button. Move the mouse over Save As and press the left mouse button again. The Save As Dialog box appears. Save the file as DATASET.SAV. Note that .SAV is the file extension for data tables in SPSS. If you need to reload this file at any point, in the Open File dialog box select the DATASET.SAV file.

Š Dr Andrew Clegg

p. p. 2-39 39


Geographical 2 Data Analysis for Techniques Research

Descriptive DescriptiveStatistics Statistics

Before using SPSS to perform basic frequency counts and descriptive statistics on the results of the Interview data you first need to understand the nature of the data. For example, some variables are based on numeric coding schemes (nominal, categorical data types) and others on specific data values (interval or ratio data types). For those questions based on numeric coding schemes, certain descriptive statistics are not appropriate, although in this case SPSS can be used to perform basic frequency counts. Details of the variables in the Dataset file are included in the Dataset guide which has been given to you as part of the module resources. Please read through this guide carefully and become familiar with the different types of data, as this will be central to your successful completion of this module.

Š Dr Andrew Clegg

p. p. 2-40 40


Geographical 2 Data Analysis for Techniques Research

2.8.2

Descriptive DescriptiveStatistics Statistics

Using the Variable View In SPSS, we can use the variable view to check the integrity of the data and to apply additional information to the coding schemes to aid our analysis of the data. In the bottom of the SPSS window, click on the Variable View tab. The Variable View window is displayed. This window provides specific information relating to the variables that we have imported in the Dataset file. A number of key areas need to be checked at this point. First, check the Type column. In order for SPSS to conduct statistical analysis on the variables in the Dataset file all the variables here should be listed as Numeric.

In this instance the Greenrank06 variable is listed as a String. This needs to be changed to Numeric. To do this move the mouse over String and press the left mouse button. The cell is highlighted and a button appears.

Click the button and the Variable Type dialog box appears.

simulation Š Dr Andrew Clegg

p. p. 2-41 41


Descriptive DescriptiveStatistics Statistics

Geographical 2 Data Analysis for Techniques Research

Select Numeric and click OK.

Check the other variables to ensure that they are set as numeric. We can also use the Variable View to check the Measurement type of the variables. In this instance the measurement type should look like this. Refer back to your introductory notes to check on different data types. If the measurement type is not correct for a specific variable, move the mouse over the measurement cell in question and press the left mouse button. The cell is highlighted and a button appears.

Click on the button and a sub menu appears, offering three options: Scale, Ordinal and Nominal. Move the move over the required data type and press the left mouse button. The new data type will be presented. Note that ratio and interval data (e.g. age/investment) are classified as Scale). In the Variable View we can also assign more specific value labels to each of the variables. For example if we take Area as an example of the basic coding scheme in place here, Chichester District = 1 and Arun District =2. Any subsequent analysis that we perform will use this base coding scheme in any output. In order to make the SPSS output more self-explanatory we can assign additional value labels so that any output actually refers to Chichester District and Arun District. In the Variable View move the mouse over Values for the Area variable and press the left mouse button. The cell is highlighted and a button appears. Click the button.

Š Dr Andrew Clegg

p. p. 2-42 42


Descriptive DescriptiveStatistics Statistics

Geographical 2 Data Analysis for Techniques Research

The Value Labels dialog box appears.

In the Value: box type 1. In the Value Label: box type Chichester District.

Chichester District

Click Add.

In the Value: box type 2. In the Value Label: box type Arun District. Click Add.

Arun District 1 = ‘Chichester District’

Click OK.

The changes you have made are reflected in the Variable View.

Repeat this process to add Value Labels to the remaining variables (where appropriate!). Return to the Data View and SAVE the file. We can now experiment with producing descriptive statistics.

© Dr Andrew Clegg

p. p. 2-43 43


Geographical 2 Data Analysis for Techniques Research

Descriptive DescriptiveStatistics Statistics

By using the Value Labels in the Data View window you can switch the value labels between the numeric coding and the full text labeling. Click the button to toggle between the different options.

Numeric Coding

Text Label

Š Dr Andrew Clegg

p. p. 2-44 44


Geographical 2 Data Analysis for Techniques Research

2.8.3

Descriptive DescriptiveStatistics Statistics

Working with SPSS Output Before we start producing descriptive statistics, it is worth mentioning that SPSS output can be cut and paste into a Word document (or equivalent package). The process is very simple. In the output window, select the item you want to cut and paste, in this case a histogram. When the item is selected a black border will appear. Copy the item (Edit>Copy or right mouse click>Copy).

Open Word and paste the selection into your document.

simulation Š Dr Andrew Clegg

p. p. 2-45 45


Geographical 2 Data Analysis for Techniques Research

Descriptive DescriptiveStatistics Statistics

To print specific elements of the output, first select the element you wish to print. When the item is selected a black border will appear. Select Print from the File menu. The Print dialog box opens. Make sure that Selection is highlighted and click OK.

The required element is printed. Please use this method to print and annotate output that will be created during the module.



Please use the cut and paste process highlighted here to complete your log book that we will use throughout this module.

Additional guidance notes on the different features of SPSS are available in the appendices of this handbook. When using SPSS to analsye data, you should not be directly cutting and pasting SPSS output into your work. Outputs tables should ideally be recreated in Word, and data should be transferred into Excel to create appropriate graphs.

Š Dr Andrew Clegg

p. p. 2-46 46

INTRO TO SPSS  
INTRO TO SPSS  

Introduction to SPSS

Advertisement