Issuu on Google+

Práctica 4.- Diseña y Elabora Algoritmos y Pseudocódigos Rolon

Castellanos

Apellido Paterno 20137417

Hector Manuel

Apellido Materno

Nombre(s)

b

No. de Cuenta

36

Grupo

Fecha

No. de Lista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema 1: Mostrar en pantalla el factorial de cualquier número, introducido desde el teclado.. Inicio Programa: factorial Inicio Leer: numero Fact=1 Cont=1 Fact= Fact x Cont Cont=Cont+1 Si Cont<=num entonces Fact= Fact x Cont Cont=Cont+1 Si no Cont<=num entonces Imprimir:Fact Finprograma

Numero

Fact=1 Cont= 1 Fact = Fact x Cont Cont = Cont + 1

SI Cont<=num N Fact

Fin


b) Problema 2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%.

Inicio

Programa salario neto 1. Inicio. 2. Observar que es lo que me piden. 3. Ver que datos tengo. 4. Multiplicar las horas trabajadas por el sueldo por hora. 5. Realizando operaciones. 6. Ya que tengas el sueldo por hora. 7. Lo multiplicas por los 30 días del mes. 8. Así ya tenemos el sueldo por mes. Finprograma

CAL.A

A=b*x-12%

A

FIN


c) Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I.

II.

III.

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.

Proceso promedios Leer b1,b2,b3,b4 Promedio=(b1+b2+b3+b4)/4 Si promedio<=8 entonces Imprimir promedio Fin Si promedio<8 entonces Imprimir “lo siento, te vas a ordinario (primera vuelta). Fin Leer pv P2=(pv+promedio)/2 Fin Si p2</6 entonces Imprimir “lo siento te vas a extraordinario (segunda vuelta). Fin Leer sv pfinal=(sv+promedio)/2 imprimir “tu calificación finales”, pfinal Finprograma


Firma de Actividad Realizada:_ Inicio

P1, P2, P3, P4

(P1, P2, P3, P4)>=(8)

n o

s i

Promedio Final

Ordinario

n o

Extraordinario

(P1, P2, P3, P4)>=(6)

s i

Promedio Final

Promedio Final

Fin



Práctica 4