Issuu on Google+

LORENZO

EVANGELISTA

Apellido Paterno 20137356

GUILLERMO

Apellido Materno D

No. de Cuenta

Nombre(s) 05/04/2014

Grupo

24

Fecha

No. de Lista

Instrucciones: Elabora el Pseudoc贸digo o algoritmo para: a) Problema 1: Mostrar en pantalla el factorial de cualquier n煤mero, introducido desde el teclado.. Inicio 1. 2. 3. 4. 5. 6. 7. 8. 9. 10. 11. 12.

Proceso factorial Leer num1 fact=1 Cont=1 Fact=fact*cont Cont= cont+1 Si cont<=num 1 entonces Fact= fact*cont Cont= cont +1 FinSi Imprimir fact FinProceso

Numero

Fact=1 Cont= 1 Fact = Fact x Cont Cont = Cont + 1

SI Cont<=num N Fact

Fin


b) Problema 2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%.

1. Proceso: Calculo de horas 2. Escribir “dame el numero de horas que trtabajo” 3. Leer numhoras 4. Escribir “ ah cuanto le pagan cada hora?” 5. Leer costoxporhora 6. Descuento=(numhoras*costoxporhora)*.12 7. Total=(numhoras*costoxhora)-descuento 8. Escribir “El total que recibe el trabajador en pesos es:” 9. Escribir total 10. FinProceso


c) Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I.

II.

III.

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.

1. Proceso: promedios 2. Leer b1, b2, b3, b4, 3. Promedio=(b1+b2+b3+b4)/4 4. Si promedio >=8 5. Imprimir promedio 6. Finsi 7. Si promedio<8 Entonces 8. Imprimir “Lo siento, te vas a ordinario(primera vuelta) 9. FinSi 10. Leer pv 11. P2=(pv+promedio)/2 12. Si pv>=6 Y promedio>=6 Entonces 13. Imprimir p2 14. FinSi 15. Si p2<6 Entonces 16. Imprimir “lo siento, te vas a extraordinario (segunda vuelta) 17. FinSi 18. Leer sv 19. Pfinal=(sv+promedio/2) 20. Impirmir “tu calificación final es” ,pfinal 21. FinProceso


Practica 4 memo