Page 1

Manual de Prácticas

Tecnologías de Información II

DGEMS

Práctica 4.- Diseña y Elabora Algoritmos y Pseudocódigos Gomez

Rocha

Apellido Paterno

Yoselin Yasmin

Apellido Materno 2D

20137317

No. de Cuenta

Nombre(s) 10/04/2014

Grupo

15

Fecha

No. De Lista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema1:Mostrar en pantalla el factorial de cualquier número, introducido desde el teclado. Inicio

Proceso factorial Numero

Leer Num 1 Fact= 1

Fact=1 Cont=1

Cont=1 Fact=fact*cont

Fact =Fact x Cont

Cont=cont+1 Si cont<=num 1 entonces

Cont =Cont+1

Fact=fact*cont Cont=cont+1 Finsi Imprimirfact

SI Cont<=num N Fact

Finproceso Fin


b) Problema2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es12%. Inicio 1.- Proceso Calculodehoras 2.- Escribir “Dame el número de horas que trabajo” 3.- Leer Numhoras 4.- Escribir “A cuánto le pagan cada hora?”

Númhoras, costoxhoras

5.- Leercostoxhora 6.Descuento=(numhoras*costoxhoras) 7.Total=(numhoras*costoxhora)descuento 8.- Escribir “El total que recibe el trabajador en pesos es:”

D=(numhoras*costoxhoras)

9.- Escribir total 10.-Finproceso

T=(numhoras*costoxhora)descuento

Total

Fin


c) Problema 3: Utiliza el procesador de palabras para elaborar el pseudoc贸digo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I. Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. II. Si el promedio de la calificaci贸n de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. III. El promedio de la calificaci贸n de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.


Inicio

B1, b2, b3, b4

1.- Proceso promedios 2.- Leer b1, b2, b3, b4

Prom=(b1+b2+b3+ b4)/4

3.- Promedio=(b1+b2+b3+b4)/4 4.- Si promedio>=8 Entonces 5.- Imprimir promedio

Promedio

6.- Finsi 7.- Si promedio<8= Entonces Finsi

8.- Imprimir “Lo siento, te vas a ordinario (primera vuelta) Si 9.- Finsi

Promedio<

10.-Leerpv 11.- P2=(pv+promedio)/2 12.- Sip2<=6 Entonces 13.- Imprimir p2

Te vas a Ordinario

14.- Finsi Finsi

15.- Si p2<6 Entonces 16.- Imprimir “Lo siento, te vas a extraordinario (segunda vuelta)

Pv

17.- Finsi 18.- Leersv P2=(pv+promedio)/2

19.- Pfinal=(sv+rpmedio)/2 20.- Imprimir “tu calificación final es”, pfinal P2

21.- Finproceso

Finsi Si Si p2<6

Te vas a Extraordinario


Finsi

Pv

Pfinal=(sv+rpmedio)/2

Pfinal

Finproceso

Practica 4