Page 1

Práctica 4.-DiseñayElaboraAlgoritmosyPseudocódigos

FREGOSO

Vera

Victor Manuel

Apellido Paterno

20137305

Apellido Materno

B

No. de Cuenta

Nombre(s)

08/04/2014

Grupo

12

Fecha

6

No. De Lista

Instrucciones: Elabora el Pseudocódigo o algoritmo para:

a) Problema1: Mostrar en pantalla el factorial de cualquier número, introducido desde el teclado... b) Fact =Fact x Cont.

Inicio

Numero

Fact=1 Cont.=


Cont. =Cont+1

SI Cont. <=nĂşm.

N

Fact

Fin


a) Problema2:Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es12% . 1. 2. 3. 4. 5. 6. 7. 8. 9.

Inicio. Observar que es lo que me piden. Ver que datos tengo. Multiplicar las horas trabajadas por el sueldo por hora. Realizando operaciones. Ya que tengas el sueldo por hora. Lo multiplicas por los 30 días del mes. Así ya tenemos el sueldo por mes. Fin.

Inicio

Cal. A

Proceso calcular horas Escribir “Dame el número de horas que trabajo” Leer num horas Escribir “A cuánto le pagan cada hora?” Leer costo x hora Descuento= (num horas*costo x hora)*.12 Total=(num horas*costo x hora)descuento Escribir “el total que recibe el trabajador en pesos es:” Escribir total Fin proceso

A=b*x-12%

A

Fin


c) Problema3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente:

I.

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta.

II.

Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta.

III.

El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.

Proceso promedios Leer b1, b2, b3, b4 Promedio= (b1+b2+b3+b4)/4 Si promedio<=8 entonces Imprimir promedio Fin Si promedio<8 entonces Imprimir “lo siento, te vas a ordinario (primera vuelta). Fin Leer pc P2= (pv+promedio)/2 Fin Si p2</6 entonces Imprimir “lo siento te vas a extraordinario (segunda vuelta). Fin Leer sv


Pfinal= (sv+promedio)/2 Imprimir “tu calificación finales”, pfinal Fin proceso

Firma de Actividad Realizada: _

practica 4