Page 1

Práctica 4.-Diseña y Elabora Algoritmos y Pseudocódigos Díaz

Manzo

Apellido Paterno

Gladys Ailsa

Apellido Materno

20137297

2D

No. de Cuenta

Grupo

Nombre(s) 07/04/2014

12

Fecha

No.deLista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema1:Mostrarenpantallaelfactorialdecualquiernúmero,introducidodesdeel teclado.. Inicio Proceso factorial Numero Leer Num 1 Fact= 1

Fact=1 Cont=1

Cont=1 Fact=fact*cont

Fact =Fact x Cont

Cont=cont+1 Si cont<=num 1 entonces

Cont =Cont+1

Fact=fact*cont Cont=cont+1 SI Finsi

Cont<=num

Imprimir fact Finproceso

N Fact

Fin


b) Problema2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%. 1.- Proceso Calculodehoras 2.- Escribir “Dame el número de horas que trabajo” 3.- Leer Numhoras 4.- Escribir “A cuánto le pagan cada hora?” 5.- Leer costoxhora 6.- Descuento=(numhoras*costoxhoras) 7.- Total=(numhoras*costoxhora)-descuento 8.- Escribir “El total que recibe el trabajador en pesos es:” 9.- Escribir total 10.-Finproceso


c)

Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I. Si el promedio de los cuatro bimestres es mayor o igual a 8.0este es el promedio final de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta.

II.

Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0este es el promedio final, de lo contrario presenta segunda vuelta.

III.

El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final. 1.- Proceso promedios

2.- Leer b1, b2, b3, b4 3.- Promedio=(b1+b2+b3+b4)/4 4.- Si promedio>=8 Entonces 5.- Imprimir promedio 6.- Finsi 7.- Si promedio<8= Entonces 8.- Imprimir “Lo siento, te vas a ordinario (primera vuelta) 9.- Finsi 10.-Leer pv 11.- P2=(pv+promedio)/2 12.- Si p2<=6 Entonces 13.- Imprimir p2 14.- Finsi 15.- Si p2<6 Entonces 16.- Imprimir “Lo siento, te vas a extraordinario (segunda vuelta) 17.- Finsi 18.- Leer sv 19.- Pfinal=(sv+rpmedio)/2 20.- Imprimir “tu calificación final es”, pfinal 21.- Finproceso


Práctica 4, segunda parcial  

Practica 4

Read more
Read more
Similar to
Popular now
Just for you