Page 1

Práctica 4.- Diseña y Elabora Algoritmos y Pseudocódigos Dávila

Olivo

Vania Palmira

Apellido Paterno 20137293

Apellido Materno 2°D

No. de Cuenta

Nombre(s)

7 de Abril del 2014

Grupo

10

Fecha

No. de Lista

Instrucciones: Elabora el Pseudocódigo o algoritmo para: a) Problema 1: Mostrar en pantalla el factorial de cualquier número, introducido desde el teclado.. Inicio

Proceso Factorial Leer num1 Fact=1 Cont=1 Fact=fact*cont Cont=cont+1 Si cont<=num1 entonces Fact=fact*cont Cont=cont+1 Numero

Finsi Imprimir Fac Finproceso

Fact=1 Cont= 1 Fact = Fact x Cont Cont = Cont + 1

SI Cont<=num N Fact


Fin


b) Problema 2: Elabora el Pseudocódigo o Algoritmo y el diagrama de flujo donde se requiere calcular el salario neto de un trabajador considerando que se conoce el número de horas trabajadas, el sueldo por hora y el impuesto retenido, que es 12%.      

++

Proceso Salario_de_un_trabajador Escribir horas trabajadas y el sueldo por hora Leer horas trabajadas*sueldo por horas e introducirle un impuesto Leer horas trabajadas +sueldo por hora*.12(impuesto) Leer horas trabajadas+sueldo por hora-impuesto Finproceso salario


c) Problema 3: Utiliza el procesador de palabras para elaborar el pseudocódigo y diagrama de flujo que determine el promedio final de un alumno tomando en cuenta lo siguiente: I.

II.

III.

Si el promedio de los cuatro bimestres es mayor o igual a 8.0 este es el promedio final, de lo contrario si es menor a 8.0 el alumno se presenta en primera vuelta. Si el promedio de la calificación de primera vuelta y el promedio de los cuatro bimestres es mayor o igual a 6.0 este es el promedio final, de lo contrario presenta segunda vuelta. El promedio de la calificación de segunda vuelta y el promedio de los cuatro bimestres es el promedio final.

Proceso Promedios Leer b1,b2,b4 Promedio=(b1+b2+b3+b4)/4 Si Promedio>=8 Entonces Imprimir promedio FinSi Si promedio<=8 entonces Imprimir “Lo siento, te vas a ordinario…(primera vuelta) FinSi Leer pv P2=(pv+promedio)/2 Si p2>=6 entonces Imprimir “lo siento te vas a ordi (segunda vuelta” finSi Leer Sv pFinSi=(sv+promedio)/2 Imprimir “Tu calificación final es, pfinal FinProceso

Firma de Actividad Realizada:_


Práctica 4 vania davila  

Tarea de compu